Настройки com-порта (Рис

Настройки com-порта (Рис.3):

Ø Автостарт порта – при выбранном значении происходит автоматическое открытие порта. Используется для автоматического соединения с сервером во время запуска программы. Во время открытия com-порта данное действие будет отображено в окне логирования следующей строкой:

[18:52:31] Открыт порт COM1 на скорости 115200

Ø Выбор com-порта – выбор необходимого (свободного) порта из существующих на Вашем компьютере. Например если к COM1 у Вас подключен модем, то вам необходимо будет выбрать другой свободный порт, иначе соединение с ресивером не будет установлено.

Ø Закрыть/открыть – принудительное (ручное) закрытие или открытие com-порта.

Рис.3


Помощь

Описание команд автоматической системы шаринга

Управление аккаунтом пользователя осуществляется через почтовые сообщения на специальный почтовый адрес робота шаринга.
Любая команда для робота оформляется в виде письма на адрес satrobot@mail.ru . В теме (subject) письма следует указывать одну из нижеследующих команд

Testlogin

Pay

Registration

Balans


Команда получения тестового логина

Testlogin

По этой команде робот высылает набор параметров для тестирования шаринга. На один почтовый ящик может быть выслан один тестовый логин. Количество тестовых логинов, выдаваемых за сутки ограничено.

Например


Команда получения параметров оплаты

Pay

После прохождения тестирования сервера шаринга Вы можете оплатить постоянное подключение. По этой команде на ваш ящик придет письмо с тарифами и описанием всех способов оплаты шаринга.

Например


Команда регистрации на постоянном сервер

Registration

Команда для регистрации в базе постоянных пользователей. В теле письма следует указать оплаченную сумму, способ оплаты, выбранные пакеты для просмотра, а так же другую дополнительную информацию. Текст письма следует писать в режиме plain text и желательно латиницей.

Например

В ответ на эту команду пользователю придет письмо с подтверждением регистрации на постоянном сервере.

После проверки правельности платежа придет подобный ответ:


Команда проверки баланса

Balans

Команда для проверки баланса пользователя. Если пользователь зарегистрирован в базе постоянных пользователей, то по этой команде придет письмо с текущим балансом.

Например

В ответ придет письмо примерно такого содержания:


Большое спасибо всем, кто помог мне в написание проекта, а именно:

  • Titan, Driver, Ago, igot_t – за помощь в программировании и алгоритмизации
  • Oleg-Mozdok, Grem, PCC, zotto (NoRG), make741, Tioska, Zaratu – за тестирование и ценные замечания
  • Oliverst – за написание Help к программе


Дополнительные настройки (Рис

Дополнительные настройки (Рис.7):

Ø Выключить компьютер в… - режим Slip. Выбор времени в часах и минутах для автоматического отсоединения от сервера шаринга и выключения компьютера.

Ø Запретить запуск второй копии программы – при включенном данном режиме во время запуска еще одной копии программы выскакивает окошко с предупреждением (Рис.6), и программа больше не запускается. В противном случае если первая копия программы уже соединена с сервером шаринга и случайно произведется запуск второй копии, то произойдет сбой уже существующего соединения. Более того, обычно провайдер шары блокирует таких вот не аккуратных пользователей. Но если у Вас есть второй ресивер и Вам необходимо подсоединить его к другому серверу провайдера, то необходимо отключить эту опцию. Но только вторая копия программы должна находится в другой папке на диске и иметь свой файл настроек OpenBoxShare.ini. Настройки во второй копии аналогичны первой копии, только нужно будет выбрать другой свободный com-порт (например в первой - Com1, а во второй - Com2) иначе произойдет сбой соединения с ресивером. В принципе, количество подключаемых ресиверов (запускаемых копий программы) ограничивается только наличием свободных com-портов.

Внимание: провайдер шаринга (сервер) должен быть другой. А если все таки сервер тот же, то Вы должны получить у провайдера другой логин и пароль, ибо более одного одновременного соединения с сервером с одинаковым логином увеличивает время отклика сервера DW и вы не сможете воспользоватся шарингом ни на одном из ресиверов. И более того, провайдер шары обычно считает это незаконным подключением и блокирует Ваш логин.

Рис.6

Ø Режим повышенной стабильности – Эта опция будет полезна при неустойчивом соединении с сервером шаринга (частые «затыки»), так как при включении данного режима обмен данными между сервером шаринга и ресивером происходит в несколько раз быстрей, что обеспечивает своевременную доставку ключей в ресивер для раскодирования каналов.


Запуск программы.

Дистрибутив программы поставляется в заархивированном виде и не нуждается в инсталляции. Достаточно просто распаковать архив в отдельную папку в любое удобное для Вас место логического диска. Архив содержит такие вложения:

OpenBoxShare.exe – сама программа

help.chm – файл справки.

aes.dll – динамическая библиотека.

После запуска программы и ввода настроек сервера шаринга будет создан файл OpenBoxShare.ini, где и будут хранится эти настройки сервера. Помните, что все настройки программы сохраняются в этом файле лишь после корректного завершения работы с программой! И при обновлении на новую версию будет достаточно скопировать этот файл в папку с новой программой.

При первом запуске программы происходит автостарт сервера и программа сворачивается в Tray ( значок закрытого ящика [image]). При успешном соединении с сервером шаринга вид значка изменяется на [image]). Чтобы открыть окно программы нужно щелкнуть на значке левой кнопкой мышки.


Настройки логирования (Рис

Настройки логирования (Рис.4):

Ø Вести лог – данная функция предоставляет возможность отображать в окне (логе) ход подключения к серверу и процесс обмена данными между ресивером и сервером шаринга в виде текстовых строк.

[19:15:59] Открыт порт COM1 на скорости 115200

[19:15:59] Попытка соединиться с сервером 1...

[19:15:59] Получили случайную последовательность!

[19:15:59] Попытка авторизации ххххххххх...

[19:16:00] Авторизация хххххххххх успешна!

[19:16:00] Запрашиваем доступные сервисы...

[19:16:00] Имеется CAID:500 IDENT:021500

[19:16:00] Имеется CAID:500 IDENT:021510

[19:16:00] Имеется CAID:500 IDENT:021570

[19:16:00] Имеется CAID:500 IDENT:021C00

[19:16:00] Имеется CAID:500 IDENT:020710

[19:16:00] Имеется CAID:500 IDENT:020700

[19:16:06] <-CAID:0500 Ident:020700 ECM:8170470090030207089f0c5255532a554b522353455256e001c0e203350903e203350907e203350921e203350925ea104545aa0155d713b87365509916edc81df008ae1c507727cbe0a4

[19:16:08] ->DW: 4C94F6D64B475DEFDC056E4FE7FF12F8 - 2,203 сек

[19:16:19] <-CAID:0500 Ident:020700 ECM:8070470090030207089f0c5255532a554b522353455256e001c0e203350903e203350907e203350921e203350925ea104545aa0155d713b820aa0a7ec360a7e9f0085c231cc08a56e03d

[19:16:20] ->DW: 4C94F6D64B475DEFEF4B619BCF69C3FB - 1,072 сек

[19:16:29] <-CAID:0500 Ident:020700 ECM:8170470090030207089f0c5255532a554b522353455256e001c0e203350903e203350907e203350921e203350925ea10b3e385a4bff1f8c44794d7ab9f99682bf008edfe7977f1d04437

[19:16:30] ->DW: 91F9E6707B591EF2EF4B619BCF69C3FB - 1,422 сек

Ø Строк в логе – количество отображаемых строк в окне логирования. Значение можно ввести вручную или изменением в меньшую или большую сторону с шагом 1. При достижении количества строк верхнего значения (например 1006 строк из рисунка 4) первые строки будут удалятся по мере добавления новых.

Ø [image] - очистка содержимого окна логирования от всех текстовых строчек.

Ø [image] - сохранения содержимого окна логирования в текстовый файл. При выполнении данного действия откроется стандартное окно Windows для сохранения файла, где вам нужно будет указать имя создаваемого txt файла и размещение на логическом диске.

Рис.4


Настройки протокола CamD3:

Ø Таймаут ответа – пауза между ответами сервера в миллисекундах. Значение можно ввести вручную или изменением в меньшую или большую сторону с шагом 1.

Рис.7


Настройки протокола NewCamD525:

Ø Разорвать соединения, если не активен… – время в секундах, через которое произойдет принудительное отсоединение от сервера шаринга в случаи его не активности. Значение можно ввести вручную или изменением в меньшую или большую сторону с шагом 1.

Ø Прекратить попытки соединится после… - количество попыток соединения с сервером шаринга, в случае потери соединения. Значение можно ввести вручную или изменением в меньшую или большую сторону с шагом 1.

Ø Повторить попытки соединится через… - время в секундах, через которое будет предпринята новая попытка вновь подсоединится к серверу шаринга. Значение можно ввести вручную или изменением в меньшую или большую сторону с шагом 1.

Ø Передергивать порт при коннекте к серверу – принудительное выключение и последующее включение com-порта в случае с потерею связи с сервером.


Настройки соединения с сервером шаринга (Рис

Настройки соединения с сервером шаринга (Рис.5):

Имеется возможность использовать до четырех разных серверов для шаринга. Если Вы используете только один, то им должен быть только Сервер1, так как он должен быть всегда активным. Настройки сервера производятся на соответствующей вкладке с номером необходимого вам сервера. На Рис.5 показаны настройки соединения с Сервером 2

Рис.5

Выбор параметров для соединения с сервером:

Ø Логин – имя регистрации на сервере. Вводится вручную или копированием из внешнего источника с использованием комбинации клавиш Ctrl+V

Ø Пароль – пароль для соединения с сервером. Вводится вручную или копированием из внешнего источника с использованием комбинации клавиш Ctrl+V. Все введенные символы для соблюдения конфиденциальности заменяются на символ *

Ø IP – адрес сервера. Вводится вручную или копированием из внешнего источника с использованием комбинации клавиш Ctrl+V. Формат ###.###.###.###

Ø Порт – номер порта сервера. Значение можно ввести вручную или изменением в меньшую или большую сторону с шагом 1.

Ø Протокол – возможные значения NewCamD525 или CamD3. Выбор нужного значения производится из выпадающего списка значений.

Ø Key – вводится только для протокола NewCamD525 и обычно имеет значение 0102030405060708091011121314.

Ø Провайдер – идентификатор (ID) разшариваемого провайдера. Это же значение необходимо ввести в Эмуляторе вашего ресивера в разделе шаринга. (Главное меню ресивера – 1117 – Шаринг (Рис 5.1) – Добавить(Рис 5.2))

Рис.5.1 Рис. 5.2

Примечание: все необходимые данные для настройки вы должны получить у поставщика шаринга. Все настройки сохраняются в файле OpenBoxShare.ini автоматически после корректного завершения работы с программой.

Когда все данные были введены а также данный сервер отмечен активным, то по нажатию на кнопку Переподсоединиться к серверу будет произведено подсоединение, и если все было сделано правильно то в окне логирования Вы увидите ход обмена данными между ресивером и сервером. Данная кнопка также используется при неустойчивой или потере связи с сервером.


1

1. Окно программы.

Общие настройки (рис.2):

Ø При запуске в Tray - выбор положения окна программы. Возможные значения: оконный режим (без отметки), режим Tray.

Ø Автостарт сервера – при выбранном значении производится автоматическое подсоединение к серверу шаринга сразу после запуска программы.

Ø Активные сервера – Выбор сервера с которым производится соединение. Минимум – один сервер, максимум - четыре. Примечание: сервер 1 всегда активен.

Ø Сервер по умолчанию – выбор номера сервера, с которым автоматически при запуске программы будет произведено соединение. Выбор производится из выпадающего списка нужного значения. (Рис.1)

Рис.1

Ø [image] - запуск программы для редактирования сетингов, каналов и ключей POBedit. Значок становится активным только в том случае, если эта программа установлена на вашем компьютере

Рис.2


Подключение компьютера к ресиверу:

Подключение компьютера к ресиверу производится с помощью нуль-модемного кабеля (Рис.10)

Внимание: При подключении Com-порта ресивер должен быть Выключен из сети 220в!!!!!

Рис.10

- можно дополнительно соединить корпуса разъёмов между собой...

- можно применить альтернативную распиновку (Рис.11)

Рис.11


Расшифровка лога:

[19:15:59] Открыт порт COM1 на скорости 115200 – открытие сом-порта

[19:15:59] Закрыт порт COM1 – Закрытие сом-порта

[19:15:59] Сервер 1 не отвечает... – отсутствие подключения к серверу шаринга

[19:15:59] Попытка соединиться с сервером 1... – запрос на соединение с сервером

[19:15:59] Получили случайную последовательность! – ответ сервера шаринга о возможности соединения

[19:15:59] Попытка авторизации ххххххххх... – запрос программы на авторизацию на сервере (проверка допустимости логина и пароля)

[19:16:00] Авторизация хххххххххх успешна! – ответ сервера об успешной авторизации

[19:16:00] Запрашиваем доступные сервисы... – запрос программы о доступных расшариваемых

[19:16:00] Имеется CAID:500 IDENT:021500 – CAID и IDENT розшариваемого пакета

[19:16:00] Имеется CAID:500 IDENT:021510 – CAID и IDENT розшариваемого пакета

[19:16:00] Имеется CAID:500 IDENT:021570 – CAID и IDENT розшариваемого пакета

[19:16:00] Имеется CAID:500 IDENT:021C00 – CAID и IDENT розшариваемого пакета

[19:16:00] Имеется CAID:500 IDENT:020710 – CAID и IDENT розшариваемого пакета

[19:16:00] Имеется CAID:500 IDENT:020700 – CAID и IDENT розшариваемого пакета

[19:16:01] Удержание канала успешно – сохранение соединение с сервером при отсутствии запросов с ресивера

[19:16:06] <-CAID:0500 Ident:020700 ECM:8170470090030207089f0c5255532a554b522353455256e001c0e203350903e203350907e203350921e203350925ea104545aa0155d713b87365509916edc81df008ae1c507727cbe0a4 – запрос на ключ из ресивера

[19:16:08] ->DW: 4C94F6D64B475DEFDC056E4FE7FF12F8 - 2,203 сек – ответ сервера шаринга


Строка информации (Рис

Строка информации (Рис.10):

Ø Передано/принято – счетчик количество переданной и принятой информации в байтах за текущий сеанс связи с сервером шаринга.

Ø [image] - сброс счетчика переданной и принятой информации. Выполняется щелчком мыши на данной кнопке и требует подтверждения действия (Рис.9)

Рис.9

Рис.10