Getting Started - SAP GUI Scripting API

SAP GUI Scripting API
Introduction

Glossary Item Box

SAP GUI Scripting API

Purpose
Ever since the release of SAP system version 4.6C, there has been only very limited support for emulating user interaction with a SAP system. Existing technologies, such as ITOLE or Guilib, connect to the SAP system at the protocol level and have never been able to emulate the behavior of the compound controls introduced with 4.6C.
For this reason, applications relying on emulating user input worked only on the decreasing number of transactions using only standard dynpro elements.
Examples of affected applications are:

  • Automatic testing of SAP functionality
  • Customized front end applications replacing the SAP GUI
  • Tools to customize applications on the SAP GUI level -> GuiXT
  • E-Learning applications that guide a user through SAP transactions

Integration
Many of the available SAP GUI controls were designed exclusively with user interaction in mind. As their business functionality is closely coupled with the user interface they cannot be instantiated outside the SAP GUI in a batch-like fashion.
We therefore decided not to add the business functionality of the SAP GUI controls to a low-level integration component such as Guilib. Instead the controls run within the SAP GUI, which itself exposes a new interface allowing the automation of tasks.

Features
We developed an object model representing the SAP GUI at runtime as a hierarchy of objects. Most of these expose an interface to an element of the user interface. These interfaces can be used to perform all the actions a user could do with the given element. In addition we offer outgoing interfaces through which an external application can receive notifications about events occurring within the SAP GUI.
Available uses for the scripting component include

  • Listening to the actions a user performs in the SAP GUI and record them as a script
  • Running a script that emulates user interaction
  • Logging the SAP system information, such as response time

Runtime hierarchy overview

Top level administrative objects
All objects defined in the scripting component's object model are available at runtime as members of a hierarchical tree with the root object being GuiApplication.

GuiApplication represents the process in which the SAP system activity takes place. Because of this there should always be only one GuiApplication object within a process. The children of GuiApplication are all the connections of class GuiConnection to the SAP systems available for scripting.

Connections are opened manually from the SAPLogon dialog or using the openConnection and openConnectionByConnectionString methods of GuiApplication from a script. As soon as a connection has been established a first session is created as a child of the connection. Up to 5 additional sessions can be created. Again, this can be done manually using the 'Create Session' menu item or toolbar button, or from a script using the CreateSession method of GuiSession.

While GuiApplication represents the overall SAP GUI application, a GuiSession represents a specific task being performed. For any given session there is exactly one transaction currently executed, and most tasks performed in SAP GUI can be performed within the context of one GuiSession.
These considerations determine the event model of the scripting component. A user's interactions are best recorded or logged in the context of one session, therefore the GuiSession exposes an outgoing interface that allows an application to listen to the user interaction.
On the other hand, the GuiApplication exposes an outgoing interface that raises administrative events, for example when a session is created or destroyed.

Top level user interface objects
A session usually has a GuiMainWindow as its child. This window is the starting point for user interaction with a session.

The children of the GuiMainWindow are easily identified straightforward.

Please note that the availability of some of these objects depends on the design mode used. The titlebar, for example, is available only in New Visual Design, not in classic mode, as can be seen in the following screenshot.

© SAP AG. All Rights Reserved.

© 2012 All Rights Reserved.


Project Overview

Project Overview

Glossary Item Box

Description

SAP GUI Scripting API

Classes

Class Module | Description
GuiAbapEditor
GuiApoGrid
GuiApplication | The GuiApplication represents the process in which all SAP GUI activity takes place. If the scripting component is accessed by attaching to a SAPlogon process, then GuiApplication will represent SAPlogon. GuiApplication is a creatable class. However, there must be only one component of this type in any process. GuiApplication extends GuiContainer.
GuiBarChart

The GuiBarChart is a powerful tool to display and modify time scale diagrams.

The object is of a very technical nature. It should only be used for recording and playback, as most of the parameters can not be determined in any other way. GuiBarChart extends GuiShell.

GuiBox | A GuiBox is a simple frame with a name. The items inside the frame are not children of the box. GuiBox extends GuiVComponent. The type prefix is box. The name property is the ABAP fieldname.
GuiButton | GuiButton represents all push buttons that are on dynpros, the toolbar or in table controls. GuiButton extends GuiVComponent. The type prefix is btn, the name property is the fieldname taken from the SAP data dictionary There is one exception: for tabstrip buttons, it is the button id set in screen painter that is taken from the SAP data dictionary.
GuiCalendar | The calendar control can be used to select single dates or periods of time. GuiCalendar extends GuiShell.
GuiChart | The GuiChart object is of a very technical nature. It should only be used for recording and playback, as most of the parameters can not be determined in any other way.
GuiCheckBox | GuiCheckBox extends GuiVComponent. The type prefix is chk, the name is the fieldname taken from the SAP data dictionary.
GuiCollection | GuiCollection is similar to GuiComponentCollection, but its members are not necessarily extensions of GuiComponent. It can be used to pass a collection as a parameter to functions of scriptable objects. An object of this class is created by calling the CreateGuiCollection function of the GuiApplication.
GuiColorSelector | GuiColorSelector displays a set of colors for selection. It extends GuiShell.
GuiComboBox | The GuiComboBox looks somewhat similar to GuiCTextField, but has a completely different implementation. While pressing the combo box button of a GuiCTextField will open a new dynpro or control in which a selection can be made, GuiComboBox retrieves all possible choices on initialization from the server, so the selection is done solely on the client. GuiComboBox extends GuiVComponent. The type prefix is cmb, the name is the fieldname taken from the SAP data dictionary.
GuiComboBoxEntry | Members of the Entries collection of a GuiComboBox are of type GuiComBoxEntry
GuiComponent | GuiComponent is the base class for most classes in the Scripting API. It was designed to allow generic programming, meaning you can work with objects without knowing their exact type.
GuiComponentCollection | The GuiComponentCollection is used for collections elements such as the children property of containers. Each element of the collection is an extension of GuiComponent.
GuiConnection | A GuiConnection represents the connection between SAP GUI and an application server. Connections can be opened from SAPlogon or from GuiApplication’s openConnection and openConnectionByConnectionString methods. GuiConnection extends GuiContainer. The type prefix for GuiConnection is con, the name is con plus the connection number in square brackets.
GuiContainer | This interface resembles GuiVContainer. The only difference is that it is not intended for visual objects but rather administrative objects such as connections or sessions. Objects exposing this interface will therefore support GuiComponent but not GuiVComponent. GuiContainer extends GuiComponent.
GuiContainerShell | A GuiContainerShell is a wrapper for a set of GuiShell objects. GuiContainerShell extends GuiVContainer. The type prefix is shellcont, the name is the last part of the id, shellcont[n].
GuiContextMenu | A GuiContextMenu may have other GuiContextMenu objects as children. GuiContextMenu extends GuiMenu. The type is mnu, the name is the function code that is sent to the system when the menu item is selected.
GuiCTextField If the cursor is set into a text field of type GuiCTextField a combo box button is displayed to the right of the text field. Pressing this button is equivalent to pressing the F4 key. The button is not represented in the scripting object model as a separate object; it is considered to be part of the text field.
There are no other differences between GuiTextField and GuiCTextField. GuiCTextField extends GuiTextField. The type prefix is ctxt, the name is the Fieldname taken from the SAP data dictionary.
GuiCustomControl | The GuiCustomControl is a wrapper object that is used to place ActiveX controls onto dynpro screens. While GuiCustomControl is a dynpro element itself, its children are of GuiContainerShell type, which is a container for controls. GuiCustomControl extends GuiVContainer. The type prefix is cntl, the name is the fieldname taken from the SAP data dictionary.
GuiDialogShell | The GuiDialogShell is an external window that is used as a container for other shells, for example a toolbar. GuiDialogShell extends GuiVContainer. The type prefix is shellcont, the name is the last part of the id, shellcont[n].
GuiEAIViewer2D

The GuiEAIViewer2D control is used to view 2-dimensional graphic images in the SAP system. Presently Webviewer2D supports 22 available image types. The user can carry out redlining over the loaded image. The scripting wrapper for this control records all user actions during the redlining process and reproduces the same actions when the recorded script is replayed.

GuiEAIViewer2D extends GuiShell.

GuiEAIViewer3D
GuiEnum
GuiFrameWindow | A GuiFrameWindow is a high level visual object in the runtime hierarchy. It can be either the main window or a modal popup window. See the GuiMainWindow and GuiModalWindow sections for examples. GuiFrameWindow itself is an abstract interface. GuiFrameWindow extends GuiVContainer. The type prefix is wnd, the name is wnd plus the window number in square brackets.
GuiGOSShell | The GuiGosShell is only available in New Visual Design mode. GuiGOSShell extends GuiVContainer. The type prefix is shellcont, the name is the last part of the id, shellcont[n].
GuiGraphAdapt | For the graphic adapter control only basic members from GuiShell are available. Recording and playback is not possible.
GuiGridView | The grid view is similar to the dynpro table control, but significantly more powerful. GuiGridView extends GuiShell.
GuiHTMLViewer | The GuiHTMLViewer is used to display an HTML document inside SAP GUI. GuiHTMLViewer extends GuiShell.
GuiLabel | GuiLabel extends GuiVComponent. The type prefix is lbl, the name is the fieldname taken from the SAP data dictionary.
GuiMainWindow

This window represents the main window of a SAP GUI session.

GuiMainWindow extends GuiFrameWindow.

GuiMap | For the map control only basic members from GuiShell are available. Recording and playback is not possible.
GuiMenu | A GuiMenu may have other GuiMenu objects as children. GuiMenu extends GuiVContainer. The type prefix is menu, the name is the text of the menu item. If the item does not have a text, which is the case for separators, then the name is the last part of the id, menu[n].
GuiMenubar | Only the main window has a menubar. The children of the menubar are menus. GuiMenubar extends GuiVContainer. The type prefix and name are mbar.
GuiMessageWindow
GuiModalWindow

A GuiModalWindow is a dialog pop-up.

GuiModalWindow extends GuiFrameWindow.

GuiNetChart | The GuiNetChart is a powerful tool to display and modify entity relationship diagrams. It is of a very technical nature and shoud only be used for recording and playback, as most of the parameters can not be determined in any other way.
GuiOfficeIntegration
GuiOkCodeField | The GuiOkCodeField is placed on the upper toolbar of the main window. It is a combo box into which commands can be entered. Setting the text of GuiOkCodeField will not execute the command until server communication is started, for example by emulating the Enter key (VKey 0). GuiOkCodeField extends GuiVComponent. The type prefix is okcd, the name is empty.
GuiPasswordField | The only difference between GuiTextField and GuiPasswordField is that the Text property can not be read for a password field. The returned text is always empty. GuiPasswordField extends GuiTextField. The type prefix is pwd, the name is the fieldname taken from the SAP data dictionary.
GuiPicture

The picture control displays a picture on a SAP GUI screen. GuiPicture extends GuiShell.

GuiRadioButton | GuiRadioButton extends GuiVComponent. The type prefix is rad, the name is the fieldname taken from the SAP data dictionary.
GuiSapChart | For the SAP chart control only basic members from GuiShell are available. Recording and playback is not possible.
GuiScrollbar | The GuiScrollbar class is a utility class used for example in GuiScrollContainer or GuiTableControl.
GuiScrollContainer | This container represents scrollable subscreens. A subscreen may be scrollable without actually having a scrollbar, because the existence of a scrollbar depends on the amount of data displayed and the size of the GuiUserArea. GuiScrollContainer extends GuiVContainer. The type prefix is ssub, the name is generated from the data dictionary settings.
GuiSession

The GuiSession provides the context in which a user performs a certain task such as working with a transaction. It is therefore the access point for applications which record a user’s actions regarding a specific task or play back those actions. GuiSession extends GuiContainer. The type prefix is ses, the name is ses plus the session number in square brackets.

GuiSessionInfo | GuiSessionInfo is a member of all GuiSession objects. It makes available technical information about the session. Some of its properties are displayed in the right corner of the SAP GUI status line.
GuiShell | GuiShell is an abstract object whose interface is supported by all the controls. GuiShell extends GuiVContainer. The type prefix is shell, the name is is the last part of the id, shell[n].
GuiSimpleContainer | This container represents non-scrollable subscreens. It does not have any functionality apart from to the inherited interfaces. GuiSimpleContainer extends GuiVContainer. The type prefix is sub, the name is is generated from the data dictionary settings.
GuiSplit | GuiSplit extends GuiShell.
GuiSplitterContainer | The GuiSplitterContainer represents the dynpro splitter element, which was introduced in the Web Application Server ABAP in NetWeaver 7.1. The dynpro splitter element is similar to the activeX based splitter control, but it is a plain dynpro element.
GuiStage | For the stage control only basic members from GuiShell are available. Recording and playback is not possible.
GuiStatusbar | GuiStatusbar represents the message displaying part of the statusbar on the bottom of the SAP GUI window. It does not include the system and login information displayed in the rightmost area of the statusbar as these are available from the GuiSessionInfo object. GuiStatusbar extends GuiVComponent. The type prefix is sbar.
GuiStatusPane
GuiTab | The GuiTab objects are the children of a GuiTabStrip object. GuiTab extends GuiVContainer. The type prefix is tabp, the name is the id of the tab’s button taken from SAP data dictionary.
GuiTableColumn | GuiTableColumn extends GuiComponentCollection.
GuiTableControl | The table control is a standard dynpro element, in contrast to the GuiCtrlGridView, which looks similar. GuiTableControl extends GuiVContainer. The type prefix is tbl, the name is the fieldname taken from the SAP data dictionary.
GuiTableRow | GuiTableRow extends GuiComponentCollection.
GuiTabStrip | A tab strip is a container whose children are of type GuiTab. GuiTabStrip extends GuiVContainer. The type prefix is tabs, the name is the fieldname taken from the SAP data dictionary.
GuiTextedit | The TextEdit control is a multiline edit control offering a number of possible benefits. With regard to scripting, the possibility of protecting text parts against editing by the user is especially useful.
GuiTextField | GuiTextField extends GuiVComponent. The type prefix is txt, the name is the fieldname taken from the SAP data dictionary.
GuiTitlebar | The titlebar is only displayed and exposed as a separate object in New Visual Design mode. GuiTitlebar extends GuiVContainer. The type prefix and name of GuiTitlebar are titl.
GuiToolbar

Every GuiFrameWindow has a GuiToolbar. The GuiMainWindow has two toolbars unless the second has been turned off by the ABAP application. The upper toolbar is the system toolbar, while the second toolbar is the application toolbar.

The children of a GuiToolbar are buttons. The indexes for toolbar buttons are determined by the virtual key values defined for the button.

GuiToolbar extends GuiVContainer. The type prefix and name are tbar.

GuiToolbarControl | GuiToolbarControl extends GuiShell.
GuiTree
GuiUserArea

The GuiUserArea comprises the area between the toolbar and statusbar for windows of GuiMainWindow type and the area between the titlebar and toolbar for modal windows, and may also be limited by docker controls. The standard dynpro elements can be found only in this area, with the exception of buttons, which are also found in the toolbars.

GuiUserArea extends GuiVContainer. The type prefix and name are usr.

GuiUtils
GuiVComponent | The GuiVComponent interface is exposed by all visual objects, such as windows, buttons or text fields. Like GuiComponent, it is an abstract interface. Any object supporting the GuiVComponent interface also exposes the GuiComponent interface. GuiVComponent extends GuiComponent.
GuiVContainer | An object exposes the GuiVContainer interface if it is both visible and can have children. It will then also expose GuiComponent and GuiVComponent. Examples of this interface are windows and subscreens, toolbars or controls having children, such as the splitter control. GuiVContainer extends GuiContainer and GuiVComponent.
ISapAbapEditorTarget

Public Enumerations

Enumeration | Description
GuiComponentType |
GuiErrorType |
GuiEventType |
GuiImageType | SAP GUI Image types
GuiMagicDispIDs |
GuiMessageBoxOption | SAP GUI Message Box Options
GuiMessageBoxResult | SAP GUI Message Box Results
GuiMessageBoxType | SAP GUI Message Box Types
GuiScrollbarType |
GuiTableSelectionType |

Remarks

SAP Notes on SAP GUI Scripting

  • 480149: Describes the ABAP and kernel patch level requirements
  • 587202: Limitations of SAP GUI Scripting
  • 548788: Creating trace files of SAP GUI Scripting problems to be send to SAP
  • 527737: Composite SAP note on SAP GUI Scripting
  • 612454: SAP GUI Scripting: Status and Lifetime
  • 619459: SAP GUI Scripting support of SAP applications
  • 692245: Additional server based security options for Scripting
  • 839115: Load test with SAP GUI scripting
  • 983990: SAP GUI Scripting security: Enable Scripting per system user
  • 1441550: SAP GUI scripting: Sample applications

SAP Support Component for SAP GUI Scripting

  • BC-FES-GUI


Getting Started - SAP GUI Scripting API

Getting Started

Glossary Item Box

Requirements

SAP System
Scripting support is available for the 3.1I, 4.0B, 4.5B, 4.6B, 4.6C, 4.6D, 6.10, and 6.20 releases and all subsequent releases.
For the releases 3.1I to 6.10 ABAP support packages and the SAP kernel patches are available to add the support, while they are already part of 6.20 and later releases. Note 480149 lists the required patch levels.

SAP GUI
The scripting interface can be installed with the SAP GUI release 6.20 and later releases. This document is based on SAP GUI 7.30 patchlevel 0. Some of the functionality described here may be missing from older versions of SAP GUI.


GuiAbapEditor Object

GuiAbapEditor Object
See Also Members

Glossary Item Box

Object Model

GuiAbapEditor ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiComponent ObjectGuiComponent Object

See Also

GuiAbapEditor Members


GuiAbapEditor Object Members

GuiAbapEditor Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method AutoBraceEnabled
Public Method AutoComplete
Public Method AutoCorrectEnabled
Public Method AutoExpand
Public Method AutoIndentEnabled
Public Method Capitalize
Public Method ClipboardCopy
Public Method ClipboardCut
Public Method ClipboardPaste
Public Method ClipboardRingPaste
Public Method CodeHintsEnabled
Public Method CommentSelectedLines
Public Method CorrectCapsEnabled
Public Method Delete
Public Method DeleteBack
Public Method DeleteRange
Public Method DeleteSelection
Public Method DeleteWord
Public Method DeleteWordBack
Public Method DumpState
Public Method DuplicateLine
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method FormatSelectedLines
Public Method GetAutoCompleteEntryCount
Public Method GetAutoCompleteEntryText
Public Method GetAutoCompleteIconType
Public Method GetAutoCompleteSubIconType
Public Method GetAutoCompleteToolbarButtonToolTip
Public Method GetAutoCompleteToolTipDelay
Public Method GetCurrentToolTipText
Public Method GetCursorColumnPosition
Public Method GetCursorLinePosition
Public Method GetFirstVisibleLine
Public Method GetHTMLClipboardContents
Public Method GetLastVisibleLine
Public Method GetLineCount
Public Method GetLineText
Public Method GetNumberedBookmarks
Public Method GetRTFClipboardContents
Public Method GetSelectedAutoComplete
Public Method GetSelectedText
Public Method GetStructureBlockEndLine
Public Method GetStructureBlockStartLine
Public Method GetUndoPosition
Public Method GetWordWrapMode
Public Method GetWordWrapPosition
Public Method GoNextBookMark
Public Method GoNumberedBookmark
Public Method GoPreviousBookMark
Public Method InsertTab
Public Method InsertText
Public Method IsAutoCompleteEntryBold
Public Method IsAutoCompleteOpen
Public Method IsAutoCompleteToolbarButtonPressed
Public Method IsAutoCompleteToolTipVisible
Public Method IsBookmark
Public Method IsBreakpointSet
Public Method IsLineCollapsed
Public Method IsLineComment
Public Method IsLineModified
Public Method IsModified
Public Method JoinSelectedLines
Public Method LowerCase
Public Method MoveCursorDocumentEnd
Public Method MoveCursorLineDown
Public Method MoveCursorLineEnd
Public Method MoveCursorLineHome
Public Method MoveCursorLineUp
Public Method MoveLineDown
Public Method MoveLineUp
Public Method MoveWordLeft
Public Method MoveWordRight
Public Method OverwriteModeEnabled
Public Method RemoveAllBookmarks
Public Method RemoveAllBreakpoints
Public Method RemoveBookmarks
Public Method RemoveBreakpoint
Public Method ReplaceSelection
Public Method SaveToFile
Public Method ScrollToLine
Public Method SelectAll
Public Method SelectBlockRange
Public Method SelectContextMenuItem
Public Method SelectContextMenuItemByPosition
Public Method SelectContextMenuItemByText
Public Method SelectRange
Public Method SelectWordLeft
Public Method SelectWordRight
Public Method Sentencize
Public Method SetAutoBrace
Public Method SetAutoCorrect
Public Method SetAutoIndent
Public Method SetBookmarks
Public Method SetBreakpoint
Public Method SetCodeHints
Public Method SetCorrectCaps
Public Method SetFocus
Public Method SetLineFeedStyle
Public Method SetOverwriteMode
Public Method SetSelectionPosInLine
Public Method SetSmartTab
Public Method SetWordWrapMode
Public Method SetWordWrapPosition
Public Method ShowContextMenu
Public Method SmartTabEnabled
Public Method SortSelectedLines
Public Method SwapCase
Public Method ToggleCapsLock
Public Method ToggleNumberedBookmark
Public Method ToggleStructureBlock
Public Method TransposeLine
Public Method UncommentSelectedLines
Public Method Undo
Public Method UnTab
Public Method UpperCase
Public Method Visualize

Public Properties

Public Property AccDescription
Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property Children
Public Property ContainerType
Public Property CurrentContextMenu
Public Property DefaultTooltip
Public Property DragDropSupported
Public Property Handle
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property OcxEvents
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property SubType
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiAbapEditor Object


AutoBraceEnabled Method

AutoBraceEnabled Method
See Also
GuiAbapEditor Object : AutoBraceEnabled Method

Glossary Item Box

Syntax

Visual Basic
Public Function AutoBraceEnabled() As Byte

See Also

GuiAbapEditor Object | GuiAbapEditor Members


AutoComplete Method

AutoComplete Method
GuiAbapEditor Object : AutoComplete Method

Glossary Item Box

Syntax

Visual Basic
Public Sub AutoComplete()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


AutoCorrectEnabled Method

AutoCorrectEnabled Method
GuiAbapEditor Object : AutoCorrectEnabled Method

Glossary Item Box

Syntax

Visual Basic
Public Function AutoCorrectEnabled() As Byte

See Also

GuiAbapEditor Object | GuiAbapEditor Members


AutoExpand Method

AutoExpand Method
GuiAbapEditor Object : AutoExpand Method

Glossary Item Box

Syntax

Visual Basic
Public Sub AutoExpand()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


AutoIndentEnabled Method

AutoIndentEnabled Method
GuiAbapEditor Object : AutoIndentEnabled Method

Glossary Item Box

Syntax

Visual Basic
Public Function AutoIndentEnabled() As Byte

See Also

GuiAbapEditor Object | GuiAbapEditor Members


Capitalize Method

Capitalize Method
GuiAbapEditor Object : Capitalize Method

Glossary Item Box

Syntax

Visual Basic
Public Sub Capitalize()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


ClipboardCopy Method

ClipboardCopy Method
GuiAbapEditor Object : ClipboardCopy Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ClipboardCopy()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


ClipboardCut Method

ClipboardCut Method
GuiAbapEditor Object : ClipboardCut Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ClipboardCut()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


ClipboardPaste Method

ClipboardPaste Method
GuiAbapEditor Object : ClipboardPaste Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ClipboardPaste()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


ClipboardRingPaste Method

ClipboardRingPaste Method
p1
GuiAbapEditor Object : ClipboardRingPaste Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ClipboardRingPaste( _
   ByVal p1 As Long _
)

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


CodeHintsEnabled Method

CodeHintsEnabled Method
GuiAbapEditor Object : CodeHintsEnabled Method

Glossary Item Box

Syntax

Visual Basic
Public Function CodeHintsEnabled() As Byte

See Also

GuiAbapEditor Object | GuiAbapEditor Members


CommentSelectedLines Method

CommentSelectedLines Method
GuiAbapEditor Object : CommentSelectedLines Method

Glossary Item Box

Syntax

Visual Basic
Public Sub CommentSelectedLines()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


CorrectCapsEnabled Method

CorrectCapsEnabled Method
GuiAbapEditor Object : CorrectCapsEnabled Method

Glossary Item Box

Syntax

Visual Basic
Public Function CorrectCapsEnabled() As Byte

See Also

GuiAbapEditor Object | GuiAbapEditor Members


Delete Method

Delete Method
GuiAbapEditor Object : Delete Method

Glossary Item Box

Syntax

Visual Basic
Public Sub Delete()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


DeleteBack Method

DeleteBack Method
GuiAbapEditor Object : DeleteBack Method

Glossary Item Box

Syntax

Visual Basic
Public Sub DeleteBack()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


DeleteRange Method

DeleteRange Method
p1
p2
p3
p4
GuiAbapEditor Object : DeleteRange Method

Glossary Item Box

Syntax

Visual Basic
Public Sub DeleteRange( _
   ByVal p1 As Long, _
   ByVal p2 As Long, _
   ByVal p3 As Long, _
   ByVal p4 As Long _
)

Parameters

p1
p2
p3
p4

See Also

GuiAbapEditor Object | GuiAbapEditor Members


DeleteSelection Method

DeleteSelection Method
GuiAbapEditor Object : DeleteSelection Method

Glossary Item Box

Syntax

Visual Basic
Public Sub DeleteSelection()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


DeleteWord Method

DeleteWord Method
GuiAbapEditor Object : DeleteWord Method

Glossary Item Box

Syntax

Visual Basic
Public Sub DeleteWord()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


DeleteWordBack Method

DeleteWordBack Method
GuiAbapEditor Object : DeleteWordBack Method

Glossary Item Box

Syntax

Visual Basic
Public Sub DeleteWordBack()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


DumpState Method

DumpState Method
InnerObject
GuiAbapEditor Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiAbapEditor Object | GuiAbapEditor Members


DuplicateLine Method

DuplicateLine Method
GuiAbapEditor Object : DuplicateLine Method

Glossary Item Box

Syntax

Visual Basic
Public Sub DuplicateLine()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiAbapEditor Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiAbapEditor Object | GuiAbapEditor Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiAbapEditor Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiAbapEditor Object | GuiAbapEditor Members


FindById Method

FindById Method
Id
Raise
GuiAbapEditor Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiAbapEditor Object | GuiAbapEditor Members


FindByName Method

FindByName Method
Name
Type
GuiAbapEditor Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiAbapEditor Object | GuiAbapEditor Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiAbapEditor Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiAbapEditor Object | GuiAbapEditor Members


FormatSelectedLines Method

FormatSelectedLines Method
GuiAbapEditor Object : FormatSelectedLines Method

Glossary Item Box

Syntax

Visual Basic
Public Sub FormatSelectedLines()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GetAutoCompleteEntryCount Method

GetAutoCompleteEntryCount Method
GuiAbapEditor Object : GetAutoCompleteEntryCount Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetAutoCompleteEntryCount() As Long

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GetAutoCompleteEntryText Method

GetAutoCompleteEntryText Method
p1
GuiAbapEditor Object : GetAutoCompleteEntryText Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetAutoCompleteEntryText( _
   ByVal p1 As Long _
) As String

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GetAutoCompleteIconType Method

GetAutoCompleteIconType Method
p1
GuiAbapEditor Object : GetAutoCompleteIconType Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetAutoCompleteIconType( _
   ByVal p1 As Long _
) As String

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GetAutoCompleteSubIconType Method

GetAutoCompleteSubIconType Method
p1
GuiAbapEditor Object : GetAutoCompleteSubIconType Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetAutoCompleteSubIconType( _
   ByVal p1 As Long _
) As String

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GetAutoCompleteToolbarButtonToolTip Method

GetAutoCompleteToolbarButtonToolTip Method
p1
GuiAbapEditor Object : GetAutoCompleteToolbarButtonToolTip Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetAutoCompleteToolbarButtonToolTip( _
   ByVal p1 As Long _
) As String

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GetAutoCompleteToolTipDelay Method

GetAutoCompleteToolTipDelay Method
GuiAbapEditor Object : GetAutoCompleteToolTipDelay Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetAutoCompleteToolTipDelay() As Long

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GetCurrentToolTipText Method

GetCurrentToolTipText Method
GuiAbapEditor Object : GetCurrentToolTipText Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetCurrentToolTipText() As String

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GetCursorColumnPosition Method

GetCursorColumnPosition Method
GuiAbapEditor Object : GetCursorColumnPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetCursorColumnPosition() As Long

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GetCursorLinePosition Method

GetCursorLinePosition Method
GuiAbapEditor Object : GetCursorLinePosition Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetCursorLinePosition() As Long

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GetFirstVisibleLine Method

GetFirstVisibleLine Method
GuiAbapEditor Object : GetFirstVisibleLine Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetFirstVisibleLine() As Long

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GetHTMLClipboardContents Method

GetHTMLClipboardContents Method
GuiAbapEditor Object : GetHTMLClipboardContents Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetHTMLClipboardContents() As String

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GetLastVisibleLine Method

GetLastVisibleLine Method
GuiAbapEditor Object : GetLastVisibleLine Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetLastVisibleLine() As Long

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GetLineCount Method

GetLineCount Method
GuiAbapEditor Object : GetLineCount Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetLineCount() As Long

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GetLineText Method

GetLineText Method
p1
GuiAbapEditor Object : GetLineText Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetLineText( _
   ByVal p1 As Long _
) As String

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GetNumberedBookmarks Method

GetNumberedBookmarks Method
p1
GuiAbapEditor Object : GetNumberedBookmarks Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetNumberedBookmarks( _
   ByVal p1 As Long _
) As Object

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GetRTFClipboardContents Method

GetRTFClipboardContents Method
GuiAbapEditor Object : GetRTFClipboardContents Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetRTFClipboardContents() As String

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GetSelectedAutoComplete Method

GetSelectedAutoComplete Method
GuiAbapEditor Object : GetSelectedAutoComplete Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetSelectedAutoComplete() As Long

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GetSelectedText Method

GetSelectedText Method
GuiAbapEditor Object : GetSelectedText Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetSelectedText() As String

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GetStructureBlockEndLine Method

GetStructureBlockEndLine Method
p1
GuiAbapEditor Object : GetStructureBlockEndLine Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetStructureBlockEndLine( _
   ByVal p1 As Long _
) As Long

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GetStructureBlockStartLine Method

GetStructureBlockStartLine Method
p1
GuiAbapEditor Object : GetStructureBlockStartLine Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetStructureBlockStartLine( _
   ByVal p1 As Long _
) As Long

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GetUndoPosition Method

GetUndoPosition Method
GuiAbapEditor Object : GetUndoPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetUndoPosition() As Long

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GetWordWrapMode Method

GetWordWrapMode Method
GuiAbapEditor Object : GetWordWrapMode Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetWordWrapMode() As Long

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GetWordWrapPosition Method

GetWordWrapPosition Method
GuiAbapEditor Object : GetWordWrapPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetWordWrapPosition() As Long

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GoNextBookMark Method

GoNextBookMark Method
GuiAbapEditor Object : GoNextBookMark Method

Glossary Item Box

Syntax

Visual Basic
Public Sub GoNextBookMark()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GoNumberedBookmark Method

GoNumberedBookmark Method
p1
GuiAbapEditor Object : GoNumberedBookmark Method

Glossary Item Box

Syntax

Visual Basic
Public Sub GoNumberedBookmark( _
   ByVal p1 As Long _
)

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GoPreviousBookMark Method

GoPreviousBookMark Method
GuiAbapEditor Object : GoPreviousBookMark Method

Glossary Item Box

Syntax

Visual Basic
Public Sub GoPreviousBookMark()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


InsertTab Method

InsertTab Method
GuiAbapEditor Object : InsertTab Method

Glossary Item Box

Syntax

Visual Basic
Public Sub InsertTab()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


InsertText Method

InsertText Method
p1
p2
p3
GuiAbapEditor Object : InsertText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub InsertText( _
   ByVal p1 As String, _
   ByVal p2 As Long, _
   ByVal p3 As Long _
)

Parameters

p1
p2
p3

See Also

GuiAbapEditor Object | GuiAbapEditor Members


IsAutoCompleteEntryBold Method

IsAutoCompleteEntryBold Method
p1
GuiAbapEditor Object : IsAutoCompleteEntryBold Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsAutoCompleteEntryBold( _
   ByVal p1 As Long _
) As Byte

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


IsAutoCompleteOpen Method

IsAutoCompleteOpen Method
GuiAbapEditor Object : IsAutoCompleteOpen Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsAutoCompleteOpen() As Byte

See Also

GuiAbapEditor Object | GuiAbapEditor Members


IsAutoCompleteToolbarButtonPressed Method

IsAutoCompleteToolbarButtonPressed Method
p1
GuiAbapEditor Object : IsAutoCompleteToolbarButtonPressed Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsAutoCompleteToolbarButtonPressed( _
   ByVal p1 As Long _
) As Byte

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


IsAutoCompleteToolTipVisible Method

IsAutoCompleteToolTipVisible Method
GuiAbapEditor Object : IsAutoCompleteToolTipVisible Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsAutoCompleteToolTipVisible() As Byte

See Also

GuiAbapEditor Object | GuiAbapEditor Members


IsBookmark Method

IsBookmark Method
p1
GuiAbapEditor Object : IsBookmark Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsBookmark( _
   ByVal p1 As Long _
) As Byte

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


IsBreakpointSet Method

IsBreakpointSet Method
p1
GuiAbapEditor Object : IsBreakpointSet Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsBreakpointSet( _
   ByVal p1 As Long _
) As Byte

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


IsLineCollapsed Method

IsLineCollapsed Method
p1
GuiAbapEditor Object : IsLineCollapsed Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsLineCollapsed( _
   ByVal p1 As Long _
) As Byte

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


IsLineComment Method

IsLineComment Method
p1
GuiAbapEditor Object : IsLineComment Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsLineComment( _
   ByVal p1 As Long _
) As Byte

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


IsLineModified Method

IsLineModified Method
p1
GuiAbapEditor Object : IsLineModified Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsLineModified( _
   ByVal p1 As Long _
) As Byte

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


IsModified Method

IsModified Method
GuiAbapEditor Object : IsModified Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsModified() As Byte

See Also

GuiAbapEditor Object | GuiAbapEditor Members


JoinSelectedLines Method

JoinSelectedLines Method
GuiAbapEditor Object : JoinSelectedLines Method

Glossary Item Box

Syntax

Visual Basic
Public Sub JoinSelectedLines()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


LowerCase Method

LowerCase Method
GuiAbapEditor Object : LowerCase Method

Glossary Item Box

Syntax

Visual Basic
Public Sub LowerCase()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


MoveCursorDocumentEnd Method

MoveCursorDocumentEnd Method
GuiAbapEditor Object : MoveCursorDocumentEnd Method

Glossary Item Box

Syntax

Visual Basic
Public Sub MoveCursorDocumentEnd()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


MoveCursorLineDown Method

MoveCursorLineDown Method
GuiAbapEditor Object : MoveCursorLineDown Method

Glossary Item Box

Syntax

Visual Basic
Public Sub MoveCursorLineDown()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


MoveCursorLineEnd Method

MoveCursorLineEnd Method
GuiAbapEditor Object : MoveCursorLineEnd Method

Glossary Item Box

Syntax

Visual Basic
Public Sub MoveCursorLineEnd()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


MoveCursorLineHome Method

MoveCursorLineHome Method
GuiAbapEditor Object : MoveCursorLineHome Method

Glossary Item Box

Syntax

Visual Basic
Public Sub MoveCursorLineHome()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


MoveCursorLineUp Method

MoveCursorLineUp Method
GuiAbapEditor Object : MoveCursorLineUp Method

Glossary Item Box

Syntax

Visual Basic
Public Sub MoveCursorLineUp()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


MoveLineDown Method

MoveLineDown Method
GuiAbapEditor Object : MoveLineDown Method

Glossary Item Box

Syntax

Visual Basic
Public Sub MoveLineDown()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


MoveLineUp Method

MoveLineUp Method
GuiAbapEditor Object : MoveLineUp Method

Glossary Item Box

Syntax

Visual Basic
Public Sub MoveLineUp()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


MoveWordLeft Method

MoveWordLeft Method
GuiAbapEditor Object : MoveWordLeft Method

Glossary Item Box

Syntax

Visual Basic
Public Sub MoveWordLeft()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


MoveWordRight Method

MoveWordRight Method
GuiAbapEditor Object : MoveWordRight Method

Glossary Item Box

Syntax

Visual Basic
Public Sub MoveWordRight()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


OverwriteModeEnabled Method

OverwriteModeEnabled Method
GuiAbapEditor Object : OverwriteModeEnabled Method

Glossary Item Box

Syntax

Visual Basic
Public Function OverwriteModeEnabled() As Byte

See Also

GuiAbapEditor Object | GuiAbapEditor Members


RemoveAllBookmarks Method

RemoveAllBookmarks Method
GuiAbapEditor Object : RemoveAllBookmarks Method

Glossary Item Box

Syntax

Visual Basic
Public Sub RemoveAllBookmarks()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


RemoveAllBreakpoints Method

RemoveAllBreakpoints Method
GuiAbapEditor Object : RemoveAllBreakpoints Method

Glossary Item Box

Syntax

Visual Basic
Public Sub RemoveAllBreakpoints()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


RemoveBookmarks Method

RemoveBookmarks Method
p1
GuiAbapEditor Object : RemoveBookmarks Method

Glossary Item Box

Syntax

Visual Basic
Public Sub RemoveBookmarks( _
   ByVal p1 As String _
)

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


RemoveBreakpoint Method

RemoveBreakpoint Method
p1
GuiAbapEditor Object : RemoveBreakpoint Method

Glossary Item Box

Syntax

Visual Basic
Public Sub RemoveBreakpoint( _
   ByVal p1 As Long _
)

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


ReplaceSelection Method

ReplaceSelection Method
p1
GuiAbapEditor Object : ReplaceSelection Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ReplaceSelection( _
   ByVal p1 As String _
)

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SaveToFile Method

SaveToFile Method
p1
GuiAbapEditor Object : SaveToFile Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SaveToFile( _
   ByVal p1 As String _
)

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


ScrollToLine Method

ScrollToLine Method
p1
GuiAbapEditor Object : ScrollToLine Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ScrollToLine( _
   ByVal p1 As Long _
)

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SelectAll Method

SelectAll Method
GuiAbapEditor Object : SelectAll Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectAll()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SelectBlockRange Method

SelectBlockRange Method
p1
p2
p3
p4
GuiAbapEditor Object : SelectBlockRange Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectBlockRange( _
   ByVal p1 As Long, _
   ByVal p2 As Long, _
   ByVal p3 As Long, _
   ByVal p4 As Long _
)

Parameters

p1
p2
p3
p4

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiAbapEditor Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiAbapEditor Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiAbapEditor Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SelectRange Method

SelectRange Method
p1
p2
p3
p4
GuiAbapEditor Object : SelectRange Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectRange( _
   ByVal p1 As Long, _
   ByVal p2 As Long, _
   ByVal p3 As Long, _
   ByVal p4 As Long _
)

Parameters

p1
p2
p3
p4

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SelectWordLeft Method

SelectWordLeft Method
GuiAbapEditor Object : SelectWordLeft Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectWordLeft()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SelectWordRight Method

SelectWordRight Method
GuiAbapEditor Object : SelectWordRight Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectWordRight()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


Sentencize Method

Sentencize Method
GuiAbapEditor Object : Sentencize Method

Glossary Item Box

Syntax

Visual Basic
Public Sub Sentencize()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SetAutoBrace Method

SetAutoBrace Method
p1
GuiAbapEditor Object : SetAutoBrace Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetAutoBrace( _
   ByVal p1 As Byte _
)

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SetAutoCorrect Method

SetAutoCorrect Method
p1
GuiAbapEditor Object : SetAutoCorrect Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetAutoCorrect( _
   ByVal p1 As Byte _
)

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SetAutoIndent Method

SetAutoIndent Method
p1
GuiAbapEditor Object : SetAutoIndent Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetAutoIndent( _
   ByVal p1 As Byte _
)

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SetBookmarks Method

SetBookmarks Method
p1
GuiAbapEditor Object : SetBookmarks Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetBookmarks( _
   ByVal p1 As String _
)

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SetBreakpoint Method

SetBreakpoint Method
p1
GuiAbapEditor Object : SetBreakpoint Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetBreakpoint( _
   ByVal p1 As Long _
)

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SetCodeHints Method

SetCodeHints Method
p1
GuiAbapEditor Object : SetCodeHints Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetCodeHints( _
   ByVal p1 As Byte _
)

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SetCorrectCaps Method

SetCorrectCaps Method
p1
GuiAbapEditor Object : SetCorrectCaps Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetCorrectCaps( _
   ByVal p1 As Byte _
)

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SetFocus Method

SetFocus Method
GuiAbapEditor Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SetLineFeedStyle Method

SetLineFeedStyle Method
p1
GuiAbapEditor Object : SetLineFeedStyle Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetLineFeedStyle( _
   ByVal p1 As Long _
)

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SetOverwriteMode Method

SetOverwriteMode Method
p1
GuiAbapEditor Object : SetOverwriteMode Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetOverwriteMode( _
   ByVal p1 As Byte _
)

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SetSelectionPosInLine Method

SetSelectionPosInLine Method
p1
p2
GuiAbapEditor Object : SetSelectionPosInLine Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetSelectionPosInLine( _
   ByVal p1 As Long, _
   ByVal p2 As Long _
)

Parameters

p1
p2

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SetSmartTab Method

SetSmartTab Method
p1
GuiAbapEditor Object : SetSmartTab Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetSmartTab( _
   ByVal p1 As Byte _
)

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SetWordWrapMode Method

SetWordWrapMode Method
p1
GuiAbapEditor Object : SetWordWrapMode Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetWordWrapMode( _
   ByVal p1 As Long _
)

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SetWordWrapPosition Method

SetWordWrapPosition Method
p1
GuiAbapEditor Object : SetWordWrapPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetWordWrapPosition( _
   ByVal p1 As Long _
)

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


ShowContextMenu Method

ShowContextMenu Method
GuiAbapEditor Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SmartTabEnabled Method

SmartTabEnabled Method
GuiAbapEditor Object : SmartTabEnabled Method

Glossary Item Box

Syntax

Visual Basic
Public Function SmartTabEnabled() As Byte

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SortSelectedLines Method

SortSelectedLines Method
GuiAbapEditor Object : SortSelectedLines Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SortSelectedLines()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SwapCase Method

SwapCase Method
GuiAbapEditor Object : SwapCase Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SwapCase()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


ToggleCapsLock Method

ToggleCapsLock Method
GuiAbapEditor Object : ToggleCapsLock Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ToggleCapsLock()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


ToggleNumberedBookmark Method

ToggleNumberedBookmark Method
p1
p2
GuiAbapEditor Object : ToggleNumberedBookmark Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ToggleNumberedBookmark( _
   ByVal p1 As Long, _
   ByVal p2 As Long _
)

Parameters

p1
p2

See Also

GuiAbapEditor Object | GuiAbapEditor Members


ToggleStructureBlock Method

ToggleStructureBlock Method
p1
GuiAbapEditor Object : ToggleStructureBlock Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ToggleStructureBlock( _
   ByVal p1 As Long _
)

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


TransposeLine Method

TransposeLine Method
GuiAbapEditor Object : TransposeLine Method

Glossary Item Box

Syntax

Visual Basic
Public Sub TransposeLine()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


UncommentSelectedLines Method

UncommentSelectedLines Method
GuiAbapEditor Object : UncommentSelectedLines Method

Glossary Item Box

Syntax

Visual Basic
Public Sub UncommentSelectedLines()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


Undo Method

Undo Method
p1
GuiAbapEditor Object : Undo Method

Glossary Item Box

Syntax

Visual Basic
Public Sub Undo( _
   ByVal p1 As Long _
)

Parameters

p1

See Also

GuiAbapEditor Object | GuiAbapEditor Members


UnTab Method

UnTab Method
GuiAbapEditor Object : UnTab Method

Glossary Item Box

Syntax

Visual Basic
Public Sub UnTab()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


UpperCase Method

UpperCase Method
GuiAbapEditor Object : UpperCase Method

Glossary Item Box

Syntax

Visual Basic
Public Sub UpperCase()

See Also

GuiAbapEditor Object | GuiAbapEditor Members


Visualize Method

Visualize Method
On
InnerObject
GuiAbapEditor Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiAbapEditor Object | GuiAbapEditor Members


AccDescription Property

AccDescription Property
GuiAbapEditor Object : AccDescription Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccDescription As String

See Also

GuiAbapEditor Object | GuiAbapEditor Members


AccLabelCollection Property

AccLabelCollection Property
GuiAbapEditor Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiAbapEditor Object | GuiAbapEditor Members


AccText Property

AccText Property
GuiAbapEditor Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiAbapEditor Object | GuiAbapEditor Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiAbapEditor Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiAbapEditor Object | GuiAbapEditor Members


AccTooltip Property

AccTooltip Property
GuiAbapEditor Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiAbapEditor Object | GuiAbapEditor Members


Changeable Property

Changeable Property
GuiAbapEditor Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiAbapEditor Object | GuiAbapEditor Members


Children Property

Children Property
GuiAbapEditor Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiAbapEditor Object | GuiAbapEditor Members


ContainerType Property

ContainerType Property
GuiAbapEditor Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiAbapEditor Object | GuiAbapEditor Members


CurrentContextMenu Property

CurrentContextMenu Property
GuiAbapEditor Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

GuiAbapEditor Object | GuiAbapEditor Members


DefaultTooltip Property

DefaultTooltip Property
GuiAbapEditor Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiAbapEditor Object | GuiAbapEditor Members


DragDropSupported Property

DragDropSupported Property
GuiAbapEditor Object : DragDropSupported Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DragDropSupported As Byte

See Also

GuiAbapEditor Object | GuiAbapEditor Members


Handle Property

Handle Property
GuiAbapEditor Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiAbapEditor Object | GuiAbapEditor Members


Height Property

Height Property
GuiAbapEditor Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiAbapEditor Object | GuiAbapEditor Members


IconName Property

IconName Property
GuiAbapEditor Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiAbapEditor Object | GuiAbapEditor Members


Id Property

Id Property
GuiAbapEditor Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiAbapEditor Object | GuiAbapEditor Members


IsSymbolFont Property

IsSymbolFont Property
GuiAbapEditor Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiAbapEditor Object | GuiAbapEditor Members


Left Property

Left Property
GuiAbapEditor Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiAbapEditor Object | GuiAbapEditor Members


Modified Property

Modified Property
GuiAbapEditor Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiAbapEditor Object | GuiAbapEditor Members


Name Property

Name Property
GuiAbapEditor Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiAbapEditor Object | GuiAbapEditor Members


OcxEvents Property

OcxEvents Property
GuiAbapEditor Object : OcxEvents Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property OcxEvents As GuiCollection

See Also

GuiAbapEditor Object | GuiAbapEditor Members


Parent Property

Parent Property
GuiAbapEditor Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiAbapEditor Object | GuiAbapEditor Members


ParentFrame Property

ParentFrame Property
GuiAbapEditor Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiAbapEditor Object | GuiAbapEditor Members


ScreenLeft Property

ScreenLeft Property
GuiAbapEditor Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiAbapEditor Object | GuiAbapEditor Members


ScreenTop Property

ScreenTop Property
GuiAbapEditor Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiAbapEditor Object | GuiAbapEditor Members


SubType Property

SubType Property
GuiAbapEditor Object : SubType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property SubType As String

See Also

GuiAbapEditor Object | GuiAbapEditor Members


Text Property

Text Property
GuiAbapEditor Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiAbapEditor Object | GuiAbapEditor Members


Tooltip Property

Tooltip Property
GuiAbapEditor Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiAbapEditor Object | GuiAbapEditor Members


Top Property

Top Property
GuiAbapEditor Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiAbapEditor Object | GuiAbapEditor Members


Type Property

Type Property
GuiAbapEditor Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiAbapEditor Object | GuiAbapEditor Members


TypeAsNumber Property

TypeAsNumber Property
GuiAbapEditor Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiAbapEditor Object | GuiAbapEditor Members


Width Property

Width Property
GuiAbapEditor Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiAbapEditor Object | GuiAbapEditor Members


GuiApoGrid Object

GuiApoGrid Object
See Also Members

Glossary Item Box

Object Model

GuiApoGrid ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiComponent ObjectGuiComponent Object

Remarks

The columns and rows are identified by their position starting with zero:

0 <= row < RowCount
0 <= column < ColumnCount

After a drill-down the rows are re-numbered so that the row number of any given row may change. Scrolling horizontally does not affect the number of a column.

Example

See Also

GuiApoGrid Members


GuiApoGrid Object Members

GuiApoGrid Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method CancelCut
Public Method ClearSelection
Public Method ContextMenu
Public Method Cut
Public Method DeselectCell
Public Method DeselectColumn
Public Method DeselectRow
Public Method DoubleClickCell
Public Method DumpState
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method GetBgdColorInfo
Public Method GetCellChangeable
Public Method GetCellFormat
Public Method GetCellTooltip
Public Method GetCellValue
Public Method GetFgdColorInfo
Public Method GetIconInfo
Public Method IsCellSelected
Public Method IsColSelected
Public Method IsRowSelected
Public Method Paste
Public Method PressEnter
Public Method SelectAll
Public Method SelectCell
Public Method SelectColumn
Public Method SelectContextMenuItem
Public Method SelectContextMenuItemByPosition
Public Method SelectContextMenuItemByText
Public Method SelectRow
Public Method SetCellValue
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccDescription |
Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property Changeable |
Public Property Children |
Public Property ColumnCount |
Public Property ContainerType |
Public Property CurrentCellColumn |
Public Property CurrentCellRow |
Public Property CurrentContextMenu |
Public Property DefaultTooltip |
Public Property DragDropSupported |
Public Property FirstVisibleColumn |
Public Property FirstVisibleRow |
Public Property FixedColumnsLeft |
Public Property FixedColumnsRight |
Public Property FixedRowsBottom |
Public Property FixedRowsTop |
Public Property Handle |
Public Property Height |
Public Property IconName |
Public Property Id |
Public Property IsSymbolFont |
Public Property Left |
Public Property Modified |
Public Property Name |
Public Property OcxEvents |
Public Property Parent |
Public Property ParentFrame |
Public Property RowCount |
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property SelectedCells |
Public Property SelectedColumns |
Public Property SelectedColumnsObject |
Public Property SelectedRows |
Public Property SelectedRowsObject |
Public Property SubType | This property has the constant value “ApoGrid”.
Public Property Text |
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property VisibleColumnCount |
Public Property VisibleRowCount |
Public Property Width |

See Also

GuiApoGrid Object


CancelCut Method

CancelCut Method
GuiApoGrid Object : CancelCut Method

Glossary Item Box

Syntax

Visual Basic
Public Sub CancelCut()

See Also

GuiApoGrid Object | GuiApoGrid Members


ClearSelection Method

ClearSelection Method
GuiApoGrid Object : ClearSelection Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ClearSelection()

See Also

GuiApoGrid Object | GuiApoGrid Members


ContextMenu Method

ContextMenu Method
Column
Row
GuiApoGrid Object : ContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ContextMenu( _
   ByVal Column As Long, _
   ByVal Row As Long _
)

Parameters

Column
Row

See Also

GuiApoGrid Object | GuiApoGrid Members


Cut Method

Cut Method
GuiApoGrid Object : Cut Method

Glossary Item Box

Syntax

Visual Basic
Public Sub Cut()

See Also

GuiApoGrid Object | GuiApoGrid Members


DeselectCell Method

DeselectCell Method
Column
Row
GuiApoGrid Object : DeselectCell Method

Glossary Item Box

Syntax

Visual Basic
Public Sub DeselectCell( _
   ByVal Column As Long, _
   ByVal Row As Long _
)

Parameters

Column
Row

See Also

GuiApoGrid Object | GuiApoGrid Members


DeselectColumn Method

DeselectColumn Method
Column
GuiApoGrid Object : DeselectColumn Method

Glossary Item Box

Syntax

Visual Basic
Public Sub DeselectColumn( _
   ByVal Column As Long _
)

Parameters

Column

See Also

GuiApoGrid Object | GuiApoGrid Members


DeselectRow Method

DeselectRow Method
Row
GuiApoGrid Object : DeselectRow Method

Glossary Item Box

Syntax

Visual Basic
Public Sub DeselectRow( _
   ByVal Row As Long _
)

Parameters

Row

See Also

GuiApoGrid Object | GuiApoGrid Members


DoubleClickCell Method

DoubleClickCell Method
Column
Row
GuiApoGrid Object : DoubleClickCell Method

Glossary Item Box

Syntax

Visual Basic
Public Sub DoubleClickCell( _
   ByVal Column As Long, _
   ByVal Row As Long _
)

Parameters

Column
Row

See Also

GuiApoGrid Object | GuiApoGrid Members


DumpState Method

DumpState Method
InnerObject
GuiApoGrid Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiApoGrid Object | GuiApoGrid Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiApoGrid Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiApoGrid Object | GuiApoGrid Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiApoGrid Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiApoGrid Object | GuiApoGrid Members


FindById Method

FindById Method
Id
Raise
GuiApoGrid Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiApoGrid Object | GuiApoGrid Members


FindByName Method

FindByName Method
Name
Type
GuiApoGrid Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiApoGrid Object | GuiApoGrid Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiApoGrid Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiApoGrid Object | GuiApoGrid Members


GetBgdColorInfo Method

GetBgdColorInfo Method
Row
Column
GuiApoGrid Object : GetBgdColorInfo Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetBgdColorInfo( _
   ByVal Row As Long, _
   ByVal Column As Long _
) As String

Parameters

Row
Column

See Also

GuiApoGrid Object | GuiApoGrid Members


GetCellChangeable Method

GetCellChangeable Method
Column
Row
GuiApoGrid Object : GetCellChangeable Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetCellChangeable( _
   ByVal Column As Long, _
   ByVal Row As Long _
) As Byte

Parameters

Column
Row

See Also

GuiApoGrid Object | GuiApoGrid Members


GetCellFormat Method

GetCellFormat Method
Column
Row
GuiApoGrid Object : GetCellFormat Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetCellFormat( _
   ByVal Column As Long, _
   ByVal Row As Long _
) As String

Parameters

Column
Row

See Also

GuiApoGrid Object | GuiApoGrid Members


GetCellTooltip Method

GetCellTooltip Method
Column
Row
GuiApoGrid Object : GetCellTooltip Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetCellTooltip( _
   ByVal Column As Long, _
   ByVal Row As Long _
) As String

Parameters

Column
Row

See Also

GuiApoGrid Object | GuiApoGrid Members


GetCellValue Method

GetCellValue Method
Column
Row
GuiApoGrid Object : GetCellValue Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetCellValue( _
   ByVal Column As Long, _
   ByVal Row As Long _
) As String

Parameters

Column
Row

See Also

GuiApoGrid Object | GuiApoGrid Members


GetFgdColorInfo Method

GetFgdColorInfo Method
Row
Column
GuiApoGrid Object : GetFgdColorInfo Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetFgdColorInfo( _
   ByVal Row As Long, _
   ByVal Column As Long _
) As String

Parameters

Row
Column

See Also

GuiApoGrid Object | GuiApoGrid Members


GetIconInfo Method

GetIconInfo Method
Row
Column
GuiApoGrid Object : GetIconInfo Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetIconInfo( _
   ByVal Row As Long, _
   ByVal Column As Long _
) As String

Parameters

Row
Column

See Also

GuiApoGrid Object | GuiApoGrid Members


IsCellSelected Method

IsCellSelected Method
Column
Row
GuiApoGrid Object : IsCellSelected Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsCellSelected( _
   ByVal Column As Long, _
   ByVal Row As Long _
) As Byte

Parameters

Column
Row

See Also

GuiApoGrid Object | GuiApoGrid Members


IsColSelected Method

IsColSelected Method
col
GuiApoGrid Object : IsColSelected Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsColSelected( _
   ByVal col As Long _
) As Byte

Parameters

col

See Also

GuiApoGrid Object | GuiApoGrid Members


IsRowSelected Method

IsRowSelected Method
Row
GuiApoGrid Object : IsRowSelected Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsRowSelected( _
   ByVal Row As Long _
) As Byte

Parameters

Row

See Also

GuiApoGrid Object | GuiApoGrid Members


Paste Method

Paste Method
CellValues
ColumnCount
GuiApoGrid Object : Paste Method

Glossary Item Box

Syntax

Visual Basic
Public Function Paste( _
   ByVal CellValues As Object, _
   ByVal ColumnCount As Long _
) As Long

Parameters

CellValues
ColumnCount

See Also

GuiApoGrid Object | GuiApoGrid Members


PressEnter Method

PressEnter Method
GuiApoGrid Object : PressEnter Method

Glossary Item Box

Syntax

Visual Basic
Public Sub PressEnter()

See Also

GuiApoGrid Object | GuiApoGrid Members


SelectAll Method

SelectAll Method
GuiApoGrid Object : SelectAll Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectAll()

See Also

GuiApoGrid Object | GuiApoGrid Members


SelectCell Method

SelectCell Method
Column
Row
GuiApoGrid Object : SelectCell Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectCell( _
   ByVal Column As Long, _
   ByVal Row As Long _
)

Parameters

Column
Row

See Also

GuiApoGrid Object | GuiApoGrid Members


SelectColumn Method

SelectColumn Method
Column
GuiApoGrid Object : SelectColumn Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectColumn( _
   ByVal Column As Long _
)

Parameters

Column

See Also

GuiApoGrid Object | GuiApoGrid Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiApoGrid Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiApoGrid Object | GuiApoGrid Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiApoGrid Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiApoGrid Object | GuiApoGrid Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiApoGrid Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

GuiApoGrid Object | GuiApoGrid Members


SelectRow Method

SelectRow Method
Row
GuiApoGrid Object : SelectRow Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectRow( _
   ByVal Row As Long _
)

Parameters

Row

See Also

GuiApoGrid Object | GuiApoGrid Members


SetCellValue Method

SetCellValue Method
Column
Row
Value
GuiApoGrid Object : SetCellValue Method

Glossary Item Box

Syntax

Visual Basic
Public Function SetCellValue( _
   ByVal Column As Long, _
   ByVal Row As Long, _
   ByVal Value As String _
) As String

Parameters

Column
Row
Value

See Also

GuiApoGrid Object | GuiApoGrid Members


SetFocus Method

SetFocus Method
GuiApoGrid Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiApoGrid Object | GuiApoGrid Members


ShowContextMenu Method

ShowContextMenu Method
GuiApoGrid Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiApoGrid Object | GuiApoGrid Members


Visualize Method

Visualize Method
On
InnerObject
GuiApoGrid Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiApoGrid Object | GuiApoGrid Members


AccDescription Property

AccDescription Property
GuiApoGrid Object : AccDescription Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccDescription As String

See Also

GuiApoGrid Object | GuiApoGrid Members


AccLabelCollection Property

AccLabelCollection Property
GuiApoGrid Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiApoGrid Object | GuiApoGrid Members


AccText Property

AccText Property
GuiApoGrid Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiApoGrid Object | GuiApoGrid Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiApoGrid Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiApoGrid Object | GuiApoGrid Members


AccTooltip Property

AccTooltip Property
GuiApoGrid Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiApoGrid Object | GuiApoGrid Members


Changeable Property

Changeable Property
GuiApoGrid Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiApoGrid Object | GuiApoGrid Members


Children Property

Children Property
GuiApoGrid Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiApoGrid Object | GuiApoGrid Members


ColumnCount Property

ColumnCount Property
GuiApoGrid Object : ColumnCount Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ColumnCount As Long

See Also

GuiApoGrid Object | GuiApoGrid Members


ContainerType Property

ContainerType Property
GuiApoGrid Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiApoGrid Object | GuiApoGrid Members


CurrentCellColumn Property

CurrentCellColumn Property
GuiApoGrid Object : CurrentCellColumn Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentCellColumn As Long

See Also

GuiApoGrid Object | GuiApoGrid Members


CurrentCellRow Property

CurrentCellRow Property
GuiApoGrid Object : CurrentCellRow Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentCellRow As Long

See Also

GuiApoGrid Object | GuiApoGrid Members


CurrentContextMenu Property

CurrentContextMenu Property
GuiApoGrid Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

GuiApoGrid Object | GuiApoGrid Members


DefaultTooltip Property

DefaultTooltip Property
GuiApoGrid Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiApoGrid Object | GuiApoGrid Members


DragDropSupported Property

DragDropSupported Property
GuiApoGrid Object : DragDropSupported Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DragDropSupported As Byte

See Also

GuiApoGrid Object | GuiApoGrid Members


FirstVisibleColumn Property

FirstVisibleColumn Property
GuiApoGrid Object : FirstVisibleColumn Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property FirstVisibleColumn As Long

See Also

GuiApoGrid Object | GuiApoGrid Members


FirstVisibleRow Property

FirstVisibleRow Property
GuiApoGrid Object : FirstVisibleRow Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property FirstVisibleRow As Long

See Also

GuiApoGrid Object | GuiApoGrid Members


FixedColumnsLeft Property

FixedColumnsLeft Property
GuiApoGrid Object : FixedColumnsLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property FixedColumnsLeft As Long

See Also

GuiApoGrid Object | GuiApoGrid Members


FixedColumnsRight Property

FixedColumnsRight Property
GuiApoGrid Object : FixedColumnsRight Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property FixedColumnsRight As Long

See Also

GuiApoGrid Object | GuiApoGrid Members


FixedRowsBottom Property

FixedRowsBottom Property
GuiApoGrid Object : FixedRowsBottom Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property FixedRowsBottom As Long

See Also

GuiApoGrid Object | GuiApoGrid Members


FixedRowsTop Property

FixedRowsTop Property
GuiApoGrid Object : FixedRowsTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property FixedRowsTop As Long

See Also

GuiApoGrid Object | GuiApoGrid Members


Handle Property

Handle Property
GuiApoGrid Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiApoGrid Object | GuiApoGrid Members


Height Property

Height Property
GuiApoGrid Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiApoGrid Object | GuiApoGrid Members


IconName Property

IconName Property
GuiApoGrid Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiApoGrid Object | GuiApoGrid Members


Id Property

Id Property
GuiApoGrid Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiApoGrid Object | GuiApoGrid Members


IsSymbolFont Property

IsSymbolFont Property
GuiApoGrid Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiApoGrid Object | GuiApoGrid Members


Left Property

Left Property
GuiApoGrid Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiApoGrid Object | GuiApoGrid Members


Modified Property

Modified Property
GuiApoGrid Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiApoGrid Object | GuiApoGrid Members


Name Property

Name Property
GuiApoGrid Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiApoGrid Object | GuiApoGrid Members


OcxEvents Property

OcxEvents Property
GuiApoGrid Object : OcxEvents Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property OcxEvents As GuiCollection

See Also

GuiApoGrid Object | GuiApoGrid Members


Parent Property

Parent Property
GuiApoGrid Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiApoGrid Object | GuiApoGrid Members


ParentFrame Property

ParentFrame Property
GuiApoGrid Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiApoGrid Object | GuiApoGrid Members


RowCount Property

RowCount Property
GuiApoGrid Object : RowCount Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property RowCount As Long

See Also

GuiApoGrid Object | GuiApoGrid Members


ScreenLeft Property

ScreenLeft Property
GuiApoGrid Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiApoGrid Object | GuiApoGrid Members


ScreenTop Property

ScreenTop Property
GuiApoGrid Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiApoGrid Object | GuiApoGrid Members


SelectedCells Property

SelectedCells Property
GuiApoGrid Object : SelectedCells Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property SelectedCells As Object

See Also

GuiApoGrid Object | GuiApoGrid Members


SelectedColumns Property

SelectedColumns Property
GuiApoGrid Object : SelectedColumns Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property SelectedColumns As String

See Also

GuiApoGrid Object | GuiApoGrid Members


SelectedColumnsObject Property

SelectedColumnsObject Property
GuiApoGrid Object : SelectedColumnsObject Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property SelectedColumnsObject As Object

See Also

GuiApoGrid Object | GuiApoGrid Members


SelectedRows Property

SelectedRows Property
GuiApoGrid Object : SelectedRows Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property SelectedRows As String

See Also

GuiApoGrid Object | GuiApoGrid Members


SelectedRowsObject Property

SelectedRowsObject Property
GuiApoGrid Object : SelectedRowsObject Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property SelectedRowsObject As Object

See Also

GuiApoGrid Object | GuiApoGrid Members


SubType Property

SubType Property
GuiApoGrid Object : SubType Property

Glossary Item Box

Description

This property has the constant value “ApoGrid”.

Property type

Read-only property

Syntax

Visual Basic
Public Property SubType As String

See Also

GuiApoGrid Object | GuiApoGrid Members


Text Property

Text Property
GuiApoGrid Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiApoGrid Object | GuiApoGrid Members


Tooltip Property

Tooltip Property
GuiApoGrid Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiApoGrid Object | GuiApoGrid Members


Top Property

Top Property
GuiApoGrid Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiApoGrid Object | GuiApoGrid Members


Type Property

Type Property
GuiApoGrid Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiApoGrid Object | GuiApoGrid Members


TypeAsNumber Property

TypeAsNumber Property
GuiApoGrid Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiApoGrid Object | GuiApoGrid Members


VisibleColumnCount Property

VisibleColumnCount Property
GuiApoGrid Object : VisibleColumnCount Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property VisibleColumnCount As Long

See Also

GuiApoGrid Object | GuiApoGrid Members


VisibleRowCount Property

VisibleRowCount Property
GuiApoGrid Object : VisibleRowCount Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property VisibleRowCount As Long

See Also

GuiApoGrid Object | GuiApoGrid Members


Width Property

Width Property
GuiApoGrid Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiApoGrid Object | GuiApoGrid Members


GuiApplication Object

GuiApplication Object
See Also Members Example

Glossary Item Box

Description

The GuiApplication represents the process in which all SAP GUI activity takes place. If the scripting component is accessed by attaching to a SAPlogon process, then GuiApplication will represent SAPlogon. GuiApplication is a creatable class. However, there must be only one component of this type in any process. GuiApplication extends GuiContainer.

Object Model

GuiApplication ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiConnection ObjectGuiConnection ObjectGuiComponent ObjectGuiUtils Object

Remarks

The type prefix and the value of the name property are 'app'.

When running a recorded script in Excel you may receive an error message 'Invalid use of property'. This may be caused by a name collision for the 'application' object. In Excel this name is predefined, and it will collide with the code generated by the SAP GUI Scripting recorder. To fix the problem, rename the SAP GUI application object.

Example

When running a recorded script in Excel you may receive an error message 'Invalid use of property'. This may be caused by a name collision for the 'application' object. In Excel this name is predefined, and it will collide with the code generated by the SAP GUI Scripting recorder. To fix the problem, rename the SAP GUI application object.
Integration with Microsoft Excel (Visual Basic) Copy Code

  Example
Using CreateObject
 | Using GetObject

  See Also
GuiApplication Members


GuiApplication Object Members

GuiApplication Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method AddHistoryEntry | SAP GUI for Windows has an input history functionality, which displays for text fields the entries made in the past as a suggestion. With this function, an entry can be added to the history database so that it will be available the next time the end user accesses the text field with the given field name.
Public Method CreateGuiCollection | Some functions accept collections as parameters. This function creates a collection object that is independent of the scripting language used, such as VBScript or JavaScript.
Public Method DropHistory | Calling this function will delete all entries from the input history. The function returns True if the history data have been deleted successfully.
Public Method FindById
Public Method Ignore | eCATT uses this function to prevent scripts from accessing the session in which eCATT itself runs. Otherwise the the token handling would cause a dead lock.
Public Method OpenConnection

The parameter connectString should contain one of the descriptions displayed in SAPlogon, for example "XYZ [PUBLIC]". If you want to create a new SAP GUI instance and place it within your application you may add the suffix “/INPLACE”.

This function will raise the exception E_ACCESSDENIED if the scripting support has been disabled by the administrator or the user.

Public Method OpenConnectionByConnectionString | The parameter connectionData is the connection string for the SAP server, for example “/R/ALR/G/SPACE”. See the description of the openConnection method for a discussion of the sync and raise parameters.
Public Method RegisterROT Accessing the SAPGUI entry in the Running Object Table from a C++ application may fail unless the interface is registered with a strong reference. This is not required when using Visual Basic or scripting languages.
The reference must be released using revokeRot before shutting down the Scripting component. Failing to do so will lead to undefined behaviour.
Most applications do not need to use this method, and shouldn’t call it.
Public Method RevokeROT | This method must be called before shutting down the Scripting component if registerROT was used.
Public Method SetCookie

Public Properties

Public Property ActiveSession | Returns the Session that the user is currently working with, which will be the topmost window.
Public Property AllowSystemMessages | System messages are displayed when an administrator invokes them on the server to send a notification to users currently logged in. This may happen at any time and interfere with the recording or playback of a script. Setting this property to FALSE will prevent system messages from being displayed.
Public Property ButtonbarVisible | Setting this property to FALSE hides the application toolbar of the main window.
Public Property Children |
Public Property ConnectionErrorText | This property contains the text of a connection error message. If openConnection fails you can retrieve information about the cause of the failure from this property.
Public Property Connections | This property is another name for the Children property. It has been added for better readability as all the children of GuiApplication are connections.
Public Property ContainerType |
Public Property HistoryEnabled | The local history function can be enabled or disabled using this property. Disabling it will significantly improve the performance of SAP GUI, which may be crucial during load tests, for example.
Public Property Id |
Public Property MajorVersion | Version of the SAP GUI release, for example ‘6.20’.
Public Property MinorVersion | Build number of the scripting component.
Public Property Name |
Public Property NewVisualDesign | Returns whether New Visual Design or Classic mode are used for the user interface.
Public Property Parent |
Public Property Patchlevel | Patchlevel of SAP GUI.
Public Property Revision | Revision of the SAP GUI release. In SAP GUI for Windows this is the compilation number.
Public Property StatusbarVisible | Setting this property to FALSE hides the statusbar of the main window.
Public Property TitlebarVisible | Setting this property to FALSE hides the titlebar of the main window.
Public Property ToolbarVisible | Setting this property to FALSE hides the system toolbar of the main window.
Public Property Type |
Public Property TypeAsNumber |
Public Property Utils | This property returns a global GuiUtils object.

Events

Public Event CreateSession | This event is raised whenever a new session is created, irrespective of whether of the session being created manually, from ABAP or by a script. The event is only raised for a session if the scripting support has been enabled for the corresponding backend.
Public Event DestroySession | This event is raised before a session is destroyed . This can be done either by closing the main window manually, or by calling the closeSession method of GuiConnection.
Public Event Error | An error event is currently only raised, if the wrapper library required to access a SAP GUI ActiveX control from a script is not available. This event is also available on the GuiSession in which the error occurred.
Public Event IgnoreSession | The event is fired when a session is set to ‘Ignored’ using IgnoreSession function. This event is only fired when using SAP GUI Scripting while running eCATT in parallel.

See Also

GuiApplication Object


AddHistoryEntry Method

AddHistoryEntry Method
Fieldname
Value
GuiApplication Object : AddHistoryEntry Method

Glossary Item Box

Description

SAP GUI for Windows has an input history functionality, which displays for text fields the entries made in the past as a suggestion. With this function, an entry can be added to the history database so that it will be available the next time the end user accesses the text field with the given field name.

Syntax

Visual Basic
Public Function AddHistoryEntry( _
   ByVal Fieldname As String, _
   ByVal Value As String _
) As Byte

Parameters

Fieldname
Value

Remarks

For a given text field, the field name can be determined by positioning the cursor on the field and pressing F1. A new window is then opened for the Performance Assistant, which has a Technical Information button. Using this will display the dialog below. The field name is displayed at the bottom of the dialog as ‘Screen field’. The functions returns True if the entry was added successfully.

See Also

GuiApplication Object | GuiApplication Members


CreateGuiCollection Method

CreateGuiCollection Method
GuiApplication Object : CreateGuiCollection Method

Glossary Item Box

Description

Some functions accept collections as parameters. This function creates a collection object that is independent of the scripting language used, such as VBScript or JavaScript.

Syntax

Visual Basic
Public Function CreateGuiCollection() As Object

See Also

GuiApplication Object | GuiApplication Members


DropHistory Method

DropHistory Method
GuiApplication Object : DropHistory Method

Glossary Item Box

Description

Calling this function will delete all entries from the input history. The function returns True if the history data have been deleted successfully.

Syntax

Visual Basic
Public Function DropHistory() As Byte

See Also

GuiApplication Object | GuiApplication Members


FindById Method

FindById Method
Id
Raise
GuiApplication Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiApplication Object | GuiApplication Members


Ignore Method

Ignore Method
WindowHandle
GuiApplication Object : Ignore Method

Glossary Item Box

Description

eCATT uses this function to prevent scripts from accessing the session in which eCATT itself runs. Otherwise the the token handling would cause a dead lock.

Syntax

Visual Basic
Public Sub Ignore( _
   ByVal WindowHandle As Integer _
)

Parameters

WindowHandle

See Also

GuiApplication Object | GuiApplication Members


OpenConnection Method

OpenConnection Method
Description
Sync
Raise
GuiApplication Object : OpenConnection Method

Glossary Item Box

Description

The parameter connectString should contain one of the descriptions displayed in SAPlogon, for example "XYZ [PUBLIC]". If you want to create a new SAP GUI instance and place it within your application you may add the suffix “/INPLACE”.

This function will raise the exception E_ACCESSDENIED if the scripting support has been disabled by the administrator or the user.

Syntax

Visual Basic
Public Function OpenConnection( _
   ByVal Description As String, _
   Optional ByVal Sync As Variant, _
   Optional ByVal Raise As Variant _
) As GuiConnection

Parameters

Description
Sync
Raise

Remarks

When opening connections manually SAP GUI executes the request asynchronously, so that the SAPLogon dialog remains responsive after requesting a new connection. This behaviour is also the default for SAP GUI Scripting.

In the Scripting context it means that the call to openConnection may return before the new connection has been opened. A side effect of this is that when opening a connection fails SAP GUI displays an error popup that can not be handled from the script. This problem can be solved by setting the sync parameter to True. Then the call to openConnection will not return until a connection has been established, or an error has been detected. If sync is set to True and an error occurs an exception is raised, unless the parameter raise is set to False.

Example

In the following example the scripting component has been placed on an HTML page and the connection was opened in the pageLoad event handler using the “/INPLACE” switch.

See Also

GuiApplication Object | GuiApplication Members


OpenConnectionByConnectionString Method

OpenConnectionByConnectionString Method
ConnectString
Sync
Raise
GuiApplication Object : OpenConnectionByConnectionString Method

Glossary Item Box

Description

The parameter connectionData is the connection string for the SAP server, for example “/R/ALR/G/SPACE”. See the description of the openConnection method for a discussion of the sync and raise parameters.

Syntax

Visual Basic
Public Function OpenConnectionByConnectionString( _
   ByVal ConnectString As String, _
   Optional ByVal Sync As Variant, _
   Optional ByVal Raise As Variant _
) As GuiConnection

Parameters

ConnectString
Sync
Raise

Remarks

Connection Strings

Connection String is a technical term used within SAP GUI. A connection string describes a connection address for a destination, e.g. an SAP system's application server, similar to an Internet URL describes a location for a web page.

Simple Connection Strings
In its simplest form, a connection string contains an IP address and a port number. This information is sufficient for SAP GUI to open a direct TCP connection to a destination, e.g. an application server. IP address and port number are marked with the prefixes '/H/' (for host) and '/S/' (for service). Note that the port number for an SAP application server is by convention 3200 plus the two-digit SAP system number.

Example for a simple connection string with an application server's IP address (172.16.64.17) and port number (3200):
/H/172.16.64.17/S/3200

If your network environment supports DNS (Domain Name Services), a hostname can be used instead of the IP address in all kinds of connection strings. (This requires a correct DNS configuration on the client, e.g. via the hosts file).

Example with an application server's hostname (iwdf8997.wdf.sap-ag.de) and port number (3200):
/H/iwdf8997.wdf.sap-ag.de/S/3200

If your network environment supports symbolic service names for well-known ports, the symbolic service name can be used instead of the port number in all kinds of connection strings. (This requires a correct service configuration on the client, e.g. in the services file). Note that SAP application server ports are by convention named 'sapdp<SID>', where <SID> is the SAP system id.

Example with host name (iwdf8997.wdf.sap-ag.de) and symbolic service name (sapdpIWD):
/H/iwdf8997.wdf.sap-ag.de/S/sapdpIWD

Simple connection strings need not be resolved by the SAP GUI application. Resolution of host names and symbolic service names is done by the operating system's network layer.

SAP Routers

In a WAN (Wide Area Network) environment, SAP routers are used to make connections to remote SAP systems that cannot be reached with a direct TCP connection. Passwords may be used for each SAP router to control access.

In order to make a connection, the client is responsible for providing the complete route to the destination, possibly including a chain of several SAP routers. Path information is not provided by the routers. (Strictly speaking, a SAP router is actually better described as an application level proxy with password capabilities and strict source routing).

The address for each router is specified by a simple connection string (with the router's host name and port number), optionally followed by '/P/' and the router password. The path from the current location to the destination is described by concatenating all router addresses, followed by the address of the destination SAP system. Thus, a connection string with SAP routers generally has the form <router 1><router 2>...<router n><destination>.

Example with two routers (gate.acme.com, port 3299, and gate.sap.com, port 3298), the first using a password (secret), for a connection to the application server iwdf8997.sap.com, port 3200):
/H/gate.acme.com/S/3299/P/secret/H/gate.sap.com/S/3298/H/iwdf8997.sap.com/S/3200
<-------- 1st router ----------><---- 2nd router ----><------ app_server ------>

Connection strings including SAP routers are passed to SAP GUI's communication layer and resolved step by step by the routers on the path. If host names and symbolic service names are used, each router must have access to correct network configuration information to resolve them.

Message Servers and Logon Groups

For load balancing purposes, application servers from one SAP system are usually configured in logon groups, where each group serves a particular kind of user. The application servers in each group are assigned to users by a least-heavily-loaded strategy. This load balancing is done by message servers. Each SAP system has exactly one message server, which can be reached via TCP on a specific message server port.

Care should be taken that the application server's port number is not confused with the message server's port number. Although the message server's host name may in small installations often be identical to the hostname of an application server, the port number is always different. Symbolic service names for message servers by convention have the form 'sapms<SID>', where <SID> is the SAP system id.

Message server and group information can be used to address a SAP system in a connection string. The address of the message server is specified as a combination of message server host name, message server port and group name. This information is marked with the prefixes '/M/' (message server host name), '/S/' (message server port) and '/G/' (logon group).

Example with message server (hostname alrmain, port number 4253) and logon group (SPACE):
/M/alrmain.wdf.sap-ag.de/S/4253/G/SPACE

Connection strings with message servers are resolved by SAP GUI by contacting the message server and retrieving the (simple) connection string of an application server for the specified group. This requires network access to the message server at the time the address is resolved.

SAP router connection strings may be used in combination with message server connection strings simply by specifying the router address before the message server address. The router is then used for contacting the message server as well as for contacting the resolved application server.

Symbolic System Names

The most user-friendly form of connection string addresses an SAP system only by its symbolic name (per convention, the system id) and the logon group name. These information are marked with the prefixes '/R/' (for the symbolic SAP system name) and '/G/' (for the logon group name).

Example with SAP system (ALR) and logon group (SPACE):
/R/ALR/G/SPACE

Connection strings with symbolic system names are resolved by SAP GUI by looking up the symbolic SAP system name in the Message Server List (a text file containing a mapping between symbolic system names and message server addresses) and replacing the /R/ part of the connection string with the resulting message server address. The result is a complete message server connection string which is then further resolved as explained above.

Formal syntax

For the technically interested reader, the following BNF grammar formally describes the syntax of connection strings:
<connection string> := [<router prefix>]<local>
<local> := <simple>|<message server>|<symbolic>
<simple> := "/H/"<host>"/S/"<service>
<host> := <hostname>|<ipaddr>
<hostname> := (any DNS hostname)
<ipaddr> := (any IP address, in dotted decimal form)
<service> := <servicename>|<port number>
<servicename> := (any IP service name)
<port number> := (any decimal number)
<messageserver> := "/M/"<host>"/S/"<service>"/G/"<group>
<group> := (any ASCII string not containing '/')
<symbolic> := "/R/"<system>"/G/"<group>
<system> := (any ASCII string not containing '/')
<router prefix> := <router>*
<router> := "/H/"<host>"/S/"<service>["/P/"<password>]
<password> := (any ASCII string not containing '/')

See Also

GuiApplication Object | GuiApplication Members


RegisterROT Method

RegisterROT Method
GuiApplication Object : RegisterROT Method

Glossary Item Box

Description

Accessing the SAPGUI entry in the Running Object Table from a C++ application may fail unless the interface is registered with a strong reference. This is not required when using Visual Basic or scripting languages.
The reference must be released using revokeRot before shutting down the Scripting component. Failing to do so will lead to undefined behaviour.
Most applications do not need to use this method, and shouldn’t call it.

Syntax

Visual Basic
Public Function RegisterROT() As Byte

See Also

GuiApplication Object | GuiApplication Members


RevokeROT Method

RevokeROT Method
GuiApplication Object : RevokeROT Method

Glossary Item Box

Description

This method must be called before shutting down the Scripting component if registerROT was used.

Syntax

Visual Basic
Public Sub RevokeROT()

See Also

GuiApplication Object | GuiApplication Members


SetCookie Method

SetCookie Method
WindowHandle
GuiApplication Object : SetCookie Method

Glossary Item Box

Syntax

Visual Basic
Public Function SetCookie( _
   ByVal WindowHandle As Integer _
) As Object

Parameters

WindowHandle

See Also

GuiApplication Object | GuiApplication Members


ActiveSession Property

ActiveSession Property
GuiApplication Object : ActiveSession Property

Glossary Item Box

Description

Returns the Session that the user is currently working with, which will be the topmost window.

Property type

Read-only property

Syntax

Visual Basic
Public Property ActiveSession As Object

See Also

GuiApplication Object | GuiApplication Members


AllowSystemMessages Property

AllowSystemMessages Property
GuiApplication Object : AllowSystemMessages Property

Glossary Item Box

Description

System messages are displayed when an administrator invokes them on the server to send a notification to users currently logged in. This may happen at any time and interfere with the recording or playback of a script. Setting this property to FALSE will prevent system messages from being displayed.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllowSystemMessages As Byte

See Also

GuiApplication Object | GuiApplication Members


ButtonbarVisible Property

ButtonbarVisible Property
GuiApplication Object : ButtonbarVisible Property

Glossary Item Box

Description

Setting this property to FALSE hides the application toolbar of the main window.

Property type

Read-write property

Syntax

Visual Basic
Public Property ButtonbarVisible As Byte

Remarks

Hiding the application toolbar may be useful if SAP GUI is displayed inplace, for example in a web page. The property should not be used when displaying SAP GUI as a standalone application.

See Also

GuiApplication Object | GuiApplication Members


Children Property

Children Property
GuiApplication Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiApplication Object | GuiApplication Members


ConnectionErrorText Property

ConnectionErrorText Property
GuiApplication Object : ConnectionErrorText Property

Glossary Item Box

Description

This property contains the text of a connection error message. If openConnection fails you can retrieve information about the cause of the failure from this property.

Property type

Read-only property

Syntax

Visual Basic
Public Property ConnectionErrorText As String

See Also

GuiApplication Object | GuiApplication Members


Connections Property

Connections Property
GuiApplication Object : Connections Property

Glossary Item Box

Description

This property is another name for the Children property. It has been added for better readability as all the children of GuiApplication are connections.

Property type

Read-only property

Syntax

Visual Basic
Public Property Connections As GuiComponentCollection

See Also

GuiApplication Object | GuiApplication Members


ContainerType Property

ContainerType Property
GuiApplication Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiApplication Object | GuiApplication Members


HistoryEnabled Property

HistoryEnabled Property
GuiApplication Object : HistoryEnabled Property

Glossary Item Box

Description

The local history function can be enabled or disabled using this property. Disabling it will significantly improve the performance of SAP GUI, which may be crucial during load tests, for example.

Property type

Read-write property

Syntax

Visual Basic
Public Property HistoryEnabled As Byte

See Also

GuiApplication Object | GuiApplication Members


Id Property

Id Property
GuiApplication Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiApplication Object | GuiApplication Members


MajorVersion Property

MajorVersion Property
GuiApplication Object : MajorVersion Property

Glossary Item Box

Description

Version of the SAP GUI release, for example ‘6.20’.

Property type

Read-only property

Syntax

Visual Basic
Public Property MajorVersion As Long

See Also

GuiApplication Object | GuiApplication Members


MinorVersion Property

MinorVersion Property
GuiApplication Object : MinorVersion Property

Glossary Item Box

Description

Build number of the scripting component.

Property type

Read-only property

Syntax

Visual Basic
Public Property MinorVersion As Long

See Also

GuiApplication Object | GuiApplication Members


Name Property

Name Property
GuiApplication Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiApplication Object | GuiApplication Members


NewVisualDesign Property

NewVisualDesign Property
GuiApplication Object : NewVisualDesign Property

Glossary Item Box

Description

Returns whether New Visual Design or Classic mode are used for the user interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property NewVisualDesign As Byte

Example

False: Classic mode

True: New Visual Design

See Also

GuiApplication Object | GuiApplication Members


Parent Property

Parent Property
GuiApplication Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiApplication Object | GuiApplication Members


Patchlevel Property

Patchlevel Property
GuiApplication Object : Patchlevel Property

Glossary Item Box

Description

Patchlevel of SAP GUI.

Property type

Read-only property

Syntax

Visual Basic
Public Property Patchlevel As Long

See Also

GuiApplication Object | GuiApplication Members


Revision Property

Revision Property
GuiApplication Object : Revision Property

Glossary Item Box

Description

Revision of the SAP GUI release. In SAP GUI for Windows this is the compilation number.

Property type

Read-only property

Syntax

Visual Basic
Public Property Revision As Long

See Also

GuiApplication Object | GuiApplication Members


StatusbarVisible Property

StatusbarVisible Property
GuiApplication Object : StatusbarVisible Property

Glossary Item Box

Description

Setting this property to FALSE hides the statusbar of the main window.

Property type

Read-write property

Syntax

Visual Basic
Public Property StatusbarVisible As Byte

Remarks

Hiding the statusbar may be useful if SAP GUI is displayed inplace, for example in a web page. The property should not be used when displaying SAP GUI as a standalone application.

See Also

GuiApplication Object | GuiApplication Members


TitlebarVisible Property

TitlebarVisible Property
GuiApplication Object : TitlebarVisible Property

Glossary Item Box

Description

Setting this property to FALSE hides the titlebar of the main window.

Property type

Read-write property

Syntax

Visual Basic
Public Property TitlebarVisible As Byte

Remarks

The titlebar is only available when SAP GUI is displayed in New Visual Design.

Hiding the titlebar may be useful if SAP GUI is displayed inplace, for example in a web page. The property should not be used when displaying SAP GUI as a standalone application.

See Also

GuiApplication Object | GuiApplication Members


ToolbarVisible Property

ToolbarVisible Property
GuiApplication Object : ToolbarVisible Property

Glossary Item Box

Description

Setting this property to FALSE hides the system toolbar of the main window.

Property type

Read-write property

Syntax

Visual Basic
Public Property ToolbarVisible As Byte

Return Type

Hiding the system toolbar may be useful if SAP GUI is displayed inplace, for example in a web page. The property should not be used when displaying SAP GUI as a standalone application.

See Also

GuiApplication Object | GuiApplication Members


Type Property

Type Property
GuiApplication Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiApplication Object | GuiApplication Members


TypeAsNumber Property

TypeAsNumber Property
GuiApplication Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiApplication Object | GuiApplication Members


Utils Property

Utils Property
GuiApplication Object : Utils Property

Glossary Item Box

Description

This property returns a global GuiUtils object.

Property type

Read-only property

Syntax

Visual Basic
Public Property Utils As GuiUtils

See Also

GuiApplication Object | GuiApplication Members


CreateSession Event

CreateSession Event
Session
GuiApplication Object : CreateSession Event

Glossary Item Box

Description

This event is raised whenever a new session is created, irrespective of whether of the session being created manually, from ABAP or by a script. The event is only raised for a session if the scripting support has been enabled for the corresponding backend.

Syntax

Visual Basic
Public Event CreateSession( _
   ByVal Session As GuiSession _
)

Parameters

Session

Example

The following script attaches itself to the SAPlogon process and displays a pop-up whenever a new session is created.

Dim objSapGui
Set objSapGui = GetObject("SAPGUI")

Dim objScriptingEngine
Set objScriptingEngine = objSapGui.GetScriptingEngine
WScript.ConnectObject objScriptingEngine, "Engine_"

Dim Waiting
Waiting = 1

Do While (Waiting = 1)
WScript.Sleep(100)
Loop

Set objScriptingEngine = Nothing
Set objSapGui = Nothing

Sub Engine_CreateSession(ByVal Session)
Dim result
result = MsgBox("Session created", vbOKCancel)
If result = vbCancel then
Waiting = 0
End If
End Sub

See Also

GuiApplication Object | GuiApplication Members


DestroySession Event

DestroySession Event
Session
GuiApplication Object : DestroySession Event

Glossary Item Box

Description

This event is raised before a session is destroyed . This can be done either by closing the main window manually, or by calling the closeSession method of GuiConnection.

Syntax

Visual Basic
Public Event DestroySession( _
   ByVal Session As GuiSession _
)

Parameters

Session

Example

You can handle this event from VBScript by adding the following procedure to the sample script on previous page:
Sub Engine_DestroySession(ByVal Session)
Dim result
result = MsgBox("Session destroyed",vbOKCancel)
If result = vbCancel then
Waiting = 0
End If
End Sub

See Also

GuiApplication Object | GuiApplication Members


Error Event

Error Event
ErrorId
Desc1
Desc2
Desc3
Desc4
GuiApplication Object : Error Event

Glossary Item Box

Description

An error event is currently only raised, if the wrapper library required to access a SAP GUI ActiveX control from a script is not available. This event is also available on the GuiSession in which the error occurred.

Syntax

Visual Basic
Public Event Error( _
   ByVal ErrorId As Long, _
   ByVal Desc1 As String, _
   ByVal Desc2 As String, _
   ByVal Desc3 As String, _
   ByVal Desc4 As String _
)

Parameters

ErrorId
Desc1
Desc2
Desc3
Desc4

See Also

GuiApplication Object | GuiApplication Members


IgnoreSession Event

IgnoreSession Event
SessionMainWindowHandle
GuiApplication Object : IgnoreSession Event

Glossary Item Box

Description

The event is fired when a session is set to ‘Ignored’ using IgnoreSession function. This event is only fired when using SAP GUI Scripting while running eCATT in parallel.

Syntax

Visual Basic
Public Event IgnoreSession( _
   ByVal SessionMainWindowHandle As Integer _
)

Parameters

SessionMainWindowHandle

See Also

GuiApplication Object | GuiApplication Members


GuiBarChart Object

GuiBarChart Object
See Also Members

Glossary Item Box

Description

The GuiBarChart is a powerful tool to display and modify time scale diagrams.

The object is of a very technical nature. It should only be used for recording and playback, as most of the parameters can not be determined in any other way. GuiBarChart extends GuiShell.

Object Model

GuiBarChart ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiComponent ObjectGuiComponent Object

Example

See Also

GuiBarChart Members


GuiBarChart Object Members

GuiBarChart Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method BarCount | Returns the number of bars in the given chart.
Public Method DumpState |
Public Method FindAllByName |
Public Method FindAllByNameEx |
Public Method FindById |
Public Method FindByName |
Public Method FindByNameEx |
Public Method GetBarContent | Returns the content of the bar.
Public Method GetGridLineContent | Returns the content of the grid line.
Public Method GridCount | Returns the number of grids within the chart.
Public Method LinkCount | Returns the number of links within the given chart.
Public Method SelectContextMenuItem |
Public Method SelectContextMenuItemByPosition |
Public Method SelectContextMenuItemByText |
Public Method SendData | Send data to the server.
Public Method SetFocus |
Public Method ShowContextMenu |
Public Method Visualize |

Public Properties

Public Property AccDescription |
Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property Changeable |
Public Property ChartCount | Number of charts.
Public Property Children |
Public Property ContainerType |
Public Property CurrentContextMenu |
Public Property DefaultTooltip |
Public Property DragDropSupported |
Public Property Handle |
Public Property Height |
Public Property IconName |
Public Property Id |
Public Property IsSymbolFont |
Public Property Left |
Public Property Modified |
Public Property Name |
Public Property OcxEvents |
Public Property Parent |
Public Property ParentFrame |
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property SubType | This property has the constant value “sapbarc”.
Public Property Text |
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property Width |

See Also

GuiBarChart Object


BarCount Method

BarCount Method
chartId
Index of the chart
GuiBarChart Object : BarCount Method

Glossary Item Box

Description

Returns the number of bars in the given chart.

Syntax

Visual Basic
Public Function BarCount( _
   ByVal chartId As Long _
) As Long

Parameters

chartId
Index of the chart

See Also

GuiBarChart Object | GuiBarChart Members


DumpState Method

DumpState Method
InnerObject
GuiBarChart Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiBarChart Object | GuiBarChart Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiBarChart Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiBarChart Object | GuiBarChart Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiBarChart Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiBarChart Object | GuiBarChart Members


FindById Method

FindById Method
Id
Raise
GuiBarChart Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiBarChart Object | GuiBarChart Members


FindByName Method

FindByName Method
Name
Type
GuiBarChart Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiBarChart Object | GuiBarChart Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiBarChart Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiBarChart Object | GuiBarChart Members


GetBarContent Method

GetBarContent Method
chartId
Index of the chart
barId

Index of the bar within the given chart.

textId
Internal value, do be determined during recording.
GuiBarChart Object : GetBarContent Method

Glossary Item Box

Description

Returns the content of the bar.

Syntax

Visual Basic
Public Function GetBarContent( _
   ByVal chartId As Long, _
   ByVal barId As Long, _
   ByVal textId As Long _
) As String

Parameters

chartId
Index of the chart
barId

Index of the bar within the given chart.

textId
Internal value, do be determined during recording.

See Also

GuiBarChart Object | GuiBarChart Members


GetGridLineContent Method

GetGridLineContent Method
chartId
Index of the chart
gridlineId
Index of the grid line within the given chart.
textId
Internal value, do be determined during recording.
GuiBarChart Object : GetGridLineContent Method

Glossary Item Box

Description

Returns the content of the grid line.

Syntax

Visual Basic
Public Function GetGridLineContent( _
   ByVal chartId As Long, _
   ByVal gridlineId As Long, _
   ByVal textId As Long _
) As String

Parameters

chartId
Index of the chart
gridlineId
Index of the grid line within the given chart.
textId
Internal value, do be determined during recording.

See Also

GuiBarChart Object | GuiBarChart Members


GridCount Method

GridCount Method
chartId
Index of the chart
GuiBarChart Object : GridCount Method

Glossary Item Box

Description

Returns the number of grids within the chart.

Syntax

Visual Basic
Public Function GridCount( _
   ByVal chartId As Long _
) As Long

Parameters

chartId
Index of the chart

See Also

GuiBarChart Object | GuiBarChart Members


LinkCount Method

LinkCount Method
chartId
Index of the chart
GuiBarChart Object : LinkCount Method

Glossary Item Box

Description

Returns the number of links within the given chart.

Syntax

Visual Basic
Public Function LinkCount( _
   ByVal chartId As Long _
) As Long

Parameters

chartId
Index of the chart

See Also

GuiBarChart Object | GuiBarChart Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiBarChart Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiBarChart Object | GuiBarChart Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiBarChart Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiBarChart Object | GuiBarChart Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiBarChart Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

GuiBarChart Object | GuiBarChart Members


SendData Method

SendData Method
Data
Internal data stream. To be determined during recording.
GuiBarChart Object : SendData Method

Glossary Item Box

Description

Send data to the server.

Syntax

Visual Basic
Public Sub SendData( _
   ByVal Data As String _
)

Parameters

Data
Internal data stream. To be determined during recording.

See Also

GuiBarChart Object | GuiBarChart Members


SetFocus Method

SetFocus Method
GuiBarChart Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiBarChart Object | GuiBarChart Members


ShowContextMenu Method

ShowContextMenu Method
GuiBarChart Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiBarChart Object | GuiBarChart Members


Visualize Method

Visualize Method
On
InnerObject
GuiBarChart Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiBarChart Object | GuiBarChart Members


AccDescription Property

AccDescription Property
GuiBarChart Object : AccDescription Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccDescription As String

See Also

GuiBarChart Object | GuiBarChart Members


AccLabelCollection Property

AccLabelCollection Property
GuiBarChart Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiBarChart Object | GuiBarChart Members


AccText Property

AccText Property
GuiBarChart Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiBarChart Object | GuiBarChart Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiBarChart Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiBarChart Object | GuiBarChart Members


AccTooltip Property

AccTooltip Property
GuiBarChart Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiBarChart Object | GuiBarChart Members


Changeable Property

Changeable Property
GuiBarChart Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiBarChart Object | GuiBarChart Members


ChartCount Property

ChartCount Property
GuiBarChart Object : ChartCount Property

Glossary Item Box

Description

Number of charts.

Property type

Read-only property

Syntax

Visual Basic
Public Property ChartCount As Long

See Also

GuiBarChart Object | GuiBarChart Members


Children Property

Children Property
GuiBarChart Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiBarChart Object | GuiBarChart Members


ContainerType Property

ContainerType Property
GuiBarChart Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiBarChart Object | GuiBarChart Members


CurrentContextMenu Property

CurrentContextMenu Property
GuiBarChart Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

GuiBarChart Object | GuiBarChart Members


DefaultTooltip Property

DefaultTooltip Property
GuiBarChart Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiBarChart Object | GuiBarChart Members


DragDropSupported Property

DragDropSupported Property
GuiBarChart Object : DragDropSupported Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DragDropSupported As Byte

See Also

GuiBarChart Object | GuiBarChart Members


Handle Property

Handle Property
GuiBarChart Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiBarChart Object | GuiBarChart Members


Height Property

Height Property
GuiBarChart Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiBarChart Object | GuiBarChart Members


IconName Property

IconName Property
GuiBarChart Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiBarChart Object | GuiBarChart Members


Id Property

Id Property
GuiBarChart Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiBarChart Object | GuiBarChart Members


IsSymbolFont Property

IsSymbolFont Property
GuiBarChart Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiBarChart Object | GuiBarChart Members


Left Property

Left Property
GuiBarChart Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiBarChart Object | GuiBarChart Members


Modified Property

Modified Property
GuiBarChart Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiBarChart Object | GuiBarChart Members


Name Property

Name Property
GuiBarChart Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiBarChart Object | GuiBarChart Members


OcxEvents Property

OcxEvents Property
GuiBarChart Object : OcxEvents Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property OcxEvents As GuiCollection

See Also

GuiBarChart Object | GuiBarChart Members


Parent Property

Parent Property
GuiBarChart Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiBarChart Object | GuiBarChart Members


ParentFrame Property

ParentFrame Property
GuiBarChart Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiBarChart Object | GuiBarChart Members


ScreenLeft Property

ScreenLeft Property
GuiBarChart Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiBarChart Object | GuiBarChart Members


ScreenTop Property

ScreenTop Property
GuiBarChart Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiBarChart Object | GuiBarChart Members


SubType Property

SubType Property
GuiBarChart Object : SubType Property

Glossary Item Box

Description

This property has the constant value “sapbarc”.

Property type

Read-only property

Syntax

Visual Basic
Public Property SubType As String

See Also

GuiBarChart Object | GuiBarChart Members


Text Property

Text Property
GuiBarChart Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiBarChart Object | GuiBarChart Members


Tooltip Property

Tooltip Property
GuiBarChart Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiBarChart Object | GuiBarChart Members


Top Property

Top Property
GuiBarChart Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiBarChart Object | GuiBarChart Members


Type Property

Type Property
GuiBarChart Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiBarChart Object | GuiBarChart Members


TypeAsNumber Property

TypeAsNumber Property
GuiBarChart Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiBarChart Object | GuiBarChart Members


Width Property

Width Property
GuiBarChart Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiBarChart Object | GuiBarChart Members


GuiBox Object

GuiBox Object
See Also Members

Glossary Item Box

Description

A GuiBox is a simple frame with a name. The items inside the frame are not children of the box. GuiBox extends GuiVComponent. The type prefix is box. The name property is the ABAP fieldname.

Object Model

GuiBox ObjectGuiComponentCollection CollectionGuiCollection CollectionGuiComponent ObjectGuiComponent Object

See Also

GuiBox Members


GuiBox Object Members

GuiBox Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property CharHeight
Public Property CharLeft
Public Property CharTop
Public Property CharWidth
Public Property ContainerType
Public Property DefaultTooltip
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiBox Object


DumpState Method

DumpState Method
InnerObject
GuiBox Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiBox Object | GuiBox Members


SetFocus Method

SetFocus Method
GuiBox Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiBox Object | GuiBox Members


ShowContextMenu Method

ShowContextMenu Method
GuiBox Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiBox Object | GuiBox Members


Visualize Method

Visualize Method
On
InnerObject
GuiBox Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiBox Object | GuiBox Members


AccLabelCollection Property

AccLabelCollection Property
GuiBox Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiBox Object | GuiBox Members


AccText Property

AccText Property
GuiBox Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiBox Object | GuiBox Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiBox Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiBox Object | GuiBox Members


AccTooltip Property

AccTooltip Property
GuiBox Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiBox Object | GuiBox Members


Changeable Property

Changeable Property
GuiBox Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiBox Object | GuiBox Members


CharHeight Property

CharHeight Property
GuiBox Object : CharHeight Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharHeight As Long

See Also

GuiBox Object | GuiBox Members


CharLeft Property

CharLeft Property
GuiBox Object : CharLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharLeft As Long

See Also

GuiBox Object | GuiBox Members


CharTop Property

CharTop Property
GuiBox Object : CharTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharTop As Long

See Also

GuiBox Object | GuiBox Members


CharWidth Property

CharWidth Property
GuiBox Object : CharWidth Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharWidth As Long

See Also

GuiBox Object | GuiBox Members


ContainerType Property

ContainerType Property
GuiBox Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiBox Object | GuiBox Members


DefaultTooltip Property

DefaultTooltip Property
GuiBox Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiBox Object | GuiBox Members


Height Property

Height Property
GuiBox Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiBox Object | GuiBox Members


IconName Property

IconName Property
GuiBox Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiBox Object | GuiBox Members


Id Property

Id Property
GuiBox Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiBox Object | GuiBox Members


IsSymbolFont Property

IsSymbolFont Property
GuiBox Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiBox Object | GuiBox Members


Left Property

Left Property
GuiBox Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiBox Object | GuiBox Members


Modified Property

Modified Property
GuiBox Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiBox Object | GuiBox Members


Name Property

Name Property
GuiBox Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiBox Object | GuiBox Members


Parent Property

Parent Property
GuiBox Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiBox Object | GuiBox Members


ParentFrame Property

ParentFrame Property
GuiBox Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiBox Object | GuiBox Members


ScreenLeft Property

ScreenLeft Property
GuiBox Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiBox Object | GuiBox Members


ScreenTop Property

ScreenTop Property
GuiBox Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiBox Object | GuiBox Members


Text Property

Text Property
GuiBox Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiBox Object | GuiBox Members


Tooltip Property

Tooltip Property
GuiBox Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiBox Object | GuiBox Members


Top Property

Top Property
GuiBox Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiBox Object | GuiBox Members


Type Property

Type Property
GuiBox Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiBox Object | GuiBox Members


TypeAsNumber Property

TypeAsNumber Property
GuiBox Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiBox Object | GuiBox Members


Width Property

Width Property
GuiBox Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiBox Object | GuiBox Members


GuiButton Object

GuiButton Object
See Also Members

Glossary Item Box

Description

GuiButton represents all push buttons that are on dynpros, the toolbar or in table controls. GuiButton extends GuiVComponent. The type prefix is btn, the name property is the fieldname taken from the SAP data dictionary There is one exception: for tabstrip buttons, it is the button id set in screen painter that is taken from the SAP data dictionary.

Object Model

GuiButton ObjectGuiComponentCollection CollectionGuiCollection CollectionGuiVComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiVComponent Object

See Also

GuiButton Members


GuiButton Object Members

GuiButton Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method Press

This emulates manually pressing a button. Pressing a button will always cause server communication to occur, rendering all references to elements below the window level invalid. The following code will therefore fail:

Set TextField = session.findById(".../txtF1")
session.findById(".../btnPB5").press
TextField.text = "Hello"

Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property CharHeight
Public Property CharLeft
Public Property CharTop
Public Property CharWidth
Public Property ContainerType
Public Property DefaultTooltip
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property LeftLabel
Public Property Modified
Public Property Name
Public Property Parent
Public Property ParentFrame
Public Property RightLabel
Public Property ScreenLeft
Public Property ScreenTop
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiButton Object


DumpState Method

DumpState Method
InnerObject
GuiButton Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiButton Object | GuiButton Members


Press Method

Press Method
GuiButton Object : Press Method

Glossary Item Box

Description

This emulates manually pressing a button. Pressing a button will always cause server communication to occur, rendering all references to elements below the window level invalid. The following code will therefore fail:

Set TextField = session.findById(".../txtF1")
session.findById(".../btnPB5").press
TextField.text = "Hello"

Syntax

Visual Basic
Public Sub Press()

See Also

GuiButton Object | GuiButton Members


SetFocus Method

SetFocus Method
GuiButton Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiButton Object | GuiButton Members


ShowContextMenu Method

ShowContextMenu Method
GuiButton Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiButton Object | GuiButton Members


Visualize Method

Visualize Method
On
InnerObject
GuiButton Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiButton Object | GuiButton Members


AccLabelCollection Property

AccLabelCollection Property
GuiButton Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiButton Object | GuiButton Members


AccText Property

AccText Property
GuiButton Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiButton Object | GuiButton Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiButton Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiButton Object | GuiButton Members


AccTooltip Property

AccTooltip Property
GuiButton Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiButton Object | GuiButton Members


Changeable Property

Changeable Property
GuiButton Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiButton Object | GuiButton Members


CharHeight Property

CharHeight Property
GuiButton Object : CharHeight Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharHeight As Long

See Also

GuiButton Object | GuiButton Members


CharLeft Property

CharLeft Property
GuiButton Object : CharLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharLeft As Long

See Also

GuiButton Object | GuiButton Members


CharTop Property

CharTop Property
GuiButton Object : CharTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharTop As Long

See Also

GuiButton Object | GuiButton Members


CharWidth Property

CharWidth Property
GuiButton Object : CharWidth Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharWidth As Long

See Also

GuiButton Object | GuiButton Members


ContainerType Property

ContainerType Property
GuiButton Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiButton Object | GuiButton Members


DefaultTooltip Property

DefaultTooltip Property
GuiButton Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiButton Object | GuiButton Members


Height Property

Height Property
GuiButton Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiButton Object | GuiButton Members


IconName Property

IconName Property
GuiButton Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiButton Object | GuiButton Members


Id Property

Id Property
GuiButton Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiButton Object | GuiButton Members


IsSymbolFont Property

IsSymbolFont Property
GuiButton Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiButton Object | GuiButton Members


Left Property

Left Property
GuiButton Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiButton Object | GuiButton Members


LeftLabel Property

LeftLabel Property
GuiButton Object : LeftLabel Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property LeftLabel As GuiVComponent

See Also

GuiButton Object | GuiButton Members


Modified Property

Modified Property
GuiButton Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiButton Object | GuiButton Members


Name Property

Name Property
GuiButton Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiButton Object | GuiButton Members


Parent Property

Parent Property
GuiButton Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiButton Object | GuiButton Members


ParentFrame Property

ParentFrame Property
GuiButton Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiButton Object | GuiButton Members


RightLabel Property

RightLabel Property
GuiButton Object : RightLabel Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property RightLabel As GuiVComponent

See Also

GuiButton Object | GuiButton Members


ScreenLeft Property

ScreenLeft Property
GuiButton Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiButton Object | GuiButton Members


ScreenTop Property

ScreenTop Property
GuiButton Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiButton Object | GuiButton Members


Text Property

Text Property
GuiButton Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiButton Object | GuiButton Members


Tooltip Property

Tooltip Property
GuiButton Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiButton Object | GuiButton Members


Top Property

Top Property
GuiButton Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiButton Object | GuiButton Members


Type Property

Type Property
GuiButton Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiButton Object | GuiButton Members


TypeAsNumber Property

TypeAsNumber Property
GuiButton Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiButton Object | GuiButton Members


Width Property

Width Property
GuiButton Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiButton Object | GuiButton Members


GuiCalendar Object

GuiCalendar Object
See Also Members

Glossary Item Box

Description

The calendar control can be used to select single dates or periods of time. GuiCalendar extends GuiShell.

Object Model

GuiCalendar ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiComponent ObjectGuiComponent Object

Example

See Also

GuiCalendar Members


GuiCalendar Object Members

GuiCalendar Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method ContextMenu | Calling this function opens a context menu.
Public Method CreateDate |
Public Method DumpState |
Public Method FindAllByName |
Public Method FindAllByNameEx |
Public Method FindById |
Public Method FindByName |
Public Method FindByNameEx |
Public Method GetColor |
Public Method GetColorInfo |
Public Method GetDateTooltip |
Public Method GetDay |
Public Method GetMonth |
Public Method GetWeekday |
Public Method GetWeekNumber |
Public Method GetYear |
Public Method IsWeekend |
Public Method SelectContextMenuItem |
Public Method SelectContextMenuItemByPosition |
Public Method SelectContextMenuItemByText |
Public Method SelectMonth |
Public Method SelectRange |
Public Method SelectWeek |
Public Method SetFocus |
Public Method ShowContextMenu |
Public Method Visualize |

Public Properties

Public Property AccDescription |
Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property Changeable |
Public Property Children |
Public Property ContainerType |
Public Property CurrentContextMenu |
Public Property DefaultTooltip |
Public Property DragDropSupported |
Public Property endSelection |
Public Property FirstVisibleDate | This is the earliest date visible in the calendar control. In the example above the value would be “20020228”.
Public Property FocusDate | The currently focussed date (identified by the focus border; see picture above) in the calendar control is available in the format “YYYYMMDD”. In this example it is “20020320”
Public Property Handle |
Public Property Height |
Public Property horizontal |
Public Property IconName |
Public Property Id |
Public Property IsSymbolFont |
Public Property LastVisibleDate |
Public Property Left |
Public Property Modified |
Public Property Name |
Public Property OcxEvents |
Public Property Parent |
Public Property ParentFrame |
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property SelectionInterval | The interval is represented by two concatenated date strings separated by a comma.
Public Property startSelection |
Public Property SubType | This property has the constant value “Calendar”.
Public Property Text |
Public Property Today |
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property Width |

See Also

GuiCalendar Object


ContextMenu Method

ContextMenu Method
CtxMenuId

Indicates the cell type of the cell in which the context menu was opened:

Value | Cell Type | Description
0 | Date | Invocation on a cell with a single date
1 | Weekday | Weekday Invocation on a button for a certain day of the week.
2 | Week | Invocation on a button for a specific week.

CtxMenuCellRow
CtxMenuCellCol
DateBegin
DateEnd
GuiCalendar Object : ContextMenu Method

Glossary Item Box

Description

Calling this function opens a context menu.

Syntax

Visual Basic
Public Sub ContextMenu( _
   ByVal CtxMenuId As Long, _
   ByVal CtxMenuCellRow As Long, _
   ByVal CtxMenuCellCol As Long, _
   ByVal DateBegin As String, _
   ByVal DateEnd As String _
)

Parameters

CtxMenuId

Indicates the cell type of the cell in which the context menu was opened:

Value | Cell Type | Description
0 | Date | Invocation on a cell with a single date
1 | Weekday | Weekday Invocation on a button for a certain day of the week.
2 | Week | Invocation on a button for a specific week.

CtxMenuCellRow
CtxMenuCellCol
DateBegin
DateEnd

See Also

GuiCalendar Object | GuiCalendar Members


CreateDate Method

CreateDate Method
day
month
year
GuiCalendar Object : CreateDate Method

Glossary Item Box

Syntax

Visual Basic
Public Function CreateDate( _
   ByVal day As Long, _
   ByVal month As Long, _
   ByVal year As Long _
) As String

Parameters

day
month
year

See Also

GuiCalendar Object | GuiCalendar Members


DumpState Method

DumpState Method
InnerObject
GuiCalendar Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiCalendar Object | GuiCalendar Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiCalendar Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiCalendar Object | GuiCalendar Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiCalendar Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiCalendar Object | GuiCalendar Members


FindById Method

FindById Method
Id
Raise
GuiCalendar Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiCalendar Object | GuiCalendar Members


FindByName Method

FindByName Method
Name
Type
GuiCalendar Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiCalendar Object | GuiCalendar Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiCalendar Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiCalendar Object | GuiCalendar Members


GetColor Method

GetColor Method
from
GuiCalendar Object : GetColor Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetColor( _
   ByVal from As String _
) As Long

Parameters

from

See Also

GuiCalendar Object | GuiCalendar Members


GetColorInfo Method

GetColorInfo Method
Color
GuiCalendar Object : GetColorInfo Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetColorInfo( _
   ByVal Color As Long _
) As String

Parameters

Color

See Also

GuiCalendar Object | GuiCalendar Members


GetDateTooltip Method

GetDateTooltip Method
date
GuiCalendar Object : GetDateTooltip Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetDateTooltip( _
   ByVal date As String _
) As String

Parameters

date

See Also

GuiCalendar Object | GuiCalendar Members


GetDay Method

GetDay Method
date
GuiCalendar Object : GetDay Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetDay( _
   ByVal date As String _
) As Long

Parameters

date

See Also

GuiCalendar Object | GuiCalendar Members


GetMonth Method

GetMonth Method
date
GuiCalendar Object : GetMonth Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetMonth( _
   ByVal date As String _
) As Long

Parameters

date

See Also

GuiCalendar Object | GuiCalendar Members


GetWeekday Method

GetWeekday Method
date
GuiCalendar Object : GetWeekday Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetWeekday( _
   ByVal date As String _
) As String

Parameters

date

See Also

GuiCalendar Object | GuiCalendar Members


GetWeekNumber Method

GetWeekNumber Method
date
GuiCalendar Object : GetWeekNumber Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetWeekNumber( _
   ByVal date As String _
) As Long

Parameters

date

See Also

GuiCalendar Object | GuiCalendar Members


GetYear Method

GetYear Method
date
GuiCalendar Object : GetYear Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetYear( _
   ByVal date As String _
) As Long

Parameters

date

See Also

GuiCalendar Object | GuiCalendar Members


IsWeekend Method

IsWeekend Method
date
GuiCalendar Object : IsWeekend Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsWeekend( _
   ByVal date As String _
) As Long

Parameters

date

See Also

GuiCalendar Object | GuiCalendar Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiCalendar Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiCalendar Object | GuiCalendar Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiCalendar Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiCalendar Object | GuiCalendar Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiCalendar Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

GuiCalendar Object | GuiCalendar Members


SelectMonth Method

SelectMonth Method
month
year
GuiCalendar Object : SelectMonth Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectMonth( _
   ByVal month As Long, _
   ByVal year As Long _
)

Parameters

month
year

See Also

GuiCalendar Object | GuiCalendar Members


SelectRange Method

SelectRange Method
from
to
GuiCalendar Object : SelectRange Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectRange( _
   ByVal from As String, _
   ByVal to As String _
)

Parameters

from
to

See Also

GuiCalendar Object | GuiCalendar Members


SelectWeek Method

SelectWeek Method
week
year
GuiCalendar Object : SelectWeek Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectWeek( _
   ByVal week As Long, _
   ByVal year As Long _
)

Parameters

week
year

See Also

GuiCalendar Object | GuiCalendar Members


SetFocus Method

SetFocus Method
GuiCalendar Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiCalendar Object | GuiCalendar Members


ShowContextMenu Method

ShowContextMenu Method
GuiCalendar Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiCalendar Object | GuiCalendar Members


Visualize Method

Visualize Method
On
InnerObject
GuiCalendar Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiCalendar Object | GuiCalendar Members


AccDescription Property

AccDescription Property
GuiCalendar Object : AccDescription Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccDescription As String

See Also

GuiCalendar Object | GuiCalendar Members


AccLabelCollection Property

AccLabelCollection Property
GuiCalendar Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiCalendar Object | GuiCalendar Members


AccText Property

AccText Property
GuiCalendar Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiCalendar Object | GuiCalendar Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiCalendar Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiCalendar Object | GuiCalendar Members


AccTooltip Property

AccTooltip Property
GuiCalendar Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiCalendar Object | GuiCalendar Members


Changeable Property

Changeable Property
GuiCalendar Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiCalendar Object | GuiCalendar Members


Children Property

Children Property
GuiCalendar Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiCalendar Object | GuiCalendar Members


ContainerType Property

ContainerType Property
GuiCalendar Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiCalendar Object | GuiCalendar Members


CurrentContextMenu Property

CurrentContextMenu Property
GuiCalendar Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

GuiCalendar Object | GuiCalendar Members


DefaultTooltip Property

DefaultTooltip Property
GuiCalendar Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiCalendar Object | GuiCalendar Members


DragDropSupported Property

DragDropSupported Property
GuiCalendar Object : DragDropSupported Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DragDropSupported As Byte

See Also

GuiCalendar Object | GuiCalendar Members


endSelection Property

endSelection Property
GuiCalendar Object : endSelection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property endSelection As String

See Also

GuiCalendar Object | GuiCalendar Members


FirstVisibleDate Property

FirstVisibleDate Property
GuiCalendar Object : FirstVisibleDate Property

Glossary Item Box

Description

This is the earliest date visible in the calendar control. In the example above the value would be “20020228”.

Property type

Read-write property

Syntax

Visual Basic
Public Property FirstVisibleDate As String

See Also

GuiCalendar Object | GuiCalendar Members


FocusDate Property

FocusDate Property
GuiCalendar Object : FocusDate Property

Glossary Item Box

Description

The currently focussed date (identified by the focus border; see picture above) in the calendar control is available in the format “YYYYMMDD”. In this example it is “20020320”

Property type

Read-write property

Syntax

Visual Basic
Public Property FocusDate As String

See Also

GuiCalendar Object | GuiCalendar Members


Handle Property

Handle Property
GuiCalendar Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiCalendar Object | GuiCalendar Members


Height Property

Height Property
GuiCalendar Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiCalendar Object | GuiCalendar Members


horizontal Property

horizontal Property
GuiCalendar Object : horizontal Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property horizontal As Long

See Also

GuiCalendar Object | GuiCalendar Members


IconName Property

IconName Property
GuiCalendar Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiCalendar Object | GuiCalendar Members


Id Property

Id Property
GuiCalendar Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiCalendar Object | GuiCalendar Members


IsSymbolFont Property

IsSymbolFont Property
GuiCalendar Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiCalendar Object | GuiCalendar Members


LastVisibleDate Property

LastVisibleDate Property
GuiCalendar Object : LastVisibleDate Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property LastVisibleDate As String

See Also

GuiCalendar Object | GuiCalendar Members


Left Property

Left Property
GuiCalendar Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiCalendar Object | GuiCalendar Members


Modified Property

Modified Property
GuiCalendar Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiCalendar Object | GuiCalendar Members


Name Property

Name Property
GuiCalendar Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiCalendar Object | GuiCalendar Members


OcxEvents Property

OcxEvents Property
GuiCalendar Object : OcxEvents Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property OcxEvents As GuiCollection

See Also

GuiCalendar Object | GuiCalendar Members


Parent Property

Parent Property
GuiCalendar Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiCalendar Object | GuiCalendar Members


ParentFrame Property

ParentFrame Property
GuiCalendar Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiCalendar Object | GuiCalendar Members


ScreenLeft Property

ScreenLeft Property
GuiCalendar Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiCalendar Object | GuiCalendar Members


ScreenTop Property

ScreenTop Property
GuiCalendar Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiCalendar Object | GuiCalendar Members


SelectionInterval Property

SelectionInterval Property
GuiCalendar Object : SelectionInterval Property

Glossary Item Box

Description

The interval is represented by two concatenated date strings separated by a comma.

Property type

Read-write property

Syntax

Visual Basic
Public Property SelectionInterval As String

Example

Depending on the order in which the user has selected the dates, the value of selectionInterval is either “20020318,20020322” or ““20020322,20020318”.

See Also

GuiCalendar Object | GuiCalendar Members


startSelection Property

startSelection Property
GuiCalendar Object : startSelection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property startSelection As String

See Also

GuiCalendar Object | GuiCalendar Members


SubType Property

SubType Property
GuiCalendar Object : SubType Property

Glossary Item Box

Description

This property has the constant value “Calendar”.

Property type

Read-only property

Syntax

Visual Basic
Public Property SubType As String

See Also

GuiCalendar Object | GuiCalendar Members


Text Property

Text Property
GuiCalendar Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiCalendar Object | GuiCalendar Members


Today Property

Today Property
GuiCalendar Object : Today Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Today As String

See Also

GuiCalendar Object | GuiCalendar Members


Tooltip Property

Tooltip Property
GuiCalendar Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiCalendar Object | GuiCalendar Members


Top Property

Top Property
GuiCalendar Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiCalendar Object | GuiCalendar Members


Type Property

Type Property
GuiCalendar Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiCalendar Object | GuiCalendar Members


TypeAsNumber Property

TypeAsNumber Property
GuiCalendar Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiCalendar Object | GuiCalendar Members


Width Property

Width Property
GuiCalendar Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiCalendar Object | GuiCalendar Members


GuiChart Object

GuiChart Object
See Also Members

Glossary Item Box

Description

The GuiChart object is of a very technical nature. It should only be used for recording and playback, as most of the parameters can not be determined in any other way.

Object Model

GuiChart ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiComponent ObjectGuiComponent Object

Example

See Also

GuiChart Members


GuiChart Object Members

GuiChart Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method SelectContextMenuItem
Public Method SelectContextMenuItemByPosition
Public Method SelectContextMenuItemByText
Public Method SetFocus
Public Method ShowContextMenu
Public Method ValueChange
Public Method Visualize

Public Properties

Public Property AccDescription |
Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property Changeable |
Public Property Children |
Public Property ContainerType |
Public Property CurrentContextMenu |
Public Property DefaultTooltip |
Public Property DragDropSupported |
Public Property Handle |
Public Property Height |
Public Property IconName |
Public Property Id |
Public Property IsSymbolFont |
Public Property Left |
Public Property Modified |
Public Property Name |
Public Property OcxEvents |
Public Property Parent |
Public Property ParentFrame |
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property SubType | This property has the constant value “Chart”.
Public Property Text |
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property Width |

See Also

GuiChart Object


DumpState Method

DumpState Method
InnerObject
GuiChart Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiChart Object | GuiChart Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiChart Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiChart Object | GuiChart Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiChart Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiChart Object | GuiChart Members


FindById Method

FindById Method
Id
Raise
GuiChart Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiChart Object | GuiChart Members


FindByName Method

FindByName Method
Name
Type
GuiChart Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiChart Object | GuiChart Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiChart Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiChart Object | GuiChart Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiChart Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiChart Object | GuiChart Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiChart Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiChart Object | GuiChart Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiChart Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

GuiChart Object | GuiChart Members


SetFocus Method

SetFocus Method
GuiChart Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiChart Object | GuiChart Members


ShowContextMenu Method

ShowContextMenu Method
GuiChart Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiChart Object | GuiChart Members


ValueChange Method

ValueChange Method
Series
Number of the data set within the row that should be changed.
Point
Number of the data point within the row that should be changed.
XValue
New x value.
YValue
New y value.
DataChange

Setting this parameter to True means the value was not changed interactively within the graphic but rather by entering the new value on the DataPoint property page.

Id
GFW data container id of the changed point. May be used instead of the pair series/point.
ZValue
New z value.
ChangeFlag

Notify which value was changed or if it was a time value. The value is set as a bit array, using the lower 5 bits.

1 | x
2 | y
4 | x is time value
8 | y is time value
16 | z

If the new value is a point in time, it should be set using a string of the format â€œmm/dd/yyyy hh:mm:ssâ€.

GuiChart Object : ValueChange Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ValueChange( _
   ByVal Series As Long, _
   ByVal Point As Long, _
   ByVal XValue As String, _
   ByVal YValue As String, _
   ByVal DataChange As Byte, _
   ByVal Id As String, _
   ByVal ZValue As String, _
   ByVal ChangeFlag As Long _
)

Parameters

Series
Number of the data set within the row that should be changed.
Point
Number of the data point within the row that should be changed.
XValue
New x value.
YValue
New y value.
DataChange

Setting this parameter to True means the value was not changed interactively within the graphic but rather by entering the new value on the DataPoint property page.

Id
GFW data container id of the changed point. May be used instead of the pair series/point.
ZValue
New z value.
ChangeFlag

Notify which value was changed or if it was a time value. The value is set as a bit array, using the lower 5 bits.

1 | x
2 | y
4 | x is time value
8 | y is time value
16 | z

If the new value is a point in time, it should be set using a string of the format â€œmm/dd/yyyy hh:mm:ssâ€.

See Also

GuiChart Object | GuiChart Members


Visualize Method

Visualize Method
On
InnerObject
GuiChart Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiChart Object | GuiChart Members


AccDescription Property

AccDescription Property
GuiChart Object : AccDescription Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccDescription As String

See Also

GuiChart Object | GuiChart Members


AccLabelCollection Property

AccLabelCollection Property
GuiChart Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiChart Object | GuiChart Members


AccText Property

AccText Property
GuiChart Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiChart Object | GuiChart Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiChart Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiChart Object | GuiChart Members


AccTooltip Property

AccTooltip Property
GuiChart Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiChart Object | GuiChart Members


Changeable Property

Changeable Property
GuiChart Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiChart Object | GuiChart Members


Children Property

Children Property
GuiChart Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiChart Object | GuiChart Members


ContainerType Property

ContainerType Property
GuiChart Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiChart Object | GuiChart Members


CurrentContextMenu Property

CurrentContextMenu Property
GuiChart Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

GuiChart Object | GuiChart Members


DefaultTooltip Property

DefaultTooltip Property
GuiChart Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiChart Object | GuiChart Members


DragDropSupported Property

DragDropSupported Property
GuiChart Object : DragDropSupported Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DragDropSupported As Byte

See Also

GuiChart Object | GuiChart Members


Handle Property

Handle Property
GuiChart Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiChart Object | GuiChart Members


Height Property

Height Property
GuiChart Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiChart Object | GuiChart Members


IconName Property

IconName Property
GuiChart Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiChart Object | GuiChart Members


Id Property

Id Property
GuiChart Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiChart Object | GuiChart Members


IsSymbolFont Property

IsSymbolFont Property
GuiChart Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiChart Object | GuiChart Members


Left Property

Left Property
GuiChart Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiChart Object | GuiChart Members


Modified Property

Modified Property
GuiChart Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiChart Object | GuiChart Members


Name Property

Name Property
GuiChart Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiChart Object | GuiChart Members


OcxEvents Property

OcxEvents Property
GuiChart Object : OcxEvents Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property OcxEvents As GuiCollection

See Also

GuiChart Object | GuiChart Members


Parent Property

Parent Property
GuiChart Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiChart Object | GuiChart Members


ParentFrame Property

ParentFrame Property
GuiChart Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiChart Object | GuiChart Members


ScreenLeft Property

ScreenLeft Property
GuiChart Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiChart Object | GuiChart Members


ScreenTop Property

ScreenTop Property
GuiChart Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiChart Object | GuiChart Members


SubType Property

SubType Property
GuiChart Object : SubType Property

Glossary Item Box

Description

This property has the constant value “Chart”.

Property type

Read-only property

Syntax

Visual Basic
Public Property SubType As String

See Also

GuiChart Object | GuiChart Members


Text Property

Text Property
GuiChart Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiChart Object | GuiChart Members


Tooltip Property

Tooltip Property
GuiChart Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiChart Object | GuiChart Members


Top Property

Top Property
GuiChart Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiChart Object | GuiChart Members


Type Property

Type Property
GuiChart Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiChart Object | GuiChart Members


TypeAsNumber Property

TypeAsNumber Property
GuiChart Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiChart Object | GuiChart Members


Width Property

Width Property
GuiChart Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiChart Object | GuiChart Members


GuiCheckBox Object

GuiCheckBox Object
See Also Members

Glossary Item Box

Description

GuiCheckBox extends GuiVComponent. The type prefix is chk, the name is the fieldname taken from the SAP data dictionary.

Object Model

GuiCheckBox ObjectGuiComponentCollection CollectionGuiCollection CollectionGuiVComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiVComponent Object

See Also

GuiCheckBox Members


GuiCheckBox Object Members

GuiCheckBox Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method GetListProperty
Public Method GetListPropertyNonRec
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property Changeable |
Public Property CharHeight |
Public Property CharLeft |
Public Property CharTop |
Public Property CharWidth |
Public Property ColorIndex |
Public Property ColorIntensified |
Public Property ColorInverse |
Public Property ContainerType |
Public Property DefaultTooltip |
Public Property Flushing |
Public Property Height |
Public Property IconName |
Public Property Id |
Public Property IsLeftLabel |
Public Property IsListElement |
Public Property IsRightLabel |
Public Property IsSymbolFont |
Public Property Left |
Public Property LeftLabel |
Public Property Modified |
Public Property Name |
Public Property Parent |
Public Property ParentFrame |
Public Property RightLabel |
Public Property RowText |
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property Selected | Like radio buttons, checking a checkbox can cause server communication, depending on the ABAP screen painter definition.
Public Property Text |
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property Width |

See Also

GuiCheckBox Object


DumpState Method

DumpState Method
InnerObject
GuiCheckBox Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiCheckBox Object | GuiCheckBox Members


GetListProperty Method

GetListProperty Method
Property
GuiCheckBox Object : GetListProperty Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetListProperty( _
   ByVal Property As String _
) As String

Parameters

Property

See Also

GuiCheckBox Object | GuiCheckBox Members


GetListPropertyNonRec Method

GetListPropertyNonRec Method
Property
GuiCheckBox Object : GetListPropertyNonRec Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetListPropertyNonRec( _
   ByVal Property As String _
) As String

Parameters

Property

See Also

GuiCheckBox Object | GuiCheckBox Members


SetFocus Method

SetFocus Method
GuiCheckBox Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiCheckBox Object | GuiCheckBox Members


ShowContextMenu Method

ShowContextMenu Method
GuiCheckBox Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiCheckBox Object | GuiCheckBox Members


Visualize Method

Visualize Method
On
InnerObject
GuiCheckBox Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiCheckBox Object | GuiCheckBox Members


AccLabelCollection Property

AccLabelCollection Property
GuiCheckBox Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiCheckBox Object | GuiCheckBox Members


AccText Property

AccText Property
GuiCheckBox Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiCheckBox Object | GuiCheckBox Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiCheckBox Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiCheckBox Object | GuiCheckBox Members


AccTooltip Property

AccTooltip Property
GuiCheckBox Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiCheckBox Object | GuiCheckBox Members


Changeable Property

Changeable Property
GuiCheckBox Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiCheckBox Object | GuiCheckBox Members


CharHeight Property

CharHeight Property
GuiCheckBox Object : CharHeight Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharHeight As Long

See Also

GuiCheckBox Object | GuiCheckBox Members


CharLeft Property

CharLeft Property
GuiCheckBox Object : CharLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharLeft As Long

See Also

GuiCheckBox Object | GuiCheckBox Members


CharTop Property

CharTop Property
GuiCheckBox Object : CharTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharTop As Long

See Also

GuiCheckBox Object | GuiCheckBox Members


CharWidth Property

CharWidth Property
GuiCheckBox Object : CharWidth Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharWidth As Long

See Also

GuiCheckBox Object | GuiCheckBox Members


ColorIndex Property

ColorIndex Property
GuiCheckBox Object : ColorIndex Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ColorIndex As Long

See Also

GuiCheckBox Object | GuiCheckBox Members


ColorIntensified Property

ColorIntensified Property
GuiCheckBox Object : ColorIntensified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ColorIntensified As Byte

See Also

GuiCheckBox Object | GuiCheckBox Members


ColorInverse Property

ColorInverse Property
GuiCheckBox Object : ColorInverse Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ColorInverse As Byte

See Also

GuiCheckBox Object | GuiCheckBox Members


ContainerType Property

ContainerType Property
GuiCheckBox Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiCheckBox Object | GuiCheckBox Members


DefaultTooltip Property

DefaultTooltip Property
GuiCheckBox Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiCheckBox Object | GuiCheckBox Members


Flushing Property

Flushing Property
GuiCheckBox Object : Flushing Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Flushing As Byte

See Also

GuiCheckBox Object | GuiCheckBox Members


Height Property

Height Property
GuiCheckBox Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiCheckBox Object | GuiCheckBox Members


IconName Property

IconName Property
GuiCheckBox Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiCheckBox Object | GuiCheckBox Members


Id Property

Id Property
GuiCheckBox Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiCheckBox Object | GuiCheckBox Members


IsLeftLabel Property

IsLeftLabel Property
GuiCheckBox Object : IsLeftLabel Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsLeftLabel As Byte

See Also

GuiCheckBox Object | GuiCheckBox Members


IsListElement Property

IsListElement Property
GuiCheckBox Object : IsListElement Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsListElement As Byte

See Also

GuiCheckBox Object | GuiCheckBox Members


IsRightLabel Property

IsRightLabel Property
GuiCheckBox Object : IsRightLabel Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsRightLabel As Byte

See Also

GuiCheckBox Object | GuiCheckBox Members


IsSymbolFont Property

IsSymbolFont Property
GuiCheckBox Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiCheckBox Object | GuiCheckBox Members


Left Property

Left Property
GuiCheckBox Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiCheckBox Object | GuiCheckBox Members


LeftLabel Property

LeftLabel Property
GuiCheckBox Object : LeftLabel Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property LeftLabel As GuiVComponent

See Also

GuiCheckBox Object | GuiCheckBox Members


Modified Property

Modified Property
GuiCheckBox Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiCheckBox Object | GuiCheckBox Members


Name Property

Name Property
GuiCheckBox Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiCheckBox Object | GuiCheckBox Members


Parent Property

Parent Property
GuiCheckBox Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiCheckBox Object | GuiCheckBox Members


ParentFrame Property

ParentFrame Property
GuiCheckBox Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiCheckBox Object | GuiCheckBox Members


RightLabel Property

RightLabel Property
GuiCheckBox Object : RightLabel Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property RightLabel As GuiVComponent

See Also

GuiCheckBox Object | GuiCheckBox Members


RowText Property

RowText Property
GuiCheckBox Object : RowText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property RowText As String

See Also

GuiCheckBox Object | GuiCheckBox Members


ScreenLeft Property

ScreenLeft Property
GuiCheckBox Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiCheckBox Object | GuiCheckBox Members


ScreenTop Property

ScreenTop Property
GuiCheckBox Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiCheckBox Object | GuiCheckBox Members


Selected Property

Selected Property
GuiCheckBox Object : Selected Property

Glossary Item Box

Description

Like radio buttons, checking a checkbox can cause server communication, depending on the ABAP screen painter definition.

Property type

Read-write property

Syntax

Visual Basic
Public Property Selected As Byte

See Also

GuiCheckBox Object | GuiCheckBox Members


Text Property

Text Property
GuiCheckBox Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiCheckBox Object | GuiCheckBox Members


Tooltip Property

Tooltip Property
GuiCheckBox Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiCheckBox Object | GuiCheckBox Members


Top Property

Top Property
GuiCheckBox Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiCheckBox Object | GuiCheckBox Members


Type Property

Type Property
GuiCheckBox Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiCheckBox Object | GuiCheckBox Members


TypeAsNumber Property

TypeAsNumber Property
GuiCheckBox Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiCheckBox Object | GuiCheckBox Members


Width Property

Width Property
GuiCheckBox Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiCheckBox Object | GuiCheckBox Members


GuiCollection Collection

GuiCollection Collection
See Also Members

Glossary Item Box

Description

GuiCollection is similar to GuiComponentCollection, but its members are not necessarily extensions of GuiComponent. It can be used to pass a collection as a parameter to functions of scriptable objects. An object of this class is created by calling the CreateGuiCollection function of the GuiApplication.

Object Model

GuiCollection Collection

See Also

GuiCollection Members


GuiCollection Collection Members

GuiCollection Collection Members
See Also Overview

Glossary Item Box

Public Methods

Public Method Add | After a GuiCollection has been created, items can be added by calling the add function.
Public Method ElementAt | This function returns the member in the collection at position index, where index may range from 0 to count-1. If no member can be found for the given index, an exception is raised.
Public Method Item | This function returns the member in the collection at position index, where index may range from 0 to count-1. It has been added for compatibility with Microsoft Visual Basic collections. If no member can be found for the given index, an exception is raised.

Public Properties

Public Property Count | The number of elements in the collection. This property has been added for compatibility with Microsoft Visual Basic collections.
Public Property Length | The number of elements in the collection.
Public Property NewEnum | It has been added for compatibility with Microsoft Visual Basic collections.
Public Property Type | The value is ‘GuiCollection’.
Public Property TypeAsNumber | The value is 120.

See Also

GuiCollection Collection


Add Method

Add Method
Item
GuiCollection Collection : Add Method

Glossary Item Box

Description

After a GuiCollection has been created, items can be added by calling the add function.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Item As Variant _
)

Parameters

Item

See Also

GuiCollection Collection | GuiCollection Members


ElementAt Method

ElementAt Method
Index
GuiCollection Collection : ElementAt Method

Glossary Item Box

Description

This function returns the member in the collection at position index, where index may range from 0 to count-1. If no member can be found for the given index, an exception is raised.

Syntax

Visual Basic
Public Function ElementAt( _
   ByVal Index As Long _
) As Variant

Parameters

Index

See Also

GuiCollection Collection | GuiCollection Members


Item Method

Item Method
Index
GuiCollection Collection : Item Method

Glossary Item Box

Description

This function returns the member in the collection at position index, where index may range from 0 to count-1. It has been added for compatibility with Microsoft Visual Basic collections. If no member can be found for the given index, an exception is raised.

Syntax

Visual Basic
Public Function Item( _
   ByVal Index As Variant _
) As Variant

Parameters

Index

See Also

GuiCollection Collection | GuiCollection Members


Count Property

Count Property
GuiCollection Collection : Count Property

Glossary Item Box

Description

The number of elements in the collection. This property has been added for compatibility with Microsoft Visual Basic collections.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

GuiCollection Collection | GuiCollection Members


Length Property

Length Property
GuiCollection Collection : Length Property

Glossary Item Box

Description

The number of elements in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Length As Long

See Also

GuiCollection Collection | GuiCollection Members


NewEnum Property

NewEnum Property
GuiCollection Collection : NewEnum Property

Glossary Item Box

Description

It has been added for compatibility with Microsoft Visual Basic collections.

Property type

Read-only property

Syntax

Visual Basic
Public Property NewEnum As Unknown

See Also

GuiCollection Collection | GuiCollection Members


Type Property

Type Property
GuiCollection Collection : Type Property

Glossary Item Box

Description

The value is ‘GuiCollection’.

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiCollection Collection | GuiCollection Members


TypeAsNumber Property

TypeAsNumber Property
GuiCollection Collection : TypeAsNumber Property

Glossary Item Box

Description

The value is 120.

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiCollection Collection | GuiCollection Members


GuiColorSelector Object

GuiColorSelector Object
See Also Members

Glossary Item Box

Description

GuiColorSelector displays a set of colors for selection. It extends GuiShell.

Object Model

GuiColorSelector ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiComponent ObjectGuiComponent Object

Example

See Also

GuiColorSelector Members


GuiColorSelector Object Members

GuiColorSelector Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method ChangeSelection | This function emulates the user’s selection of the color at the given index position.
Public Method DumpState |
Public Method FindAllByName |
Public Method FindAllByNameEx |
Public Method FindById |
Public Method FindByName |
Public Method FindByNameEx |
Public Method SelectContextMenuItem |
Public Method SelectContextMenuItemByPosition |
Public Method SelectContextMenuItemByText |
Public Method SetFocus |
Public Method ShowContextMenu |
Public Method Visualize |

Public Properties

Public Property AccDescription |
Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property Changeable |
Public Property Children |
Public Property ContainerType |
Public Property CurrentContextMenu |
Public Property DefaultTooltip |
Public Property DragDropSupported |
Public Property Handle |
Public Property Height |
Public Property IconName |
Public Property Id |
Public Property IsSymbolFont |
Public Property Left |
Public Property Modified |
Public Property Name |
Public Property OcxEvents |
Public Property Parent |
Public Property ParentFrame |
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property SubType | This property has the constant value “ColorSelector”
Public Property Text |
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property Width |

See Also

GuiColorSelector Object


ChangeSelection Method

ChangeSelection Method
i
GuiColorSelector Object : ChangeSelection Method

Glossary Item Box

Description

This function emulates the user’s selection of the color at the given index position.

Syntax

Visual Basic
Public Sub ChangeSelection( _
   ByVal i As Integer _
)

Parameters

i

See Also

GuiColorSelector Object | GuiColorSelector Members


DumpState Method

DumpState Method
InnerObject
GuiColorSelector Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiColorSelector Object | GuiColorSelector Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiColorSelector Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiColorSelector Object | GuiColorSelector Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiColorSelector Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiColorSelector Object | GuiColorSelector Members


FindById Method

FindById Method
Id
Raise
GuiColorSelector Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiColorSelector Object | GuiColorSelector Members


FindByName Method

FindByName Method
Name
Type
GuiColorSelector Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiColorSelector Object | GuiColorSelector Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiColorSelector Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiColorSelector Object | GuiColorSelector Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiColorSelector Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiColorSelector Object | GuiColorSelector Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiColorSelector Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiColorSelector Object | GuiColorSelector Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiColorSelector Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

GuiColorSelector Object | GuiColorSelector Members


SetFocus Method

SetFocus Method
GuiColorSelector Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiColorSelector Object | GuiColorSelector Members


ShowContextMenu Method

ShowContextMenu Method
GuiColorSelector Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiColorSelector Object | GuiColorSelector Members


Visualize Method

Visualize Method
On
InnerObject
GuiColorSelector Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiColorSelector Object | GuiColorSelector Members


AccDescription Property

AccDescription Property
GuiColorSelector Object : AccDescription Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccDescription As String

See Also

GuiColorSelector Object | GuiColorSelector Members


AccLabelCollection Property

AccLabelCollection Property
GuiColorSelector Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiColorSelector Object | GuiColorSelector Members


AccText Property

AccText Property
GuiColorSelector Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiColorSelector Object | GuiColorSelector Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiColorSelector Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiColorSelector Object | GuiColorSelector Members


AccTooltip Property

AccTooltip Property
GuiColorSelector Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiColorSelector Object | GuiColorSelector Members


Changeable Property

Changeable Property
GuiColorSelector Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiColorSelector Object | GuiColorSelector Members


Children Property

Children Property
GuiColorSelector Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiColorSelector Object | GuiColorSelector Members


ContainerType Property

ContainerType Property
GuiColorSelector Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiColorSelector Object | GuiColorSelector Members


CurrentContextMenu Property

CurrentContextMenu Property
GuiColorSelector Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

GuiColorSelector Object | GuiColorSelector Members


DefaultTooltip Property

DefaultTooltip Property
GuiColorSelector Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiColorSelector Object | GuiColorSelector Members


DragDropSupported Property

DragDropSupported Property
GuiColorSelector Object : DragDropSupported Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DragDropSupported As Byte

See Also

GuiColorSelector Object | GuiColorSelector Members


Handle Property

Handle Property
GuiColorSelector Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiColorSelector Object | GuiColorSelector Members


Height Property

Height Property
GuiColorSelector Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiColorSelector Object | GuiColorSelector Members


IconName Property

IconName Property
GuiColorSelector Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiColorSelector Object | GuiColorSelector Members


Id Property

Id Property
GuiColorSelector Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiColorSelector Object | GuiColorSelector Members


IsSymbolFont Property

IsSymbolFont Property
GuiColorSelector Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiColorSelector Object | GuiColorSelector Members


Left Property

Left Property
GuiColorSelector Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiColorSelector Object | GuiColorSelector Members


Modified Property

Modified Property
GuiColorSelector Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiColorSelector Object | GuiColorSelector Members


Name Property

Name Property
GuiColorSelector Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiColorSelector Object | GuiColorSelector Members


OcxEvents Property

OcxEvents Property
GuiColorSelector Object : OcxEvents Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property OcxEvents As GuiCollection

See Also

GuiColorSelector Object | GuiColorSelector Members


Parent Property

Parent Property
GuiColorSelector Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiColorSelector Object | GuiColorSelector Members


ParentFrame Property

ParentFrame Property
GuiColorSelector Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiColorSelector Object | GuiColorSelector Members


ScreenLeft Property

ScreenLeft Property
GuiColorSelector Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiColorSelector Object | GuiColorSelector Members


ScreenTop Property

ScreenTop Property
GuiColorSelector Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiColorSelector Object | GuiColorSelector Members


SubType Property

SubType Property
GuiColorSelector Object : SubType Property

Glossary Item Box

Description

This property has the constant value “ColorSelector”

Property type

Read-only property

Syntax

Visual Basic
Public Property SubType As String

See Also

GuiColorSelector Object | GuiColorSelector Members


Text Property

Text Property
GuiColorSelector Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiColorSelector Object | GuiColorSelector Members


Tooltip Property

Tooltip Property
GuiColorSelector Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiColorSelector Object | GuiColorSelector Members


Top Property

Top Property
GuiColorSelector Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiColorSelector Object | GuiColorSelector Members


Type Property

Type Property
GuiColorSelector Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiColorSelector Object | GuiColorSelector Members


TypeAsNumber Property

TypeAsNumber Property
GuiColorSelector Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiColorSelector Object | GuiColorSelector Members


Width Property

Width Property
GuiColorSelector Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiColorSelector Object | GuiColorSelector Members


GuiComboBox Object

GuiComboBox Object
See Also Members

Glossary Item Box

Description

The GuiComboBox looks somewhat similar to GuiCTextField, but has a completely different implementation. While pressing the combo box button of a GuiCTextField will open a new dynpro or control in which a selection can be made, GuiComboBox retrieves all possible choices on initialization from the server, so the selection is done solely on the client. GuiComboBox extends GuiVComponent. The type prefix is cmb, the name is the fieldname taken from the SAP data dictionary.

Object Model

GuiComboBox ObjectGuiComponentCollection CollectionGuiComboBoxEntry ObjectGuiCollection CollectionGuiCollection CollectionGuiVComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiVComponent Object

Remarks

A combo box can be configured to send a function code to the server when the selection changes, which will invalidate references to all visible elements below the window level.

See Also

GuiComboBox Members


GuiComboBox Object Members

GuiComboBox Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState |
Public Method SetFocus |
Public Method SetKeySpace | This function sets the key property of the combo box to the space character. It was introduced for eCATT.
Public Method ShowContextMenu |
Public Method Visualize |

Public Properties

Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property Changeable |
Public Property CharHeight |
Public Property CharLeft |
Public Property CharTop |
Public Property CharWidth |
Public Property ContainerType |
Public Property CurListBoxEntry | The currently focussed entry of the dropdown list.
Public Property DefaultTooltip |
Public Property Entries | All members of this collection are of GuiComboBoxEntry type and have just two properties, key and value, both of type String. The key data can be displayed in SAP GUI by setting the ‘Show keys…’ check box on the option dialog’s expert page.
Public Property Flushing |
Public Property Height |
Public Property Highlighted |
Public Property IconName |
Public Property Id |
Public Property IsLeftLabel |
Public Property IsListBoxActive | This property is True if the list box of the the combo box is currently open.
Public Property IsRightLabel |
Public Property IsSymbolFont |
Public Property Key | This is the key of the currently selected item. You can change this item by setting the key property to a new value.
Public Property Left |
Public Property LeftLabel | This label has been defined in ABAP Screen Painter to be the left label of the control.
Public Property Modified |
Public Property Name |
Public Property Parent |
Public Property ParentFrame |
Public Property Required | If the required flag is set for a combo box then the empty entry is not selectable from the list.
Public Property RightLabel | This label has been defined in ABAP Screen Painter to be the right label of the control.
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property ShowKey |
Public Property Text |
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property Value | This is the value of the currently selected item. You can change this item by setting the value property to a new value.
Public Property Width |

See Also

GuiComboBox Object


DumpState Method

DumpState Method
InnerObject
GuiComboBox Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiComboBox Object | GuiComboBox Members


SetFocus Method

SetFocus Method
GuiComboBox Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiComboBox Object | GuiComboBox Members


SetKeySpace Method

SetKeySpace Method
GuiComboBox Object : SetKeySpace Method

Glossary Item Box

Description

This function sets the key property of the combo box to the space character. It was introduced for eCATT.

Syntax

Visual Basic
Public Sub SetKeySpace()

See Also

GuiComboBox Object | GuiComboBox Members


ShowContextMenu Method

ShowContextMenu Method
GuiComboBox Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiComboBox Object | GuiComboBox Members


Visualize Method

Visualize Method
On
InnerObject
GuiComboBox Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiComboBox Object | GuiComboBox Members


AccLabelCollection Property

AccLabelCollection Property
GuiComboBox Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiComboBox Object | GuiComboBox Members


AccText Property

AccText Property
GuiComboBox Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiComboBox Object | GuiComboBox Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiComboBox Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiComboBox Object | GuiComboBox Members


AccTooltip Property

AccTooltip Property
GuiComboBox Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiComboBox Object | GuiComboBox Members


Changeable Property

Changeable Property
GuiComboBox Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiComboBox Object | GuiComboBox Members


CharHeight Property

CharHeight Property
GuiComboBox Object : CharHeight Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharHeight As Long

See Also

GuiComboBox Object | GuiComboBox Members


CharLeft Property

CharLeft Property
GuiComboBox Object : CharLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharLeft As Long

See Also

GuiComboBox Object | GuiComboBox Members


CharTop Property

CharTop Property
GuiComboBox Object : CharTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharTop As Long

See Also

GuiComboBox Object | GuiComboBox Members


CharWidth Property

CharWidth Property
GuiComboBox Object : CharWidth Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharWidth As Long

See Also

GuiComboBox Object | GuiComboBox Members


ContainerType Property

ContainerType Property
GuiComboBox Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiComboBox Object | GuiComboBox Members


CurListBoxEntry Property

CurListBoxEntry Property
GuiComboBox Object : CurListBoxEntry Property

Glossary Item Box

Description

The currently focussed entry of the dropdown list.

Property type

Read-only property

Syntax

Visual Basic
Public Property CurListBoxEntry As GuiComboBoxEntry

See Also

GuiComboBox Object | GuiComboBox Members


DefaultTooltip Property

DefaultTooltip Property
GuiComboBox Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiComboBox Object | GuiComboBox Members


Entries Property

Entries Property
GuiComboBox Object : Entries Property

Glossary Item Box

Description

All members of this collection are of GuiComboBoxEntry type and have just two properties, key and value, both of type String. The key data can be displayed in SAP GUI by setting the ‘Show keys…’ check box on the option dialog’s expert page.

Property type

Read-only property

Syntax

Visual Basic
Public Property Entries As GuiCollection

Example

In this example the first column contains the key property and the second column contains the value property.

See Also

GuiComboBox Object | GuiComboBox Members


Flushing Property

Flushing Property
GuiComboBox Object : Flushing Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Flushing As Byte

See Also

GuiComboBox Object | GuiComboBox Members


Height Property

Height Property
GuiComboBox Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiComboBox Object | GuiComboBox Members


Highlighted Property

Highlighted Property
GuiComboBox Object : Highlighted Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Highlighted As Byte

See Also

GuiComboBox Object | GuiComboBox Members


IconName Property

IconName Property
GuiComboBox Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiComboBox Object | GuiComboBox Members


Id Property

Id Property
GuiComboBox Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiComboBox Object | GuiComboBox Members


IsLeftLabel Property

IsLeftLabel Property
GuiComboBox Object : IsLeftLabel Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsLeftLabel As Byte

See Also

GuiComboBox Object | GuiComboBox Members


IsListBoxActive Property

IsListBoxActive Property
GuiComboBox Object : IsListBoxActive Property

Glossary Item Box

Description

This property is True if the list box of the the combo box is currently open.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsListBoxActive As Byte

See Also

GuiComboBox Object | GuiComboBox Members


IsRightLabel Property

IsRightLabel Property
GuiComboBox Object : IsRightLabel Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsRightLabel As Byte

See Also

GuiComboBox Object | GuiComboBox Members


IsSymbolFont Property

IsSymbolFont Property
GuiComboBox Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiComboBox Object | GuiComboBox Members


Key Property

Key Property
GuiComboBox Object : Key Property

Glossary Item Box

Description

This is the key of the currently selected item. You can change this item by setting the key property to a new value.

Property type

Read-write property

Syntax

Visual Basic
Public Property Key As String

See Also

GuiComboBox Object | GuiComboBox Members


Left Property

Left Property
GuiComboBox Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiComboBox Object | GuiComboBox Members


LeftLabel Property

LeftLabel Property
GuiComboBox Object : LeftLabel Property

Glossary Item Box

Description

This label has been defined in ABAP Screen Painter to be the left label of the control.

Property type

Read-only property

Syntax

Visual Basic
Public Property LeftLabel As GuiVComponent

See Also

GuiComboBox Object | GuiComboBox Members


Modified Property

Modified Property
GuiComboBox Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiComboBox Object | GuiComboBox Members


Name Property

Name Property
GuiComboBox Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiComboBox Object | GuiComboBox Members


Parent Property

Parent Property
GuiComboBox Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiComboBox Object | GuiComboBox Members


ParentFrame Property

ParentFrame Property
GuiComboBox Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiComboBox Object | GuiComboBox Members


Required Property

Required Property
GuiComboBox Object : Required Property

Glossary Item Box

Description

If the required flag is set for a combo box then the empty entry is not selectable from the list.

Property type

Read-only property

Syntax

Visual Basic
Public Property Required As Byte

See Also

GuiComboBox Object | GuiComboBox Members


RightLabel Property

RightLabel Property
GuiComboBox Object : RightLabel Property

Glossary Item Box

Description

This label has been defined in ABAP Screen Painter to be the right label of the control.

Property type

Read-only property

Syntax

Visual Basic
Public Property RightLabel As GuiVComponent

See Also

GuiComboBox Object | GuiComboBox Members


ScreenLeft Property

ScreenLeft Property
GuiComboBox Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiComboBox Object | GuiComboBox Members


ScreenTop Property

ScreenTop Property
GuiComboBox Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiComboBox Object | GuiComboBox Members


ShowKey Property

ShowKey Property
GuiComboBox Object : ShowKey Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ShowKey As Byte

See Also

GuiComboBox Object | GuiComboBox Members


Text Property

Text Property
GuiComboBox Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiComboBox Object | GuiComboBox Members


Tooltip Property

Tooltip Property
GuiComboBox Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiComboBox Object | GuiComboBox Members


Top Property

Top Property
GuiComboBox Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiComboBox Object | GuiComboBox Members


Type Property

Type Property
GuiComboBox Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiComboBox Object | GuiComboBox Members


TypeAsNumber Property

TypeAsNumber Property
GuiComboBox Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiComboBox Object | GuiComboBox Members


Value Property

Value Property
GuiComboBox Object : Value Property

Glossary Item Box

Description

This is the value of the currently selected item. You can change this item by setting the value property to a new value.

Property type

Read-write property

Syntax

Visual Basic
Public Property Value As String

See Also

GuiComboBox Object | GuiComboBox Members


Width Property

Width Property
GuiComboBox Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiComboBox Object | GuiComboBox Members


GuiComboBoxEntry Object

GuiComboBoxEntry Object
See Also Members

Glossary Item Box

Description

Members of the Entries collection of a GuiComboBox are of type GuiComBoxEntry

Object Model

GuiComboBoxEntry Object

See Also

GuiComboBoxEntry Members


GuiComboBoxEntry Object Members

GuiComboBoxEntry Object Members
See Also Overview

Glossary Item Box

Public Properties

Public Property Key | Key value of the combo box entry.
Public Property Pos | Position of the combo box entry.
Public Property Value | Value of the combo box entry.

See Also

GuiComboBoxEntry Object


Key Property

Key Property
GuiComboBoxEntry Object : Key Property

Glossary Item Box

Description

Key value of the combo box entry.

Property type

Read-only property

Syntax

Visual Basic
Public Property Key As String

See Also

GuiComboBoxEntry Object | GuiComboBoxEntry Members


Pos Property

Pos Property
GuiComboBoxEntry Object : Pos Property

Glossary Item Box

Description

Position of the combo box entry.

Property type

Read-only property

Syntax

Visual Basic
Public Property Pos As Long

See Also

GuiComboBoxEntry Object | GuiComboBoxEntry Members


Value Property

Value Property
GuiComboBoxEntry Object : Value Property

Glossary Item Box

Description

Value of the combo box entry.

Property type

Read-only property

Syntax

Visual Basic
Public Property Value As String

See Also

GuiComboBoxEntry Object | GuiComboBoxEntry Members


GuiComponent Object

GuiComponent Object
See Also Members

Glossary Item Box

Description

GuiComponent is the base class for most classes in the Scripting API. It was designed to allow generic programming, meaning you can work with objects without knowing their exact type.

Object Model

GuiComponent Object

Remarks

GuiComponent is an abstract class.

See Also

GuiComponent Members


GuiComponent Object Members

GuiComponent Object Members
See Also Overview

Glossary Item Box

Public Properties

Public Property ContainerType
Public Property Id
Public Property Name
Public Property Parent
Public Property Type
Public Property TypeAsNumber

See Also

GuiComponent Object


ContainerType Property

ContainerType Property
GuiComponent Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiComponent Object | GuiComponent Members


Id Property

Id Property
GuiComponent Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiComponent Object | GuiComponent Members


Name Property

Name Property
GuiComponent Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiComponent Object | GuiComponent Members


Parent Property

Parent Property
GuiComponent Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As Object

See Also

GuiComponent Object | GuiComponent Members


Type Property

Type Property
GuiComponent Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiComponent Object | GuiComponent Members


TypeAsNumber Property

TypeAsNumber Property
GuiComponent Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiComponent Object | GuiComponent Members


GuiComponentCollection Collection

GuiComponentCollection Collection
See Also Members

Glossary Item Box

Description

The GuiComponentCollection is used for collections elements such as the children property of containers. Each element of the collection is an extension of GuiComponent.

Object Model

GuiComponentCollection Collection

See Also

GuiComponentCollection Members


GuiComponentCollection Collection Members

GuiComponentCollection Collection Members
See Also Overview

Glossary Item Box

Public Methods

Public Method ElementAt | This function returns the member in the collection at position index, where index may range from 0 to count-1. If no member can be found for the given index, the exception Gui_Err_Enumerator_Index (614) is raised.
Public Method Item | This function returns the member in the collection at position index, where index may range from 0 to count-1. It has been added for compatibility with Microsoft Visual Basic collections. If no member can be found for the given index the exception Gui_Err_Enumerator_Index (614) is raised.

Public Properties

Public Property Count | The number of elements in the collection. This property is used implicitly from Visual Basic applications.
Public Property Length | The number of elements in the collection.
Public Property NewEnum | This property is used implicitly from Visual Basic applications.
Public Property Type | The value is ‘GuiCollection’.
Public Property TypeAsNumber | The value is 120.

See Also

GuiComponentCollection Collection


ElementAt Method

ElementAt Method
Index
GuiComponentCollection Collection : ElementAt Method

Glossary Item Box

Description

This function returns the member in the collection at position index, where index may range from 0 to count-1. If no member can be found for the given index, the exception Gui_Err_Enumerator_Index (614) is raised.

Syntax

Visual Basic
Public Function ElementAt( _
   ByVal Index As Long _
) As GuiComponent

Parameters

Index

See Also

GuiComponentCollection Collection | GuiComponentCollection Members


Item Method

Item Method
Index
GuiComponentCollection Collection : Item Method

Glossary Item Box

Description

This function returns the member in the collection at position index, where index may range from 0 to count-1. It has been added for compatibility with Microsoft Visual Basic collections. If no member can be found for the given index the exception Gui_Err_Enumerator_Index (614) is raised.

Syntax

Visual Basic
Public Function Item( _
   ByVal Index As Variant _
) As GuiComponent

Parameters

Index

See Also

GuiComponentCollection Collection | GuiComponentCollection Members


Count Property

Count Property
GuiComponentCollection Collection : Count Property

Glossary Item Box

Description

The number of elements in the collection. This property is used implicitly from Visual Basic applications.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

GuiComponentCollection Collection | GuiComponentCollection Members


Length Property

Length Property
GuiComponentCollection Collection : Length Property

Glossary Item Box

Description

The number of elements in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Length As Long

See Also

GuiComponentCollection Collection | GuiComponentCollection Members


NewEnum Property

NewEnum Property
GuiComponentCollection Collection : NewEnum Property

Glossary Item Box

Description

This property is used implicitly from Visual Basic applications.

Property type

Read-only property

Syntax

Visual Basic
Public Property NewEnum As Unknown

See Also

GuiComponentCollection Collection | GuiComponentCollection Members


Type Property

Type Property
GuiComponentCollection Collection : Type Property

Glossary Item Box

Description

The value is ‘GuiCollection’.

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiComponentCollection Collection | GuiComponentCollection Members


TypeAsNumber Property

TypeAsNumber Property
GuiComponentCollection Collection : TypeAsNumber Property

Glossary Item Box

Description

The value is 120.

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiComponentCollection Collection | GuiComponentCollection Members


GuiConnection Object

GuiConnection Object
See Also Members

Glossary Item Box

Description

A GuiConnection represents the connection between SAP GUI and an application server. Connections can be opened from SAPlogon or from GuiApplication’s openConnection and openConnectionByConnectionString methods. GuiConnection extends GuiContainer. The type prefix for GuiConnection is con, the name is con plus the connection number in square brackets.

Object Model

GuiConnection ObjectGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponentCollection Collection

Remarks

It is possible to connect to an application server from ABAP using the following command:
CALL FUNCTION func DESTINATION dest.
However, this connection is implemented as a re-direction between the two application servers involved. There will therefore be no new GuiConnection object available and the existing object will not reflect the server switch.

See Also

GuiConnection Members


GuiConnection Object Members

GuiConnection Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method CloseConnection |
Public Method CloseSession | A session can be closed by calling this method of the connection. Closing the last session of a connection will close the connection, too.
Public Method FindById |

Public Properties

Public Property Children |
Public Property ConnectionString | This property contains the connection string defining the backend connection. It is more difficult to read, but it doesn’t rely on the SAPLogon entries.
Public Property ContainerType |
Public Property Description | This description is only available if the connection was started either from SAPlogon or using GuiApplication.OpenConnection. In both cases the description can then be used when calling the OpenConnection method to play back a script on the same system.
Public Property DisabledByServer | This property is set to True if the scripting support has not been enabled for the application server .
Public Property Id |
Public Property Name |
Public Property Parent |
Public Property Sessions | This property is another name for the children property. It was added for better readability as all the children of GuiConnection are sessions. Accessing either the children property or the sessions property can cause the exception Gui_Err_Scripting_Disabled_Srv (624) to be raised if the respective application server has not enabled the scripting support.
Public Property Type |
Public Property TypeAsNumber |

See Also

GuiConnection Object


CloseConnection Method

CloseConnection Method
GuiConnection Object : CloseConnection Method

Glossary Item Box

Syntax

Visual Basic
Public Sub CloseConnection()

See Also

GuiConnection Object | GuiConnection Members


CloseSession Method

CloseSession Method
Id
GuiConnection Object : CloseSession Method

Glossary Item Box

Description

A session can be closed by calling this method of the connection. Closing the last session of a connection will close the connection, too.

Syntax

Visual Basic
Public Sub CloseSession( _
   ByVal Id As String _
)

Parameters

Id

See Also

GuiConnection Object | GuiConnection Members


FindById Method

FindById Method
Id
Raise
GuiConnection Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiConnection Object | GuiConnection Members


Children Property

Children Property
GuiConnection Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiConnection Object | GuiConnection Members


ConnectionString Property

ConnectionString Property
GuiConnection Object : ConnectionString Property

Glossary Item Box

Description

This property contains the connection string defining the backend connection. It is more difficult to read, but it doesn’t rely on the SAPLogon entries.

Property type

Read-only property

Syntax

Visual Basic
Public Property ConnectionString As String

See Also

GuiConnection Object | GuiConnection Members


ContainerType Property

ContainerType Property
GuiConnection Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiConnection Object | GuiConnection Members


Description Property

Description Property
GuiConnection Object : Description Property

Glossary Item Box

Description

This description is only available if the connection was started either from SAPlogon or using GuiApplication.OpenConnection. In both cases the description can then be used when calling the OpenConnection method to play back a script on the same system.

Property type

Read-only property

Syntax

Visual Basic
Public Property Description As String

See Also

GuiConnection Object | GuiConnection Members


DisabledByServer Property

DisabledByServer Property
GuiConnection Object : DisabledByServer Property

Glossary Item Box

Description

This property is set to True if the scripting support has not been enabled for the application server .

Property type

Read-only property

Syntax

Visual Basic
Public Property DisabledByServer As Byte

See Also

GuiConnection Object | GuiConnection Members


Id Property

Id Property
GuiConnection Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiConnection Object | GuiConnection Members


Name Property

Name Property
GuiConnection Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiConnection Object | GuiConnection Members


Parent Property

Parent Property
GuiConnection Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiConnection Object | GuiConnection Members


Sessions Property

Sessions Property
GuiConnection Object : Sessions Property

Glossary Item Box

Description

This property is another name for the children property. It was added for better readability as all the children of GuiConnection are sessions. Accessing either the children property or the sessions property can cause the exception Gui_Err_Scripting_Disabled_Srv (624) to be raised if the respective application server has not enabled the scripting support.

Property type

Read-only property

Syntax

Visual Basic
Public Property Sessions As GuiComponentCollection

See Also

GuiConnection Object | GuiConnection Members


Type Property

Type Property
GuiConnection Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiConnection Object | GuiConnection Members


TypeAsNumber Property

TypeAsNumber Property
GuiConnection Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiConnection Object | GuiConnection Members


GuiContainer Object

GuiContainer Object
See Also Members

Glossary Item Box

Description

This interface resembles GuiVContainer. The only difference is that it is not intended for visual objects but rather administrative objects such as connections or sessions. Objects exposing this interface will therefore support GuiComponent but not GuiVComponent. GuiContainer extends GuiComponent.

Object Model

GuiContainer ObjectGuiComponentCollection CollectionGuiComponent ObjectGuiComponent Object

See Also

GuiContainer Members


GuiContainer Object Members

GuiContainer Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method FindById

Public Properties

Public Property Children
Public Property ContainerType
Public Property Id
Public Property Name
Public Property Parent
Public Property Type
Public Property TypeAsNumber

See Also

GuiContainer Object


FindById Method

FindById Method
Id
Raise
GuiContainer Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiContainer Object | GuiContainer Members


Children Property

Children Property
GuiContainer Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiContainer Object | GuiContainer Members


ContainerType Property

ContainerType Property
GuiContainer Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiContainer Object | GuiContainer Members


Id Property

Id Property
GuiContainer Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiContainer Object | GuiContainer Members


Name Property

Name Property
GuiContainer Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiContainer Object | GuiContainer Members


Parent Property

Parent Property
GuiContainer Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiContainer Object | GuiContainer Members


Type Property

Type Property
GuiContainer Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiContainer Object | GuiContainer Members


TypeAsNumber Property

TypeAsNumber Property
GuiContainer Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiContainer Object | GuiContainer Members


GuiContainerShell Object

GuiContainerShell Object
See Also Members

Glossary Item Box

Description

A GuiContainerShell is a wrapper for a set of GuiShell objects. GuiContainerShell extends GuiVContainer. The type prefix is shellcont, the name is the last part of the id, shellcont[n].

Object Model

GuiContainerShell ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent Object

See Also

GuiContainerShell Members


GuiContainerShell Object Members

GuiContainerShell Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property Changeable |
Public Property Children |
Public Property ContainerType |
Public Property DefaultTooltip |
Public Property DockerIsVertical | Is TRUE if the container is a vertical docker control.
Public Property DockerPixelSize | Returns the size of the docker control in pixels.
Public Property Height |
Public Property IconName |
Public Property Id |
Public Property IsSymbolFont |
Public Property Left |
Public Property Modified |
Public Property Name |
Public Property Parent |
Public Property ParentFrame |
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property Text |
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property Width |

See Also

GuiContainerShell Object


DumpState Method

DumpState Method
InnerObject
GuiContainerShell Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiContainerShell Object | GuiContainerShell Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiContainerShell Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiContainerShell Object | GuiContainerShell Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiContainerShell Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiContainerShell Object | GuiContainerShell Members


FindById Method

FindById Method
Id
Raise
GuiContainerShell Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiContainerShell Object | GuiContainerShell Members


FindByName Method

FindByName Method
Name
Type
GuiContainerShell Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiContainerShell Object | GuiContainerShell Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiContainerShell Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiContainerShell Object | GuiContainerShell Members


SetFocus Method

SetFocus Method
GuiContainerShell Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiContainerShell Object | GuiContainerShell Members


ShowContextMenu Method

ShowContextMenu Method
GuiContainerShell Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiContainerShell Object | GuiContainerShell Members


Visualize Method

Visualize Method
On
InnerObject
GuiContainerShell Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiContainerShell Object | GuiContainerShell Members


AccLabelCollection Property

AccLabelCollection Property
GuiContainerShell Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiContainerShell Object | GuiContainerShell Members


AccText Property

AccText Property
GuiContainerShell Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiContainerShell Object | GuiContainerShell Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiContainerShell Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiContainerShell Object | GuiContainerShell Members


AccTooltip Property

AccTooltip Property
GuiContainerShell Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiContainerShell Object | GuiContainerShell Members


Changeable Property

Changeable Property
GuiContainerShell Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiContainerShell Object | GuiContainerShell Members


Children Property

Children Property
GuiContainerShell Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiContainerShell Object | GuiContainerShell Members


ContainerType Property

ContainerType Property
GuiContainerShell Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiContainerShell Object | GuiContainerShell Members


DefaultTooltip Property

DefaultTooltip Property
GuiContainerShell Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiContainerShell Object | GuiContainerShell Members


DockerIsVertical Property

DockerIsVertical Property
GuiContainerShell Object : DockerIsVertical Property

Glossary Item Box

Description

Is TRUE if the container is a vertical docker control.

Property type

Read-only property

Syntax

Visual Basic
Public Property DockerIsVertical As Byte

See Also

GuiContainerShell Object | GuiContainerShell Members


DockerPixelSize Property

DockerPixelSize Property
GuiContainerShell Object : DockerPixelSize Property

Glossary Item Box

Description

Returns the size of the docker control in pixels.

Property type

Read-write property

Syntax

Visual Basic
Public Property DockerPixelSize As Long

See Also

GuiContainerShell Object | GuiContainerShell Members


Height Property

Height Property
GuiContainerShell Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiContainerShell Object | GuiContainerShell Members


IconName Property

IconName Property
GuiContainerShell Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiContainerShell Object | GuiContainerShell Members


Id Property

Id Property
GuiContainerShell Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiContainerShell Object | GuiContainerShell Members


IsSymbolFont Property

IsSymbolFont Property
GuiContainerShell Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiContainerShell Object | GuiContainerShell Members


Left Property

Left Property
GuiContainerShell Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiContainerShell Object | GuiContainerShell Members


Modified Property

Modified Property
GuiContainerShell Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiContainerShell Object | GuiContainerShell Members


Name Property

Name Property
GuiContainerShell Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiContainerShell Object | GuiContainerShell Members


Parent Property

Parent Property
GuiContainerShell Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiContainerShell Object | GuiContainerShell Members


ParentFrame Property

ParentFrame Property
GuiContainerShell Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiContainerShell Object | GuiContainerShell Members


ScreenLeft Property

ScreenLeft Property
GuiContainerShell Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiContainerShell Object | GuiContainerShell Members


ScreenTop Property

ScreenTop Property
GuiContainerShell Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiContainerShell Object | GuiContainerShell Members


Text Property

Text Property
GuiContainerShell Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiContainerShell Object | GuiContainerShell Members


Tooltip Property

Tooltip Property
GuiContainerShell Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiContainerShell Object | GuiContainerShell Members


Top Property

Top Property
GuiContainerShell Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiContainerShell Object | GuiContainerShell Members


Type Property

Type Property
GuiContainerShell Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiContainerShell Object | GuiContainerShell Members


TypeAsNumber Property

TypeAsNumber Property
GuiContainerShell Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiContainerShell Object | GuiContainerShell Members


Width Property

Width Property
GuiContainerShell Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiContainerShell Object | GuiContainerShell Members


GuiContextMenu Object

GuiContextMenu Object
See Also Members

Glossary Item Box

Description

A GuiContextMenu may have other GuiContextMenu objects as children. GuiContextMenu extends GuiMenu. The type is mnu, the name is the function code that is sent to the system when the menu item is selected.

Object Model

GuiContextMenu ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent Object

See Also

GuiContextMenu Members


GuiContextMenu Object Members

GuiContextMenu Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState |
Public Method FindAllByName |
Public Method FindAllByNameEx |
Public Method FindById |
Public Method FindByName |
Public Method FindByNameEx |
Public Method Select | Select the context menu item.
Public Method SetFocus |
Public Method ShowContextMenu |
Public Method Visualize |

Public Properties

Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property Children
Public Property ContainerType
Public Property DefaultTooltip
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiContextMenu Object


DumpState Method

DumpState Method
InnerObject
GuiContextMenu Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiContextMenu Object | GuiContextMenu Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiContextMenu Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiContextMenu Object | GuiContextMenu Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiContextMenu Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiContextMenu Object | GuiContextMenu Members


FindById Method

FindById Method
Id
Raise
GuiContextMenu Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiContextMenu Object | GuiContextMenu Members


FindByName Method

FindByName Method
Name
Type
GuiContextMenu Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiContextMenu Object | GuiContextMenu Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiContextMenu Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiContextMenu Object | GuiContextMenu Members


Select Method

Select Method
GuiContextMenu Object : Select Method

Glossary Item Box

Description

Select the context menu item.

Syntax

Visual Basic
Public Sub Select()

See Also

GuiContextMenu Object | GuiContextMenu Members


SetFocus Method

SetFocus Method
GuiContextMenu Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiContextMenu Object | GuiContextMenu Members


ShowContextMenu Method

ShowContextMenu Method
GuiContextMenu Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiContextMenu Object | GuiContextMenu Members


Visualize Method

Visualize Method
On
InnerObject
GuiContextMenu Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiContextMenu Object | GuiContextMenu Members


AccLabelCollection Property

AccLabelCollection Property
GuiContextMenu Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiContextMenu Object | GuiContextMenu Members


AccText Property

AccText Property
GuiContextMenu Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiContextMenu Object | GuiContextMenu Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiContextMenu Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiContextMenu Object | GuiContextMenu Members


AccTooltip Property

AccTooltip Property
GuiContextMenu Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiContextMenu Object | GuiContextMenu Members


Changeable Property

Changeable Property
GuiContextMenu Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiContextMenu Object | GuiContextMenu Members


Children Property

Children Property
GuiContextMenu Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiContextMenu Object | GuiContextMenu Members


ContainerType Property

ContainerType Property
GuiContextMenu Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiContextMenu Object | GuiContextMenu Members


DefaultTooltip Property

DefaultTooltip Property
GuiContextMenu Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiContextMenu Object | GuiContextMenu Members


Height Property

Height Property
GuiContextMenu Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiContextMenu Object | GuiContextMenu Members


IconName Property

IconName Property
GuiContextMenu Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiContextMenu Object | GuiContextMenu Members


Id Property

Id Property
GuiContextMenu Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiContextMenu Object | GuiContextMenu Members


IsSymbolFont Property

IsSymbolFont Property
GuiContextMenu Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiContextMenu Object | GuiContextMenu Members


Left Property

Left Property
GuiContextMenu Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiContextMenu Object | GuiContextMenu Members


Modified Property

Modified Property
GuiContextMenu Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiContextMenu Object | GuiContextMenu Members


Name Property

Name Property
GuiContextMenu Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiContextMenu Object | GuiContextMenu Members


Parent Property

Parent Property
GuiContextMenu Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiContextMenu Object | GuiContextMenu Members


ParentFrame Property

ParentFrame Property
GuiContextMenu Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiContextMenu Object | GuiContextMenu Members


ScreenLeft Property

ScreenLeft Property
GuiContextMenu Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiContextMenu Object | GuiContextMenu Members


ScreenTop Property

ScreenTop Property
GuiContextMenu Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiContextMenu Object | GuiContextMenu Members


Text Property

Text Property
GuiContextMenu Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiContextMenu Object | GuiContextMenu Members


Tooltip Property

Tooltip Property
GuiContextMenu Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiContextMenu Object | GuiContextMenu Members


Top Property

Top Property
GuiContextMenu Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiContextMenu Object | GuiContextMenu Members


Type Property

Type Property
GuiContextMenu Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiContextMenu Object | GuiContextMenu Members


TypeAsNumber Property

TypeAsNumber Property
GuiContextMenu Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiContextMenu Object | GuiContextMenu Members


Width Property

Width Property
GuiContextMenu Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiContextMenu Object | GuiContextMenu Members


GuiCTextField Object

GuiCTextField Object
See Also Members

Glossary Item Box

Description

If the cursor is set into a text field of type GuiCTextField a combo box button is displayed to the right of the text field. Pressing this button is equivalent to pressing the F4 key. The button is not represented in the scripting object model as a separate object; it is considered to be part of the text field.
There are no other differences between GuiTextField and GuiCTextField. GuiCTextField extends GuiTextField. The type prefix is ctxt, the name is the Fieldname taken from the SAP data dictionary.

Object Model

GuiCTextField ObjectGuiComponentCollection CollectionGuiCollection CollectionGuiCollection CollectionGuiVComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiVComponent Object

Example

This is an example of GuiCTextField type text field, where the upper field has the focus. Please note that the button is only displayed when the corresponding input field has the focus.

See Also

GuiCTextField Members


GuiCTextField Object Members

GuiCTextField Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property CaretPosition
Public Property Changeable
Public Property CharHeight
Public Property CharLeft
Public Property CharTop
Public Property CharWidth
Public Property ContainerType
Public Property DefaultTooltip
Public Property DisplayedText
Public Property Height
Public Property Highlighted
Public Property HistoryCurEntry
Public Property HistoryCurIndex
Public Property HistoryIsActive
Public Property HistoryList
Public Property IconName
Public Property Id
Public Property IsHotspot
Public Property IsLeftLabel
Public Property IsOField
Public Property IsRightLabel
Public Property IsSymbolFont
Public Property Left
Public Property LeftLabel
Public Property MaxLength
Public Property Modified
Public Property Name
Public Property Numerical
Public Property Parent
Public Property ParentFrame
Public Property Required
Public Property RightLabel
Public Property ScreenLeft
Public Property ScreenTop
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiCTextField Object


DumpState Method

DumpState Method
InnerObject
GuiCTextField Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiCTextField Object | GuiCTextField Members


SetFocus Method

SetFocus Method
GuiCTextField Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiCTextField Object | GuiCTextField Members


ShowContextMenu Method

ShowContextMenu Method
GuiCTextField Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiCTextField Object | GuiCTextField Members


Visualize Method

Visualize Method
On
InnerObject
GuiCTextField Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiCTextField Object | GuiCTextField Members


AccLabelCollection Property

AccLabelCollection Property
GuiCTextField Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiCTextField Object | GuiCTextField Members


AccText Property

AccText Property
GuiCTextField Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiCTextField Object | GuiCTextField Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiCTextField Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiCTextField Object | GuiCTextField Members


AccTooltip Property

AccTooltip Property
GuiCTextField Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiCTextField Object | GuiCTextField Members


CaretPosition Property

CaretPosition Property
GuiCTextField Object : CaretPosition Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property CaretPosition As Long

See Also

GuiCTextField Object | GuiCTextField Members


Changeable Property

Changeable Property
GuiCTextField Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiCTextField Object | GuiCTextField Members


CharHeight Property

CharHeight Property
GuiCTextField Object : CharHeight Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharHeight As Long

See Also

GuiCTextField Object | GuiCTextField Members


CharLeft Property

CharLeft Property
GuiCTextField Object : CharLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharLeft As Long

See Also

GuiCTextField Object | GuiCTextField Members


CharTop Property

CharTop Property
GuiCTextField Object : CharTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharTop As Long

See Also

GuiCTextField Object | GuiCTextField Members


CharWidth Property

CharWidth Property
GuiCTextField Object : CharWidth Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharWidth As Long

See Also

GuiCTextField Object | GuiCTextField Members


ContainerType Property

ContainerType Property
GuiCTextField Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiCTextField Object | GuiCTextField Members


DefaultTooltip Property

DefaultTooltip Property
GuiCTextField Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiCTextField Object | GuiCTextField Members


DisplayedText Property

DisplayedText Property
GuiCTextField Object : DisplayedText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DisplayedText As String

See Also

GuiCTextField Object | GuiCTextField Members


Height Property

Height Property
GuiCTextField Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiCTextField Object | GuiCTextField Members


Highlighted Property

Highlighted Property
GuiCTextField Object : Highlighted Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Highlighted As Byte

See Also

GuiCTextField Object | GuiCTextField Members


HistoryCurEntry Property

HistoryCurEntry Property
GuiCTextField Object : HistoryCurEntry Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property HistoryCurEntry As String

See Also

GuiCTextField Object | GuiCTextField Members


HistoryCurIndex Property

HistoryCurIndex Property
GuiCTextField Object : HistoryCurIndex Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property HistoryCurIndex As Long

See Also

GuiCTextField Object | GuiCTextField Members


HistoryIsActive Property

HistoryIsActive Property
GuiCTextField Object : HistoryIsActive Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property HistoryIsActive As Byte

See Also

GuiCTextField Object | GuiCTextField Members


HistoryList Property

HistoryList Property
GuiCTextField Object : HistoryList Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property HistoryList As GuiCollection

See Also

GuiCTextField Object | GuiCTextField Members


IconName Property

IconName Property
GuiCTextField Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiCTextField Object | GuiCTextField Members


Id Property

Id Property
GuiCTextField Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiCTextField Object | GuiCTextField Members


IsHotspot Property

IsHotspot Property
GuiCTextField Object : IsHotspot Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsHotspot As Byte

See Also

GuiCTextField Object | GuiCTextField Members


IsLeftLabel Property

IsLeftLabel Property
GuiCTextField Object : IsLeftLabel Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsLeftLabel As Byte

See Also

GuiCTextField Object | GuiCTextField Members


IsOField Property

IsOField Property
GuiCTextField Object : IsOField Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsOField As Byte

See Also

GuiCTextField Object | GuiCTextField Members


IsRightLabel Property

IsRightLabel Property
GuiCTextField Object : IsRightLabel Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsRightLabel As Byte

See Also

GuiCTextField Object | GuiCTextField Members


IsSymbolFont Property

IsSymbolFont Property
GuiCTextField Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiCTextField Object | GuiCTextField Members


Left Property

Left Property
GuiCTextField Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiCTextField Object | GuiCTextField Members


LeftLabel Property

LeftLabel Property
GuiCTextField Object : LeftLabel Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property LeftLabel As GuiVComponent

See Also

GuiCTextField Object | GuiCTextField Members


MaxLength Property

MaxLength Property
GuiCTextField Object : MaxLength Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property MaxLength As Long

See Also

GuiCTextField Object | GuiCTextField Members


Modified Property

Modified Property
GuiCTextField Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiCTextField Object | GuiCTextField Members


Name Property

Name Property
GuiCTextField Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiCTextField Object | GuiCTextField Members


Numerical Property

Numerical Property
GuiCTextField Object : Numerical Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Numerical As Byte

See Also

GuiCTextField Object | GuiCTextField Members


Parent Property

Parent Property
GuiCTextField Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiCTextField Object | GuiCTextField Members


ParentFrame Property

ParentFrame Property
GuiCTextField Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiCTextField Object | GuiCTextField Members


Required Property

Required Property
GuiCTextField Object : Required Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Required As Byte

See Also

GuiCTextField Object | GuiCTextField Members


RightLabel Property

RightLabel Property
GuiCTextField Object : RightLabel Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property RightLabel As GuiVComponent

See Also

GuiCTextField Object | GuiCTextField Members


ScreenLeft Property

ScreenLeft Property
GuiCTextField Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiCTextField Object | GuiCTextField Members


ScreenTop Property

ScreenTop Property
GuiCTextField Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiCTextField Object | GuiCTextField Members


Text Property

Text Property
GuiCTextField Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiCTextField Object | GuiCTextField Members


Tooltip Property

Tooltip Property
GuiCTextField Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiCTextField Object | GuiCTextField Members


Top Property

Top Property
GuiCTextField Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiCTextField Object | GuiCTextField Members


Type Property

Type Property
GuiCTextField Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiCTextField Object | GuiCTextField Members


TypeAsNumber Property

TypeAsNumber Property
GuiCTextField Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiCTextField Object | GuiCTextField Members


Width Property

Width Property
GuiCTextField Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiCTextField Object | GuiCTextField Members


GuiCustomControl Object

GuiCustomControl Object
See Also Members

Glossary Item Box

Description

The GuiCustomControl is a wrapper object that is used to place ActiveX controls onto dynpro screens. While GuiCustomControl is a dynpro element itself, its children are of GuiContainerShell type, which is a container for controls. GuiCustomControl extends GuiVContainer. The type prefix is cntl, the name is the fieldname taken from the SAP data dictionary.

Object Model

GuiCustomControl ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent Object

See Also

GuiCustomControl Members


GuiCustomControl Object Members

GuiCustomControl Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property CharHeight
Public Property CharLeft
Public Property CharTop
Public Property CharWidth
Public Property Children
Public Property ContainerType
Public Property DefaultTooltip
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiCustomControl Object


DumpState Method

DumpState Method
InnerObject
GuiCustomControl Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiCustomControl Object | GuiCustomControl Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiCustomControl Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiCustomControl Object | GuiCustomControl Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiCustomControl Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiCustomControl Object | GuiCustomControl Members


FindById Method

FindById Method
Id
Raise
GuiCustomControl Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiCustomControl Object | GuiCustomControl Members


FindByName Method

FindByName Method
Name
Type
GuiCustomControl Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiCustomControl Object | GuiCustomControl Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiCustomControl Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiCustomControl Object | GuiCustomControl Members


SetFocus Method

SetFocus Method
GuiCustomControl Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiCustomControl Object | GuiCustomControl Members


ShowContextMenu Method

ShowContextMenu Method
GuiCustomControl Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiCustomControl Object | GuiCustomControl Members


Visualize Method

Visualize Method
On
InnerObject
GuiCustomControl Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiCustomControl Object | GuiCustomControl Members


AccLabelCollection Property

AccLabelCollection Property
GuiCustomControl Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiCustomControl Object | GuiCustomControl Members


AccText Property

AccText Property
GuiCustomControl Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiCustomControl Object | GuiCustomControl Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiCustomControl Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiCustomControl Object | GuiCustomControl Members


AccTooltip Property

AccTooltip Property
GuiCustomControl Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiCustomControl Object | GuiCustomControl Members


Changeable Property

Changeable Property
GuiCustomControl Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiCustomControl Object | GuiCustomControl Members


CharHeight Property

CharHeight Property
GuiCustomControl Object : CharHeight Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharHeight As Long

See Also

GuiCustomControl Object | GuiCustomControl Members


CharLeft Property

CharLeft Property
GuiCustomControl Object : CharLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharLeft As Long

See Also

GuiCustomControl Object | GuiCustomControl Members


CharTop Property

CharTop Property
GuiCustomControl Object : CharTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharTop As Long

See Also

GuiCustomControl Object | GuiCustomControl Members


CharWidth Property

CharWidth Property
GuiCustomControl Object : CharWidth Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharWidth As Long

See Also

GuiCustomControl Object | GuiCustomControl Members


Children Property

Children Property
GuiCustomControl Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiCustomControl Object | GuiCustomControl Members


ContainerType Property

ContainerType Property
GuiCustomControl Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiCustomControl Object | GuiCustomControl Members


DefaultTooltip Property

DefaultTooltip Property
GuiCustomControl Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiCustomControl Object | GuiCustomControl Members


Height Property

Height Property
GuiCustomControl Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiCustomControl Object | GuiCustomControl Members


IconName Property

IconName Property
GuiCustomControl Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiCustomControl Object | GuiCustomControl Members


Id Property

Id Property
GuiCustomControl Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiCustomControl Object | GuiCustomControl Members


IsSymbolFont Property

IsSymbolFont Property
GuiCustomControl Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiCustomControl Object | GuiCustomControl Members


Left Property

Left Property
GuiCustomControl Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiCustomControl Object | GuiCustomControl Members


Modified Property

Modified Property
GuiCustomControl Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiCustomControl Object | GuiCustomControl Members


Name Property

Name Property
GuiCustomControl Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiCustomControl Object | GuiCustomControl Members


Parent Property

Parent Property
GuiCustomControl Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiCustomControl Object | GuiCustomControl Members


ParentFrame Property

ParentFrame Property
GuiCustomControl Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiCustomControl Object | GuiCustomControl Members


ScreenLeft Property

ScreenLeft Property
GuiCustomControl Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiCustomControl Object | GuiCustomControl Members


ScreenTop Property

ScreenTop Property
GuiCustomControl Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiCustomControl Object | GuiCustomControl Members


Text Property

Text Property
GuiCustomControl Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiCustomControl Object | GuiCustomControl Members


Tooltip Property

Tooltip Property
GuiCustomControl Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiCustomControl Object | GuiCustomControl Members


Top Property

Top Property
GuiCustomControl Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiCustomControl Object | GuiCustomControl Members


Type Property

Type Property
GuiCustomControl Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiCustomControl Object | GuiCustomControl Members


TypeAsNumber Property

TypeAsNumber Property
GuiCustomControl Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiCustomControl Object | GuiCustomControl Members


Width Property

Width Property
GuiCustomControl Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiCustomControl Object | GuiCustomControl Members


GuiDialogShell Object

GuiDialogShell Object
See Also Members

Glossary Item Box

Description

The GuiDialogShell is an external window that is used as a container for other shells, for example a toolbar. GuiDialogShell extends GuiVContainer. The type prefix is shellcont, the name is the last part of the id, shellcont[n].

Object Model

GuiDialogShell ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent Object

Example

See Also

GuiDialogShell Members


GuiDialogShell Object Members

GuiDialogShell Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method Close | This method closes the external window.
Public Method DumpState |
Public Method FindAllByName |
Public Method FindAllByNameEx |
Public Method FindById |
Public Method FindByName |
Public Method FindByNameEx |
Public Method SetFocus |
Public Method ShowContextMenu |
Public Method Visualize |

Public Properties

Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property Changeable |
Public Property Children |
Public Property ContainerType |
Public Property DefaultTooltip |
Public Property Height |
Public Property IconName |
Public Property Id |
Public Property IsSymbolFont |
Public Property Left |
Public Property Modified |
Public Property Name |
Public Property Parent |
Public Property ParentFrame |
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property Text |
Public Property Title | Title of the dialog.
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property Width |

See Also

GuiDialogShell Object


Close Method

Close Method
GuiDialogShell Object : Close Method

Glossary Item Box

Description

This method closes the external window.

Syntax

Visual Basic
Public Sub Close()

See Also

GuiDialogShell Object | GuiDialogShell Members


DumpState Method

DumpState Method
InnerObject
GuiDialogShell Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiDialogShell Object | GuiDialogShell Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiDialogShell Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiDialogShell Object | GuiDialogShell Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiDialogShell Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiDialogShell Object | GuiDialogShell Members


FindById Method

FindById Method
Id
Raise
GuiDialogShell Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiDialogShell Object | GuiDialogShell Members


FindByName Method

FindByName Method
Name
Type
GuiDialogShell Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiDialogShell Object | GuiDialogShell Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiDialogShell Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiDialogShell Object | GuiDialogShell Members


SetFocus Method

SetFocus Method
GuiDialogShell Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiDialogShell Object | GuiDialogShell Members


ShowContextMenu Method

ShowContextMenu Method
GuiDialogShell Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiDialogShell Object | GuiDialogShell Members


Visualize Method

Visualize Method
On
InnerObject
GuiDialogShell Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiDialogShell Object | GuiDialogShell Members


AccLabelCollection Property

AccLabelCollection Property
GuiDialogShell Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiDialogShell Object | GuiDialogShell Members


AccText Property

AccText Property
GuiDialogShell Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiDialogShell Object | GuiDialogShell Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiDialogShell Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiDialogShell Object | GuiDialogShell Members


AccTooltip Property

AccTooltip Property
GuiDialogShell Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiDialogShell Object | GuiDialogShell Members


Changeable Property

Changeable Property
GuiDialogShell Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiDialogShell Object | GuiDialogShell Members


Children Property

Children Property
GuiDialogShell Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiDialogShell Object | GuiDialogShell Members


ContainerType Property

ContainerType Property
GuiDialogShell Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiDialogShell Object | GuiDialogShell Members


DefaultTooltip Property

DefaultTooltip Property
GuiDialogShell Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiDialogShell Object | GuiDialogShell Members


Height Property

Height Property
GuiDialogShell Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiDialogShell Object | GuiDialogShell Members


IconName Property

IconName Property
GuiDialogShell Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiDialogShell Object | GuiDialogShell Members


Id Property

Id Property
GuiDialogShell Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiDialogShell Object | GuiDialogShell Members


IsSymbolFont Property

IsSymbolFont Property
GuiDialogShell Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiDialogShell Object | GuiDialogShell Members


Left Property

Left Property
GuiDialogShell Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiDialogShell Object | GuiDialogShell Members


Modified Property

Modified Property
GuiDialogShell Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiDialogShell Object | GuiDialogShell Members


Name Property

Name Property
GuiDialogShell Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiDialogShell Object | GuiDialogShell Members


Parent Property

Parent Property
GuiDialogShell Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiDialogShell Object | GuiDialogShell Members


ParentFrame Property

ParentFrame Property
GuiDialogShell Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiDialogShell Object | GuiDialogShell Members


ScreenLeft Property

ScreenLeft Property
GuiDialogShell Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiDialogShell Object | GuiDialogShell Members


ScreenTop Property

ScreenTop Property
GuiDialogShell Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiDialogShell Object | GuiDialogShell Members


Text Property

Text Property
GuiDialogShell Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiDialogShell Object | GuiDialogShell Members


Title Property

Title Property
GuiDialogShell Object : Title Property

Glossary Item Box

Description

Title of the dialog.

Property type

Read-only property

Syntax

Visual Basic
Public Property Title As String

See Also

GuiDialogShell Object | GuiDialogShell Members


Tooltip Property

Tooltip Property
GuiDialogShell Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiDialogShell Object | GuiDialogShell Members


Top Property

Top Property
GuiDialogShell Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiDialogShell Object | GuiDialogShell Members


Type Property

Type Property
GuiDialogShell Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiDialogShell Object | GuiDialogShell Members


TypeAsNumber Property

TypeAsNumber Property
GuiDialogShell Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiDialogShell Object | GuiDialogShell Members


Width Property

Width Property
GuiDialogShell Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiDialogShell Object | GuiDialogShell Members


GuiEAIViewer2D Object

GuiEAIViewer2D Object
See Also Members

Glossary Item Box

Description

The GuiEAIViewer2D control is used to view 2-dimensional graphic images in the SAP system. Presently Webviewer2D supports 22 available image types. The user can carry out redlining over the loaded image. The scripting wrapper for this control records all user actions during the redlining process and reproduces the same actions when the recorded script is replayed.

GuiEAIViewer2D extends GuiShell.

Object Model

GuiEAIViewer2D ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiComponent ObjectGuiComponent Object

Example

See Also

GuiEAIViewer2D Members


GuiEAIViewer2D Object Members

GuiEAIViewer2D Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method annotationTextRequest
Public Method DumpState
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method SelectContextMenuItem
Public Method SelectContextMenuItemByPosition
Public Method SelectContextMenuItemByText
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccDescription |
Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property AnnotationEnabled | The value of this property is set to 1 when redlining is started. The wrapper control starts recording user actions as soon as this property is set to value 1.
Public Property AnnotationMode | During redlining, the selected redlining mode is stored in this property.
Public Property Changeable |
Public Property Children |
Public Property ContainerType |
Public Property CurrentContextMenu |
Public Property DefaultTooltip |
Public Property DragDropSupported |
Public Property Handle |
Public Property Height |
Public Property IconName |
Public Property Id |
Public Property IsSymbolFont |
Public Property Left |
Public Property Modified |
Public Property Name |
Public Property OcxEvents |
Public Property Parent |
Public Property ParentFrame |
Public Property RedliningStream | This property stores the redlining layer as BLOB (Binary large data object). During recording, the whole BLOB is copied into the generated script.
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property SubType | This property has the constant value EAI2D.
Public Property Text |
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property Width |

See Also

GuiEAIViewer2D Object


annotationTextRequest Method

annotationTextRequest Method
strText
GuiEAIViewer2D Object : annotationTextRequest Method

Glossary Item Box

Syntax

Visual Basic
Public Sub annotationTextRequest( _
   ByVal strText As String _
)

Parameters

strText

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


DumpState Method

DumpState Method
InnerObject
GuiEAIViewer2D Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiEAIViewer2D Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiEAIViewer2D Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


FindById Method

FindById Method
Id
Raise
GuiEAIViewer2D Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


FindByName Method

FindByName Method
Name
Type
GuiEAIViewer2D Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiEAIViewer2D Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiEAIViewer2D Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiEAIViewer2D Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiEAIViewer2D Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


SetFocus Method

SetFocus Method
GuiEAIViewer2D Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


ShowContextMenu Method

ShowContextMenu Method
GuiEAIViewer2D Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


Visualize Method

Visualize Method
On
InnerObject
GuiEAIViewer2D Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


AccDescription Property

AccDescription Property
GuiEAIViewer2D Object : AccDescription Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccDescription As String

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


AccLabelCollection Property

AccLabelCollection Property
GuiEAIViewer2D Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


AccText Property

AccText Property
GuiEAIViewer2D Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiEAIViewer2D Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


AccTooltip Property

AccTooltip Property
GuiEAIViewer2D Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


AnnotationEnabled Property

AnnotationEnabled Property
GuiEAIViewer2D Object : AnnotationEnabled Property

Glossary Item Box

Description

The value of this property is set to 1 when redlining is started. The wrapper control starts recording user actions as soon as this property is set to value 1.

Property type

Read-write property

Syntax

Visual Basic
Public Property AnnotationEnabled As Long

Example

The following screen shot shows how to start redlining:

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


AnnotationMode Property

AnnotationMode Property
GuiEAIViewer2D Object : AnnotationMode Property

Glossary Item Box

Description

During redlining, the selected redlining mode is stored in this property.

Property type

Read-write property

Syntax

Visual Basic
Public Property AnnotationMode As Integer

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


Changeable Property

Changeable Property
GuiEAIViewer2D Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


Children Property

Children Property
GuiEAIViewer2D Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


ContainerType Property

ContainerType Property
GuiEAIViewer2D Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


CurrentContextMenu Property

CurrentContextMenu Property
GuiEAIViewer2D Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


DefaultTooltip Property

DefaultTooltip Property
GuiEAIViewer2D Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


DragDropSupported Property

DragDropSupported Property
GuiEAIViewer2D Object : DragDropSupported Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DragDropSupported As Byte

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


Handle Property

Handle Property
GuiEAIViewer2D Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


Height Property

Height Property
GuiEAIViewer2D Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


IconName Property

IconName Property
GuiEAIViewer2D Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


Id Property

Id Property
GuiEAIViewer2D Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


IsSymbolFont Property

IsSymbolFont Property
GuiEAIViewer2D Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


Left Property

Left Property
GuiEAIViewer2D Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


Modified Property

Modified Property
GuiEAIViewer2D Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


Name Property

Name Property
GuiEAIViewer2D Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


OcxEvents Property

OcxEvents Property
GuiEAIViewer2D Object : OcxEvents Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property OcxEvents As GuiCollection

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


Parent Property

Parent Property
GuiEAIViewer2D Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


ParentFrame Property

ParentFrame Property
GuiEAIViewer2D Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


RedliningStream Property

RedliningStream Property
GuiEAIViewer2D Object : RedliningStream Property

Glossary Item Box

Description

This property stores the redlining layer as BLOB (Binary large data object). During recording, the whole BLOB is copied into the generated script.

Property type

Read-write property

Syntax

Visual Basic
Public Property RedliningStream As String

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


ScreenLeft Property

ScreenLeft Property
GuiEAIViewer2D Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


ScreenTop Property

ScreenTop Property
GuiEAIViewer2D Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


SubType Property

SubType Property
GuiEAIViewer2D Object : SubType Property

Glossary Item Box

Description

This property has the constant value EAI2D.

Property type

Read-only property

Syntax

Visual Basic
Public Property SubType As String

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


Text Property

Text Property
GuiEAIViewer2D Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


Tooltip Property

Tooltip Property
GuiEAIViewer2D Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


Top Property

Top Property
GuiEAIViewer2D Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


Type Property

Type Property
GuiEAIViewer2D Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


TypeAsNumber Property

TypeAsNumber Property
GuiEAIViewer2D Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


Width Property

Width Property
GuiEAIViewer2D Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiEAIViewer2D Object | GuiEAIViewer2D Members


GuiEAIViewer3D Object

GuiEAIViewer3D Object
See Also Members

Glossary Item Box

Object Model

GuiEAIViewer3D ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiComponent ObjectGuiComponent Object

See Also

GuiEAIViewer3D Members


GuiEAIViewer3D Object Members

GuiEAIViewer3D Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method SelectContextMenuItem
Public Method SelectContextMenuItemByPosition
Public Method SelectContextMenuItemByText
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccDescription
Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property Children
Public Property ContainerType
Public Property CurrentContextMenu
Public Property DefaultTooltip
Public Property DragDropSupported
Public Property Handle
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property OcxEvents
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property SubType
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiEAIViewer3D Object


DumpState Method

DumpState Method
InnerObject
GuiEAIViewer3D Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiEAIViewer3D Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiEAIViewer3D Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


FindById Method

FindById Method
Id
Raise
GuiEAIViewer3D Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


FindByName Method

FindByName Method
Name
Type
GuiEAIViewer3D Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiEAIViewer3D Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiEAIViewer3D Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiEAIViewer3D Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiEAIViewer3D Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


SetFocus Method

SetFocus Method
GuiEAIViewer3D Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


ShowContextMenu Method

ShowContextMenu Method
GuiEAIViewer3D Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


Visualize Method

Visualize Method
On
InnerObject
GuiEAIViewer3D Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


AccDescription Property

AccDescription Property
GuiEAIViewer3D Object : AccDescription Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccDescription As String

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


AccLabelCollection Property

AccLabelCollection Property
GuiEAIViewer3D Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


AccText Property

AccText Property
GuiEAIViewer3D Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiEAIViewer3D Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


AccTooltip Property

AccTooltip Property
GuiEAIViewer3D Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


Changeable Property

Changeable Property
GuiEAIViewer3D Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


Children Property

Children Property
GuiEAIViewer3D Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


ContainerType Property

ContainerType Property
GuiEAIViewer3D Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


CurrentContextMenu Property

CurrentContextMenu Property
GuiEAIViewer3D Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


DefaultTooltip Property

DefaultTooltip Property
GuiEAIViewer3D Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


DragDropSupported Property

DragDropSupported Property
GuiEAIViewer3D Object : DragDropSupported Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DragDropSupported As Byte

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


Handle Property

Handle Property
GuiEAIViewer3D Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


Height Property

Height Property
GuiEAIViewer3D Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


IconName Property

IconName Property
GuiEAIViewer3D Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


Id Property

Id Property
GuiEAIViewer3D Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


IsSymbolFont Property

IsSymbolFont Property
GuiEAIViewer3D Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


Left Property

Left Property
GuiEAIViewer3D Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


Modified Property

Modified Property
GuiEAIViewer3D Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


Name Property

Name Property
GuiEAIViewer3D Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


OcxEvents Property

OcxEvents Property
GuiEAIViewer3D Object : OcxEvents Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property OcxEvents As GuiCollection

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


Parent Property

Parent Property
GuiEAIViewer3D Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


ParentFrame Property

ParentFrame Property
GuiEAIViewer3D Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


ScreenLeft Property

ScreenLeft Property
GuiEAIViewer3D Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


ScreenTop Property

ScreenTop Property
GuiEAIViewer3D Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


SubType Property

SubType Property
GuiEAIViewer3D Object : SubType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property SubType As String

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


Text Property

Text Property
GuiEAIViewer3D Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


Tooltip Property

Tooltip Property
GuiEAIViewer3D Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


Top Property

Top Property
GuiEAIViewer3D Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


Type Property

Type Property
GuiEAIViewer3D Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


TypeAsNumber Property

TypeAsNumber Property
GuiEAIViewer3D Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


Width Property

Width Property
GuiEAIViewer3D Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiEAIViewer3D Object | GuiEAIViewer3D Members


GuiEnum Object

GuiEnum Object
See Also Members

Glossary Item Box

Object Model

GuiEnum Object

See Also

GuiEnum Members


GuiEnum Object Members

GuiEnum Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method Clone
Public Method Next
Public Method Reset
Public Method Skip

See Also

GuiEnum Object


Clone Method

Clone Method
ppenum
GuiEnum Object : Clone Method

Glossary Item Box

Syntax

Visual Basic
Public Function Clone( _
   ByRef ppenum As GuiEnum _
) As HResult

Parameters

ppenum

See Also

GuiEnum Object | GuiEnum Members


Next Method

Next Method
celt
rgvar
pceltFetched
GuiEnum Object : Next Method

Glossary Item Box

Syntax

Visual Basic
Public Function Next( _
   ByVal celt As ULong, _
   ByRef rgvar As Variant, _
   ByRef pceltFetched As ULong _
) As HResult

Parameters

celt
rgvar
pceltFetched

See Also

GuiEnum Object | GuiEnum Members


Reset Method

Reset Method
GuiEnum Object : Reset Method

Glossary Item Box

Syntax

Visual Basic
Public Function Reset() As HResult

See Also

GuiEnum Object | GuiEnum Members


Skip Method

Skip Method
celt
GuiEnum Object : Skip Method

Glossary Item Box

Syntax

Visual Basic
Public Function Skip( _
   ByVal celt As ULong _
) As HResult

Parameters

celt

See Also

GuiEnum Object | GuiEnum Members


GuiFrameWindow Object

GuiFrameWindow Object
See Also Members

Glossary Item Box

Description

A GuiFrameWindow is a high level visual object in the runtime hierarchy. It can be either the main window or a modal popup window. See the GuiMainWindow and GuiModalWindow sections for examples. GuiFrameWindow itself is an abstract interface. GuiFrameWindow extends GuiVContainer. The type prefix is wnd, the name is wnd plus the window number in square brackets.

Object Model

GuiFrameWindow ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiVComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiVComponent Object

See Also

GuiFrameWindow Members


GuiFrameWindow Object Members

GuiFrameWindow Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method Close | The function attempts to close the window. Trying to close the last main window of a session will not succeed immediately; the dialog ‘Do you really want to log off?’ will be displayed first.
Public Method CompBitmap | This method compares two bitmap files pixel by pixel.
Public Method DumpState |
Public Method FindAllByName |
Public Method FindAllByNameEx |
Public Method FindById |
Public Method FindByName |
Public Method FindByNameEx |
Public Method HardCopy | This function dumps a hardcopy of the window as a bitmap file to disk. The parameter is the name of the file. If the function succeeds, then the return value will be the fully qualified path of the file. If no path information is given, then the file will be written to the SapWorkDir.
Public Method HardCopyToMemory | This function returns a hardcopy of the window as a safe array of bytes.
Public Method Iconify | This will set a window to the iconified state. It is not possible to iconify a specific window of a session; both the main window and all existing modals will be iconfied.
Public Method IsVKeyAllowed | This function returns True if the virtual key VKey is currently available. The VKeys are defined in the menu painter.
Public Method JumpBackward |
Public Method JumpForward |
Public Method Maximize | This will maximize a window. It is not possible to maximize a modal window; it is always the main window which will be maximized.
Public Method Restore | This will restore a window from its iconified state. It is not possible to restore a specific window of a session; both the main window and all existing modals will be restored.
Public Method SendVKey | The virtual key VKey is executed on the window. The VKeys are defined in the menu painter.
Public Method SetFocus |
Public Method ShowMessageBox | This method shows the message box modal to the GuiFrameWindow. The title and text parameters set the title and text of the message box. The return value will be one of the MESSAGE_RESULT_* values.
Public Method TabBackward |
Public Method TabForward |
Public Method Visualize |

Public Properties

Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property Changeable |
Public Property Children |
Public Property ContainerType |
Public Property DefaultTooltip |
Public Property ElementVisualizationMode | When elementVisualizationMode is enabled, a hit test can be performed on SAP GUI by moving the cursor over the window. The hit event of the session is fired when a component was found at the mouse position.
Public Property GuiFocus | The systemFocus only supports dynpro elements. To receive information about the currently focussed ActiveX control you can access the guiFocus property.
Public Property Handle | This is the handle of the underlying window in Microsoft Windows.
Public Property Height |
Public Property Iconic | This property is True if the window is iconified. It is possible to execute script commands on an iconified window , but there may be undefined results, especially when controls are involved, as these may have invalid size settings.
Public Property IconName |
Public Property Id |
Public Property IsSymbolFont |
Public Property Left |
Public Property Modified |
Public Property Name |
Public Property Parent |
Public Property ParentFrame |
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property SystemFocus | The systemFocus specifies the component that the SAP system is currently seeing as being focussed. This value is only valid for dynpro elements and might therefore differ from the focus as seen on the frontend.
Public Property Text |
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property Width |
Public Property WorkingPaneHeight | This is the height of the working pane in character metric.
Public Property WorkingPaneWidth | This is the width of the working pane in character metric. The working pane is the area between the toolbars in the upper area of the window and the statusbar at the bottom of the window.

See Also

GuiFrameWindow Object


Close Method

Close Method
GuiFrameWindow Object : Close Method

Glossary Item Box

Description

The function attempts to close the window. Trying to close the last main window of a session will not succeed immediately; the dialog ‘Do you really want to log off?’ will be displayed first.

Syntax

Visual Basic
Public Sub Close()

See Also

GuiFrameWindow Object | GuiFrameWindow Members


CompBitmap Method

CompBitmap Method
Filename1
Filename2
GuiFrameWindow Object : CompBitmap Method

Glossary Item Box

Description

This method compares two bitmap files pixel by pixel.

Syntax

Visual Basic
Public Function CompBitmap( _
   ByVal Filename1 As String, _
   ByVal Filename2 As String _
) As Long

Parameters

Filename1
Filename2

Return Type

The method returns one of the following values:

  • 0: The files do not differ
  • 1: The files differ in size
  • 2: The files have different content
  • 3: There was an error

Example

result = MyWindow.CompBitmap(file1, file2)

Select Case result
Case 0 MsgBox "Files " & file1 & " and " & file2 & " are equal", vbOKOnly & vbInformation, "File Comparison"
Case 1 MsgBox "Files " & file1 & " and " & file2 & " differ in size", vbOKOnly & vbCritical, "File Comparison"
Case 2 MsgBox "Files " & file1 & " and " & file2 & " differ in content", vbOKOnly & vbCritical, "File Comparison"
Case 3 MsgBox "Error comparing files " & file1 & " and " & file2, vbOKOnly & vbCritical, "File Comparison"
End Select

See Also

GuiFrameWindow Object | GuiFrameWindow Members


DumpState Method

DumpState Method
InnerObject
GuiFrameWindow Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiFrameWindow Object | GuiFrameWindow Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiFrameWindow Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiFrameWindow Object | GuiFrameWindow Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiFrameWindow Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiFrameWindow Object | GuiFrameWindow Members


FindById Method

FindById Method
Id
Raise
GuiFrameWindow Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiFrameWindow Object | GuiFrameWindow Members


FindByName Method

FindByName Method
Name
Type
GuiFrameWindow Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiFrameWindow Object | GuiFrameWindow Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiFrameWindow Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiFrameWindow Object | GuiFrameWindow Members


HardCopy Method

HardCopy Method
Filename
ImageType

The following values are valid:

  • 0: BMP
  • 1: JPG
  • 2: PNG
  • 3: GIF
  • 4: TIFF

BMP is the default format.

xPos
If the optional parameters xPos, yPos, nWidth and nHeight are set, only the specified rectangle of the main window will be captured.
yPos
If the optional parameters xPos, yPos, nWidth and nHeight are set, only the specified rectangle of the main window will be captured.
nWidth
If the optional parameters xPos, yPos, nWidth and nHeight are set, only the specified rectangle of the main window will be captured.
nHeight
If the optional parameters xPos, yPos, nWidth and nHeight are set, only the specified rectangle of the main window will be captured.
GuiFrameWindow Object : HardCopy Method

Glossary Item Box

Description

This function dumps a hardcopy of the window as a bitmap file to disk. The parameter is the name of the file. If the function succeeds, then the return value will be the fully qualified path of the file. If no path information is given, then the file will be written to the SapWorkDir.

Syntax

Visual Basic
Public Function HardCopy( _
   ByVal Filename As String, _
   Optional ByVal ImageType As Variant, _
   Optional ByVal xPos As Variant, _
   Optional ByVal yPos As Variant, _
   Optional ByVal nWidth As Variant, _
   Optional ByVal nHeight As Variant _
) As String

Parameters

Filename
ImageType

The following values are valid:

  • 0: BMP
  • 1: JPG
  • 2: PNG
  • 3: GIF
  • 4: TIFF

BMP is the default format.

xPos
If the optional parameters xPos, yPos, nWidth and nHeight are set, only the specified rectangle of the main window will be captured.
yPos
If the optional parameters xPos, yPos, nWidth and nHeight are set, only the specified rectangle of the main window will be captured.
nWidth
If the optional parameters xPos, yPos, nWidth and nHeight are set, only the specified rectangle of the main window will be captured.
nHeight
If the optional parameters xPos, yPos, nWidth and nHeight are set, only the specified rectangle of the main window will be captured.

See Also

GuiFrameWindow Object | GuiFrameWindow Members


HardCopyToMemory Method

HardCopyToMemory Method
ImageType

The following values are valid:

  • 0: BMP
  • 1: JPG
  • 2: PNG
  • 3: GIF

BMP is the default format.

GuiFrameWindow Object : HardCopyToMemory Method

Glossary Item Box

Description

This function returns a hardcopy of the window as a safe array of bytes.

Syntax

Visual Basic
Public Function HardCopyToMemory( _
   Optional ByVal ImageType As Variant _
) As Variant

Parameters

ImageType

The following values are valid:

  • 0: BMP
  • 1: JPG
  • 2: PNG
  • 3: GIF

BMP is the default format.

See Also

GuiFrameWindow Object | GuiFrameWindow Members


Iconify Method

Iconify Method
GuiFrameWindow Object : Iconify Method

Glossary Item Box

Description

This will set a window to the iconified state. It is not possible to iconify a specific window of a session; both the main window and all existing modals will be iconfied.

Syntax

Visual Basic
Public Sub Iconify()

See Also

GuiFrameWindow Object | GuiFrameWindow Members


IsVKeyAllowed Method

IsVKeyAllowed Method
VKey
GuiFrameWindow Object : IsVKeyAllowed Method

Glossary Item Box

Description

This function returns True if the virtual key VKey is currently available. The VKeys are defined in the menu painter.

Syntax

Visual Basic
Public Function IsVKeyAllowed( _
   ByVal VKey As Integer _
) As Byte

Parameters

VKey

See Also

GuiFrameWindow Object | GuiFrameWindow Members


JumpBackward Method

JumpBackward Method
GuiFrameWindow Object : JumpBackward Method

Glossary Item Box

Syntax

Visual Basic
Public Sub JumpBackward()

See Also

GuiFrameWindow Object | GuiFrameWindow Members


JumpForward Method

JumpForward Method
GuiFrameWindow Object : JumpForward Method

Glossary Item Box

Syntax

Visual Basic
Public Sub JumpForward()

See Also

GuiFrameWindow Object | GuiFrameWindow Members


Maximize Method

Maximize Method
GuiFrameWindow Object : Maximize Method

Glossary Item Box

Description

This will maximize a window. It is not possible to maximize a modal window; it is always the main window which will be maximized.

Syntax

Visual Basic
Public Sub Maximize()

See Also

GuiFrameWindow Object | GuiFrameWindow Members


Restore Method

Restore Method
GuiFrameWindow Object : Restore Method

Glossary Item Box

Description

This will restore a window from its iconified state. It is not possible to restore a specific window of a session; both the main window and all existing modals will be restored.

Syntax

Visual Basic
Public Sub Restore()

See Also

GuiFrameWindow Object | GuiFrameWindow Members


SendVKey Method

SendVKey Method
VKey
GuiFrameWindow Object : SendVKey Method

Glossary Item Box

Description

The virtual key VKey is executed on the window. The VKeys are defined in the menu painter.

Syntax

Visual Basic
Public Sub SendVKey( _
   ByVal VKey As Integer _
)

Parameters

VKey

See Also

GuiFrameWindow Object | GuiFrameWindow Members


SetFocus Method

SetFocus Method
GuiFrameWindow Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiFrameWindow Object | GuiFrameWindow Members


ShowMessageBox Method

ShowMessageBox Method
Title
Text
MsgIcon
The msgIcon parameter sets the icon to be used for the message box and should be set to one of the MESSAGE_TYPE_* constants.
MsgType
msgType sets the buttons available on the message box and should be set to one of the MESSAGE_OPTION* constants.
GuiFrameWindow Object : ShowMessageBox Method

Glossary Item Box

Description

This method shows the message box modal to the GuiFrameWindow. The title and text parameters set the title and text of the message box. The return value will be one of the MESSAGE_RESULT_* values.

Syntax

Visual Basic
Public Function ShowMessageBox( _
   ByVal Title As String, _
   ByVal Text As String, _
   ByVal MsgIcon As Long, _
   ByVal MsgType As Long _
) As Long

Parameters

Title
Text
MsgIcon
The msgIcon parameter sets the icon to be used for the message box and should be set to one of the MESSAGE_TYPE_* constants.
MsgType
msgType sets the buttons available on the message box and should be set to one of the MESSAGE_OPTION* constants.

See Also

GuiFrameWindow Object | GuiFrameWindow Members


TabBackward Method

TabBackward Method
GuiFrameWindow Object : TabBackward Method

Glossary Item Box

Syntax

Visual Basic
Public Sub TabBackward()

See Also

GuiFrameWindow Object | GuiFrameWindow Members


TabForward Method

TabForward Method
GuiFrameWindow Object : TabForward Method

Glossary Item Box

Syntax

Visual Basic
Public Sub TabForward()

See Also

GuiFrameWindow Object | GuiFrameWindow Members


Visualize Method

Visualize Method
On
InnerObject
GuiFrameWindow Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiFrameWindow Object | GuiFrameWindow Members


AccLabelCollection Property

AccLabelCollection Property
GuiFrameWindow Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiFrameWindow Object | GuiFrameWindow Members


AccText Property

AccText Property
GuiFrameWindow Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiFrameWindow Object | GuiFrameWindow Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiFrameWindow Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiFrameWindow Object | GuiFrameWindow Members


AccTooltip Property

AccTooltip Property
GuiFrameWindow Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiFrameWindow Object | GuiFrameWindow Members


Changeable Property

Changeable Property
GuiFrameWindow Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiFrameWindow Object | GuiFrameWindow Members


Children Property

Children Property
GuiFrameWindow Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiFrameWindow Object | GuiFrameWindow Members


ContainerType Property

ContainerType Property
GuiFrameWindow Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiFrameWindow Object | GuiFrameWindow Members


DefaultTooltip Property

DefaultTooltip Property
GuiFrameWindow Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiFrameWindow Object | GuiFrameWindow Members


ElementVisualizationMode Property

ElementVisualizationMode Property
GuiFrameWindow Object : ElementVisualizationMode Property

Glossary Item Box

Description

When elementVisualizationMode is enabled, a hit test can be performed on SAP GUI by moving the cursor over the window. The hit event of the session is fired when a component was found at the mouse position.

Property type

Read-write property

Syntax

Visual Basic
Public Property ElementVisualizationMode As Byte

See Also

GuiFrameWindow Object | GuiFrameWindow Members


GuiFocus Property

GuiFocus Property
GuiFrameWindow Object : GuiFocus Property

Glossary Item Box

Description

The systemFocus only supports dynpro elements. To receive information about the currently focussed ActiveX control you can access the guiFocus property.

Property type

Read-only property

Syntax

Visual Basic
Public Property GuiFocus As GuiVComponent

See Also

GuiFrameWindow Object | GuiFrameWindow Members


Handle Property

Handle Property
GuiFrameWindow Object : Handle Property

Glossary Item Box

Description

This is the handle of the underlying window in Microsoft Windows.

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiFrameWindow Object | GuiFrameWindow Members


Height Property

Height Property
GuiFrameWindow Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiFrameWindow Object | GuiFrameWindow Members


Iconic Property

Iconic Property
GuiFrameWindow Object : Iconic Property

Glossary Item Box

Description

This property is True if the window is iconified. It is possible to execute script commands on an iconified window , but there may be undefined results, especially when controls are involved, as these may have invalid size settings.

Property type

Read-only property

Syntax

Visual Basic
Public Property Iconic As Byte

See Also

GuiFrameWindow Object | GuiFrameWindow Members


IconName Property

IconName Property
GuiFrameWindow Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiFrameWindow Object | GuiFrameWindow Members


Id Property

Id Property
GuiFrameWindow Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiFrameWindow Object | GuiFrameWindow Members


IsSymbolFont Property

IsSymbolFont Property
GuiFrameWindow Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiFrameWindow Object | GuiFrameWindow Members


Left Property

Left Property
GuiFrameWindow Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiFrameWindow Object | GuiFrameWindow Members


Modified Property

Modified Property
GuiFrameWindow Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiFrameWindow Object | GuiFrameWindow Members


Name Property

Name Property
GuiFrameWindow Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiFrameWindow Object | GuiFrameWindow Members


Parent Property

Parent Property
GuiFrameWindow Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiFrameWindow Object | GuiFrameWindow Members


ParentFrame Property

ParentFrame Property
GuiFrameWindow Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiFrameWindow Object | GuiFrameWindow Members


ScreenLeft Property

ScreenLeft Property
GuiFrameWindow Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiFrameWindow Object | GuiFrameWindow Members


ScreenTop Property

ScreenTop Property
GuiFrameWindow Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiFrameWindow Object | GuiFrameWindow Members


SystemFocus Property

SystemFocus Property
GuiFrameWindow Object : SystemFocus Property

Glossary Item Box

Description

The systemFocus specifies the component that the SAP system is currently seeing as being focussed. This value is only valid for dynpro elements and might therefore differ from the focus as seen on the frontend.

Property type

Read-only property

Syntax

Visual Basic
Public Property SystemFocus As GuiVComponent

See Also

GuiFrameWindow Object | GuiFrameWindow Members


Text Property

Text Property
GuiFrameWindow Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiFrameWindow Object | GuiFrameWindow Members


Tooltip Property

Tooltip Property
GuiFrameWindow Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiFrameWindow Object | GuiFrameWindow Members


Top Property

Top Property
GuiFrameWindow Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiFrameWindow Object | GuiFrameWindow Members


Type Property

Type Property
GuiFrameWindow Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiFrameWindow Object | GuiFrameWindow Members


TypeAsNumber Property

TypeAsNumber Property
GuiFrameWindow Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiFrameWindow Object | GuiFrameWindow Members


Width Property

Width Property
GuiFrameWindow Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiFrameWindow Object | GuiFrameWindow Members


WorkingPaneHeight Property

WorkingPaneHeight Property
GuiFrameWindow Object : WorkingPaneHeight Property

Glossary Item Box

Description

This is the height of the working pane in character metric.

Property type

Read-only property

Syntax

Visual Basic
Public Property WorkingPaneHeight As Long

See Also

GuiFrameWindow Object | GuiFrameWindow Members


WorkingPaneWidth Property

WorkingPaneWidth Property
GuiFrameWindow Object : WorkingPaneWidth Property

Glossary Item Box

Description

This is the width of the working pane in character metric. The working pane is the area between the toolbars in the upper area of the window and the statusbar at the bottom of the window.

Property type

Read-only property

Syntax

Visual Basic
Public Property WorkingPaneWidth As Long

See Also

GuiFrameWindow Object | GuiFrameWindow Members


GuiGOSShell Object

GuiGOSShell Object
See Also Members

Glossary Item Box

Description

The GuiGosShell is only available in New Visual Design mode. GuiGOSShell extends GuiVContainer. The type prefix is shellcont, the name is the last part of the id, shellcont[n].

Object Model

GuiGOSShell ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent Object

Example

Transaction me22:

The GOS shell is a child of the titlebar and will contain another shell, in this example a toolbar control.

See Also

GuiGOSShell Members


GuiGOSShell Object Members

GuiGOSShell Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property Children
Public Property ContainerType
Public Property DefaultTooltip
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiGOSShell Object


DumpState Method

DumpState Method
InnerObject
GuiGOSShell Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiGOSShell Object | GuiGOSShell Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiGOSShell Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiGOSShell Object | GuiGOSShell Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiGOSShell Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiGOSShell Object | GuiGOSShell Members


FindById Method

FindById Method
Id
Raise
GuiGOSShell Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiGOSShell Object | GuiGOSShell Members


FindByName Method

FindByName Method
Name
Type
GuiGOSShell Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiGOSShell Object | GuiGOSShell Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiGOSShell Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiGOSShell Object | GuiGOSShell Members


SetFocus Method

SetFocus Method
GuiGOSShell Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiGOSShell Object | GuiGOSShell Members


ShowContextMenu Method

ShowContextMenu Method
GuiGOSShell Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiGOSShell Object | GuiGOSShell Members


Visualize Method

Visualize Method
On
InnerObject
GuiGOSShell Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiGOSShell Object | GuiGOSShell Members


AccLabelCollection Property

AccLabelCollection Property
GuiGOSShell Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiGOSShell Object | GuiGOSShell Members


AccText Property

AccText Property
GuiGOSShell Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiGOSShell Object | GuiGOSShell Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiGOSShell Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiGOSShell Object | GuiGOSShell Members


AccTooltip Property

AccTooltip Property
GuiGOSShell Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiGOSShell Object | GuiGOSShell Members


Changeable Property

Changeable Property
GuiGOSShell Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiGOSShell Object | GuiGOSShell Members


Children Property

Children Property
GuiGOSShell Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiGOSShell Object | GuiGOSShell Members


ContainerType Property

ContainerType Property
GuiGOSShell Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiGOSShell Object | GuiGOSShell Members


DefaultTooltip Property

DefaultTooltip Property
GuiGOSShell Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiGOSShell Object | GuiGOSShell Members


Height Property

Height Property
GuiGOSShell Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiGOSShell Object | GuiGOSShell Members


IconName Property

IconName Property
GuiGOSShell Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiGOSShell Object | GuiGOSShell Members


Id Property

Id Property
GuiGOSShell Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiGOSShell Object | GuiGOSShell Members


IsSymbolFont Property

IsSymbolFont Property
GuiGOSShell Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiGOSShell Object | GuiGOSShell Members


Left Property

Left Property
GuiGOSShell Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiGOSShell Object | GuiGOSShell Members


Modified Property

Modified Property
GuiGOSShell Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiGOSShell Object | GuiGOSShell Members


Name Property

Name Property
GuiGOSShell Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiGOSShell Object | GuiGOSShell Members


Parent Property

Parent Property
GuiGOSShell Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiGOSShell Object | GuiGOSShell Members


ParentFrame Property

ParentFrame Property
GuiGOSShell Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiGOSShell Object | GuiGOSShell Members


ScreenLeft Property

ScreenLeft Property
GuiGOSShell Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiGOSShell Object | GuiGOSShell Members


ScreenTop Property

ScreenTop Property
GuiGOSShell Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiGOSShell Object | GuiGOSShell Members


Text Property

Text Property
GuiGOSShell Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiGOSShell Object | GuiGOSShell Members


Tooltip Property

Tooltip Property
GuiGOSShell Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiGOSShell Object | GuiGOSShell Members


Top Property

Top Property
GuiGOSShell Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiGOSShell Object | GuiGOSShell Members


Type Property

Type Property
GuiGOSShell Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiGOSShell Object | GuiGOSShell Members


TypeAsNumber Property

TypeAsNumber Property
GuiGOSShell Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiGOSShell Object | GuiGOSShell Members


Width Property

Width Property
GuiGOSShell Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiGOSShell Object | GuiGOSShell Members


GuiGraphAdapt Object

GuiGraphAdapt Object
See Also Members

Glossary Item Box

Description

For the graphic adapter control only basic members from GuiShell are available. Recording and playback is not possible.

Object Model

GuiGraphAdapt ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiComponent ObjectGuiComponent Object

Remarks

In addition to the new, activeX based controls SAP GUI also comes with a set of external graphics executables, for example to display a GANTT chart. These executables are not supported within the API. If during the execution of a script one of these executables is launched, then the script will be blocked.

If you need to automate a process during which a graphics executable is displayed, then you need an automation tool then allows you to both manipulate SAP GUI using the Scripting API, and other Windows applications using native methods.

There are many automation tools on the market that come with these features. The sample script below was written for WinBatch from Wilson WindowWare.

Open and close a graphics executable

This WinBatch script automates SAP GUI to open an external graphics executable and then closes the executable using WinBatch functions.

SapGuiAuto = ObjectGet("SAPGUI");

Application = SapGuiAuto.GetScriptingEngine;

AllConnections = Application.Children;
Connection = AllConnections.ElementAt(0);

AllSessions = Connection.Children;
Session = AllSessions.ElementAt(0);

session.findById("wnd[0]/tbar[0]/okcd").text = "/nse38";
session.findById("wnd[0]").sendVKey(0);

session.findById("wnd[0]/usr/ctxtRS38M-PROGRAMM").text = "GRGANT_1";
session.findById("wnd[0]").sendVKey(8);

session.findById("wnd[0]/tbar[1]/btn[8]").press(); At this point the graphics

                                                 ; executable is displayed

WinClose( "Studio-Disposition" );

session.findById("wnd[0]/tbar[0]/okcd").text = "/n";
session.findById("wnd[0]").sendVKey(0);

Message ("My Script", "Done");

See Also

GuiGraphAdapt Members


GuiGraphAdapt Object Members

GuiGraphAdapt Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method SelectContextMenuItem
Public Method SelectContextMenuItemByPosition
Public Method SelectContextMenuItemByText
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccDescription
Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property Children
Public Property ContainerType
Public Property CurrentContextMenu
Public Property DefaultTooltip
Public Property DragDropSupported
Public Property Handle
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property OcxEvents
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property SubType
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiGraphAdapt Object


DumpState Method

DumpState Method
InnerObject
GuiGraphAdapt Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiGraphAdapt Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiGraphAdapt Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


FindById Method

FindById Method
Id
Raise
GuiGraphAdapt Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


FindByName Method

FindByName Method
Name
Type
GuiGraphAdapt Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiGraphAdapt Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiGraphAdapt Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiGraphAdapt Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiGraphAdapt Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


SetFocus Method

SetFocus Method
GuiGraphAdapt Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


ShowContextMenu Method

ShowContextMenu Method
GuiGraphAdapt Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


Visualize Method

Visualize Method
On
InnerObject
GuiGraphAdapt Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


AccDescription Property

AccDescription Property
GuiGraphAdapt Object : AccDescription Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccDescription As String

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


AccLabelCollection Property

AccLabelCollection Property
GuiGraphAdapt Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


AccText Property

AccText Property
GuiGraphAdapt Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiGraphAdapt Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


AccTooltip Property

AccTooltip Property
GuiGraphAdapt Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


Changeable Property

Changeable Property
GuiGraphAdapt Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


Children Property

Children Property
GuiGraphAdapt Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


ContainerType Property

ContainerType Property
GuiGraphAdapt Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


CurrentContextMenu Property

CurrentContextMenu Property
GuiGraphAdapt Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


DefaultTooltip Property

DefaultTooltip Property
GuiGraphAdapt Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


DragDropSupported Property

DragDropSupported Property
GuiGraphAdapt Object : DragDropSupported Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DragDropSupported As Byte

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


Handle Property

Handle Property
GuiGraphAdapt Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


Height Property

Height Property
GuiGraphAdapt Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


IconName Property

IconName Property
GuiGraphAdapt Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


Id Property

Id Property
GuiGraphAdapt Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


IsSymbolFont Property

IsSymbolFont Property
GuiGraphAdapt Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


Left Property

Left Property
GuiGraphAdapt Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


Modified Property

Modified Property
GuiGraphAdapt Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


Name Property

Name Property
GuiGraphAdapt Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


OcxEvents Property

OcxEvents Property
GuiGraphAdapt Object : OcxEvents Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property OcxEvents As GuiCollection

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


Parent Property

Parent Property
GuiGraphAdapt Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


ParentFrame Property

ParentFrame Property
GuiGraphAdapt Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


ScreenLeft Property

ScreenLeft Property
GuiGraphAdapt Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


ScreenTop Property

ScreenTop Property
GuiGraphAdapt Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


SubType Property

SubType Property
GuiGraphAdapt Object : SubType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property SubType As String

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


Text Property

Text Property
GuiGraphAdapt Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


Tooltip Property

Tooltip Property
GuiGraphAdapt Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


Top Property

Top Property
GuiGraphAdapt Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


Type Property

Type Property
GuiGraphAdapt Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


TypeAsNumber Property

TypeAsNumber Property
GuiGraphAdapt Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


Width Property

Width Property
GuiGraphAdapt Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiGraphAdapt Object | GuiGraphAdapt Members


GuiGridView Object

GuiGridView Object
See Also Members

Glossary Item Box

Description

The grid view is similar to the dynpro table control, but significantly more powerful. GuiGridView extends GuiShell.

Object Model

GuiGridView ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiComponent ObjectGuiComponent Object

Example

See Also

GuiGridView Members


GuiGridView Object Members

GuiGridView Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method ClearSelection | Calling clearSelection removes all row, column and cell selections.
Public Method Click | This function emulates a mouse click on a given cell if the parameters are valid and raises an exception otherwise.
Public Method ClickCurrentCell | This function emulates a mouse click on the current cell.
Public Method ContextMenu | Calling contextMenu emulates the context menu request.
Public Method CurrentCellMoved | This function notifies the server that a different cell has been made the current cell. It must be called whenever the current cell is changed.
Public Method DeleteRows | The parameter rows is a comma separated string of indices or index ranges, for example “3,5-8,14,15”. The entries must be ordered and not overlap, otherwise an exception is raised.
Public Method DeselectColumn | This function removes the specified column from the collection of the selected columns.
Public Method DoubleClick | This function emulates a mouse double click on a given cell if the parameters are valid and raises an exception otherwise.
Public Method DoubleClickCurrentCell | This function emulates a mouse double click on the current cell.
Public Method DumpState
Public Method DuplicateRows | The parameter rows is a comma separated string of indices or index ranges, for example “3,5-8,14,15”. For any single index a copy of the row will be inserted at the given index. If a range of indexes is duplicated then all the new lines are inserted as one block, before the old lines. The entries must be ordered and not overlap, otherwise an exception is raised.
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method GetCellChangeable | This function returns True if the specified cell is changeable.
Public Method GetCellCheckBoxChecked | Returns True if the checkbox at the specified position is checked. Throws an exception if there is no checkbox in the specified cell.
Public Method GetCellColor | Returns an identifier for the color of the cell. This can be used to retrieve the color information using GetColorInfo.
Public Method GetCellHeight | Return the height of the cell in pixels.
Public Method GetCellIcon | Return the icon string of the cell, if the cell contains an icon. The string has the ABAP icon format '@xy@', where xy is a number or character.
Public Method GetCellLeft | Returns the left position of the cell in client coordinates.
Public Method GetCellMaxLength | Returns the maximum length of the cell in number of bytes.
Public Method GetCellState

Returns the state of the cell. Possible values are:

  • Normal
  • Error
  • Warning
  • Info
Public Method GetCellTooltip | Returns the tooltip of the cell.
Public Method GetCellTop | Returns the top position of the cell in client coordinates.
Public Method GetCellType

This function returns the type of the specified cell. Possible values are:

  • Normal
  • Button
  • Checkbox
  • ValueList
  • RadioButton
Public Method GetCellValue | This function returns the value of the specified cell.
Public Method GetCellWidth | Returns the width of the cell in pixels.
Public Method GetColorInfo | Returns the description for the color of the cell.
Public Method GetColumnDataType | Returns the data type of the column according to the 'built-in datatypes' of the XML schema standard.
Public Method GetColumnPosition | Returns the position of the column as shown on the screen, starting from 1.
Public Method GetColumnSortType

Returns the sort type of the column. Possible values are:

  • None
  • Ascending
  • Descending
Public Method GetColumnTitles | This function returns a collection of strings that are used to display the title of a column. The control chooses the appropriate title according to the width of the column.
Public Method GetColumnTooltip | The tooltip of a column contains a text which is designed to help the user understands the meaning of the column.
Public Method GetColumnTotalType

Returns the total type of the column. Possible values are:

  • None
  • Total
  • Subtotal
Public Method GetDisplayedColumnTitle | This function returns the title of the column that is currently displayed. This text is one of the values of the collection returned from the function “getColumnTitles”.
Public Method GetRowTotalLevel | Returns the level of the row.
Public Method GetSymbolInfo | Returns the description for the symbol in the cell.
Public Method GetToolbarButtonChecked | Returns True if the button is currently checked (pressed).
Public Method GetToolbarButtonEnabled | Indicates if the button can be pressed.
Public Method GetToolbarButtonIcon | Returns the name of the icon of the specified toolbar button.
Public Method GetToolbarButtonId | Returns the ID of the specified toolbar button, as defined in the ABAP data dictionary.
Public Method GetToolbarButtonText | Returns the text of the specified toolbar button.
Public Method GetToolbarButtonTooltip | Returns the tooltip of the specified toolbar button.
Public Method GetToolbarButtonType Returns the type of the specified toolbar button. Possible values are:
"Button", "ButtonAndMenu", "Menu", "Separator", "Group", "CheckBox"
Public Method GetToolbarFocusButton | Returns the position of the toolbar button that has the focus. If no button in the toolbar has the focus, the method returns -1.
Public Method HasCellF4Help | Returns True if the cell has a value help.
Public Method InsertRows | The parameter rows is a comma separated text of indices or index ranges, for example “3,5-8,14,15”. For any single index, a new row will be added at the given index, moving the old row one line down. If a range of indexes is inserted then all the new lines are inserted as one block, before any of the old lines. The entries must be ordered and not overlap, otherwise, an exception is raised.
Public Method IsCellHotspot | Returns True if the cell is a link.
Public Method IsCellSymbol | Returns True if the text in the cell is displayed in the SAP symbol font.
Public Method IsCellTotalExpander | Returns True if the cell contains a total expander button.
Public Method IsColumnFiltered | Returns True if a filter was applied to the column.
Public Method IsColumnKey | Returns True if the column is marked as a key column.
Public Method IsTotalRowExpanded | Returns true if the row containing an expander is currently expanded.
Public Method ModifyCell | If row and column identify a valid editable cell and value has a valid type for this cell, then the value of the cell is changed. Otherwise, an exception is raised.
Public Method ModifyCheckBox | If row and column identify a valid editable cell containing a checkbox, then the value of the cell is changed. Otherwise, an exception is raised.
Public Method MoveRows The rows with an index greater than or equal to fromRow up to an index less than or equal to toRow are moved to the position of destRow .
Passing invalid index values as parameters raises an exception.
Public Method PressButton | This function emulates pressing a button placed in a given cell. It will raise an exception if the cell does not contain a button, or does not even exist.
Public Method PressButtonCurrentCell | This function emulates pressing a button placed in the current cell. It will raise an exception if the cell does not contain a button.
Public Method PressColumnHeader | This function emulates a mouse click on the header of the column if the parameter identifies a valid column and raises an exception otherwise.
Public Method PressEnter | This emulates pressing the Enter key.
Public Method PressF1 | This emulates pressing the F1 key while the focus is on the grid view.
Public Method PressF4 | This emulates pressing the F4 key.
Public Method PressToolbarButton | This function emulates clicking a button in the grid view’s toolbar.
Public Method PressToolbarContextButton | This emulates opening the context menu of the grid view’s toolbar.
Public Method PressTotalRow | Pressing the total row button expands or condenses the grouped rows. If the selected cell is not a total row cell an exception is raised.
Public Method PressTotalRowCurrentCell | This function differs from pressTotalRow only in that it tries to press the expansion button on the current cell.
Public Method SelectAll | This function selects the whole grid content (i.e. all rows and all columns).
Public Method SelectColumn | This function adds the specified column to the collection of the selected columns.
Public Method SelectContextMenuItem
Public Method SelectContextMenuItemByPosition
Public Method SelectContextMenuItemByText
Public Method SelectionChanged | This function notifies the server that the selection has changed.
Public Method SelectToolbarMenuItem | This function emulates the selection of an item from the context menu of the grid view’s toolbar. The parameter should be the function code of the item.
Public Method SetColumnWidth | The width of a column can be set using this function. The width is given in characters. For proportional fonts this refers to the width of an average character. Depending on the contents of the cell more or less characters may fit in the column. If the parameter is invalid an exception is raised.
Public Method SetCurrentCell | If row and column identify a valid cell, this cell becomes the current cell. Otherwise, an exception is raised.
Public Method SetFocus
Public Method ShowContextMenu
Public Method TriggerModified | Notifies the server of multiple changes in cells. Typically this method should be called after multiple calls to ModifyCell.
Public Method Visualize

Public Properties

Public Property AccDescription
Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property Children
Public Property ColumnCount | This property represents the number of columns in the control.
Public Property ColumnOrder | This collection contains all the column identifiers in the order in which they are currently displayed. Passing an invalid column identifier to this property will raise an exception.
Public Property ContainerType
Public Property CurrentCellColumn | The string identifying a column is the field name defined in the SAP data dictionary. In the example above the identifiers are named CARRID, CONNID, FLDATE, PRICE etc.
Public Property CurrentCellRow | The row index of the current cell ranges from 0 to the number of rows less 1, with -1 being the index of the title row.
Public Property CurrentContextMenu
Public Property DefaultTooltip
Public Property DragDropSupported
Public Property FirstVisibleColumn | This property represents the first visible column of the scrollable area of the grid view. Fixed columns are ignored. Setting the property to an invalid column identifier will raise an exception.
Public Property FirstVisibleRow | This is the index of the first visible row in the grid. Setting this property to an invalid row index will raise an exception.
Public Property FrozenColumnCount | This property represents the number of columns that are excluded from horizontal scrolling.
Public Property Handle
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property OcxEvents
Public Property Parent
Public Property ParentFrame
Public Property RowCount | This property represents the number of rows in the control.
Public Property ScreenLeft
Public Property ScreenTop
Public Property SelectedCells | The collection of selected cells contains strings, each of which has the format “<index of the row>,<column identifier>”, such as “0,CARRID”. Trying to set this property to an invalid value will raise an exception.
Public Property SelectedColumns | The selected columns are available as a collection of strings like the currentCellColumn string. Setting this property can raise an exception, if the new collection contains an invalid column identifier.
Public Property SelectedRows The string is a comma separated list of row index numbers or index ranges, such as “1,2,4-8,10”.
Setting this property to an invalid string or a string containing invalid row indices will raise an exception.
Public Property SelectionMode

Possible values are:

  • “RowsAndColumns”: Only rows and columns can be selected. Individual rectangular areas of cells are not allowed.
  • “ListboxSingle”: Only one single row can be selected.
  • “ListboxMultiple”: One or more rows can be selected.
  • “Free”: Any kind of selection can be made.
Public Property SubType | This property has the constant value “GridView”.
Public Property Text
Public Property Title | This property represents title of the grid control.
Public Property ToolbarButtonCount | The number of toolbar buttons including separators.
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property VisibleRowCount | Retrieves the number of visible rows of the grid.
Public Property Width

See Also

GuiGridView Object


ClearSelection Method

ClearSelection Method
GuiGridView Object : ClearSelection Method

Glossary Item Box

Description

Calling clearSelection removes all row, column and cell selections.

Syntax

Visual Basic
Public Sub ClearSelection()

See Also

GuiGridView Object | GuiGridView Members


Click Method

Click Method
Row
Column
GuiGridView Object : Click Method

Glossary Item Box

Description

This function emulates a mouse click on a given cell if the parameters are valid and raises an exception otherwise.

Syntax

Visual Basic
Public Sub Click( _
   ByVal Row As Long, _
   ByVal Column As String _
)

Parameters

Row
Column

See Also

GuiGridView Object | GuiGridView Members


ClickCurrentCell Method

ClickCurrentCell Method
GuiGridView Object : ClickCurrentCell Method

Glossary Item Box

Description

This function emulates a mouse click on the current cell.

Syntax

Visual Basic
Public Sub ClickCurrentCell()

See Also

GuiGridView Object | GuiGridView Members


ContextMenu Method

ContextMenu Method
GuiGridView Object : ContextMenu Method

Glossary Item Box

Description

Calling contextMenu emulates the context menu request.

Syntax

Visual Basic
Public Sub ContextMenu()

See Also

GuiGridView Object | GuiGridView Members


CurrentCellMoved Method

CurrentCellMoved Method
GuiGridView Object : CurrentCellMoved Method

Glossary Item Box

Description

This function notifies the server that a different cell has been made the current cell. It must be called whenever the current cell is changed.

Syntax

Visual Basic
Public Sub CurrentCellMoved()

See Also

GuiGridView Object | GuiGridView Members


DeleteRows Method

DeleteRows Method
Rows
GuiGridView Object : DeleteRows Method

Glossary Item Box

Description

The parameter rows is a comma separated string of indices or index ranges, for example “3,5-8,14,15”. The entries must be ordered and not overlap, otherwise an exception is raised.

Syntax

Visual Basic
Public Sub DeleteRows( _
   ByVal Rows As String _
)

Parameters

Rows

See Also

GuiGridView Object | GuiGridView Members


DeselectColumn Method

DeselectColumn Method
Column
GuiGridView Object : DeselectColumn Method

Glossary Item Box

Description

This function removes the specified column from the collection of the selected columns.

Syntax

Visual Basic
Public Sub DeselectColumn( _
   ByVal Column As String _
)

Parameters

Column

See Also

GuiGridView Object | GuiGridView Members


DoubleClick Method

DoubleClick Method
Row
Column
GuiGridView Object : DoubleClick Method

Glossary Item Box

Description

This function emulates a mouse double click on a given cell if the parameters are valid and raises an exception otherwise.

Syntax

Visual Basic
Public Sub DoubleClick( _
   ByVal Row As Long, _
   ByVal Column As String _
)

Parameters

Row
Column

See Also

GuiGridView Object | GuiGridView Members


DoubleClickCurrentCell Method

DoubleClickCurrentCell Method
GuiGridView Object : DoubleClickCurrentCell Method

Glossary Item Box

Description

This function emulates a mouse double click on the current cell.

Syntax

Visual Basic
Public Sub DoubleClickCurrentCell()

See Also

GuiGridView Object | GuiGridView Members


DumpState Method

DumpState Method
InnerObject
GuiGridView Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

Remarks

The GridView accepts the following values as “innerObject”:

  • "Toolbar": The returned GuiCollection contains information about the grid’s toolbar.
  • “Cell(row,column)”: The values of “row” and “column” must identify a cell of the grid (e.g. “Cell(2,PRICE)”). The returned GuiCollection contains information about the referenced cell.

See Also

GuiGridView Object | GuiGridView Members


DuplicateRows Method

DuplicateRows Method
Rows
GuiGridView Object : DuplicateRows Method

Glossary Item Box

Description

The parameter rows is a comma separated string of indices or index ranges, for example “3,5-8,14,15”. For any single index a copy of the row will be inserted at the given index. If a range of indexes is duplicated then all the new lines are inserted as one block, before the old lines. The entries must be ordered and not overlap, otherwise an exception is raised.

Syntax

Visual Basic
Public Sub DuplicateRows( _
   ByVal Rows As String _
)

Parameters

Rows

Example

0 | Value A
1 | Value B

If rows is “0,1” then the resulting table would be:

0 | Value A
1 | Value A
2 | Value B
3 | Value B

If on the other hand rows is “0-1” then the resulting table is:

0 | Value A
1 | Value B
2 | Value A
3 | Value B

See Also

GuiGridView Object | GuiGridView Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiGridView Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiGridView Object | GuiGridView Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiGridView Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiGridView Object | GuiGridView Members


FindById Method

FindById Method
Id
Raise
GuiGridView Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiGridView Object | GuiGridView Members


FindByName Method

FindByName Method
Name
Type
GuiGridView Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiGridView Object | GuiGridView Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiGridView Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiGridView Object | GuiGridView Members


GetCellChangeable Method

GetCellChangeable Method
Row
Column
GuiGridView Object : GetCellChangeable Method

Glossary Item Box

Description

This function returns True if the specified cell is changeable.

Syntax

Visual Basic
Public Function GetCellChangeable( _
   ByVal Row As Long, _
   ByVal Column As String _
) As Byte

Parameters

Row
Column

See Also

GuiGridView Object | GuiGridView Members


GetCellCheckBoxChecked Method

GetCellCheckBoxChecked Method
Row
Column
GuiGridView Object : GetCellCheckBoxChecked Method

Glossary Item Box

Description

Returns True if the checkbox at the specified position is checked. Throws an exception if there is no checkbox in the specified cell.

Syntax

Visual Basic
Public Function GetCellCheckBoxChecked( _
   ByVal Row As Long, _
   ByVal Column As String _
) As Byte

Parameters

Row
Column

See Also

GuiGridView Object | GuiGridView Members


GetCellColor Method

GetCellColor Method
Row
Column
GuiGridView Object : GetCellColor Method

Glossary Item Box

Description

Returns an identifier for the color of the cell. This can be used to retrieve the color information using GetColorInfo.

Syntax

Visual Basic
Public Function GetCellColor( _
   ByVal Row As Long, _
   ByVal Column As String _
) As Long

Parameters

Row
Column

See Also

GuiGridView Object | GuiGridView Members


GetCellHeight Method

GetCellHeight Method
Row
Column
GuiGridView Object : GetCellHeight Method

Glossary Item Box

Description

Return the height of the cell in pixels.

Syntax

Visual Basic
Public Function GetCellHeight( _
   ByVal Row As Long, _
   ByVal Column As String _
) As Long

Parameters

Row
Column

See Also

GuiGridView Object | GuiGridView Members


GetCellIcon Method

GetCellIcon Method
Row
Column
GuiGridView Object : GetCellIcon Method

Glossary Item Box

Description

Return the icon string of the cell, if the cell contains an icon. The string has the ABAP icon format '@xy@', where xy is a number or character.

Syntax

Visual Basic
Public Function GetCellIcon( _
   ByVal Row As Long, _
   ByVal Column As String _
) As String

Parameters

Row
Column

See Also

GuiGridView Object | GuiGridView Members


GetCellLeft Method

GetCellLeft Method
Row
Column
GuiGridView Object : GetCellLeft Method

Glossary Item Box

Description

Returns the left position of the cell in client coordinates.

Syntax

Visual Basic
Public Function GetCellLeft( _
   ByVal Row As Long, _
   ByVal Column As String _
) As Long

Parameters

Row
Column

See Also

GuiGridView Object | GuiGridView Members


GetCellMaxLength Method

GetCellMaxLength Method
Row
Column
GuiGridView Object : GetCellMaxLength Method

Glossary Item Box

Description

Returns the maximum length of the cell in number of bytes.

Syntax

Visual Basic
Public Function GetCellMaxLength( _
   ByVal Row As Long, _
   ByVal Column As String _
) As Long

Parameters

Row
Column

See Also

GuiGridView Object | GuiGridView Members


GetCellState Method

GetCellState Method
Row
Column
GuiGridView Object : GetCellState Method

Glossary Item Box

Description

Returns the state of the cell. Possible values are:

  • Normal
  • Error
  • Warning
  • Info

Syntax

Visual Basic
Public Function GetCellState( _
   ByVal Row As Long, _
   ByVal Column As String _
) As String

Parameters

Row
Column

See Also

GuiGridView Object | GuiGridView Members


GetCellTooltip Method

GetCellTooltip Method
Row
Column
GuiGridView Object : GetCellTooltip Method

Glossary Item Box

Description

Returns the tooltip of the cell.

Syntax

Visual Basic
Public Function GetCellTooltip( _
   ByVal Row As Long, _
   ByVal Column As String _
) As String

Parameters

Row
Column

See Also

GuiGridView Object | GuiGridView Members


GetCellTop Method

GetCellTop Method
Row
Column
GuiGridView Object : GetCellTop Method

Glossary Item Box

Description

Returns the top position of the cell in client coordinates.

Syntax

Visual Basic
Public Function GetCellTop( _
   ByVal Row As Long, _
   ByVal Column As String _
) As Long

Parameters

Row
Column

See Also

GuiGridView Object | GuiGridView Members


GetCellType Method

GetCellType Method
Row
Column
GuiGridView Object : GetCellType Method

Glossary Item Box

Description

This function returns the type of the specified cell. Possible values are:

  • Normal
  • Button
  • Checkbox
  • ValueList
  • RadioButton

Syntax

Visual Basic
Public Function GetCellType( _
   ByVal Row As Long, _
   ByVal Column As String _
) As String

Parameters

Row
Column

See Also

GuiGridView Object | GuiGridView Members


GetCellValue Method

GetCellValue Method
Row
Column
GuiGridView Object : GetCellValue Method

Glossary Item Box

Description

This function returns the value of the specified cell.

Syntax

Visual Basic
Public Function GetCellValue( _
   ByVal Row As Long, _
   ByVal Column As String _
) As String

Parameters

Row
Column

See Also

GuiGridView Object | GuiGridView Members


GetCellWidth Method

GetCellWidth Method
Row
Column
GuiGridView Object : GetCellWidth Method

Glossary Item Box

Description

Returns the width of the cell in pixels.

Syntax

Visual Basic
Public Function GetCellWidth( _
   ByVal Row As Long, _
   ByVal Column As String _
) As Long

Parameters

Row
Column

See Also

GuiGridView Object | GuiGridView Members


GetColorInfo Method

GetColorInfo Method
Color
Identifier returned by GetCellColor
GuiGridView Object : GetColorInfo Method

Glossary Item Box

Description

Returns the description for the color of the cell.

Syntax

Visual Basic
Public Function GetColorInfo( _
   ByVal Color As Long _
) As String

Parameters

Color
Identifier returned by GetCellColor

Remarks

This function will only return a value when the accessibility mode of SAP GUI is enabled.

See Also

GuiGridView Object | GuiGridView Members


GetColumnDataType Method

GetColumnDataType Method
Column
GuiGridView Object : GetColumnDataType Method

Glossary Item Box

Description

Returns the data type of the column according to the 'built-in datatypes' of the XML schema standard.

Syntax

Visual Basic
Public Function GetColumnDataType( _
   ByVal Column As String _
) As String

Parameters

Column

See Also

GuiGridView Object | GuiGridView Members


GetColumnPosition Method

GetColumnPosition Method
Column
GuiGridView Object : GetColumnPosition Method

Glossary Item Box

Description

Returns the position of the column as shown on the screen, starting from 1.

Syntax

Visual Basic
Public Function GetColumnPosition( _
   ByVal Column As String _
) As Long

Parameters

Column

See Also

GuiGridView Object | GuiGridView Members


GetColumnSortType Method

GetColumnSortType Method
Column
GuiGridView Object : GetColumnSortType Method

Glossary Item Box

Description

Returns the sort type of the column. Possible values are:

  • None
  • Ascending
  • Descending

Syntax

Visual Basic
Public Function GetColumnSortType( _
   ByVal Column As String _
) As String

Parameters

Column

See Also

GuiGridView Object | GuiGridView Members


GetColumnTitles Method

GetColumnTitles Method
Column
GuiGridView Object : GetColumnTitles Method

Glossary Item Box

Description

This function returns a collection of strings that are used to display the title of a column. The control chooses the appropriate title according to the width of the column.

Syntax

Visual Basic
Public Function GetColumnTitles( _
   ByVal Column As String _
) As Object

Parameters

Column

See Also

GuiGridView Object | GuiGridView Members


GetColumnTooltip Method

GetColumnTooltip Method
Column
GuiGridView Object : GetColumnTooltip Method

Glossary Item Box

Description

The tooltip of a column contains a text which is designed to help the user understands the meaning of the column.

Syntax

Visual Basic
Public Function GetColumnTooltip( _
   ByVal Column As String _
) As String

Parameters

Column

See Also

GuiGridView Object | GuiGridView Members


GetColumnTotalType Method

GetColumnTotalType Method
Column
GuiGridView Object : GetColumnTotalType Method

Glossary Item Box

Description

Returns the total type of the column. Possible values are:

  • None
  • Total
  • Subtotal

Syntax

Visual Basic
Public Function GetColumnTotalType( _
   ByVal Column As String _
) As String

Parameters

Column

See Also

GuiGridView Object | GuiGridView Members


GetDisplayedColumnTitle Method

GetDisplayedColumnTitle Method
Column
GuiGridView Object : GetDisplayedColumnTitle Method

Glossary Item Box

Description

This function returns the title of the column that is currently displayed. This text is one of the values of the collection returned from the function “getColumnTitles”.

Syntax

Visual Basic
Public Function GetDisplayedColumnTitle( _
   ByVal Column As String _
) As String

Parameters

Column

See Also

GuiGridView Object | GuiGridView Members


GetRowTotalLevel Method

GetRowTotalLevel Method
Row
GuiGridView Object : GetRowTotalLevel Method

Glossary Item Box

Description

Returns the level of the row.

Syntax

Visual Basic
Public Function GetRowTotalLevel( _
   ByVal Row As Long _
) As Long

Parameters

Row

Example

In this example the level is visualized by the number of dots in the sum/total column.

See Also

GuiGridView Object | GuiGridView Members


GetSymbolInfo Method

GetSymbolInfo Method
Symbol
Value of the cell.
GuiGridView Object : GetSymbolInfo Method

Glossary Item Box

Description

Returns the description for the symbol in the cell.

Syntax

Visual Basic
Public Function GetSymbolInfo( _
   ByVal Symbol As String _
) As String

Parameters

Symbol
Value of the cell.

Remarks

This function will only return a value when the accessibility mode of SAP GUI is enabled.

See Also

GuiGridView Object | GuiGridView Members


GetToolbarButtonChecked Method

GetToolbarButtonChecked Method
ButtonPos
GuiGridView Object : GetToolbarButtonChecked Method

Glossary Item Box

Description

Returns True if the button is currently checked (pressed).

Syntax

Visual Basic
Public Function GetToolbarButtonChecked( _
   ByVal ButtonPos As Long _
) As Byte

Parameters

ButtonPos

See Also

GuiGridView Object | GuiGridView Members


GetToolbarButtonEnabled Method

GetToolbarButtonEnabled Method
ButtonPos
GuiGridView Object : GetToolbarButtonEnabled Method

Glossary Item Box

Description

Indicates if the button can be pressed.

Syntax

Visual Basic
Public Function GetToolbarButtonEnabled( _
   ByVal ButtonPos As Long _
) As Byte

Parameters

ButtonPos

See Also

GuiGridView Object | GuiGridView Members


GetToolbarButtonIcon Method

GetToolbarButtonIcon Method
ButtonPos
GuiGridView Object : GetToolbarButtonIcon Method

Glossary Item Box

Description

Returns the name of the icon of the specified toolbar button.

Syntax

Visual Basic
Public Function GetToolbarButtonIcon( _
   ByVal ButtonPos As Long _
) As String

Parameters

ButtonPos

See Also

GuiGridView Object | GuiGridView Members


GetToolbarButtonId Method

GetToolbarButtonId Method
ButtonPos
GuiGridView Object : GetToolbarButtonId Method

Glossary Item Box

Description

Returns the ID of the specified toolbar button, as defined in the ABAP data dictionary.

Syntax

Visual Basic
Public Function GetToolbarButtonId( _
   ByVal ButtonPos As Long _
) As String

Parameters

ButtonPos

See Also

GuiGridView Object | GuiGridView Members


GetToolbarButtonText Method

GetToolbarButtonText Method
ButtonPos
GuiGridView Object : GetToolbarButtonText Method

Glossary Item Box

Description

Returns the text of the specified toolbar button.

Syntax

Visual Basic
Public Function GetToolbarButtonText( _
   ByVal ButtonPos As Long _
) As String

Parameters

ButtonPos

See Also

GuiGridView Object | GuiGridView Members


GetToolbarButtonTooltip Method

GetToolbarButtonTooltip Method
ButtonPos
GuiGridView Object : GetToolbarButtonTooltip Method

Glossary Item Box

Description

Returns the tooltip of the specified toolbar button.

Syntax

Visual Basic
Public Function GetToolbarButtonTooltip( _
   ByVal ButtonPos As Long _
) As String

Parameters

ButtonPos

See Also

GuiGridView Object | GuiGridView Members


GetToolbarButtonType Method

GetToolbarButtonType Method
ButtonPos
GuiGridView Object : GetToolbarButtonType Method

Glossary Item Box

Description

Returns the type of the specified toolbar button. Possible values are:
"Button", "ButtonAndMenu", "Menu", "Separator", "Group", "CheckBox"

Syntax

Visual Basic
Public Function GetToolbarButtonType( _
   ByVal ButtonPos As Long _
) As String

Parameters

ButtonPos

See Also

GuiGridView Object | GuiGridView Members


GetToolbarFocusButton Method

GetToolbarFocusButton Method
GuiGridView Object : GetToolbarFocusButton Method

Glossary Item Box

Description

Returns the position of the toolbar button that has the focus. If no button in the toolbar has the focus, the method returns -1.

Syntax

Visual Basic
Public Function GetToolbarFocusButton() As Long

See Also

GuiGridView Object | GuiGridView Members


HasCellF4Help Method

HasCellF4Help Method
Row
Column
GuiGridView Object : HasCellF4Help Method

Glossary Item Box

Description

Returns True if the cell has a value help.

Syntax

Visual Basic
Public Function HasCellF4Help( _
   ByVal Row As Long, _
   ByVal Column As String _
) As Byte

Parameters

Row
Column

Example

See Also

GuiGridView Object | GuiGridView Members


InsertRows Method

InsertRows Method
Rows
GuiGridView Object : InsertRows Method

Glossary Item Box

Description

The parameter rows is a comma separated text of indices or index ranges, for example “3,5-8,14,15”. For any single index, a new row will be added at the given index, moving the old row one line down. If a range of indexes is inserted then all the new lines are inserted as one block, before any of the old lines. The entries must be ordered and not overlap, otherwise, an exception is raised.

Syntax

Visual Basic
Public Sub InsertRows( _
   ByVal Rows As String _
)

Parameters

Rows

Example

0 | Value A
1 | Value B

If rows is “0,1”, then the resulting table would be:

0 |
1 | Value A
2 |
3 | Value B

If, on the other hand, rows is “0-1”, then the resulting table is:

0 |
1 |
2 | Value A
3 | Value B

See Also

GuiGridView Object | GuiGridView Members


IsCellHotspot Method

IsCellHotspot Method
Row
Column
GuiGridView Object : IsCellHotspot Method

Glossary Item Box

Description

Returns True if the cell is a link.

Syntax

Visual Basic
Public Function IsCellHotspot( _
   ByVal Row As Long, _
   ByVal Column As String _
) As Byte

Parameters

Row
Column

Example

See Also

GuiGridView Object | GuiGridView Members


IsCellSymbol Method

IsCellSymbol Method
Row
Column
GuiGridView Object : IsCellSymbol Method

Glossary Item Box

Description

Returns True if the text in the cell is displayed in the SAP symbol font.

Syntax

Visual Basic
Public Function IsCellSymbol( _
   ByVal Row As Long, _
   ByVal Column As String _
) As Byte

Parameters

Row
Column

Example

See Also

GuiGridView Object | GuiGridView Members


IsCellTotalExpander Method

IsCellTotalExpander Method
Row
Column
GuiGridView Object : IsCellTotalExpander Method

Glossary Item Box

Description

Returns True if the cell contains a total expander button.

Syntax

Visual Basic
Public Function IsCellTotalExpander( _
   ByVal Row As Long, _
   ByVal Column As String _
) As Byte

Parameters

Row
Column

Example

See Also

GuiGridView Object | GuiGridView Members


IsColumnFiltered Method

IsColumnFiltered Method
Column
GuiGridView Object : IsColumnFiltered Method

Glossary Item Box

Description

Returns True if a filter was applied to the column.

Syntax

Visual Basic
Public Function IsColumnFiltered( _
   ByVal Column As String _
) As Byte

Parameters

Column

Example

See Also

GuiGridView Object | GuiGridView Members


IsColumnKey Method

IsColumnKey Method
Column
GuiGridView Object : IsColumnKey Method

Glossary Item Box

Description

Returns True if the column is marked as a key column.

Syntax

Visual Basic
Public Function IsColumnKey( _
   ByVal Column As String _
) As Byte

Parameters

Column

See Also

GuiGridView Object | GuiGridView Members


IsTotalRowExpanded Method

IsTotalRowExpanded Method
Row
GuiGridView Object : IsTotalRowExpanded Method

Glossary Item Box

Description

Returns true if the row containing an expander is currently expanded.

Syntax

Visual Basic
Public Function IsTotalRowExpanded( _
   ByVal Row As Long _
) As Byte

Parameters

Row

Example

Expanded:

Collapsed:

See Also

GuiGridView Object | GuiGridView Members


ModifyCell Method

ModifyCell Method
Row
Column
Value
GuiGridView Object : ModifyCell Method

Glossary Item Box

Description

If row and column identify a valid editable cell and value has a valid type for this cell, then the value of the cell is changed. Otherwise, an exception is raised.

Syntax

Visual Basic
Public Sub ModifyCell( _
   ByVal Row As Long, _
   ByVal Column As String, _
   ByVal Value As String _
)

Parameters

Row
Column
Value

See Also

GuiGridView Object | GuiGridView Members


ModifyCheckBox Method

ModifyCheckBox Method
Row
Column
Checked
GuiGridView Object : ModifyCheckBox Method

Glossary Item Box

Description

If row and column identify a valid editable cell containing a checkbox, then the value of the cell is changed. Otherwise, an exception is raised.

Syntax

Visual Basic
Public Sub ModifyCheckBox( _
   ByVal Row As Long, _
   ByVal Column As String, _
   ByVal Checked As Boolean _
)

Parameters

Row
Column
Checked

See Also

GuiGridView Object | GuiGridView Members


MoveRows Method

MoveRows Method
FromRow
ToRow
DestRow
GuiGridView Object : MoveRows Method

Glossary Item Box

Description

The rows with an index greater than or equal to fromRow up to an index less than or equal to toRow are moved to the position of destRow .
Passing invalid index values as parameters raises an exception.

Syntax

Visual Basic
Public Sub MoveRows( _
   ByVal FromRow As Long, _
   ByVal ToRow As Long, _
   ByVal DestRow As Long _
)

Parameters

FromRow
ToRow
DestRow

See Also

GuiGridView Object | GuiGridView Members


PressButton Method

PressButton Method
Row
Column
GuiGridView Object : PressButton Method

Glossary Item Box

Description

This function emulates pressing a button placed in a given cell. It will raise an exception if the cell does not contain a button, or does not even exist.

Syntax

Visual Basic
Public Sub PressButton( _
   ByVal Row As Long, _
   ByVal Column As String _
)

Parameters

Row
Column

See Also

GuiGridView Object | GuiGridView Members


PressButtonCurrentCell Method

PressButtonCurrentCell Method
GuiGridView Object : PressButtonCurrentCell Method

Glossary Item Box

Description

This function emulates pressing a button placed in the current cell. It will raise an exception if the cell does not contain a button.

Syntax

Visual Basic
Public Sub PressButtonCurrentCell()

See Also

GuiGridView Object | GuiGridView Members


PressColumnHeader Method

PressColumnHeader Method
Column
GuiGridView Object : PressColumnHeader Method

Glossary Item Box

Description

This function emulates a mouse click on the header of the column if the parameter identifies a valid column and raises an exception otherwise.

Syntax

Visual Basic
Public Sub PressColumnHeader( _
   ByVal Column As String _
)

Parameters

Column

See Also

GuiGridView Object | GuiGridView Members


PressEnter Method

PressEnter Method
GuiGridView Object : PressEnter Method

Glossary Item Box

Description

This emulates pressing the Enter key.

Syntax

Visual Basic
Public Sub PressEnter()

See Also

GuiGridView Object | GuiGridView Members


PressF1 Method

PressF1 Method
GuiGridView Object : PressF1 Method

Glossary Item Box

Description

This emulates pressing the F1 key while the focus is on the grid view.

Syntax

Visual Basic
Public Sub PressF1()

See Also

GuiGridView Object | GuiGridView Members


PressF4 Method

PressF4 Method
GuiGridView Object : PressF4 Method

Glossary Item Box

Description

This emulates pressing the F4 key.

Syntax

Visual Basic
Public Sub PressF4()

See Also

GuiGridView Object | GuiGridView Members


PressToolbarButton Method

PressToolbarButton Method
Id
GuiGridView Object : PressToolbarButton Method

Glossary Item Box

Description

This function emulates clicking a button in the grid view’s toolbar.

Syntax

Visual Basic
Public Sub PressToolbarButton( _
   ByVal Id As String _
)

Parameters

Id

See Also

GuiGridView Object | GuiGridView Members


PressToolbarContextButton Method

PressToolbarContextButton Method
Id
GuiGridView Object : PressToolbarContextButton Method

Glossary Item Box

Description

This emulates opening the context menu of the grid view’s toolbar.

Syntax

Visual Basic
Public Sub PressToolbarContextButton( _
   ByVal Id As String _
)

Parameters

Id

See Also

GuiGridView Object | GuiGridView Members


PressTotalRow Method

PressTotalRow Method
Row
Column
GuiGridView Object : PressTotalRow Method

Glossary Item Box

Description

Pressing the total row button expands or condenses the grouped rows. If the selected cell is not a total row cell an exception is raised.

Syntax

Visual Basic
Public Sub PressTotalRow( _
   ByVal Row As Long, _
   ByVal Column As String _
)

Parameters

Row
Column

Example

See Also

GuiGridView Object | GuiGridView Members


PressTotalRowCurrentCell Method

PressTotalRowCurrentCell Method
GuiGridView Object : PressTotalRowCurrentCell Method

Glossary Item Box

Description

This function differs from pressTotalRow only in that it tries to press the expansion button on the current cell.

Syntax

Visual Basic
Public Sub PressTotalRowCurrentCell()

See Also

GuiGridView Object | GuiGridView Members


SelectAll Method

SelectAll Method
GuiGridView Object : SelectAll Method

Glossary Item Box

Description

This function selects the whole grid content (i.e. all rows and all columns).

Syntax

Visual Basic
Public Sub SelectAll()

See Also

GuiGridView Object | GuiGridView Members


SelectColumn Method

SelectColumn Method
Column
GuiGridView Object : SelectColumn Method

Glossary Item Box

Description

This function adds the specified column to the collection of the selected columns.

Syntax

Visual Basic
Public Sub SelectColumn( _
   ByVal Column As String _
)

Parameters

Column

See Also

GuiGridView Object | GuiGridView Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiGridView Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiGridView Object | GuiGridView Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiGridView Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiGridView Object | GuiGridView Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiGridView Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

GuiGridView Object | GuiGridView Members


SelectionChanged Method

SelectionChanged Method
GuiGridView Object : SelectionChanged Method

Glossary Item Box

Description

This function notifies the server that the selection has changed.

Syntax

Visual Basic
Public Sub SelectionChanged()

See Also

GuiGridView Object | GuiGridView Members


SelectToolbarMenuItem Method

SelectToolbarMenuItem Method
Id
GuiGridView Object : SelectToolbarMenuItem Method

Glossary Item Box

Description

This function emulates the selection of an item from the context menu of the grid view’s toolbar. The parameter should be the function code of the item.

Syntax

Visual Basic
Public Sub SelectToolbarMenuItem( _
   ByVal Id As String _
)

Parameters

Id

See Also

GuiGridView Object | GuiGridView Members


SetColumnWidth Method

SetColumnWidth Method
Column
Width
GuiGridView Object : SetColumnWidth Method

Glossary Item Box

Description

The width of a column can be set using this function. The width is given in characters. For proportional fonts this refers to the width of an average character. Depending on the contents of the cell more or less characters may fit in the column. If the parameter is invalid an exception is raised.

Syntax

Visual Basic
Public Sub SetColumnWidth( _
   ByVal Column As String, _
   ByVal Width As Long _
)

Parameters

Column
Width

See Also

GuiGridView Object | GuiGridView Members


SetCurrentCell Method

SetCurrentCell Method
Row
Column
GuiGridView Object : SetCurrentCell Method

Glossary Item Box

Description

If row and column identify a valid cell, this cell becomes the current cell. Otherwise, an exception is raised.

Syntax

Visual Basic
Public Sub SetCurrentCell( _
   ByVal Row As Long, _
   ByVal Column As String _
)

Parameters

Row
Column

See Also

GuiGridView Object | GuiGridView Members


SetFocus Method

SetFocus Method
GuiGridView Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiGridView Object | GuiGridView Members


ShowContextMenu Method

ShowContextMenu Method
GuiGridView Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiGridView Object | GuiGridView Members


TriggerModified Method

TriggerModified Method
GuiGridView Object : TriggerModified Method

Glossary Item Box

Description

Notifies the server of multiple changes in cells. Typically this method should be called after multiple calls to ModifyCell.

Syntax

Visual Basic
Public Sub TriggerModified()

See Also

GuiGridView Object | GuiGridView Members


Visualize Method

Visualize Method
On
InnerObject
GuiGridView Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiGridView Object | GuiGridView Members


AccDescription Property

AccDescription Property
GuiGridView Object : AccDescription Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccDescription As String

See Also

GuiGridView Object | GuiGridView Members


AccLabelCollection Property

AccLabelCollection Property
GuiGridView Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiGridView Object | GuiGridView Members


AccText Property

AccText Property
GuiGridView Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiGridView Object | GuiGridView Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiGridView Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiGridView Object | GuiGridView Members


AccTooltip Property

AccTooltip Property
GuiGridView Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiGridView Object | GuiGridView Members


Changeable Property

Changeable Property
GuiGridView Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiGridView Object | GuiGridView Members


Children Property

Children Property
GuiGridView Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiGridView Object | GuiGridView Members


ColumnCount Property

ColumnCount Property
GuiGridView Object : ColumnCount Property

Glossary Item Box

Description

This property represents the number of columns in the control.

Property type

Read-only property

Syntax

Visual Basic
Public Property ColumnCount As Long

See Also

GuiGridView Object | GuiGridView Members


ColumnOrder Property

ColumnOrder Property
GuiGridView Object : ColumnOrder Property

Glossary Item Box

Description

This collection contains all the column identifiers in the order in which they are currently displayed. Passing an invalid column identifier to this property will raise an exception.

Property type

Read-write property

Syntax

Visual Basic
Public Property ColumnOrder As Object

See Also

GuiGridView Object | GuiGridView Members


ContainerType Property

ContainerType Property
GuiGridView Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiGridView Object | GuiGridView Members


CurrentCellColumn Property

CurrentCellColumn Property
GuiGridView Object : CurrentCellColumn Property

Glossary Item Box

Description

The string identifying a column is the field name defined in the SAP data dictionary. In the example above the identifiers are named CARRID, CONNID, FLDATE, PRICE etc.

Property type

Read-write property

Syntax

Visual Basic
Public Property CurrentCellColumn As String

See Also

GuiGridView Object | GuiGridView Members


CurrentCellRow Property

CurrentCellRow Property
GuiGridView Object : CurrentCellRow Property

Glossary Item Box

Description

The row index of the current cell ranges from 0 to the number of rows less 1, with -1 being the index of the title row.

Property type

Read-write property

Syntax

Visual Basic
Public Property CurrentCellRow As Long

See Also

GuiGridView Object | GuiGridView Members


CurrentContextMenu Property

CurrentContextMenu Property
GuiGridView Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

GuiGridView Object | GuiGridView Members


DefaultTooltip Property

DefaultTooltip Property
GuiGridView Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiGridView Object | GuiGridView Members


DragDropSupported Property

DragDropSupported Property
GuiGridView Object : DragDropSupported Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DragDropSupported As Byte

See Also

GuiGridView Object | GuiGridView Members


FirstVisibleColumn Property

FirstVisibleColumn Property
GuiGridView Object : FirstVisibleColumn Property

Glossary Item Box

Description

This property represents the first visible column of the scrollable area of the grid view. Fixed columns are ignored. Setting the property to an invalid column identifier will raise an exception.

Property type

Read-write property

Syntax

Visual Basic
Public Property FirstVisibleColumn As String

See Also

GuiGridView Object | GuiGridView Members


FirstVisibleRow Property

FirstVisibleRow Property
GuiGridView Object : FirstVisibleRow Property

Glossary Item Box

Description

This is the index of the first visible row in the grid. Setting this property to an invalid row index will raise an exception.

Property type

Read-write property

Syntax

Visual Basic
Public Property FirstVisibleRow As Long

See Also

GuiGridView Object | GuiGridView Members


FrozenColumnCount Property

FrozenColumnCount Property
GuiGridView Object : FrozenColumnCount Property

Glossary Item Box

Description

This property represents the number of columns that are excluded from horizontal scrolling.

Property type

Read-only property

Syntax

Visual Basic
Public Property FrozenColumnCount As Long

See Also

GuiGridView Object | GuiGridView Members


Handle Property

Handle Property
GuiGridView Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiGridView Object | GuiGridView Members


Height Property

Height Property
GuiGridView Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiGridView Object | GuiGridView Members


IconName Property

IconName Property
GuiGridView Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiGridView Object | GuiGridView Members


Id Property

Id Property
GuiGridView Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiGridView Object | GuiGridView Members


IsSymbolFont Property

IsSymbolFont Property
GuiGridView Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiGridView Object | GuiGridView Members


Left Property

Left Property
GuiGridView Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiGridView Object | GuiGridView Members


Modified Property

Modified Property
GuiGridView Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiGridView Object | GuiGridView Members


Name Property

Name Property
GuiGridView Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiGridView Object | GuiGridView Members


OcxEvents Property

OcxEvents Property
GuiGridView Object : OcxEvents Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property OcxEvents As GuiCollection

See Also

GuiGridView Object | GuiGridView Members


Parent Property

Parent Property
GuiGridView Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiGridView Object | GuiGridView Members


ParentFrame Property

ParentFrame Property
GuiGridView Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiGridView Object | GuiGridView Members


RowCount Property

RowCount Property
GuiGridView Object : RowCount Property

Glossary Item Box

Description

This property represents the number of rows in the control.

Property type

Read-only property

Syntax

Visual Basic
Public Property RowCount As Long

See Also

GuiGridView Object | GuiGridView Members


ScreenLeft Property

ScreenLeft Property
GuiGridView Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiGridView Object | GuiGridView Members


ScreenTop Property

ScreenTop Property
GuiGridView Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiGridView Object | GuiGridView Members


SelectedCells Property

SelectedCells Property
GuiGridView Object : SelectedCells Property

Glossary Item Box

Description

The collection of selected cells contains strings, each of which has the format “<index of the row>,<column identifier>”, such as “0,CARRID”. Trying to set this property to an invalid value will raise an exception.

Property type

Read-write property

Syntax

Visual Basic
Public Property SelectedCells As Object

See Also

GuiGridView Object | GuiGridView Members


SelectedColumns Property

SelectedColumns Property
GuiGridView Object : SelectedColumns Property

Glossary Item Box

Description

The selected columns are available as a collection of strings like the currentCellColumn string. Setting this property can raise an exception, if the new collection contains an invalid column identifier.

Property type

Read-write property

Syntax

Visual Basic
Public Property SelectedColumns As Object

See Also

GuiGridView Object | GuiGridView Members


SelectedRows Property

SelectedRows Property
GuiGridView Object : SelectedRows Property

Glossary Item Box

Description

The string is a comma separated list of row index numbers or index ranges, such as “1,2,4-8,10”.
Setting this property to an invalid string or a string containing invalid row indices will raise an exception.

Property type

Read-write property

Syntax

Visual Basic
Public Property SelectedRows As String

See Also

GuiGridView Object | GuiGridView Members


SelectionMode Property

SelectionMode Property
GuiGridView Object : SelectionMode Property

Glossary Item Box

Description

Possible values are:

  • “RowsAndColumns”: Only rows and columns can be selected. Individual rectangular areas of cells are not allowed.
  • “ListboxSingle”: Only one single row can be selected.
  • “ListboxMultiple”: One or more rows can be selected.
  • “Free”: Any kind of selection can be made.

Property type

Read-only property

Syntax

Visual Basic
Public Property SelectionMode As String

See Also

GuiGridView Object | GuiGridView Members


SubType Property

SubType Property
GuiGridView Object : SubType Property

Glossary Item Box

Description

This property has the constant value “GridView”.

Property type

Read-only property

Syntax

Visual Basic
Public Property SubType As String

See Also

GuiGridView Object | GuiGridView Members


Text Property

Text Property
GuiGridView Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiGridView Object | GuiGridView Members


Title Property

Title Property
GuiGridView Object : Title Property

Glossary Item Box

Description

This property represents title of the grid control.

Property type

Read-only property

Syntax

Visual Basic
Public Property Title As String

See Also

GuiGridView Object | GuiGridView Members


ToolbarButtonCount Property

ToolbarButtonCount Property
GuiGridView Object : ToolbarButtonCount Property

Glossary Item Box

Description

The number of toolbar buttons including separators.

Property type

Read-only property

Syntax

Visual Basic
Public Property ToolbarButtonCount As Long

See Also

GuiGridView Object | GuiGridView Members


Tooltip Property

Tooltip Property
GuiGridView Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiGridView Object | GuiGridView Members


Top Property

Top Property
GuiGridView Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiGridView Object | GuiGridView Members


Type Property

Type Property
GuiGridView Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiGridView Object | GuiGridView Members


TypeAsNumber Property

TypeAsNumber Property
GuiGridView Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiGridView Object | GuiGridView Members


VisibleRowCount Property

VisibleRowCount Property
GuiGridView Object : VisibleRowCount Property

Glossary Item Box

Description

Retrieves the number of visible rows of the grid.

Property type

Read-only property

Syntax

Visual Basic
Public Property VisibleRowCount As Long

See Also

GuiGridView Object | GuiGridView Members


Width Property

Width Property
GuiGridView Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiGridView Object | GuiGridView Members


GuiHTMLViewer Object

GuiHTMLViewer Object
See Also Members

Glossary Item Box

Description

The GuiHTMLViewer is used to display an HTML document inside SAP GUI. GuiHTMLViewer extends GuiShell.

Object Model

GuiHTMLViewer ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiComponent ObjectGuiComponent Object

See Also

GuiHTMLViewer Members


GuiHTMLViewer Object Members

GuiHTMLViewer Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method ContextMenu | Calling contextMenu emulates the context menu request. Note that this function applies only to context menus provided by the backend, not to the local context menu, which is generated by the HTML control.
Public Method DumpState |
Public Method FindAllByName |
Public Method FindAllByNameEx |
Public Method FindById |
Public Method FindByName |
Public Method FindByNameEx |
Public Method SapEvent | This function submits an HTML form to the backend.
Public Method SelectContextMenuItem |
Public Method SelectContextMenuItemByPosition |
Public Method SelectContextMenuItemByText |
Public Method SetFocus |
Public Method ShowContextMenu |
Public Method Visualize |

Public Properties

Public Property AccDescription |
Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property BrowserHandle |
Public Property Changeable |
Public Property Children |
Public Property ContainerType |
Public Property CurrentContextMenu |
Public Property DefaultTooltip |
Public Property DocumentComplete |
Public Property DragDropSupported |
Public Property Handle |
Public Property Height |
Public Property IconName |
Public Property Id |
Public Property IsSymbolFont |
Public Property Left |
Public Property Modified |
Public Property Name |
Public Property OcxEvents |
Public Property Parent |
Public Property ParentFrame |
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property SubType | This property has the constant value HTMLViewer.
Public Property Text |
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property Width |

See Also

GuiHTMLViewer Object


ContextMenu Method

ContextMenu Method
GuiHTMLViewer Object : ContextMenu Method

Glossary Item Box

Description

Calling contextMenu emulates the context menu request. Note that this function applies only to context menus provided by the backend, not to the local context menu, which is generated by the HTML control.

Syntax

Visual Basic
Public Sub ContextMenu()

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


DumpState Method

DumpState Method
InnerObject
GuiHTMLViewer Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiHTMLViewer Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiHTMLViewer Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


FindById Method

FindById Method
Id
Raise
GuiHTMLViewer Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


FindByName Method

FindByName Method
Name
Type
GuiHTMLViewer Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiHTMLViewer Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


SapEvent Method

SapEvent Method
FrameName
This is the name of the frame in which the HTML form that has been submitted lives.
PostData
Contains the form data when a submit is made using the POST method.
Url
This is the URL which is submitted to the backend. The protocol name for the URL string is “sapevent:”. This is followed by the name of the event as defined in the Action Property of the HTML form which is called.
GuiHTMLViewer Object : SapEvent Method

Glossary Item Box

Description

This function submits an HTML form to the backend.

Syntax

Visual Basic
Public Sub SapEvent( _
   ByVal FrameName As String, _
   ByVal PostData As String, _
   ByVal Url As String _
)

Parameters

FrameName
This is the name of the frame in which the HTML form that has been submitted lives.
PostData
Contains the form data when a submit is made using the POST method.
Url
This is the URL which is submitted to the backend. The protocol name for the URL string is “sapevent:”. This is followed by the name of the event as defined in the Action Property of the HTML form which is called.

Remarks

If the form is to be submitted using the GET method, the data is appended to the event name in the usual http URL fashion, for example:

sapEvent("Frame1","","sapevent:SUBMIT_FORM_AS_GET_METHOD?FirstName=John&LastName=Smith");

In this case, postData is always an empty string.

If the form is to be submitted using the POST method, the data is transported in the postData parameter:

sapEvent("Frame1","FirstName=John&LastName=Smith","sapevent:SUBMIT_FORM_AS_POST_METHOD");

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiHTMLViewer Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiHTMLViewer Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiHTMLViewer Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


SetFocus Method

SetFocus Method
GuiHTMLViewer Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


ShowContextMenu Method

ShowContextMenu Method
GuiHTMLViewer Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


Visualize Method

Visualize Method
On
InnerObject
GuiHTMLViewer Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


AccDescription Property

AccDescription Property
GuiHTMLViewer Object : AccDescription Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccDescription As String

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


AccLabelCollection Property

AccLabelCollection Property
GuiHTMLViewer Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


AccText Property

AccText Property
GuiHTMLViewer Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiHTMLViewer Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


AccTooltip Property

AccTooltip Property
GuiHTMLViewer Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


BrowserHandle Property

BrowserHandle Property
GuiHTMLViewer Object : BrowserHandle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property BrowserHandle As Object

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


Changeable Property

Changeable Property
GuiHTMLViewer Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


Children Property

Children Property
GuiHTMLViewer Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


ContainerType Property

ContainerType Property
GuiHTMLViewer Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


CurrentContextMenu Property

CurrentContextMenu Property
GuiHTMLViewer Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


DefaultTooltip Property

DefaultTooltip Property
GuiHTMLViewer Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


DocumentComplete Property

DocumentComplete Property
GuiHTMLViewer Object : DocumentComplete Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DocumentComplete As Long

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


DragDropSupported Property

DragDropSupported Property
GuiHTMLViewer Object : DragDropSupported Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DragDropSupported As Byte

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


Handle Property

Handle Property
GuiHTMLViewer Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


Height Property

Height Property
GuiHTMLViewer Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


IconName Property

IconName Property
GuiHTMLViewer Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


Id Property

Id Property
GuiHTMLViewer Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


IsSymbolFont Property

IsSymbolFont Property
GuiHTMLViewer Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


Left Property

Left Property
GuiHTMLViewer Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


Modified Property

Modified Property
GuiHTMLViewer Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


Name Property

Name Property
GuiHTMLViewer Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


OcxEvents Property

OcxEvents Property
GuiHTMLViewer Object : OcxEvents Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property OcxEvents As GuiCollection

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


Parent Property

Parent Property
GuiHTMLViewer Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


ParentFrame Property

ParentFrame Property
GuiHTMLViewer Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


ScreenLeft Property

ScreenLeft Property
GuiHTMLViewer Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


ScreenTop Property

ScreenTop Property
GuiHTMLViewer Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


SubType Property

SubType Property
GuiHTMLViewer Object : SubType Property

Glossary Item Box

Description

This property has the constant value HTMLViewer.

Property type

Read-only property

Syntax

Visual Basic
Public Property SubType As String

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


Text Property

Text Property
GuiHTMLViewer Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


Tooltip Property

Tooltip Property
GuiHTMLViewer Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


Top Property

Top Property
GuiHTMLViewer Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


Type Property

Type Property
GuiHTMLViewer Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


TypeAsNumber Property

TypeAsNumber Property
GuiHTMLViewer Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


Width Property

Width Property
GuiHTMLViewer Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiHTMLViewer Object | GuiHTMLViewer Members


GuiLabel Object

GuiLabel Object
See Also Members

Glossary Item Box

Description

GuiLabel extends GuiVComponent. The type prefix is lbl, the name is the fieldname taken from the SAP data dictionary.

Object Model

GuiLabel ObjectGuiComponentCollection CollectionGuiCollection CollectionGuiComponent ObjectGuiComponent Object

See Also

GuiLabel Members


GuiLabel Object Members

GuiLabel Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method GetListProperty
Public Method GetListPropertyNonRec
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property CaretPosition | Setting the caret position within a label is possible even though it is not visualized as a caret by SAP GUI. However, the position is transmitted to the server, so ABAP application logic may depend on this position.
Public Property Changeable |
Public Property CharHeight |
Public Property CharLeft |
Public Property CharTop |
Public Property CharWidth |
Public Property ColorIndex |
Public Property ColorIntensified |
Public Property ColorInverse |
Public Property ContainerType |
Public Property DefaultTooltip |
Public Property DisplayedText |
Public Property Height |
Public Property Highlighted |
Public Property IconName |
Public Property Id |
Public Property IsHotspot |
Public Property IsLeftLabel | This property is set if the label has been assigned as the left label of another control.
Public Property IsListElement |
Public Property IsRightLabel | This property is set if the label has been assigned as the right label of another control.
Public Property IsSymbolFont |
Public Property Left |
Public Property MaxLength | The maximum text length of a label is counted in code units. On non-Unicode clients these are equivalent to bytes.
Public Property Modified |
Public Property Name |
Public Property Numerical | This flag is True if the label may only contain numbers.
Public Property Parent |
Public Property ParentFrame |
Public Property RowText |
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property Text |
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property Width |

See Also

GuiLabel Object


DumpState Method

DumpState Method
InnerObject
GuiLabel Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiLabel Object | GuiLabel Members


GetListProperty Method

GetListProperty Method
Property
GuiLabel Object : GetListProperty Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetListProperty( _
   ByVal Property As String _
) As String

Parameters

Property

Remarks

Attributes of containers in general

  • ContainerType
    • "L": Entire list
    • "T": A table
    • "G": A group inside a table
    • "S" : A subgroup (inside a group)
    • "R": A line in the body of a table
    • "B": A text box
    • "E": A tree
    • "F": Simple "free" text outside any box
  • ContainerTitle: Title of a table (if provided) or of a text box
  • ContainerInputFields: Used iff a table or a tree has input fields (incl. checkboxes): Number of input fields

Attributes of containers of type "L" (Entire list)

  • ListTablesTotal: Number of tables on the list
  • ListTextBoxesTotal: Number of text boxes on the list
  • ListTreesTotal: Number of trees on the list
  • ListErrorMessage: Used iff the structure recognition detected a (severe) error.
  • ListInputType
    • "N": list contains no input fields
    • "C": list contains check boxes
    • "E": list contains edit fields
    • "A": list contains edit fields and check boxes

Attributes of containers of type "T" (Table), "G" (Group) and "S" (Subgroup)

  • RowsTotal: Number of logical rows in the table body. If this is an attribute of a (sub-)group, number of logical rows until the next (sub-)group starts. The numbers do NOT include summation lines and inserted lines.
  • RowsSummation: Number of rows with color COL_SUMMING INTENSIFIED ON (if there are any).
  • RowsSubSummation: Number of rows with color COL_SUMMING INTENSIFIED OFF (if there are any).
  • RowsInserted: Number of inserted rows (if there are any).

Attributes of containers of type "T" (Table)

  • TableNo: Number of the table if there is more than one table on the list
  • ColumnsTotal: Number of logical columns
  • SuperColumnsTotal: Used iff the table has a hierarchical header
  • TableHierarchical: Used iff the table is hierarchical-sequential
    • "A": ALV-like 2-level hierarchical-seq.
    • "2": 2-level hierarchical-seq.
    • "3": 3-level hierarchical-seq.
  • TableGroupsTotal: Used iff the table is hierarchical-seq.: Number of groups (not counting subgroups)
  • Columns2LevelALV: Used iff TableHierarchical is "A": Number of columns in the group header
  • HeaderRows2LevelALV: Used iff TableHierarchical is "A": Number of lines in the group header
  • TableHierarchicalHeader: Used iff the table has a hierarchical header
  • TableMultipleRows: Used iff the table is a multiple-line table: Number of physical lines per logical line

Attributes of containers of type "G" (Group) and "S" (Subgroup)

  • GroupNo: Number of current group if container is of type "G".
  • SubGroupNo: Number of current subgroup if container is of type "S".
  • SubgroupsTotal: Number of subgroups if table is 3-level hierarchical-sequential and container is of type "G"
  • GroupHeaderRows: Number of physical lines in the group header
  • GroupHeaderValues: Number of label-value pairs in the group header if the table is 2- or 3- level hierarchical-sequential.

Attributes of containers of type "R" (Row)

  • RowType: Used iff the row has a special type
    • "S": Color COL_SUMMING INTENSIFIED ON
    • "U": Color COL_SUMMING INTENSIFIED OFF
    • "I": Inserted line
  • RowNo: Number of current (logical) row, relative to the beginning of the (sub-)group if the table is 3- or 2-level hierarchical-seq.
  • RowMultipleRows: Number of physical lines for current logical line; used iff > 1 (multiple-line tables). Lines with totals may or may not be multiple lines.
  • RowInputFields: Number of input fields in the current line (if any).

Attributes of fields in tables

  • FieldHeader: The text of the column header (unavailable if the field itself is in the header, or the field is the label of a label-value pair in a hierarchical-sequential table, or the field is in an inserted line and does not belong to any column).
  • FieldSuperHeader: Text of the supercolumn if the field is in the lower line of a hierarchical header or in the table body (and belongs to a column).
  • ColumnNo: The number of the logical column (if the field belongs to a column).
  • LabelType: Used iff the field is in the header or is a label of a label-value pair in a hierarchical-seq. table.
    • "N": normal header field (lowest level in hierar.-seq. tables)
    • "H": header field in a supercolumn (upper line of a hierarchical header)
    • "A": group header field (COL_GROUPING INTENSIFIED ON) in table whereTableHierarchical is "A"
    • "G": group header field (COL_GROUPING INTENSIFIED ON) in 2-level hierarchical-sequential table
    • "S": subgroup header field (COL_HEADING INTENSIFIED ON) in 3-level hierarchical-sequential table
    • "T": title-field COL_NORMAL INTENSIFIED ON
  • ColumnType: Used if the field is a column header of a special column.
    • "C": column contains checkboxes
    • "S": column contains symbols and/or icons
  • SubordinateColumns: Number of subordinate columns if the field is in the upper line of a hierarchical header.
  • FieldMultipleRows: Used iff the field is in a table header and word wrapping was done: Number of physical lines of the "logical field".
  • FieldWithEllipsis: The field is directly followed by SYM_ELLIPSIS, i.e. "...".

Attributes of fields in tables, trees or title lines of text boxes

  • FieldPhysRowNo: If we are in the body of a multiple-line table or in a multiple-line node of a tree or word wrapping is used in the table header: Current physical line number within the logical line.

Attributes of text boxes

  • TextBoxNo: Number of the text box if there is more than one text box on the list

Attributes of containers in an SEUT tree

  • TreeNo: Number of the tree if there is more than one tree on the list and the current container is the root node
  • NodeName: Text of the first field of the node (STREENODE-NAME)
  • NodeLevelNo: The current level number; the root has level 0
  • NodeNo: The current node number; the "oldest brother" has number 1.
  • NodeExpandable: Used iff the current node can be expanded (folder with "+").
  • NodeMarked: Node has been marked (yellow in SEUT).
  • NodeChildrenTotal: Used iff the current node is expanded (folder with "-"): Number of children. (Grand children are not counted.)
  • NodeMultipleRows: Used iff the current node has more than one physical line: Number of physical lines

See Also

GuiLabel Object | GuiLabel Members


GetListPropertyNonRec Method

GetListPropertyNonRec Method
Property
GuiLabel Object : GetListPropertyNonRec Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetListPropertyNonRec( _
   ByVal Property As String _
) As String

Parameters

Property

See Also

GuiLabel Object | GuiLabel Members


SetFocus Method

SetFocus Method
GuiLabel Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiLabel Object | GuiLabel Members


ShowContextMenu Method

ShowContextMenu Method
GuiLabel Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiLabel Object | GuiLabel Members


Visualize Method

Visualize Method
On
InnerObject
GuiLabel Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiLabel Object | GuiLabel Members


AccLabelCollection Property

AccLabelCollection Property
GuiLabel Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiLabel Object | GuiLabel Members


AccText Property

AccText Property
GuiLabel Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiLabel Object | GuiLabel Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiLabel Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiLabel Object | GuiLabel Members


AccTooltip Property

AccTooltip Property
GuiLabel Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiLabel Object | GuiLabel Members


CaretPosition Property

CaretPosition Property
GuiLabel Object : CaretPosition Property

Glossary Item Box

Description

Setting the caret position within a label is possible even though it is not visualized as a caret by SAP GUI. However, the position is transmitted to the server, so ABAP application logic may depend on this position.

Property type

Read-write property

Syntax

Visual Basic
Public Property CaretPosition As Long

See Also

GuiLabel Object | GuiLabel Members


Changeable Property

Changeable Property
GuiLabel Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiLabel Object | GuiLabel Members


CharHeight Property

CharHeight Property
GuiLabel Object : CharHeight Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharHeight As Long

See Also

GuiLabel Object | GuiLabel Members


CharLeft Property

CharLeft Property
GuiLabel Object : CharLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharLeft As Long

See Also

GuiLabel Object | GuiLabel Members


CharTop Property

CharTop Property
GuiLabel Object : CharTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharTop As Long

See Also

GuiLabel Object | GuiLabel Members


CharWidth Property

CharWidth Property
GuiLabel Object : CharWidth Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharWidth As Long

See Also

GuiLabel Object | GuiLabel Members


ColorIndex Property

ColorIndex Property
GuiLabel Object : ColorIndex Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ColorIndex As Long

See Also

GuiLabel Object | GuiLabel Members


ColorIntensified Property

ColorIntensified Property
GuiLabel Object : ColorIntensified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ColorIntensified As Byte

See Also

GuiLabel Object | GuiLabel Members


ColorInverse Property

ColorInverse Property
GuiLabel Object : ColorInverse Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ColorInverse As Byte

See Also

GuiLabel Object | GuiLabel Members


ContainerType Property

ContainerType Property
GuiLabel Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiLabel Object | GuiLabel Members


DefaultTooltip Property

DefaultTooltip Property
GuiLabel Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiLabel Object | GuiLabel Members


DisplayedText Property

DisplayedText Property
GuiLabel Object : DisplayedText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DisplayedText As String

See Also

GuiLabel Object | GuiLabel Members


Height Property

Height Property
GuiLabel Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiLabel Object | GuiLabel Members


Highlighted Property

Highlighted Property
GuiLabel Object : Highlighted Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Highlighted As Byte

Example

This is an example of both a highlighted GuiLabel on the left and a highlighted GuiTextField on the right. The highlighted property is defined in the data dictionary.

See Also

GuiLabel Object | GuiLabel Members


IconName Property

IconName Property
GuiLabel Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiLabel Object | GuiLabel Members


Id Property

Id Property
GuiLabel Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiLabel Object | GuiLabel Members


IsHotspot Property

IsHotspot Property
GuiLabel Object : IsHotspot Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsHotspot As Byte

See Also

GuiLabel Object | GuiLabel Members


IsLeftLabel Property

IsLeftLabel Property
GuiLabel Object : IsLeftLabel Property

Glossary Item Box

Description

This property is set if the label has been assigned as the left label of another control.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsLeftLabel As Byte

See Also

GuiLabel Object | GuiLabel Members


IsListElement Property

IsListElement Property
GuiLabel Object : IsListElement Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsListElement As Byte

See Also

GuiLabel Object | GuiLabel Members


IsRightLabel Property

IsRightLabel Property
GuiLabel Object : IsRightLabel Property

Glossary Item Box

Description

This property is set if the label has been assigned as the right label of another control.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsRightLabel As Byte

See Also

GuiLabel Object | GuiLabel Members


IsSymbolFont Property

IsSymbolFont Property
GuiLabel Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiLabel Object | GuiLabel Members


Left Property

Left Property
GuiLabel Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiLabel Object | GuiLabel Members


MaxLength Property

MaxLength Property
GuiLabel Object : MaxLength Property

Glossary Item Box

Description

The maximum text length of a label is counted in code units. On non-Unicode clients these are equivalent to bytes.

Property type

Read-only property

Syntax

Visual Basic
Public Property MaxLength As Long

See Also

GuiLabel Object | GuiLabel Members


Modified Property

Modified Property
GuiLabel Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiLabel Object | GuiLabel Members


Name Property

Name Property
GuiLabel Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiLabel Object | GuiLabel Members


Numerical Property

Numerical Property
GuiLabel Object : Numerical Property

Glossary Item Box

Description

This flag is True if the label may only contain numbers.

Property type

Read-only property

Syntax

Visual Basic
Public Property Numerical As Byte

See Also

GuiLabel Object | GuiLabel Members


Parent Property

Parent Property
GuiLabel Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiLabel Object | GuiLabel Members


ParentFrame Property

ParentFrame Property
GuiLabel Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiLabel Object | GuiLabel Members


RowText Property

RowText Property
GuiLabel Object : RowText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property RowText As String

See Also

GuiLabel Object | GuiLabel Members


ScreenLeft Property

ScreenLeft Property
GuiLabel Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiLabel Object | GuiLabel Members


ScreenTop Property

ScreenTop Property
GuiLabel Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiLabel Object | GuiLabel Members


Text Property

Text Property
GuiLabel Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiLabel Object | GuiLabel Members


Tooltip Property

Tooltip Property
GuiLabel Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiLabel Object | GuiLabel Members


Top Property

Top Property
GuiLabel Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiLabel Object | GuiLabel Members


Type Property

Type Property
GuiLabel Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiLabel Object | GuiLabel Members


TypeAsNumber Property

TypeAsNumber Property
GuiLabel Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiLabel Object | GuiLabel Members


Width Property

Width Property
GuiLabel Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiLabel Object | GuiLabel Members


GuiMainWindow Object

GuiMainWindow Object
See Also Members

Glossary Item Box

Description

This window represents the main window of a SAP GUI session.

GuiMainWindow extends GuiFrameWindow.

Object Model

GuiMainWindow ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiVComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiVComponent Object

See Also

GuiMainWindow Members


GuiMainWindow Object Members

GuiMainWindow Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method Close | Close the main window.
Public Method CompBitmap |
Public Method DumpState |
Public Method FindAllByName |
Public Method FindAllByNameEx |
Public Method FindById |
Public Method FindByName |
Public Method FindByNameEx |
Public Method HardCopy | Create a hardcopy of the main window.
Public Method HardCopyToMemory | Create a screenshot of SAP GUI and return it in a memory block to the caller.
Public Method Iconify | Collapse the main window to the minimized state.
Public Method IsVKeyAllowed | The method returns True if the given virtual key can be executed on the current screen.
Public Method JumpBackward |
Public Method JumpForward |
Public Method Maximize | Maximize the main window.
Public Method ResizeWorkingPane | The ResizeWorkingPane function will resize the window so that the available working area has the given width and height in character metric.
Public Method ResizeWorkingPaneEx | The ResizeWorkingPaneEx function will resize the window so that the available working area has the given width and height in pixels.
Public Method Restore | Restore the main window.
Public Method SendVKey | Send a virtual key to the system.
Public Method SetFocus |
Public Method ShowMessageBox | This method displays a message box. It may be used in scripting environments where there is no built-in function to display a message box, such as JScript. In Visual Basic Script the Windows Script Host supports the MsgBox function.
Public Method TabBackward |
Public Method TabForward |
Public Method Visualize |

Public Properties

Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property ButtonbarVisible | This property it True if the application toolbar, the lower toolbar within SAP GUI, is visible. Setting this property to False will hide the application toolbar.
Public Property Changeable
Public Property Children
Public Property ContainerType
Public Property DefaultTooltip
Public Property ElementVisualizationMode
Public Property GuiFocus

The GuiFocus is the element within SAP GUI that currently has the focus. This may not be the same element as the one pointed to by SystemFocus.

GuiFocus can be any element within SAP GUI, including elements that do not exist in the server model, such as toolbar buttons or the command field.

Public Property Handle
Public Property Height
Public Property Iconic | This property is True if the main window is currently minimized.
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property StatusbarVisible
Public Property SystemFocus

SystemFocus is the element within SAP GUI that has the focus from the server application's perspective. This may only be an element which exists in the server model, such as dynpro or list elements.

Public Property Text
Public Property TitlebarVisible | This property it True if the title bar is visible. Setting this property to False will hide the title bar.
Public Property ToolbarVisible | This property it True if the systen toolbar, the upper toolbar within SAP GUI, is visible. Setting this property to False will hide the system toolbar.
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width
Public Property WorkingPaneHeight
Public Property WorkingPaneWidth

See Also

GuiMainWindow Object


Close Method

Close Method
GuiMainWindow Object : Close Method

Glossary Item Box

Description

Close the main window.

Syntax

Visual Basic
Public Sub Close()

See Also

GuiMainWindow Object | GuiMainWindow Members


CompBitmap Method

CompBitmap Method
Filename1
Filename2
GuiMainWindow Object : CompBitmap Method

Glossary Item Box

Syntax

Visual Basic
Public Function CompBitmap( _
   ByVal Filename1 As String, _
   ByVal Filename2 As String _
) As Long

Parameters

Filename1
Filename2

See Also

GuiMainWindow Object | GuiMainWindow Members


DumpState Method

DumpState Method
InnerObject
GuiMainWindow Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiMainWindow Object | GuiMainWindow Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiMainWindow Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiMainWindow Object | GuiMainWindow Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiMainWindow Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiMainWindow Object | GuiMainWindow Members


FindById Method

FindById Method
Id
Raise
GuiMainWindow Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiMainWindow Object | GuiMainWindow Members


FindByName Method

FindByName Method
Name
Type
GuiMainWindow Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiMainWindow Object | GuiMainWindow Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiMainWindow Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiMainWindow Object | GuiMainWindow Members


HardCopy Method

HardCopy Method
Filename
Name of the file to which the hard copy should be written.
ImageType
xPos
yPos
nWidth
nHeight
GuiMainWindow Object : HardCopy Method

Glossary Item Box

Description

Create a hardcopy of the main window.

Syntax

Visual Basic
Public Function HardCopy( _
   ByVal Filename As String, _
   Optional ByVal ImageType As Variant, _
   Optional ByVal xPos As Variant, _
   Optional ByVal yPos As Variant, _
   Optional ByVal nWidth As Variant, _
   Optional ByVal nHeight As Variant _
) As String

Parameters

Filename
Name of the file to which the hard copy should be written.
ImageType
xPos
yPos
nWidth
nHeight

Remarks

Currently only BMP is supported as output format.

See Also

GuiMainWindow Object | GuiMainWindow Members


HardCopyToMemory Method

HardCopyToMemory Method
See Also Example
ImageType
GuiMainWindow Object : HardCopyToMemory Method

Glossary Item Box

Description

Create a screenshot of SAP GUI and return it in a memory block to the caller.

Syntax

Visual Basic
Public Function HardCopyToMemory( _
   Optional ByVal ImageType As Variant _
) As Variant

Parameters

ImageType

Remarks

This method may be more efficient for users who do not want a file to be created on the local filesystem.

Example

Create a screenshot, return it as a memory block and write it to file in the script.
Hardcopy to Memory (Visual Basic) Copy Code
If Not IsObject(application) Then
   Set SapGuiAuto  = GetObject("SAPGUI")
   Set application = SapGuiAuto.GetScriptingEngine
End If
If Not IsObject(connection) Then
   Set connection = application.Children(0)
End If
If Not IsObject(session) Then
   Set session    = connection.Children(0)
End If

Image = session.findById("wnd[0]").HardCopyToMemory()

Const adTypeBinary          = 1
Const adSaveCreateOverWrite = 2

Dim BinaryStream
Set BinaryStream = CreateObject("ADODB.Stream")

BinaryStream.Type = adTypeBinary

BinaryStream.Open
BinaryStream.Write Image
BinaryStream.SaveToFile "C:\screenshot.bmp", adSaveCreateOverWrite

MsgBox "Done"

See Also

GuiMainWindow Object | GuiMainWindow Members


Iconify Method

Iconify Method
GuiMainWindow Object : Iconify Method

Glossary Item Box

Description

Collapse the main window to the minimized state.

Syntax

Visual Basic
Public Sub Iconify()

See Also

GuiMainWindow Object | GuiMainWindow Members


IsVKeyAllowed Method

IsVKeyAllowed Method
VKey
GuiMainWindow Object : IsVKeyAllowed Method

Glossary Item Box

Description

The method returns True if the given virtual key can be executed on the current screen.

Syntax

Visual Basic
Public Function IsVKeyAllowed( _
   ByVal VKey As Integer _
) As Byte

Parameters

VKey

Example

If F8 can be pressed on a given screen to execute a report, then the method IsVKeyAllowed(8) will return True.

See Also

GuiMainWindow Object | GuiMainWindow Members


JumpBackward Method

JumpBackward Method
GuiMainWindow Object : JumpBackward Method

Glossary Item Box

Syntax

Visual Basic
Public Sub JumpBackward()

See Also

GuiMainWindow Object | GuiMainWindow Members


JumpForward Method

JumpForward Method
GuiMainWindow Object : JumpForward Method

Glossary Item Box

Syntax

Visual Basic
Public Sub JumpForward()

See Also

GuiMainWindow Object | GuiMainWindow Members


Maximize Method

Maximize Method
GuiMainWindow Object : Maximize Method

Glossary Item Box

Description

Maximize the main window.

Syntax

Visual Basic
Public Sub Maximize()

See Also

GuiMainWindow Object | GuiMainWindow Members


ResizeWorkingPane Method

ResizeWorkingPane Method
Width
Height
ThrowOnFail
The throwOnFail parameter has been added for use in the SAP GUI for Java because some window managers may not support a program driven resize of a window.
GuiMainWindow Object : ResizeWorkingPane Method

Glossary Item Box

Description

The ResizeWorkingPane function will resize the window so that the available working area has the given width and height in character metric.

Syntax

Visual Basic
Public Sub ResizeWorkingPane( _
   ByVal Width As Long, _
   ByVal Height As Long, _
   ByVal ThrowOnFail As Boolean _
)

Parameters

Width
Height
ThrowOnFail
The throwOnFail parameter has been added for use in the SAP GUI for Java because some window managers may not support a program driven resize of a window.

Remarks

A script may fail during playback if the size of the window differs from the size during recording. This becomes obvious when you compare the two screen shots below:

If the user selected ‘Two-Line List’ while recording a script and this line is not available during playback because the size of the window has been decreased, then the selection will fail.

This is because only the visible lines of the list are available on the client. Scrolling always requires a new set of data to be read from the server. This may not be the case for other elements of the user interface. For example, a line of the Grid View which will be discussed later is accessible even if it is not currently visible on the client.

See Also

GuiMainWindow Object | GuiMainWindow Members


ResizeWorkingPaneEx Method

ResizeWorkingPaneEx Method
Width
Height
ThrowOnFail
GuiMainWindow Object : ResizeWorkingPaneEx Method

Glossary Item Box

Description

The ResizeWorkingPaneEx function will resize the window so that the available working area has the given width and height in pixels.

Syntax

Visual Basic
Public Sub ResizeWorkingPaneEx( _
   ByVal Width As Long, _
   ByVal Height As Long, _
   ByVal ThrowOnFail As Boolean _
)

Parameters

Width
Height
ThrowOnFail

Remarks

This method is only used during recording if the DWORD registry key ResizeWorkingPaneEx in patch HKCU\Software\SAP\SAPGUI Front\SAP Frontend Server\Scripting exists and has the value 1.

See Also

GuiMainWindow Object | GuiMainWindow Members


Restore Method

Restore Method
GuiMainWindow Object : Restore Method

Glossary Item Box

Description

Restore the main window.

Syntax

Visual Basic
Public Sub Restore()

See Also

GuiMainWindow Object | GuiMainWindow Members


SendVKey Method

SendVKey Method
VKey
GuiMainWindow Object : SendVKey Method

Glossary Item Box

Description

Send a virtual key to the system.

Syntax

Visual Basic
Public Sub SendVKey( _
   ByVal VKey As Integer _
)

Parameters

VKey

Remarks

Possible values for the VKey parameter can be found in the table GUI_FKEY.

VKey | Keyboard Combination
00 | Enter
01 | F1
02 | F2
03 | F3
04 | F4
05 | F5
06 | F6
07 | F7
08 | F8
09 | F9
10 | F10
11 | Ctrl+S
12 | F12
13 | Shift+F1
14 | Shift+F2
15 | Shift+F3
16 | Shift+F4
17 | Shift+F5
18 | Shift+F6
19 | Shift+F7
20 | Shift+F8
21 | Shift+F9
22 | Shift+Ctrl+0
23 | Shift+F11
24 | Shift+F12
25 | Ctrl+F1
26 | Ctrl+F2
27 | Ctrl+F3
28 | Ctrl+F4
29 | Ctrl+F5
30 | Ctrl+F6
31 | Ctrl+F7
32 | Ctrl+F8
33 | Ctrl+F9
34 | Ctrl+F10
35 | Ctrl+F11
36 | Ctrl+F12
37 | Ctrl+Shift+F1
38 | Ctrl+Shift+F2
39 | Ctrl+Shift+F3
40 | Ctrl+Shift+F4
41 | Ctrl+Shift+F5
42 | Ctrl+Shift+F6
43 | Ctrl+Shift+F7
44 | Ctrl+Shift+F8
45 | Ctrl+Shift+F9
46 | Ctrl+Shift+F10
47 | Ctrl+Shift+F11
48 | Ctrl+Shift+F12
70 | Ctrl+E
71 | Ctrl+F
72 | Ctrl+/
73 | Ctrl+\
74 | Ctrl+N
75 | Ctrl+O
76 | Ctrl+X
77 | Ctrl+C
78 | Ctrl+V
79 | Ctrl+Z
80 | Ctrl+PageUp
81 | PageUp
82 | PageDown
83 | Ctrl+PageDown
84 | Ctrl+G
85 | Ctrl+R
86 | Ctrl+P

See Also

GuiMainWindow Object | GuiMainWindow Members


SetFocus Method

SetFocus Method
GuiMainWindow Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiMainWindow Object | GuiMainWindow Members


ShowMessageBox Method

ShowMessageBox Method
Title
Title of the message box.
Text
Text message in the message box.
MsgIcon
Value from the GuiMessageBoxType enumeration.
MsgType
Value from the GuiMessageBoxOption enumeration.
GuiMainWindow Object : ShowMessageBox Method

Glossary Item Box

Description

This method displays a message box. It may be used in scripting environments where there is no built-in function to display a message box, such as JScript. In Visual Basic Script the Windows Script Host supports the MsgBox function.

Syntax

Visual Basic
Public Function ShowMessageBox( _
   ByVal Title As String, _
   ByVal Text As String, _
   ByVal MsgIcon As Long, _
   ByVal MsgType As Long _
) As Long

Parameters

Title
Title of the message box.
Text
Text message in the message box.
MsgIcon
Value from the GuiMessageBoxType enumeration.
MsgType
Value from the GuiMessageBoxOption enumeration.

See Also

GuiMainWindow Object | GuiMainWindow Members


TabBackward Method

TabBackward Method
GuiMainWindow Object : TabBackward Method

Glossary Item Box

Syntax

Visual Basic
Public Sub TabBackward()

See Also

GuiMainWindow Object | GuiMainWindow Members


TabForward Method

TabForward Method
GuiMainWindow Object : TabForward Method

Glossary Item Box

Syntax

Visual Basic
Public Sub TabForward()

See Also

GuiMainWindow Object | GuiMainWindow Members


Visualize Method

Visualize Method
On
InnerObject
GuiMainWindow Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiMainWindow Object | GuiMainWindow Members


AccLabelCollection Property

AccLabelCollection Property
GuiMainWindow Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiMainWindow Object | GuiMainWindow Members


AccText Property

AccText Property
GuiMainWindow Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiMainWindow Object | GuiMainWindow Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiMainWindow Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiMainWindow Object | GuiMainWindow Members


AccTooltip Property

AccTooltip Property
GuiMainWindow Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiMainWindow Object | GuiMainWindow Members


ButtonbarVisible Property

ButtonbarVisible Property
GuiMainWindow Object : ButtonbarVisible Property

Glossary Item Box

Description

This property it True if the application toolbar, the lower toolbar within SAP GUI, is visible. Setting this property to False will hide the application toolbar.

Property type

Read-write property

Syntax

Visual Basic
Public Property ButtonbarVisible As Byte

See Also

GuiMainWindow Object | GuiMainWindow Members


Changeable Property

Changeable Property
GuiMainWindow Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiMainWindow Object | GuiMainWindow Members


Children Property

Children Property
GuiMainWindow Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiMainWindow Object | GuiMainWindow Members


ContainerType Property

ContainerType Property
GuiMainWindow Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiMainWindow Object | GuiMainWindow Members


DefaultTooltip Property

DefaultTooltip Property
GuiMainWindow Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiMainWindow Object | GuiMainWindow Members


ElementVisualizationMode Property

ElementVisualizationMode Property
GuiMainWindow Object : ElementVisualizationMode Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property ElementVisualizationMode As Byte

See Also

GuiMainWindow Object | GuiMainWindow Members


GuiFocus Property

GuiFocus Property
GuiMainWindow Object : GuiFocus Property

Glossary Item Box

Description

The GuiFocus is the element within SAP GUI that currently has the focus. This may not be the same element as the one pointed to by SystemFocus.

GuiFocus can be any element within SAP GUI, including elements that do not exist in the server model, such as toolbar buttons or the command field.

Property type

Read-only property

Syntax

Visual Basic
Public Property GuiFocus As GuiVComponent

See Also

GuiMainWindow Object | GuiMainWindow Members


Handle Property

Handle Property
GuiMainWindow Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiMainWindow Object | GuiMainWindow Members


Height Property

Height Property
GuiMainWindow Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiMainWindow Object | GuiMainWindow Members


Iconic Property

Iconic Property
GuiMainWindow Object : Iconic Property

Glossary Item Box

Description

This property is True if the main window is currently minimized.

Property type

Read-only property

Syntax

Visual Basic
Public Property Iconic As Byte

See Also

GuiMainWindow Object | GuiMainWindow Members


IconName Property

IconName Property
GuiMainWindow Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiMainWindow Object | GuiMainWindow Members


Id Property

Id Property
GuiMainWindow Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiMainWindow Object | GuiMainWindow Members


IsSymbolFont Property

IsSymbolFont Property
GuiMainWindow Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiMainWindow Object | GuiMainWindow Members


Left Property

Left Property
GuiMainWindow Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiMainWindow Object | GuiMainWindow Members


Modified Property

Modified Property
GuiMainWindow Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiMainWindow Object | GuiMainWindow Members


Name Property

Name Property
GuiMainWindow Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiMainWindow Object | GuiMainWindow Members


Parent Property

Parent Property
GuiMainWindow Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiMainWindow Object | GuiMainWindow Members


ParentFrame Property

ParentFrame Property
GuiMainWindow Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiMainWindow Object | GuiMainWindow Members


ScreenLeft Property

ScreenLeft Property
GuiMainWindow Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiMainWindow Object | GuiMainWindow Members


ScreenTop Property

ScreenTop Property
GuiMainWindow Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiMainWindow Object | GuiMainWindow Members


StatusbarVisible Property

StatusbarVisible Property
GuiMainWindow Object : StatusbarVisible Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property StatusbarVisible As Byte

See Also

GuiMainWindow Object | GuiMainWindow Members


SystemFocus Property

SystemFocus Property
GuiMainWindow Object : SystemFocus Property

Glossary Item Box

Description

SystemFocus is the element within SAP GUI that has the focus from the server application's perspective. This may only be an element which exists in the server model, such as dynpro or list elements.

Property type

Read-only property

Syntax

Visual Basic
Public Property SystemFocus As GuiVComponent

Remarks

It is possible for the SystemFocus to be on a dynpro element, while at the same time the GuiFocus is on the command field or a toolbar button, for example.

See Also

GuiMainWindow Object | GuiMainWindow Members


Text Property

Text Property
GuiMainWindow Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiMainWindow Object | GuiMainWindow Members


TitlebarVisible Property

TitlebarVisible Property
GuiMainWindow Object : TitlebarVisible Property

Glossary Item Box

Description

This property it True if the title bar is visible. Setting this property to False will hide the title bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property TitlebarVisible As Byte

Remarks

The title bar is only available in New Visual Design, not in Classic Design.

See Also

GuiMainWindow Object | GuiMainWindow Members


ToolbarVisible Property

ToolbarVisible Property
GuiMainWindow Object : ToolbarVisible Property

Glossary Item Box

Description

This property it True if the systen toolbar, the upper toolbar within SAP GUI, is visible. Setting this property to False will hide the system toolbar.

Property type

Read-write property

Syntax

Visual Basic
Public Property ToolbarVisible As Byte

See Also

GuiMainWindow Object | GuiMainWindow Members


Tooltip Property

Tooltip Property
GuiMainWindow Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiMainWindow Object | GuiMainWindow Members


Top Property

Top Property
GuiMainWindow Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiMainWindow Object | GuiMainWindow Members


Type Property

Type Property
GuiMainWindow Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiMainWindow Object | GuiMainWindow Members


TypeAsNumber Property

TypeAsNumber Property
GuiMainWindow Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiMainWindow Object | GuiMainWindow Members


Width Property

Width Property
GuiMainWindow Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiMainWindow Object | GuiMainWindow Members


WorkingPaneHeight Property

WorkingPaneHeight Property
GuiMainWindow Object : WorkingPaneHeight Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property WorkingPaneHeight As Long

See Also

GuiMainWindow Object | GuiMainWindow Members


WorkingPaneWidth Property

WorkingPaneWidth Property
GuiMainWindow Object : WorkingPaneWidth Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property WorkingPaneWidth As Long

See Also

GuiMainWindow Object | GuiMainWindow Members


GuiMap Object

GuiMap Object
See Also Members

Glossary Item Box

Description

For the map control only basic members from GuiShell are available. Recording and playback is not possible.

Object Model

GuiMap ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiComponent ObjectGuiComponent Object

See Also

GuiMap Members


GuiMap Object Members

GuiMap Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method SelectContextMenuItem
Public Method SelectContextMenuItemByPosition
Public Method SelectContextMenuItemByText
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccDescription
Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property Children
Public Property ContainerType
Public Property CurrentContextMenu
Public Property DefaultTooltip
Public Property DragDropSupported
Public Property Handle
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property OcxEvents
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property SubType
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiMap Object


DumpState Method

DumpState Method
InnerObject
GuiMap Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiMap Object | GuiMap Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiMap Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiMap Object | GuiMap Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiMap Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiMap Object | GuiMap Members


FindById Method

FindById Method
Id
Raise
GuiMap Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiMap Object | GuiMap Members


FindByName Method

FindByName Method
Name
Type
GuiMap Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiMap Object | GuiMap Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiMap Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiMap Object | GuiMap Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiMap Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiMap Object | GuiMap Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiMap Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiMap Object | GuiMap Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiMap Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

GuiMap Object | GuiMap Members


SetFocus Method

SetFocus Method
GuiMap Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiMap Object | GuiMap Members


ShowContextMenu Method

ShowContextMenu Method
GuiMap Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiMap Object | GuiMap Members


Visualize Method

Visualize Method
On
InnerObject
GuiMap Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiMap Object | GuiMap Members


AccDescription Property

AccDescription Property
GuiMap Object : AccDescription Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccDescription As String

See Also

GuiMap Object | GuiMap Members


AccLabelCollection Property

AccLabelCollection Property
GuiMap Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiMap Object | GuiMap Members


AccText Property

AccText Property
GuiMap Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiMap Object | GuiMap Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiMap Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiMap Object | GuiMap Members


AccTooltip Property

AccTooltip Property
GuiMap Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiMap Object | GuiMap Members


Changeable Property

Changeable Property
GuiMap Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiMap Object | GuiMap Members


Children Property

Children Property
GuiMap Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiMap Object | GuiMap Members


ContainerType Property

ContainerType Property
GuiMap Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiMap Object | GuiMap Members


CurrentContextMenu Property

CurrentContextMenu Property
GuiMap Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

GuiMap Object | GuiMap Members


DefaultTooltip Property

DefaultTooltip Property
GuiMap Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiMap Object | GuiMap Members


DragDropSupported Property

DragDropSupported Property
GuiMap Object : DragDropSupported Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DragDropSupported As Byte

See Also

GuiMap Object | GuiMap Members


Handle Property

Handle Property
GuiMap Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiMap Object | GuiMap Members


Height Property

Height Property
GuiMap Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiMap Object | GuiMap Members


IconName Property

IconName Property
GuiMap Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiMap Object | GuiMap Members


Id Property

Id Property
GuiMap Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiMap Object | GuiMap Members


IsSymbolFont Property

IsSymbolFont Property
GuiMap Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiMap Object | GuiMap Members


Left Property

Left Property
GuiMap Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiMap Object | GuiMap Members


Modified Property

Modified Property
GuiMap Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiMap Object | GuiMap Members


Name Property

Name Property
GuiMap Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiMap Object | GuiMap Members


OcxEvents Property

OcxEvents Property
GuiMap Object : OcxEvents Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property OcxEvents As GuiCollection

See Also

GuiMap Object | GuiMap Members


Parent Property

Parent Property
GuiMap Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiMap Object | GuiMap Members


ParentFrame Property

ParentFrame Property
GuiMap Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiMap Object | GuiMap Members


ScreenLeft Property

ScreenLeft Property
GuiMap Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiMap Object | GuiMap Members


ScreenTop Property

ScreenTop Property
GuiMap Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiMap Object | GuiMap Members


SubType Property

SubType Property
GuiMap Object : SubType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property SubType As String

See Also

GuiMap Object | GuiMap Members


Text Property

Text Property
GuiMap Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiMap Object | GuiMap Members


Tooltip Property

Tooltip Property
GuiMap Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiMap Object | GuiMap Members


Top Property

Top Property
GuiMap Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiMap Object | GuiMap Members


Type Property

Type Property
GuiMap Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiMap Object | GuiMap Members


TypeAsNumber Property

TypeAsNumber Property
GuiMap Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiMap Object | GuiMap Members


Width Property

Width Property
GuiMap Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiMap Object | GuiMap Members


GuiMenu Object

GuiMenu Object
See Also Members

Glossary Item Box

Description

A GuiMenu may have other GuiMenu objects as children. GuiMenu extends GuiVContainer. The type prefix is menu, the name is the text of the menu item. If the item does not have a text, which is the case for separators, then the name is the last part of the id, menu[n].

Object Model

GuiMenu ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent Object

See Also

GuiMenu Members


GuiMenu Object Members

GuiMenu Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState |
Public Method FindAllByName |
Public Method FindAllByNameEx |
Public Method FindById |
Public Method FindByName |
Public Method FindByNameEx |
Public Method Select | Select the menu.
Public Method SetFocus |
Public Method ShowContextMenu |
Public Method Visualize |

Public Properties

Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property Children
Public Property ContainerType
Public Property DefaultTooltip
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiMenu Object


DumpState Method

DumpState Method
InnerObject
GuiMenu Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiMenu Object | GuiMenu Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiMenu Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiMenu Object | GuiMenu Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiMenu Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiMenu Object | GuiMenu Members


FindById Method

FindById Method
Id
Raise
GuiMenu Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiMenu Object | GuiMenu Members


FindByName Method

FindByName Method
Name
Type
GuiMenu Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiMenu Object | GuiMenu Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiMenu Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiMenu Object | GuiMenu Members


Select Method

Select Method
GuiMenu Object : Select Method

Glossary Item Box

Description

Select the menu.

Syntax

Visual Basic
Public Sub Select()

See Also

GuiMenu Object | GuiMenu Members


SetFocus Method

SetFocus Method
GuiMenu Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiMenu Object | GuiMenu Members


ShowContextMenu Method

ShowContextMenu Method
GuiMenu Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiMenu Object | GuiMenu Members


Visualize Method

Visualize Method
On
InnerObject
GuiMenu Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiMenu Object | GuiMenu Members


AccLabelCollection Property

AccLabelCollection Property
GuiMenu Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiMenu Object | GuiMenu Members


AccText Property

AccText Property
GuiMenu Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiMenu Object | GuiMenu Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiMenu Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiMenu Object | GuiMenu Members


AccTooltip Property

AccTooltip Property
GuiMenu Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiMenu Object | GuiMenu Members


Changeable Property

Changeable Property
GuiMenu Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiMenu Object | GuiMenu Members


Children Property

Children Property
GuiMenu Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiMenu Object | GuiMenu Members


ContainerType Property

ContainerType Property
GuiMenu Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiMenu Object | GuiMenu Members


DefaultTooltip Property

DefaultTooltip Property
GuiMenu Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiMenu Object | GuiMenu Members


Height Property

Height Property
GuiMenu Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiMenu Object | GuiMenu Members


IconName Property

IconName Property
GuiMenu Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiMenu Object | GuiMenu Members


Id Property

Id Property
GuiMenu Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiMenu Object | GuiMenu Members


IsSymbolFont Property

IsSymbolFont Property
GuiMenu Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiMenu Object | GuiMenu Members


Left Property

Left Property
GuiMenu Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiMenu Object | GuiMenu Members


Modified Property

Modified Property
GuiMenu Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiMenu Object | GuiMenu Members


Name Property

Name Property
GuiMenu Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiMenu Object | GuiMenu Members


Parent Property

Parent Property
GuiMenu Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiMenu Object | GuiMenu Members


ParentFrame Property

ParentFrame Property
GuiMenu Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiMenu Object | GuiMenu Members


ScreenLeft Property

ScreenLeft Property
GuiMenu Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiMenu Object | GuiMenu Members


ScreenTop Property

ScreenTop Property
GuiMenu Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiMenu Object | GuiMenu Members


Text Property

Text Property
GuiMenu Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiMenu Object | GuiMenu Members


Tooltip Property

Tooltip Property
GuiMenu Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiMenu Object | GuiMenu Members


Top Property

Top Property
GuiMenu Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiMenu Object | GuiMenu Members


Type Property

Type Property
GuiMenu Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiMenu Object | GuiMenu Members


TypeAsNumber Property

TypeAsNumber Property
GuiMenu Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiMenu Object | GuiMenu Members


Width Property

Width Property
GuiMenu Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiMenu Object | GuiMenu Members


GuiMenubar Object

GuiMenubar Object
See Also Members

Glossary Item Box

Description

Only the main window has a menubar. The children of the menubar are menus. GuiMenubar extends GuiVContainer. The type prefix and name are mbar.

Object Model

GuiMenubar ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent Object

See Also

GuiMenubar Members


GuiMenubar Object Members

GuiMenubar Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property Children
Public Property ContainerType
Public Property DefaultTooltip
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiMenubar Object


DumpState Method

DumpState Method
InnerObject
GuiMenubar Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiMenubar Object | GuiMenubar Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiMenubar Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiMenubar Object | GuiMenubar Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiMenubar Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiMenubar Object | GuiMenubar Members


FindById Method

FindById Method
Id
Raise
GuiMenubar Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiMenubar Object | GuiMenubar Members


FindByName Method

FindByName Method
Name
Type
GuiMenubar Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiMenubar Object | GuiMenubar Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiMenubar Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiMenubar Object | GuiMenubar Members


SetFocus Method

SetFocus Method
GuiMenubar Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiMenubar Object | GuiMenubar Members


ShowContextMenu Method

ShowContextMenu Method
GuiMenubar Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiMenubar Object | GuiMenubar Members


Visualize Method

Visualize Method
On
InnerObject
GuiMenubar Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiMenubar Object | GuiMenubar Members


AccLabelCollection Property

AccLabelCollection Property
GuiMenubar Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiMenubar Object | GuiMenubar Members


AccText Property

AccText Property
GuiMenubar Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiMenubar Object | GuiMenubar Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiMenubar Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiMenubar Object | GuiMenubar Members


AccTooltip Property

AccTooltip Property
GuiMenubar Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiMenubar Object | GuiMenubar Members


Changeable Property

Changeable Property
GuiMenubar Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiMenubar Object | GuiMenubar Members


Children Property

Children Property
GuiMenubar Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiMenubar Object | GuiMenubar Members


ContainerType Property

ContainerType Property
GuiMenubar Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiMenubar Object | GuiMenubar Members


DefaultTooltip Property

DefaultTooltip Property
GuiMenubar Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiMenubar Object | GuiMenubar Members


Height Property

Height Property
GuiMenubar Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiMenubar Object | GuiMenubar Members


IconName Property

IconName Property
GuiMenubar Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiMenubar Object | GuiMenubar Members


Id Property

Id Property
GuiMenubar Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiMenubar Object | GuiMenubar Members


IsSymbolFont Property

IsSymbolFont Property
GuiMenubar Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiMenubar Object | GuiMenubar Members


Left Property

Left Property
GuiMenubar Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiMenubar Object | GuiMenubar Members


Modified Property

Modified Property
GuiMenubar Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiMenubar Object | GuiMenubar Members


Name Property

Name Property
GuiMenubar Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiMenubar Object | GuiMenubar Members


Parent Property

Parent Property
GuiMenubar Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiMenubar Object | GuiMenubar Members


ParentFrame Property

ParentFrame Property
GuiMenubar Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiMenubar Object | GuiMenubar Members


ScreenLeft Property

ScreenLeft Property
GuiMenubar Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiMenubar Object | GuiMenubar Members


ScreenTop Property

ScreenTop Property
GuiMenubar Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiMenubar Object | GuiMenubar Members


Text Property

Text Property
GuiMenubar Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiMenubar Object | GuiMenubar Members


Tooltip Property

Tooltip Property
GuiMenubar Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiMenubar Object | GuiMenubar Members


Top Property

Top Property
GuiMenubar Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiMenubar Object | GuiMenubar Members


Type Property

Type Property
GuiMenubar Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiMenubar Object | GuiMenubar Members


TypeAsNumber Property

TypeAsNumber Property
GuiMenubar Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiMenubar Object | GuiMenubar Members


Width Property

Width Property
GuiMenubar Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiMenubar Object | GuiMenubar Members


GuiMessageWindow Object

GuiMessageWindow Object
See Also Members

Glossary Item Box

Object Model

GuiMessageWindow ObjectGuiComponentCollection CollectionGuiCollection CollectionGuiComponent ObjectGuiComponent Object

See Also

GuiMessageWindow Members


GuiMessageWindow Object Members

GuiMessageWindow Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property ContainerType
Public Property DefaultTooltip
Public Property FocusedButton
Public Property Height
Public Property HelpButtonHelpText
Public Property HelpButtonText
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property MessageText
Public Property MessageType
Public Property Modified
Public Property Name
Public Property OKButtonHelpText
Public Property OKButtonText
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Visible
Public Property Width

See Also

GuiMessageWindow Object


DumpState Method

DumpState Method
InnerObject
GuiMessageWindow Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiMessageWindow Object | GuiMessageWindow Members


SetFocus Method

SetFocus Method
GuiMessageWindow Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiMessageWindow Object | GuiMessageWindow Members


ShowContextMenu Method

ShowContextMenu Method
GuiMessageWindow Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiMessageWindow Object | GuiMessageWindow Members


Visualize Method

Visualize Method
On
InnerObject
GuiMessageWindow Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiMessageWindow Object | GuiMessageWindow Members


AccLabelCollection Property

AccLabelCollection Property
GuiMessageWindow Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiMessageWindow Object | GuiMessageWindow Members


AccText Property

AccText Property
GuiMessageWindow Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiMessageWindow Object | GuiMessageWindow Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiMessageWindow Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiMessageWindow Object | GuiMessageWindow Members


AccTooltip Property

AccTooltip Property
GuiMessageWindow Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiMessageWindow Object | GuiMessageWindow Members


Changeable Property

Changeable Property
GuiMessageWindow Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiMessageWindow Object | GuiMessageWindow Members


ContainerType Property

ContainerType Property
GuiMessageWindow Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiMessageWindow Object | GuiMessageWindow Members


DefaultTooltip Property

DefaultTooltip Property
GuiMessageWindow Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiMessageWindow Object | GuiMessageWindow Members


FocusedButton Property

FocusedButton Property
GuiMessageWindow Object : FocusedButton Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property FocusedButton As Long

See Also

GuiMessageWindow Object | GuiMessageWindow Members


Height Property

Height Property
GuiMessageWindow Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiMessageWindow Object | GuiMessageWindow Members


HelpButtonHelpText Property

HelpButtonHelpText Property
GuiMessageWindow Object : HelpButtonHelpText Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property HelpButtonHelpText As String

See Also

GuiMessageWindow Object | GuiMessageWindow Members


HelpButtonText Property

HelpButtonText Property
GuiMessageWindow Object : HelpButtonText Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property HelpButtonText As String

See Also

GuiMessageWindow Object | GuiMessageWindow Members


IconName Property

IconName Property
GuiMessageWindow Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiMessageWindow Object | GuiMessageWindow Members


Id Property

Id Property
GuiMessageWindow Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiMessageWindow Object | GuiMessageWindow Members


IsSymbolFont Property

IsSymbolFont Property
GuiMessageWindow Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiMessageWindow Object | GuiMessageWindow Members


Left Property

Left Property
GuiMessageWindow Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiMessageWindow Object | GuiMessageWindow Members


MessageText Property

MessageText Property
GuiMessageWindow Object : MessageText Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property MessageText As String

See Also

GuiMessageWindow Object | GuiMessageWindow Members


MessageType Property

MessageType Property
GuiMessageWindow Object : MessageType Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property MessageType As Long

See Also

GuiMessageWindow Object | GuiMessageWindow Members


Modified Property

Modified Property
GuiMessageWindow Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiMessageWindow Object | GuiMessageWindow Members


Name Property

Name Property
GuiMessageWindow Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiMessageWindow Object | GuiMessageWindow Members


OKButtonHelpText Property

OKButtonHelpText Property
GuiMessageWindow Object : OKButtonHelpText Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property OKButtonHelpText As String

See Also

GuiMessageWindow Object | GuiMessageWindow Members


OKButtonText Property

OKButtonText Property
GuiMessageWindow Object : OKButtonText Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property OKButtonText As String

See Also

GuiMessageWindow Object | GuiMessageWindow Members


Parent Property

Parent Property
GuiMessageWindow Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiMessageWindow Object | GuiMessageWindow Members


ParentFrame Property

ParentFrame Property
GuiMessageWindow Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiMessageWindow Object | GuiMessageWindow Members


ScreenLeft Property

ScreenLeft Property
GuiMessageWindow Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiMessageWindow Object | GuiMessageWindow Members


ScreenTop Property

ScreenTop Property
GuiMessageWindow Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiMessageWindow Object | GuiMessageWindow Members


Text Property

Text Property
GuiMessageWindow Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiMessageWindow Object | GuiMessageWindow Members


Tooltip Property

Tooltip Property
GuiMessageWindow Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiMessageWindow Object | GuiMessageWindow Members


Top Property

Top Property
GuiMessageWindow Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiMessageWindow Object | GuiMessageWindow Members


Type Property

Type Property
GuiMessageWindow Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiMessageWindow Object | GuiMessageWindow Members


TypeAsNumber Property

TypeAsNumber Property
GuiMessageWindow Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiMessageWindow Object | GuiMessageWindow Members


Visible Property

Visible Property
GuiMessageWindow Object : Visible Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Visible As Byte

See Also

GuiMessageWindow Object | GuiMessageWindow Members


Width Property

Width Property
GuiMessageWindow Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiMessageWindow Object | GuiMessageWindow Members


GuiModalWindow Object

GuiModalWindow Object
See Also Members

Glossary Item Box

Description

A GuiModalWindow is a dialog pop-up.

GuiModalWindow extends GuiFrameWindow.

Object Model

GuiModalWindow ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiVComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiVComponent Object

See Also

GuiModalWindow Members


GuiModalWindow Object Members

GuiModalWindow Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method Close
Public Method CompBitmap
Public Method DumpState
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method HardCopy
Public Method HardCopyToMemory
Public Method Iconify
Public Method IsVKeyAllowed
Public Method JumpBackward
Public Method JumpForward
Public Method Maximize
Public Method Restore
Public Method SendVKey
Public Method SetFocus
Public Method ShowMessageBox
Public Method TabBackward
Public Method TabForward
Public Method Visualize

Public Properties

Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property Children
Public Property ContainerType
Public Property DefaultTooltip
Public Property ElementVisualizationMode
Public Property GuiFocus
Public Property Handle
Public Property Height
Public Property Iconic
Public Property IconName
Public Property Id
Public Property IsPopupDialog

Some modal windows represent popup dialogs. In this case the IsPopupDialog property is True. Popup dialogs are identified by checking the ABAP source name and dynpro number.

Currently the following are supported:

  • SAPLSPO1 / 500 (Function module Popup_To_Confirm)
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property Parent
Public Property ParentFrame
Public Property PopupDialogText
Public Property ScreenLeft
Public Property ScreenTop
Public Property SystemFocus
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width
Public Property WorkingPaneHeight
Public Property WorkingPaneWidth

See Also

GuiModalWindow Object


Close Method

Close Method
GuiModalWindow Object : Close Method

Glossary Item Box

Syntax

Visual Basic
Public Sub Close()

See Also

GuiModalWindow Object | GuiModalWindow Members


CompBitmap Method

CompBitmap Method
Filename1
Filename2
GuiModalWindow Object : CompBitmap Method

Glossary Item Box

Syntax

Visual Basic
Public Function CompBitmap( _
   ByVal Filename1 As String, _
   ByVal Filename2 As String _
) As Long

Parameters

Filename1
Filename2

See Also

GuiModalWindow Object | GuiModalWindow Members


DumpState Method

DumpState Method
InnerObject
GuiModalWindow Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiModalWindow Object | GuiModalWindow Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiModalWindow Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiModalWindow Object | GuiModalWindow Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiModalWindow Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiModalWindow Object | GuiModalWindow Members


FindById Method

FindById Method
Id
Raise
GuiModalWindow Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiModalWindow Object | GuiModalWindow Members


FindByName Method

FindByName Method
Name
Type
GuiModalWindow Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiModalWindow Object | GuiModalWindow Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiModalWindow Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiModalWindow Object | GuiModalWindow Members


HardCopy Method

HardCopy Method
Filename
ImageType
xPos
yPos
nWidth
nHeight
GuiModalWindow Object : HardCopy Method

Glossary Item Box

Syntax

Visual Basic
Public Function HardCopy( _
   ByVal Filename As String, _
   Optional ByVal ImageType As Variant, _
   Optional ByVal xPos As Variant, _
   Optional ByVal yPos As Variant, _
   Optional ByVal nWidth As Variant, _
   Optional ByVal nHeight As Variant _
) As String

Parameters

Filename
ImageType
xPos
yPos
nWidth
nHeight

See Also

GuiModalWindow Object | GuiModalWindow Members


HardCopyToMemory Method

HardCopyToMemory Method
ImageType
GuiModalWindow Object : HardCopyToMemory Method

Glossary Item Box

Syntax

Visual Basic
Public Function HardCopyToMemory( _
   Optional ByVal ImageType As Variant _
) As Variant

Parameters

ImageType

See Also

GuiModalWindow Object | GuiModalWindow Members


Iconify Method

Iconify Method
GuiModalWindow Object : Iconify Method

Glossary Item Box

Syntax

Visual Basic
Public Sub Iconify()

See Also

GuiModalWindow Object | GuiModalWindow Members


IsVKeyAllowed Method

IsVKeyAllowed Method
VKey
GuiModalWindow Object : IsVKeyAllowed Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsVKeyAllowed( _
   ByVal VKey As Integer _
) As Byte

Parameters

VKey

See Also

GuiModalWindow Object | GuiModalWindow Members


JumpBackward Method

JumpBackward Method
GuiModalWindow Object : JumpBackward Method

Glossary Item Box

Syntax

Visual Basic
Public Sub JumpBackward()

See Also

GuiModalWindow Object | GuiModalWindow Members


JumpForward Method

JumpForward Method
GuiModalWindow Object : JumpForward Method

Glossary Item Box

Syntax

Visual Basic
Public Sub JumpForward()

See Also

GuiModalWindow Object | GuiModalWindow Members


Maximize Method

Maximize Method
GuiModalWindow Object : Maximize Method

Glossary Item Box

Syntax

Visual Basic
Public Sub Maximize()

See Also

GuiModalWindow Object | GuiModalWindow Members


Restore Method

Restore Method
GuiModalWindow Object : Restore Method

Glossary Item Box

Syntax

Visual Basic
Public Sub Restore()

See Also

GuiModalWindow Object | GuiModalWindow Members


SendVKey Method

SendVKey Method
VKey
GuiModalWindow Object : SendVKey Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SendVKey( _
   ByVal VKey As Integer _
)

Parameters

VKey

See Also

GuiModalWindow Object | GuiModalWindow Members


SetFocus Method

SetFocus Method
GuiModalWindow Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiModalWindow Object | GuiModalWindow Members


ShowMessageBox Method

ShowMessageBox Method
Title
Text
MsgIcon
MsgType
GuiModalWindow Object : ShowMessageBox Method

Glossary Item Box

Syntax

Visual Basic
Public Function ShowMessageBox( _
   ByVal Title As String, _
   ByVal Text As String, _
   ByVal MsgIcon As Long, _
   ByVal MsgType As Long _
) As Long

Parameters

Title
Text
MsgIcon
MsgType

See Also

GuiModalWindow Object | GuiModalWindow Members


TabBackward Method

TabBackward Method
GuiModalWindow Object : TabBackward Method

Glossary Item Box

Syntax

Visual Basic
Public Sub TabBackward()

See Also

GuiModalWindow Object | GuiModalWindow Members


TabForward Method

TabForward Method
GuiModalWindow Object : TabForward Method

Glossary Item Box

Syntax

Visual Basic
Public Sub TabForward()

See Also

GuiModalWindow Object | GuiModalWindow Members


Visualize Method

Visualize Method
On
InnerObject
GuiModalWindow Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiModalWindow Object | GuiModalWindow Members


AccLabelCollection Property

AccLabelCollection Property
GuiModalWindow Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiModalWindow Object | GuiModalWindow Members


AccText Property

AccText Property
GuiModalWindow Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiModalWindow Object | GuiModalWindow Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiModalWindow Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiModalWindow Object | GuiModalWindow Members


AccTooltip Property

AccTooltip Property
GuiModalWindow Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiModalWindow Object | GuiModalWindow Members


Changeable Property

Changeable Property
GuiModalWindow Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiModalWindow Object | GuiModalWindow Members


Children Property

Children Property
GuiModalWindow Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiModalWindow Object | GuiModalWindow Members


ContainerType Property

ContainerType Property
GuiModalWindow Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiModalWindow Object | GuiModalWindow Members


DefaultTooltip Property

DefaultTooltip Property
GuiModalWindow Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiModalWindow Object | GuiModalWindow Members


ElementVisualizationMode Property

ElementVisualizationMode Property
GuiModalWindow Object : ElementVisualizationMode Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property ElementVisualizationMode As Byte

See Also

GuiModalWindow Object | GuiModalWindow Members


GuiFocus Property

GuiFocus Property
GuiModalWindow Object : GuiFocus Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property GuiFocus As GuiVComponent

See Also

GuiModalWindow Object | GuiModalWindow Members


Handle Property

Handle Property
GuiModalWindow Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiModalWindow Object | GuiModalWindow Members


Height Property

Height Property
GuiModalWindow Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiModalWindow Object | GuiModalWindow Members


Iconic Property

Iconic Property
GuiModalWindow Object : Iconic Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Iconic As Byte

See Also

GuiModalWindow Object | GuiModalWindow Members


IconName Property

IconName Property
GuiModalWindow Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiModalWindow Object | GuiModalWindow Members


Id Property

Id Property
GuiModalWindow Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiModalWindow Object | GuiModalWindow Members


IsPopupDialog Property

IsPopupDialog Property
GuiModalWindow Object : IsPopupDialog Property

Glossary Item Box

Description

Some modal windows represent popup dialogs. In this case the IsPopupDialog property is True. Popup dialogs are identified by checking the ABAP source name and dynpro number.

Currently the following are supported:

  • SAPLSPO1 / 500 (Function module Popup_To_Confirm)

Property type

Read-write property

Syntax

Visual Basic
Public Property IsPopupDialog As Byte

See Also

GuiModalWindow Object | GuiModalWindow Members


IsSymbolFont Property

IsSymbolFont Property
GuiModalWindow Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiModalWindow Object | GuiModalWindow Members


Left Property

Left Property
GuiModalWindow Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiModalWindow Object | GuiModalWindow Members


Modified Property

Modified Property
GuiModalWindow Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiModalWindow Object | GuiModalWindow Members


Name Property

Name Property
GuiModalWindow Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiModalWindow Object | GuiModalWindow Members


Parent Property

Parent Property
GuiModalWindow Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiModalWindow Object | GuiModalWindow Members


ParentFrame Property

ParentFrame Property
GuiModalWindow Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiModalWindow Object | GuiModalWindow Members


PopupDialogText Property

PopupDialogText Property
GuiModalWindow Object : PopupDialogText Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property PopupDialogText As String

See Also

GuiModalWindow Object | GuiModalWindow Members


ScreenLeft Property

ScreenLeft Property
GuiModalWindow Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiModalWindow Object | GuiModalWindow Members


ScreenTop Property

ScreenTop Property
GuiModalWindow Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiModalWindow Object | GuiModalWindow Members


SystemFocus Property

SystemFocus Property
GuiModalWindow Object : SystemFocus Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property SystemFocus As GuiVComponent

See Also

GuiModalWindow Object | GuiModalWindow Members


Text Property

Text Property
GuiModalWindow Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiModalWindow Object | GuiModalWindow Members


Tooltip Property

Tooltip Property
GuiModalWindow Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiModalWindow Object | GuiModalWindow Members


Top Property

Top Property
GuiModalWindow Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiModalWindow Object | GuiModalWindow Members


Type Property

Type Property
GuiModalWindow Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiModalWindow Object | GuiModalWindow Members


TypeAsNumber Property

TypeAsNumber Property
GuiModalWindow Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiModalWindow Object | GuiModalWindow Members


Width Property

Width Property
GuiModalWindow Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiModalWindow Object | GuiModalWindow Members


WorkingPaneHeight Property

WorkingPaneHeight Property
GuiModalWindow Object : WorkingPaneHeight Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property WorkingPaneHeight As Long

See Also

GuiModalWindow Object | GuiModalWindow Members


WorkingPaneWidth Property

WorkingPaneWidth Property
GuiModalWindow Object : WorkingPaneWidth Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property WorkingPaneWidth As Long

See Also

GuiModalWindow Object | GuiModalWindow Members


GuiNetChart Object

GuiNetChart Object
See Also Members

Glossary Item Box

Description

The GuiNetChart is a powerful tool to display and modify entity relationship diagrams. It is of a very technical nature and shoud only be used for recording and playback, as most of the parameters can not be determined in any other way.

Object Model

GuiNetChart ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiComponent ObjectGuiComponent Object

Example

See Also

GuiNetChart Members


GuiNetChart Object Members

GuiNetChart Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method GetLinkContent | Returns the content of the link.
Public Method GetNodeContent | Returns the content of the node.
Public Method SelectContextMenuItem
Public Method SelectContextMenuItemByPosition
Public Method SelectContextMenuItemByText
Public Method SendData

This function emulates the output of each action triggered at the control side. The result of the action is sent to the server.

It’s currently not possible to select – deselect single objects at the client-side and to replay/script these “local” actions.

Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccDescription |
Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property Changeable |
Public Property Children |
Public Property ContainerType |
Public Property CurrentContextMenu |
Public Property DefaultTooltip |
Public Property DragDropSupported |
Public Property Handle |
Public Property Height |
Public Property IconName |
Public Property Id |
Public Property IsSymbolFont |
Public Property Left |
Public Property LinkCount | Number of links in the net.
Public Property Modified |
Public Property Name |
Public Property NodeCount | Number of Nodes in the net.
Public Property OcxEvents |
Public Property Parent |
Public Property ParentFrame |
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property SubType | This property has the constant value “sapnetz”
Public Property Text |
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property Width |

See Also

GuiNetChart Object


DumpState Method

DumpState Method
InnerObject
GuiNetChart Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiNetChart Object | GuiNetChart Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiNetChart Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiNetChart Object | GuiNetChart Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiNetChart Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiNetChart Object | GuiNetChart Members


FindById Method

FindById Method
Id
Raise
GuiNetChart Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiNetChart Object | GuiNetChart Members


FindByName Method

FindByName Method
Name
Type
GuiNetChart Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiNetChart Object | GuiNetChart Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiNetChart Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiNetChart Object | GuiNetChart Members


GetLinkContent Method

GetLinkContent Method
linkId
Index of the link.
textId
Internal value, do be determined during recording.
GuiNetChart Object : GetLinkContent Method

Glossary Item Box

Description

Returns the content of the link.

Syntax

Visual Basic
Public Function GetLinkContent( _
   ByVal linkId As Long, _
   ByVal textId As Long _
) As String

Parameters

linkId
Index of the link.
textId
Internal value, do be determined during recording.

See Also

GuiNetChart Object | GuiNetChart Members


GetNodeContent Method

GetNodeContent Method
nodeId
Index of the node.
textId
Internal value, do be determined during recording.
GuiNetChart Object : GetNodeContent Method

Glossary Item Box

Description

Returns the content of the node.

Syntax

Visual Basic
Public Function GetNodeContent( _
   ByVal nodeId As Long, _
   ByVal textId As Long _
) As String

Parameters

nodeId
Index of the node.
textId
Internal value, do be determined during recording.

See Also

GuiNetChart Object | GuiNetChart Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiNetChart Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiNetChart Object | GuiNetChart Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiNetChart Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiNetChart Object | GuiNetChart Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiNetChart Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

GuiNetChart Object | GuiNetChart Members


SendData Method

SendData Method
Data
Internal data stream. To be determined during recording.
GuiNetChart Object : SendData Method

Glossary Item Box

Description

This function emulates the output of each action triggered at the control side. The result of the action is sent to the server.

It’s currently not possible to select – deselect single objects at the client-side and to replay/script these “local” actions.

Syntax

Visual Basic
Public Sub SendData( _
   ByVal Data As String _
)

Parameters

Data
Internal data stream. To be determined during recording.

See Also

GuiNetChart Object | GuiNetChart Members


SetFocus Method

SetFocus Method
GuiNetChart Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiNetChart Object | GuiNetChart Members


ShowContextMenu Method

ShowContextMenu Method
GuiNetChart Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiNetChart Object | GuiNetChart Members


Visualize Method

Visualize Method
On
InnerObject
GuiNetChart Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiNetChart Object | GuiNetChart Members


AccDescription Property

AccDescription Property
GuiNetChart Object : AccDescription Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccDescription As String

See Also

GuiNetChart Object | GuiNetChart Members


AccLabelCollection Property

AccLabelCollection Property
GuiNetChart Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiNetChart Object | GuiNetChart Members


AccText Property

AccText Property
GuiNetChart Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiNetChart Object | GuiNetChart Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiNetChart Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiNetChart Object | GuiNetChart Members


AccTooltip Property

AccTooltip Property
GuiNetChart Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiNetChart Object | GuiNetChart Members


Changeable Property

Changeable Property
GuiNetChart Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiNetChart Object | GuiNetChart Members


Children Property

Children Property
GuiNetChart Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiNetChart Object | GuiNetChart Members


ContainerType Property

ContainerType Property
GuiNetChart Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiNetChart Object | GuiNetChart Members


CurrentContextMenu Property

CurrentContextMenu Property
GuiNetChart Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

GuiNetChart Object | GuiNetChart Members


DefaultTooltip Property

DefaultTooltip Property
GuiNetChart Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiNetChart Object | GuiNetChart Members


DragDropSupported Property

DragDropSupported Property
GuiNetChart Object : DragDropSupported Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DragDropSupported As Byte

See Also

GuiNetChart Object | GuiNetChart Members


Handle Property

Handle Property
GuiNetChart Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiNetChart Object | GuiNetChart Members


Height Property

Height Property
GuiNetChart Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiNetChart Object | GuiNetChart Members


IconName Property

IconName Property
GuiNetChart Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiNetChart Object | GuiNetChart Members


Id Property

Id Property
GuiNetChart Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiNetChart Object | GuiNetChart Members


IsSymbolFont Property

IsSymbolFont Property
GuiNetChart Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiNetChart Object | GuiNetChart Members


Left Property

Left Property
GuiNetChart Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiNetChart Object | GuiNetChart Members


LinkCount Property

LinkCount Property
GuiNetChart Object : LinkCount Property

Glossary Item Box

Description

Number of links in the net.

Property type

Read-only property

Syntax

Visual Basic
Public Property LinkCount As Long

See Also

GuiNetChart Object | GuiNetChart Members


Modified Property

Modified Property
GuiNetChart Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiNetChart Object | GuiNetChart Members


Name Property

Name Property
GuiNetChart Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiNetChart Object | GuiNetChart Members


NodeCount Property

NodeCount Property
GuiNetChart Object : NodeCount Property

Glossary Item Box

Description

Number of Nodes in the net.

Property type

Read-only property

Syntax

Visual Basic
Public Property NodeCount As Long

See Also

GuiNetChart Object | GuiNetChart Members


OcxEvents Property

OcxEvents Property
GuiNetChart Object : OcxEvents Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property OcxEvents As GuiCollection

See Also

GuiNetChart Object | GuiNetChart Members


Parent Property

Parent Property
GuiNetChart Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiNetChart Object | GuiNetChart Members


ParentFrame Property

ParentFrame Property
GuiNetChart Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiNetChart Object | GuiNetChart Members


ScreenLeft Property

ScreenLeft Property
GuiNetChart Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiNetChart Object | GuiNetChart Members


ScreenTop Property

ScreenTop Property
GuiNetChart Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiNetChart Object | GuiNetChart Members


SubType Property

SubType Property
GuiNetChart Object : SubType Property

Glossary Item Box

Description

This property has the constant value “sapnetz”

Property type

Read-only property

Syntax

Visual Basic
Public Property SubType As String

See Also

GuiNetChart Object | GuiNetChart Members


Text Property

Text Property
GuiNetChart Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiNetChart Object | GuiNetChart Members


Tooltip Property

Tooltip Property
GuiNetChart Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiNetChart Object | GuiNetChart Members


Top Property

Top Property
GuiNetChart Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiNetChart Object | GuiNetChart Members


Type Property

Type Property
GuiNetChart Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiNetChart Object | GuiNetChart Members


TypeAsNumber Property

TypeAsNumber Property
GuiNetChart Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiNetChart Object | GuiNetChart Members


Width Property

Width Property
GuiNetChart Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiNetChart Object | GuiNetChart Members


GuiOfficeIntegration Object

GuiOfficeIntegration Object
See Also Members

Glossary Item Box

Object Model

GuiOfficeIntegration ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiComponent ObjectGuiComponent Object

See Also

GuiOfficeIntegration Members


GuiOfficeIntegration Object Members

GuiOfficeIntegration Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method AppendRow | This function appends a new row to a table specified by the parameter name in the table collection. The parameter row is the base64 representation of the binary row.
Public Method CloseDocument | This function sends the close event of the document specified by the parameter cookie to the server.
Public Method CustomEvent | This function sends the custom event eventName to the server. The document specified by the parameter cookie is the source.
Public Method DumpState |
Public Method FindAllByName |
Public Method FindAllByNameEx |
Public Method FindById |
Public Method FindByName |
Public Method FindByNameEx |
Public Method RemoveContent | This function removes the content of a table in the table collection. The parameter name is the name of the table.
Public Method SaveDocument | This function sends the save event of the document specified by the parameter cookie to the server.
Public Method SelectContextMenuItem |
Public Method SelectContextMenuItemByPosition |
Public Method SelectContextMenuItemByText |
Public Method SetDocument | This function replaces or adds a new document with the specified index. The parameter document is the base64-representation of the binary document.
Public Method SetFocus |
Public Method ShowContextMenu |
Public Method Visualize |

Public Properties

Public Property AccDescription |
Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property Changeable |
Public Property Children |
Public Property ContainerType |
Public Property CurrentContextMenu |
Public Property DefaultTooltip |
Public Property Document |
Public Property DragDropSupported |
Public Property Handle |
Public Property Height |
Public Property HostedApplication |
Public Property IconName |
Public Property Id |
Public Property IsSymbolFont |
Public Property Left |
Public Property Modified |
Public Property Name |
Public Property OcxEvents |
Public Property Parent |
Public Property ParentFrame |
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property SubType | This property has the constant value “OfficeIntegration”.
Public Property Text |
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property Width |

See Also

GuiOfficeIntegration Object


AppendRow Method

AppendRow Method
Name
Row
GuiOfficeIntegration Object : AppendRow Method

Glossary Item Box

Description

This function appends a new row to a table specified by the parameter name in the table collection. The parameter row is the base64 representation of the binary row.

Syntax

Visual Basic
Public Sub AppendRow( _
   ByVal Name As String, _
   ByVal Row As String _
)

Parameters

Name
Row

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


CloseDocument Method

CloseDocument Method
Cookie
EverChanged
ChangedAfterSave
GuiOfficeIntegration Object : CloseDocument Method

Glossary Item Box

Description

This function sends the close event of the document specified by the parameter cookie to the server.

Syntax

Visual Basic
Public Sub CloseDocument( _
   ByVal Cookie As Long, _
   ByVal EverChanged As Byte, _
   ByVal ChangedAfterSave As Byte _
)

Parameters

Cookie
EverChanged
ChangedAfterSave

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


CustomEvent Method

CustomEvent Method
Cookie
EventName
ParamCount
Par1
Par2
Par3
Par4
Par5
Par6
Par7
Par8
Par9
Par10
Par11
Par12
GuiOfficeIntegration Object : CustomEvent Method

Glossary Item Box

Description

This function sends the custom event eventName to the server. The document specified by the parameter cookie is the source.

Syntax

Visual Basic
Public Sub CustomEvent( _
   ByVal Cookie As Long, _
   ByVal EventName As String, _
   ByVal ParamCount As Long, _
   Optional ByVal Par1 As Variant, _
   Optional ByVal Par2 As Variant, _
   Optional ByVal Par3 As Variant, _
   Optional ByVal Par4 As Variant, _
   Optional ByVal Par5 As Variant, _
   Optional ByVal Par6 As Variant, _
   Optional ByVal Par7 As Variant, _
   Optional ByVal Par8 As Variant, _
   Optional ByVal Par9 As Variant, _
   Optional ByVal Par10 As Variant, _
   Optional ByVal Par11 As Variant, _
   Optional ByVal Par12 As Variant _
)

Parameters

Cookie
EventName
ParamCount
Par1
Par2
Par3
Par4
Par5
Par6
Par7
Par8
Par9
Par10
Par11
Par12

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


DumpState Method

DumpState Method
InnerObject
GuiOfficeIntegration Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiOfficeIntegration Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiOfficeIntegration Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


FindById Method

FindById Method
Id
Raise
GuiOfficeIntegration Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


FindByName Method

FindByName Method
Name
Type
GuiOfficeIntegration Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiOfficeIntegration Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


RemoveContent Method

RemoveContent Method
Name
GuiOfficeIntegration Object : RemoveContent Method

Glossary Item Box

Description

This function removes the content of a table in the table collection. The parameter name is the name of the table.

Syntax

Visual Basic
Public Sub RemoveContent( _
   ByVal Name As String _
)

Parameters

Name

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


SaveDocument Method

SaveDocument Method
Cookie
Changed
GuiOfficeIntegration Object : SaveDocument Method

Glossary Item Box

Description

This function sends the save event of the document specified by the parameter cookie to the server.

Syntax

Visual Basic
Public Sub SaveDocument( _
   ByVal Cookie As Long, _
   ByVal Changed As Byte _
)

Parameters

Cookie
Changed

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiOfficeIntegration Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiOfficeIntegration Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiOfficeIntegration Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


SetDocument Method

SetDocument Method
Index
Document
GuiOfficeIntegration Object : SetDocument Method

Glossary Item Box

Description

This function replaces or adds a new document with the specified index. The parameter document is the base64-representation of the binary document.

Syntax

Visual Basic
Public Sub SetDocument( _
   ByVal Index As Long, _
   ByVal Document As String _
)

Parameters

Index
Document

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


SetFocus Method

SetFocus Method
GuiOfficeIntegration Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


ShowContextMenu Method

ShowContextMenu Method
GuiOfficeIntegration Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


Visualize Method

Visualize Method
On
InnerObject
GuiOfficeIntegration Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


AccDescription Property

AccDescription Property
GuiOfficeIntegration Object : AccDescription Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccDescription As String

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


AccLabelCollection Property

AccLabelCollection Property
GuiOfficeIntegration Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


AccText Property

AccText Property
GuiOfficeIntegration Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiOfficeIntegration Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


AccTooltip Property

AccTooltip Property
GuiOfficeIntegration Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


Changeable Property

Changeable Property
GuiOfficeIntegration Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


Children Property

Children Property
GuiOfficeIntegration Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


ContainerType Property

ContainerType Property
GuiOfficeIntegration Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


CurrentContextMenu Property

CurrentContextMenu Property
GuiOfficeIntegration Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


DefaultTooltip Property

DefaultTooltip Property
GuiOfficeIntegration Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


Document Property

Document Property
GuiOfficeIntegration Object : Document Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Document As Object

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


DragDropSupported Property

DragDropSupported Property
GuiOfficeIntegration Object : DragDropSupported Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DragDropSupported As Byte

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


Handle Property

Handle Property
GuiOfficeIntegration Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


Height Property

Height Property
GuiOfficeIntegration Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


HostedApplication Property

HostedApplication Property
GuiOfficeIntegration Object : HostedApplication Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property HostedApplication As Long

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


IconName Property

IconName Property
GuiOfficeIntegration Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


Id Property

Id Property
GuiOfficeIntegration Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


IsSymbolFont Property

IsSymbolFont Property
GuiOfficeIntegration Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


Left Property

Left Property
GuiOfficeIntegration Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


Modified Property

Modified Property
GuiOfficeIntegration Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


Name Property

Name Property
GuiOfficeIntegration Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


OcxEvents Property

OcxEvents Property
GuiOfficeIntegration Object : OcxEvents Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property OcxEvents As GuiCollection

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


Parent Property

Parent Property
GuiOfficeIntegration Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


ParentFrame Property

ParentFrame Property
GuiOfficeIntegration Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


ScreenLeft Property

ScreenLeft Property
GuiOfficeIntegration Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


ScreenTop Property

ScreenTop Property
GuiOfficeIntegration Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


SubType Property

SubType Property
GuiOfficeIntegration Object : SubType Property

Glossary Item Box

Description

This property has the constant value “OfficeIntegration”.

Property type

Read-only property

Syntax

Visual Basic
Public Property SubType As String

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


Text Property

Text Property
GuiOfficeIntegration Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


Tooltip Property

Tooltip Property
GuiOfficeIntegration Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


Top Property

Top Property
GuiOfficeIntegration Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


Type Property

Type Property
GuiOfficeIntegration Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


TypeAsNumber Property

TypeAsNumber Property
GuiOfficeIntegration Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


Width Property

Width Property
GuiOfficeIntegration Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiOfficeIntegration Object | GuiOfficeIntegration Members


GuiOkCodeField Object

GuiOkCodeField Object
See Also Members

Glossary Item Box

Description

The GuiOkCodeField is placed on the upper toolbar of the main window. It is a combo box into which commands can be entered. Setting the text of GuiOkCodeField will not execute the command until server communication is started, for example by emulating the Enter key (VKey 0). GuiOkCodeField extends GuiVComponent. The type prefix is okcd, the name is empty.

Object Model

GuiOkCodeField ObjectGuiComponentCollection CollectionGuiCollection CollectionGuiComponent ObjectGuiComponent Object

Example

See Also

GuiOkCodeField Members


GuiOkCodeField Object Members

GuiOkCodeField Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState |
Public Method PressF1 | Emulate pressing the F1 key while the focus is on the GuiOkCodeField.
Public Method SetFocus |
Public Method ShowContextMenu |
Public Method Visualize |

Public Properties

Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property Changeable |
Public Property ContainerType |
Public Property DefaultTooltip |
Public Property Height |
Public Property IconName |
Public Property Id |
Public Property IsSymbolFont |
Public Property Left |
Public Property Modified |
Public Property Name |
Public Property Opened | In New Visual Design the GuiOkCodeField can be collapsed using the arrow button to the right of it.
Public Property Parent |
Public Property ParentFrame |
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property Text |
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property Width |

See Also

GuiOkCodeField Object


DumpState Method

DumpState Method
InnerObject
GuiOkCodeField Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiOkCodeField Object | GuiOkCodeField Members


PressF1 Method

PressF1 Method
GuiOkCodeField Object : PressF1 Method

Glossary Item Box

Description

Emulate pressing the F1 key while the focus is on the GuiOkCodeField.

Syntax

Visual Basic
Public Sub PressF1()

See Also

GuiOkCodeField Object | GuiOkCodeField Members


SetFocus Method

SetFocus Method
GuiOkCodeField Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiOkCodeField Object | GuiOkCodeField Members


ShowContextMenu Method

ShowContextMenu Method
GuiOkCodeField Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiOkCodeField Object | GuiOkCodeField Members


Visualize Method

Visualize Method
On
InnerObject
GuiOkCodeField Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiOkCodeField Object | GuiOkCodeField Members


AccLabelCollection Property

AccLabelCollection Property
GuiOkCodeField Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiOkCodeField Object | GuiOkCodeField Members


AccText Property

AccText Property
GuiOkCodeField Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiOkCodeField Object | GuiOkCodeField Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiOkCodeField Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiOkCodeField Object | GuiOkCodeField Members


AccTooltip Property

AccTooltip Property
GuiOkCodeField Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiOkCodeField Object | GuiOkCodeField Members


Changeable Property

Changeable Property
GuiOkCodeField Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiOkCodeField Object | GuiOkCodeField Members


ContainerType Property

ContainerType Property
GuiOkCodeField Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiOkCodeField Object | GuiOkCodeField Members


DefaultTooltip Property

DefaultTooltip Property
GuiOkCodeField Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiOkCodeField Object | GuiOkCodeField Members


Height Property

Height Property
GuiOkCodeField Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiOkCodeField Object | GuiOkCodeField Members


IconName Property

IconName Property
GuiOkCodeField Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiOkCodeField Object | GuiOkCodeField Members


Id Property

Id Property
GuiOkCodeField Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiOkCodeField Object | GuiOkCodeField Members


IsSymbolFont Property

IsSymbolFont Property
GuiOkCodeField Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiOkCodeField Object | GuiOkCodeField Members


Left Property

Left Property
GuiOkCodeField Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiOkCodeField Object | GuiOkCodeField Members


Modified Property

Modified Property
GuiOkCodeField Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiOkCodeField Object | GuiOkCodeField Members


Name Property

Name Property
GuiOkCodeField Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiOkCodeField Object | GuiOkCodeField Members


Opened Property

Opened Property
GuiOkCodeField Object : Opened Property

Glossary Item Box

Description

In New Visual Design the GuiOkCodeField can be collapsed using the arrow button to the right of it.

Property type

Read-write property

Syntax

Visual Basic
Public Property Opened As Byte

Example

Open:

Closed:

See Also

GuiOkCodeField Object | GuiOkCodeField Members


Parent Property

Parent Property
GuiOkCodeField Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiOkCodeField Object | GuiOkCodeField Members


ParentFrame Property

ParentFrame Property
GuiOkCodeField Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiOkCodeField Object | GuiOkCodeField Members


ScreenLeft Property

ScreenLeft Property
GuiOkCodeField Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiOkCodeField Object | GuiOkCodeField Members


ScreenTop Property

ScreenTop Property
GuiOkCodeField Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiOkCodeField Object | GuiOkCodeField Members


Text Property

Text Property
GuiOkCodeField Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiOkCodeField Object | GuiOkCodeField Members


Tooltip Property

Tooltip Property
GuiOkCodeField Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiOkCodeField Object | GuiOkCodeField Members


Top Property

Top Property
GuiOkCodeField Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiOkCodeField Object | GuiOkCodeField Members


Type Property

Type Property
GuiOkCodeField Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiOkCodeField Object | GuiOkCodeField Members


TypeAsNumber Property

TypeAsNumber Property
GuiOkCodeField Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiOkCodeField Object | GuiOkCodeField Members


Width Property

Width Property
GuiOkCodeField Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiOkCodeField Object | GuiOkCodeField Members


GuiPasswordField Object

GuiPasswordField Object
See Also Members

Glossary Item Box

Description

The only difference between GuiTextField and GuiPasswordField is that the Text property can not be read for a password field. The returned text is always empty. GuiPasswordField extends GuiTextField. The type prefix is pwd, the name is the fieldname taken from the SAP data dictionary.

Object Model

GuiPasswordField ObjectGuiComponentCollection CollectionGuiCollection CollectionGuiCollection CollectionGuiVComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiVComponent Object

See Also

GuiPasswordField Members


GuiPasswordField Object Members

GuiPasswordField Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property CaretPosition
Public Property Changeable
Public Property CharHeight
Public Property CharLeft
Public Property CharTop
Public Property CharWidth
Public Property ContainerType
Public Property DefaultTooltip
Public Property DisplayedText
Public Property Height
Public Property Highlighted
Public Property HistoryCurEntry
Public Property HistoryCurIndex
Public Property HistoryIsActive
Public Property HistoryList
Public Property IconName
Public Property Id
Public Property IsHotspot
Public Property IsLeftLabel
Public Property IsOField
Public Property IsRightLabel
Public Property IsSymbolFont
Public Property Left
Public Property LeftLabel
Public Property MaxLength
Public Property Modified
Public Property Name
Public Property Numerical
Public Property Parent
Public Property ParentFrame
Public Property Required
Public Property RightLabel
Public Property ScreenLeft
Public Property ScreenTop
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiPasswordField Object


DumpState Method

DumpState Method
InnerObject
GuiPasswordField Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiPasswordField Object | GuiPasswordField Members


SetFocus Method

SetFocus Method
GuiPasswordField Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiPasswordField Object | GuiPasswordField Members


ShowContextMenu Method

ShowContextMenu Method
GuiPasswordField Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiPasswordField Object | GuiPasswordField Members


Visualize Method

Visualize Method
On
InnerObject
GuiPasswordField Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiPasswordField Object | GuiPasswordField Members


AccLabelCollection Property

AccLabelCollection Property
GuiPasswordField Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiPasswordField Object | GuiPasswordField Members


AccText Property

AccText Property
GuiPasswordField Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiPasswordField Object | GuiPasswordField Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiPasswordField Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiPasswordField Object | GuiPasswordField Members


AccTooltip Property

AccTooltip Property
GuiPasswordField Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiPasswordField Object | GuiPasswordField Members


CaretPosition Property

CaretPosition Property
GuiPasswordField Object : CaretPosition Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property CaretPosition As Long

See Also

GuiPasswordField Object | GuiPasswordField Members


Changeable Property

Changeable Property
GuiPasswordField Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiPasswordField Object | GuiPasswordField Members


CharHeight Property

CharHeight Property
GuiPasswordField Object : CharHeight Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharHeight As Long

See Also

GuiPasswordField Object | GuiPasswordField Members


CharLeft Property

CharLeft Property
GuiPasswordField Object : CharLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharLeft As Long

See Also

GuiPasswordField Object | GuiPasswordField Members


CharTop Property

CharTop Property
GuiPasswordField Object : CharTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharTop As Long

See Also

GuiPasswordField Object | GuiPasswordField Members


CharWidth Property

CharWidth Property
GuiPasswordField Object : CharWidth Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharWidth As Long

See Also

GuiPasswordField Object | GuiPasswordField Members


ContainerType Property

ContainerType Property
GuiPasswordField Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiPasswordField Object | GuiPasswordField Members


DefaultTooltip Property

DefaultTooltip Property
GuiPasswordField Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiPasswordField Object | GuiPasswordField Members


DisplayedText Property

DisplayedText Property
GuiPasswordField Object : DisplayedText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DisplayedText As String

See Also

GuiPasswordField Object | GuiPasswordField Members


Height Property

Height Property
GuiPasswordField Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiPasswordField Object | GuiPasswordField Members


Highlighted Property

Highlighted Property
GuiPasswordField Object : Highlighted Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Highlighted As Byte

See Also

GuiPasswordField Object | GuiPasswordField Members


HistoryCurEntry Property

HistoryCurEntry Property
GuiPasswordField Object : HistoryCurEntry Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property HistoryCurEntry As String

See Also

GuiPasswordField Object | GuiPasswordField Members


HistoryCurIndex Property

HistoryCurIndex Property
GuiPasswordField Object : HistoryCurIndex Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property HistoryCurIndex As Long

See Also

GuiPasswordField Object | GuiPasswordField Members


HistoryIsActive Property

HistoryIsActive Property
GuiPasswordField Object : HistoryIsActive Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property HistoryIsActive As Byte

See Also

GuiPasswordField Object | GuiPasswordField Members


HistoryList Property

HistoryList Property
GuiPasswordField Object : HistoryList Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property HistoryList As GuiCollection

See Also

GuiPasswordField Object | GuiPasswordField Members


IconName Property

IconName Property
GuiPasswordField Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiPasswordField Object | GuiPasswordField Members


Id Property

Id Property
GuiPasswordField Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiPasswordField Object | GuiPasswordField Members


IsHotspot Property

IsHotspot Property
GuiPasswordField Object : IsHotspot Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsHotspot As Byte

See Also

GuiPasswordField Object | GuiPasswordField Members


IsLeftLabel Property

IsLeftLabel Property
GuiPasswordField Object : IsLeftLabel Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsLeftLabel As Byte

See Also

GuiPasswordField Object | GuiPasswordField Members


IsOField Property

IsOField Property
GuiPasswordField Object : IsOField Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsOField As Byte

See Also

GuiPasswordField Object | GuiPasswordField Members


IsRightLabel Property

IsRightLabel Property
GuiPasswordField Object : IsRightLabel Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsRightLabel As Byte

See Also

GuiPasswordField Object | GuiPasswordField Members


IsSymbolFont Property

IsSymbolFont Property
GuiPasswordField Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiPasswordField Object | GuiPasswordField Members


Left Property

Left Property
GuiPasswordField Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiPasswordField Object | GuiPasswordField Members


LeftLabel Property

LeftLabel Property
GuiPasswordField Object : LeftLabel Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property LeftLabel As GuiVComponent

See Also

GuiPasswordField Object | GuiPasswordField Members


MaxLength Property

MaxLength Property
GuiPasswordField Object : MaxLength Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property MaxLength As Long

See Also

GuiPasswordField Object | GuiPasswordField Members


Modified Property

Modified Property
GuiPasswordField Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiPasswordField Object | GuiPasswordField Members


Name Property

Name Property
GuiPasswordField Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiPasswordField Object | GuiPasswordField Members


Numerical Property

Numerical Property
GuiPasswordField Object : Numerical Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Numerical As Byte

See Also

GuiPasswordField Object | GuiPasswordField Members


Parent Property

Parent Property
GuiPasswordField Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiPasswordField Object | GuiPasswordField Members


ParentFrame Property

ParentFrame Property
GuiPasswordField Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiPasswordField Object | GuiPasswordField Members


Required Property

Required Property
GuiPasswordField Object : Required Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Required As Byte

See Also

GuiPasswordField Object | GuiPasswordField Members


RightLabel Property

RightLabel Property
GuiPasswordField Object : RightLabel Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property RightLabel As GuiVComponent

See Also

GuiPasswordField Object | GuiPasswordField Members


ScreenLeft Property

ScreenLeft Property
GuiPasswordField Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiPasswordField Object | GuiPasswordField Members


ScreenTop Property

ScreenTop Property
GuiPasswordField Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiPasswordField Object | GuiPasswordField Members


Text Property

Text Property
GuiPasswordField Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiPasswordField Object | GuiPasswordField Members


Tooltip Property

Tooltip Property
GuiPasswordField Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiPasswordField Object | GuiPasswordField Members


Top Property

Top Property
GuiPasswordField Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiPasswordField Object | GuiPasswordField Members


Type Property

Type Property
GuiPasswordField Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiPasswordField Object | GuiPasswordField Members


TypeAsNumber Property

TypeAsNumber Property
GuiPasswordField Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiPasswordField Object | GuiPasswordField Members


Width Property

Width Property
GuiPasswordField Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiPasswordField Object | GuiPasswordField Members


GuiPicture Object

GuiPicture Object
See Also Members

Glossary Item Box

Description

The picture control displays a picture on a SAP GUI screen. GuiPicture extends GuiShell.

Object Model

GuiPicture ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiComponent ObjectGuiComponent Object

Example

See Also

GuiPicture Members


GuiPicture Object Members

GuiPicture Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method Click | This function emulates a single mouse click on a picture.
Public Method ClickControlArea | The function emulates a click on a given position. The coordinates should be given in pixels with respect to the picture control as it is displayed on the screen.
Public Method ClickPictureArea | The function emulates a click on a given position. The coordinates should be given in pixels with respect to the original picture file. They may differ from the pixel coordinates of the displayed picture because of scaling.
Public Method ContextMenu | The function opens a context menu on the given position. The coordinates should be given in pixels with respect to the picture control as it is displayed on the screen.
Public Method DoubleClick | This function emulates a double click on a picture.
Public Method DoubleClickControlArea | The function emulates a double click on a given position. The coordinates should be given in pixels with respect to the picture control as it is displayed on the screen.
Public Method DoubleClickPictureArea | The function emulates a double click on a given position. The coordinates should be given in pixels with respect to the original picture file. They may differ from the pixel coordinates of the displayed picture because of scaling.
Public Method DumpState |
Public Method FindAllByName |
Public Method FindAllByNameEx |
Public Method FindById |
Public Method FindByName |
Public Method FindByNameEx |
Public Method SelectContextMenuItem |
Public Method SelectContextMenuItemByPosition |
Public Method SelectContextMenuItemByText |
Public Method SetFocus |
Public Method ShowContextMenu |
Public Method Visualize |

Public Properties

Public Property AccDescription
Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property AltText
Public Property Changeable
Public Property Children
Public Property ContainerType
Public Property CurrentContextMenu
Public Property DefaultTooltip
Public Property DisplayMode

Possible values of this property are:

  • ”Normal”: This value indicated that the picture is shown in its original size. If the picture’s size is larger than the size of the control, the control provides scrollbars. If the picture’s size is smaller than the size of the control, the picture is shown in the upper left corner of the control.
  • “Stretch”: The picture is resized in a way that it always occupies the complete area of the control.
  • “Fit”: The picture is resized on way that it fits into the control area without havin the need to show scrollbars. In contrast to “Strech” the mode “Fit” preserves the ratio of width and height of the picture.
  • “NormalCenter”: Like “Normal” except that the picture is not shown in the upper left corner but in the center of the control.
  • “FitCenter”: Like “Fit” except that the picture is not shown in the upper left corner but in the center of the control.
Public Property DragDropSupported
Public Property Handle
Public Property Height
Public Property Icon | Returns the SAPGUI icon code (e.g. “@01@”) of the displayed icon. If no icon is displayed, the property contains an empty string.
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property OcxEvents
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property SubType | This property has the constant value “Picture”
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Url | Returns the URL of the displayed picture. If an icon is displayed (see property “icon”), the property contains an empty string. Depending in the application that used the control the URL may contain temporary URL parts (e.g. UUIDs).
Public Property Width

See Also

GuiPicture Object


Click Method

Click Method
GuiPicture Object : Click Method

Glossary Item Box

Description

This function emulates a single mouse click on a picture.

Syntax

Visual Basic
Public Sub Click()

See Also

GuiPicture Object | GuiPicture Members


ClickControlArea Method

ClickControlArea Method
x
y
GuiPicture Object : ClickControlArea Method

Glossary Item Box

Description

The function emulates a click on a given position. The coordinates should be given in pixels with respect to the picture control as it is displayed on the screen.

Syntax

Visual Basic
Public Sub ClickControlArea( _
   ByVal x As Long, _
   ByVal y As Long _
)

Parameters

x
y

See Also

GuiPicture Object | GuiPicture Members


ClickPictureArea Method

ClickPictureArea Method
x
y
GuiPicture Object : ClickPictureArea Method

Glossary Item Box

Description

The function emulates a click on a given position. The coordinates should be given in pixels with respect to the original picture file. They may differ from the pixel coordinates of the displayed picture because of scaling.

Syntax

Visual Basic
Public Sub ClickPictureArea( _
   ByVal x As Long, _
   ByVal y As Long _
)

Parameters

x
y

See Also

GuiPicture Object | GuiPicture Members


ContextMenu Method

ContextMenu Method
x
y
GuiPicture Object : ContextMenu Method

Glossary Item Box

Description

The function opens a context menu on the given position. The coordinates should be given in pixels with respect to the picture control as it is displayed on the screen.

Syntax

Visual Basic
Public Sub ContextMenu( _
   ByVal x As Long, _
   ByVal y As Long _
)

Parameters

x
y

See Also

GuiPicture Object | GuiPicture Members


DoubleClick Method

DoubleClick Method
GuiPicture Object : DoubleClick Method

Glossary Item Box

Description

This function emulates a double click on a picture.

Syntax

Visual Basic
Public Sub DoubleClick()

See Also

GuiPicture Object | GuiPicture Members


DoubleClickControlArea Method

DoubleClickControlArea Method
x
y
GuiPicture Object : DoubleClickControlArea Method

Glossary Item Box

Description

The function emulates a double click on a given position. The coordinates should be given in pixels with respect to the picture control as it is displayed on the screen.

Syntax

Visual Basic
Public Sub DoubleClickControlArea( _
   ByVal x As Long, _
   ByVal y As Long _
)

Parameters

x
y

See Also

GuiPicture Object | GuiPicture Members


DoubleClickPictureArea Method

DoubleClickPictureArea Method
x
y
GuiPicture Object : DoubleClickPictureArea Method

Glossary Item Box

Description

The function emulates a double click on a given position. The coordinates should be given in pixels with respect to the original picture file. They may differ from the pixel coordinates of the displayed picture because of scaling.

Syntax

Visual Basic
Public Sub DoubleClickPictureArea( _
   ByVal x As Long, _
   ByVal y As Long _
)

Parameters

x
y

See Also

GuiPicture Object | GuiPicture Members


DumpState Method

DumpState Method
InnerObject
GuiPicture Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiPicture Object | GuiPicture Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiPicture Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiPicture Object | GuiPicture Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiPicture Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiPicture Object | GuiPicture Members


FindById Method

FindById Method
Id
Raise
GuiPicture Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiPicture Object | GuiPicture Members


FindByName Method

FindByName Method
Name
Type
GuiPicture Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiPicture Object | GuiPicture Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiPicture Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiPicture Object | GuiPicture Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiPicture Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiPicture Object | GuiPicture Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiPicture Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiPicture Object | GuiPicture Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiPicture Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

GuiPicture Object | GuiPicture Members


SetFocus Method

SetFocus Method
GuiPicture Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiPicture Object | GuiPicture Members


ShowContextMenu Method

ShowContextMenu Method
GuiPicture Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiPicture Object | GuiPicture Members


Visualize Method

Visualize Method
On
InnerObject
GuiPicture Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiPicture Object | GuiPicture Members


AccDescription Property

AccDescription Property
GuiPicture Object : AccDescription Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccDescription As String

See Also

GuiPicture Object | GuiPicture Members


AccLabelCollection Property

AccLabelCollection Property
GuiPicture Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiPicture Object | GuiPicture Members


AccText Property

AccText Property
GuiPicture Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiPicture Object | GuiPicture Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiPicture Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiPicture Object | GuiPicture Members


AccTooltip Property

AccTooltip Property
GuiPicture Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiPicture Object | GuiPicture Members


AltText Property

AltText Property
GuiPicture Object : AltText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AltText As String

See Also

GuiPicture Object | GuiPicture Members


Changeable Property

Changeable Property
GuiPicture Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiPicture Object | GuiPicture Members


Children Property

Children Property
GuiPicture Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiPicture Object | GuiPicture Members


ContainerType Property

ContainerType Property
GuiPicture Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiPicture Object | GuiPicture Members


CurrentContextMenu Property

CurrentContextMenu Property
GuiPicture Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

GuiPicture Object | GuiPicture Members


DefaultTooltip Property

DefaultTooltip Property
GuiPicture Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiPicture Object | GuiPicture Members


DisplayMode Property

DisplayMode Property
GuiPicture Object : DisplayMode Property

Glossary Item Box

Description

Possible values of this property are:

  • ”Normal”: This value indicated that the picture is shown in its original size. If the picture’s size is larger than the size of the control, the control provides scrollbars. If the picture’s size is smaller than the size of the control, the picture is shown in the upper left corner of the control.
  • “Stretch”: The picture is resized in a way that it always occupies the complete area of the control.
  • “Fit”: The picture is resized on way that it fits into the control area without havin the need to show scrollbars. In contrast to “Strech” the mode “Fit” preserves the ratio of width and height of the picture.
  • “NormalCenter”: Like “Normal” except that the picture is not shown in the upper left corner but in the center of the control.
  • “FitCenter”: Like “Fit” except that the picture is not shown in the upper left corner but in the center of the control.

Property type

Read-only property

Syntax

Visual Basic
Public Property DisplayMode As String

See Also

GuiPicture Object | GuiPicture Members


DragDropSupported Property

DragDropSupported Property
GuiPicture Object : DragDropSupported Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DragDropSupported As Byte

See Also

GuiPicture Object | GuiPicture Members


Handle Property

Handle Property
GuiPicture Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiPicture Object | GuiPicture Members


Height Property

Height Property
GuiPicture Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiPicture Object | GuiPicture Members


Icon Property

Icon Property
GuiPicture Object : Icon Property

Glossary Item Box

Description

Returns the SAPGUI icon code (e.g. “@01@”) of the displayed icon. If no icon is displayed, the property contains an empty string.

Property type

Read-only property

Syntax

Visual Basic
Public Property Icon As String

See Also

GuiPicture Object | GuiPicture Members


IconName Property

IconName Property
GuiPicture Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiPicture Object | GuiPicture Members


Id Property

Id Property
GuiPicture Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiPicture Object | GuiPicture Members


IsSymbolFont Property

IsSymbolFont Property
GuiPicture Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiPicture Object | GuiPicture Members


Left Property

Left Property
GuiPicture Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiPicture Object | GuiPicture Members


Modified Property

Modified Property
GuiPicture Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiPicture Object | GuiPicture Members


Name Property

Name Property
GuiPicture Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiPicture Object | GuiPicture Members


OcxEvents Property

OcxEvents Property
GuiPicture Object : OcxEvents Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property OcxEvents As GuiCollection

See Also

GuiPicture Object | GuiPicture Members


Parent Property

Parent Property
GuiPicture Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiPicture Object | GuiPicture Members


ParentFrame Property

ParentFrame Property
GuiPicture Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiPicture Object | GuiPicture Members


ScreenLeft Property

ScreenLeft Property
GuiPicture Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiPicture Object | GuiPicture Members


ScreenTop Property

ScreenTop Property
GuiPicture Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiPicture Object | GuiPicture Members


SubType Property

SubType Property
GuiPicture Object : SubType Property

Glossary Item Box

Description

This property has the constant value “Picture”

Property type

Read-only property

Syntax

Visual Basic
Public Property SubType As String

See Also

GuiPicture Object | GuiPicture Members


Text Property

Text Property
GuiPicture Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiPicture Object | GuiPicture Members


Tooltip Property

Tooltip Property
GuiPicture Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiPicture Object | GuiPicture Members


Top Property

Top Property
GuiPicture Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiPicture Object | GuiPicture Members


Type Property

Type Property
GuiPicture Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiPicture Object | GuiPicture Members


TypeAsNumber Property

TypeAsNumber Property
GuiPicture Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiPicture Object | GuiPicture Members


Url Property

Url Property
GuiPicture Object : Url Property

Glossary Item Box

Description

Returns the URL of the displayed picture. If an icon is displayed (see property “icon”), the property contains an empty string. Depending in the application that used the control the URL may contain temporary URL parts (e.g. UUIDs).

Property type

Read-only property

Syntax

Visual Basic
Public Property Url As String

See Also

GuiPicture Object | GuiPicture Members


Width Property

Width Property
GuiPicture Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiPicture Object | GuiPicture Members


GuiRadioButton Object

GuiRadioButton Object
See Also Members

Glossary Item Box

Description

GuiRadioButton extends GuiVComponent. The type prefix is rad, the name is the fieldname taken from the SAP data dictionary.

Object Model

GuiRadioButton ObjectGuiComponentCollection CollectionGuiCollection CollectionGuiComponentCollection CollectionGuiVComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiVComponent Object

See Also

GuiRadioButton Members


GuiRadioButton Object Members

GuiRadioButton Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState |
Public Method Select | Selecting a radio button automatically deselects all the other buttons within that group. This may cause a server roundtrip, depending on the definition of the button in the screen painter.
Public Method SetFocus |
Public Method ShowContextMenu |
Public Method Visualize |

Public Properties

Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property Changeable |
Public Property CharHeight |
Public Property CharLeft |
Public Property CharTop |
Public Property CharWidth |
Public Property ContainerType |
Public Property DefaultTooltip |
Public Property Flushing |
Public Property GroupCount |
Public Property GroupMembers |
Public Property GroupPos |
Public Property Height |
Public Property IconName |
Public Property Id |
Public Property IsLeftLabel |
Public Property IsRightLabel |
Public Property IsSymbolFont |
Public Property Left |
Public Property LeftLabel |
Public Property Modified |
Public Property Name |
Public Property Parent |
Public Property ParentFrame |
Public Property RightLabel |
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property Selected | This property is True if the radio button is selected.
Public Property Text |
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property Width |

See Also

GuiRadioButton Object


DumpState Method

DumpState Method
InnerObject
GuiRadioButton Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiRadioButton Object | GuiRadioButton Members


Select Method

Select Method
GuiRadioButton Object : Select Method

Glossary Item Box

Description

Selecting a radio button automatically deselects all the other buttons within that group. This may cause a server roundtrip, depending on the definition of the button in the screen painter.

Syntax

Visual Basic
Public Sub Select()

Example

In this example selecting the radio button ‘Other…’ causes the SAP server to enable the text field.

See Also

GuiRadioButton Object | GuiRadioButton Members


SetFocus Method

SetFocus Method
GuiRadioButton Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiRadioButton Object | GuiRadioButton Members


ShowContextMenu Method

ShowContextMenu Method
GuiRadioButton Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiRadioButton Object | GuiRadioButton Members


Visualize Method

Visualize Method
On
InnerObject
GuiRadioButton Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiRadioButton Object | GuiRadioButton Members


AccLabelCollection Property

AccLabelCollection Property
GuiRadioButton Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiRadioButton Object | GuiRadioButton Members


AccText Property

AccText Property
GuiRadioButton Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiRadioButton Object | GuiRadioButton Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiRadioButton Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiRadioButton Object | GuiRadioButton Members


AccTooltip Property

AccTooltip Property
GuiRadioButton Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiRadioButton Object | GuiRadioButton Members


Changeable Property

Changeable Property
GuiRadioButton Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiRadioButton Object | GuiRadioButton Members


CharHeight Property

CharHeight Property
GuiRadioButton Object : CharHeight Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharHeight As Long

See Also

GuiRadioButton Object | GuiRadioButton Members


CharLeft Property

CharLeft Property
GuiRadioButton Object : CharLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharLeft As Long

See Also

GuiRadioButton Object | GuiRadioButton Members


CharTop Property

CharTop Property
GuiRadioButton Object : CharTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharTop As Long

See Also

GuiRadioButton Object | GuiRadioButton Members


CharWidth Property

CharWidth Property
GuiRadioButton Object : CharWidth Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharWidth As Long

See Also

GuiRadioButton Object | GuiRadioButton Members


ContainerType Property

ContainerType Property
GuiRadioButton Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiRadioButton Object | GuiRadioButton Members


DefaultTooltip Property

DefaultTooltip Property
GuiRadioButton Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiRadioButton Object | GuiRadioButton Members


Flushing Property

Flushing Property
GuiRadioButton Object : Flushing Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Flushing As Byte

See Also

GuiRadioButton Object | GuiRadioButton Members


GroupCount Property

GroupCount Property
GuiRadioButton Object : GroupCount Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property GroupCount As Long

See Also

GuiRadioButton Object | GuiRadioButton Members


GroupMembers Property

GroupMembers Property
GuiRadioButton Object : GroupMembers Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property GroupMembers As GuiComponentCollection

Example

Set GroupMembers = session.findById("wnd[0]/usr/radRB2").GroupMembers
For Each GroupMember In GroupMembers
MsgBox GroupMember.Text
Next

See Also

GuiRadioButton Object | GuiRadioButton Members


GroupPos Property

GroupPos Property
GuiRadioButton Object : GroupPos Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property GroupPos As Long

See Also

GuiRadioButton Object | GuiRadioButton Members


Height Property

Height Property
GuiRadioButton Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiRadioButton Object | GuiRadioButton Members


IconName Property

IconName Property
GuiRadioButton Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiRadioButton Object | GuiRadioButton Members


Id Property

Id Property
GuiRadioButton Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiRadioButton Object | GuiRadioButton Members


IsLeftLabel Property

IsLeftLabel Property
GuiRadioButton Object : IsLeftLabel Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsLeftLabel As Byte

See Also

GuiRadioButton Object | GuiRadioButton Members


IsRightLabel Property

IsRightLabel Property
GuiRadioButton Object : IsRightLabel Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsRightLabel As Byte

See Also

GuiRadioButton Object | GuiRadioButton Members


IsSymbolFont Property

IsSymbolFont Property
GuiRadioButton Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiRadioButton Object | GuiRadioButton Members


Left Property

Left Property
GuiRadioButton Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiRadioButton Object | GuiRadioButton Members


LeftLabel Property

LeftLabel Property
GuiRadioButton Object : LeftLabel Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property LeftLabel As GuiVComponent

See Also

GuiRadioButton Object | GuiRadioButton Members


Modified Property

Modified Property
GuiRadioButton Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiRadioButton Object | GuiRadioButton Members


Name Property

Name Property
GuiRadioButton Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiRadioButton Object | GuiRadioButton Members


Parent Property

Parent Property
GuiRadioButton Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiRadioButton Object | GuiRadioButton Members


ParentFrame Property

ParentFrame Property
GuiRadioButton Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiRadioButton Object | GuiRadioButton Members


RightLabel Property

RightLabel Property
GuiRadioButton Object : RightLabel Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property RightLabel As GuiVComponent

See Also

GuiRadioButton Object | GuiRadioButton Members


ScreenLeft Property

ScreenLeft Property
GuiRadioButton Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiRadioButton Object | GuiRadioButton Members


ScreenTop Property

ScreenTop Property
GuiRadioButton Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiRadioButton Object | GuiRadioButton Members


Selected Property

Selected Property
GuiRadioButton Object : Selected Property

Glossary Item Box

Description

This property is True if the radio button is selected.

Property type

Read-write property

Syntax

Visual Basic
Public Property Selected As Byte

See Also

GuiRadioButton Object | GuiRadioButton Members


Text Property

Text Property
GuiRadioButton Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiRadioButton Object | GuiRadioButton Members


Tooltip Property

Tooltip Property
GuiRadioButton Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiRadioButton Object | GuiRadioButton Members


Top Property

Top Property
GuiRadioButton Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiRadioButton Object | GuiRadioButton Members


Type Property

Type Property
GuiRadioButton Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiRadioButton Object | GuiRadioButton Members


TypeAsNumber Property

TypeAsNumber Property
GuiRadioButton Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiRadioButton Object | GuiRadioButton Members


Width Property

Width Property
GuiRadioButton Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiRadioButton Object | GuiRadioButton Members


GuiSapChart Object

GuiSapChart Object
See Also Members

Glossary Item Box

Description

For the SAP chart control only basic members from GuiShell are available. Recording and playback is not possible.

Object Model

GuiSapChart ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiComponent ObjectGuiComponent Object

See Also

GuiSapChart Members


GuiSapChart Object Members

GuiSapChart Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method SelectContextMenuItem
Public Method SelectContextMenuItemByPosition
Public Method SelectContextMenuItemByText
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccDescription
Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property Children
Public Property ContainerType
Public Property CurrentContextMenu
Public Property DefaultTooltip
Public Property DragDropSupported
Public Property Handle
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property OcxEvents
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property SubType
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiSapChart Object


DumpState Method

DumpState Method
InnerObject
GuiSapChart Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiSapChart Object | GuiSapChart Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiSapChart Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiSapChart Object | GuiSapChart Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiSapChart Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiSapChart Object | GuiSapChart Members


FindById Method

FindById Method
Id
Raise
GuiSapChart Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiSapChart Object | GuiSapChart Members


FindByName Method

FindByName Method
Name
Type
GuiSapChart Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiSapChart Object | GuiSapChart Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiSapChart Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiSapChart Object | GuiSapChart Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiSapChart Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiSapChart Object | GuiSapChart Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiSapChart Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiSapChart Object | GuiSapChart Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiSapChart Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

GuiSapChart Object | GuiSapChart Members


SetFocus Method

SetFocus Method
GuiSapChart Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiSapChart Object | GuiSapChart Members


ShowContextMenu Method

ShowContextMenu Method
GuiSapChart Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiSapChart Object | GuiSapChart Members


Visualize Method

Visualize Method
On
InnerObject
GuiSapChart Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiSapChart Object | GuiSapChart Members


AccDescription Property

AccDescription Property
GuiSapChart Object : AccDescription Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccDescription As String

See Also

GuiSapChart Object | GuiSapChart Members


AccLabelCollection Property

AccLabelCollection Property
GuiSapChart Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiSapChart Object | GuiSapChart Members


AccText Property

AccText Property
GuiSapChart Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiSapChart Object | GuiSapChart Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiSapChart Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiSapChart Object | GuiSapChart Members


AccTooltip Property

AccTooltip Property
GuiSapChart Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiSapChart Object | GuiSapChart Members


Changeable Property

Changeable Property
GuiSapChart Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiSapChart Object | GuiSapChart Members


Children Property

Children Property
GuiSapChart Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiSapChart Object | GuiSapChart Members


ContainerType Property

ContainerType Property
GuiSapChart Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiSapChart Object | GuiSapChart Members


CurrentContextMenu Property

CurrentContextMenu Property
GuiSapChart Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

GuiSapChart Object | GuiSapChart Members


DefaultTooltip Property

DefaultTooltip Property
GuiSapChart Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiSapChart Object | GuiSapChart Members


DragDropSupported Property

DragDropSupported Property
GuiSapChart Object : DragDropSupported Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DragDropSupported As Byte

See Also

GuiSapChart Object | GuiSapChart Members


Handle Property

Handle Property
GuiSapChart Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiSapChart Object | GuiSapChart Members


Height Property

Height Property
GuiSapChart Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiSapChart Object | GuiSapChart Members


IconName Property

IconName Property
GuiSapChart Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiSapChart Object | GuiSapChart Members


Id Property

Id Property
GuiSapChart Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiSapChart Object | GuiSapChart Members


IsSymbolFont Property

IsSymbolFont Property
GuiSapChart Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiSapChart Object | GuiSapChart Members


Left Property

Left Property
GuiSapChart Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiSapChart Object | GuiSapChart Members


Modified Property

Modified Property
GuiSapChart Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiSapChart Object | GuiSapChart Members


Name Property

Name Property
GuiSapChart Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiSapChart Object | GuiSapChart Members


OcxEvents Property

OcxEvents Property
GuiSapChart Object : OcxEvents Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property OcxEvents As GuiCollection

See Also

GuiSapChart Object | GuiSapChart Members


Parent Property

Parent Property
GuiSapChart Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiSapChart Object | GuiSapChart Members


ParentFrame Property

ParentFrame Property
GuiSapChart Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiSapChart Object | GuiSapChart Members


ScreenLeft Property

ScreenLeft Property
GuiSapChart Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiSapChart Object | GuiSapChart Members


ScreenTop Property

ScreenTop Property
GuiSapChart Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiSapChart Object | GuiSapChart Members


SubType Property

SubType Property
GuiSapChart Object : SubType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property SubType As String

See Also

GuiSapChart Object | GuiSapChart Members


Text Property

Text Property
GuiSapChart Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiSapChart Object | GuiSapChart Members


Tooltip Property

Tooltip Property
GuiSapChart Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiSapChart Object | GuiSapChart Members


Top Property

Top Property
GuiSapChart Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiSapChart Object | GuiSapChart Members


Type Property

Type Property
GuiSapChart Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiSapChart Object | GuiSapChart Members


TypeAsNumber Property

TypeAsNumber Property
GuiSapChart Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiSapChart Object | GuiSapChart Members


Width Property

Width Property
GuiSapChart Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiSapChart Object | GuiSapChart Members


GuiScrollbar Object

GuiScrollbar Object
See Also Members

Glossary Item Box

Description

The GuiScrollbar class is a utility class used for example in GuiScrollContainer or GuiTableControl.

Object Model

GuiScrollbar Object

See Also

GuiScrollbar Members


GuiScrollbar Object Members

GuiScrollbar Object Members
See Also Overview

Glossary Item Box

Public Properties

Public Property Maximum | This is the maximum position of the scrollbar.
Public Property Minimum | This is the minimum position of the scrollbar.
Public Property PageSize | When the user scrolls down a page, position will be increased by the value of pageSize.
Public Property Position | The position of the thumb of the scrollbar can be set to values from minimum to maximum.

See Also

GuiScrollbar Object


Maximum Property

Maximum Property
GuiScrollbar Object : Maximum Property

Glossary Item Box

Description

This is the maximum position of the scrollbar.

Property type

Read-only property

Syntax

Visual Basic
Public Property Maximum As Long

See Also

GuiScrollbar Object | GuiScrollbar Members


Minimum Property

Minimum Property
GuiScrollbar Object : Minimum Property

Glossary Item Box

Description

This is the minimum position of the scrollbar.

Property type

Read-only property

Syntax

Visual Basic
Public Property Minimum As Long

See Also

GuiScrollbar Object | GuiScrollbar Members


PageSize Property

PageSize Property
GuiScrollbar Object : PageSize Property

Glossary Item Box

Description

When the user scrolls down a page, position will be increased by the value of pageSize.

Property type

Read-only property

Syntax

Visual Basic
Public Property PageSize As Long

See Also

GuiScrollbar Object | GuiScrollbar Members


Position Property

Position Property
GuiScrollbar Object : Position Property

Glossary Item Box

Description

The position of the thumb of the scrollbar can be set to values from minimum to maximum.

Property type

Read-write property

Syntax

Visual Basic
Public Property Position As Long

See Also

GuiScrollbar Object | GuiScrollbar Members


GuiScrollContainer Object

GuiScrollContainer Object
See Also Members

Glossary Item Box

Description

This container represents scrollable subscreens. A subscreen may be scrollable without actually having a scrollbar, because the existence of a scrollbar depends on the amount of data displayed and the size of the GuiUserArea. GuiScrollContainer extends GuiVContainer. The type prefix is ssub, the name is generated from the data dictionary settings.

Object Model

GuiScrollContainer ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiScrollbar ObjectGuiComponent ObjectGuiComponent ObjectGuiScrollbar Object

See Also

GuiScrollContainer Members


GuiScrollContainer Object Members

GuiScrollContainer Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property CharHeight
Public Property CharLeft
Public Property CharTop
Public Property CharWidth
Public Property Children
Public Property ContainerType
Public Property DefaultTooltip
Public Property Height
Public Property HorizontalScrollbar
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property VerticalScrollbar
Public Property Width

See Also

GuiScrollContainer Object


DumpState Method

DumpState Method
InnerObject
GuiScrollContainer Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiScrollContainer Object | GuiScrollContainer Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiScrollContainer Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiScrollContainer Object | GuiScrollContainer Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiScrollContainer Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiScrollContainer Object | GuiScrollContainer Members


FindById Method

FindById Method
Id
Raise
GuiScrollContainer Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiScrollContainer Object | GuiScrollContainer Members


FindByName Method

FindByName Method
Name
Type
GuiScrollContainer Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiScrollContainer Object | GuiScrollContainer Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiScrollContainer Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiScrollContainer Object | GuiScrollContainer Members


SetFocus Method

SetFocus Method
GuiScrollContainer Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiScrollContainer Object | GuiScrollContainer Members


ShowContextMenu Method

ShowContextMenu Method
GuiScrollContainer Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiScrollContainer Object | GuiScrollContainer Members


Visualize Method

Visualize Method
On
InnerObject
GuiScrollContainer Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiScrollContainer Object | GuiScrollContainer Members


AccLabelCollection Property

AccLabelCollection Property
GuiScrollContainer Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiScrollContainer Object | GuiScrollContainer Members


AccText Property

AccText Property
GuiScrollContainer Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiScrollContainer Object | GuiScrollContainer Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiScrollContainer Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiScrollContainer Object | GuiScrollContainer Members


AccTooltip Property

AccTooltip Property
GuiScrollContainer Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiScrollContainer Object | GuiScrollContainer Members


Changeable Property

Changeable Property
GuiScrollContainer Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiScrollContainer Object | GuiScrollContainer Members


CharHeight Property

CharHeight Property
GuiScrollContainer Object : CharHeight Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharHeight As Long

See Also

GuiScrollContainer Object | GuiScrollContainer Members


CharLeft Property

CharLeft Property
GuiScrollContainer Object : CharLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharLeft As Long

See Also

GuiScrollContainer Object | GuiScrollContainer Members


CharTop Property

CharTop Property
GuiScrollContainer Object : CharTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharTop As Long

See Also

GuiScrollContainer Object | GuiScrollContainer Members


CharWidth Property

CharWidth Property
GuiScrollContainer Object : CharWidth Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharWidth As Long

See Also

GuiScrollContainer Object | GuiScrollContainer Members


Children Property

Children Property
GuiScrollContainer Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiScrollContainer Object | GuiScrollContainer Members


ContainerType Property

ContainerType Property
GuiScrollContainer Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiScrollContainer Object | GuiScrollContainer Members


DefaultTooltip Property

DefaultTooltip Property
GuiScrollContainer Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiScrollContainer Object | GuiScrollContainer Members


Height Property

Height Property
GuiScrollContainer Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiScrollContainer Object | GuiScrollContainer Members


HorizontalScrollbar Property

HorizontalScrollbar Property
GuiScrollContainer Object : HorizontalScrollbar Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property HorizontalScrollbar As GuiScrollbar

See Also

GuiScrollContainer Object | GuiScrollContainer Members


IconName Property

IconName Property
GuiScrollContainer Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiScrollContainer Object | GuiScrollContainer Members


Id Property

Id Property
GuiScrollContainer Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiScrollContainer Object | GuiScrollContainer Members


IsSymbolFont Property

IsSymbolFont Property
GuiScrollContainer Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiScrollContainer Object | GuiScrollContainer Members


Left Property

Left Property
GuiScrollContainer Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiScrollContainer Object | GuiScrollContainer Members


Modified Property

Modified Property
GuiScrollContainer Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiScrollContainer Object | GuiScrollContainer Members


Name Property

Name Property
GuiScrollContainer Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiScrollContainer Object | GuiScrollContainer Members


Parent Property

Parent Property
GuiScrollContainer Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiScrollContainer Object | GuiScrollContainer Members


ParentFrame Property

ParentFrame Property
GuiScrollContainer Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiScrollContainer Object | GuiScrollContainer Members


ScreenLeft Property

ScreenLeft Property
GuiScrollContainer Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiScrollContainer Object | GuiScrollContainer Members


ScreenTop Property

ScreenTop Property
GuiScrollContainer Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiScrollContainer Object | GuiScrollContainer Members


Text Property

Text Property
GuiScrollContainer Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiScrollContainer Object | GuiScrollContainer Members


Tooltip Property

Tooltip Property
GuiScrollContainer Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiScrollContainer Object | GuiScrollContainer Members


Top Property

Top Property
GuiScrollContainer Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiScrollContainer Object | GuiScrollContainer Members


Type Property

Type Property
GuiScrollContainer Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiScrollContainer Object | GuiScrollContainer Members


TypeAsNumber Property

TypeAsNumber Property
GuiScrollContainer Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiScrollContainer Object | GuiScrollContainer Members


VerticalScrollbar Property

VerticalScrollbar Property
GuiScrollContainer Object : VerticalScrollbar Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property VerticalScrollbar As GuiScrollbar

See Also

GuiScrollContainer Object | GuiScrollContainer Members


Width Property

Width Property
GuiScrollContainer Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiScrollContainer Object | GuiScrollContainer Members


GuiSession Object

GuiSession Object
See Also Members

Glossary Item Box

Description

The GuiSession provides the context in which a user performs a certain task such as working with a transaction. It is therefore the access point for applications which record a user’s actions regarding a specific task or play back those actions. GuiSession extends GuiContainer. The type prefix is ses, the name is ses plus the session number in square brackets.

Object Model

GuiSession ObjectGuiFrameWindow ObjectGuiComponentCollection CollectionGuiCollection CollectionGuiComponent ObjectGuiCollection CollectionGuiSessionInfo ObjectGuiComponent Object

Remarks

GuiSession is self-contained in that ids within the context of a session remain valid independently of other connections or sessions being open at the same time. Usually an external application will first determine with which session to interact. Once that is clear, the application will work more or less exclusively on that session.
Traversing the object hierarchy from the GuiApplication to the user interface elements, it is the session among whose children the highest level visible objects can be found. In contrast to objects like buttons or text fields, the session remains valid until the corresponding main window has been closed, whereas buttons, for example, are destroyed during each server communication .

See Also

GuiSession Members


GuiSession Object Members

GuiSession Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method AsStdNumberFormat | Depending on the system's number format the minus sign of numbers may be placed to the right of the number. Using this function the minus sign is moved to the left.
Public Method ClearErrorList | This method clears the list of errors that may be created when ActiveX controls are found on a screen that do not support SAP GUI Scripting. Otherwise the list is cleared after an error event was raised. This happens at the end of a round trip.
Public Method CreateSession | This function opens a new session, which is then visualized by a new main window. This resembles the “/o” command that can be executed from the command field.
Public Method EnableJawsEvents |
Public Method EndTransaction | Calling this function has the same effect as SendCommand("/n").
Public Method FindById |
Public Method FindByPosition | This method can be used to do a hittest on a SAP GUI session. The parameters x and y should be given in screen coordinates. If no component is found an exception is raised unless raise is set to False. In that case a Null/Nothing object is returned.
Public Method GetIconResourceName | In SAP GUI icons are often described as text in the format @nn@ where nn is a number. The function getIconResourceName translates the @nn@ notation into the name of the resource in sapbtmp.dll. For example the string @36@ is translated into B_TVARS, which is the resource name for the icon [image] .
Public Method GetVKeyDescription | When a script is recorded, it will often contain sendVKey(n) calls, where n is a number. The method getVKeyDescription translates these numbers into a readable text. For example the number 0 is translated into the text “Enter”.
Public Method LockSessionUI | This method locks the session so that no user interaction is possible until the session is unlocked using UnlockSessionUI.
Public Method SendCommand | Using this function you can execute any command string, which could otherwise be entered in the command field combo box indicated below.
Public Method StartTransaction | Calling this function with parameter "xyz" has the same effect as SendCommand("/nxyz").
Public Method UnlockSessionUI | This method unlocks the session after it was locked using LockSessionUI.

Public Properties

Public Property AccEnhancedTabChain
Public Property AccSymbolReplacement
Public Property ActiveWindow | All windows can be found in the children collection of GuiSession. However, most of the time an application will access the currently activated window of the session, as that is the window with which a user will probably interact. This property is intended as a shortcut to this window.
Public Property Busy

While SAP GUI is waiting for data from the server, any Scripting call will not return, which blocks the executing thread. This may not be acceptable for advanced applications.

A way to prevent this is to check the busy property of the session. If this property is True, then a subsequent Scripting call will wait for the server communication to be finished.

Public Property Children
Public Property ContainerType
Public Property ErrorList
Public Property Id
Public Property Info | Info is of type GuiSessionInfo. It contains technical information about the current connection, the login data, the running SAP application and more.
Public Property IsActive | TRUE if the session window is active. FALSE overwise.
Public Property IsListBoxActive
Public Property ListBoxCurrEntry
Public Property ListBoxCurrEntryHeight
Public Property ListBoxCurrEntryLeft
Public Property ListBoxCurrEntryTop
Public Property ListBoxCurrEntryWidth
Public Property ListBoxHeight
Public Property ListBoxLeft
Public Property ListBoxTop
Public Property ListBoxWidth
Public Property Name
Public Property Parent
Public Property PassportPreSystemId | The pre-system ID. Part of the passport information.
Public Property PassportSystemId | The system ID. Part of the passport information.
Public Property PassportTransactionId | The unique ID of the transaction. Part of the passport information.
Public Property ProgressPercent
Public Property ProgressText
Public Property Record

Setting this property to True enables the recording mode of the session. In this mode changes to elements of the user interface are recorded within SAP GUI and sent to a recording application using the Change event described later.

Public Property RecordFile | A simple way to record a script it to set the recordFile property to a valid filename and then enable the record property. A Visual Basic Script file of the given name will be created in the SapWorkDir on the client PC.
Public Property SaveAsUnicode | If this property is set to TRUE, the recorded scripts will be saved in UNICODE encoding. Overwise is the current system codepage.
Public Property ShowDropdownKeys | If this property is TRUE, the dropdowns show not only the text of dropdown entries, but also the keys.
Public Property SuppressBackendPopups
Public Property TestToolMode

During internal tests some aspects of the user interface proved to be difficult to handle with test tools using the Scripting API to automate SAP GUI. For this reason a special mode has been added in which the following changes are administered.

  • While success (S), warning (W) and error (E) messages are always displayed in the statusbar, information (I) and abort (A) messages are displayed as pop-up windows unless testToolMode is set.
  • The update mode of the application server is changed to immediate mode for the connection.
  • System messages are ignored so that they do not interrupt the recording or playback of scripts.
Public Property Type
Public Property TypeAsNumber

Events

Public Event AbapScriptingEvent
Public Event Activated
Public Event AutomationFCode | The event is only fired when using the SAP Workplace. It notifies the listener that SAP GUI executes a function code that was set by the Workplace framework.
Public Event Change | In record mode, the session collects changes to elements of the user interface and sends these changes to a listening application whenever server communication is about to start or if the record mode is turned off. The change events are raised immediately before the startRequest event. There is at least one event for every modified element in the recorded session.
Public Event ContextMenu

The contextMenu event is fired when SAP GUI is about to display a context menu. There are currently the following limitations:

  • Only context menus of controls of type GuiShell are supported.
  • The event is not fired for “cached” context menus, which are not retrieved from the server when being opened.
Public Event Destroy | This event is raised before a session is destroyed.
Public Event EndRequest | endRequest is called immediately after the session is unlocked after server communication.
Public Event Error | An error event is currently only raised, if the wrapper library required to access a SAP GUI ActiveX control from a script is not available. error events from all sessions are also available at the GuiApplication.
Public Event FocusChanged
Public Event HistoryOpened
Public Event Hit

The hit event is only raised when elementVisualizationMode is set to True, which turns on the hit test mode of SAP GUI. If in this mode a SAP GUI component is identified, the hit event is raised. The parameters of this event are

  • The session on which the component was hit
  • The component that was hit
  • A description of an inner object of the component if an inner object was hit
Public Event ProgressIndicator
Public Event StartRequest | The startRequest event is raised before the session is locked during server communication. At this point user input can be checked before it is sent to the server. It is not possible to prevent server communication from this event.

See Also

GuiSession Object


AsStdNumberFormat Method

AsStdNumberFormat Method
Number
GuiSession Object : AsStdNumberFormat Method

Glossary Item Box

Description

Depending on the system's number format the minus sign of numbers may be placed to the right of the number. Using this function the minus sign is moved to the left.

Syntax

Visual Basic
Public Function AsStdNumberFormat( _
   ByVal Number As String _
) As String

Parameters

Number

See Also

GuiSession Object | GuiSession Members


ClearErrorList Method

ClearErrorList Method
GuiSession Object : ClearErrorList Method

Glossary Item Box

Description

This method clears the list of errors that may be created when ActiveX controls are found on a screen that do not support SAP GUI Scripting. Otherwise the list is cleared after an error event was raised. This happens at the end of a round trip.

Syntax

Visual Basic
Public Sub ClearErrorList()

See Also

GuiSession Object | GuiSession Members


CreateSession Method

CreateSession Method
GuiSession Object : CreateSession Method

Glossary Item Box

Description

This function opens a new session, which is then visualized by a new main window. This resembles the “/o” command that can be executed from the command field.

Syntax

Visual Basic
Public Sub CreateSession()

See Also

GuiSession Object | GuiSession Members


EnableJawsEvents Method

EnableJawsEvents Method
GuiSession Object : EnableJawsEvents Method

Glossary Item Box

Syntax

Visual Basic
Public Sub EnableJawsEvents()

See Also

GuiSession Object | GuiSession Members


EndTransaction Method

EndTransaction Method
GuiSession Object : EndTransaction Method

Glossary Item Box

Description

Calling this function has the same effect as SendCommand("/n").

Syntax

Visual Basic
Public Sub EndTransaction()

See Also

GuiSession Object | GuiSession Members


FindById Method

FindById Method
Id
Raise
GuiSession Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiSession Object | GuiSession Members


FindByPosition Method

FindByPosition Method
x
y
Raise
GuiSession Object : FindByPosition Method

Glossary Item Box

Description

This method can be used to do a hittest on a SAP GUI session. The parameters x and y should be given in screen coordinates. If no component is found an exception is raised unless raise is set to False. In that case a Null/Nothing object is returned.

Syntax

Visual Basic
Public Function FindByPosition( _
   ByVal x As Long, _
   ByVal y As Long, _
   Optional ByVal Raise As Variant _
) As GuiCollection

Parameters

x
y
Raise

Remarks

If a component is found, the collection contains 2 strings: The Id of the component and the description string for the inner object, which is only set for some complex components such as GuiCtrlGridView.

See Also

GuiSession Object | GuiSession Members


GetIconResourceName Method

GetIconResourceName Method
Text
GuiSession Object : GetIconResourceName Method

Glossary Item Box

Description

In SAP GUI icons are often described as text in the format @nn@ where nn is a number. The function getIconResourceName translates the @nn@ notation into the name of the resource in sapbtmp.dll.
For example the string @36@ is translated into B_TVARS, which is the resource name for the icon [image].

Syntax

Visual Basic
Public Function GetIconResourceName( _
   ByVal Text As String _
) As String

Parameters

Text

See Also

GuiSession Object | GuiSession Members


GetVKeyDescription Method

GetVKeyDescription Method
VKey
GuiSession Object : GetVKeyDescription Method

Glossary Item Box

Description

When a script is recorded, it will often contain sendVKey(n) calls, where n is a number. The method getVKeyDescription translates these numbers into a readable text. For example the number 0 is translated into the text “Enter”.

Syntax

Visual Basic
Public Function GetVKeyDescription( _
   ByVal VKey As Long _
) As String

Parameters

VKey

See Also

GuiSession Object | GuiSession Members


LockSessionUI Method

LockSessionUI Method
GuiSession Object : LockSessionUI Method

Glossary Item Box

Description

This method locks the session so that no user interaction is possible until the session is unlocked using UnlockSessionUI.

Syntax

Visual Basic
Public Sub LockSessionUI()

See Also

GuiSession Object | GuiSession Members


SendCommand Method

SendCommand Method
Command
GuiSession Object : SendCommand Method

Glossary Item Box

Description

Using this function you can execute any command string, which could otherwise be entered in the command field combo box indicated below.

Syntax

Visual Basic
Public Sub SendCommand( _
   ByVal Command As String _
)

Parameters

Command

See Also

GuiSession Object | GuiSession Members


StartTransaction Method

StartTransaction Method
Transaction
GuiSession Object : StartTransaction Method

Glossary Item Box

Description

Calling this function with parameter "xyz" has the same effect as SendCommand("/nxyz").

Syntax

Visual Basic
Public Sub StartTransaction( _
   ByVal Transaction As String _
)

Parameters

Transaction

See Also

GuiSession Object | GuiSession Members


UnlockSessionUI Method

UnlockSessionUI Method
GuiSession Object : UnlockSessionUI Method

Glossary Item Box

Description

This method unlocks the session after it was locked using LockSessionUI.

Syntax

Visual Basic
Public Sub UnlockSessionUI()

See Also

GuiSession Object | GuiSession Members


AccEnhancedTabChain Property

AccEnhancedTabChain Property
GuiSession Object : AccEnhancedTabChain Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property AccEnhancedTabChain As Byte

See Also

GuiSession Object | GuiSession Members


AccSymbolReplacement Property

AccSymbolReplacement Property
GuiSession Object : AccSymbolReplacement Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property AccSymbolReplacement As Byte

See Also

GuiSession Object | GuiSession Members


ActiveWindow Property

ActiveWindow Property
GuiSession Object : ActiveWindow Property

Glossary Item Box

Description

All windows can be found in the children collection of GuiSession. However, most of the time an application will access the currently activated window of the session, as that is the window with which a user will probably interact. This property is intended as a shortcut to this window.

Property type

Read-only property

Syntax

Visual Basic
Public Property ActiveWindow As GuiFrameWindow

See Also

GuiSession Object | GuiSession Members


Busy Property

Busy Property
GuiSession Object : Busy Property

Glossary Item Box

Description

While SAP GUI is waiting for data from the server, any Scripting call will not return, which blocks the executing thread. This may not be acceptable for advanced applications.

A way to prevent this is to check the busy property of the session. If this property is True, then a subsequent Scripting call will wait for the server communication to be finished.

Property type

Read-write property

Syntax

Visual Basic
Public Property Busy As Byte

See Also

GuiSession Object | GuiSession Members


Children Property

Children Property
GuiSession Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiSession Object | GuiSession Members


ContainerType Property

ContainerType Property
GuiSession Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiSession Object | GuiSession Members


ErrorList Property

ErrorList Property
GuiSession Object : ErrorList Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property ErrorList As GuiCollection

See Also

GuiSession Object | GuiSession Members


Id Property

Id Property
GuiSession Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiSession Object | GuiSession Members


Info Property

Info Property
GuiSession Object : Info Property

Glossary Item Box

Description

Info is of type GuiSessionInfo. It contains technical information about the current connection, the login data, the running SAP application and more.

Property type

Read-only property

Syntax

Visual Basic
Public Property Info As GuiSessionInfo

See Also

GuiSession Object | GuiSession Members


IsActive Property

IsActive Property
GuiSession Object : IsActive Property

Glossary Item Box

Description

TRUE if the session window is active. FALSE overwise.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsActive As Byte

See Also

GuiSession Object | GuiSession Members


IsListBoxActive Property

IsListBoxActive Property
GuiSession Object : IsListBoxActive Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsListBoxActive As Byte

See Also

GuiSession Object | GuiSession Members


ListBoxCurrEntry Property

ListBoxCurrEntry Property
GuiSession Object : ListBoxCurrEntry Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ListBoxCurrEntry As Long

See Also

GuiSession Object | GuiSession Members


ListBoxCurrEntryHeight Property

ListBoxCurrEntryHeight Property
GuiSession Object : ListBoxCurrEntryHeight Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ListBoxCurrEntryHeight As Long

See Also

GuiSession Object | GuiSession Members


ListBoxCurrEntryLeft Property

ListBoxCurrEntryLeft Property
GuiSession Object : ListBoxCurrEntryLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ListBoxCurrEntryLeft As Long

See Also

GuiSession Object | GuiSession Members


ListBoxCurrEntryTop Property

ListBoxCurrEntryTop Property
GuiSession Object : ListBoxCurrEntryTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ListBoxCurrEntryTop As Long

See Also

GuiSession Object | GuiSession Members


ListBoxCurrEntryWidth Property

ListBoxCurrEntryWidth Property
GuiSession Object : ListBoxCurrEntryWidth Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ListBoxCurrEntryWidth As Long

See Also

GuiSession Object | GuiSession Members


ListBoxHeight Property

ListBoxHeight Property
GuiSession Object : ListBoxHeight Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ListBoxHeight As Long

See Also

GuiSession Object | GuiSession Members


ListBoxLeft Property

ListBoxLeft Property
GuiSession Object : ListBoxLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ListBoxLeft As Long

See Also

GuiSession Object | GuiSession Members


ListBoxTop Property

ListBoxTop Property
GuiSession Object : ListBoxTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ListBoxTop As Long

See Also

GuiSession Object | GuiSession Members


ListBoxWidth Property

ListBoxWidth Property
GuiSession Object : ListBoxWidth Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ListBoxWidth As Long

See Also

GuiSession Object | GuiSession Members


Name Property

Name Property
GuiSession Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiSession Object | GuiSession Members


Parent Property

Parent Property
GuiSession Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiSession Object | GuiSession Members


PassportPreSystemId Property

PassportPreSystemId Property
GuiSession Object : PassportPreSystemId Property

Glossary Item Box

Description

The pre-system ID. Part of the passport information.

Property type

Read-write property

Syntax

Visual Basic
Public Property PassportPreSystemId As String

See Also

GuiSession Object | GuiSession Members


PassportSystemId Property

PassportSystemId Property
GuiSession Object : PassportSystemId Property

Glossary Item Box

Description

The system ID. Part of the passport information.

Property type

Read-write property

Syntax

Visual Basic
Public Property PassportSystemId As String

See Also

GuiSession Object | GuiSession Members


PassportTransactionId Property

PassportTransactionId Property
GuiSession Object : PassportTransactionId Property

Glossary Item Box

Description

The unique ID of the transaction. Part of the passport information.

Property type

Read-write property

Syntax

Visual Basic
Public Property PassportTransactionId As String

See Also

GuiSession Object | GuiSession Members


ProgressPercent Property

ProgressPercent Property
GuiSession Object : ProgressPercent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ProgressPercent As Long

See Also

GuiSession Object | GuiSession Members


ProgressText Property

ProgressText Property
GuiSession Object : ProgressText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ProgressText As String

See Also

GuiSession Object | GuiSession Members


Record Property

Record Property
GuiSession Object : Record Property

Glossary Item Box

Description

Setting this property to True enables the recording mode of the session. In this mode changes to elements of the user interface are recorded within SAP GUI and sent to a recording application using the Change event described later.

Property type

Read-write property

Syntax

Visual Basic
Public Property Record As Byte

Remarks

Some elements of the user interface may behave differently in record mode than during playback or manual interaction.

  • The F4 help dialog is always displayed as a modal window.
  • Drag & Drop is disabled.

See Also

GuiSession Object | GuiSession Members


RecordFile Property

RecordFile Property
GuiSession Object : RecordFile Property

Glossary Item Box

Description

A simple way to record a script it to set the recordFile property to a valid filename and then enable the record property. A Visual Basic Script file of the given name will be created in the SapWorkDir on the client PC.

Property type

Read-write property

Syntax

Visual Basic
Public Property RecordFile As String

Remarks

This property only accepts simple filenames without path information.

See Also

GuiSession Object | GuiSession Members


SaveAsUnicode Property

SaveAsUnicode Property
GuiSession Object : SaveAsUnicode Property

Glossary Item Box

Description

If this property is set to TRUE, the recorded scripts will be saved in UNICODE encoding. Overwise is the current system codepage.

Property type

Read-write property

Syntax

Visual Basic
Public Property SaveAsUnicode As Byte

See Also

GuiSession Object | GuiSession Members


ShowDropdownKeys Property

ShowDropdownKeys Property
GuiSession Object : ShowDropdownKeys Property

Glossary Item Box

Description

If this property is TRUE, the dropdowns show not only the text of dropdown entries, but also the keys.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowDropdownKeys As Byte

See Also

GuiSession Object | GuiSession Members


SuppressBackendPopups Property

SuppressBackendPopups Property
GuiSession Object : SuppressBackendPopups Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property SuppressBackendPopups As Byte

See Also

GuiSession Object | GuiSession Members


TestToolMode Property

TestToolMode Property
GuiSession Object : TestToolMode Property

Glossary Item Box

Description

During internal tests some aspects of the user interface proved to be difficult to handle with test tools using the Scripting API to automate SAP GUI. For this reason a special mode has been added in which the following changes are administered.

  • While success (S), warning (W) and error (E) messages are always displayed in the statusbar, information (I) and abort (A) messages are displayed as pop-up windows unless testToolMode is set.
  • The update mode of the application server is changed to immediate mode for the connection.
  • System messages are ignored so that they do not interrupt the recording or playback of scripts.

Property type

Read-write property

Syntax

Visual Basic
Public Property TestToolMode As Long

Remarks

The test tool mode requires one of the following versions of the SAP kernel:

  • 6.20 Patch level 29 and all following kernel versions
  • 4.6D Patch level 1208, see note 511310.

Currently only the following values are allowed for this property:

  • 0: Disable testToolMode
  • 1: Enable testToolMode

See Also

GuiSession Object | GuiSession Members


Type Property

Type Property
GuiSession Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiSession Object | GuiSession Members


TypeAsNumber Property

TypeAsNumber Property
GuiSession Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiSession Object | GuiSession Members


AbapScriptingEvent Event

AbapScriptingEvent Event
param
GuiSession Object : AbapScriptingEvent Event

Glossary Item Box

Syntax

Visual Basic
Public Event AbapScriptingEvent( _
   ByVal param As String _
)

Parameters

param

See Also

GuiSession Object | GuiSession Members


Activated Event

Activated Event
Session
GuiSession Object : Activated Event

Glossary Item Box

Syntax

Visual Basic
Public Event Activated( _
   ByVal Session As GuiSession _
)

Parameters

Session

See Also

GuiSession Object | GuiSession Members


AutomationFCode Event

AutomationFCode Event
Session
FunctionCode
GuiSession Object : AutomationFCode Event

Glossary Item Box

Description

The event is only fired when using the SAP Workplace. It notifies the listener that SAP GUI executes a function code that was set by the Workplace framework.

Syntax

Visual Basic
Public Event AutomationFCode( _
   ByVal Session As GuiSession, _
   ByVal FunctionCode As String _
)

Parameters

Session
FunctionCode

See Also

GuiSession Object | GuiSession Members


Change Event

Change Event
Session
Component
CommandArray
GuiSession Object : Change Event

Glossary Item Box

Description

In record mode, the session collects changes to elements of the user interface and sends these changes to a listening application whenever server communication is about to start or if the record mode is turned off. The change events are raised immediately before the startRequest event. There is at least one event for every modified element in the recorded session.

Syntax

Visual Basic
Public Event Change( _
   ByVal Session As GuiSession, _
   ByVal Component As GuiComponent, _
   ByVal CommandArray As Variant _
)

Parameters

Session
Component
CommandArray

Remarks

Only changes made at the SAP GUI level are recorded. Transactions may preset some of the entry fields with values from parameters stored in the SAP system. If these data are not changed in SAP GUI, they will not be recorded. This may cause problems during playback of scripts, if the entry fields are preset with different values.

If any of the following techniques is used in a transaction, the user should manually modify all the entries he wants to see recorded:

  • Usage of SAP parameters
  • Variants
  • Hold Data, from the menu System -> User Profile

Playback of the changes will only work, if the order of the calls is the same as during recording.

Each event represents one line of script code. The Component parameter specifies the object on which to invoke a method or property. Therefore the first thing to record is Component.id for later use with findById. The recorder may however also decide to record other properties of Component. If, for example, a line in a table control or list is selected, it may be prudent not to record the position of the line, but rather the values in it. That way, a script can be generated that is more robust with respect to changes in the number, and therefore in the position, of lines.

If new function modules have been added, selecting a line from the list might return the wrong function module.

Type | Method/Property name | Parameters
"SP" | "Text" | "Hello World"

This sets the parameter Text to value “Hello World”.

Type | Method/Property name | Parameters
"SP" | "RecordMode" | True

This sets the parameter RecordMode to the Boolean value True. It is up to the recorder to generate a script line with a valid textual representation of Boolean values, such as “true”, “True” or “TRUE” for example.

Type | Method/Property name | Parameters
"SP" | "TestToolMode" | 0

This sets the parameter TestToolMode to value 0.

Type | Method/Property name | Parameters
"M" | "Resize" | 96
 |  | 32
 |  | False

The method Resize is called with three parameters. In this case the third member of the CommandArray is an array with 3 elements.

There are cases in which the CommandArray contains more than one line.

If a row is selected in this table control, two entries are added to the generated Change event’s CommandArray parameter.

Type | Method/Property name | Parameters
"M" | "getAbsoluteRow" | 1
"SP" | "selected" | True

The script code required to select this line should then look like this:
Session.findById("wnd[0]/usr/tblSAPMBIBSTC537").getAbsoluteRow("1").selected = "True"

See Also

GuiSession Object | GuiSession Members


ContextMenu Event

ContextMenu Event
Session
Component
GuiSession Object : ContextMenu Event

Glossary Item Box

Description

The contextMenu event is fired when SAP GUI is about to display a context menu. There are currently the following limitations:

  • Only context menus of controls of type GuiShell are supported.
  • The event is not fired for “cached” context menus, which are not retrieved from the server when being opened.

Syntax

Visual Basic
Public Event ContextMenu( _
   ByVal Session As GuiSession, _
   ByVal Component As GuiVComponent _
)

Parameters

Session
Component

See Also

GuiSession Object | GuiSession Members


Destroy Event

Destroy Event
Session
GuiSession Object : Destroy Event

Glossary Item Box

Description

This event is raised before a session is destroyed.

Syntax

Visual Basic
Public Event Destroy( _
   ByVal Session As GuiSession _
)

Parameters

Session

See Also

GuiSession Object | GuiSession Members


EndRequest Event

EndRequest Event
Session
GuiSession Object : EndRequest Event

Glossary Item Box

Description

endRequest is called immediately after the session is unlocked after server communication.

Syntax

Visual Basic
Public Event EndRequest( _
   ByVal Session As GuiSession _
)

Parameters

Session

See Also

GuiSession Object | GuiSession Members


Error Event

Error Event
Session
ErrorId
Desc1
Desc2
Desc3
Desc4
GuiSession Object : Error Event

Glossary Item Box

Description

An error event is currently only raised, if the wrapper library required to access a SAP GUI ActiveX control from a script is not available. error events from all sessions are also available at the GuiApplication.

Syntax

Visual Basic
Public Event Error( _
   ByVal Session As GuiSession, _
   ByVal ErrorId As Long, _
   ByVal Desc1 As String, _
   ByVal Desc2 As String, _
   ByVal Desc3 As String, _
   ByVal Desc4 As String _
)

Parameters

Session
ErrorId
Desc1
Desc2
Desc3
Desc4

See Also

GuiSession Object | GuiSession Members


FocusChanged Event

FocusChanged Event
Session
NewFocusedControl
GuiSession Object : FocusChanged Event

Glossary Item Box

Syntax

Visual Basic
Public Event FocusChanged( _
   ByVal Session As GuiSession, _
   ByVal NewFocusedControl As GuiVComponent _
)

Parameters

Session
NewFocusedControl

See Also

GuiSession Object | GuiSession Members


HistoryOpened Event

HistoryOpened Event
Session
NewFocusedControl
GuiSession Object : HistoryOpened Event

Glossary Item Box

Syntax

Visual Basic
Public Event HistoryOpened( _
   ByVal Session As GuiSession, _
   ByVal NewFocusedControl As GuiVComponent _
)

Parameters

Session
NewFocusedControl

See Also

GuiSession Object | GuiSession Members


Hit Event

Hit Event
Session
Component
InnerObject
GuiSession Object : Hit Event

Glossary Item Box

Description

The hit event is only raised when elementVisualizationMode is set to True, which turns on the hit test mode of SAP GUI. If in this mode a SAP GUI component is identified, the hit event is raised. The parameters of this event are

  • The session on which the component was hit
  • The component that was hit
  • A description of an inner object of the component if an inner object was hit

Syntax

Visual Basic
Public Event Hit( _
   ByVal Session As GuiSession, _
   ByVal Component As GuiComponent, _
   ByVal InnerObject As String _
)

Parameters

Session
Component
InnerObject

See Also

GuiSession Object | GuiSession Members


ProgressIndicator Event

ProgressIndicator Event
percentage
Text
GuiSession Object : ProgressIndicator Event

Glossary Item Box

Syntax

Visual Basic
Public Event ProgressIndicator( _
   ByVal percentage As Long, _
   ByVal Text As String _
)

Parameters

percentage
Text

See Also

GuiSession Object | GuiSession Members


StartRequest Event

StartRequest Event
Session
GuiSession Object : StartRequest Event

Glossary Item Box

Description

The startRequest event is raised before the session is locked during server communication. At this point user input can be checked before it is sent to the server. It is not possible to prevent server communication from this event.

Syntax

Visual Basic
Public Event StartRequest( _
   ByVal Session As GuiSession _
)

Parameters

Session

See Also

GuiSession Object | GuiSession Members


GuiSessionInfo Object

GuiSessionInfo Object
See Also Members

Glossary Item Box

Description

GuiSessionInfo is a member of all GuiSession objects. It makes available technical information about the session. Some of its properties are displayed in the right corner of the SAP GUI status line.

Object Model

GuiSessionInfo Object

See Also

GuiSessionInfo Members


GuiSessionInfo Object Members

GuiSessionInfo Object Members
See Also Overview

Glossary Item Box

Public Properties

Public Property ApplicationServer | The name of the application server is set only if the session belongs to a connection that was started without load balancing, by specifying an application server.
Public Property Client | The client selected on the login screen.
Public Property Codepage | The codepage specified in SAPlogon in the properties of the connection.
Public Property Flushes | The property flushes counts the number of flushes in the automation queue during server communication.
Public Property Group | The login group information is available only if the session belongs to a connection which was started using load balancing.
Public Property GuiCodepage | A list of codepages is available in table TCP00A of the SAP system. On a client running Microsoft Windows with codepage 1252 (Latin I) the property guiCodepage is 1160.
Public Property I18NMode | The I18N mode of SAP GUI is required for multi-byte character sets.
Public Property InterpretationTime | The interpretation time begins after the data have arrived from the server. It comprises the parsing of the data and distribution to the SAP GUI elements. The unit is milliseconds.
Public Property IsLowSpeedConnection | The property is True if the connection to which the session belongs runs with the low speed connection flag. This flag can be set on the advanced connection properties page of the SAPLogon dialog. The SAP GUI Scripting support is very limited for low speed connections, because information required to identify SAP GUI objects is not being sent.
Public Property Language | The language specified on the login screen.
Public Property MessageServer | The message server information is available only if the session belongs to a connection which was started using load balancing.
Public Property Program | The name of the source program that is currently being executed.
Public Property ResponseTime | This is the time that is spent on network communication from the moment data are sent to the server to the moment the server response arrives. The unit is milliseconds.
Public Property RoundTrips | Before SAP GUI sends data to the server it locks the user interface. In many cases it will not unlock the interface once data arrive from the server, but instead will send a new request to the server immediately. Controls in particular use this technology to load the data they need for visualization. The count of these token switches between SAP GUI and the server is the roundTrips property.
Public Property ScreenNumber | The number of the screen currently displayed.
Public Property ScriptingModeReadOnly

The read only mode can be enabled using an application server profile parameter. In this mode the state of SAP applications can not be changed through the Scripting API, which means:

  • Properties can only be read, but not set
  • Functions can only be called if they do not change the control’s state.
Public Property ScriptingModeRecordingDisabled | The recording disabled mode can be enabled using an application server profile parameter. In this mode SAP GUI Scripting does not fire any events. This implies that user interaction can not be recorded. However data can be read from SAP GUI and scripts can be used to run transactions.
Public Property SessionNumber | The number of the session is also displayed in SAP GUI on the statusbar.
Public Property SystemName | This is the name of the SAP system.
Public Property SystemNumber | The system number is set only if the session belongs to a connection that was started without load balancing, by specifying an application server.
Public Property SystemSessionId | All SAP GUI sessions of the same connection are represented on the server with the same SystemSessionId. Using SystemSessionId and SessionNumber, it is possible to find a matching SAP GUI session from an ABAP application.
Public Property Transaction | The transaction that is currently being executed.
Public Property User | The SAP name of the user logged into the system.

See Also

GuiSessionInfo Object


ApplicationServer Property

ApplicationServer Property
GuiSessionInfo Object : ApplicationServer Property

Glossary Item Box

Description

The name of the application server is set only if the session belongs to a connection that was started without load balancing, by specifying an application server.

Property type

Read-only property

Syntax

Visual Basic
Public Property ApplicationServer As String

See Also

GuiSessionInfo Object | GuiSessionInfo Members


Client Property

Client Property
GuiSessionInfo Object : Client Property

Glossary Item Box

Description

The client selected on the login screen.

Property type

Read-only property

Syntax

Visual Basic
Public Property Client As String

See Also

GuiSessionInfo Object | GuiSessionInfo Members


Codepage Property

Codepage Property
GuiSessionInfo Object : Codepage Property

Glossary Item Box

Description

The codepage specified in SAPlogon in the properties of the connection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Codepage As Long

See Also

GuiSessionInfo Object | GuiSessionInfo Members


Flushes Property

Flushes Property
GuiSessionInfo Object : Flushes Property

Glossary Item Box

Description

The property flushes counts the number of flushes in the automation queue during server communication.

Property type

Read-only property

Syntax

Visual Basic
Public Property Flushes As Long

See Also

GuiSessionInfo Object | GuiSessionInfo Members


Group Property

Group Property
GuiSessionInfo Object : Group Property

Glossary Item Box

Description

The login group information is available only if the session belongs to a connection which was started using load balancing.

Property type

Read-only property

Syntax

Visual Basic
Public Property Group As String

See Also

GuiSessionInfo Object | GuiSessionInfo Members


GuiCodepage Property

GuiCodepage Property
GuiSessionInfo Object : GuiCodepage Property

Glossary Item Box

Description

A list of codepages is available in table TCP00A of the SAP system. On a client running Microsoft Windows with codepage 1252 (Latin I) the property guiCodepage is 1160.

Property type

Read-only property

Syntax

Visual Basic
Public Property GuiCodepage As Long

See Also

GuiSessionInfo Object | GuiSessionInfo Members


I18NMode Property

I18NMode Property
GuiSessionInfo Object : I18NMode Property

Glossary Item Box

Description

The I18N mode of SAP GUI is required for multi-byte character sets.

Property type

Read-only property

Syntax

Visual Basic
Public Property I18NMode As Byte

See Also

GuiSessionInfo Object | GuiSessionInfo Members


InterpretationTime Property

InterpretationTime Property
GuiSessionInfo Object : InterpretationTime Property

Glossary Item Box

Description

The interpretation time begins after the data have arrived from the server. It comprises the parsing of the data and distribution to the SAP GUI elements. The unit is milliseconds.

Property type

Read-only property

Syntax

Visual Basic
Public Property InterpretationTime As Long

See Also

GuiSessionInfo Object | GuiSessionInfo Members


IsLowSpeedConnection Property

IsLowSpeedConnection Property
GuiSessionInfo Object : IsLowSpeedConnection Property

Glossary Item Box

Description

The property is True if the connection to which the session belongs runs with the low speed connection flag. This flag can be set on the advanced connection properties page of the SAPLogon dialog. The SAP GUI Scripting support is very limited for low speed connections, because information required to identify SAP GUI objects is not being sent.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsLowSpeedConnection As Byte

See Also

GuiSessionInfo Object | GuiSessionInfo Members


Language Property

Language Property
GuiSessionInfo Object : Language Property

Glossary Item Box

Description

The language specified on the login screen.

Property type

Read-only property

Syntax

Visual Basic
Public Property Language As String

See Also

GuiSessionInfo Object | GuiSessionInfo Members


MessageServer Property

MessageServer Property
GuiSessionInfo Object : MessageServer Property

Glossary Item Box

Description

The message server information is available only if the session belongs to a connection which was started using load balancing.

Property type

Read-only property

Syntax

Visual Basic
Public Property MessageServer As String

See Also

GuiSessionInfo Object | GuiSessionInfo Members


Program Property

Program Property
GuiSessionInfo Object : Program Property

Glossary Item Box

Description

The name of the source program that is currently being executed.

Property type

Read-only property

Syntax

Visual Basic
Public Property Program As String

See Also

GuiSessionInfo Object | GuiSessionInfo Members


ResponseTime Property

ResponseTime Property
GuiSessionInfo Object : ResponseTime Property

Glossary Item Box

Description

This is the time that is spent on network communication from the moment data are sent to the server to the moment the server response arrives. The unit is milliseconds.

Property type

Read-only property

Syntax

Visual Basic
Public Property ResponseTime As Long

See Also

GuiSessionInfo Object | GuiSessionInfo Members


RoundTrips Property

RoundTrips Property
GuiSessionInfo Object : RoundTrips Property

Glossary Item Box

Description

Before SAP GUI sends data to the server it locks the user interface. In many cases it will not unlock the interface once data arrive from the server, but instead will send a new request to the server immediately. Controls in particular use this technology to load the data they need for visualization. The count of these token switches between SAP GUI and the server is the roundTrips property.

Property type

Read-only property

Syntax

Visual Basic
Public Property RoundTrips As Long

See Also

GuiSessionInfo Object | GuiSessionInfo Members


ScreenNumber Property

ScreenNumber Property
GuiSessionInfo Object : ScreenNumber Property

Glossary Item Box

Description

The number of the screen currently displayed.

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenNumber As Long

See Also

GuiSessionInfo Object | GuiSessionInfo Members


ScriptingModeReadOnly Property

ScriptingModeReadOnly Property
GuiSessionInfo Object : ScriptingModeReadOnly Property

Glossary Item Box

Description

The read only mode can be enabled using an application server profile parameter. In this mode the state of SAP applications can not be changed through the Scripting API, which means:

  • Properties can only be read, but not set
  • Functions can only be called if they do not change the control’s state.

Property type

Read-only property

Syntax

Visual Basic
Public Property ScriptingModeReadOnly As Byte

Remarks

In this mode scripts can be recorded and information about the application can be read from SAP GUI. However a transaction can not be run from a script. Additional documentation is available is OSS note 692245 and in the SAP GUI Scripting security documentation on the service market place.

See Also

GuiSessionInfo Object | GuiSessionInfo Members


ScriptingModeRecordingDisabled Property

ScriptingModeRecordingDisabled Property
GuiSessionInfo Object : ScriptingModeRecordingDisabled Property

Glossary Item Box

Description

The recording disabled mode can be enabled using an application server profile parameter. In this mode SAP GUI Scripting does not fire any events. This implies that user interaction can not be recorded. However data can be read from SAP GUI and scripts can be used to run transactions.

Property type

Read-only property

Syntax

Visual Basic
Public Property ScriptingModeRecordingDisabled As Byte

Remarks

Additional documentation is available is OSS note 692245 and in the SAP GUI Scripting security documentation on the service market place.

See Also

GuiSessionInfo Object | GuiSessionInfo Members


SessionNumber Property

SessionNumber Property
GuiSessionInfo Object : SessionNumber Property

Glossary Item Box

Description

The number of the session is also displayed in SAP GUI on the statusbar.

Property type

Read-only property

Syntax

Visual Basic
Public Property SessionNumber As Long

See Also

GuiSessionInfo Object | GuiSessionInfo Members


SystemName Property

SystemName Property
GuiSessionInfo Object : SystemName Property

Glossary Item Box

Description

This is the name of the SAP system.

Property type

Read-only property

Syntax

Visual Basic
Public Property SystemName As String

See Also

GuiSessionInfo Object | GuiSessionInfo Members


SystemNumber Property

SystemNumber Property
GuiSessionInfo Object : SystemNumber Property

Glossary Item Box

Description

The system number is set only if the session belongs to a connection that was started without load balancing, by specifying an application server.

Property type

Read-only property

Syntax

Visual Basic
Public Property SystemNumber As Long

See Also

GuiSessionInfo Object | GuiSessionInfo Members


SystemSessionId Property

SystemSessionId Property
GuiSessionInfo Object : SystemSessionId Property

Glossary Item Box

Description

All SAP GUI sessions of the same connection are represented on the server with the same SystemSessionId. Using SystemSessionId and SessionNumber, it is possible to find a matching SAP GUI session from an ABAP application.

Property type

Read-only property

Syntax

Visual Basic
Public Property SystemSessionId As String

See Also

GuiSessionInfo Object | GuiSessionInfo Members


Transaction Property

Transaction Property
GuiSessionInfo Object : Transaction Property

Glossary Item Box

Description

The transaction that is currently being executed.

Property type

Read-only property

Syntax

Visual Basic
Public Property Transaction As String

See Also

GuiSessionInfo Object | GuiSessionInfo Members


User Property

User Property
GuiSessionInfo Object : User Property

Glossary Item Box

Description

The SAP name of the user logged into the system.

Property type

Read-only property

Syntax

Visual Basic
Public Property User As String

See Also

GuiSessionInfo Object | GuiSessionInfo Members


GuiShell Object

GuiShell Object
See Also Members

Glossary Item Box

Description

GuiShell is an abstract object whose interface is supported by all the controls. GuiShell extends GuiVContainer. The type prefix is shell, the name is is the last part of the id, shell[n].

Object Model

GuiShell ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiComponent ObjectGuiComponent Object

See Also

GuiShell Members


GuiShell Object Members

GuiShell Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method SelectContextMenuItem
Public Method SelectContextMenuItemByPosition
Public Method SelectContextMenuItemByText
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccDescription
Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property Children
Public Property ContainerType
Public Property CurrentContextMenu
Public Property DefaultTooltip
Public Property DragDropSupported
Public Property Handle
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property OcxEvents
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property SubType
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiShell Object


DumpState Method

DumpState Method
InnerObject
GuiShell Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiShell Object | GuiShell Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiShell Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiShell Object | GuiShell Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiShell Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiShell Object | GuiShell Members


FindById Method

FindById Method
Id
Raise
GuiShell Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiShell Object | GuiShell Members


FindByName Method

FindByName Method
Name
Type
GuiShell Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiShell Object | GuiShell Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiShell Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiShell Object | GuiShell Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiShell Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiShell Object | GuiShell Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiShell Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiShell Object | GuiShell Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiShell Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

Example

In the following example the text to use as parameter of this function would be "Submenu|Submenu - Entry 1".

See Also

GuiShell Object | GuiShell Members


SetFocus Method

SetFocus Method
GuiShell Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiShell Object | GuiShell Members


ShowContextMenu Method

ShowContextMenu Method
GuiShell Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiShell Object | GuiShell Members


Visualize Method

Visualize Method
On
InnerObject
GuiShell Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiShell Object | GuiShell Members


AccDescription Property

AccDescription Property
GuiShell Object : AccDescription Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccDescription As String

See Also

GuiShell Object | GuiShell Members


AccLabelCollection Property

AccLabelCollection Property
GuiShell Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiShell Object | GuiShell Members


AccText Property

AccText Property
GuiShell Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiShell Object | GuiShell Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiShell Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiShell Object | GuiShell Members


AccTooltip Property

AccTooltip Property
GuiShell Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiShell Object | GuiShell Members


Changeable Property

Changeable Property
GuiShell Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiShell Object | GuiShell Members


Children Property

Children Property
GuiShell Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiShell Object | GuiShell Members


ContainerType Property

ContainerType Property
GuiShell Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiShell Object | GuiShell Members


CurrentContextMenu Property

CurrentContextMenu Property
GuiShell Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

GuiShell Object | GuiShell Members


DefaultTooltip Property

DefaultTooltip Property
GuiShell Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiShell Object | GuiShell Members


DragDropSupported Property

DragDropSupported Property
GuiShell Object : DragDropSupported Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DragDropSupported As Byte

See Also

GuiShell Object | GuiShell Members


Handle Property

Handle Property
GuiShell Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiShell Object | GuiShell Members


Height Property

Height Property
GuiShell Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiShell Object | GuiShell Members


IconName Property

IconName Property
GuiShell Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiShell Object | GuiShell Members


Id Property

Id Property
GuiShell Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiShell Object | GuiShell Members


IsSymbolFont Property

IsSymbolFont Property
GuiShell Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiShell Object | GuiShell Members


Left Property

Left Property
GuiShell Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiShell Object | GuiShell Members


Modified Property

Modified Property
GuiShell Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiShell Object | GuiShell Members


Name Property

Name Property
GuiShell Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiShell Object | GuiShell Members


OcxEvents Property

OcxEvents Property
GuiShell Object : OcxEvents Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property OcxEvents As GuiCollection

See Also

GuiShell Object | GuiShell Members


Parent Property

Parent Property
GuiShell Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiShell Object | GuiShell Members


ParentFrame Property

ParentFrame Property
GuiShell Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiShell Object | GuiShell Members


ScreenLeft Property

ScreenLeft Property
GuiShell Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiShell Object | GuiShell Members


ScreenTop Property

ScreenTop Property
GuiShell Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiShell Object | GuiShell Members


SubType Property

SubType Property
GuiShell Object : SubType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property SubType As String

See Also

GuiShell Object | GuiShell Members


Text Property

Text Property
GuiShell Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiShell Object | GuiShell Members


Tooltip Property

Tooltip Property
GuiShell Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiShell Object | GuiShell Members


Top Property

Top Property
GuiShell Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiShell Object | GuiShell Members


Type Property

Type Property
GuiShell Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiShell Object | GuiShell Members


TypeAsNumber Property

TypeAsNumber Property
GuiShell Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiShell Object | GuiShell Members


Width Property

Width Property
GuiShell Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiShell Object | GuiShell Members


GuiSimpleContainer Object

GuiSimpleContainer Object
See Also Members

Glossary Item Box

Description

This container represents non-scrollable subscreens. It does not have any functionality apart from to the inherited interfaces. GuiSimpleContainer extends GuiVContainer. The type prefix is sub, the name is is generated from the data dictionary settings.

Object Model

GuiSimpleContainer ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent Object

See Also

GuiSimpleContainer Members


GuiSimpleContainer Object Members

GuiSimpleContainer Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method GetListProperty
Public Method GetListPropertyNonRec
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property Changeable |
Public Property CharHeight |
Public Property CharLeft |
Public Property CharTop |
Public Property CharWidth |
Public Property Children |
Public Property ContainerType |
Public Property DefaultTooltip |
Public Property Height |
Public Property IconName |
Public Property Id |
Public Property IsListElement |
Public Property IsStepLoop | This property is True if the container is a step loop container.
Public Property IsSymbolFont |
Public Property Left |
Public Property LoopColCount | If the container is a step loop container, then this property contains the number of columns in the step loop.
Public Property LoopCurrentCol | If the container is a step loop container, then this property contains the current row number in the step loop.
Public Property LoopCurrentRow | If the container is a step loop container, then this property contains the current column number in the step loop.
Public Property LoopRowCount | If the container is a step loop container, then this property contains the number of rows in the step loop.
Public Property Modified |
Public Property Name |
Public Property Parent |
Public Property ParentFrame |
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property Text |
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property Width |

See Also

GuiSimpleContainer Object


DumpState Method

DumpState Method
InnerObject
GuiSimpleContainer Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiSimpleContainer Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiSimpleContainer Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


FindById Method

FindById Method
Id
Raise
GuiSimpleContainer Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


FindByName Method

FindByName Method
Name
Type
GuiSimpleContainer Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiSimpleContainer Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


GetListProperty Method

GetListProperty Method
Property
GuiSimpleContainer Object : GetListProperty Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetListProperty( _
   ByVal Property As String _
) As String

Parameters

Property

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


GetListPropertyNonRec Method

GetListPropertyNonRec Method
Property
GuiSimpleContainer Object : GetListPropertyNonRec Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetListPropertyNonRec( _
   ByVal Property As String _
) As String

Parameters

Property

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


SetFocus Method

SetFocus Method
GuiSimpleContainer Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


ShowContextMenu Method

ShowContextMenu Method
GuiSimpleContainer Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


Visualize Method

Visualize Method
On
InnerObject
GuiSimpleContainer Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


AccLabelCollection Property

AccLabelCollection Property
GuiSimpleContainer Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


AccText Property

AccText Property
GuiSimpleContainer Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiSimpleContainer Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


AccTooltip Property

AccTooltip Property
GuiSimpleContainer Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


Changeable Property

Changeable Property
GuiSimpleContainer Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


CharHeight Property

CharHeight Property
GuiSimpleContainer Object : CharHeight Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharHeight As Long

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


CharLeft Property

CharLeft Property
GuiSimpleContainer Object : CharLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharLeft As Long

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


CharTop Property

CharTop Property
GuiSimpleContainer Object : CharTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharTop As Long

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


CharWidth Property

CharWidth Property
GuiSimpleContainer Object : CharWidth Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharWidth As Long

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


Children Property

Children Property
GuiSimpleContainer Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


ContainerType Property

ContainerType Property
GuiSimpleContainer Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


DefaultTooltip Property

DefaultTooltip Property
GuiSimpleContainer Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


Height Property

Height Property
GuiSimpleContainer Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


IconName Property

IconName Property
GuiSimpleContainer Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


Id Property

Id Property
GuiSimpleContainer Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


IsListElement Property

IsListElement Property
GuiSimpleContainer Object : IsListElement Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsListElement As Byte

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


IsStepLoop Property

IsStepLoop Property
GuiSimpleContainer Object : IsStepLoop Property

Glossary Item Box

Description

This property is True if the container is a step loop container.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsStepLoop As Byte

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


IsSymbolFont Property

IsSymbolFont Property
GuiSimpleContainer Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


Left Property

Left Property
GuiSimpleContainer Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


LoopColCount Property

LoopColCount Property
GuiSimpleContainer Object : LoopColCount Property

Glossary Item Box

Description

If the container is a step loop container, then this property contains the number of columns in the step loop.

Property type

Read-only property

Syntax

Visual Basic
Public Property LoopColCount As Long

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


LoopCurrentCol Property

LoopCurrentCol Property
GuiSimpleContainer Object : LoopCurrentCol Property

Glossary Item Box

Description

If the container is a step loop container, then this property contains the current row number in the step loop.

Property type

Read-only property

Syntax

Visual Basic
Public Property LoopCurrentCol As Long

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


LoopCurrentRow Property

LoopCurrentRow Property
GuiSimpleContainer Object : LoopCurrentRow Property

Glossary Item Box

Description

If the container is a step loop container, then this property contains the current column number in the step loop.

Property type

Read-only property

Syntax

Visual Basic
Public Property LoopCurrentRow As Long

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


LoopRowCount Property

LoopRowCount Property
GuiSimpleContainer Object : LoopRowCount Property

Glossary Item Box

Description

If the container is a step loop container, then this property contains the number of rows in the step loop.

Property type

Read-only property

Syntax

Visual Basic
Public Property LoopRowCount As Long

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


Modified Property

Modified Property
GuiSimpleContainer Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


Name Property

Name Property
GuiSimpleContainer Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


Parent Property

Parent Property
GuiSimpleContainer Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


ParentFrame Property

ParentFrame Property
GuiSimpleContainer Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


ScreenLeft Property

ScreenLeft Property
GuiSimpleContainer Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


ScreenTop Property

ScreenTop Property
GuiSimpleContainer Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


Text Property

Text Property
GuiSimpleContainer Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


Tooltip Property

Tooltip Property
GuiSimpleContainer Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


Top Property

Top Property
GuiSimpleContainer Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


Type Property

Type Property
GuiSimpleContainer Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


TypeAsNumber Property

TypeAsNumber Property
GuiSimpleContainer Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


Width Property

Width Property
GuiSimpleContainer Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiSimpleContainer Object | GuiSimpleContainer Members


GuiSplit Object

GuiSplit Object
See Also Members

Glossary Item Box

Description

GuiSplit extends GuiShell.

Object Model

GuiSplit ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiComponent ObjectGuiComponent Object

See Also

GuiSplit Members


GuiSplit Object Members

GuiSplit Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method GetColSize
Public Method GetRowSize
Public Method SelectContextMenuItem
Public Method SelectContextMenuItemByPosition
Public Method SelectContextMenuItemByText
Public Method SetColSize
Public Method SetFocus
Public Method SetRowSize
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccDescription |
Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property Changeable |
Public Property Children |
Public Property ContainerType |
Public Property CurrentContextMenu |
Public Property DefaultTooltip |
Public Property DragDropSupported |
Public Property Handle |
Public Property Height |
Public Property IconName |
Public Property Id |
Public Property IsSymbolFont |
Public Property IsVertical |
Public Property Left |
Public Property Modified |
Public Property Name |
Public Property OcxEvents |
Public Property Parent |
Public Property ParentFrame |
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property SubType | This property has the constant value “Splitter”.
Public Property Text |
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property Width |

See Also

GuiSplit Object


DumpState Method

DumpState Method
InnerObject
GuiSplit Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiSplit Object | GuiSplit Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiSplit Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiSplit Object | GuiSplit Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiSplit Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiSplit Object | GuiSplit Members


FindById Method

FindById Method
Id
Raise
GuiSplit Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiSplit Object | GuiSplit Members


FindByName Method

FindByName Method
Name
Type
GuiSplit Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiSplit Object | GuiSplit Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiSplit Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiSplit Object | GuiSplit Members


GetColSize Method

GetColSize Method
Id
GuiSplit Object : GetColSize Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetColSize( _
   ByVal Id As Long _
) As Long

Parameters

Id

See Also

GuiSplit Object | GuiSplit Members


GetRowSize Method

GetRowSize Method
Id
GuiSplit Object : GetRowSize Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetRowSize( _
   ByVal Id As Long _
) As Long

Parameters

Id

See Also

GuiSplit Object | GuiSplit Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiSplit Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiSplit Object | GuiSplit Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiSplit Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiSplit Object | GuiSplit Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiSplit Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

GuiSplit Object | GuiSplit Members


SetColSize Method

SetColSize Method
Id
Size
GuiSplit Object : SetColSize Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetColSize( _
   ByVal Id As Long, _
   ByVal Size As Long _
)

Parameters

Id
Size

See Also

GuiSplit Object | GuiSplit Members


SetFocus Method

SetFocus Method
GuiSplit Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiSplit Object | GuiSplit Members


SetRowSize Method

SetRowSize Method
Id
Size
GuiSplit Object : SetRowSize Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetRowSize( _
   ByVal Id As Long, _
   ByVal Size As Long _
)

Parameters

Id
Size

See Also

GuiSplit Object | GuiSplit Members


ShowContextMenu Method

ShowContextMenu Method
GuiSplit Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiSplit Object | GuiSplit Members


Visualize Method

Visualize Method
On
InnerObject
GuiSplit Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiSplit Object | GuiSplit Members


AccDescription Property

AccDescription Property
GuiSplit Object : AccDescription Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccDescription As String

See Also

GuiSplit Object | GuiSplit Members


AccLabelCollection Property

AccLabelCollection Property
GuiSplit Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiSplit Object | GuiSplit Members


AccText Property

AccText Property
GuiSplit Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiSplit Object | GuiSplit Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiSplit Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiSplit Object | GuiSplit Members


AccTooltip Property

AccTooltip Property
GuiSplit Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiSplit Object | GuiSplit Members


Changeable Property

Changeable Property
GuiSplit Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiSplit Object | GuiSplit Members


Children Property

Children Property
GuiSplit Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiSplit Object | GuiSplit Members


ContainerType Property

ContainerType Property
GuiSplit Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiSplit Object | GuiSplit Members


CurrentContextMenu Property

CurrentContextMenu Property
GuiSplit Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

GuiSplit Object | GuiSplit Members


DefaultTooltip Property

DefaultTooltip Property
GuiSplit Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiSplit Object | GuiSplit Members


DragDropSupported Property

DragDropSupported Property
GuiSplit Object : DragDropSupported Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DragDropSupported As Byte

See Also

GuiSplit Object | GuiSplit Members


Handle Property

Handle Property
GuiSplit Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiSplit Object | GuiSplit Members


Height Property

Height Property
GuiSplit Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiSplit Object | GuiSplit Members


IconName Property

IconName Property
GuiSplit Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiSplit Object | GuiSplit Members


Id Property

Id Property
GuiSplit Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiSplit Object | GuiSplit Members


IsSymbolFont Property

IsSymbolFont Property
GuiSplit Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiSplit Object | GuiSplit Members


IsVertical Property

IsVertical Property
GuiSplit Object : IsVertical Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsVertical As Long

See Also

GuiSplit Object | GuiSplit Members


Left Property

Left Property
GuiSplit Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiSplit Object | GuiSplit Members


Modified Property

Modified Property
GuiSplit Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiSplit Object | GuiSplit Members


Name Property

Name Property
GuiSplit Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiSplit Object | GuiSplit Members


OcxEvents Property

OcxEvents Property
GuiSplit Object : OcxEvents Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property OcxEvents As GuiCollection

See Also

GuiSplit Object | GuiSplit Members


Parent Property

Parent Property
GuiSplit Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiSplit Object | GuiSplit Members


ParentFrame Property

ParentFrame Property
GuiSplit Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiSplit Object | GuiSplit Members


ScreenLeft Property

ScreenLeft Property
GuiSplit Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiSplit Object | GuiSplit Members


ScreenTop Property

ScreenTop Property
GuiSplit Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiSplit Object | GuiSplit Members


SubType Property

SubType Property
GuiSplit Object : SubType Property

Glossary Item Box

Description

This property has the constant value “Splitter”.

Property type

Read-only property

Syntax

Visual Basic
Public Property SubType As String

See Also

GuiSplit Object | GuiSplit Members


Text Property

Text Property
GuiSplit Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiSplit Object | GuiSplit Members


Tooltip Property

Tooltip Property
GuiSplit Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiSplit Object | GuiSplit Members


Top Property

Top Property
GuiSplit Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiSplit Object | GuiSplit Members


Type Property

Type Property
GuiSplit Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiSplit Object | GuiSplit Members


TypeAsNumber Property

TypeAsNumber Property
GuiSplit Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiSplit Object | GuiSplit Members


Width Property

Width Property
GuiSplit Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiSplit Object | GuiSplit Members


GuiSplitterContainer Object

GuiSplitterContainer Object
See Also Members

Glossary Item Box

Description

The GuiSplitterContainer represents the dynpro splitter element, which was introduced in the Web Application Server ABAP in NetWeaver 7.1. The dynpro splitter element is similar to the activeX based splitter control, but it is a plain dynpro element.

Object Model

GuiSplitterContainer ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent Object

See Also

GuiSplitterContainer Members


GuiSplitterContainer Object Members

GuiSplitterContainer Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method SelectContextMenuItem
Public Method SelectContextMenuItemByPosition
Public Method SelectContextMenuItemByText
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property Children
Public Property ContainerType
Public Property DefaultTooltip
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property IsVertical
Public Property Left
Public Property Modified
Public Property Name
Public Property Parent
Public Property ParentFrame
Public Property SashPosition
Public Property ScreenLeft
Public Property ScreenTop
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiSplitterContainer Object


DumpState Method

DumpState Method
InnerObject
GuiSplitterContainer Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiSplitterContainer Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiSplitterContainer Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


FindById Method

FindById Method
Id
Raise
GuiSplitterContainer Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


FindByName Method

FindByName Method
Name
Type
GuiSplitterContainer Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiSplitterContainer Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiSplitterContainer Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiSplitterContainer Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiSplitterContainer Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


SetFocus Method

SetFocus Method
GuiSplitterContainer Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


ShowContextMenu Method

ShowContextMenu Method
GuiSplitterContainer Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


Visualize Method

Visualize Method
On
InnerObject
GuiSplitterContainer Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


AccLabelCollection Property

AccLabelCollection Property
GuiSplitterContainer Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


AccText Property

AccText Property
GuiSplitterContainer Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiSplitterContainer Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


AccTooltip Property

AccTooltip Property
GuiSplitterContainer Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


Changeable Property

Changeable Property
GuiSplitterContainer Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


Children Property

Children Property
GuiSplitterContainer Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


ContainerType Property

ContainerType Property
GuiSplitterContainer Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


DefaultTooltip Property

DefaultTooltip Property
GuiSplitterContainer Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


Height Property

Height Property
GuiSplitterContainer Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


IconName Property

IconName Property
GuiSplitterContainer Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


Id Property

Id Property
GuiSplitterContainer Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


IsSymbolFont Property

IsSymbolFont Property
GuiSplitterContainer Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


IsVertical Property

IsVertical Property
GuiSplitterContainer Object : IsVertical Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsVertical As Byte

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


Left Property

Left Property
GuiSplitterContainer Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


Modified Property

Modified Property
GuiSplitterContainer Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


Name Property

Name Property
GuiSplitterContainer Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


Parent Property

Parent Property
GuiSplitterContainer Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


ParentFrame Property

ParentFrame Property
GuiSplitterContainer Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


SashPosition Property

SashPosition Property
GuiSplitterContainer Object : SashPosition Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property SashPosition As Long

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


ScreenLeft Property

ScreenLeft Property
GuiSplitterContainer Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


ScreenTop Property

ScreenTop Property
GuiSplitterContainer Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


Text Property

Text Property
GuiSplitterContainer Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


Tooltip Property

Tooltip Property
GuiSplitterContainer Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


Top Property

Top Property
GuiSplitterContainer Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


Type Property

Type Property
GuiSplitterContainer Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


TypeAsNumber Property

TypeAsNumber Property
GuiSplitterContainer Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


Width Property

Width Property
GuiSplitterContainer Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiSplitterContainer Object | GuiSplitterContainer Members


GuiStage Object

GuiStage Object
See Also Members

Glossary Item Box

Description

For the stage control only basic members from GuiShell are available. Recording and playback is not possible.

Object Model

GuiStage ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiComponent ObjectGuiComponent Object

See Also

GuiStage Members


GuiStage Object Members

GuiStage Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method ContextMenu
Public Method DoubleClick
Public Method DumpState
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method SelectContextMenuItem
Public Method SelectContextMenuItemByPosition
Public Method SelectContextMenuItemByText
Public Method SelectItems
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccDescription
Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property Children
Public Property ContainerType
Public Property CurrentContextMenu
Public Property DefaultTooltip
Public Property DragDropSupported
Public Property Handle
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property OcxEvents
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property SubType
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiStage Object


ContextMenu Method

ContextMenu Method
strId
GuiStage Object : ContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ContextMenu( _
   ByVal strId As String _
)

Parameters

strId

See Also

GuiStage Object | GuiStage Members


DoubleClick Method

DoubleClick Method
strId
GuiStage Object : DoubleClick Method

Glossary Item Box

Syntax

Visual Basic
Public Sub DoubleClick( _
   ByVal strId As String _
)

Parameters

strId

See Also

GuiStage Object | GuiStage Members


DumpState Method

DumpState Method
InnerObject
GuiStage Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiStage Object | GuiStage Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiStage Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiStage Object | GuiStage Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiStage Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiStage Object | GuiStage Members


FindById Method

FindById Method
Id
Raise
GuiStage Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiStage Object | GuiStage Members


FindByName Method

FindByName Method
Name
Type
GuiStage Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiStage Object | GuiStage Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiStage Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiStage Object | GuiStage Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiStage Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiStage Object | GuiStage Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiStage Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiStage Object | GuiStage Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiStage Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

GuiStage Object | GuiStage Members


SelectItems Method

SelectItems Method
strItems
GuiStage Object : SelectItems Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectItems( _
   ByVal strItems As String _
)

Parameters

strItems

See Also

GuiStage Object | GuiStage Members


SetFocus Method

SetFocus Method
GuiStage Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiStage Object | GuiStage Members


ShowContextMenu Method

ShowContextMenu Method
GuiStage Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiStage Object | GuiStage Members


Visualize Method

Visualize Method
On
InnerObject
GuiStage Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiStage Object | GuiStage Members


AccDescription Property

AccDescription Property
GuiStage Object : AccDescription Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccDescription As String

See Also

GuiStage Object | GuiStage Members


AccLabelCollection Property

AccLabelCollection Property
GuiStage Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiStage Object | GuiStage Members


AccText Property

AccText Property
GuiStage Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiStage Object | GuiStage Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiStage Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiStage Object | GuiStage Members


AccTooltip Property

AccTooltip Property
GuiStage Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiStage Object | GuiStage Members


Changeable Property

Changeable Property
GuiStage Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiStage Object | GuiStage Members


Children Property

Children Property
GuiStage Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiStage Object | GuiStage Members


ContainerType Property

ContainerType Property
GuiStage Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiStage Object | GuiStage Members


CurrentContextMenu Property

CurrentContextMenu Property
GuiStage Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

GuiStage Object | GuiStage Members


DefaultTooltip Property

DefaultTooltip Property
GuiStage Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiStage Object | GuiStage Members


DragDropSupported Property

DragDropSupported Property
GuiStage Object : DragDropSupported Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DragDropSupported As Byte

See Also

GuiStage Object | GuiStage Members


Handle Property

Handle Property
GuiStage Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiStage Object | GuiStage Members


Height Property

Height Property
GuiStage Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiStage Object | GuiStage Members


IconName Property

IconName Property
GuiStage Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiStage Object | GuiStage Members


Id Property

Id Property
GuiStage Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiStage Object | GuiStage Members


IsSymbolFont Property

IsSymbolFont Property
GuiStage Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiStage Object | GuiStage Members


Left Property

Left Property
GuiStage Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiStage Object | GuiStage Members


Modified Property

Modified Property
GuiStage Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiStage Object | GuiStage Members


Name Property

Name Property
GuiStage Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiStage Object | GuiStage Members


OcxEvents Property

OcxEvents Property
GuiStage Object : OcxEvents Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property OcxEvents As GuiCollection

See Also

GuiStage Object | GuiStage Members


Parent Property

Parent Property
GuiStage Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiStage Object | GuiStage Members


ParentFrame Property

ParentFrame Property
GuiStage Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiStage Object | GuiStage Members


ScreenLeft Property

ScreenLeft Property
GuiStage Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiStage Object | GuiStage Members


ScreenTop Property

ScreenTop Property
GuiStage Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiStage Object | GuiStage Members


SubType Property

SubType Property
GuiStage Object : SubType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property SubType As String

See Also

GuiStage Object | GuiStage Members


Text Property

Text Property
GuiStage Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiStage Object | GuiStage Members


Tooltip Property

Tooltip Property
GuiStage Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiStage Object | GuiStage Members


Top Property

Top Property
GuiStage Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiStage Object | GuiStage Members


Type Property

Type Property
GuiStage Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiStage Object | GuiStage Members


TypeAsNumber Property

TypeAsNumber Property
GuiStage Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiStage Object | GuiStage Members


Width Property

Width Property
GuiStage Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiStage Object | GuiStage Members


GuiStatusbar Object

GuiStatusbar Object
See Also Members

Glossary Item Box

Description

GuiStatusbar represents the message displaying part of the statusbar on the bottom of the SAP GUI window. It does not include the system and login information displayed in the rightmost area of the statusbar as these are available from the GuiSessionInfo object. GuiStatusbar extends GuiVComponent. The type prefix is sbar.

Object Model

GuiStatusbar ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent Object

See Also

GuiStatusbar Members


GuiStatusbar Object Members

GuiStatusbar Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DoubleClick | When a message is displayed in the GuiStatusbar, this message can be double clicked. This will usually open the SAP performance assistant.
Public Method DumpState |
Public Method FindAllByName |
Public Method FindAllByNameEx |
Public Method FindById |
Public Method FindByName |
Public Method FindByNameEx |
Public Method SetFocus |
Public Method ShowContextMenu |
Public Method Visualize |

Public Properties

Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property Children
Public Property ContainerType
Public Property DefaultTooltip
Public Property Handle
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property MessageAsPopup | Some messages may be displayed not only on the statusbar but also as a pop-up window. In such cases, this property is set to True so that a script knows it has to close a pop-up to continue.
Public Property MessageId | This is the name of the message class used in the ABAP message call.
Public Property MessageNumber | This is the name of the message number used in the ABAP message call. It will usually be a number, but this is not enforced by the system.
Public Property MessageParameter | These are the values of the parameters used to expand the placeholders in the message text definition in the data dictionary. The text property of the GuiStatusbar already contains the expanded text of the message. A maximum of 8 parameter values can be provided in the ABAP coding, so index should be in the range from 0 to 7.
Public Property MessageType

This property may have any of the following values:

Value | Description
S | Success
W | Warning
E | Error
A | Abort
I | Information

Public Property Modified
Public Property Name
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiStatusbar Object


DoubleClick Method

DoubleClick Method
GuiStatusbar Object : DoubleClick Method

Glossary Item Box

Description

When a message is displayed in the GuiStatusbar, this message can be double clicked. This will usually open the SAP performance assistant.

Syntax

Visual Basic
Public Sub DoubleClick()

See Also

GuiStatusbar Object | GuiStatusbar Members


DumpState Method

DumpState Method
InnerObject
GuiStatusbar Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiStatusbar Object | GuiStatusbar Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiStatusbar Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiStatusbar Object | GuiStatusbar Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiStatusbar Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiStatusbar Object | GuiStatusbar Members


FindById Method

FindById Method
Id
Raise
GuiStatusbar Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiStatusbar Object | GuiStatusbar Members


FindByName Method

FindByName Method
Name
Type
GuiStatusbar Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiStatusbar Object | GuiStatusbar Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiStatusbar Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiStatusbar Object | GuiStatusbar Members


SetFocus Method

SetFocus Method
GuiStatusbar Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiStatusbar Object | GuiStatusbar Members


ShowContextMenu Method

ShowContextMenu Method
GuiStatusbar Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiStatusbar Object | GuiStatusbar Members


Visualize Method

Visualize Method
On
InnerObject
GuiStatusbar Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiStatusbar Object | GuiStatusbar Members


AccLabelCollection Property

AccLabelCollection Property
GuiStatusbar Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiStatusbar Object | GuiStatusbar Members


AccText Property

AccText Property
GuiStatusbar Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiStatusbar Object | GuiStatusbar Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiStatusbar Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiStatusbar Object | GuiStatusbar Members


AccTooltip Property

AccTooltip Property
GuiStatusbar Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiStatusbar Object | GuiStatusbar Members


Changeable Property

Changeable Property
GuiStatusbar Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiStatusbar Object | GuiStatusbar Members


Children Property

Children Property
GuiStatusbar Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiStatusbar Object | GuiStatusbar Members


ContainerType Property

ContainerType Property
GuiStatusbar Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiStatusbar Object | GuiStatusbar Members


DefaultTooltip Property

DefaultTooltip Property
GuiStatusbar Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiStatusbar Object | GuiStatusbar Members


Handle Property

Handle Property
GuiStatusbar Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiStatusbar Object | GuiStatusbar Members


Height Property

Height Property
GuiStatusbar Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiStatusbar Object | GuiStatusbar Members


IconName Property

IconName Property
GuiStatusbar Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiStatusbar Object | GuiStatusbar Members


Id Property

Id Property
GuiStatusbar Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiStatusbar Object | GuiStatusbar Members


IsSymbolFont Property

IsSymbolFont Property
GuiStatusbar Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiStatusbar Object | GuiStatusbar Members


Left Property

Left Property
GuiStatusbar Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiStatusbar Object | GuiStatusbar Members


MessageAsPopup Property

MessageAsPopup Property
GuiStatusbar Object : MessageAsPopup Property

Glossary Item Box

Description

Some messages may be displayed not only on the statusbar but also as a pop-up window. In such cases, this property is set to True so that a script knows it has to close a pop-up to continue.

Property type

Read-only property

Syntax

Visual Basic
Public Property MessageAsPopup As Byte

See Also

GuiStatusbar Object | GuiStatusbar Members


MessageId Property

MessageId Property
GuiStatusbar Object : MessageId Property

Glossary Item Box

Description

This is the name of the message class used in the ABAP message call.

Property type

Read-only property

Syntax

Visual Basic
Public Property MessageId As String

See Also

GuiStatusbar Object | GuiStatusbar Members


MessageNumber Property

MessageNumber Property
GuiStatusbar Object : MessageNumber Property

Glossary Item Box

Description

This is the name of the message number used in the ABAP message call. It will usually be a number, but this is not enforced by the system.

Property type

Read-only property

Syntax

Visual Basic
Public Property MessageNumber As String

See Also

GuiStatusbar Object | GuiStatusbar Members


MessageParameter Property

MessageParameter Property
GuiStatusbar Object : MessageParameter Property

Glossary Item Box

Description

These are the values of the parameters used to expand the placeholders in the message text definition in the data dictionary. The text property of the GuiStatusbar already contains the expanded text of the message. A maximum of 8 parameter values can be provided in the ABAP coding, so index should be in the range from 0 to 7.

Property type

Read-only property

Syntax

Visual Basic
Public Property MessageParameter As String

Example

The ABAP language line
message e319(01) with 'test1' 'test2' 'test3' 'test4'.

will result in the following property values:
Text = E: test1 test2 test3 test4
Type = E
Id = 01
Number = 319
Parameter 0 = test1
Parameter 1 = test2
Parameter 2 = test3
Parameter 3 = test4
Parameter 4 =
Parameter 5 =
Parameter 6 =
Parameter 7 =
as Popup = False

The message 319 in message class 01 is defined as ‘ & & & &’, with ‘&’ being a placeholder.

See Also

GuiStatusbar Object | GuiStatusbar Members


MessageType Property

MessageType Property
GuiStatusbar Object : MessageType Property

Glossary Item Box

Description

This property may have any of the following values:

Value | Description
S | Success
W | Warning
E | Error
A | Abort
I | Information

Property type

Read-only property

Syntax

Visual Basic
Public Property MessageType As String

See Also

GuiStatusbar Object | GuiStatusbar Members


Modified Property

Modified Property
GuiStatusbar Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiStatusbar Object | GuiStatusbar Members


Name Property

Name Property
GuiStatusbar Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiStatusbar Object | GuiStatusbar Members


Parent Property

Parent Property
GuiStatusbar Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiStatusbar Object | GuiStatusbar Members


ParentFrame Property

ParentFrame Property
GuiStatusbar Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiStatusbar Object | GuiStatusbar Members


ScreenLeft Property

ScreenLeft Property
GuiStatusbar Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiStatusbar Object | GuiStatusbar Members


ScreenTop Property

ScreenTop Property
GuiStatusbar Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiStatusbar Object | GuiStatusbar Members


Text Property

Text Property
GuiStatusbar Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiStatusbar Object | GuiStatusbar Members


Tooltip Property

Tooltip Property
GuiStatusbar Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiStatusbar Object | GuiStatusbar Members


Top Property

Top Property
GuiStatusbar Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiStatusbar Object | GuiStatusbar Members


Type Property

Type Property
GuiStatusbar Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiStatusbar Object | GuiStatusbar Members


TypeAsNumber Property

TypeAsNumber Property
GuiStatusbar Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiStatusbar Object | GuiStatusbar Members


Width Property

Width Property
GuiStatusbar Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiStatusbar Object | GuiStatusbar Members


GuiStatusPane Object

GuiStatusPane Object
See Also Members

Glossary Item Box

Object Model

GuiStatusPane ObjectGuiComponentCollection CollectionGuiCollection CollectionGuiComponent ObjectGuiComponent Object

See Also

GuiStatusPane Members


GuiStatusPane Object Members

GuiStatusPane Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property ContainerType
Public Property DefaultTooltip
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiStatusPane Object


DumpState Method

DumpState Method
InnerObject
GuiStatusPane Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiStatusPane Object | GuiStatusPane Members


SetFocus Method

SetFocus Method
GuiStatusPane Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiStatusPane Object | GuiStatusPane Members


ShowContextMenu Method

ShowContextMenu Method
GuiStatusPane Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiStatusPane Object | GuiStatusPane Members


Visualize Method

Visualize Method
On
InnerObject
GuiStatusPane Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiStatusPane Object | GuiStatusPane Members


AccLabelCollection Property

AccLabelCollection Property
GuiStatusPane Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiStatusPane Object | GuiStatusPane Members


AccText Property

AccText Property
GuiStatusPane Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiStatusPane Object | GuiStatusPane Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiStatusPane Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiStatusPane Object | GuiStatusPane Members


AccTooltip Property

AccTooltip Property
GuiStatusPane Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiStatusPane Object | GuiStatusPane Members


Changeable Property

Changeable Property
GuiStatusPane Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiStatusPane Object | GuiStatusPane Members


ContainerType Property

ContainerType Property
GuiStatusPane Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiStatusPane Object | GuiStatusPane Members


DefaultTooltip Property

DefaultTooltip Property
GuiStatusPane Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiStatusPane Object | GuiStatusPane Members


Height Property

Height Property
GuiStatusPane Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiStatusPane Object | GuiStatusPane Members


IconName Property

IconName Property
GuiStatusPane Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiStatusPane Object | GuiStatusPane Members


Id Property

Id Property
GuiStatusPane Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiStatusPane Object | GuiStatusPane Members


IsSymbolFont Property

IsSymbolFont Property
GuiStatusPane Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiStatusPane Object | GuiStatusPane Members


Left Property

Left Property
GuiStatusPane Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiStatusPane Object | GuiStatusPane Members


Modified Property

Modified Property
GuiStatusPane Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiStatusPane Object | GuiStatusPane Members


Name Property

Name Property
GuiStatusPane Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiStatusPane Object | GuiStatusPane Members


Parent Property

Parent Property
GuiStatusPane Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiStatusPane Object | GuiStatusPane Members


ParentFrame Property

ParentFrame Property
GuiStatusPane Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiStatusPane Object | GuiStatusPane Members


ScreenLeft Property

ScreenLeft Property
GuiStatusPane Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiStatusPane Object | GuiStatusPane Members


ScreenTop Property

ScreenTop Property
GuiStatusPane Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiStatusPane Object | GuiStatusPane Members


Text Property

Text Property
GuiStatusPane Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiStatusPane Object | GuiStatusPane Members


Tooltip Property

Tooltip Property
GuiStatusPane Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiStatusPane Object | GuiStatusPane Members


Top Property

Top Property
GuiStatusPane Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiStatusPane Object | GuiStatusPane Members


Type Property

Type Property
GuiStatusPane Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiStatusPane Object | GuiStatusPane Members


TypeAsNumber Property

TypeAsNumber Property
GuiStatusPane Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiStatusPane Object | GuiStatusPane Members


Width Property

Width Property
GuiStatusPane Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiStatusPane Object | GuiStatusPane Members


GuiTab Object

GuiTab Object
See Also Members

Glossary Item Box

Description

The GuiTab objects are the children of a GuiTabStrip object. GuiTab extends GuiVContainer. The type prefix is tabp, the name is the id of the tab’s button taken from SAP data dictionary.

Object Model

GuiTab ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent Object

See Also

GuiTab Members


GuiTab Object Members

GuiTab Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState |
Public Method FindAllByName |
Public Method FindAllByNameEx |
Public Method FindById |
Public Method FindByName |
Public Method FindByNameEx |
Public Method ScrollToLeft | ScrollToLeft shifts the tabs so that a certain tab becomes the leftTab of the tab strip.
Public Method Select | This function sets the tab to be the tab strip’s selected tab. Changing the selected tab of a tab strip may cause server communication.
Public Method SetFocus |
Public Method ShowContextMenu |
Public Method Visualize |

Public Properties

Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property Children
Public Property ContainerType
Public Property DefaultTooltip
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiTab Object


DumpState Method

DumpState Method
InnerObject
GuiTab Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiTab Object | GuiTab Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiTab Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiTab Object | GuiTab Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiTab Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiTab Object | GuiTab Members


FindById Method

FindById Method
Id
Raise
GuiTab Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiTab Object | GuiTab Members


FindByName Method

FindByName Method
Name
Type
GuiTab Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiTab Object | GuiTab Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiTab Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiTab Object | GuiTab Members


ScrollToLeft Method

ScrollToLeft Method
GuiTab Object : ScrollToLeft Method

Glossary Item Box

Description

ScrollToLeft shifts the tabs so that a certain tab becomes the leftTab of the tab strip.

Syntax

Visual Basic
Public Sub ScrollToLeft()

See Also

GuiTab Object | GuiTab Members


Select Method

Select Method
GuiTab Object : Select Method

Glossary Item Box

Description

This function sets the tab to be the tab strip’s selected tab. Changing the selected tab of a tab strip may cause server communication.

Syntax

Visual Basic
Public Sub Select()

See Also

GuiTab Object | GuiTab Members


SetFocus Method

SetFocus Method
GuiTab Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiTab Object | GuiTab Members


ShowContextMenu Method

ShowContextMenu Method
GuiTab Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiTab Object | GuiTab Members


Visualize Method

Visualize Method
On
InnerObject
GuiTab Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiTab Object | GuiTab Members


AccLabelCollection Property

AccLabelCollection Property
GuiTab Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiTab Object | GuiTab Members


AccText Property

AccText Property
GuiTab Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiTab Object | GuiTab Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiTab Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiTab Object | GuiTab Members


AccTooltip Property

AccTooltip Property
GuiTab Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiTab Object | GuiTab Members


Changeable Property

Changeable Property
GuiTab Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiTab Object | GuiTab Members


Children Property

Children Property
GuiTab Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiTab Object | GuiTab Members


ContainerType Property

ContainerType Property
GuiTab Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiTab Object | GuiTab Members


DefaultTooltip Property

DefaultTooltip Property
GuiTab Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiTab Object | GuiTab Members


Height Property

Height Property
GuiTab Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiTab Object | GuiTab Members


IconName Property

IconName Property
GuiTab Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiTab Object | GuiTab Members


Id Property

Id Property
GuiTab Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiTab Object | GuiTab Members


IsSymbolFont Property

IsSymbolFont Property
GuiTab Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiTab Object | GuiTab Members


Left Property

Left Property
GuiTab Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiTab Object | GuiTab Members


Modified Property

Modified Property
GuiTab Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiTab Object | GuiTab Members


Name Property

Name Property
GuiTab Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiTab Object | GuiTab Members


Parent Property

Parent Property
GuiTab Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiTab Object | GuiTab Members


ParentFrame Property

ParentFrame Property
GuiTab Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiTab Object | GuiTab Members


ScreenLeft Property

ScreenLeft Property
GuiTab Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiTab Object | GuiTab Members


ScreenTop Property

ScreenTop Property
GuiTab Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiTab Object | GuiTab Members


Text Property

Text Property
GuiTab Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiTab Object | GuiTab Members


Tooltip Property

Tooltip Property
GuiTab Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiTab Object | GuiTab Members


Top Property

Top Property
GuiTab Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiTab Object | GuiTab Members


Type Property

Type Property
GuiTab Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiTab Object | GuiTab Members


TypeAsNumber Property

TypeAsNumber Property
GuiTab Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiTab Object | GuiTab Members


Width Property

Width Property
GuiTab Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiTab Object | GuiTab Members


GuiTableColumn Collection

GuiTableColumn Collection
See Also Members

Glossary Item Box

Description

GuiTableColumn extends GuiComponentCollection.

Object Model

GuiTableColumn Collection

See Also

GuiTableColumn Members


GuiTableColumn Collection Members

GuiTableColumn Collection Members
See Also Overview

Glossary Item Box

Public Methods

Public Method ElementAt
Public Method Item

Public Properties

Public Property Count |
Public Property DefaultTooltip |
Public Property Fixed | Some columns may be fixed, which means that they will not be scrolled with the rest of the columns.
Public Property IconName |
Public Property Length |
Public Property NewEnum |
Public Property Selected |
Public Property Title | This is the caption of the column.
Public Property Tooltip |
Public Property Type |
Public Property TypeAsNumber |

See Also

GuiTableColumn Collection


ElementAt Method

ElementAt Method
Index
GuiTableColumn Collection : ElementAt Method

Glossary Item Box

Syntax

Visual Basic
Public Function ElementAt( _
   ByVal Index As Long _
) As GuiComponent

Parameters

Index

See Also

GuiTableColumn Collection | GuiTableColumn Members


Item Method

Item Method
Index
GuiTableColumn Collection : Item Method

Glossary Item Box

Syntax

Visual Basic
Public Function Item( _
   ByVal Index As Variant _
) As GuiComponent

Parameters

Index

See Also

GuiTableColumn Collection | GuiTableColumn Members


Count Property

Count Property
GuiTableColumn Collection : Count Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

GuiTableColumn Collection | GuiTableColumn Members


DefaultTooltip Property

DefaultTooltip Property
GuiTableColumn Collection : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiTableColumn Collection | GuiTableColumn Members


Fixed Property

Fixed Property
GuiTableColumn Collection : Fixed Property

Glossary Item Box

Description

Some columns may be fixed, which means that they will not be scrolled with the rest of the columns.

Property type

Read-only property

Syntax

Visual Basic
Public Property Fixed As Byte

Example

In the following example the column ‘User’ is selected:

See Also

GuiTableColumn Collection | GuiTableColumn Members


IconName Property

IconName Property
GuiTableColumn Collection : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiTableColumn Collection | GuiTableColumn Members


Length Property

Length Property
GuiTableColumn Collection : Length Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Length As Long

See Also

GuiTableColumn Collection | GuiTableColumn Members


NewEnum Property

NewEnum Property
GuiTableColumn Collection : NewEnum Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property NewEnum As Unknown

See Also

GuiTableColumn Collection | GuiTableColumn Members


Selected Property

Selected Property
GuiTableColumn Collection : Selected Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Selected As Byte

See Also

GuiTableColumn Collection | GuiTableColumn Members


Title Property

Title Property
GuiTableColumn Collection : Title Property

Glossary Item Box

Description

This is the caption of the column.

Property type

Read-only property

Syntax

Visual Basic
Public Property Title As String

Example

In the example above the script
MsgBox session.findById ("wnd[0]/usr/tblSAPMBIBSTC535").columns(3).title
displays the text ‘Account’.

See Also

GuiTableColumn Collection | GuiTableColumn Members


Tooltip Property

Tooltip Property
GuiTableColumn Collection : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiTableColumn Collection | GuiTableColumn Members


Type Property

Type Property
GuiTableColumn Collection : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiTableColumn Collection | GuiTableColumn Members


TypeAsNumber Property

TypeAsNumber Property
GuiTableColumn Collection : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiTableColumn Collection | GuiTableColumn Members


GuiTableControl Object

GuiTableControl Object
See Also Members

Glossary Item Box

Description

The table control is a standard dynpro element, in contrast to the GuiCtrlGridView, which looks similar. GuiTableControl extends GuiVContainer. The type prefix is tbl, the name is the fieldname taken from the SAP data dictionary.

Object Model

GuiTableControl ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiCollection CollectionGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiTableRow CollectionGuiVComponent ObjectGuiScrollbar ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiScrollbar Object

Example

See Also

GuiTableControl Members


GuiTableControl Object Members

GuiTableControl Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method ConfigureLayout | In the configuration dialog the layout of the table can be changed. This dialog is a GuiModalWindow.
Public Method DeselectAllColumns | This function can be used for table controls with a button that allows to de-select all columns in one step.
Public Method DumpState |
Public Method FindAllByName |
Public Method FindAllByNameEx |
Public Method FindById |
Public Method FindByName |
Public Method FindByNameEx |
Public Method GetAbsoluteRow | Unlike the rows collection, the indexing supported by this function does not reset the index after scrolling, but counts the rows starting with the first row with respect to the first scroll position. If the selected row is not currently visible then an exception is raised.
Public Method GetCell | This method returns a given table cell. It is more efficient than accessing a single cell using the rows or columns collections.
Public Method ReorderTable | The parameter permutation describes a new ordering of the columns. For example “1 3 2” will move column 3 to second position.
Public Method SelectAllColumns | This function can be used for table controls with a button that allows to select all columns in one step.
Public Method SetFocus |
Public Method ShowContextMenu |
Public Method Visualize |

Public Properties

Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property Changeable |
Public Property CharHeight |
Public Property CharLeft |
Public Property CharTop |
Public Property CharWidth |
Public Property Children |
Public Property ColSelectMode | There are three different modes for selecting columns or rows, which are defined in the enumeration type GuiTableSelectionType.
Public Property Columns | The members of this collection are of GuiTableColumn type. Therefore they do not support properties like id or name.
Public Property ContainerType |
Public Property CurrentCol | Zero-based index of the current column.
Public Property CurrentRow | Zero-based index of the current row.
Public Property DefaultTooltip |
Public Property Height |
Public Property HorizontalScrollbar | The horizontal scrollbar of the table control.
Public Property IconName |
Public Property Id |
Public Property IsSymbolFont |
Public Property Left |
Public Property Modified |
Public Property Name |
Public Property Parent |
Public Property ParentFrame |
Public Property RowCount | Number of rows in the table. This includes invisible rows. For the number of visible rows the property VisibleRowCount is available.
Public Property Rows | The members of this collection are of GuiTableRow type. Indexing starts with 0 for the first visible row, independent of the current position of the horizontal scrollbar. After scrolling, a different row will have the index 0.
Public Property RowSelectMode | There are three different modes for selecting columns or rows, which are defined in the enumeration type GuiTableSelectionType.
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property TableFieldName | The name property of the table control contains the ABAP program name in addition to the plain field name. This property contains just the field name.
Public Property Text |
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property VerticalScrollbar | The vertical scrollbar of the table control.
Public Property VisibleRowCount | Number of visible rows in the table. For the number of all rows the property RowCount is available.
Public Property Width |

See Also

GuiTableControl Object


ConfigureLayout Method

ConfigureLayout Method
GuiTableControl Object : ConfigureLayout Method

Glossary Item Box

Description

In the configuration dialog the layout of the table can be changed. This dialog is a GuiModalWindow.

Syntax

Visual Basic
Public Sub ConfigureLayout()

Example

See Also

GuiTableControl Object | GuiTableControl Members


DeselectAllColumns Method

DeselectAllColumns Method
GuiTableControl Object : DeselectAllColumns Method

Glossary Item Box

Description

This function can be used for table controls with a button that allows to de-select all columns in one step.

Syntax

Visual Basic
Public Sub DeselectAllColumns()

See Also

GuiTableControl Object | GuiTableControl Members


DumpState Method

DumpState Method
InnerObject
GuiTableControl Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiTableControl Object | GuiTableControl Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiTableControl Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiTableControl Object | GuiTableControl Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiTableControl Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiTableControl Object | GuiTableControl Members


FindById Method

FindById Method
Id
Raise
GuiTableControl Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiTableControl Object | GuiTableControl Members


FindByName Method

FindByName Method
Name
Type
GuiTableControl Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiTableControl Object | GuiTableControl Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiTableControl Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiTableControl Object | GuiTableControl Members


GetAbsoluteRow Method

GetAbsoluteRow Method
Index
GuiTableControl Object : GetAbsoluteRow Method

Glossary Item Box

Description

Unlike the rows collection, the indexing supported by this function does not reset the index after scrolling, but counts the rows starting with the first row with respect to the first scroll position. If the selected row is not currently visible then an exception is raised.

Syntax

Visual Basic
Public Function GetAbsoluteRow( _
   ByVal Index As Long _
) As GuiTableRow

Parameters

Index

See Also

GuiTableControl Object | GuiTableControl Members


GetCell Method

GetCell Method
Row
Zero-based index of the row.
Column
Zero-based index of the column.
GuiTableControl Object : GetCell Method

Glossary Item Box

Description

This method returns a given table cell. It is more efficient than accessing a single cell using the rows or columns collections.

Syntax

Visual Basic
Public Function GetCell( _
   ByVal Row As Long, _
   ByVal Column As Long _
) As GuiVComponent

Parameters

Row
Zero-based index of the row.
Column
Zero-based index of the column.

See Also

GuiTableControl Object | GuiTableControl Members


ReorderTable Method

ReorderTable Method
Permutation
GuiTableControl Object : ReorderTable Method

Glossary Item Box

Description

The parameter permutation describes a new ordering of the columns. For example “1 3 2” will move column 3 to second position.

Syntax

Visual Basic
Public Sub ReorderTable( _
   ByVal Permutation As String _
)

Parameters

Permutation

See Also

GuiTableControl Object | GuiTableControl Members


SelectAllColumns Method

SelectAllColumns Method
GuiTableControl Object : SelectAllColumns Method

Glossary Item Box

Description

This function can be used for table controls with a button that allows to select all columns in one step.

Syntax

Visual Basic
Public Sub SelectAllColumns()

See Also

GuiTableControl Object | GuiTableControl Members


SetFocus Method

SetFocus Method
GuiTableControl Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiTableControl Object | GuiTableControl Members


ShowContextMenu Method

ShowContextMenu Method
GuiTableControl Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiTableControl Object | GuiTableControl Members


Visualize Method

Visualize Method
On
InnerObject
GuiTableControl Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiTableControl Object | GuiTableControl Members


AccLabelCollection Property

AccLabelCollection Property
GuiTableControl Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiTableControl Object | GuiTableControl Members


AccText Property

AccText Property
GuiTableControl Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiTableControl Object | GuiTableControl Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiTableControl Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiTableControl Object | GuiTableControl Members


AccTooltip Property

AccTooltip Property
GuiTableControl Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiTableControl Object | GuiTableControl Members


Changeable Property

Changeable Property
GuiTableControl Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiTableControl Object | GuiTableControl Members


CharHeight Property

CharHeight Property
GuiTableControl Object : CharHeight Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharHeight As Long

See Also

GuiTableControl Object | GuiTableControl Members


CharLeft Property

CharLeft Property
GuiTableControl Object : CharLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharLeft As Long

See Also

GuiTableControl Object | GuiTableControl Members


CharTop Property

CharTop Property
GuiTableControl Object : CharTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharTop As Long

See Also

GuiTableControl Object | GuiTableControl Members


CharWidth Property

CharWidth Property
GuiTableControl Object : CharWidth Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharWidth As Long

See Also

GuiTableControl Object | GuiTableControl Members


Children Property

Children Property
GuiTableControl Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiTableControl Object | GuiTableControl Members


ColSelectMode Property

ColSelectMode Property
GuiTableControl Object : ColSelectMode Property

Glossary Item Box

Description

There are three different modes for selecting columns or rows, which are defined in the enumeration type GuiTableSelectionType.

Property type

Read-only property

Syntax

Visual Basic
Public Property ColSelectMode As GuiTableSelectionType

See Also

GuiTableControl Object | GuiTableControl Members


Columns Property

Columns Property
GuiTableControl Object : Columns Property

Glossary Item Box

Description

The members of this collection are of GuiTableColumn type. Therefore they do not support properties like id or name.

Property type

Read-only property

Syntax

Visual Basic
Public Property Columns As GuiCollection

See Also

GuiTableControl Object | GuiTableControl Members


ContainerType Property

ContainerType Property
GuiTableControl Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiTableControl Object | GuiTableControl Members


CurrentCol Property

CurrentCol Property
GuiTableControl Object : CurrentCol Property

Glossary Item Box

Description

Zero-based index of the current column.

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentCol As Long

See Also

GuiTableControl Object | GuiTableControl Members


CurrentRow Property

CurrentRow Property
GuiTableControl Object : CurrentRow Property

Glossary Item Box

Description

Zero-based index of the current row.

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentRow As Long

See Also

GuiTableControl Object | GuiTableControl Members


DefaultTooltip Property

DefaultTooltip Property
GuiTableControl Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiTableControl Object | GuiTableControl Members


Height Property

Height Property
GuiTableControl Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiTableControl Object | GuiTableControl Members


HorizontalScrollbar Property

HorizontalScrollbar Property
GuiTableControl Object : HorizontalScrollbar Property

Glossary Item Box

Description

The horizontal scrollbar of the table control.

Property type

Read-only property

Syntax

Visual Basic
Public Property HorizontalScrollbar As GuiScrollbar

See Also

GuiTableControl Object | GuiTableControl Members


IconName Property

IconName Property
GuiTableControl Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiTableControl Object | GuiTableControl Members


Id Property

Id Property
GuiTableControl Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiTableControl Object | GuiTableControl Members


IsSymbolFont Property

IsSymbolFont Property
GuiTableControl Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiTableControl Object | GuiTableControl Members


Left Property

Left Property
GuiTableControl Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiTableControl Object | GuiTableControl Members


Modified Property

Modified Property
GuiTableControl Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiTableControl Object | GuiTableControl Members


Name Property

Name Property
GuiTableControl Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiTableControl Object | GuiTableControl Members


Parent Property

Parent Property
GuiTableControl Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiTableControl Object | GuiTableControl Members


ParentFrame Property

ParentFrame Property
GuiTableControl Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiTableControl Object | GuiTableControl Members


RowCount Property

RowCount Property
GuiTableControl Object : RowCount Property

Glossary Item Box

Description

Number of rows in the table. This includes invisible rows. For the number of visible rows the property VisibleRowCount is available.

Property type

Read-only property

Syntax

Visual Basic
Public Property RowCount As Long

See Also

GuiTableControl Object | GuiTableControl Members


Rows Property

Rows Property
GuiTableControl Object : Rows Property

Glossary Item Box

Description

The members of this collection are of GuiTableRow type. Indexing starts with 0 for the first visible row, independent of the current position of the horizontal scrollbar. After scrolling, a different row will have the index 0.

Property type

Read-only property

Syntax

Visual Basic
Public Property Rows As GuiCollection

See Also

GuiTableControl Object | GuiTableControl Members


RowSelectMode Property

RowSelectMode Property
GuiTableControl Object : RowSelectMode Property

Glossary Item Box

Description

There are three different modes for selecting columns or rows, which are defined in the enumeration type GuiTableSelectionType.

Property type

Read-only property

Syntax

Visual Basic
Public Property RowSelectMode As GuiTableSelectionType

See Also

GuiTableControl Object | GuiTableControl Members


ScreenLeft Property

ScreenLeft Property
GuiTableControl Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiTableControl Object | GuiTableControl Members


ScreenTop Property

ScreenTop Property
GuiTableControl Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiTableControl Object | GuiTableControl Members


TableFieldName Property

TableFieldName Property
GuiTableControl Object : TableFieldName Property

Glossary Item Box

Description

The name property of the table control contains the ABAP program name in addition to the plain field name. This property contains just the field name.

Property type

Read-only property

Syntax

Visual Basic
Public Property TableFieldName As String

See Also

GuiTableControl Object | GuiTableControl Members


Text Property

Text Property
GuiTableControl Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiTableControl Object | GuiTableControl Members


Tooltip Property

Tooltip Property
GuiTableControl Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiTableControl Object | GuiTableControl Members


Top Property

Top Property
GuiTableControl Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiTableControl Object | GuiTableControl Members


Type Property

Type Property
GuiTableControl Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiTableControl Object | GuiTableControl Members


TypeAsNumber Property

TypeAsNumber Property
GuiTableControl Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiTableControl Object | GuiTableControl Members


VerticalScrollbar Property

VerticalScrollbar Property
GuiTableControl Object : VerticalScrollbar Property

Glossary Item Box

Description

The vertical scrollbar of the table control.

Property type

Read-only property

Syntax

Visual Basic
Public Property VerticalScrollbar As GuiScrollbar

See Also

GuiTableControl Object | GuiTableControl Members


VisibleRowCount Property

VisibleRowCount Property
GuiTableControl Object : VisibleRowCount Property

Glossary Item Box

Description

Number of visible rows in the table. For the number of all rows the property RowCount is available.

Property type

Read-only property

Syntax

Visual Basic
Public Property VisibleRowCount As Long

See Also

GuiTableControl Object | GuiTableControl Members


Width Property

Width Property
GuiTableControl Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiTableControl Object | GuiTableControl Members


GuiTableRow Collection

GuiTableRow Collection
See Also Members

Glossary Item Box

Description

GuiTableRow extends GuiComponentCollection.

Object Model

GuiTableRow Collection

See Also

GuiTableRow Members


GuiTableRow Collection Members

GuiTableRow Collection Members
See Also Overview

Glossary Item Box

Public Methods

Public Method ElementAt
Public Method Item

Public Properties

Public Property Count | Number of cells in the row.
Public Property Length | Number of cells in the row.
Public Property NewEnum | Property for VB collection handling.
Public Property Selectable | This propergy is True if the row can be selected.
Public Property Selected | This property is true if the row is selected.
Public Property Type |
Public Property TypeAsNumber |

See Also

GuiTableRow Collection


ElementAt Method

ElementAt Method
Index
GuiTableRow Collection : ElementAt Method

Glossary Item Box

Syntax

Visual Basic
Public Function ElementAt( _
   ByVal Index As Long _
) As GuiComponent

Parameters

Index

See Also

GuiTableRow Collection | GuiTableRow Members


Item Method

Item Method
Index
GuiTableRow Collection : Item Method

Glossary Item Box

Syntax

Visual Basic
Public Function Item( _
   ByVal Index As Variant _
) As GuiComponent

Parameters

Index

See Also

GuiTableRow Collection | GuiTableRow Members


Count Property

Count Property
GuiTableRow Collection : Count Property

Glossary Item Box

Description

Number of cells in the row.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

GuiTableRow Collection | GuiTableRow Members


Length Property

Length Property
GuiTableRow Collection : Length Property

Glossary Item Box

Description

Number of cells in the row.

Property type

Read-only property

Syntax

Visual Basic
Public Property Length As Long

See Also

GuiTableRow Collection | GuiTableRow Members


NewEnum Property

NewEnum Property
GuiTableRow Collection : NewEnum Property

Glossary Item Box

Description

Property for VB collection handling.

Property type

Read-only property

Syntax

Visual Basic
Public Property NewEnum As Unknown

See Also

GuiTableRow Collection | GuiTableRow Members


Selectable Property

Selectable Property
GuiTableRow Collection : Selectable Property

Glossary Item Box

Description

This propergy is True if the row can be selected.

Property type

Read-write property

Syntax

Visual Basic
Public Property Selectable As Byte

See Also

GuiTableRow Collection | GuiTableRow Members


Selected Property

Selected Property
GuiTableRow Collection : Selected Property

Glossary Item Box

Description

This property is true if the row is selected.

Property type

Read-write property

Syntax

Visual Basic
Public Property Selected As Byte

Example

In this example multiple lines are selected.

See Also

GuiTableRow Collection | GuiTableRow Members


Type Property

Type Property
GuiTableRow Collection : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiTableRow Collection | GuiTableRow Members


TypeAsNumber Property

TypeAsNumber Property
GuiTableRow Collection : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiTableRow Collection | GuiTableRow Members


GuiTabStrip Object

GuiTabStrip Object
See Also Members

Glossary Item Box

Description

A tab strip is a container whose children are of type GuiTab. GuiTabStrip extends GuiVContainer. The type prefix is tabs, the name is the fieldname taken from the SAP data dictionary.

Object Model

GuiTabStrip ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiTab ObjectGuiComponent ObjectGuiComponent ObjectGuiTab Object

Example

The children of the tab strip are the tabs. While all tabs are available at any given time, only the children of the selected tab exist in the object hierarchy for server driven tab strips. So in this example, the text field ‘Applicant no.’ can only be found if the tab labelled ‘General data’ has been selected.

In some transactions there are local tabs strips where all tabs are available without further server access being required.

See Also

GuiTabStrip Members


GuiTabStrip Object Members

GuiTabStrip Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property Changeable |
Public Property CharHeight |
Public Property CharLeft |
Public Property CharTop |
Public Property CharWidth |
Public Property Children |
Public Property ContainerType |
Public Property DefaultTooltip |
Public Property Height |
Public Property IconName |
Public Property Id |
Public Property IsSymbolFont |
Public Property Left |
Public Property LeftTab | This is the left most tab whose caption is visible. In the example above it is the one with text ‘Period closing’. The leftTab property can be changed by calling the ScrollToLeft method of a different GuiTab, as described below.
Public Property Modified |
Public Property Name |
Public Property Parent |
Public Property ParentFrame |
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property SelectedTab | The selected tab is the one whose descendants are currently visualized, in the example above it is the ‘General data’ tab. The selected tab has exactly one child, which is a GuiScrollContainer.
Public Property Text |
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property Width |

See Also

GuiTabStrip Object


DumpState Method

DumpState Method
InnerObject
GuiTabStrip Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiTabStrip Object | GuiTabStrip Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiTabStrip Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiTabStrip Object | GuiTabStrip Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiTabStrip Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiTabStrip Object | GuiTabStrip Members


FindById Method

FindById Method
Id
Raise
GuiTabStrip Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiTabStrip Object | GuiTabStrip Members


FindByName Method

FindByName Method
Name
Type
GuiTabStrip Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiTabStrip Object | GuiTabStrip Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiTabStrip Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiTabStrip Object | GuiTabStrip Members


SetFocus Method

SetFocus Method
GuiTabStrip Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiTabStrip Object | GuiTabStrip Members


ShowContextMenu Method

ShowContextMenu Method
GuiTabStrip Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiTabStrip Object | GuiTabStrip Members


Visualize Method

Visualize Method
On
InnerObject
GuiTabStrip Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiTabStrip Object | GuiTabStrip Members


AccLabelCollection Property

AccLabelCollection Property
GuiTabStrip Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiTabStrip Object | GuiTabStrip Members


AccText Property

AccText Property
GuiTabStrip Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiTabStrip Object | GuiTabStrip Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiTabStrip Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiTabStrip Object | GuiTabStrip Members


AccTooltip Property

AccTooltip Property
GuiTabStrip Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiTabStrip Object | GuiTabStrip Members


Changeable Property

Changeable Property
GuiTabStrip Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiTabStrip Object | GuiTabStrip Members


CharHeight Property

CharHeight Property
GuiTabStrip Object : CharHeight Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharHeight As Long

See Also

GuiTabStrip Object | GuiTabStrip Members


CharLeft Property

CharLeft Property
GuiTabStrip Object : CharLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharLeft As Long

See Also

GuiTabStrip Object | GuiTabStrip Members


CharTop Property

CharTop Property
GuiTabStrip Object : CharTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharTop As Long

See Also

GuiTabStrip Object | GuiTabStrip Members


CharWidth Property

CharWidth Property
GuiTabStrip Object : CharWidth Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharWidth As Long

See Also

GuiTabStrip Object | GuiTabStrip Members


Children Property

Children Property
GuiTabStrip Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiTabStrip Object | GuiTabStrip Members


ContainerType Property

ContainerType Property
GuiTabStrip Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiTabStrip Object | GuiTabStrip Members


DefaultTooltip Property

DefaultTooltip Property
GuiTabStrip Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiTabStrip Object | GuiTabStrip Members


Height Property

Height Property
GuiTabStrip Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiTabStrip Object | GuiTabStrip Members


IconName Property

IconName Property
GuiTabStrip Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiTabStrip Object | GuiTabStrip Members


Id Property

Id Property
GuiTabStrip Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiTabStrip Object | GuiTabStrip Members


IsSymbolFont Property

IsSymbolFont Property
GuiTabStrip Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiTabStrip Object | GuiTabStrip Members


Left Property

Left Property
GuiTabStrip Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiTabStrip Object | GuiTabStrip Members


LeftTab Property

LeftTab Property
GuiTabStrip Object : LeftTab Property

Glossary Item Box

Description

This is the left most tab whose caption is visible. In the example above it is the one with text ‘Period closing’. The leftTab property can be changed by calling the ScrollToLeft method of a different GuiTab, as described below.

Property type

Read-only property

Syntax

Visual Basic
Public Property LeftTab As GuiTab

See Also

GuiTabStrip Object | GuiTabStrip Members


Modified Property

Modified Property
GuiTabStrip Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiTabStrip Object | GuiTabStrip Members


Name Property

Name Property
GuiTabStrip Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiTabStrip Object | GuiTabStrip Members


Parent Property

Parent Property
GuiTabStrip Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiTabStrip Object | GuiTabStrip Members


ParentFrame Property

ParentFrame Property
GuiTabStrip Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiTabStrip Object | GuiTabStrip Members


ScreenLeft Property

ScreenLeft Property
GuiTabStrip Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiTabStrip Object | GuiTabStrip Members


ScreenTop Property

ScreenTop Property
GuiTabStrip Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiTabStrip Object | GuiTabStrip Members


SelectedTab Property

SelectedTab Property
GuiTabStrip Object : SelectedTab Property

Glossary Item Box

Description

The selected tab is the one whose descendants are currently visualized, in the example above it is the ‘General data’ tab. The selected tab has exactly one child, which is a GuiScrollContainer.

Property type

Read-only property

Syntax

Visual Basic
Public Property SelectedTab As GuiTab

See Also

GuiTabStrip Object | GuiTabStrip Members


Text Property

Text Property
GuiTabStrip Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiTabStrip Object | GuiTabStrip Members


Tooltip Property

Tooltip Property
GuiTabStrip Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiTabStrip Object | GuiTabStrip Members


Top Property

Top Property
GuiTabStrip Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiTabStrip Object | GuiTabStrip Members


Type Property

Type Property
GuiTabStrip Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiTabStrip Object | GuiTabStrip Members


TypeAsNumber Property

TypeAsNumber Property
GuiTabStrip Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiTabStrip Object | GuiTabStrip Members


Width Property

Width Property
GuiTabStrip Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiTabStrip Object | GuiTabStrip Members


GuiTextedit Object

GuiTextedit Object
See Also Members

Glossary Item Box

Description

The TextEdit control is a multiline edit control offering a number of possible benefits. With regard to scripting, the possibility of protecting text parts against editing by the user is especially useful.

Object Model

GuiTextedit ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiComponent ObjectGuiComponent Object

See Also

GuiTextedit Members


GuiTextedit Object Members

GuiTextedit Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method ContextMenu | Calling ContextMenu emulates the context menu request.
Public Method DoubleClick | This function emulates a mouse double click. For setting the selection, the function setSelectionIndexes can be called in advance.
Public Method DumpState |
Public Method FindAllByName |
Public Method FindAllByNameEx |
Public Method FindById |
Public Method FindByName |
Public Method FindByNameEx |
Public Method GetLineText | Returns the text of the specified line.
Public Method GetUnprotectedTextPart | This function retrieves the content of an unprotected text part using the zero based index part.
Public Method IsBreakpointLine | Returns TRUE if the specified line contains a breakpoint .
Public Method IsCommentLine | Returns TRUE if the specified line is a comment line.
Public Method IsHighlightedLine | Returns TRUE if the specified line is highlighted.
Public Method IsProtectedLine | Returns TRUE if the specified line is protected.
Public Method IsSelectedLine | Returns TRUE if the specified line is selected.
Public Method ModifiedStatusChanged | This function emulates the change of the modified status.
Public Method MultipleFilesDropped | Emulate a Drag&Drop operation, in which several files are dropped on the textedit control. The collection contains for each file the fully qualified file name as a string.
Public Method PressF1 | This function emulates pressing the F1 key on the keyboard.
Public Method PressF4 | This function emulates pressing the F4 key on the keyboard.
Public Method SelectContextMenuItem |
Public Method SelectContextMenuItemByPosition |
Public Method SelectContextMenuItemByText |
Public Method SetFocus |
Public Method SetSelectionIndexes | This function sets the visually selected text range. start and end are absolute, zero based character indexes. start corresponds to the position where the selection begins and end is the position of the first character following the selection. Note that setting start equal to end results in setting the cursor on this position.
Public Method SetUnprotectedTextPart | This function assigns the content of text to the unprotected text part with zero based index part. The function returns True if it was possible to perform the assignment. Otherwise, False is returned.
Public Method ShowContextMenu |
Public Method SingleFileDropped | This function emulates the drop of a single file with the directory path fileName.
Public Method Visualize |

Public Properties

Public Property AccDescription |
Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property Changeable |
Public Property Children |
Public Property ContainerType |
Public Property CurrentColumn | The number of the column in which the text caret is currently positioned.
Public Property CurrentContextMenu |
Public Property CurrentLine | The number of the line in which the text caret is currently positioned.
Public Property DefaultTooltip |
Public Property DragDropSupported |
Public Property FirstVisibleLine | The first visible line is visualized at the top border of the control.
Public Property Handle |
Public Property Height |
Public Property IconName |
Public Property Id |
Public Property IsSymbolFont |
Public Property LastVisibleLine | The number of the last line that is currently visible.
Public Property Left |
Public Property LineCount | The number of all lines in the current document.
Public Property Modified |
Public Property Name |
Public Property NumberOfUnprotectedTextParts | The number of unprotected text parts which are contained.
Public Property OcxEvents |
Public Property Parent |
Public Property ParentFrame |
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property SelectedText | The currently selected text.
Public Property SelectionEndColumn | The number of the column in which the current selection ends.
Public Property SelectionEndLine | The number of the line in which the current selection ends.
Public Property SelectionIndexEnd | Retrieves the absolute, zero based character index of the ending point from the visually selected text range, i.e. the position where the selection ends. Note that a selection can be degenerated, i.e. selectionIndexStart is equal to selectionIndexEnd.
Public Property SelectionIndexStart | Retrieves the absolute, zero based character index of the starting point from the visually selected text range, i.e. the position, where the selection begins. Note that a selection can be degenerated, i.e. selectionIndexStart is equal to selectionIndexEnd.
Public Property SelectionStartColumn | The number of the column in which the current selection starts.
Public Property SelectionStartLine | The number of the line in which the current selection starts.
Public Property SubType | This property has the constant value “TextEdit”.
Public Property Text | The value of this property represents the text contained in the control. Note that setting the text is denied if the control is in read only mode or a certain text part is protected.
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property Width |

See Also

GuiTextedit Object


ContextMenu Method

ContextMenu Method
GuiTextedit Object : ContextMenu Method

Glossary Item Box

Description

Calling ContextMenu emulates the context menu request.

Syntax

Visual Basic
Public Sub ContextMenu()

See Also

GuiTextedit Object | GuiTextedit Members


DoubleClick Method

DoubleClick Method
GuiTextedit Object : DoubleClick Method

Glossary Item Box

Description

This function emulates a mouse double click. For setting the selection, the function setSelectionIndexes can be called in advance.

Syntax

Visual Basic
Public Sub DoubleClick()

See Also

GuiTextedit Object | GuiTextedit Members


DumpState Method

DumpState Method
InnerObject
GuiTextedit Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiTextedit Object | GuiTextedit Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiTextedit Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiTextedit Object | GuiTextedit Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiTextedit Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiTextedit Object | GuiTextedit Members


FindById Method

FindById Method
Id
Raise
GuiTextedit Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiTextedit Object | GuiTextedit Members


FindByName Method

FindByName Method
Name
Type
GuiTextedit Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiTextedit Object | GuiTextedit Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiTextedit Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiTextedit Object | GuiTextedit Members


GetLineText Method

GetLineText Method
nLine
Index of the line
GuiTextedit Object : GetLineText Method

Glossary Item Box

Description

Returns the text of the specified line.

Syntax

Visual Basic
Public Function GetLineText( _
   ByVal nLine As Long _
) As String

Parameters

nLine
Index of the line

See Also

GuiTextedit Object | GuiTextedit Members


GetUnprotectedTextPart Method

GetUnprotectedTextPart Method
Part
GuiTextedit Object : GetUnprotectedTextPart Method

Glossary Item Box

Description

This function retrieves the content of an unprotected text part using the zero based index part.

Syntax

Visual Basic
Public Function GetUnprotectedTextPart( _
   ByVal Part As Long _
) As String

Parameters

Part

See Also

GuiTextedit Object | GuiTextedit Members


IsBreakpointLine Method

IsBreakpointLine Method
nLine
GuiTextedit Object : IsBreakpointLine Method

Glossary Item Box

Description

Returns TRUE if the specified line contains a breakpoint .

Syntax

Visual Basic
Public Function IsBreakpointLine( _
   ByVal nLine As Long _
) As Byte

Parameters

nLine

See Also

GuiTextedit Object | GuiTextedit Members


IsCommentLine Method

IsCommentLine Method
nLine
GuiTextedit Object : IsCommentLine Method

Glossary Item Box

Description

Returns TRUE if the specified line is a comment line.

Syntax

Visual Basic
Public Function IsCommentLine( _
   ByVal nLine As Long _
) As Byte

Parameters

nLine

See Also

GuiTextedit Object | GuiTextedit Members


IsHighlightedLine Method

IsHighlightedLine Method
nLine
GuiTextedit Object : IsHighlightedLine Method

Glossary Item Box

Description

Returns TRUE if the specified line is highlighted.

Syntax

Visual Basic
Public Function IsHighlightedLine( _
   ByVal nLine As Long _
) As Byte

Parameters

nLine

See Also

GuiTextedit Object | GuiTextedit Members


IsProtectedLine Method

IsProtectedLine Method
nLine
GuiTextedit Object : IsProtectedLine Method

Glossary Item Box

Description

Returns TRUE if the specified line is protected.

Syntax

Visual Basic
Public Function IsProtectedLine( _
   ByVal nLine As Long _
) As Byte

Parameters

nLine

See Also

GuiTextedit Object | GuiTextedit Members


IsSelectedLine Method

IsSelectedLine Method
nLine
GuiTextedit Object : IsSelectedLine Method

Glossary Item Box

Description

Returns TRUE if the specified line is selected.

Syntax

Visual Basic
Public Function IsSelectedLine( _
   ByVal nLine As Long _
) As Byte

Parameters

nLine

See Also

GuiTextedit Object | GuiTextedit Members


ModifiedStatusChanged Method

ModifiedStatusChanged Method
Status
GuiTextedit Object : ModifiedStatusChanged Method

Glossary Item Box

Description

This function emulates the change of the modified status.

Syntax

Visual Basic
Public Sub ModifiedStatusChanged( _
   ByVal Status As Boolean _
)

Parameters

Status

See Also

GuiTextedit Object | GuiTextedit Members


MultipleFilesDropped Method

MultipleFilesDropped Method
GuiTextedit Object : MultipleFilesDropped Method

Glossary Item Box

Description

Emulate a Drag&Drop operation, in which several files are dropped on the textedit control. The collection contains for each file the fully qualified file name as a string.

Syntax

Visual Basic
Public Sub MultipleFilesDropped()

See Also

GuiTextedit Object | GuiTextedit Members


PressF1 Method

PressF1 Method
GuiTextedit Object : PressF1 Method

Glossary Item Box

Description

This function emulates pressing the F1 key on the keyboard.

Syntax

Visual Basic
Public Sub PressF1()

See Also

GuiTextedit Object | GuiTextedit Members


PressF4 Method

PressF4 Method
GuiTextedit Object : PressF4 Method

Glossary Item Box

Description

This function emulates pressing the F4 key on the keyboard.

Syntax

Visual Basic
Public Sub PressF4()

See Also

GuiTextedit Object | GuiTextedit Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiTextedit Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiTextedit Object | GuiTextedit Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiTextedit Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiTextedit Object | GuiTextedit Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiTextedit Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

GuiTextedit Object | GuiTextedit Members


SetFocus Method

SetFocus Method
GuiTextedit Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiTextedit Object | GuiTextedit Members


SetSelectionIndexes Method

SetSelectionIndexes Method
Start
End
GuiTextedit Object : SetSelectionIndexes Method

Glossary Item Box

Description

This function sets the visually selected text range. start and end are absolute, zero based character indexes. start corresponds to the position where the selection begins and end is the position of the first character following the selection. Note that setting start equal to end results in setting the cursor on this position.

Syntax

Visual Basic
Public Sub SetSelectionIndexes( _
   ByVal Start As Long, _
   ByVal End As Long _
)

Parameters

Start
End

See Also

GuiTextedit Object | GuiTextedit Members


SetUnprotectedTextPart Method

SetUnprotectedTextPart Method
Part
Text
GuiTextedit Object : SetUnprotectedTextPart Method

Glossary Item Box

Description

This function assigns the content of text to the unprotected text part with zero based index part. The function returns True if it was possible to perform the assignment. Otherwise, False is returned.

Syntax

Visual Basic
Public Function SetUnprotectedTextPart( _
   ByVal Part As Long, _
   ByVal Text As String _
) As Byte

Parameters

Part
Text

See Also

GuiTextedit Object | GuiTextedit Members


ShowContextMenu Method

ShowContextMenu Method
GuiTextedit Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiTextedit Object | GuiTextedit Members


SingleFileDropped Method

SingleFileDropped Method
Filename
GuiTextedit Object : SingleFileDropped Method

Glossary Item Box

Description

This function emulates the drop of a single file with the directory path fileName.

Syntax

Visual Basic
Public Sub SingleFileDropped( _
   ByVal Filename As String _
)

Parameters

Filename

See Also

GuiTextedit Object | GuiTextedit Members


Visualize Method

Visualize Method
On
InnerObject
GuiTextedit Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiTextedit Object | GuiTextedit Members


AccDescription Property

AccDescription Property
GuiTextedit Object : AccDescription Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccDescription As String

See Also

GuiTextedit Object | GuiTextedit Members


AccLabelCollection Property

AccLabelCollection Property
GuiTextedit Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiTextedit Object | GuiTextedit Members


AccText Property

AccText Property
GuiTextedit Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiTextedit Object | GuiTextedit Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiTextedit Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiTextedit Object | GuiTextedit Members


AccTooltip Property

AccTooltip Property
GuiTextedit Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiTextedit Object | GuiTextedit Members


Changeable Property

Changeable Property
GuiTextedit Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiTextedit Object | GuiTextedit Members


Children Property

Children Property
GuiTextedit Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiTextedit Object | GuiTextedit Members


ContainerType Property

ContainerType Property
GuiTextedit Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiTextedit Object | GuiTextedit Members


CurrentColumn Property

CurrentColumn Property
GuiTextedit Object : CurrentColumn Property

Glossary Item Box

Description

The number of the column in which the text caret is currently positioned.

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentColumn As Long

See Also

GuiTextedit Object | GuiTextedit Members


CurrentContextMenu Property

CurrentContextMenu Property
GuiTextedit Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

GuiTextedit Object | GuiTextedit Members


CurrentLine Property

CurrentLine Property
GuiTextedit Object : CurrentLine Property

Glossary Item Box

Description

The number of the line in which the text caret is currently positioned.

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentLine As Long

See Also

GuiTextedit Object | GuiTextedit Members


DefaultTooltip Property

DefaultTooltip Property
GuiTextedit Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiTextedit Object | GuiTextedit Members


DragDropSupported Property

DragDropSupported Property
GuiTextedit Object : DragDropSupported Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DragDropSupported As Byte

See Also

GuiTextedit Object | GuiTextedit Members


FirstVisibleLine Property

FirstVisibleLine Property
GuiTextedit Object : FirstVisibleLine Property

Glossary Item Box

Description

The first visible line is visualized at the top border of the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property FirstVisibleLine As Long

See Also

GuiTextedit Object | GuiTextedit Members


Handle Property

Handle Property
GuiTextedit Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiTextedit Object | GuiTextedit Members


Height Property

Height Property
GuiTextedit Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiTextedit Object | GuiTextedit Members


IconName Property

IconName Property
GuiTextedit Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiTextedit Object | GuiTextedit Members


Id Property

Id Property
GuiTextedit Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiTextedit Object | GuiTextedit Members


IsSymbolFont Property

IsSymbolFont Property
GuiTextedit Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiTextedit Object | GuiTextedit Members


LastVisibleLine Property

LastVisibleLine Property
GuiTextedit Object : LastVisibleLine Property

Glossary Item Box

Description

The number of the last line that is currently visible.

Property type

Read-only property

Syntax

Visual Basic
Public Property LastVisibleLine As Long

See Also

GuiTextedit Object | GuiTextedit Members


Left Property

Left Property
GuiTextedit Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiTextedit Object | GuiTextedit Members


LineCount Property

LineCount Property
GuiTextedit Object : LineCount Property

Glossary Item Box

Description

The number of all lines in the current document.

Property type

Read-only property

Syntax

Visual Basic
Public Property LineCount As Long

See Also

GuiTextedit Object | GuiTextedit Members


Modified Property

Modified Property
GuiTextedit Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiTextedit Object | GuiTextedit Members


Name Property

Name Property
GuiTextedit Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiTextedit Object | GuiTextedit Members


NumberOfUnprotectedTextParts Property

NumberOfUnprotectedTextParts Property
GuiTextedit Object : NumberOfUnprotectedTextParts Property

Glossary Item Box

Description

The number of unprotected text parts which are contained.

Property type

Read-only property

Syntax

Visual Basic
Public Property NumberOfUnprotectedTextParts As Long

See Also

GuiTextedit Object | GuiTextedit Members


OcxEvents Property

OcxEvents Property
GuiTextedit Object : OcxEvents Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property OcxEvents As GuiCollection

See Also

GuiTextedit Object | GuiTextedit Members


Parent Property

Parent Property
GuiTextedit Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiTextedit Object | GuiTextedit Members


ParentFrame Property

ParentFrame Property
GuiTextedit Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiTextedit Object | GuiTextedit Members


ScreenLeft Property

ScreenLeft Property
GuiTextedit Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiTextedit Object | GuiTextedit Members


ScreenTop Property

ScreenTop Property
GuiTextedit Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiTextedit Object | GuiTextedit Members


SelectedText Property

SelectedText Property
GuiTextedit Object : SelectedText Property

Glossary Item Box

Description

The currently selected text.

Property type

Read-only property

Syntax

Visual Basic
Public Property SelectedText As String

See Also

GuiTextedit Object | GuiTextedit Members


SelectionEndColumn Property

SelectionEndColumn Property
GuiTextedit Object : SelectionEndColumn Property

Glossary Item Box

Description

The number of the column in which the current selection ends.

Property type

Read-only property

Syntax

Visual Basic
Public Property SelectionEndColumn As Long

See Also

GuiTextedit Object | GuiTextedit Members


SelectionEndLine Property

SelectionEndLine Property
GuiTextedit Object : SelectionEndLine Property

Glossary Item Box

Description

The number of the line in which the current selection ends.

Property type

Read-only property

Syntax

Visual Basic
Public Property SelectionEndLine As Long

See Also

GuiTextedit Object | GuiTextedit Members


SelectionIndexEnd Property

SelectionIndexEnd Property
GuiTextedit Object : SelectionIndexEnd Property

Glossary Item Box

Description

Retrieves the absolute, zero based character index of the ending point from the visually selected text range, i.e. the position where the selection ends. Note that a selection can be degenerated, i.e. selectionIndexStart is equal to selectionIndexEnd.

Property type

Read-only property

Syntax

Visual Basic
Public Property SelectionIndexEnd As Long

See Also

GuiTextedit Object | GuiTextedit Members


SelectionIndexStart Property

SelectionIndexStart Property
GuiTextedit Object : SelectionIndexStart Property

Glossary Item Box

Description

Retrieves the absolute, zero based character index of the starting point from the visually selected text range, i.e. the position, where the selection begins. Note that a selection can be degenerated, i.e. selectionIndexStart is equal to selectionIndexEnd.

Property type

Read-only property

Syntax

Visual Basic
Public Property SelectionIndexStart As Long

See Also

GuiTextedit Object | GuiTextedit Members


SelectionStartColumn Property

SelectionStartColumn Property
GuiTextedit Object : SelectionStartColumn Property

Glossary Item Box

Description

The number of the column in which the current selection starts.

Property type

Read-only property

Syntax

Visual Basic
Public Property SelectionStartColumn As Long

See Also

GuiTextedit Object | GuiTextedit Members


SelectionStartLine Property

SelectionStartLine Property
GuiTextedit Object : SelectionStartLine Property

Glossary Item Box

Description

The number of the line in which the current selection starts.

Property type

Read-only property

Syntax

Visual Basic
Public Property SelectionStartLine As Long

See Also

GuiTextedit Object | GuiTextedit Members


SubType Property

SubType Property
GuiTextedit Object : SubType Property

Glossary Item Box

Description

This property has the constant value “TextEdit”.

Property type

Read-only property

Syntax

Visual Basic
Public Property SubType As String

See Also

GuiTextedit Object | GuiTextedit Members


Text Property

Text Property
GuiTextedit Object : Text Property

Glossary Item Box

Description

The value of this property represents the text contained in the control. Note that setting the text is denied if the control is in read only mode or a certain text part is protected.

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiTextedit Object | GuiTextedit Members


Tooltip Property

Tooltip Property
GuiTextedit Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiTextedit Object | GuiTextedit Members


Top Property

Top Property
GuiTextedit Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiTextedit Object | GuiTextedit Members


Type Property

Type Property
GuiTextedit Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiTextedit Object | GuiTextedit Members


TypeAsNumber Property

TypeAsNumber Property
GuiTextedit Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiTextedit Object | GuiTextedit Members


Width Property

Width Property
GuiTextedit Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiTextedit Object | GuiTextedit Members


GuiTextField Object

GuiTextField Object
See Also Members

Glossary Item Box

Description

GuiTextField extends GuiVComponent. The type prefix is txt, the name is the fieldname taken from the SAP data dictionary.

Object Model

GuiTextField ObjectGuiComponentCollection CollectionGuiCollection CollectionGuiCollection CollectionGuiVComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiVComponent Object

See Also

GuiTextField Members


GuiTextField Object Members

GuiTextField Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method GetListProperty
Public Method GetListPropertyNonRec
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property CaretPosition | The position of the caret within a text field may be checked by the ABAP application to determine which word the caret is in. Among other things this is useful for context sensitive help.
Public Property Changeable |
Public Property CharHeight |
Public Property CharLeft |
Public Property CharTop |
Public Property CharWidth |
Public Property ContainerType |
Public Property DefaultTooltip |
Public Property DisplayedText |
Public Property Height |
Public Property Highlighted | See GuiLabel for an example.
Public Property HistoryCurEntry |
Public Property HistoryCurIndex |
Public Property HistoryIsActive |
Public Property HistoryList |
Public Property IconName |
Public Property Id |
Public Property IsHotspot |
Public Property IsLeftLabel |
Public Property IsListElement |
Public Property IsOField |
Public Property IsRightLabel |
Public Property IsSymbolFont |
Public Property Left |
Public Property LeftLabel | This label has been defined in ABAP Screen Painter to be the left label of the control.
Public Property MaxLength | The maximum length of text that can be written in a text field is counted in code units. On non-Unicode clients these are equivalent to bytes.
Public Property Modified |
Public Property Name |
Public Property Numerical | If this flag is set only numbers and special characters may be written into the text field.
Public Property Parent |
Public Property ParentFrame |
Public Property Required |
Public Property RightLabel | This label has been defined in ABAP Screen Painter to be the right label of the control.
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property Text |
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property Width |

See Also

GuiTextField Object


DumpState Method

DumpState Method
InnerObject
GuiTextField Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiTextField Object | GuiTextField Members


GetListProperty Method

GetListProperty Method
Property
GuiTextField Object : GetListProperty Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetListProperty( _
   ByVal Property As String _
) As String

Parameters

Property

See Also

GuiTextField Object | GuiTextField Members


GetListPropertyNonRec Method

GetListPropertyNonRec Method
Property
GuiTextField Object : GetListPropertyNonRec Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetListPropertyNonRec( _
   ByVal Property As String _
) As String

Parameters

Property

See Also

GuiTextField Object | GuiTextField Members


SetFocus Method

SetFocus Method
GuiTextField Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiTextField Object | GuiTextField Members


ShowContextMenu Method

ShowContextMenu Method
GuiTextField Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiTextField Object | GuiTextField Members


Visualize Method

Visualize Method
On
InnerObject
GuiTextField Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiTextField Object | GuiTextField Members


AccLabelCollection Property

AccLabelCollection Property
GuiTextField Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiTextField Object | GuiTextField Members


AccText Property

AccText Property
GuiTextField Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiTextField Object | GuiTextField Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiTextField Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiTextField Object | GuiTextField Members


AccTooltip Property

AccTooltip Property
GuiTextField Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiTextField Object | GuiTextField Members


CaretPosition Property

CaretPosition Property
GuiTextField Object : CaretPosition Property

Glossary Item Box

Description

The position of the caret within a text field may be checked by the ABAP application to determine which word the caret is in. Among other things this is useful for context sensitive help.

Property type

Read-write property

Syntax

Visual Basic
Public Property CaretPosition As Long

See Also

GuiTextField Object | GuiTextField Members


Changeable Property

Changeable Property
GuiTextField Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiTextField Object | GuiTextField Members


CharHeight Property

CharHeight Property
GuiTextField Object : CharHeight Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharHeight As Long

See Also

GuiTextField Object | GuiTextField Members


CharLeft Property

CharLeft Property
GuiTextField Object : CharLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharLeft As Long

See Also

GuiTextField Object | GuiTextField Members


CharTop Property

CharTop Property
GuiTextField Object : CharTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharTop As Long

See Also

GuiTextField Object | GuiTextField Members


CharWidth Property

CharWidth Property
GuiTextField Object : CharWidth Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CharWidth As Long

See Also

GuiTextField Object | GuiTextField Members


ContainerType Property

ContainerType Property
GuiTextField Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiTextField Object | GuiTextField Members


DefaultTooltip Property

DefaultTooltip Property
GuiTextField Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiTextField Object | GuiTextField Members


DisplayedText Property

DisplayedText Property
GuiTextField Object : DisplayedText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DisplayedText As String

See Also

GuiTextField Object | GuiTextField Members


Height Property

Height Property
GuiTextField Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiTextField Object | GuiTextField Members


Highlighted Property

Highlighted Property
GuiTextField Object : Highlighted Property

Glossary Item Box

Description

See GuiLabel for an example.

Property type

Read-only property

Syntax

Visual Basic
Public Property Highlighted As Byte

See Also

GuiTextField Object | GuiTextField Members


HistoryCurEntry Property

HistoryCurEntry Property
GuiTextField Object : HistoryCurEntry Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property HistoryCurEntry As String

See Also

GuiTextField Object | GuiTextField Members


HistoryCurIndex Property

HistoryCurIndex Property
GuiTextField Object : HistoryCurIndex Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property HistoryCurIndex As Long

See Also

GuiTextField Object | GuiTextField Members


HistoryIsActive Property

HistoryIsActive Property
GuiTextField Object : HistoryIsActive Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property HistoryIsActive As Byte

See Also

GuiTextField Object | GuiTextField Members


HistoryList Property

HistoryList Property
GuiTextField Object : HistoryList Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property HistoryList As GuiCollection

See Also

GuiTextField Object | GuiTextField Members


IconName Property

IconName Property
GuiTextField Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiTextField Object | GuiTextField Members


Id Property

Id Property
GuiTextField Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiTextField Object | GuiTextField Members


IsHotspot Property

IsHotspot Property
GuiTextField Object : IsHotspot Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsHotspot As Byte

See Also

GuiTextField Object | GuiTextField Members


IsLeftLabel Property

IsLeftLabel Property
GuiTextField Object : IsLeftLabel Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsLeftLabel As Byte

See Also

GuiTextField Object | GuiTextField Members


IsListElement Property

IsListElement Property
GuiTextField Object : IsListElement Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsListElement As Byte

See Also

GuiTextField Object | GuiTextField Members


IsOField Property

IsOField Property
GuiTextField Object : IsOField Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsOField As Byte

See Also

GuiTextField Object | GuiTextField Members


IsRightLabel Property

IsRightLabel Property
GuiTextField Object : IsRightLabel Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsRightLabel As Byte

See Also

GuiTextField Object | GuiTextField Members


IsSymbolFont Property

IsSymbolFont Property
GuiTextField Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiTextField Object | GuiTextField Members


Left Property

Left Property
GuiTextField Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiTextField Object | GuiTextField Members


LeftLabel Property

LeftLabel Property
GuiTextField Object : LeftLabel Property

Glossary Item Box

Description

This label has been defined in ABAP Screen Painter to be the left label of the control.

Property type

Read-only property

Syntax

Visual Basic
Public Property LeftLabel As GuiVComponent

See Also

GuiTextField Object | GuiTextField Members


MaxLength Property

MaxLength Property
GuiTextField Object : MaxLength Property

Glossary Item Box

Description

The maximum length of text that can be written in a text field is counted in code units. On non-Unicode clients these are equivalent to bytes.

Property type

Read-only property

Syntax

Visual Basic
Public Property MaxLength As Long

See Also

GuiTextField Object | GuiTextField Members


Modified Property

Modified Property
GuiTextField Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiTextField Object | GuiTextField Members


Name Property

Name Property
GuiTextField Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiTextField Object | GuiTextField Members


Numerical Property

Numerical Property
GuiTextField Object : Numerical Property

Glossary Item Box

Description

If this flag is set only numbers and special characters may be written into the text field.

Property type

Read-only property

Syntax

Visual Basic
Public Property Numerical As Byte

See Also

GuiTextField Object | GuiTextField Members


Parent Property

Parent Property
GuiTextField Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiTextField Object | GuiTextField Members


ParentFrame Property

ParentFrame Property
GuiTextField Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiTextField Object | GuiTextField Members


Required Property

Required Property
GuiTextField Object : Required Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Required As Byte

Example

The following example shows the required text field for the user name, in both New Visual Design and in classic mode.

See Also

GuiTextField Object | GuiTextField Members


RightLabel Property

RightLabel Property
GuiTextField Object : RightLabel Property

Glossary Item Box

Description

This label has been defined in ABAP Screen Painter to be the right label of the control.

Property type

Read-only property

Syntax

Visual Basic
Public Property RightLabel As GuiVComponent

See Also

GuiTextField Object | GuiTextField Members


ScreenLeft Property

ScreenLeft Property
GuiTextField Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiTextField Object | GuiTextField Members


ScreenTop Property

ScreenTop Property
GuiTextField Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiTextField Object | GuiTextField Members


Text Property

Text Property
GuiTextField Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiTextField Object | GuiTextField Members


Tooltip Property

Tooltip Property
GuiTextField Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiTextField Object | GuiTextField Members


Top Property

Top Property
GuiTextField Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiTextField Object | GuiTextField Members


Type Property

Type Property
GuiTextField Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiTextField Object | GuiTextField Members


TypeAsNumber Property

TypeAsNumber Property
GuiTextField Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiTextField Object | GuiTextField Members


Width Property

Width Property
GuiTextField Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiTextField Object | GuiTextField Members


GuiTitlebar Object

GuiTitlebar Object
See Also Members

Glossary Item Box

Description

The titlebar is only displayed and exposed as a separate object in New Visual Design mode. GuiTitlebar extends GuiVContainer. The type prefix and name of GuiTitlebar are titl.

Object Model

GuiTitlebar ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent Object

Remarks

In some transactions the titlebar may contain objects of GuiGosShell type.

See Also

GuiTitlebar Members


GuiTitlebar Object Members

GuiTitlebar Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property Children
Public Property ContainerType
Public Property DefaultTooltip
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiTitlebar Object


DumpState Method

DumpState Method
InnerObject
GuiTitlebar Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiTitlebar Object | GuiTitlebar Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiTitlebar Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiTitlebar Object | GuiTitlebar Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiTitlebar Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiTitlebar Object | GuiTitlebar Members


FindById Method

FindById Method
Id
Raise
GuiTitlebar Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiTitlebar Object | GuiTitlebar Members


FindByName Method

FindByName Method
Name
Type
GuiTitlebar Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiTitlebar Object | GuiTitlebar Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiTitlebar Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiTitlebar Object | GuiTitlebar Members


SetFocus Method

SetFocus Method
GuiTitlebar Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiTitlebar Object | GuiTitlebar Members


ShowContextMenu Method

ShowContextMenu Method
GuiTitlebar Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiTitlebar Object | GuiTitlebar Members


Visualize Method

Visualize Method
On
InnerObject
GuiTitlebar Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiTitlebar Object | GuiTitlebar Members


AccLabelCollection Property

AccLabelCollection Property
GuiTitlebar Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiTitlebar Object | GuiTitlebar Members


AccText Property

AccText Property
GuiTitlebar Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiTitlebar Object | GuiTitlebar Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiTitlebar Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiTitlebar Object | GuiTitlebar Members


AccTooltip Property

AccTooltip Property
GuiTitlebar Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiTitlebar Object | GuiTitlebar Members


Changeable Property

Changeable Property
GuiTitlebar Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiTitlebar Object | GuiTitlebar Members


Children Property

Children Property
GuiTitlebar Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiTitlebar Object | GuiTitlebar Members


ContainerType Property

ContainerType Property
GuiTitlebar Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiTitlebar Object | GuiTitlebar Members


DefaultTooltip Property

DefaultTooltip Property
GuiTitlebar Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiTitlebar Object | GuiTitlebar Members


Height Property

Height Property
GuiTitlebar Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiTitlebar Object | GuiTitlebar Members


IconName Property

IconName Property
GuiTitlebar Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiTitlebar Object | GuiTitlebar Members


Id Property

Id Property
GuiTitlebar Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiTitlebar Object | GuiTitlebar Members


IsSymbolFont Property

IsSymbolFont Property
GuiTitlebar Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiTitlebar Object | GuiTitlebar Members


Left Property

Left Property
GuiTitlebar Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiTitlebar Object | GuiTitlebar Members


Modified Property

Modified Property
GuiTitlebar Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiTitlebar Object | GuiTitlebar Members


Name Property

Name Property
GuiTitlebar Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiTitlebar Object | GuiTitlebar Members


Parent Property

Parent Property
GuiTitlebar Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiTitlebar Object | GuiTitlebar Members


ParentFrame Property

ParentFrame Property
GuiTitlebar Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiTitlebar Object | GuiTitlebar Members


ScreenLeft Property

ScreenLeft Property
GuiTitlebar Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiTitlebar Object | GuiTitlebar Members


ScreenTop Property

ScreenTop Property
GuiTitlebar Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiTitlebar Object | GuiTitlebar Members


Text Property

Text Property
GuiTitlebar Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiTitlebar Object | GuiTitlebar Members


Tooltip Property

Tooltip Property
GuiTitlebar Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiTitlebar Object | GuiTitlebar Members


Top Property

Top Property
GuiTitlebar Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiTitlebar Object | GuiTitlebar Members


Type Property

Type Property
GuiTitlebar Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiTitlebar Object | GuiTitlebar Members


TypeAsNumber Property

TypeAsNumber Property
GuiTitlebar Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiTitlebar Object | GuiTitlebar Members


Width Property

Width Property
GuiTitlebar Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiTitlebar Object | GuiTitlebar Members


GuiToolbar Object

GuiToolbar Object
See Also Members

Glossary Item Box

Description

Every GuiFrameWindow has a GuiToolbar. The GuiMainWindow has two toolbars unless the second has been turned off by the ABAP application. The upper toolbar is the system toolbar, while the second toolbar is the application toolbar.

The children of a GuiToolbar are buttons. The indexes for toolbar buttons are determined by the virtual key values defined for the button.

GuiToolbar extends GuiVContainer. The type prefix and name are tbar.

Object Model

GuiToolbar ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent Object

See Also

GuiToolbar Members


GuiToolbar Object Members

GuiToolbar Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property Children
Public Property ContainerType
Public Property DefaultTooltip
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiToolbar Object


DumpState Method

DumpState Method
InnerObject
GuiToolbar Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiToolbar Object | GuiToolbar Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiToolbar Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiToolbar Object | GuiToolbar Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiToolbar Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiToolbar Object | GuiToolbar Members


FindById Method

FindById Method
Id
Raise
GuiToolbar Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiToolbar Object | GuiToolbar Members


FindByName Method

FindByName Method
Name
Type
GuiToolbar Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiToolbar Object | GuiToolbar Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiToolbar Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiToolbar Object | GuiToolbar Members


SetFocus Method

SetFocus Method
GuiToolbar Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiToolbar Object | GuiToolbar Members


ShowContextMenu Method

ShowContextMenu Method
GuiToolbar Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiToolbar Object | GuiToolbar Members


Visualize Method

Visualize Method
On
InnerObject
GuiToolbar Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiToolbar Object | GuiToolbar Members


AccLabelCollection Property

AccLabelCollection Property
GuiToolbar Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiToolbar Object | GuiToolbar Members


AccText Property

AccText Property
GuiToolbar Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiToolbar Object | GuiToolbar Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiToolbar Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiToolbar Object | GuiToolbar Members


AccTooltip Property

AccTooltip Property
GuiToolbar Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiToolbar Object | GuiToolbar Members


Changeable Property

Changeable Property
GuiToolbar Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiToolbar Object | GuiToolbar Members


Children Property

Children Property
GuiToolbar Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiToolbar Object | GuiToolbar Members


ContainerType Property

ContainerType Property
GuiToolbar Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiToolbar Object | GuiToolbar Members


DefaultTooltip Property

DefaultTooltip Property
GuiToolbar Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiToolbar Object | GuiToolbar Members


Height Property

Height Property
GuiToolbar Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiToolbar Object | GuiToolbar Members


IconName Property

IconName Property
GuiToolbar Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiToolbar Object | GuiToolbar Members


Id Property

Id Property
GuiToolbar Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiToolbar Object | GuiToolbar Members


IsSymbolFont Property

IsSymbolFont Property
GuiToolbar Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiToolbar Object | GuiToolbar Members


Left Property

Left Property
GuiToolbar Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiToolbar Object | GuiToolbar Members


Modified Property

Modified Property
GuiToolbar Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiToolbar Object | GuiToolbar Members


Name Property

Name Property
GuiToolbar Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiToolbar Object | GuiToolbar Members


Parent Property

Parent Property
GuiToolbar Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiToolbar Object | GuiToolbar Members


ParentFrame Property

ParentFrame Property
GuiToolbar Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiToolbar Object | GuiToolbar Members


ScreenLeft Property

ScreenLeft Property
GuiToolbar Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiToolbar Object | GuiToolbar Members


ScreenTop Property

ScreenTop Property
GuiToolbar Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiToolbar Object | GuiToolbar Members


Text Property

Text Property
GuiToolbar Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiToolbar Object | GuiToolbar Members


Tooltip Property

Tooltip Property
GuiToolbar Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiToolbar Object | GuiToolbar Members


Top Property

Top Property
GuiToolbar Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiToolbar Object | GuiToolbar Members


Type Property

Type Property
GuiToolbar Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiToolbar Object | GuiToolbar Members


TypeAsNumber Property

TypeAsNumber Property
GuiToolbar Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiToolbar Object | GuiToolbar Members


Width Property

Width Property
GuiToolbar Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiToolbar Object | GuiToolbar Members


GuiToolbarControl Object

GuiToolbarControl Object
See Also Members

Glossary Item Box

Description

GuiToolbarControl extends GuiShell.

Object Model

GuiToolbarControl ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiComponent ObjectGuiComponent Object

See Also

GuiToolbarControl Members


GuiToolbarControl Object Members

GuiToolbarControl Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState |
Public Method FindAllByName |
Public Method FindAllByNameEx |
Public Method FindById |
Public Method FindByName |
Public Method FindByNameEx |
Public Method GetButtonChecked | Returns if the button is currently checked (pressed).
Public Method GetButtonEnabled | Indicates if the button can be pressed.
Public Method GetButtonIcon | Returns the name of the icon of the specified toolbar button.
Public Method GetButtonId | Returns the ID of the specified toolbar button.
Public Method GetButtonText | Returns the text of the specified toolbar button.
Public Method GetButtonTooltip | Returns the tooltip of the specified toolbar button.
Public Method GetButtonType | Returns the type of the specified toolbar button. Possible values are: "Button", "ButtonAndMenu", "Menu", "Separator", "Group", "CheckBox"
Public Method GetMenuItemIdFromPosition | This function returns the identifier of the menu item with index Position.
Public Method PressButton | This function emulates pressing the button with the given id.
Public Method PressContextButton | This function emulates pressing the context button with the given id.
Public Method SelectContextMenuItem |
Public Method SelectContextMenuItemByPosition |
Public Method SelectContextMenuItemByText |
Public Method SelectMenuItem | This function emulates selecting the menu item with the given id.
Public Method SelectMenuItemByText | This function emulates selecting the menu item by menu item text.
Public Method SetFocus |
Public Method ShowContextMenu |
Public Method Visualize |

Public Properties

Public Property AccDescription |
Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property ButtonCount | The number of toolbar buttons including separators.
Public Property Changeable |
Public Property Children |
Public Property ContainerType |
Public Property CurrentContextMenu |
Public Property DefaultTooltip |
Public Property DragDropSupported |
Public Property FocusedButton | Zero-based index of the button that currently has the focus.
Public Property Handle |
Public Property Height |
Public Property IconName |
Public Property Id |
Public Property IsSymbolFont |
Public Property Left |
Public Property Modified |
Public Property Name |
Public Property OcxEvents |
Public Property Parent |
Public Property ParentFrame |
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property SubType | This property has the constant value “Toolbar”.
Public Property Text |
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property Width |

See Also

GuiToolbarControl Object


DumpState Method

DumpState Method
InnerObject
GuiToolbarControl Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiToolbarControl Object | GuiToolbarControl Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiToolbarControl Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiToolbarControl Object | GuiToolbarControl Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiToolbarControl Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiToolbarControl Object | GuiToolbarControl Members


FindById Method

FindById Method
Id
Raise
GuiToolbarControl Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiToolbarControl Object | GuiToolbarControl Members


FindByName Method

FindByName Method
Name
Type
GuiToolbarControl Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiToolbarControl Object | GuiToolbarControl Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiToolbarControl Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiToolbarControl Object | GuiToolbarControl Members


GetButtonChecked Method

GetButtonChecked Method
ButtonPos
GuiToolbarControl Object : GetButtonChecked Method

Glossary Item Box

Description

Returns if the button is currently checked (pressed).

Syntax

Visual Basic
Public Function GetButtonChecked( _
   ByVal ButtonPos As Long _
) As Byte

Parameters

ButtonPos

See Also

GuiToolbarControl Object | GuiToolbarControl Members


GetButtonEnabled Method

GetButtonEnabled Method
ButtonPos
GuiToolbarControl Object : GetButtonEnabled Method

Glossary Item Box

Description

Indicates if the button can be pressed.

Syntax

Visual Basic
Public Function GetButtonEnabled( _
   ByVal ButtonPos As Long _
) As Byte

Parameters

ButtonPos

See Also

GuiToolbarControl Object | GuiToolbarControl Members


GetButtonIcon Method

GetButtonIcon Method
ButtonPos
GuiToolbarControl Object : GetButtonIcon Method

Glossary Item Box

Description

Returns the name of the icon of the specified toolbar button.

Syntax

Visual Basic
Public Function GetButtonIcon( _
   ByVal ButtonPos As Long _
) As String

Parameters

ButtonPos

See Also

GuiToolbarControl Object | GuiToolbarControl Members


GetButtonId Method

GetButtonId Method
ButtonPos
GuiToolbarControl Object : GetButtonId Method

Glossary Item Box

Description

Returns the ID of the specified toolbar button.

Syntax

Visual Basic
Public Function GetButtonId( _
   ByVal ButtonPos As Long _
) As String

Parameters

ButtonPos

See Also

GuiToolbarControl Object | GuiToolbarControl Members


GetButtonText Method

GetButtonText Method
ButtonPos
GuiToolbarControl Object : GetButtonText Method

Glossary Item Box

Description

Returns the text of the specified toolbar button.

Syntax

Visual Basic
Public Function GetButtonText( _
   ByVal ButtonPos As Long _
) As String

Parameters

ButtonPos

See Also

GuiToolbarControl Object | GuiToolbarControl Members


GetButtonTooltip Method

GetButtonTooltip Method
ButtonPos
GuiToolbarControl Object : GetButtonTooltip Method

Glossary Item Box

Description

Returns the tooltip of the specified toolbar button.

Syntax

Visual Basic
Public Function GetButtonTooltip( _
   ByVal ButtonPos As Long _
) As String

Parameters

ButtonPos

See Also

GuiToolbarControl Object | GuiToolbarControl Members


GetButtonType Method

GetButtonType Method
ButtonPos
GuiToolbarControl Object : GetButtonType Method

Glossary Item Box

Description

Returns the type of the specified toolbar button. Possible values are:
"Button", "ButtonAndMenu", "Menu", "Separator", "Group", "CheckBox"

Syntax

Visual Basic
Public Function GetButtonType( _
   ByVal ButtonPos As Long _
) As String

Parameters

ButtonPos

See Also

GuiToolbarControl Object | GuiToolbarControl Members


GetMenuItemIdFromPosition Method

GetMenuItemIdFromPosition Method
Pos
GuiToolbarControl Object : GetMenuItemIdFromPosition Method

Glossary Item Box

Description

This function returns the identifier of the menu item with index Position.

Syntax

Visual Basic
Public Function GetMenuItemIdFromPosition( _
   ByVal Pos As Long _
) As String

Parameters

Pos

See Also

GuiToolbarControl Object | GuiToolbarControl Members


PressButton Method

PressButton Method
Id
GuiToolbarControl Object : PressButton Method

Glossary Item Box

Description

This function emulates pressing the button with the given id.

Syntax

Visual Basic
Public Sub PressButton( _
   ByVal Id As String _
)

Parameters

Id

See Also

GuiToolbarControl Object | GuiToolbarControl Members


PressContextButton Method

PressContextButton Method
Id
GuiToolbarControl Object : PressContextButton Method

Glossary Item Box

Description

This function emulates pressing the context button with the given id.

Syntax

Visual Basic
Public Sub PressContextButton( _
   ByVal Id As String _
)

Parameters

Id

See Also

GuiToolbarControl Object | GuiToolbarControl Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiToolbarControl Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiToolbarControl Object | GuiToolbarControl Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiToolbarControl Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiToolbarControl Object | GuiToolbarControl Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiToolbarControl Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

GuiToolbarControl Object | GuiToolbarControl Members


SelectMenuItem Method

SelectMenuItem Method
Id
GuiToolbarControl Object : SelectMenuItem Method

Glossary Item Box

Description

This function emulates selecting the menu item with the given id.

Syntax

Visual Basic
Public Sub SelectMenuItem( _
   ByVal Id As String _
)

Parameters

Id

See Also

GuiToolbarControl Object | GuiToolbarControl Members


SelectMenuItemByText Method

SelectMenuItemByText Method
strText
GuiToolbarControl Object : SelectMenuItemByText Method

Glossary Item Box

Description

This function emulates selecting the menu item by menu item text.

Syntax

Visual Basic
Public Sub SelectMenuItemByText( _
   ByVal strText As String _
)

Parameters

strText

See Also

GuiToolbarControl Object | GuiToolbarControl Members


SetFocus Method

SetFocus Method
GuiToolbarControl Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiToolbarControl Object | GuiToolbarControl Members


ShowContextMenu Method

ShowContextMenu Method
GuiToolbarControl Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiToolbarControl Object | GuiToolbarControl Members


Visualize Method

Visualize Method
On
InnerObject
GuiToolbarControl Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiToolbarControl Object | GuiToolbarControl Members


AccDescription Property

AccDescription Property
GuiToolbarControl Object : AccDescription Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccDescription As String

See Also

GuiToolbarControl Object | GuiToolbarControl Members


AccLabelCollection Property

AccLabelCollection Property
GuiToolbarControl Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiToolbarControl Object | GuiToolbarControl Members


AccText Property

AccText Property
GuiToolbarControl Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiToolbarControl Object | GuiToolbarControl Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiToolbarControl Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiToolbarControl Object | GuiToolbarControl Members


AccTooltip Property

AccTooltip Property
GuiToolbarControl Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiToolbarControl Object | GuiToolbarControl Members


ButtonCount Property

ButtonCount Property
GuiToolbarControl Object : ButtonCount Property

Glossary Item Box

Description

The number of toolbar buttons including separators.

Property type

Read-only property

Syntax

Visual Basic
Public Property ButtonCount As Long

See Also

GuiToolbarControl Object | GuiToolbarControl Members


Changeable Property

Changeable Property
GuiToolbarControl Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiToolbarControl Object | GuiToolbarControl Members


Children Property

Children Property
GuiToolbarControl Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiToolbarControl Object | GuiToolbarControl Members


ContainerType Property

ContainerType Property
GuiToolbarControl Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiToolbarControl Object | GuiToolbarControl Members


CurrentContextMenu Property

CurrentContextMenu Property
GuiToolbarControl Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

GuiToolbarControl Object | GuiToolbarControl Members


DefaultTooltip Property

DefaultTooltip Property
GuiToolbarControl Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiToolbarControl Object | GuiToolbarControl Members


DragDropSupported Property

DragDropSupported Property
GuiToolbarControl Object : DragDropSupported Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DragDropSupported As Byte

See Also

GuiToolbarControl Object | GuiToolbarControl Members


FocusedButton Property

FocusedButton Property
GuiToolbarControl Object : FocusedButton Property

Glossary Item Box

Description

Zero-based index of the button that currently has the focus.

Property type

Read-only property

Syntax

Visual Basic
Public Property FocusedButton As Long

See Also

GuiToolbarControl Object | GuiToolbarControl Members


Handle Property

Handle Property
GuiToolbarControl Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiToolbarControl Object | GuiToolbarControl Members


Height Property

Height Property
GuiToolbarControl Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiToolbarControl Object | GuiToolbarControl Members


IconName Property

IconName Property
GuiToolbarControl Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiToolbarControl Object | GuiToolbarControl Members


Id Property

Id Property
GuiToolbarControl Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiToolbarControl Object | GuiToolbarControl Members


IsSymbolFont Property

IsSymbolFont Property
GuiToolbarControl Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiToolbarControl Object | GuiToolbarControl Members


Left Property

Left Property
GuiToolbarControl Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiToolbarControl Object | GuiToolbarControl Members


Modified Property

Modified Property
GuiToolbarControl Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiToolbarControl Object | GuiToolbarControl Members


Name Property

Name Property
GuiToolbarControl Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiToolbarControl Object | GuiToolbarControl Members


OcxEvents Property

OcxEvents Property
GuiToolbarControl Object : OcxEvents Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property OcxEvents As GuiCollection

See Also

GuiToolbarControl Object | GuiToolbarControl Members


Parent Property

Parent Property
GuiToolbarControl Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiToolbarControl Object | GuiToolbarControl Members


ParentFrame Property

ParentFrame Property
GuiToolbarControl Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiToolbarControl Object | GuiToolbarControl Members


ScreenLeft Property

ScreenLeft Property
GuiToolbarControl Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiToolbarControl Object | GuiToolbarControl Members


ScreenTop Property

ScreenTop Property
GuiToolbarControl Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiToolbarControl Object | GuiToolbarControl Members


SubType Property

SubType Property
GuiToolbarControl Object : SubType Property

Glossary Item Box

Description

This property has the constant value “Toolbar”.

Property type

Read-only property

Syntax

Visual Basic
Public Property SubType As String

See Also

GuiToolbarControl Object | GuiToolbarControl Members


Text Property

Text Property
GuiToolbarControl Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiToolbarControl Object | GuiToolbarControl Members


Tooltip Property

Tooltip Property
GuiToolbarControl Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiToolbarControl Object | GuiToolbarControl Members


Top Property

Top Property
GuiToolbarControl Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiToolbarControl Object | GuiToolbarControl Members


Type Property

Type Property
GuiToolbarControl Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiToolbarControl Object | GuiToolbarControl Members


TypeAsNumber Property

TypeAsNumber Property
GuiToolbarControl Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiToolbarControl Object | GuiToolbarControl Members


Width Property

Width Property
GuiToolbarControl Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiToolbarControl Object | GuiToolbarControl Members


GuiTree Object

GuiTree Object
See Also Members

Glossary Item Box

Object Model

GuiTree ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiComponent ObjectGuiComponent Object

Example

The Tree Control supports three Tree Types.

Simple Tree:

List Tree:

The List Tree can have a header:

Column Tree:

See Also

GuiTree Members


GuiTree Object Members

GuiTree Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method ChangeCheckbox | This method emulates changing a checkbox state.
Public Method ClickLink | This function emulates triggering a link.
Public Method CollapseNode | This function closes the node with the key nodeKey.
Public Method DefaultContextMenu | This method requests a context menu for the whole Tree Control.
Public Method DoubleClickItem | This function emulates double clicking on a text item.
Public Method DoubleClickNode | This function emulates double clicking a node.
Public Method DumpState
Public Method EnsureVisibleHorizontalItem | This function scrolls the Tree horizontally until the Item is visible.
Public Method ExpandNode | This function expands the node with the key nodeKey.
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method FindNodeKeyByPath
Public Method GetAbapImage
Public Method GetAllNodeKeys | method GetAllNodeKeys
Public Method GetCheckBoxState | Retrieves the CheckBox state (1 = Checked, 0 = Unchecked).
Public Method GetColumnCol | The keys of all the items in the given column.
Public Method GetColumnHeaders | Collection of the titles of the columns.
Public Method GetColumnIndexFromName
Public Method GetColumnNames | Returns a collection of the column names.
Public Method GetColumnTitleFromName
Public Method GetColumnTitles
Public Method GetFocusedNodeKey
Public Method GetHierarchyLevel
Public Method GetHierarchyTitle | method GetHierarchyTitle
Public Method GetIsDisabled | method GetIsDisabled
Public Method GetIsHighLighted
Public Method GetItemHeight | method GetItemHeight
Public Method GetItemLeft | method GetItemLeft
Public Method GetItemStyle
Public Method GetItemText | This function returns the text of the item specified by the key and name parameters.
Public Method GetItemTextColor
Public Method GetItemToolTip
Public Method GetItemTop | method GetItemTop
Public Method GetItemType

Retrieves the column tree item type:

  • trvTreeStructureHierarchy = 0
  • trvTreeStructureImage = 1
  • trvTreeStructureText = 2
  • trvTreeStructureBool = 3
  • trvTreeStructureButton = 4
  • trvTreeStructureLink = 5
Public Method GetItemWidth | method GetItemWidth
Public Method GetListTreeNodeItemCount
Public Method GetNextNodeKey
Public Method GetNodeAbapImage
Public Method GetNodeChildrenCount
Public Method GetNodeChildrenCountByPath | This function returns the number of children of the node given by the path parameter.
Public Method GetNodeHeight | method GetNodeHeight
Public Method GetNodeIndex
Public Method GetNodeItemHeaders
Public Method GetNodeKeyByPath | Key of the node specified by the given path description.
Public Method GetNodeLeft | method GetNodeLeft
Public Method GetNodePathByKey | Given a node key, the path is retrieved (e.g. 2\1\2).
Public Method GetNodesCol | The collection contains the node keys of all the nodes in the tree.
Public Method GetNodeStyle
Public Method GetNodeTextByKey | This function returns the text of the node specified by the given key.
Public Method GetNodeTextByPath | The text of a node defined by the given path is returned.
Public Method GetNodeTextColor
Public Method GetNodeToolTip
Public Method GetNodeTop | method GetNodeTop
Public Method GetNodeWidth | method GetNodeWidth
Public Method GetParent | Key of the parent node of the node specified by the given key.
Public Method GetPreviousNodeKey
Public Method GetSelectedNodes
Public Method GetSelectionMode | The selection behaviour of a Tree Control instance is set once at the time of creation.
Public Method GetStyleDescription
Public Method GetSubNodesCol | Collection of the keys of all subnodes of the node specified by the given key.
Public Method GetTreeType

The returned number has the following meaning:

  • 0 : Simple tree
  • 1 : List tree
  • 2 : Column tree
Public Method HeaderContextMenu | This method requests a context menu for a header.
Public Method IsFolder
Public Method IsFolderExpandable
Public Method IsFolderExpanded
Public Method ItemContextMenu | This method requests a context menu for an item.
Public Method NodeContextMenu | This method requests a context menu for a node.
Public Method PressButton | This method emulates pressing a button.
Public Method PressHeader | This method emulates clicking a header.
Public Method PressKey | This method emulates pressing a key.
Public Method SelectColumn | This function adds a column to the column selection. A node or item selection is removed.
Public Method SelectContextMenuItem
Public Method SelectContextMenuItemByPosition
Public Method SelectContextMenuItemByText
Public Method SelectedItemColumn
Public Method SelectedItemNode
Public Method SelectItem | This function emulates the selection of an item. This selection removes all other selections.
Public Method SelectNode | The node with the key nodeKey is added to the Node Selection.
Public Method SetCheckBoxState
Public Method SetColumnWidth | This function sets the width of a column in pixels.
Public Method SetFocus
Public Method ShowContextMenu
Public Method UnselectAll | All selections are removed.
Public Method UnselectColumn | This function removes a column from the column selection.
Public Method UnselectNode | The node with the key nodeKey is removed from the Node Selection.
Public Method Visualize

Public Properties

Public Property AccDescription |
Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property Changeable |
Public Property Children |
Public Property ColumnOrder | The property is used for working with a sequence of columns. The name of each column in the Column Tree must occur exactly once.
Public Property ContainerType |
Public Property CurrentContextMenu |
Public Property DefaultTooltip |
Public Property DragDropSupported |
Public Property Handle |
Public Property Height |
Public Property HierarchyHeaderWidth | The width of the Hierarchy Header in pixels.
Public Property IconName |
Public Property Id |
Public Property IsSymbolFont |
Public Property Left |
Public Property Modified |
Public Property Name |
Public Property OcxEvents |
Public Property Parent |
Public Property ParentFrame |
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property SelectedNode | This is the key of the currently selected node. Selecting a node removes other selections (that is Column Selection and Item Selection).
Public Property SubType | This property has the constant value “Tree”.
Public Property Text |
Public Property Tooltip |
Public Property Top |
Public Property TopNode | This property influences the vertical scrolling of the Tree Control. TopNode contains the key of the node that is located on the upper edge of the Tree Control. Setting a node x as top node is only possible if there are enough visible nodes below x to fill the display area of the Tree Control.
Public Property Type |
Public Property TypeAsNumber |
Public Property Width |

See Also

GuiTree Object


ChangeCheckbox Method

ChangeCheckbox Method
NodeKey
ItemName
Checked
GuiTree Object : ChangeCheckbox Method

Glossary Item Box

Description

This method emulates changing a checkbox state.

Syntax

Visual Basic
Public Sub ChangeCheckbox( _
   ByVal NodeKey As String, _
   ByVal ItemName As String, _
   ByVal Checked As Boolean _
)

Parameters

NodeKey
ItemName
Checked

See Also

GuiTree Object | GuiTree Members


ClickLink Method

ClickLink Method
NodeKey
ItemName
GuiTree Object : ClickLink Method

Glossary Item Box

Description

This function emulates triggering a link.

Syntax

Visual Basic
Public Sub ClickLink( _
   ByVal NodeKey As String, _
   ByVal ItemName As String _
)

Parameters

NodeKey
ItemName

See Also

GuiTree Object | GuiTree Members


CollapseNode Method

CollapseNode Method
NodeKey
GuiTree Object : CollapseNode Method

Glossary Item Box

Description

This function closes the node with the key nodeKey.

Syntax

Visual Basic
Public Sub CollapseNode( _
   ByVal NodeKey As String _
)

Parameters

NodeKey

See Also

GuiTree Object | GuiTree Members


DefaultContextMenu Method

DefaultContextMenu Method
GuiTree Object : DefaultContextMenu Method

Glossary Item Box

Description

This method requests a context menu for the whole Tree Control.

Syntax

Visual Basic
Public Sub DefaultContextMenu()

See Also

GuiTree Object | GuiTree Members


DoubleClickItem Method

DoubleClickItem Method
NodeKey
ItemName
GuiTree Object : DoubleClickItem Method

Glossary Item Box

Description

This function emulates double clicking on a text item.

Syntax

Visual Basic
Public Sub DoubleClickItem( _
   ByVal NodeKey As String, _
   ByVal ItemName As String _
)

Parameters

NodeKey
ItemName

See Also

GuiTree Object | GuiTree Members


DoubleClickNode Method

DoubleClickNode Method
NodeKey
GuiTree Object : DoubleClickNode Method

Glossary Item Box

Description

This function emulates double clicking a node.

Syntax

Visual Basic
Public Sub DoubleClickNode( _
   ByVal NodeKey As String _
)

Parameters

NodeKey

Remarks

If Item Selection is enabled, double clicking a node can only be performed by double clicking on the Folder/Leaf Symbol of the node.

See Also

GuiTree Object | GuiTree Members


DumpState Method

DumpState Method
InnerObject
GuiTree Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiTree Object | GuiTree Members


EnsureVisibleHorizontalItem Method

EnsureVisibleHorizontalItem Method
NodeKey
ItemName
GuiTree Object : EnsureVisibleHorizontalItem Method

Glossary Item Box

Description

This function scrolls the Tree horizontally until the Item is visible.

Syntax

Visual Basic
Public Sub EnsureVisibleHorizontalItem( _
   ByVal NodeKey As String, _
   ByVal ItemName As String _
)

Parameters

NodeKey
ItemName

See Also

GuiTree Object | GuiTree Members


ExpandNode Method

ExpandNode Method
NodeKey
GuiTree Object : ExpandNode Method

Glossary Item Box

Description

This function expands the node with the key nodeKey.

Syntax

Visual Basic
Public Sub ExpandNode( _
   ByVal NodeKey As String _
)

Parameters

NodeKey

See Also

GuiTree Object | GuiTree Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiTree Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiTree Object | GuiTree Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiTree Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiTree Object | GuiTree Members


FindById Method

FindById Method
Id
Raise
GuiTree Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiTree Object | GuiTree Members


FindByName Method

FindByName Method
Name
Type
GuiTree Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiTree Object | GuiTree Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiTree Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiTree Object | GuiTree Members


FindNodeKeyByPath Method

FindNodeKeyByPath Method
Path
GuiTree Object : FindNodeKeyByPath Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindNodeKeyByPath( _
   ByVal Path As String _
) As String

Parameters

Path

See Also

GuiTree Object | GuiTree Members


GetAbapImage Method

GetAbapImage Method
Key
Name
GuiTree Object : GetAbapImage Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetAbapImage( _
   ByVal Key As String, _
   ByVal Name As String _
) As String

Parameters

Key
Name

See Also

GuiTree Object | GuiTree Members


GetAllNodeKeys Method

GetAllNodeKeys Method
GuiTree Object : GetAllNodeKeys Method

Glossary Item Box

Description

method GetAllNodeKeys

Syntax

Visual Basic
Public Function GetAllNodeKeys() As Object

See Also

GuiTree Object | GuiTree Members


GetCheckBoxState Method

GetCheckBoxState Method
NodeKey
ItemName
GuiTree Object : GetCheckBoxState Method

Glossary Item Box

Description

Retrieves the CheckBox state (1 = Checked, 0 = Unchecked).

Syntax

Visual Basic
Public Function GetCheckBoxState( _
   ByVal NodeKey As String, _
   ByVal ItemName As String _
) As Byte

Parameters

NodeKey
ItemName

See Also

GuiTree Object | GuiTree Members


GetColumnCol Method

GetColumnCol Method
colName
GuiTree Object : GetColumnCol Method

Glossary Item Box

Description

The keys of all the items in the given column.

Syntax

Visual Basic
Public Function GetColumnCol( _
   ByVal colName As String _
) As Object

Parameters

colName

See Also

GuiTree Object | GuiTree Members


GetColumnHeaders Method

GetColumnHeaders Method
GuiTree Object : GetColumnHeaders Method

Glossary Item Box

Description

Collection of the titles of the columns.

Syntax

Visual Basic
Public Function GetColumnHeaders() As Object

See Also

GuiTree Object | GuiTree Members


GetColumnIndexFromName Method

GetColumnIndexFromName Method
Key
GuiTree Object : GetColumnIndexFromName Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetColumnIndexFromName( _
   ByVal Key As String _
) As Long

Parameters

Key

See Also

GuiTree Object | GuiTree Members


GetColumnNames Method

GetColumnNames Method
GuiTree Object : GetColumnNames Method

Glossary Item Box

Description

Returns a collection of the column names.

Syntax

Visual Basic
Public Function GetColumnNames() As Object

See Also

GuiTree Object | GuiTree Members


GetColumnTitleFromName Method

GetColumnTitleFromName Method
Key
GuiTree Object : GetColumnTitleFromName Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetColumnTitleFromName( _
   ByVal Key As String _
) As String

Parameters

Key

See Also

GuiTree Object | GuiTree Members


GetColumnTitles Method

GetColumnTitles Method
GuiTree Object : GetColumnTitles Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetColumnTitles() As Object

See Also

GuiTree Object | GuiTree Members


GetFocusedNodeKey Method

GetFocusedNodeKey Method
GuiTree Object : GetFocusedNodeKey Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetFocusedNodeKey() As String

See Also

GuiTree Object | GuiTree Members


GetHierarchyLevel Method

GetHierarchyLevel Method
Key
GuiTree Object : GetHierarchyLevel Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetHierarchyLevel( _
   ByVal Key As String _
) As Long

Parameters

Key

See Also

GuiTree Object | GuiTree Members


GetHierarchyTitle Method

GetHierarchyTitle Method
GuiTree Object : GetHierarchyTitle Method

Glossary Item Box

Description

method GetHierarchyTitle

Syntax

Visual Basic
Public Function GetHierarchyTitle() As String

See Also

GuiTree Object | GuiTree Members


GetIsDisabled Method

GetIsDisabled Method
NodeKey
ItemName
GuiTree Object : GetIsDisabled Method

Glossary Item Box

Description

method GetIsDisabled

Syntax

Visual Basic
Public Function GetIsDisabled( _
   ByVal NodeKey As String, _
   ByVal ItemName As String _
) As Byte

Parameters

NodeKey
ItemName

See Also

GuiTree Object | GuiTree Members


GetIsHighLighted Method

GetIsHighLighted Method
NodeKey
ItemName
GuiTree Object : GetIsHighLighted Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetIsHighLighted( _
   ByVal NodeKey As String, _
   ByVal ItemName As String _
) As Byte

Parameters

NodeKey
ItemName

See Also

GuiTree Object | GuiTree Members


GetItemHeight Method

GetItemHeight Method
NodeKey
ItemName
GuiTree Object : GetItemHeight Method

Glossary Item Box

Description

method GetItemHeight

Syntax

Visual Basic
Public Function GetItemHeight( _
   ByVal NodeKey As String, _
   ByVal ItemName As String _
) As Long

Parameters

NodeKey
ItemName

See Also

GuiTree Object | GuiTree Members


GetItemLeft Method

GetItemLeft Method
NodeKey
ItemName
GuiTree Object : GetItemLeft Method

Glossary Item Box

Description

method GetItemLeft

Syntax

Visual Basic
Public Function GetItemLeft( _
   ByVal NodeKey As String, _
   ByVal ItemName As String _
) As Long

Parameters

NodeKey
ItemName

See Also

GuiTree Object | GuiTree Members


GetItemStyle Method

GetItemStyle Method
NodeKey
ItemName
GuiTree Object : GetItemStyle Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetItemStyle( _
   ByVal NodeKey As String, _
   ByVal ItemName As String _
) As Long

Parameters

NodeKey
ItemName

See Also

GuiTree Object | GuiTree Members


GetItemText Method

GetItemText Method
Key
Name
GuiTree Object : GetItemText Method

Glossary Item Box

Description

This function returns the text of the item specified by the key and name parameters.

Syntax

Visual Basic
Public Function GetItemText( _
   ByVal Key As String, _
   ByVal Name As String _
) As String

Parameters

Key
Name

See Also

GuiTree Object | GuiTree Members


GetItemTextColor Method

GetItemTextColor Method
Key
Name
GuiTree Object : GetItemTextColor Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetItemTextColor( _
   ByVal Key As String, _
   ByVal Name As String _
) As ULong

Parameters

Key
Name

See Also

GuiTree Object | GuiTree Members


GetItemToolTip Method

GetItemToolTip Method
Key
Name
GuiTree Object : GetItemToolTip Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetItemToolTip( _
   ByVal Key As String, _
   ByVal Name As String _
) As String

Parameters

Key
Name

See Also

GuiTree Object | GuiTree Members


GetItemTop Method

GetItemTop Method
NodeKey
ItemName
GuiTree Object : GetItemTop Method

Glossary Item Box

Description

method GetItemTop

Syntax

Visual Basic
Public Function GetItemTop( _
   ByVal NodeKey As String, _
   ByVal ItemName As String _
) As Long

Parameters

NodeKey
ItemName

See Also

GuiTree Object | GuiTree Members


GetItemType Method

GetItemType Method
Key
Name
GuiTree Object : GetItemType Method

Glossary Item Box

Description

Retrieves the column tree item type:

  • trvTreeStructureHierarchy = 0
  • trvTreeStructureImage = 1
  • trvTreeStructureText = 2
  • trvTreeStructureBool = 3
  • trvTreeStructureButton = 4
  • trvTreeStructureLink = 5

Syntax

Visual Basic
Public Function GetItemType( _
   ByVal Key As String, _
   ByVal Name As String _
) As Long

Parameters

Key
Name

See Also

GuiTree Object | GuiTree Members


GetItemWidth Method

GetItemWidth Method
NodeKey
ItemName
GuiTree Object : GetItemWidth Method

Glossary Item Box

Description

method GetItemWidth

Syntax

Visual Basic
Public Function GetItemWidth( _
   ByVal NodeKey As String, _
   ByVal ItemName As String _
) As Long

Parameters

NodeKey
ItemName

See Also

GuiTree Object | GuiTree Members


GetListTreeNodeItemCount Method

GetListTreeNodeItemCount Method
NodeKey
GuiTree Object : GetListTreeNodeItemCount Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetListTreeNodeItemCount( _
   ByVal NodeKey As String _
) As Long

Parameters

NodeKey

See Also

GuiTree Object | GuiTree Members


GetNextNodeKey Method

GetNextNodeKey Method
NodeKey
GuiTree Object : GetNextNodeKey Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetNextNodeKey( _
   ByVal NodeKey As String _
) As String

Parameters

NodeKey

See Also

GuiTree Object | GuiTree Members


GetNodeAbapImage Method

GetNodeAbapImage Method
Key
GuiTree Object : GetNodeAbapImage Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetNodeAbapImage( _
   ByVal Key As String _
) As String

Parameters

Key

See Also

GuiTree Object | GuiTree Members


GetNodeChildrenCount Method

GetNodeChildrenCount Method
Key
GuiTree Object : GetNodeChildrenCount Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetNodeChildrenCount( _
   ByVal Key As String _
) As Long

Parameters

Key

See Also

GuiTree Object | GuiTree Members


GetNodeChildrenCountByPath Method

GetNodeChildrenCountByPath Method
Path
GuiTree Object : GetNodeChildrenCountByPath Method

Glossary Item Box

Description

This function returns the number of children of the node given by the path parameter.

Syntax

Visual Basic
Public Function GetNodeChildrenCountByPath( _
   ByVal Path As String _
) As Long

Parameters

Path

See Also

GuiTree Object | GuiTree Members


GetNodeHeight Method

GetNodeHeight Method
Key
GuiTree Object : GetNodeHeight Method

Glossary Item Box

Description

method GetNodeHeight

Syntax

Visual Basic
Public Function GetNodeHeight( _
   ByVal Key As String _
) As Long

Parameters

Key

See Also

GuiTree Object | GuiTree Members


GetNodeIndex Method

GetNodeIndex Method
Key
GuiTree Object : GetNodeIndex Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetNodeIndex( _
   ByVal Key As String _
) As Long

Parameters

Key

See Also

GuiTree Object | GuiTree Members


GetNodeItemHeaders Method

GetNodeItemHeaders Method
NodeKey
GuiTree Object : GetNodeItemHeaders Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetNodeItemHeaders( _
   ByVal NodeKey As String _
) As Object

Parameters

NodeKey

See Also

GuiTree Object | GuiTree Members


GetNodeKeyByPath Method

GetNodeKeyByPath Method
Path
GuiTree Object : GetNodeKeyByPath Method

Glossary Item Box

Description

Key of the node specified by the given path description.

Syntax

Visual Basic
Public Function GetNodeKeyByPath( _
   ByVal Path As String _
) As String

Parameters

Path

See Also

GuiTree Object | GuiTree Members


GetNodeLeft Method

GetNodeLeft Method
Key
GuiTree Object : GetNodeLeft Method

Glossary Item Box

Description

method GetNodeLeft

Syntax

Visual Basic
Public Function GetNodeLeft( _
   ByVal Key As String _
) As Long

Parameters

Key

See Also

GuiTree Object | GuiTree Members


GetNodePathByKey Method

GetNodePathByKey Method
Key
GuiTree Object : GetNodePathByKey Method

Glossary Item Box

Description

Given a node key, the path is retrieved (e.g. 2\1\2).

Syntax

Visual Basic
Public Function GetNodePathByKey( _
   ByVal Key As String _
) As String

Parameters

Key

See Also

GuiTree Object | GuiTree Members


GetNodesCol Method

GetNodesCol Method
GuiTree Object : GetNodesCol Method

Glossary Item Box

Description

The collection contains the node keys of all the nodes in the tree.

Syntax

Visual Basic
Public Function GetNodesCol() As Object

See Also

GuiTree Object | GuiTree Members


GetNodeStyle Method

GetNodeStyle Method
NodeKey
GuiTree Object : GetNodeStyle Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetNodeStyle( _
   ByVal NodeKey As String _
) As Long

Parameters

NodeKey

See Also

GuiTree Object | GuiTree Members


GetNodeTextByKey Method

GetNodeTextByKey Method
Path
GuiTree Object : GetNodeTextByKey Method

Glossary Item Box

Description

This function returns the text of the node specified by the given key.

Syntax

Visual Basic
Public Function GetNodeTextByKey( _
   ByVal Path As String _
) As String

Parameters

Path

See Also

GuiTree Object | GuiTree Members


GetNodeTextByPath Method

GetNodeTextByPath Method
Path
GuiTree Object : GetNodeTextByPath Method

Glossary Item Box

Description

The text of a node defined by the given path is returned.

Syntax

Visual Basic
Public Function GetNodeTextByPath( _
   ByVal Path As String _
) As String

Parameters

Path

See Also

GuiTree Object | GuiTree Members


GetNodeTextColor Method

GetNodeTextColor Method
Key
GuiTree Object : GetNodeTextColor Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetNodeTextColor( _
   ByVal Key As String _
) As ULong

Parameters

Key

See Also

GuiTree Object | GuiTree Members


GetNodeToolTip Method

GetNodeToolTip Method
NodeKey
GuiTree Object : GetNodeToolTip Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetNodeToolTip( _
   ByVal NodeKey As String _
) As String

Parameters

NodeKey

See Also

GuiTree Object | GuiTree Members


GetNodeTop Method

GetNodeTop Method
Key
GuiTree Object : GetNodeTop Method

Glossary Item Box

Description

method GetNodeTop

Syntax

Visual Basic
Public Function GetNodeTop( _
   ByVal Key As String _
) As Long

Parameters

Key

See Also

GuiTree Object | GuiTree Members


GetNodeWidth Method

GetNodeWidth Method
Key
GuiTree Object : GetNodeWidth Method

Glossary Item Box

Description

method GetNodeWidth

Syntax

Visual Basic
Public Function GetNodeWidth( _
   ByVal Key As String _
) As Long

Parameters

Key

See Also

GuiTree Object | GuiTree Members


GetParent Method

GetParent Method
CKey
GuiTree Object : GetParent Method

Glossary Item Box

Description

Key of the parent node of the node specified by the given key.

Syntax

Visual Basic
Public Function GetParent( _
   ByVal CKey As String _
) As String

Parameters

CKey

See Also

GuiTree Object | GuiTree Members


GetPreviousNodeKey Method

GetPreviousNodeKey Method
NodeKey
GuiTree Object : GetPreviousNodeKey Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetPreviousNodeKey( _
   ByVal NodeKey As String _
) As String

Parameters

NodeKey

See Also

GuiTree Object | GuiTree Members


GetSelectedNodes Method

GetSelectedNodes Method
GuiTree Object : GetSelectedNodes Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetSelectedNodes() As Object

See Also

GuiTree Object | GuiTree Members


GetSelectionMode Method

GetSelectionMode Method
GuiTree Object : GetSelectionMode Method

Glossary Item Box

Description

The selection behaviour of a Tree Control instance is set once at the time of creation.

Syntax

Visual Basic
Public Function GetSelectionMode() As Integer

Return Type

  • 0: Single Node
  • 1: Multiple Node
  • 2: Single Item
  • 3: Multiple Item

Example

Node Selection Mode

  • SingleNodeSelection: Only one node can be selected.
  • MultipleNodeSelection: Several nodes may be selected.

Item Selection
If Item Selection is enabled, then just one item can be selected. Otherwise, only complete nodes can be selected. Item Selection is not available for the Simple Tree.

Column Selection
If Column Selection is enabled, one or more columns can be selected.

Node Selection, Item Selection and Column selection are mutually exclusive. For example, selecting an Item removes a Node Selection automatically.

See Also

GuiTree Object | GuiTree Members


GetStyleDescription Method

GetStyleDescription Method
nStyle
GuiTree Object : GetStyleDescription Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetStyleDescription( _
   ByVal nStyle As Long _
) As String

Parameters

nStyle

See Also

GuiTree Object | GuiTree Members


GetSubNodesCol Method

GetSubNodesCol Method
Path
GuiTree Object : GetSubNodesCol Method

Glossary Item Box

Description

Collection of the keys of all subnodes of the node specified by the given key.

Syntax

Visual Basic
Public Function GetSubNodesCol( _
   ByVal Path As String _
) As Object

Parameters

Path

See Also

GuiTree Object | GuiTree Members


GetTreeType Method

GetTreeType Method
GuiTree Object : GetTreeType Method

Glossary Item Box

Description

The returned number has the following meaning:

  • 0 : Simple tree
  • 1 : List tree
  • 2 : Column tree

Syntax

Visual Basic
Public Function GetTreeType() As Long

See Also

GuiTree Object | GuiTree Members


HeaderContextMenu Method

HeaderContextMenu Method
HeaderName
GuiTree Object : HeaderContextMenu Method

Glossary Item Box

Description

This method requests a context menu for a header.

Syntax

Visual Basic
Public Sub HeaderContextMenu( _
   ByVal HeaderName As String _
)

Parameters

HeaderName

See Also

GuiTree Object | GuiTree Members


IsFolder Method

IsFolder Method
NodeKey
GuiTree Object : IsFolder Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsFolder( _
   ByVal NodeKey As String _
) As Byte

Parameters

NodeKey

See Also

GuiTree Object | GuiTree Members


IsFolderExpandable Method

IsFolderExpandable Method
NodeKey
GuiTree Object : IsFolderExpandable Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsFolderExpandable( _
   ByVal NodeKey As String _
) As Byte

Parameters

NodeKey

See Also

GuiTree Object | GuiTree Members


IsFolderExpanded Method

IsFolderExpanded Method
NodeKey
GuiTree Object : IsFolderExpanded Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsFolderExpanded( _
   ByVal NodeKey As String _
) As Byte

Parameters

NodeKey

See Also

GuiTree Object | GuiTree Members


ItemContextMenu Method

ItemContextMenu Method
NodeKey
ItemName
GuiTree Object : ItemContextMenu Method

Glossary Item Box

Description

This method requests a context menu for an item.

Syntax

Visual Basic
Public Sub ItemContextMenu( _
   ByVal NodeKey As String, _
   ByVal ItemName As String _
)

Parameters

NodeKey
ItemName

See Also

GuiTree Object | GuiTree Members


NodeContextMenu Method

NodeContextMenu Method
NodeKey
GuiTree Object : NodeContextMenu Method

Glossary Item Box

Description

This method requests a context menu for a node.

Syntax

Visual Basic
Public Sub NodeContextMenu( _
   ByVal NodeKey As String _
)

Parameters

NodeKey

See Also

GuiTree Object | GuiTree Members


PressButton Method

PressButton Method
NodeKey
ItemName
GuiTree Object : PressButton Method

Glossary Item Box

Description

This method emulates pressing a button.

Syntax

Visual Basic
Public Sub PressButton( _
   ByVal NodeKey As String, _
   ByVal ItemName As String _
)

Parameters

NodeKey
ItemName

See Also

GuiTree Object | GuiTree Members


PressHeader Method

PressHeader Method
HeaderName
GuiTree Object : PressHeader Method

Glossary Item Box

Description

This method emulates clicking a header.

Syntax

Visual Basic
Public Sub PressHeader( _
   ByVal HeaderName As String _
)

Parameters

HeaderName

See Also

GuiTree Object | GuiTree Members


PressKey Method

PressKey Method
Key
Possible values are: F1, F4, Delete, Insert, Enter, Cut, Copy, and Paste
GuiTree Object : PressKey Method

Glossary Item Box

Description

This method emulates pressing a key.

Syntax

Visual Basic
Public Sub PressKey( _
   ByVal Key As String _
)

Parameters

Key
Possible values are: F1, F4, Delete, Insert, Enter, Cut, Copy, and Paste

See Also

GuiTree Object | GuiTree Members


SelectColumn Method

SelectColumn Method
ColumnName
GuiTree Object : SelectColumn Method

Glossary Item Box

Description

This function adds a column to the column selection. A node or item selection is removed.

Syntax

Visual Basic
Public Sub SelectColumn( _
   ByVal ColumnName As String _
)

Parameters

ColumnName

See Also

GuiTree Object | GuiTree Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiTree Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiTree Object | GuiTree Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiTree Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiTree Object | GuiTree Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiTree Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

GuiTree Object | GuiTree Members


SelectedItemColumn Method

SelectedItemColumn Method
GuiTree Object : SelectedItemColumn Method

Glossary Item Box

Syntax

Visual Basic
Public Function SelectedItemColumn() As String

See Also

GuiTree Object | GuiTree Members


SelectedItemNode Method

SelectedItemNode Method
GuiTree Object : SelectedItemNode Method

Glossary Item Box

Syntax

Visual Basic
Public Function SelectedItemNode() As String

See Also

GuiTree Object | GuiTree Members


SelectItem Method

SelectItem Method
NodeKey
ItemName
GuiTree Object : SelectItem Method

Glossary Item Box

Description

This function emulates the selection of an item. This selection removes all other selections.

Syntax

Visual Basic
Public Sub SelectItem( _
   ByVal NodeKey As String, _
   ByVal ItemName As String _
)

Parameters

NodeKey
ItemName

See Also

GuiTree Object | GuiTree Members


SelectNode Method

SelectNode Method
NodeKey
GuiTree Object : SelectNode Method

Glossary Item Box

Description

The node with the key nodeKey is added to the Node Selection.

Syntax

Visual Basic
Public Sub SelectNode( _
   ByVal NodeKey As String _
)

Parameters

NodeKey

See Also

GuiTree Object | GuiTree Members


SetCheckBoxState Method

SetCheckBoxState Method
NodeKey
ItemName
state
GuiTree Object : SetCheckBoxState Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetCheckBoxState( _
   ByVal NodeKey As String, _
   ByVal ItemName As String, _
   ByVal state As Long _
)

Parameters

NodeKey
ItemName
state

See Also

GuiTree Object | GuiTree Members


SetColumnWidth Method

SetColumnWidth Method
ColumnName
Width
GuiTree Object : SetColumnWidth Method

Glossary Item Box

Description

This function sets the width of a column in pixels.

Syntax

Visual Basic
Public Sub SetColumnWidth( _
   ByVal ColumnName As String, _
   ByVal Width As Long _
)

Parameters

ColumnName
Width

See Also

GuiTree Object | GuiTree Members


SetFocus Method

SetFocus Method
GuiTree Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiTree Object | GuiTree Members


ShowContextMenu Method

ShowContextMenu Method
GuiTree Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiTree Object | GuiTree Members


UnselectAll Method

UnselectAll Method
GuiTree Object : UnselectAll Method

Glossary Item Box

Description

All selections are removed.

Syntax

Visual Basic
Public Sub UnselectAll()

See Also

GuiTree Object | GuiTree Members


UnselectColumn Method

UnselectColumn Method
ColumnName
GuiTree Object : UnselectColumn Method

Glossary Item Box

Description

This function removes a column from the column selection.

Syntax

Visual Basic
Public Sub UnselectColumn( _
   ByVal ColumnName As String _
)

Parameters

ColumnName

See Also

GuiTree Object | GuiTree Members


UnselectNode Method

UnselectNode Method
NodeKey
GuiTree Object : UnselectNode Method

Glossary Item Box

Description

The node with the key nodeKey is removed from the Node Selection.

Syntax

Visual Basic
Public Sub UnselectNode( _
   ByVal NodeKey As String _
)

Parameters

NodeKey

See Also

GuiTree Object | GuiTree Members


Visualize Method

Visualize Method
On
InnerObject
GuiTree Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiTree Object | GuiTree Members


AccDescription Property

AccDescription Property
GuiTree Object : AccDescription Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccDescription As String

See Also

GuiTree Object | GuiTree Members


AccLabelCollection Property

AccLabelCollection Property
GuiTree Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiTree Object | GuiTree Members


AccText Property

AccText Property
GuiTree Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiTree Object | GuiTree Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiTree Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiTree Object | GuiTree Members


AccTooltip Property

AccTooltip Property
GuiTree Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiTree Object | GuiTree Members


Changeable Property

Changeable Property
GuiTree Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiTree Object | GuiTree Members


Children Property

Children Property
GuiTree Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiTree Object | GuiTree Members


ColumnOrder Property

ColumnOrder Property
GuiTree Object : ColumnOrder Property

Glossary Item Box

Description

The property is used for working with a sequence of columns. The name of each column in the Column Tree must occur exactly once.

Property type

Read-write property

Syntax

Visual Basic
Public Property ColumnOrder As Object

Remarks

Preconditions: Tree is a Column Tree and the Column Order can be changed.

See Also

GuiTree Object | GuiTree Members


ContainerType Property

ContainerType Property
GuiTree Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiTree Object | GuiTree Members


CurrentContextMenu Property

CurrentContextMenu Property
GuiTree Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

GuiTree Object | GuiTree Members


DefaultTooltip Property

DefaultTooltip Property
GuiTree Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiTree Object | GuiTree Members


DragDropSupported Property

DragDropSupported Property
GuiTree Object : DragDropSupported Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DragDropSupported As Byte

See Also

GuiTree Object | GuiTree Members


Handle Property

Handle Property
GuiTree Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

GuiTree Object | GuiTree Members


Height Property

Height Property
GuiTree Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiTree Object | GuiTree Members


HierarchyHeaderWidth Property

HierarchyHeaderWidth Property
GuiTree Object : HierarchyHeaderWidth Property

Glossary Item Box

Description

The width of the Hierarchy Header in pixels.

Property type

Read-write property

Syntax

Visual Basic
Public Property HierarchyHeaderWidth As Long

Remarks

Precondition: Tree is a Column Tree or a List Tree with Header

See Also

GuiTree Object | GuiTree Members


IconName Property

IconName Property
GuiTree Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiTree Object | GuiTree Members


Id Property

Id Property
GuiTree Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiTree Object | GuiTree Members


IsSymbolFont Property

IsSymbolFont Property
GuiTree Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiTree Object | GuiTree Members


Left Property

Left Property
GuiTree Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiTree Object | GuiTree Members


Modified Property

Modified Property
GuiTree Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiTree Object | GuiTree Members


Name Property

Name Property
GuiTree Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiTree Object | GuiTree Members


OcxEvents Property

OcxEvents Property
GuiTree Object : OcxEvents Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property OcxEvents As GuiCollection

See Also

GuiTree Object | GuiTree Members


Parent Property

Parent Property
GuiTree Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiTree Object | GuiTree Members


ParentFrame Property

ParentFrame Property
GuiTree Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiTree Object | GuiTree Members


ScreenLeft Property

ScreenLeft Property
GuiTree Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiTree Object | GuiTree Members


ScreenTop Property

ScreenTop Property
GuiTree Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiTree Object | GuiTree Members


SelectedNode Property

SelectedNode Property
GuiTree Object : SelectedNode Property

Glossary Item Box

Description

This is the key of the currently selected node. Selecting a node removes other selections (that is Column Selection and Item Selection).

Property type

Read-write property

Syntax

Visual Basic
Public Property SelectedNode As String

Remarks

Precondition: Node Selection Mode is SingleNodeSelection

See Also

GuiTree Object | GuiTree Members


SubType Property

SubType Property
GuiTree Object : SubType Property

Glossary Item Box

Description

This property has the constant value “Tree”.

Property type

Read-only property

Syntax

Visual Basic
Public Property SubType As String

See Also

GuiTree Object | GuiTree Members


Text Property

Text Property
GuiTree Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiTree Object | GuiTree Members


Tooltip Property

Tooltip Property
GuiTree Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiTree Object | GuiTree Members


Top Property

Top Property
GuiTree Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiTree Object | GuiTree Members


TopNode Property

TopNode Property
GuiTree Object : TopNode Property

Glossary Item Box

Description

This property influences the vertical scrolling of the Tree Control. TopNode contains the key of the node that is located on the upper edge of the Tree Control. Setting a node x as top node is only possible if there are enough visible nodes below x to fill the display area of the Tree Control.

Property type

Read-write property

Syntax

Visual Basic
Public Property TopNode As String

See Also

GuiTree Object | GuiTree Members


Type Property

Type Property
GuiTree Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiTree Object | GuiTree Members


TypeAsNumber Property

TypeAsNumber Property
GuiTree Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiTree Object | GuiTree Members


Width Property

Width Property
GuiTree Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiTree Object | GuiTree Members


GuiUserArea Object

GuiUserArea Object
See Also Members

Glossary Item Box

Description

The GuiUserArea comprises the area between the toolbar and statusbar for windows of GuiMainWindow type and the area between the titlebar and toolbar for modal windows, and may also be limited by docker controls. The standard dynpro elements can be found only in this area, with the exception of buttons, which are also found in the toolbars.

GuiUserArea extends GuiVContainer. The type prefix and name are usr.

Object Model

GuiUserArea ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiScrollbar ObjectGuiComponent ObjectGuiComponent ObjectGuiScrollbar Object

See Also

GuiUserArea Members


GuiUserArea Object Members

GuiUserArea Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState |
Public Method FindAllByName |
Public Method FindAllByNameEx |
Public Method FindById |
Public Method FindByLabel | A very simple method for finding an object is to search by specifying the text of the respective label.
Public Method FindByName |
Public Method FindByNameEx |
Public Method SelectContextMenuItem | This function emulates the selection of an item from the user area’s context menu.
Public Method SelectContextMenuItemByPosition |
Public Method SelectContextMenuItemByText |
Public Method SetFocus |
Public Method ShowContextMenu |
Public Method Visualize |

Public Properties

Public Property AccLabelCollection |
Public Property AccText |
Public Property AccTextOnRequest |
Public Property AccTooltip |
Public Property Changeable |
Public Property Children |
Public Property ContainerType |
Public Property CurrentContextMenu |
Public Property DefaultTooltip |
Public Property Height |
Public Property HorizontalScrollbar | The user area is defined to be scrollable even if the scrollbars are not always visible.
Public Property IconName |
Public Property Id |
Public Property IsOTFPreview |
Public Property IsSymbolFont |
Public Property Left |
Public Property Modified |
Public Property Name |
Public Property Parent |
Public Property ParentFrame |
Public Property ScreenLeft |
Public Property ScreenTop |
Public Property Text |
Public Property Tooltip |
Public Property Top |
Public Property Type |
Public Property TypeAsNumber |
Public Property VerticalScrollbar | The user area is defined to be scrollable even if the scrollbars are not always visible.
Public Property Width |

See Also

GuiUserArea Object


DumpState Method

DumpState Method
InnerObject
GuiUserArea Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiUserArea Object | GuiUserArea Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiUserArea Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiUserArea Object | GuiUserArea Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiUserArea Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiUserArea Object | GuiUserArea Members


FindById Method

FindById Method
Id
Raise
GuiUserArea Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

GuiUserArea Object | GuiUserArea Members


FindByLabel Method

FindByLabel Method
Text
Type
GuiUserArea Object : FindByLabel Method

Glossary Item Box

Description

A very simple method for finding an object is to search by specifying the text of the respective label.

Syntax

Visual Basic
Public Function FindByLabel( _
   ByVal Text As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Text
Type

Example

In this case the upper text field can be found by searching for a GuiTextField with the label text ‘Normal’ describing it. This match is done through searching for a label with the given text and then checking if there is a matching object on the same line. This should be only used for simple dynpros.

See Also

GuiUserArea Object | GuiUserArea Members


FindByName Method

FindByName Method
Name
Type
GuiUserArea Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiUserArea Object | GuiUserArea Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiUserArea Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiUserArea Object | GuiUserArea Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
GuiUserArea Object : SelectContextMenuItem Method

Glossary Item Box

Description

This function emulates the selection of an item from the user area’s context menu.

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

GuiUserArea Object | GuiUserArea Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
GuiUserArea Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

GuiUserArea Object | GuiUserArea Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
GuiUserArea Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

GuiUserArea Object | GuiUserArea Members


SetFocus Method

SetFocus Method
GuiUserArea Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

GuiUserArea Object | GuiUserArea Members


ShowContextMenu Method

ShowContextMenu Method
GuiUserArea Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiUserArea Object | GuiUserArea Members


Visualize Method

Visualize Method
On
InnerObject
GuiUserArea Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiUserArea Object | GuiUserArea Members


AccLabelCollection Property

AccLabelCollection Property
GuiUserArea Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiUserArea Object | GuiUserArea Members


AccText Property

AccText Property
GuiUserArea Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiUserArea Object | GuiUserArea Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiUserArea Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiUserArea Object | GuiUserArea Members


AccTooltip Property

AccTooltip Property
GuiUserArea Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiUserArea Object | GuiUserArea Members


Changeable Property

Changeable Property
GuiUserArea Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiUserArea Object | GuiUserArea Members


Children Property

Children Property
GuiUserArea Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiUserArea Object | GuiUserArea Members


ContainerType Property

ContainerType Property
GuiUserArea Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiUserArea Object | GuiUserArea Members


CurrentContextMenu Property

CurrentContextMenu Property
GuiUserArea Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

GuiUserArea Object | GuiUserArea Members


DefaultTooltip Property

DefaultTooltip Property
GuiUserArea Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiUserArea Object | GuiUserArea Members


Height Property

Height Property
GuiUserArea Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiUserArea Object | GuiUserArea Members


HorizontalScrollbar Property

HorizontalScrollbar Property
GuiUserArea Object : HorizontalScrollbar Property

Glossary Item Box

Description

The user area is defined to be scrollable even if the scrollbars are not always visible.

Property type

Read-only property

Syntax

Visual Basic
Public Property HorizontalScrollbar As GuiScrollbar

See Also

GuiUserArea Object | GuiUserArea Members


IconName Property

IconName Property
GuiUserArea Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiUserArea Object | GuiUserArea Members


Id Property

Id Property
GuiUserArea Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiUserArea Object | GuiUserArea Members


IsOTFPreview Property

IsOTFPreview Property
GuiUserArea Object : IsOTFPreview Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property IsOTFPreview As Byte

See Also

GuiUserArea Object | GuiUserArea Members


IsSymbolFont Property

IsSymbolFont Property
GuiUserArea Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiUserArea Object | GuiUserArea Members


Left Property

Left Property
GuiUserArea Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiUserArea Object | GuiUserArea Members


Modified Property

Modified Property
GuiUserArea Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiUserArea Object | GuiUserArea Members


Name Property

Name Property
GuiUserArea Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiUserArea Object | GuiUserArea Members


Parent Property

Parent Property
GuiUserArea Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiUserArea Object | GuiUserArea Members


ParentFrame Property

ParentFrame Property
GuiUserArea Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiUserArea Object | GuiUserArea Members


ScreenLeft Property

ScreenLeft Property
GuiUserArea Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiUserArea Object | GuiUserArea Members


ScreenTop Property

ScreenTop Property
GuiUserArea Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiUserArea Object | GuiUserArea Members


Text Property

Text Property
GuiUserArea Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiUserArea Object | GuiUserArea Members


Tooltip Property

Tooltip Property
GuiUserArea Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiUserArea Object | GuiUserArea Members


Top Property

Top Property
GuiUserArea Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiUserArea Object | GuiUserArea Members


Type Property

Type Property
GuiUserArea Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiUserArea Object | GuiUserArea Members


TypeAsNumber Property

TypeAsNumber Property
GuiUserArea Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiUserArea Object | GuiUserArea Members


VerticalScrollbar Property

VerticalScrollbar Property
GuiUserArea Object : VerticalScrollbar Property

Glossary Item Box

Description

The user area is defined to be scrollable even if the scrollbars are not always visible.

Property type

Read-only property

Syntax

Visual Basic
Public Property VerticalScrollbar As GuiScrollbar

See Also

GuiUserArea Object | GuiUserArea Members


Width Property

Width Property
GuiUserArea Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiUserArea Object | GuiUserArea Members


GuiUtils Object

GuiUtils Object
See Also Members

Glossary Item Box

Object Model

GuiUtils Object

See Also

GuiUtils Members


GuiUtils Object Members

GuiUtils Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method CloseFile | This function closes a file that was opened using OpenFile.
Public Method OpenFile | The file will be created in the SapWorkDir.
Public Method ShowMessageBox | Shows a message box.
Public Method Write | Write text to an open file without a new line at the end.
Public Method WriteLine | Write text to an open file with a new line at the end.

Public Properties

Public Property MESSAGE_OPTION_OK
Public Property MESSAGE_OPTION_OKCANCEL
Public Property MESSAGE_OPTION_YESNO
Public Property MESSAGE_RESULT_CANCEL
Public Property MESSAGE_RESULT_NO
Public Property MESSAGE_RESULT_OK
Public Property MESSAGE_RESULT_YES
Public Property MESSAGE_TYPE_ERROR
Public Property MESSAGE_TYPE_INFORMATION
Public Property MESSAGE_TYPE_PLAIN
Public Property MESSAGE_TYPE_QUESTION
Public Property MESSAGE_TYPE_WARNING

See Also

GuiUtils Object


CloseFile Method

CloseFile Method
File
GuiUtils Object : CloseFile Method

Glossary Item Box

Description

This function closes a file that was opened using OpenFile.

Syntax

Visual Basic
Public Sub CloseFile( _
   ByVal File As Long _
)

Parameters

File

See Also

GuiUtils Object | GuiUtils Members


OpenFile Method

OpenFile Method
Name
Name of the text file to be created. For security reasons this name must not contain any path information.
GuiUtils Object : OpenFile Method

Glossary Item Box

Description

The file will be created in the SapWorkDir.

Syntax

Visual Basic
Public Function OpenFile( _
   ByVal Name As String _
) As Long

Parameters

Name
Name of the text file to be created. For security reasons this name must not contain any path information.

Return Type

The return value is a handle to the file.

See Also

GuiUtils Object | GuiUtils Members


ShowMessageBox Method

ShowMessageBox Method
Title
Title of the message box
Text
Text of the message box.
MsgIcon
MsgIcon sets the icon to be used for the message box and should be set to one of the GuiMessageBoxType constants.
MsgType
MsgType sets the buttons available on the message box and should be set to one of the GuiMessageBoxOption constants.
GuiUtils Object : ShowMessageBox Method

Glossary Item Box

Description

Shows a message box.

Syntax

Visual Basic
Public Function ShowMessageBox( _
   ByVal Title As String, _
   ByVal Text As String, _
   ByVal MsgIcon As Long, _
   ByVal MsgType As Long _
) As Long

Parameters

Title
Title of the message box
Text
Text of the message box.
MsgIcon
MsgIcon sets the icon to be used for the message box and should be set to one of the GuiMessageBoxType constants.
MsgType
MsgType sets the buttons available on the message box and should be set to one of the GuiMessageBoxOption constants.

Return Type

The return value will be one of the GuiMessageBoxResult constants.

See Also

GuiUtils Object | GuiUtils Members


Write Method

Write Method
File
Text
GuiUtils Object : Write Method

Glossary Item Box

Description

Write text to an open file without a new line at the end.

Syntax

Visual Basic
Public Sub Write( _
   ByVal File As Long, _
   ByVal Text As String _
)

Parameters

File
Text

See Also

GuiUtils Object | GuiUtils Members


WriteLine Method

WriteLine Method
File
Text
GuiUtils Object : WriteLine Method

Glossary Item Box

Description

Write text to an open file with a new line at the end.

Syntax

Visual Basic
Public Sub WriteLine( _
   ByVal File As Long, _
   ByVal Text As String _
)

Parameters

File
Text

See Also

GuiUtils Object | GuiUtils Members


MESSAGE_OPTION_OK Property

MESSAGE_OPTION_OK Property
GuiUtils Object : MESSAGE_OPTION_OK Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property MESSAGE_OPTION_OK As Long

See Also

GuiUtils Object | GuiUtils Members


MESSAGE_OPTION_OKCANCEL Property

MESSAGE_OPTION_OKCANCEL Property
GuiUtils Object : MESSAGE_OPTION_OKCANCEL Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property MESSAGE_OPTION_OKCANCEL As Long

See Also

GuiUtils Object | GuiUtils Members


MESSAGE_OPTION_YESNO Property

MESSAGE_OPTION_YESNO Property
GuiUtils Object : MESSAGE_OPTION_YESNO Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property MESSAGE_OPTION_YESNO As Long

See Also

GuiUtils Object | GuiUtils Members


MESSAGE_RESULT_CANCEL Property

MESSAGE_RESULT_CANCEL Property
GuiUtils Object : MESSAGE_RESULT_CANCEL Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property MESSAGE_RESULT_CANCEL As Long

See Also

GuiUtils Object | GuiUtils Members


MESSAGE_RESULT_NO Property

MESSAGE_RESULT_NO Property
GuiUtils Object : MESSAGE_RESULT_NO Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property MESSAGE_RESULT_NO As Long

See Also

GuiUtils Object | GuiUtils Members


MESSAGE_RESULT_OK Property

MESSAGE_RESULT_OK Property
GuiUtils Object : MESSAGE_RESULT_OK Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property MESSAGE_RESULT_OK As Long

See Also

GuiUtils Object | GuiUtils Members


MESSAGE_RESULT_YES Property

MESSAGE_RESULT_YES Property
GuiUtils Object : MESSAGE_RESULT_YES Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property MESSAGE_RESULT_YES As Long

See Also

GuiUtils Object | GuiUtils Members


MESSAGE_TYPE_ERROR Property

MESSAGE_TYPE_ERROR Property
GuiUtils Object : MESSAGE_TYPE_ERROR Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property MESSAGE_TYPE_ERROR As Long

See Also

GuiUtils Object | GuiUtils Members


MESSAGE_TYPE_INFORMATION Property

MESSAGE_TYPE_INFORMATION Property
GuiUtils Object : MESSAGE_TYPE_INFORMATION Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property MESSAGE_TYPE_INFORMATION As Long

See Also

GuiUtils Object | GuiUtils Members


MESSAGE_TYPE_PLAIN Property

MESSAGE_TYPE_PLAIN Property
GuiUtils Object : MESSAGE_TYPE_PLAIN Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property MESSAGE_TYPE_PLAIN As Long

See Also

GuiUtils Object | GuiUtils Members


MESSAGE_TYPE_QUESTION Property

MESSAGE_TYPE_QUESTION Property
GuiUtils Object : MESSAGE_TYPE_QUESTION Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property MESSAGE_TYPE_QUESTION As Long

See Also

GuiUtils Object | GuiUtils Members


MESSAGE_TYPE_WARNING Property

MESSAGE_TYPE_WARNING Property
GuiUtils Object : MESSAGE_TYPE_WARNING Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property MESSAGE_TYPE_WARNING As Long

See Also

GuiUtils Object | GuiUtils Members


GuiVComponent Object

GuiVComponent Object
See Also Members

Glossary Item Box

Description

The GuiVComponent interface is exposed by all visual objects, such as windows, buttons or text fields. Like GuiComponent, it is an abstract interface. Any object supporting the GuiVComponent interface also exposes the GuiComponent interface. GuiVComponent extends GuiComponent.

Object Model

GuiVComponent ObjectGuiComponentCollection CollectionGuiCollection CollectionGuiComponent ObjectGuiComponent Object

See Also

GuiVComponent Members


GuiVComponent Object Members

GuiVComponent Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property ContainerType
Public Property DefaultTooltip
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiVComponent Object


DumpState Method

DumpState Method
InnerObject
GuiVComponent Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiVComponent Object | GuiVComponent Members


SetFocus Method

SetFocus Method
GuiVComponent Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

Example

See Also

GuiVComponent Object | GuiVComponent Members


ShowContextMenu Method

ShowContextMenu Method
GuiVComponent Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiVComponent Object | GuiVComponent Members


Visualize Method

Visualize Method
On
InnerObject
GuiVComponent Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiVComponent Object | GuiVComponent Members


AccLabelCollection Property

AccLabelCollection Property
GuiVComponent Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiVComponent Object | GuiVComponent Members


AccText Property

AccText Property
GuiVComponent Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiVComponent Object | GuiVComponent Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiVComponent Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiVComponent Object | GuiVComponent Members


AccTooltip Property

AccTooltip Property
GuiVComponent Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiVComponent Object | GuiVComponent Members


Changeable Property

Changeable Property
GuiVComponent Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiVComponent Object | GuiVComponent Members


ContainerType Property

ContainerType Property
GuiVComponent Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiVComponent Object | GuiVComponent Members


DefaultTooltip Property

DefaultTooltip Property
GuiVComponent Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiVComponent Object | GuiVComponent Members


Height Property

Height Property
GuiVComponent Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiVComponent Object | GuiVComponent Members


IconName Property

IconName Property
GuiVComponent Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiVComponent Object | GuiVComponent Members


Id Property

Id Property
GuiVComponent Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiVComponent Object | GuiVComponent Members


IsSymbolFont Property

IsSymbolFont Property
GuiVComponent Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiVComponent Object | GuiVComponent Members


Left Property

Left Property
GuiVComponent Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiVComponent Object | GuiVComponent Members


Modified Property

Modified Property
GuiVComponent Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiVComponent Object | GuiVComponent Members


Name Property

Name Property
GuiVComponent Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiVComponent Object | GuiVComponent Members


Parent Property

Parent Property
GuiVComponent Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiVComponent Object | GuiVComponent Members


ParentFrame Property

ParentFrame Property
GuiVComponent Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiVComponent Object | GuiVComponent Members


ScreenLeft Property

ScreenLeft Property
GuiVComponent Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiVComponent Object | GuiVComponent Members


ScreenTop Property

ScreenTop Property
GuiVComponent Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiVComponent Object | GuiVComponent Members


Text Property

Text Property
GuiVComponent Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiVComponent Object | GuiVComponent Members


Tooltip Property

Tooltip Property
GuiVComponent Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiVComponent Object | GuiVComponent Members


Top Property

Top Property
GuiVComponent Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiVComponent Object | GuiVComponent Members


Type Property

Type Property
GuiVComponent Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiVComponent Object | GuiVComponent Members


TypeAsNumber Property

TypeAsNumber Property
GuiVComponent Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiVComponent Object | GuiVComponent Members


Width Property

Width Property
GuiVComponent Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiVComponent Object | GuiVComponent Members


GuiVContainer Object

GuiVContainer Object
See Also Members

Glossary Item Box

Description

An object exposes the GuiVContainer interface if it is both visible and can have children. It will then also expose GuiComponent and GuiVComponent. Examples of this interface are windows and subscreens, toolbars or controls having children, such as the splitter control. GuiVContainer extends GuiContainer and GuiVComponent.

Object Model

GuiVContainer ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiComponent Object

See Also

GuiVContainer Members


GuiVContainer Object Members

GuiVContainer Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method DumpState
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method SetFocus
Public Method ShowContextMenu
Public Method Visualize

Public Properties

Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property Children
Public Property ContainerType
Public Property DefaultTooltip
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

GuiVContainer Object


DumpState Method

DumpState Method
InnerObject
GuiVContainer Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

GuiVContainer Object | GuiVContainer Members


FindAllByName Method

FindAllByName Method
Name
Type
GuiVContainer Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiVContainer Object | GuiVContainer Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
GuiVContainer Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

GuiVContainer Object | GuiVContainer Members


FindById Method

FindById Method
Id
Raise
Default value is TRUE.
GuiVContainer Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise
Default value is TRUE.

See Also

GuiVContainer Object | GuiVContainer Members


FindByName Method

FindByName Method
Name
Type
GuiVContainer Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

GuiVContainer Object | GuiVContainer Members


FindByNameEx Method

FindByNameEx Method
Name
Type
GuiVContainer Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

GuiVContainer Object | GuiVContainer Members


SetFocus Method

SetFocus Method
GuiVContainer Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

Example

See Also

GuiVContainer Object | GuiVContainer Members


ShowContextMenu Method

ShowContextMenu Method
GuiVContainer Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

GuiVContainer Object | GuiVContainer Members


Visualize Method

Visualize Method
On
InnerObject
GuiVContainer Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

GuiVContainer Object | GuiVContainer Members


AccLabelCollection Property

AccLabelCollection Property
GuiVContainer Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

GuiVContainer Object | GuiVContainer Members


AccText Property

AccText Property
GuiVContainer Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

GuiVContainer Object | GuiVContainer Members


AccTextOnRequest Property

AccTextOnRequest Property
GuiVContainer Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

GuiVContainer Object | GuiVContainer Members


AccTooltip Property

AccTooltip Property
GuiVContainer Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

GuiVContainer Object | GuiVContainer Members


Changeable Property

Changeable Property
GuiVContainer Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

GuiVContainer Object | GuiVContainer Members


Children Property

Children Property
GuiVContainer Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

GuiVContainer Object | GuiVContainer Members


ContainerType Property

ContainerType Property
GuiVContainer Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

GuiVContainer Object | GuiVContainer Members


DefaultTooltip Property

DefaultTooltip Property
GuiVContainer Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

GuiVContainer Object | GuiVContainer Members


Height Property

Height Property
GuiVContainer Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

GuiVContainer Object | GuiVContainer Members


IconName Property

IconName Property
GuiVContainer Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

GuiVContainer Object | GuiVContainer Members


Id Property

Id Property
GuiVContainer Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

GuiVContainer Object | GuiVContainer Members


IsSymbolFont Property

IsSymbolFont Property
GuiVContainer Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

GuiVContainer Object | GuiVContainer Members


Left Property

Left Property
GuiVContainer Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

GuiVContainer Object | GuiVContainer Members


Modified Property

Modified Property
GuiVContainer Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

GuiVContainer Object | GuiVContainer Members


Name Property

Name Property
GuiVContainer Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

GuiVContainer Object | GuiVContainer Members


Parent Property

Parent Property
GuiVContainer Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

GuiVContainer Object | GuiVContainer Members


ParentFrame Property

ParentFrame Property
GuiVContainer Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

GuiVContainer Object | GuiVContainer Members


ScreenLeft Property

ScreenLeft Property
GuiVContainer Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

GuiVContainer Object | GuiVContainer Members


ScreenTop Property

ScreenTop Property
GuiVContainer Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

GuiVContainer Object | GuiVContainer Members


Text Property

Text Property
GuiVContainer Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

GuiVContainer Object | GuiVContainer Members


Tooltip Property

Tooltip Property
GuiVContainer Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

GuiVContainer Object | GuiVContainer Members


Top Property

Top Property
GuiVContainer Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

GuiVContainer Object | GuiVContainer Members


Type Property

Type Property
GuiVContainer Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

GuiVContainer Object | GuiVContainer Members


TypeAsNumber Property

TypeAsNumber Property
GuiVContainer Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

GuiVContainer Object | GuiVContainer Members


Width Property

Width Property
GuiVContainer Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

GuiVContainer Object | GuiVContainer Members


ISapAbapEditorTarget Object

ISapAbapEditorTarget Object
See Also Members

Glossary Item Box

Object Model

ISapAbapEditorTarget ObjectGuiComponentCollection CollectionGuiComponentCollection CollectionGuiContextMenu ObjectGuiCollection CollectionGuiComponentCollection CollectionGuiComponentCollection CollectionGuiComponent ObjectGuiComponent ObjectGuiComponent ObjectGuiCollection CollectionGuiComponent ObjectGuiComponent Object

See Also

ISapAbapEditorTarget Members


ISapAbapEditorTarget Object Members

ISapAbapEditorTarget Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method AutoBraceEnabled
Public Method AutoComplete
Public Method AutoCorrectEnabled
Public Method AutoExpand
Public Method AutoIndentEnabled
Public Method Capitalize
Public Method ClipboardCopy
Public Method ClipboardCut
Public Method ClipboardPaste
Public Method ClipboardRingPaste
Public Method CodeHintsEnabled
Public Method CommentSelectedLines
Public Method CorrectCapsEnabled
Public Method Delete
Public Method DeleteBack
Public Method DeleteRange
Public Method DeleteSelection
Public Method DeleteWord
Public Method DeleteWordBack
Public Method DumpState
Public Method DuplicateLine
Public Method FindAllByName
Public Method FindAllByNameEx
Public Method FindById
Public Method FindByName
Public Method FindByNameEx
Public Method FormatSelectedLines
Public Method GetAutoCompleteEntryCount
Public Method GetAutoCompleteEntryText
Public Method GetAutoCompleteIconType
Public Method GetAutoCompleteSubIconType
Public Method GetAutoCompleteToolbarButtonToolTip
Public Method GetAutoCompleteToolTipDelay
Public Method GetCurrentToolTipText
Public Method GetCursorColumnPosition
Public Method GetCursorLinePosition
Public Method GetFirstVisibleLine
Public Method GetHTMLClipboardContents
Public Method GetLastVisibleLine
Public Method GetLineCount
Public Method GetLineText
Public Method GetNumberedBookmarks
Public Method GetRTFClipboardContents
Public Method GetSelectedAutoComplete
Public Method GetSelectedText
Public Method GetStructureBlockEndLine
Public Method GetStructureBlockStartLine
Public Method GetUndoPosition
Public Method GetWordWrapMode
Public Method GetWordWrapPosition
Public Method GoNextBookMark
Public Method GoNumberedBookmark
Public Method GoPreviousBookMark
Public Method InsertTab
Public Method InsertText
Public Method IsAutoCompleteEntryBold
Public Method IsAutoCompleteOpen
Public Method IsAutoCompleteToolbarButtonPressed
Public Method IsAutoCompleteToolTipVisible
Public Method IsBookmark
Public Method IsBreakpointSet
Public Method IsLineCollapsed
Public Method IsLineComment
Public Method IsLineModified
Public Method IsModified
Public Method JoinSelectedLines
Public Method LowerCase
Public Method MoveCursorDocumentEnd
Public Method MoveCursorLineDown
Public Method MoveCursorLineEnd
Public Method MoveCursorLineHome
Public Method MoveCursorLineUp
Public Method MoveLineDown
Public Method MoveLineUp
Public Method MoveWordLeft
Public Method MoveWordRight
Public Method OverwriteModeEnabled
Public Method RemoveAllBookmarks
Public Method RemoveAllBreakpoints
Public Method RemoveBookmarks
Public Method RemoveBreakpoint
Public Method ReplaceSelection
Public Method SaveToFile
Public Method ScrollToLine
Public Method SelectAll
Public Method SelectBlockRange
Public Method SelectContextMenuItem
Public Method SelectContextMenuItemByPosition
Public Method SelectContextMenuItemByText
Public Method SelectRange
Public Method SelectWordLeft
Public Method SelectWordRight
Public Method Sentencize
Public Method SetAutoBrace
Public Method SetAutoCorrect
Public Method SetAutoIndent
Public Method SetBookmarks
Public Method SetBreakpoint
Public Method SetCodeHints
Public Method SetCorrectCaps
Public Method SetFocus
Public Method SetLineFeedStyle
Public Method SetOverwriteMode
Public Method SetSelectionPosInLine
Public Method SetSmartTab
Public Method SetWordWrapMode
Public Method SetWordWrapPosition
Public Method ShowContextMenu
Public Method SmartTabEnabled
Public Method SortSelectedLines
Public Method SwapCase
Public Method ToggleCapsLock
Public Method ToggleNumberedBookmark
Public Method ToggleStructureBlock
Public Method TransposeLine
Public Method UncommentSelectedLines
Public Method Undo
Public Method UnTab
Public Method UpperCase
Public Method Visualize

Public Properties

Public Property AccDescription
Public Property AccLabelCollection
Public Property AccText
Public Property AccTextOnRequest
Public Property AccTooltip
Public Property Changeable
Public Property Children
Public Property ContainerType
Public Property CurrentContextMenu
Public Property DefaultTooltip
Public Property DragDropSupported
Public Property Handle
Public Property Height
Public Property IconName
Public Property Id
Public Property IsSymbolFont
Public Property Left
Public Property Modified
Public Property Name
Public Property OcxEvents
Public Property Parent
Public Property ParentFrame
Public Property ScreenLeft
Public Property ScreenTop
Public Property SubType
Public Property Text
Public Property Tooltip
Public Property Top
Public Property Type
Public Property TypeAsNumber
Public Property Width

See Also

ISapAbapEditorTarget Object


AutoBraceEnabled Method

AutoBraceEnabled Method
ISapAbapEditorTarget Object : AutoBraceEnabled Method

Glossary Item Box

Syntax

Visual Basic
Public Function AutoBraceEnabled() As Byte

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


AutoComplete Method

AutoComplete Method
ISapAbapEditorTarget Object : AutoComplete Method

Glossary Item Box

Syntax

Visual Basic
Public Sub AutoComplete()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


AutoCorrectEnabled Method

AutoCorrectEnabled Method
ISapAbapEditorTarget Object : AutoCorrectEnabled Method

Glossary Item Box

Syntax

Visual Basic
Public Function AutoCorrectEnabled() As Byte

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


AutoExpand Method

AutoExpand Method
ISapAbapEditorTarget Object : AutoExpand Method

Glossary Item Box

Syntax

Visual Basic
Public Sub AutoExpand()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


AutoIndentEnabled Method

AutoIndentEnabled Method
ISapAbapEditorTarget Object : AutoIndentEnabled Method

Glossary Item Box

Syntax

Visual Basic
Public Function AutoIndentEnabled() As Byte

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


Capitalize Method

Capitalize Method
ISapAbapEditorTarget Object : Capitalize Method

Glossary Item Box

Syntax

Visual Basic
Public Sub Capitalize()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


ClipboardCopy Method

ClipboardCopy Method
ISapAbapEditorTarget Object : ClipboardCopy Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ClipboardCopy()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


ClipboardCut Method

ClipboardCut Method
ISapAbapEditorTarget Object : ClipboardCut Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ClipboardCut()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


ClipboardPaste Method

ClipboardPaste Method
ISapAbapEditorTarget Object : ClipboardPaste Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ClipboardPaste()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


ClipboardRingPaste Method

ClipboardRingPaste Method
p1
ISapAbapEditorTarget Object : ClipboardRingPaste Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ClipboardRingPaste( _
   ByVal p1 As Long _
)

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


CodeHintsEnabled Method

CodeHintsEnabled Method
ISapAbapEditorTarget Object : CodeHintsEnabled Method

Glossary Item Box

Syntax

Visual Basic
Public Function CodeHintsEnabled() As Byte

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


CommentSelectedLines Method

CommentSelectedLines Method
ISapAbapEditorTarget Object : CommentSelectedLines Method

Glossary Item Box

Syntax

Visual Basic
Public Sub CommentSelectedLines()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


CorrectCapsEnabled Method

CorrectCapsEnabled Method
ISapAbapEditorTarget Object : CorrectCapsEnabled Method

Glossary Item Box

Syntax

Visual Basic
Public Function CorrectCapsEnabled() As Byte

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


Delete Method

Delete Method
ISapAbapEditorTarget Object : Delete Method

Glossary Item Box

Syntax

Visual Basic
Public Sub Delete()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


DeleteBack Method

DeleteBack Method
ISapAbapEditorTarget Object : DeleteBack Method

Glossary Item Box

Syntax

Visual Basic
Public Sub DeleteBack()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


DeleteRange Method

DeleteRange Method
p1
p2
p3
p4
ISapAbapEditorTarget Object : DeleteRange Method

Glossary Item Box

Syntax

Visual Basic
Public Sub DeleteRange( _
   ByVal p1 As Long, _
   ByVal p2 As Long, _
   ByVal p3 As Long, _
   ByVal p4 As Long _
)

Parameters

p1
p2
p3
p4

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


DeleteSelection Method

DeleteSelection Method
ISapAbapEditorTarget Object : DeleteSelection Method

Glossary Item Box

Syntax

Visual Basic
Public Sub DeleteSelection()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


DeleteWord Method

DeleteWord Method
ISapAbapEditorTarget Object : DeleteWord Method

Glossary Item Box

Syntax

Visual Basic
Public Sub DeleteWord()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


DeleteWordBack Method

DeleteWordBack Method
ISapAbapEditorTarget Object : DeleteWordBack Method

Glossary Item Box

Syntax

Visual Basic
Public Sub DeleteWordBack()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


DumpState Method

DumpState Method
InnerObject
ISapAbapEditorTarget Object : DumpState Method

Glossary Item Box

Syntax

Visual Basic
Public Function DumpState( _
   ByVal InnerObject As String _
) As GuiCollection

Parameters

InnerObject

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


DuplicateLine Method

DuplicateLine Method
ISapAbapEditorTarget Object : DuplicateLine Method

Glossary Item Box

Syntax

Visual Basic
Public Sub DuplicateLine()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


FindAllByName Method

FindAllByName Method
Name
Type
ISapAbapEditorTarget Object : FindAllByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponentCollection

Parameters

Name
Type

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


FindAllByNameEx Method

FindAllByNameEx Method
Name
Type
ISapAbapEditorTarget Object : FindAllByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindAllByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponentCollection

Parameters

Name
Type

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


FindById Method

FindById Method
Id
Raise
ISapAbapEditorTarget Object : FindById Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindById( _
   ByVal Id As String, _
   Optional ByVal Raise As Variant _
) As GuiComponent

Parameters

Id
Raise

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


FindByName Method

FindByName Method
Name
Type
ISapAbapEditorTarget Object : FindByName Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByName( _
   ByVal Name As String, _
   ByVal Type As String _
) As GuiComponent

Parameters

Name
Type

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


FindByNameEx Method

FindByNameEx Method
Name
Type
ISapAbapEditorTarget Object : FindByNameEx Method

Glossary Item Box

Syntax

Visual Basic
Public Function FindByNameEx( _
   ByVal Name As String, _
   ByVal Type As Long _
) As GuiComponent

Parameters

Name
Type

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


FormatSelectedLines Method

FormatSelectedLines Method
ISapAbapEditorTarget Object : FormatSelectedLines Method

Glossary Item Box

Syntax

Visual Basic
Public Sub FormatSelectedLines()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GetAutoCompleteEntryCount Method

GetAutoCompleteEntryCount Method
ISapAbapEditorTarget Object : GetAutoCompleteEntryCount Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetAutoCompleteEntryCount() As Long

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GetAutoCompleteEntryText Method

GetAutoCompleteEntryText Method
p1
ISapAbapEditorTarget Object : GetAutoCompleteEntryText Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetAutoCompleteEntryText( _
   ByVal p1 As Long _
) As String

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GetAutoCompleteIconType Method

GetAutoCompleteIconType Method
p1
ISapAbapEditorTarget Object : GetAutoCompleteIconType Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetAutoCompleteIconType( _
   ByVal p1 As Long _
) As String

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GetAutoCompleteSubIconType Method

GetAutoCompleteSubIconType Method
p1
ISapAbapEditorTarget Object : GetAutoCompleteSubIconType Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetAutoCompleteSubIconType( _
   ByVal p1 As Long _
) As String

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GetAutoCompleteToolbarButtonToolTip Method

GetAutoCompleteToolbarButtonToolTip Method
p1
ISapAbapEditorTarget Object : GetAutoCompleteToolbarButtonToolTip Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetAutoCompleteToolbarButtonToolTip( _
   ByVal p1 As Long _
) As String

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GetAutoCompleteToolTipDelay Method

GetAutoCompleteToolTipDelay Method
ISapAbapEditorTarget Object : GetAutoCompleteToolTipDelay Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetAutoCompleteToolTipDelay() As Long

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GetCurrentToolTipText Method

GetCurrentToolTipText Method
ISapAbapEditorTarget Object : GetCurrentToolTipText Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetCurrentToolTipText() As String

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GetCursorColumnPosition Method

GetCursorColumnPosition Method
ISapAbapEditorTarget Object : GetCursorColumnPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetCursorColumnPosition() As Long

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GetCursorLinePosition Method

GetCursorLinePosition Method
ISapAbapEditorTarget Object : GetCursorLinePosition Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetCursorLinePosition() As Long

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GetFirstVisibleLine Method

GetFirstVisibleLine Method
ISapAbapEditorTarget Object : GetFirstVisibleLine Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetFirstVisibleLine() As Long

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GetHTMLClipboardContents Method

GetHTMLClipboardContents Method
ISapAbapEditorTarget Object : GetHTMLClipboardContents Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetHTMLClipboardContents() As String

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GetLastVisibleLine Method

GetLastVisibleLine Method
ISapAbapEditorTarget Object : GetLastVisibleLine Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetLastVisibleLine() As Long

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GetLineCount Method

GetLineCount Method
ISapAbapEditorTarget Object : GetLineCount Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetLineCount() As Long

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GetLineText Method

GetLineText Method
p1
ISapAbapEditorTarget Object : GetLineText Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetLineText( _
   ByVal p1 As Long _
) As String

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GetNumberedBookmarks Method

GetNumberedBookmarks Method
p1
ISapAbapEditorTarget Object : GetNumberedBookmarks Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetNumberedBookmarks( _
   ByVal p1 As Long _
) As Object

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GetRTFClipboardContents Method

GetRTFClipboardContents Method
ISapAbapEditorTarget Object : GetRTFClipboardContents Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetRTFClipboardContents() As String

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GetSelectedAutoComplete Method

GetSelectedAutoComplete Method
ISapAbapEditorTarget Object : GetSelectedAutoComplete Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetSelectedAutoComplete() As Long

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GetSelectedText Method

GetSelectedText Method
ISapAbapEditorTarget Object : GetSelectedText Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetSelectedText() As String

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GetStructureBlockEndLine Method

GetStructureBlockEndLine Method
p1
ISapAbapEditorTarget Object : GetStructureBlockEndLine Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetStructureBlockEndLine( _
   ByVal p1 As Long _
) As Long

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GetStructureBlockStartLine Method

GetStructureBlockStartLine Method
p1
ISapAbapEditorTarget Object : GetStructureBlockStartLine Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetStructureBlockStartLine( _
   ByVal p1 As Long _
) As Long

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GetUndoPosition Method

GetUndoPosition Method
ISapAbapEditorTarget Object : GetUndoPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetUndoPosition() As Long

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GetWordWrapMode Method

GetWordWrapMode Method
ISapAbapEditorTarget Object : GetWordWrapMode Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetWordWrapMode() As Long

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GetWordWrapPosition Method

GetWordWrapPosition Method
ISapAbapEditorTarget Object : GetWordWrapPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Function GetWordWrapPosition() As Long

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GoNextBookMark Method

GoNextBookMark Method
ISapAbapEditorTarget Object : GoNextBookMark Method

Glossary Item Box

Syntax

Visual Basic
Public Sub GoNextBookMark()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GoNumberedBookmark Method

GoNumberedBookmark Method
p1
ISapAbapEditorTarget Object : GoNumberedBookmark Method

Glossary Item Box

Syntax

Visual Basic
Public Sub GoNumberedBookmark( _
   ByVal p1 As Long _
)

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GoPreviousBookMark Method

GoPreviousBookMark Method
ISapAbapEditorTarget Object : GoPreviousBookMark Method

Glossary Item Box

Syntax

Visual Basic
Public Sub GoPreviousBookMark()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


InsertTab Method

InsertTab Method
ISapAbapEditorTarget Object : InsertTab Method

Glossary Item Box

Syntax

Visual Basic
Public Sub InsertTab()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


InsertText Method

InsertText Method
p1
p2
p3
ISapAbapEditorTarget Object : InsertText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub InsertText( _
   ByVal p1 As String, _
   ByVal p2 As Long, _
   ByVal p3 As Long _
)

Parameters

p1
p2
p3

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


IsAutoCompleteEntryBold Method

IsAutoCompleteEntryBold Method
p1
ISapAbapEditorTarget Object : IsAutoCompleteEntryBold Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsAutoCompleteEntryBold( _
   ByVal p1 As Long _
) As Byte

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


IsAutoCompleteOpen Method

IsAutoCompleteOpen Method
ISapAbapEditorTarget Object : IsAutoCompleteOpen Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsAutoCompleteOpen() As Byte

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


IsAutoCompleteToolbarButtonPressed Method

IsAutoCompleteToolbarButtonPressed Method
p1
ISapAbapEditorTarget Object : IsAutoCompleteToolbarButtonPressed Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsAutoCompleteToolbarButtonPressed( _
   ByVal p1 As Long _
) As Byte

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


IsAutoCompleteToolTipVisible Method

IsAutoCompleteToolTipVisible Method
ISapAbapEditorTarget Object : IsAutoCompleteToolTipVisible Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsAutoCompleteToolTipVisible() As Byte

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


IsBookmark Method

IsBookmark Method
p1
ISapAbapEditorTarget Object : IsBookmark Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsBookmark( _
   ByVal p1 As Long _
) As Byte

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


IsBreakpointSet Method

IsBreakpointSet Method
p1
ISapAbapEditorTarget Object : IsBreakpointSet Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsBreakpointSet( _
   ByVal p1 As Long _
) As Byte

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


IsLineCollapsed Method

IsLineCollapsed Method
p1
ISapAbapEditorTarget Object : IsLineCollapsed Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsLineCollapsed( _
   ByVal p1 As Long _
) As Byte

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


IsLineComment Method

IsLineComment Method
p1
ISapAbapEditorTarget Object : IsLineComment Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsLineComment( _
   ByVal p1 As Long _
) As Byte

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


IsLineModified Method

IsLineModified Method
p1
ISapAbapEditorTarget Object : IsLineModified Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsLineModified( _
   ByVal p1 As Long _
) As Byte

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


IsModified Method

IsModified Method
ISapAbapEditorTarget Object : IsModified Method

Glossary Item Box

Syntax

Visual Basic
Public Function IsModified() As Byte

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


JoinSelectedLines Method

JoinSelectedLines Method
ISapAbapEditorTarget Object : JoinSelectedLines Method

Glossary Item Box

Syntax

Visual Basic
Public Sub JoinSelectedLines()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


LowerCase Method

LowerCase Method
ISapAbapEditorTarget Object : LowerCase Method

Glossary Item Box

Syntax

Visual Basic
Public Sub LowerCase()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


MoveCursorDocumentEnd Method

MoveCursorDocumentEnd Method
ISapAbapEditorTarget Object : MoveCursorDocumentEnd Method

Glossary Item Box

Syntax

Visual Basic
Public Sub MoveCursorDocumentEnd()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


MoveCursorLineDown Method

MoveCursorLineDown Method
ISapAbapEditorTarget Object : MoveCursorLineDown Method

Glossary Item Box

Syntax

Visual Basic
Public Sub MoveCursorLineDown()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


MoveCursorLineEnd Method

MoveCursorLineEnd Method
ISapAbapEditorTarget Object : MoveCursorLineEnd Method

Glossary Item Box

Syntax

Visual Basic
Public Sub MoveCursorLineEnd()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


MoveCursorLineHome Method

MoveCursorLineHome Method
ISapAbapEditorTarget Object : MoveCursorLineHome Method

Glossary Item Box

Syntax

Visual Basic
Public Sub MoveCursorLineHome()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


MoveCursorLineUp Method

MoveCursorLineUp Method
ISapAbapEditorTarget Object : MoveCursorLineUp Method

Glossary Item Box

Syntax

Visual Basic
Public Sub MoveCursorLineUp()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


MoveLineDown Method

MoveLineDown Method
ISapAbapEditorTarget Object : MoveLineDown Method

Glossary Item Box

Syntax

Visual Basic
Public Sub MoveLineDown()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


MoveLineUp Method

MoveLineUp Method
ISapAbapEditorTarget Object : MoveLineUp Method

Glossary Item Box

Syntax

Visual Basic
Public Sub MoveLineUp()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


MoveWordLeft Method

MoveWordLeft Method
ISapAbapEditorTarget Object : MoveWordLeft Method

Glossary Item Box

Syntax

Visual Basic
Public Sub MoveWordLeft()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


MoveWordRight Method

MoveWordRight Method
ISapAbapEditorTarget Object : MoveWordRight Method

Glossary Item Box

Syntax

Visual Basic
Public Sub MoveWordRight()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


OverwriteModeEnabled Method

OverwriteModeEnabled Method
ISapAbapEditorTarget Object : OverwriteModeEnabled Method

Glossary Item Box

Syntax

Visual Basic
Public Function OverwriteModeEnabled() As Byte

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


RemoveAllBookmarks Method

RemoveAllBookmarks Method
ISapAbapEditorTarget Object : RemoveAllBookmarks Method

Glossary Item Box

Syntax

Visual Basic
Public Sub RemoveAllBookmarks()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


RemoveAllBreakpoints Method

RemoveAllBreakpoints Method
ISapAbapEditorTarget Object : RemoveAllBreakpoints Method

Glossary Item Box

Syntax

Visual Basic
Public Sub RemoveAllBreakpoints()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


RemoveBookmarks Method

RemoveBookmarks Method
p1
ISapAbapEditorTarget Object : RemoveBookmarks Method

Glossary Item Box

Syntax

Visual Basic
Public Sub RemoveBookmarks( _
   ByVal p1 As String _
)

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


RemoveBreakpoint Method

RemoveBreakpoint Method
p1
ISapAbapEditorTarget Object : RemoveBreakpoint Method

Glossary Item Box

Syntax

Visual Basic
Public Sub RemoveBreakpoint( _
   ByVal p1 As Long _
)

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


ReplaceSelection Method

ReplaceSelection Method
p1
ISapAbapEditorTarget Object : ReplaceSelection Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ReplaceSelection( _
   ByVal p1 As String _
)

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SaveToFile Method

SaveToFile Method
p1
ISapAbapEditorTarget Object : SaveToFile Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SaveToFile( _
   ByVal p1 As String _
)

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


ScrollToLine Method

ScrollToLine Method
p1
ISapAbapEditorTarget Object : ScrollToLine Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ScrollToLine( _
   ByVal p1 As Long _
)

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SelectAll Method

SelectAll Method
ISapAbapEditorTarget Object : SelectAll Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectAll()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SelectBlockRange Method

SelectBlockRange Method
p1
p2
p3
p4
ISapAbapEditorTarget Object : SelectBlockRange Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectBlockRange( _
   ByVal p1 As Long, _
   ByVal p2 As Long, _
   ByVal p3 As Long, _
   ByVal p4 As Long _
)

Parameters

p1
p2
p3
p4

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SelectContextMenuItem Method

SelectContextMenuItem Method
FunctionCode
ISapAbapEditorTarget Object : SelectContextMenuItem Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItem( _
   ByVal FunctionCode As String _
)

Parameters

FunctionCode

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SelectContextMenuItemByPosition Method

SelectContextMenuItemByPosition Method
PositionDesc
ISapAbapEditorTarget Object : SelectContextMenuItemByPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByPosition( _
   ByVal PositionDesc As String _
)

Parameters

PositionDesc

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SelectContextMenuItemByText Method

SelectContextMenuItemByText Method
Text
ISapAbapEditorTarget Object : SelectContextMenuItemByText Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectContextMenuItemByText( _
   ByVal Text As String _
)

Parameters

Text

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SelectRange Method

SelectRange Method
p1
p2
p3
p4
ISapAbapEditorTarget Object : SelectRange Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectRange( _
   ByVal p1 As Long, _
   ByVal p2 As Long, _
   ByVal p3 As Long, _
   ByVal p4 As Long _
)

Parameters

p1
p2
p3
p4

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SelectWordLeft Method

SelectWordLeft Method
ISapAbapEditorTarget Object : SelectWordLeft Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectWordLeft()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SelectWordRight Method

SelectWordRight Method
ISapAbapEditorTarget Object : SelectWordRight Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SelectWordRight()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


Sentencize Method

Sentencize Method
ISapAbapEditorTarget Object : Sentencize Method

Glossary Item Box

Syntax

Visual Basic
Public Sub Sentencize()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SetAutoBrace Method

SetAutoBrace Method
p1
ISapAbapEditorTarget Object : SetAutoBrace Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetAutoBrace( _
   ByVal p1 As Byte _
)

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SetAutoCorrect Method

SetAutoCorrect Method
p1
ISapAbapEditorTarget Object : SetAutoCorrect Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetAutoCorrect( _
   ByVal p1 As Byte _
)

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SetAutoIndent Method

SetAutoIndent Method
p1
ISapAbapEditorTarget Object : SetAutoIndent Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetAutoIndent( _
   ByVal p1 As Byte _
)

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SetBookmarks Method

SetBookmarks Method
p1
ISapAbapEditorTarget Object : SetBookmarks Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetBookmarks( _
   ByVal p1 As String _
)

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SetBreakpoint Method

SetBreakpoint Method
p1
ISapAbapEditorTarget Object : SetBreakpoint Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetBreakpoint( _
   ByVal p1 As Long _
)

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SetCodeHints Method

SetCodeHints Method
p1
ISapAbapEditorTarget Object : SetCodeHints Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetCodeHints( _
   ByVal p1 As Byte _
)

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SetCorrectCaps Method

SetCorrectCaps Method
p1
ISapAbapEditorTarget Object : SetCorrectCaps Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetCorrectCaps( _
   ByVal p1 As Byte _
)

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SetFocus Method

SetFocus Method
ISapAbapEditorTarget Object : SetFocus Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetFocus()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SetLineFeedStyle Method

SetLineFeedStyle Method
p1
ISapAbapEditorTarget Object : SetLineFeedStyle Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetLineFeedStyle( _
   ByVal p1 As Long _
)

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SetOverwriteMode Method

SetOverwriteMode Method
p1
ISapAbapEditorTarget Object : SetOverwriteMode Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetOverwriteMode( _
   ByVal p1 As Byte _
)

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SetSelectionPosInLine Method

SetSelectionPosInLine Method
p1
p2
ISapAbapEditorTarget Object : SetSelectionPosInLine Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetSelectionPosInLine( _
   ByVal p1 As Long, _
   ByVal p2 As Long _
)

Parameters

p1
p2

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SetSmartTab Method

SetSmartTab Method
p1
ISapAbapEditorTarget Object : SetSmartTab Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetSmartTab( _
   ByVal p1 As Byte _
)

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SetWordWrapMode Method

SetWordWrapMode Method
p1
ISapAbapEditorTarget Object : SetWordWrapMode Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetWordWrapMode( _
   ByVal p1 As Long _
)

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SetWordWrapPosition Method

SetWordWrapPosition Method
p1
ISapAbapEditorTarget Object : SetWordWrapPosition Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SetWordWrapPosition( _
   ByVal p1 As Long _
)

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


ShowContextMenu Method

ShowContextMenu Method
ISapAbapEditorTarget Object : ShowContextMenu Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ShowContextMenu()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SmartTabEnabled Method

SmartTabEnabled Method
ISapAbapEditorTarget Object : SmartTabEnabled Method

Glossary Item Box

Syntax

Visual Basic
Public Function SmartTabEnabled() As Byte

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SortSelectedLines Method

SortSelectedLines Method
ISapAbapEditorTarget Object : SortSelectedLines Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SortSelectedLines()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SwapCase Method

SwapCase Method
ISapAbapEditorTarget Object : SwapCase Method

Glossary Item Box

Syntax

Visual Basic
Public Sub SwapCase()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


ToggleCapsLock Method

ToggleCapsLock Method
ISapAbapEditorTarget Object : ToggleCapsLock Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ToggleCapsLock()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


ToggleNumberedBookmark Method

ToggleNumberedBookmark Method
p1
p2
ISapAbapEditorTarget Object : ToggleNumberedBookmark Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ToggleNumberedBookmark( _
   ByVal p1 As Long, _
   ByVal p2 As Long _
)

Parameters

p1
p2

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


ToggleStructureBlock Method

ToggleStructureBlock Method
p1
ISapAbapEditorTarget Object : ToggleStructureBlock Method

Glossary Item Box

Syntax

Visual Basic
Public Sub ToggleStructureBlock( _
   ByVal p1 As Long _
)

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


TransposeLine Method

TransposeLine Method
ISapAbapEditorTarget Object : TransposeLine Method

Glossary Item Box

Syntax

Visual Basic
Public Sub TransposeLine()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


UncommentSelectedLines Method

UncommentSelectedLines Method
ISapAbapEditorTarget Object : UncommentSelectedLines Method

Glossary Item Box

Syntax

Visual Basic
Public Sub UncommentSelectedLines()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


Undo Method

Undo Method
p1
ISapAbapEditorTarget Object : Undo Method

Glossary Item Box

Syntax

Visual Basic
Public Sub Undo( _
   ByVal p1 As Long _
)

Parameters

p1

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


UnTab Method

UnTab Method
ISapAbapEditorTarget Object : UnTab Method

Glossary Item Box

Syntax

Visual Basic
Public Sub UnTab()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


UpperCase Method

UpperCase Method
ISapAbapEditorTarget Object : UpperCase Method

Glossary Item Box

Syntax

Visual Basic
Public Sub UpperCase()

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


Visualize Method

Visualize Method
On
InnerObject
ISapAbapEditorTarget Object : Visualize Method

Glossary Item Box

Syntax

Visual Basic
Public Function Visualize( _
   ByVal On As Boolean, _
   Optional ByVal InnerObject As Variant _
) As Byte

Parameters

On
InnerObject

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


AccDescription Property

AccDescription Property
ISapAbapEditorTarget Object : AccDescription Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccDescription As String

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


AccLabelCollection Property

AccLabelCollection Property
ISapAbapEditorTarget Object : AccLabelCollection Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccLabelCollection As GuiComponentCollection

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


AccText Property

AccText Property
ISapAbapEditorTarget Object : AccText Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccText As String

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


AccTextOnRequest Property

AccTextOnRequest Property
ISapAbapEditorTarget Object : AccTextOnRequest Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTextOnRequest As String

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


AccTooltip Property

AccTooltip Property
ISapAbapEditorTarget Object : AccTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property AccTooltip As String

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


Changeable Property

Changeable Property
ISapAbapEditorTarget Object : Changeable Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Changeable As Byte

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


Children Property

Children Property
ISapAbapEditorTarget Object : Children Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Children As GuiComponentCollection

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


ContainerType Property

ContainerType Property
ISapAbapEditorTarget Object : ContainerType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ContainerType As Byte

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


CurrentContextMenu Property

CurrentContextMenu Property
ISapAbapEditorTarget Object : CurrentContextMenu Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentContextMenu As GuiContextMenu

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


DefaultTooltip Property

DefaultTooltip Property
ISapAbapEditorTarget Object : DefaultTooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultTooltip As String

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


DragDropSupported Property

DragDropSupported Property
ISapAbapEditorTarget Object : DragDropSupported Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property DragDropSupported As Byte

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


Handle Property

Handle Property
ISapAbapEditorTarget Object : Handle Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Handle As Long

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


Height Property

Height Property
ISapAbapEditorTarget Object : Height Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


IconName Property

IconName Property
ISapAbapEditorTarget Object : IconName Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IconName As String

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


Id Property

Id Property
ISapAbapEditorTarget Object : Id Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Id As String

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


IsSymbolFont Property

IsSymbolFont Property
ISapAbapEditorTarget Object : IsSymbolFont Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSymbolFont As Byte

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


Left Property

Left Property
ISapAbapEditorTarget Object : Left Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


Modified Property

Modified Property
ISapAbapEditorTarget Object : Modified Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Modified As Byte

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


Name Property

Name Property
ISapAbapEditorTarget Object : Name Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


OcxEvents Property

OcxEvents Property
ISapAbapEditorTarget Object : OcxEvents Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property OcxEvents As GuiCollection

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


Parent Property

Parent Property
ISapAbapEditorTarget Object : Parent Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Parent As GuiComponent

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


ParentFrame Property

ParentFrame Property
ISapAbapEditorTarget Object : ParentFrame Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ParentFrame As GuiComponent

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


ScreenLeft Property

ScreenLeft Property
ISapAbapEditorTarget Object : ScreenLeft Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenLeft As Long

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


ScreenTop Property

ScreenTop Property
ISapAbapEditorTarget Object : ScreenTop Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property ScreenTop As Long

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


SubType Property

SubType Property
ISapAbapEditorTarget Object : SubType Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property SubType As String

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


Text Property

Text Property
ISapAbapEditorTarget Object : Text Property

Glossary Item Box

Property type

Read-write property

Syntax

Visual Basic
Public Property Text As String

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


Tooltip Property

Tooltip Property
ISapAbapEditorTarget Object : Tooltip Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Tooltip As String

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


Top Property

Top Property
ISapAbapEditorTarget Object : Top Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


Type Property

Type Property
ISapAbapEditorTarget Object : Type Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As String

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


TypeAsNumber Property

TypeAsNumber Property
ISapAbapEditorTarget Object : TypeAsNumber Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property TypeAsNumber As Long

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


Width Property

Width Property
ISapAbapEditorTarget Object : Width Property

Glossary Item Box

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

ISapAbapEditorTarget Object | ISapAbapEditorTarget Members


GuiComponentType Enumeration

GuiComponentType Enumeration

Glossary Item Box

Members

Member | Value | Description
GuiApplication | 10 | GuiApplication
GuiBox | 62 | GuiBox
GuiButton | 40 | GuiButton
GuiCheckBox | 42 | GuiCheckBox
GuiCollection | 120 | GuiCollection
GuiComboBox | 34 | GuiComboBox
GuiComponent | 0 | GuiComponent
GuiComponentCollection | 128 | GuiComponentCollection
GuiConnection | 11 | GuiConnection
GuiContainer | 70 | GuiContainer
GuiContainerShell | 51 | GuiContainerShell
GuiContextMenu | 127 | GuiContextMenu
GuiCTextField | 32 | GuiCTextField
GuiCustomControl | 50 | GuiCustomControl
GuiDialogShell | 125 | GuiDialogShell
GuiDockShell | 126 | GuiDockShell
GuiFrameWindow | 20 | GuiFrameWindow
GuiGOSShell | 123 | GuiGOSShell
GuiLabel | 30 | GuiLabel
GuiListContainer | 73 | GuiListContainer
GuiMainWindow | 21 | GuiMainWindow
GuiMenu | 110 | GuiMenu
GuiMenubar | 111 | GuiMenubar
GuiMessageWindow | 23 | GuiMessageWindow
GuiModalWindow | 22 | GuiModalWindow
GuiOkCodeField | 35 | GuiOkCodeField
GuiPasswordField | 33 | GuiPasswordField
GuiRadioButton | 41 | GuiRadioButton
GuiScrollbar | 100 | GuiScrollbar
GuiScrollContainer | 72 | GuiScrollContainer
GuiSession | 12 | GuiSession
GuiSessionInfo | 121 | GuiSessionInfo
GuiShell | 122 | GuiShell
GuiSimpleContainer | 71 | GuiSimpleContainer
GuiSplitterContainer | 75 | GuiSplitterContainer
GuiSplitterShell | 124 | GuiSplitterShell
GuiStatusbar | 103 | GuiStatusbar
GuiStatusPane | 43 | GuiStatusPane
GuiTab | 91 | GuiTab
GuiTableColumn | 81 | GuiTableColumn
GuiTableControl | 80 | GuiTableControl
GuiTableRow | 82 | GuiTableRow
GuiTabStrip | 90 | GuiTabStrip
GuiTextField | 31 | GuiTextField
GuiTitlebar | 102 | GuiTitlebar
GuiToolbar | 101 | GuiToolbar
GuiUnknown | -1 | GuiUnknown
GuiUserArea | 74 | GuiUserArea
GuiVComponent | 1 | GuiVComponent
GuiVContainer | 2 | GuiVContainer


GuiErrorType Enumeration

GuiErrorType Enumeration

Glossary Item Box

Members

Member | Value | Description
Gui_Err_AccessDenied | 633 | Access denied.
Gui_Err_Bad_Focus | 634 | Can not set focus to this object.
Gui_Err_Bad_Index_Type | 618 | Bad index type for collection access.
Gui_Err_Control_Label | 615 | The control could not be found by label.
Gui_Err_Control_Name | 608 | The control could not be found by name.
Gui_Err_Control_Position | 616 | The control could not be found by position.
Gui_Err_Disconnected | 621 | The object invoked has disconnected from its clients.
Gui_Err_Enumerator_Index | 614 | The enumerator of the collection cannot find an element with the specified index.
Gui_Err_Enumerator_Reset | 612 | The enumerator of the collection cannot be reset.
Gui_Err_FindById | 619 | The control could not be found by id.
Gui_Err_FindByName | 620 | The control could not be found by name.
Gui_Err_FindByPos | 632 | The control could not be found by position.
Gui_Err_Front_Module | 602 | The path of the 'sapfront.dll' could not be determined.
Gui_Err_Init | 601 | Sapgui engine cannot be initialized.
Gui_Err_Int_Get_Session_Failed | 629 | Can not get session from TLS
Gui_Err_Int_GetCtrl_Failed | 625 | Could not get ctrl (Internal Error)
Gui_Err_Int_GetFocusManFromSes_Failed | 627 | Could not get focus manager from session (Internal Error)
Gui_Err_Int_GetSesFromCtrl_Failed | 626 | Could not get session from ctrl (Internal Error)
Gui_Err_Int_Invalid_TestToolMode | 628 | Invalid test tool mode
Gui_Err_Int_View_Not_Set | 630 | View not set (Internal Error)
Gui_Err_Invalid_Argument | 613 | The method got an invalid argument.
Gui_Err_Invalid_Context | 603 | Function called in invalid thread context
Gui_Err_Invalid_Window | 611 | The required window is invalid.
Gui_Err_Logon_Module | 604 | The 'Sapgui Logon Component' could not be instantiated.
Gui_Err_Menu_Disabled | 623 | The menu item is disabled.
Gui_Err_No_Memory | 607 | The system is out of memory.
Gui_Err_No_Wrapper | 622 | No wrapper available for this control.
Gui_Err_Not_Implemented | 610 | The method or property is currently not implemented.
Gui_Err_Permission_Denied | 637 | Permission denied.
Gui_Err_Property_Readonly | 609 | The property is readonly.
Gui_Err_Resize_Failed | 631 | Resize failed.
Gui_Err_Sapgui_Module | 605 | The 'Sapgui Component' could not be instantiated.
Gui_Err_Save_Image | 635 | Error saving image.
Gui_Err_Scripting_Disabled_Srv | 624 | Scripting is disabled by the server.
Gui_Err_Session_Index | 606 | The session index is out of range.
Gui_Err_Shortcut_Evaluation | 636 | Shortcut evaluation failed.
Gui_Err_SL_No_Entry | 1000 | Not a valid SAPLogon entry
Gui_Err_VKey_Disabled | 617 | The virtual key is not enabled.


GuiEventType Enumeration

GuiEventType Enumeration

Glossary Item Box

Members

Member | Value | Description
SapApplicationCreateSessionEvent | 2002 | ApplicationCreateSession
SapApplicationDestroySessionEvent | 2003 | ApplicationDestroySession
SapApplicationErrorEvent | 2004 | ApplicationErrorEvent
SapApplicationIgnoreSessionEvent | 2005 | ApplicationIgnoreSession
SapContextMenuEvent | 1282 | ContextMenu
SapCustomDataChangedEvent | 1280 | CustomDataChanged
SapDefaultEvent | 0 | Default
SapHitSelectEvent | 1281 | Hit
SapSessionAbapScriptingEvent | 1289 | AbapScriptingEvent
SapSessionActivatedEvent | 1285 | SessionActivated
SapSessionAutoFCodeEvent | 1284 | SessionAutoFCode
SapSessionDestroyEvent | 1283 | SessionDestroy
SapSessionEndRequestEvent | 515 | SessionEndRequest
SapSessionErrorEvent | 516 | SessionError
SapSessionFocusChangedEvent | 1286 | SessionFocusChanged
SapSessionHistoryOpenedEvent | 1287 | SessionHistoryOpened
SapSessionProgressIndicatorEvent | 1288 | ProgressIndicatorOpened
SapSessionStartRequestEvent | 514 | SessionStartRequest


GuiImageType Enumeration

GuiImageType Enumeration

Glossary Item Box

Description

SAP GUI Image types

Members

Member | Value | Description
BMP | 0 | BMP
GIF | 2 | GIF
JPEG | 1 | JPEG
PNG | 2 | PNG


GuiMagicDispIDs Enumeration

GuiMagicDispIDs Enumeration

Glossary Item Box

Members

Member | Value | Description
GuiDispIDBTPress | 32200 |
GuiDispIDCBChecked | 32011 |
GuiDispIDCBCurListBoxEntry | 32305 |
GuiDispIDCBEntries | 32302 |
GuiDispIDCBEntryKey | 33800 |
GuiDispIDCBEntryPos | 33802 |
GuiDispIDCBEntryValue | 33801 |
GuiDispIDCBIsListBoxActive | 32304 |
GuiDispIDCBKey | 32300 |
GuiDispIDCBKeySpace | 32303 |
GuiDispIDCBShowKey | 32306 |
GuiDispIDCBValue | 32301 |
GuiDispIDCollAdd | 33103 |
GuiDispIDCollCount | 33100 |
GuiDispIDCollElAt | 33102 |
GuiDispIDCollLength | 33101 |
GuiDispIDConConnString | 33003 |
GuiDispIDConDescription | 33002 |
GuiDispIDConDisabled | 33001 |
GuiDispIDConnClose | 32831 |
GuiDispIDConSessions | 33000 |
GuiDispIDCTFindAllByName | 32035 |
GuiDispIDCTFindAllByNameEx | 32036 |
GuiDispIDCTFindById | 32029 |
GuiDispIDCTFindByLabel | 32027 |
GuiDispIDCTFindByName | 32026 |
GuiDispIDCTFindByNameEx | 32034 |
GuiDispIDCTFindByPosition | 32028 |
GuiDispIDDockerIsVertical | 34301 |
GuiDispIDDockerPixelSize | 34300 |
GuiDispIDEngAddHist | 32913 |
GuiDispIDEngButtonB | 32903 |
GuiDispIDEngCon | 32900 |
GuiDispIDEngConnErr | 32924 |
GuiDispIDEngCrColl | 32911 |
GuiDispIDEngDropHist | 32914 |
GuiDispIDEngGetEng | 1 |
GuiDispIDEngHistEnabled | 32916 |
GuiDispIDEngIgnore | 32908 |
GuiDispIDEngInplace | 32907 |
GuiDispIDEngMajor | 32909 |
GuiDispIDEngMinor | 32910 |
GuiDispIDEngNoSysMsg | 32925 |
GuiDispIDEngOpenCon | 32905 |
GuiDispIDEngOpenConEx | 32918 |
GuiDispIDEngOpenWDCon | 32926 |
GuiDispIDEngPatchlevel | 32919 |
GuiDispIDEngQuit | 32906 |
GuiDispIDEngRegister | 32921 |
GuiDispIDEngRevision | 32920 |
GuiDispIDEngRevoke | 32923 |
GuiDispIDEngStatusB | 32902 |
GuiDispIDEngTheme | 32912 |
GuiDispIDEngTitleB | 32904 |
GuiDispIDEngToolB | 32901 |
GuiDispIDEngUtils | 32917 |
GuiDispIDEngWDSessions | 32927 |
GuiDispIDErrDesc1 | 33601 |
GuiDispIDErrDesc2 | 33602 |
GuiDispIDErrDesc3 | 33603 |
GuiDispIDErrDesc4 | 33604 |
GuiDispIDErrNo | 33600 |
GuiDispIDGActiveSession | 32049 |
GuiDispIDGActiveSession2 | 32075 |
GuiDispIDGCAccDescription | 33703 |
GuiDispIDGCAccLabelCol | 32043 |
GuiDispIDGCAccText | 32044 |
GuiDispIDGCAccTextOnReq | 32045 |
GuiDispIDGCAccTooltip | 32042 |
GuiDispIDGCChangeable | 32009 |
GuiDispIDGCCharHeight | 32073 |
GuiDispIDGCCharLeft | 32070 |
GuiDispIDGCCharTop | 32071 |
GuiDispIDGCCharWidth | 32072 |
GuiDispIDGCChildren | 32019 |
GuiDispIDGCClass | 32017 |
GuiDispIDGCColorIndex | 32058 |
GuiDispIDGCColorIntensified | 32059 |
GuiDispIDGCColorInverse | 32060 |
GuiDispIDGCCtxMnu | 33701 |
GuiDispIDGCDefaultTooltip | 32069 |
GuiDispIDGCDisplayedText | 32074 |
GuiDispIDGCDragDrop | 33706 |
GuiDispIDGCDumpState | 31194 |
GuiDispIDGCFlushing | 33704 |
GuiDispIDGCHeight | 32006 |
GuiDispIDGCHwnd | 33702 |
GuiDispIDGCIcon | 32037 |
GuiDispIDGCId | 32025 |
GuiDispIDGCIsContainer | 32033 |
GuiDispIDGCIsHotspot | 32051 |
GuiDispIDGCIsList | 32052 |
GuiDispIDGCIsStepLoop | 32062 |
GuiDispIDGCIsSymbolFont | 32061 |
GuiDispIDGCLeft | 32003 |
GuiDispIDGCLeftLabel | 32040 |
GuiDispIDGCLoopCurrentCol | 32065 |
GuiDispIDGCLoopCurrentRow | 32066 |
GuiDispIDGCLoopHeight | 32064 |
GuiDispIDGCLoopWidth | 32063 |
GuiDispIDGCModified | 32030 |
GuiDispIDGCName | 32001 |
GuiDispIDGCOcxEvents | 33705 |
GuiDispIDGCParent | 32038 |
GuiDispIDGCParentFrame | 32050 |
GuiDispIDGCRightLabel | 32041 |
GuiDispIDGCRowText | 32053 |
GuiDispIDGCScreenLeft | 32046 |
GuiDispIDGCScreenTop | 32047 |
GuiDispIDGCSession | 32018 |
GuiDispIDGCSetFocus | 32024 |
GuiDispIDGCShortId | 32031 |
GuiDispIDGCShowContextMenu | 32068 |
GuiDispIDGCSubType | 33700 |
GuiDispIDGCText | 32000 |
GuiDispIDGCTitle | 32048 |
GuiDispIDGCTooltip | 32008 |
GuiDispIDGCTop | 32004 |
GuiDispIDGCType | 32015 |
GuiDispIDGCTypeAsNum | 32032 |
GuiDispIDGCVisualize | 32039 |
GuiDispIDGCWidth | 32005 |
GuiDispIDGECATTReplay | 32076 |
GuiDispIDGetAbsoluteRow | 33407 |
GuiDispIDGMSelect | 33300 |
GuiDispIDGMWFocusedButton | 32433 |
GuiDispIDGMWHelpButtonHelpText | 32440 |
GuiDispIDGMWHelpButtonText | 32435 |
GuiDispIDGMWMessageText | 32437 |
GuiDispIDGMWMessageType | 32436 |
GuiDispIDGMWOKButtonHelpText | 32439 |
GuiDispIDGMWOKButtonText | 32434 |
GuiDispIDGMWVisible | 32438 |
GuiDispIDGUCharHeight | 32603 |
GuiDispIDGUCharWidth | 32602 |
GuiDispIDGUHorizontalScrollbar | 32600 |
GuiDispIDGUListNav | 32605 |
GuiDispIDGUOTFPreview | 32606 |
GuiDispIDGUResize | 32604 |
GuiDispIDGUVerticalScrollbar | 32601 |
GuiDispIDGWButtonB | 32425 |
GuiDispIDGWClose | 32414 |
GuiDispIDGWCompBitmap | 32443 |
GuiDispIDGWGuiFocus | 32422 |
GuiDispIDGWHandle | 32420 |
GuiDispIDGWHardCopy | 32415 |
GuiDispIDGWHardCopyMem | 32441 |
GuiDispIDGWIconic | 32400 |
GuiDispIDGWIconify | 32408 |
GuiDispIDGWIsPopupDialog | 32427 |
GuiDispIDGWJumpBackward | 32432 |
GuiDispIDGWJumpForward | 32431 |
GuiDispIDGWMaximize | 32410 |
GuiDispIDGWMoveWindow | 32407 |
GuiDispIDGWPopupDialogText | 32428 |
GuiDispIDGWRestore | 32409 |
GuiDispIDGWSpyMode | 32413 |
GuiDispIDGWStatusB | 32424 |
GuiDispIDGWSysFocus | 32421 |
GuiDispIDGWTabBackward | 32430 |
GuiDispIDGWTabForward | 32429 |
GuiDispIDGWTitleB | 32426 |
GuiDispIDGWToolB | 32423 |
GuiDispIDGWVKAllowed | 32412 |
GuiDispIDGWWPHeight | 32417 |
GuiDispIDGWWPMsgBox | 32419 |
GuiDispIDGWWPResize | 32418 |
GuiDispIDGWWPResizeEx | 32442 |
GuiDispIDGWWPWidth | 32416 |
GuiDispIDIsListBoxActive | 32840 |
GuiDispIDLCursor | 32022 |
GuiDispIDLHighlighted | 32100 |
GuiDispIDLIsLeftLabel | 32101 |
GuiDispIDLIsRightLabel | 32102 |
GuiDispIDListBoxCurrEntry | 32849 |
GuiDispIDListBoxCurrEntryHeight | 32848 |
GuiDispIDListBoxCurrEntryLeft | 32846 |
GuiDispIDListBoxCurrEntryTop | 32845 |
GuiDispIDListBoxCurrEntryWidth | 32847 |
GuiDispIDListBoxHeight | 32844 |
GuiDispIDListBoxLeft | 32842 |
GuiDispIDListBoxTop | 32841 |
GuiDispIDListBoxWidth | 32843 |
GuiDispIDLListProperty | 32103 |
GuiDispIDLMaxLength | 32012 |
GuiDispIDLNumerical | 32013 |
GuiDispIDLPassword | 32016 |
GuiDispIDLSimpleListProperty | 32104 |
GuiDispIDMsgAsPopup | 34004 |
GuiDispIDMsgId | 34001 |
GuiDispIDMsgNumber | 34002 |
GuiDispIDMsgPar | 34003 |
GuiDispIDMsgType | 34000 |
GuiDispIDOcxCallbackChange | 200889 |
GuiDispIDOcxCallbackHighlight | 200890 |
GuiDispIDOcxCallbackHit | 200891 |
GuiDispIDOcxControl | 271062 |
GuiDispIDOcxGetRect | 31192 |
GuiDispIDOcxHit | 31195 |
GuiDispIDOcxHitTest | 31193 |
GuiDispIDOcxHover | 31196 |
GuiDispIDOcxIsReadOnlyCall | 31191 |
GuiDispIDOcxNotify | 31199 |
GuiDispIDOcxNotifyContEvSink | 31197 |
GuiDispIDOcxNotifyCtrlEvent | 31198 |
GuiDispIDOKF1 | 32351 |
GuiDispIDOKOpened | 32350 |
GuiDispIDRBGroupColl | 32504 |
GuiDispIDRBGroupCount | 32502 |
GuiDispIDRBGroupPos | 32503 |
GuiDispIDRBSelect | 32501 |
GuiDispIDRBSelected | 32500 |
GuiDispIDSBDblClick | 32750 |
GuiDispIDScrollMax | 33904 |
GuiDispIDScrollMin | 33905 |
GuiDispIDScrollPage | 33903 |
GuiDispIDScrollPos | 33902 |
GuiDispIDScrollRange | 33900 |
GuiDispIDSesActivWin | 32800 |
GuiDispIDSesBusy | 32803 |
GuiDispIDSesClearErrorList | 32825 |
GuiDispIDSesClose | 32811 |
GuiDispIDSesCmd | 32805 |
GuiDispIDSesCmdAsync | 32806 |
GuiDispIDSesCreate | 32812 |
GuiDispIDSesEnableAccSymbols | 32830 |
GuiDispIDSesEnableAccTabChain | 32829 |
GuiDispIDSesEnableJaws | 32828 |
GuiDispIDSesEndT | 32810 |
GuiDispIDSesErrorList | 32824 |
GuiDispIDSesFindByPos | 32818 |
GuiDispIDSesIconDesc | 33525 |
GuiDispIDSesInfo | 32802 |
GuiDispIDSesInfoAppSr | 33508 |
GuiDispIDSesInfoCl | 33509 |
GuiDispIDSesInfoCP | 33512 |
GuiDispIDSesInfoDisRec | 33521 |
GuiDispIDSesInfoDynp | 33506 |
GuiDispIDSesInfoFlush | 33503 |
GuiDispIDSesInfoForceNot | 33522 |
GuiDispIDSesInfoGrpN | 33515 |
GuiDispIDSesInfoGuiCP | 33523 |
GuiDispIDSesInfoI18N | 33524 |
GuiDispIDSesInfoITime | 33501 |
GuiDispIDSesInfoLang | 33511 |
GuiDispIDSesInfoModeNo | 33517 |
GuiDispIDSesInfoMsgSrc | 33514 |
GuiDispIDSesInfoMsgSrv | 33513 |
GuiDispIDSesInfoProg | 33505 |
GuiDispIDSesInfoReadOnly | 33520 |
GuiDispIDSesInfoRound | 33504 |
GuiDispIDSesInfoRTime | 33500 |
GuiDispIDSesInfoSesCtx | 33518 |
GuiDispIDSesInfoSysN | 33507 |
GuiDispIDSesInfoSysNo | 33516 |
GuiDispIDSesInfoTrans | 33502 |
GuiDispIDSesInfoUser | 33510 |
GuiDispIDSesInfoWAN | 33519 |
GuiDispIDSesIsActive | 32819 |
GuiDispIDSesLockSessionUI | 32826 |
GuiDispIDSesMenu | 32807 |
GuiDispIDSesPPPSyId | 32821 |
GuiDispIDSesPPSyId | 32822 |
GuiDispIDSesPPTaId | 32820 |
GuiDispIDSesProgressPercent | 32832 |
GuiDispIDSesProgressText | 32833 |
GuiDispIDSesRecFile | 32814 |
GuiDispIDSesRecord | 32804 |
GuiDispIDSesRunScrCtrl | 32816 |
GuiDispIDSesSaveAsUnicode | 32823 |
GuiDispIDSesShowKeys | 33527 |
GuiDispIDSesStartT | 32809 |
GuiDispIDSesStdNumFmt | 33526 |
GuiDispIDSesSuppressBackendPopups | 32834 |
GuiDispIDSesTestTool | 32813 |
GuiDispIDSesUnlockSessionUI | 32827 |
GuiDispIDSesVKey | 32808 |
GuiDispIDSesVKeyDesc | 32817 |
GuiDispIDSHSelCtxtMenIt | 34100 |
GuiDispIDSHSelCtxtMenItPos | 34102 |
GuiDispIDSHSelCtxtMenItTxt | 34101 |
GuiDispIDSplitterIsVertical | 34400 |
GuiDispIDSplitterSashPosition | 34401 |
GuiDispIDTableBase | 33400 |
GuiDispIDTableColBase | 33420 |
GuiDispIDTableColFixed | 33421 |
GuiDispIDTableColSelected | 33422 |
GuiDispIDTableColSelectMode | 33401 |
GuiDispIDTableColTitle | 33420 |
GuiDispIDTableColumns | 33402 |
GuiDispIDTableConfigureLayout | 33406 |
GuiDispIDTableCurrentCol | 33410 |
GuiDispIDTableCurrentRow | 33411 |
GuiDispIDTableDeselAllCols | 33414 |
GuiDispIDTableFieldName | 33409 |
GuiDispIDTabLeftTab | 33200 |
GuiDispIDTableGetCell | 33415 |
GuiDispIDTableReorderTable | 33405 |
GuiDispIDTableRowBase | 33430 |
GuiDispIDTableRowCount | 33412 |
GuiDispIDTableRows | 33404 |
GuiDispIDTableRowSelectable | 33431 |
GuiDispIDTableRowSelected | 33430 |
GuiDispIDTableRowSelectMode | 33403 |
GuiDispIDTableSelAllCols | 33408 |
GuiDispIDTableVisRowCount | 33413 |
GuiDispIDTabSelTab | 33201 |
GuiDispIDTBSelect | 32700 |
GuiDispIDTBToLeft | 32701 |
GuiDispIDTHistoryCurEntry | 32057 |
GuiDispIDTHistoryCurIndex | 32056 |
GuiDispIDTHistoryIsActive | 32054 |
GuiDispIDTHistoryList | 32055 |
GuiDispIDTIsOField | 32067 |
GuiDispIDTRequired | 32014 |
GuiDispIDUtilCloseFile | 34202 |
GuiDispIDUtilMsgBox | 34200 |
GuiDispIDUtilMsgOptOK | 34220 |
GuiDispIDUtilMsgOptOKCan | 34222 |
GuiDispIDUtilMsgOptYesNo | 34221 |
GuiDispIDUtilMsgResCancel | 34230 |
GuiDispIDUtilMsgResNo | 34233 |
GuiDispIDUtilMsgResOK | 34231 |
GuiDispIDUtilMsgResYes | 34232 |
GuiDispIDUtilMsgTypeE | 34208 |
GuiDispIDUtilMsgTypeI | 34205 |
GuiDispIDUtilMsgTypeP | 34209 |
GuiDispIDUtilMsgTypeQ | 34206 |
GuiDispIDUtilMsgTypeW | 34207 |
GuiDispIDUtilOpenFile | 34201 |
GuiDispIDUtilWriteFile | 34203 |
GuiDispIDUtilWriteLnFile | 34204 |


GuiMessageBoxOption Enumeration

GuiMessageBoxOption Enumeration

Glossary Item Box

Description

SAP GUI Message Box Options

Members

Member | Value | Description
MSG_OPTION_OK | 0 | Constant value to be used when calling the showMessageBox method. Using this value will display an ‘OK’ button only. (0)
MSG_OPTION_OKCANCEL | 2 | Constant value to be used when calling the showMessageBox method. Using this value will display an ‘OK’ button and a ‘Cancel’ button. (2)
MSG_OPTION_YESNO | 1 | Constant value to be used when calling the showMessageBox method. Using this value will display a ‘Yes’ button and a ‘No’ button. (1)


GuiMessageBoxResult Enumeration

GuiMessageBoxResult Enumeration

Glossary Item Box

Description

SAP GUI Message Box Results

Members

Member | Value | Description
MSG_RESULT_CANCEL | 0 | Constant value to be used as a return value by the showMessageBox method. This value is returned when the ‘Cancel’ button has been pressed. (0)
MSG_RESULT_NO | 3 | Constant value to be used as a return value by the showMessageBox method. This value is returned when the ‘No’ button has been pressed. (3)
MSG_RESULT_OK | 1 | Constant value to be used as a return value by the showMessageBox method. This value is returned when the ‘OK’ button has been pressed. (1)
MSG_RESULT_YES | 2 | Constant value to be used as a return value by the showMessageBox method. This value is returned when the ‘Yes’ button has been pressed. (2)


GuiMessageBoxType Enumeration

GuiMessageBoxType Enumeration

Glossary Item Box

Description

SAP GUI Message Box Types

Members

Member | Value | Description
MSG_TYPE_ERROR | 3 | Constant value to be used when calling the showMessageBox method. Using this value will display a stop sign as the message box icon. (3)
MSG_TYPE_INFORMATION | 0 | Constant value to be used when calling the showMessageBox method. Using this value will display the letter ‘i’ as the message box icon. (0)
MSG_TYPE_PLAIN | 4 | Constant value to be used when calling the showMessageBox method. Using this value will display no message box icon. (4)
MSG_TYPE_QUESTION | 1 | Constant value to be used when calling the showMessageBox method. Using this value will display a question mark as the message box icon. (1)
MSG_TYPE_WARNING | 2 | Constant value to be used when calling the showMessageBox method. Using this value will display an exclamation mark as the message box icon. (2)


GuiScrollbarType Enumeration

GuiScrollbarType Enumeration

Glossary Item Box

Members

Member | Value | Description
GuiScrollbarTypeHorizontal | 2 | Horizontal
GuiScrollbarTypeUnknown | 0 | Unknown
GuiScrollbarTypeVertical | 1 | Vertical


GuiTableSelectionType Enumeration

GuiTableSelectionType Enumeration

Glossary Item Box

Members

Member | Value | Description
MULTIPLE_INTERVAL_SELECTION | 2 | Several columns/rows can be selected. (2)
NO_SELECTION | 0 | No selection possible. (0)
SINGLE_SELECTION | 1 | One column/row can be selected. (1)


Getting Started - SAP GUI Scripting ROT Entry Helper

SAP GUI Scripting ROT Entry Helper
Introduction

Glossary Item Box


Project Overview

SAP GUI Scripting ROT Entry Helper
Project Overview

Glossary Item Box

Description

This is a helper library that contains just one object. It is used to allow COM clients to access a running SAP GUI process.

Classes

Class Module | Description
SapGuiAuto | This object is registered in the Windows Running Object Table whenever the SAP GUI main process saplogon.exe runs, assuming that SAP GUI Scripting is installed on the client PC.

Remarks

Some scripting languages do not allow accessing an entry in the Running Object Table. Even though they may offer a 'GetObject' function, this function will then only support accessing files in the file system or creating COM objects using the COM progid. In this case you need to start by creating another helper object, CSapROTWrapper, which in turn allows you to access the ROT entry for SAP GUI.


Getting Started - SAP GUI Scripting ROT Entry Helper

SAP GUI Scripting ROT Entry Helper
Getting Started

Glossary Item Box


SapGuiAuto Object

SAP GUI Scripting ROT Entry Helper
SapGuiAuto Object
See Also Members

Glossary Item Box

Description

This object is registered in the Windows Running Object Table whenever the SAP GUI main process saplogon.exe runs, assuming that SAP GUI Scripting is installed on the client PC.

Object Model

SapGuiAuto Object

See Also

SapGuiAuto Members


SapGuiAuto Object Members

SAP GUI Scripting ROT Entry Helper
SapGuiAuto Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method GetScriptingEngine This method returns the GuiApplication COM interface for the currently running SAP GUI process.

See Also

SapGuiAuto Object


GetScriptingEngine Method

SAP GUI Scripting ROT Entry Helper
GetScriptingEngine Method
See Also Example
SapGuiAuto Object : GetScriptingEngine Method

Glossary Item Box

Description

This method returns the GuiApplication COM interface for the currently running SAP GUI process.

Syntax

Visual Basic
Public Function GetScriptingEngine() As Object

Return Type

GuiApplication

Example

Retrieving the GuiApplication interface from the ROT:
Visual Basic Script (Visual Basic) Copy Code
Set SapGuiAuto  = GetObject("SAPGUI")
Set application = SapGuiAuto.GetScriptingEngine
WinBatch by Wilson WindowWare (Visual Basic) Copy Code
SapGuiAuto = ObjectGet("SAPGUI");
Application = SapGuiAuto.GetScriptingEngine;

See Also

SapGuiAuto Object | SapGuiAuto Members


Getting Started - SAP GUI Scripting ROT Access Helper

SAP GUI Scripting ROT Access Helper
Introduction

Glossary Item Box


Project Overview

SAP GUI Scripting ROT Access Helper
Project Overview

Glossary Item Box

Description

This library contains just one object. It is required in cases where the scripting engine does not allow accessing entries in the Running Object Table. This is for example the case for the following engines

  • JAWS script, the scripting language of the JAWS Screenreader, by Freedom Scientific
  • AutoIt, a freeware Windows automation language

For these languages you need to create a CSapROTWrapper object first, before you can access the ROT entry and get the GuiApplication interface of the running SAP GUI process.

Classes

Class Module | Description
CSapROTWrapper | SapROTWrapper Class


Getting Started - SAP GUI Scripting ROT Access Helper

SAP GUI Scripting ROT Access Helper
Getting Started

Glossary Item Box


CSapROTWrapper Object

SAP GUI Scripting ROT Access Helper
CSapROTWrapper Object
See Also Members

Glossary Item Box

Description

SapROTWrapper Class

Object Model

CSapROTWrapper Object

See Also

CSapROTWrapper Members


CSapROTWrapper Object Members

SAP GUI Scripting ROT Access Helper
CSapROTWrapper Object Members
See Also Overview

Glossary Item Box

Public Methods

Public Method GetROTEntry This method returns the ROT entry of SAP GUI.

See Also

CSapROTWrapper Object


GetROTEntry Method

SAP GUI Scripting ROT Access Helper
GetROTEntry Method
See Also Example
strDisplayName
This parameter must have the value "SAPGUI". Any other value returns an error.
CSapROTWrapper Object : GetROTEntry Method

Glossary Item Box

Description

This method returns the ROT entry of SAP GUI.

Syntax

Visual Basic
Public Function GetROTEntry( _
   ByVal strDisplayName As String _
) As Object

Parameters

strDisplayName
This parameter must have the value "SAPGUI". Any other value returns an error.

Example

Accessing the GuiApplication interface for the running SAP GUI process from AutoIt
AutoIt (Visual Basic) Copy Code
Dim $Wrapper     = ObjCreate ("SapROTWr.SapROTWrapper")
Dim $RotSAPGUI   = $Wrapper.GetROTEntry ("SAPGUI")
Dim $Application = $RotSAPGUI.GetScriptingEngine()
Accessing the GuiApplication interface for the running SAP GUI process from JAWS
JAWS Script (Visual Basic) Copy Code
Object Wrapper,
  Object RotSAPGUI,
  Object SAPGUI

  Let Wrapper   = CreateObject ("SapROTWr.SapROTWrapper")
  Let RotSAPGUI = Wrapper.GetROTEntry ("SAPGUI")
  Let SAPGUI    = RotSAPGUI.GetScriptingEngine
Accessing the GuiSession interface for the running SAP GUI process from a Yahoo widget
Yahoo Widget (Visual Basic) Copy Code
var Wrapper        = COM.createObject("SapROTWr.SapROTWrapper");
var SapGuiAuto     = Wrapper.GetROTEntry("SAPGUI");
var GuiApplication = SapGuiAuto.GetScriptingEngine();
var GuiConnection  = GuiApplication.OpenConnection( "My System" );
var AllSessions    = GuiConnection.Children;
var GuiSession     = AllSessions.ElementAt(0);
alert("Session: " + GuiSession.Id);

See Also

CSapROTWrapper Object | CSapROTWrapper Members


References

References

Glossary Item Box


Using CreateObject

Using CreateObject

Glossary Item Box

Description

You can instantiate a SAP GUI application object using CreateObject.

Source code

Rem Create the GuiApplication object
Set Application = CreateObject("Sapgui.ScriptingCtrl.1")

Rem Open a connection in synchronous mode
Set Connection  = Application.OpenConnection("U9C [PUBLIC]", True)
Set Session     = Connection.Children(0)

Rem Do something: Either fill out the login screen
Rem or in case of Single-Sign-On start a transaction.
Session.SendCommand("/nbibs")

MsgBox "Waiting..."

Rem Shutdown the connection
Set Session     = Nothing
Connection.CloseSession("ses[0]")
Set Connection  = Nothing

Rem Wait a bit for the connection to be closed completely
Wscript.Sleep 1000
Set Application = Nothing

MsgBox "Done"


Using GetObject

Using GetObject

Glossary Item Box

Description

You can attach to a running instance of SAP GUI through the Running Object Table.

Source code

Rem Get the application object from the Running Object Table
Set rotEntry  = GetObject("SAPGUI")
Set application = rotEntry.GetScriptingEngine

Rem Get the first session of the first connection
Rem You may have to adjust this to access a different session
Set connection = application.Children(0)
Set session    = connection.Children(0)

Rem Start a transaction
session.findById("wnd[0]/tbar[0]/okcd").text = "/nbibs"
session.findById("wnd[0]").sendVKey 0


References

SAP GUI Scripting ROT Entry Helper
References

Glossary Item Box


References

SAP GUI Scripting ROT Access Helper
References

Glossary Item Box