 Frontend Editor (Source Code Mode - New)

Frontend Editor (Source Code Mode - New)

Einsatzmöglichkeiten

Der neue Frontend Editor ersetzt den bisherigen Frontend Editor.

Er hat eine moderne Benutzungsoberfläche und lässt sich vollständig an die Bedürfnisse des Programmierers anpassen.

Der neue Editor ist integriert in Transaktionen wie die ABAP Workbench (Transaktion SE80), den Function Builder (Transaktion SE37), den Report Builder (Transaktion SE38) und den Class Builder (Transaktion SE24). Er erweitert den alten Editor um die Funktionen eines modernen Programmierwerkzeugs.

Der Frontend Editor vereint alle modernen Bearbeitungsfunktionen für Programmcode in einem Werkzeug. Er ist ein universelles Programmierwerkzeug und funktioniert mit den meisten Programmiersprachen, die ein definiertes Syntaxschema aufweisen, wie etwa ABAP, eCATT, BSP usw. Es ist schnell, flexibel und einfach in der Handhabung.

Der Frontend Editor ist mit SAP GUI für Windows 6.40, Patch Level 10 oder höher verfügbar. Um jedoch den Editor in die ABAP Workbench integrieren und alle verwandten Transaktionen verwenden zu können, benötigen Sie die geeignete SAP-System-Version. Die erste Version, die den neuen Editor unterstützt, ist SAP NetWeaver 2004s.

Siehe auch:

Frontend Editor starten

Hauptbild

Wichtigste Funktionen des Frontend Editors

Optioneneinstellungen


 Frontend Editor starten

Frontend Editor starten

Verwendung

Zum Starten des Frontend Editors führen Sie die unten beschriebenen Schritte durch.

Voraussetzungen

Sie haben sich an einem geeigneten SAP-System über die SAP-Anmeldung angemeldet. Sie haben einen der folgenden Transaktionscodes ausgeführt, um auf die ABAP Workbench zuzugreifen: SE80, SE38, SE24 oder SE37.

Vorgehensweise

...

1. Wählen Sie im Hauptmenü Hilfsmittel ® Einstellungen.

Das Bild für die benutzerspezifischen Einstellungen erscheint.

Benutzerspezifische Einstellungen

2. Wählen Sie auf diesem Bild das Register ABAP Editor, sofern ein anderes Register angezeigt wird.

3. Markieren Sie die Auswahltaste Frontend Editor (neu).

4. Wählen Sie [image] mit dem Quick-Info-Text Übernehmen (Enter), um die Transaktion zu starten.

Ergebnis

Der neue Frontend Editor erscheint; Sie können mit der Arbeit beginnen.


 Hauptbild

Hauptbild

Definition

Dies ist ein Überblick, der Ihnen das Hauptbild des Frontend Editors näher bringt.

Die nachfolgende Abbildung zeigt Ihnen das Editor-Hauptbild:

Hauptbild des Frontend Editors

Struktur

In dem voran stehenden Bild sehen Sie folgende Bereiche des Editors:

● Indikatorspalte – beige-farbener Bereich auf der linken Seite des Bildes

● Lesezeichen für schnelle Navigation – ein blaues Fähnchen mit einer Nummer daneben

● Breakpoint – ein rotes Stoppzeichen hinter einem kleinen blauen Bildschirm

● Zeilennummern-Spalte – Bereich neben der Indikatorspalte

● Indikator für Änderungen – ein rotes Dreieck, das auf Änderungen aufmerksam macht

● Expandieren-/Komprimieren-Indikator – ein quadratischer Indikator mit einem Plus oder Minus zum Expandieren bzw. Komprimieren einer Struktur

● Aktive Statusleiste – unterer Bereich, in dem Sie Ihren aktuellen Status sehen können

● Einstellungen-Symbol – Quick Link zu Funktionseinstellungen

● Code-Hinweis Quick-Info – zum Vorschlagen von Code-Templates

● Blättern Quick-Info – gibt Informationen zur aktuellen Blätterposition

● Fenster-Teilungslinie – eine sichtbare Linie, die den Bildschirm in zwei Anzeigebereiche teilt


 Wichtigste Funktionen des Frontend Editors

Wichtigste Funktionen des Frontend Editors

Verwendung

Der Frontend Editor stellt ABAP-Programmierern eine voll funktionsfähige Entwicklungsumgebung zur Verfügung.

Er unterstützt alle modernen Programmiertechniken wie die Hervorhebung von Sprachsyntax, das Skizzieren von Sprachstrukturen, Echtzeit-Codinghilfen und automatisch Vervollständigung von Sprachstrukturen und -elementen.

Funktionalität

Der Frontend Editor besitzt eine funktionale Hülle, in deren Schutz benutzerdefinierte Quelltextvorlagen angelegt und ausgeführt werden können; sie bietet Editorvariablen und interaktive Elemente an, mit denen sich die Entwicklung beschleunigen lässt und Zeit und Kosten eingespart werden können.

Der Frontend Editor unterstützt weit reichende Formatierfunktionen und erhöht die Interaktivität des Programmierens in Echtzeit. Er erweitert dadurch die vom bisherigen Frontend Editor und vom Backend Editor zur Verfügung gestellte Funktionalität erheblich: Automatische Code-Einrückung, Smart Tabs, automatische Klammerung, automatische Korrektur von Tippfehlern und fehlerhafter Groß-/Kleinschreibung.

Der Frontend Editor unterstützt Farbdruck mit Druckvorschau, die entsprechenden WYSIWYG-Standards, die das Anlegen von Dokumentation erleichtern, und das Verständnis komplexer Programmlisten.

Siehe auch:

Anzeigefunktionen

Bearbeitungsfunktionen

Zwischenablage

Suchen und Ersetzen

Navigation

Drucken

Export-Funktionen

Tastenkombinationen

XML-Einstellungen

Optioneneinstellungen


 Anzeigefunktionen

Anzeigefunktionen

Verwendung

Hier werden die unterschiedlichen Anzeigefunktionen und ihre Verwendung im Editor beschrieben. Sie finden diese Funktionen auf dem Hauptbild des Editors, wenn Sie das Coding schreiben.

Funktionen

Der Frontend Editor unterstützt diverse Anzeigeeinstellungen:

● Indikator für geänderte Zeilen

Diese Funktion zeigt Ihnen, welche Teile des Codings während der aktuellen Sitzung geändert wurden und welche gesichert wurden. Sie können damit auch fehlerhaftes Coding oder Coding, das von einem anderen Entwickler angelegt wurde, ändern.

● Zeilennummern

Diese Funktion unterstützt Sie bei der Navigation im Coding. Damit können Sie umgebrochene Zeilen erkennen, wenn Sie im Umbruchmodus arbeiten.

Sie können Indikatoren, Zeilennummern und Umrissränder verbergen oder anzeigen, je nach Größe des verfügbaren horizontalen Raumes.

● Geschützte Bereiche

Über diese Funktion können Sie Teile des Dokuments als schreibgeschützt definieren. Diese Teile werden dann in einer bestimmten Farbe und mit einem zusätzlichen Symbol in der Spalte für geänderte Zeilen angezeigt

● Hervorhebung der aktuellen Zeile

Diese Funktion zeigt Ihnen die aktuelle Cursorposition im Dokument.

● Alle Zeichen

Mit dieser Funktion machen Sie alle verborgenen Symbole sichtbar, wie Leerzeichen, Tabulatoren und Zeilenumbrüche.

● Vertikale und horizontale Blätterleisten

Sie können sowohl vertikale als auch horizontale Blätterleisten anzeigen oder verbergen.

● Indikator für Seitenbreite

Mit dieser Funktion können Sie die Seitenbreite zur Prüfung der Länge Ihrer Zeilen verwenden, um zu sehen, ob sie innerhalb eines definierten Bereichs liegen.

● Strukturseparatoren

Diese Funktion zeigt Ihnen, wo hochrangige Strukturen enden (Funktion, Unterroutine, Klasse, Methode usw.). Sie trennt sie voneinander und erleichtert so die Navigation.

Der Frontend Editor unterstützt weitere Anzeigefunktionen.

Weitere Informationen finden Sie unter:

Kontextmenü

Aktive Statusleiste

Aussehen von Mauszeiger, Cursor und Textcursor

Fenster-Teilungslinien

Breakpoints

Anzeigeoptionen


 Kontextmenü

Kontextmenü

Verwendung

Über Kontextmenüs führen Sie die einzelnen Aktionen aus, wenn Sie Code schreiben. Im folgenden werden die Kontextmenüs beschrieben, die im Frontend Editor verfügbar sind.

Funktionen

Es gibt zwei Menüs, die erscheinen, wenn Sie mit der sekundären Maustaste auf der grafischen Oberfläche klicken; die Liste der darin angebotenen Optionen richtet sich dabei nach dem Kontext der Aktionen und den ausgewählten Bereichen.

...that has the following list

● Kontextmenü Indikatorspalte

Wird am linken Rand angezeigt. Um das Kontextmenü zu öffnen, positionieren Sie den Mauspfeil auf die Indikatorspalte und klicken mit der sekundären Maustaste.

Sie sehen dann folgendes Bild:

Kontextmenü Indikatorspalte

● Kontextmenü Bildinhalt

Wird im übrigen Editorbild angezeigt. Um das Kontextmenü zu öffnen, positionieren Sie den Mauspfeil auf das Hauptbild des Editors und klicken mit der sekundären Maustaste.

Sie sehen dann folgendes Bild:

Kontextmenü Bildinhalt


 Aktive Statusleiste

Aktive Statusleiste

Verwendung

Mit der aktiven Statusleiste führen Sie unterschiedliche Aktionen aus, wie das Umschalten zu Groß- oder Kleinschreibung, das Kopieren des Dokumentnamens in die Zwischenablage (Clipboard) usw. Die Verwendungsmöglichkeiten der aktiven Statusleiste im Frontend Editor werden hier beschrieben.

Funktionen

Sie finden die aktive Statusleiste am unteren Rand des Editorbildes. Die einzelnen Bereiche in der aktiven Statusleiste zeigen den Status der Modi CapsLock (Umschaltsperre), NumLock (Nummernblocksperre) und OVR (Überschreiben) an. Sie können jeden Modus durch einen Doppelklick oder über die Tastatur ändern.

● Gehe zu Zeile

Diesen Dialog rufen Sie durch Doppelklick auf den Positionsbereich auf.

● Caps Lock (Umschaltsperre)

Sie können die Umschaltsperre (von Groß- auf Groß-/Kleinschreibung) durch Doppelklick auf den Bereich CAP ein und aus schalten.

● Num (Nummernblocksperre)

● Sie können die Nummernblocksperre durch Doppelklick auf den Bereich NUM ein und aus schalten.

● Kopieren in Clipboard

Sie können den Namen des Dokuments durch Doppelklick auf den Bereich mit dem Dokumentnamen in die Zwischenablage (Clipboard) kopieren.

● Einfügemodus

Sie schalten den Textcursor durch Doppelklick auf den Bereich OVR auf Einfügemodus um. Der Bereich ändert seine Bezeichnung dann auf INS.

● Überschreibemodus (Overwrite)

Sie schalten den Textcursor durch Doppelklick auf den Bereich INS auf Überschreibemodus um. Der Bereich ändert seine Bezeichnung dann auf OVR.

● Optioneneinstellungen

Sie öffnen den Optionen-Dialog über [image].

Sie sehen dann ein Bild ähnlich dem folgenden:

Aktive Statusleiste


 Aussehen von Mauszeiger, Cursor und Textcursor

Aussehen von Mauszeiger, Cursor und Textcursor

Verwendung

Sie können sehen, wie sich das Aussehen der Mauszeiger, Cursor und Textcursor ändert, wenn Sie im Editor unterschiedliche Optionen wählen.

Funktionen

Der Editor zeigt Mauszeiger, Cursor und Textcursor beim Überschreiben, Einfügen, interaktiven Suchen und bei Blockauswahl unterschiedlich an, wodurch Sie sofort erkennen können, in welchem Operations- oder Ausführungsmodus Sie sich gerade befinden.

Mauszeiger

● Fernglas mit Zeigepfeil

Wenn Sie Inkrementell suchen wählen, verändert der Mauszeiger sein Aussehen zu einem Fernglas mit einem nach unten zeigenden Pfeil.

● Kreuzzeiger

Wenn Sie einen Block auswählen, verändert der Zeiger sein Aussehen zu einem Kreuzzeiger.

● Zweiseitiger Pfeil

Wenn Sie den Mauszeiger im Bereich der Fenster-Teilungslinie bewegen, verändert er sein Aussehen zu einem zweiseitigen Pfeil.

Aussehen des Textcursors

Der Textcursor kann mehrere Formen annehmen.

● Dicker vertikaler schwarzer Balken

In dieser Form sehen Sie den Textcursor, wenn Sie sich im Überschreibemodus (OVR) befinden. Er blinkt an der Stelle im Coding, an die Sie ihn gestellt haben. Im Modus OVR können Sie an der Position des Textcursors Text überschreiben und die Zeichen löschen.

Sie sehen dann ein Bild ähnlich dem folgenden:

Dicker vertikaler schwarzer Balken

● Vertikaler Strich

In dieser Form sehen Sie den Textcursor, wenn Sie sich im Einfügemodus (INS) befinden. Er blinkt an der Stelle im Coding, an die Sie ihn gestellt haben. Im Modus INS können Sie Text zwischen Zeichen einfügen, ohne diese dabei zu löschen.

Sie sehen dann ein Bild ähnlich dem folgenden:

Vertikaler Strich

Sie können zwischen diesen beiden Textcursor-Modi wechseln, indem Sie den gewünschten Modus aus der aktiven Statusleiste auswählen.


 Fenster-Teilungslinie

Fenster-Teilungslinie

Verwendung

Die Fenster-Teilungslinie hilft Ihnen dabei, gleichzeitig mit unterschiedlichen Teilen des Dokuments zu arbeiten.

Die Verwendungsmöglichkeiten der Fenster-Teilungslinie im Frontend Editor werden hier beschrieben.

Funktionen

Sie stellen den Editor durch Doppelklick auf die Teilungslinie auf den Fenster-Teilungsmodus um; die Teilungslinie finden Sie am oberen Ende der vertikalen Blätterleiste. Sie können sie auch herunter ziehen, um sie im Vollmodus zu sehen. Schließen können Sie den Teilungsmodus durch Doppelklick auf die Teilungslinie.

Sie sehen dann folgendes Bild:

Horizontale Teilung


 Breakpoints

Breakpoints

Verwendung

Im folgenden werden die im Frontend Editor verwendeten Breakpoints beschrieben.

Funktionsumfang

Um einen neuen Breakpoint hinzuzufügen, klicken Sie in der Indikator-Spalte neben die Zeile, in der der Breakpoint stehen soll. Es erscheint ein ovales rotes Stoppschild mit einem kleinen blauen Bildschirm, das die Position des Breakpoints kenntlich macht:

Breakpoint

Um einen Breakpoint aus dem Coding herauszunehmen, klicken Sie ihn mit der primären Maustaste an.


 Anzeigeoptionen

Anzeigeoptionen

Verwendung

Sie können das Aussehen Ihres Codings ändern. Nehmen Sie dazu die entsprechenden Einstellungen in den Bereichen Anzeigen und Zeilenumbruch vor. Sie können je nach Bedarf alle Anzeige- und Zeilenumbruchsoptionen ein- oder ausschalten.

● Der Bereich Anzeigen bietet Funktionen, mit denen Sie je nach Aufgabe Ihre Arbeit übersichtlich und klar darstellen können.

● Der Bereich Zeilenumbruch bricht eine Zeichenkette bei einer angegebene Anzahl Zeichen um. Sie sehen dann ein entsprechendes Umbruchsymbol auf der rechten Seite des Editorbilds. Außerdem erkennen Sie Zeilenumbrüche daran, dass das umgebrochene Zeilenstück keine Zeilennummer hat.

Integration

Mit diesen Optionen müssen Sie Ihre Coding-Umgebung einstellen, ehe Sie mit der Arbeit beginnen. Sie können die Optionen natürlich bei Bedarf auch während der Arbeit ändern. Um das Register Optionen zu öffnen, wählen Sie [image] rechts unten auf dem Editorbild.

Voraussetzungen

Sie haben den Dialog Options geöffnet. Sie haben die Option Anzeigen gewählt.

Sie sehen dann ein Bild ähnlich dem folgenden:

Anzeigen

Funktionen

Anzeigen

● Indikatorspalte

Diese Funktion liefert Ihnen sichtbare Anhaltspunkte für bestimmte Aktionen wie z.B. Breakpoints, während Sie Ihr Coding bearbeiten. Sie erscheint am linken Rand in der Code-Sicht. Über das entsprechende Ankreuzfeld können Sie die Indikatorspalte anzeigen oder verbergen.

● Zeilennummern

Diese Funktion zeigt Ihnen Nummern neben jeder Textzeile an. Das ist nützlich, wenn Sie sich auf bestimmte Zeilen im Coding beziehen müssen. Wenn Sie diese Option aktivieren, erscheinen die farbigen Zeilennummern am linken Rand des Editorbildes neben der Indikatorspalte.

● Geänderte Zeilen

Mit dieser Funktion können Sie alle kürzlich am Coding vorgenommenen Änderungen verfolgen. Wenn Sie Änderungen am Coding vornehmen, erscheinen rote Dreiecke als Änderungsindikatoren am linken Rand des Editorbildes neben den Zeilennummern. Außerdem erscheinen hellrote Dreiecke am linken Rand des Editorbildes, wenn Änderungen durchgeführt und gesichert wurden.

● Block-Komprimierung

Mit dieser Funktion können Sie einen Block im Coding anzeigen oder verbergen. Sie erscheint auf der linken Seite des Editorbilds neben der Indikatorspalte. Sie öffnen und schließen Blöcke, indem Sie auf das kleine Quadrat mit dem Plus- oder Minuszeichen klicken.

● Seitenbreite

Diese Funktion definiert die Breite Ihrer Coding-Seite. Sie sehen dann, wenn eine Zeile die eingestellte Maximalzeilenlänge überschreitet. Diese Funktion ist auch hilfreich, um zu sehen, wo Zeilenumbruch nach Spaltenanzahl und einem fest eingestellten Zeilenumbruch ausgeführt werden.

● Strukturtrenner

Diese Funktion liefert Ihnen einen Anhaltspunkt dafür, wo es sinnvoll ist, das Coding zu unterteilen. Nach manchen Sprachblöcken (z.B. Form .... EndForm) wird die Trennung automatisch eingefügt. Aktivieren Sie diese Option, dann ist der Trenner aktiv.

● Leerzeichen

Mit dieser Funktion können Sie alle Leerstellen innerhalb Ihres Codings aufspüren. Wenn Sie diese Option aktivieren, erscheinen alle Formatierungsmasken wie Tabulatorzeichen, Absatzmarken und verborgener Text im Coding.

● Vertikale Bildlaufleiste

Mit dieser Funktion können Sie vertikal in Ihrem Coding blättern. Wenn Sie diese Option aktivieren, erscheint die Vertikale Bildlaufleiste auf der rechten Seite des Editorbildes.

● Horizontale Bildlaufleiste

Mit dieser Funktion können Sie horizontal in Ihrem Coding blättern. Wenn Sie diese Option aktivieren, erscheint die Horizontale Bildlaufleiste am unteren Rand des Editorbildes.

Wenn Zeilenumbruch an Fensterrandaktiviert ist, sehen Sie diese Leiste nicht. Blätterleisten werden nicht angezeigt, wenn die Maximallänge des Texts oder die Anzahl der Zeilen kleiner ist als die Fenstergröße.

● Die Statusleiste ist der Bereich am unteren Rand des Editorbildes. Sie kann unterschiedliche Informationen anzeigen. Mit dieser Funktion können Sie die aktuelle Umgebung, die aktiven Sprachen, die Position des Cursors sowie CapsLock- und NumLock-Modus sehen. Wenn Sie diese Option aktivieren, erscheint die Statusleiste am unteren Rand des Editorbildes.

● Aktuelle Zeile hervorheben

Mit dieser Funktion heben Sie die Zeile hervor, in der sich der Cursor befindet. Sie können die Farben des Vordergrunds (Text) und des Hintergrunds ändern. Wenn Sie diese Option aktivieren, wird die aktuelle Zeile in einer anderen Farbe angezeigt.

● Gleichmäßiges Blättern

Diese Funktion ermöglicht eine bestimmte Art des Blätterns, um Inhalte in einer vorher festgelegten Geschwindigkeit anzuzeigen. Wenn Sie diese Option aktivieren, können Sie sich durch einfaches Vor- und Zurückblättern schnell und bequem durch Ihr Coding bewegen.

Zeilenumbruch

● Zeilenumbruch deaktivieren

Mit dieser Funktion deaktivieren Sie den Zeilenumbruch. Coding-Zeilen passen nicht ins Editorfenster.

● Umbruch an Fensterrand

Mit dieser Funktion werden die Coding-Zeilen an die Fenstergröße des Editors angepasst.

● Umbruch nach Seitenbreite

Mit dieser Funktion können Sie die Breite einer Zeile auf eine bestimmte Spaltenanzahl begrenzen.

● Fester Zeilenumbruch nach Spaltenanzahl

Mit dieser Funktion setzen Sie einen festen Zeilenumbruch nach einer bestimmten Spaltenanzahl.

Seitenbreite

Mit dieser Funktion wählen Sie eine Zahl für die maximale Zeilenlänge aus der Zahlenliste. Wenn Sie eine bestimmte vordefinierte Zahl wählen, erscheinen die Zeichen, die Sie in einer Zeile eingeben, bis zur ausgewählten Zahl.


 Bearbeitungsfunktionen

Bearbeitungsfunktionen

Verwendung

Der Frontend Editor unterstützt eine Reihe nützlicher Bearbeitungsfunktionen. Diese Funktionen werden hier im Detail beschrieben. Wie Sie eine Funktion auswählen, sehen Sie auf der nachfolgenden Abbildung.

Funktionen

Sie können alle nachstehend aufgeführten Funktionen aufrufen, indem Sie im Coding die sekundäre Maustaste betätigen und im Kontextmenü die entsprechende Funktion auswählen.

● Rückgängig/Wiederherstellen

Mit dieser Funktion zeigen Sie den letzten Befehl in der aktuellen Zeile an. Die jeweils letzten Änderungen im Coding werden im Clipboard abgelegt.

○ Mit Rückgängig machen Sie die letzte Aktivität aus dem Clipboard rückgängig. Wählen Sie dazu Rückgängig aus dem Kontextmenü Bildinhalt.

○ Mit Wiederherstellen wiederholen Sie die letzte Aktivität. Wählen Sie dazu Wiederherstellen aus dem Kontextmenü Bildinhalt.

● Ausschneiden

Mit dieser Funktion löschen Sie einen ausgewählten Text aus der aktuellen Zeile. Wenn Sie einen Text auswählen, können Sie ihn über Ausschneiden im Kontextmenü Bildinhalt ausschneiden.

● Kopieren

Mit dieser Funktion stellen Sie einen ausgewählten Text aus dem Coding in das Clipboard. Wenn Sie einen Text auswählen, können Sie ihn über Kopieren im Kontextmenü Bildinhalt kopieren.

● Einfügen

Mit dieser Funktion holen Sie den zuletzt abgelegten Inhalt aus dem Clipboard und fügen ihn an einer bestimmten Position im Coding ein. Wählen Sie dazu Einfügen aus dem Kontextmenü Bildinhalt.

● Löschen

Mit dieser Funktion löschen Sie einen ausgewählten Text aus dem Coding. Wählen Sie dazu Mehr ® Löschen aus dem Kontextmenü Bildinhalt.

● Alles auswählen

Mit dieser Funktion markieren Sie den gesamten Text im Coding. Wählen Sie dazu Mehr ® Alles auswählen aus dem Kontextmenü Bildinhalt.

● Kopieren und anhängen

Diese Funktion bietet eine weitere Möglichkeit des intuitiven Kopierens und Einfügens.

Sie wählen mit dem Mauszeiger einen Teil des Codings aus und verschieben den ausgewählten Text an eine bestimmte Position. Dann lassen Sie ihn an der gewünschten Stelle im Coding los und fügen ihn so ein. Sie können einen Text mit der Funktion Drag&Drop auch von einer Stelle an eine andere kopieren; halten Sie dazu gleichzeitig die Taste Strg gedrückt.

● Datum/Zeit in unterschiedlichen Formaten einfügen

Mit dieser Funktion können Sie Datum- und Zeitangaben im Coding einfügen.

Wählen Sie dazu Mehr ® Einfügen Spezial aus dem Kontextmenü Bildinhalt.

● Kopieren und anhängen / Ausschneiden und anhängen

Mit diesen Funktionen können Sie Text aus dem Coding ausschneiden oder kopieren, um ihn im Clipboard abzulegen.

Um die Kopierfunktion Kopieren und anhängen zu verwenden, wählen Sie Mehr ® Kopieren und anhängen aus dem Kontextmenü Bildinhalt.

Um die Ausschneidefunktion Ausschneiden und anhängen zu verwenden, wählen Sie Mehr ® Ausschneiden und anhängen aus dem Kontextmenü Bildinhalt.

● Zeile kopieren

Mit dieser Funktion können Sie eine ausgewählte Zeile aus dem Coding kopieren, um sie im Clipboard abzulegen.

Wählen Sie dazu Mehr ® Zeile ® Kopieren aus dem Kontextmenü Bildinhalt.

● Zeile ausschneiden

Mit dieser Funktion schneiden Sie eine ausgewählte Zeile aus, stellen Sie ins Clipboard und löschen sie damit gleichzeitig aus dem Coding.

Wählen Sie dazu Mehr ® Zeile ® Ausschneiden aus dem Kontextmenü Bildinhalt.

● Zeile löschen

Mit dieser Funktion löschen Sie eine ausgewählte Zeile aus dem Coding.

Wählen Sie dazu Mehr ® Zeile ® Löschen aus dem Kontextmenü Bildinhalt.

● Zeile umsetzen

Mit dieser Funktion verschieben Sie eine ausgewählte Zeile im Coding um eine Zeile höher.

Wählen Sie dazu Mehr ® Zeile ® Umsetzen aus dem Kontextmenü Bildinhalt.

● Zeile duplizieren

Mit dieser Funktion stellen Sie eine Kopie der ausgewählten Zeile aus dem Coding her. Diese Kopie erscheint direkt anschließend an die Originalzeile.

Wählen Sie dazu Mehr ® Zeile ® Duplizieren aus dem Kontextmenü Bildinhalt.

● Zeile nach oben verschieben

Mit dieser Funktion verschieben Sie einen ausgewählten Text um eine Zeile nach oben.

Wählen Sie dazu Mehr ® Zeile ® Nach oben aus dem Kontextmenü Bildinhalt.

● Zeile nach unten verschieben

Mit dieser Funktion verschieben Sie einen ausgewählten Text um eine Zeile nach unten.

Wählen Sie dazu Mehr ® Zeile ® Nach unten aus dem Kontextmenü Bildinhalt.

Kontextmenü zur Auswahl der Bearbeitungsfunktionen

Der Frontend Editor unterstützt weitere Bearbeitungsfunktionen.

Weitere Informationen finden Sie unter:

Blockauswahl

Automatischer Klammer- und Strukturabgleich

Schriftarten und Farben

Code-Hinweise einfügen

Code-Vervollständigung

Format

Benutzerdefinierte Code-Vorlagen


 Blockauswahl

Blockauswahl

Verwendung

Im Folgenden wird die im Frontend Editor unterstützte Blockauswahl beschrieben.

Funktionsumfang

Die meisten allgemeinen Aktionen, die mit einer normalen Auswahl (Markierung) durchgeführt werden (kopieren, einfügen, einrücken usw.), stehen auch für die Blockauswahl zur Verfügung.

Um einen Block auszuwählen und zu markieren, verwenden Sie eine Kombination aus dem Hotkey ALT+ und dem Mauszeiger, wie in der folgenden Abbildung gezeigt. Wenn Sie ALT+ drücken, sehen Sie, wie sich der Mauszeiger von einem Pfeil in ein Kreuz verwandelt.

Blockauswahl


 Automatischer Klammer- und Strukturabgleich

Automatischer Klammer- und Strukturabgleich

Verwendung

Hier wird der automatische Klammer- und Strukturabgleich im Frontend Editor beschrieben.

Funktionsumfang

Durch Doppelklick auf ein Offen-/Geschlossen-Strukturkennzeichen gelangen Sie auf das entsprechende Offen-/Geschlossen-Kennzeichen im Dokument. Durch Doppelklick auf das Schlüsselwort CASE bei gleichzeitigem Drücken der Taste ALT springen Sie automatisch zur WHEN-Klausel. Durch Doppelklick auf das Schlüsselwort WHEN bei gleichzeitigem Drücken der Taste CTRL (STRG) springen Sie automatisch zurück zur CASE-Anweisung. Die nachstehende Abbildung zeigt als Beispiel einen Strukturabgleich für if/endif case/when/endcase:

Laufzeit-Hervorhebung abgeglichener Strukturen beim Tippen

Die aktuelle Bereichsfunktion zeigt Ihnen den aktuellen Klammer- und Hierarchiebereich während Sie durch das Coding blättern und hebt aktive Klammerpaare und Strukturen hervor. Die aktuelle Bereichsfunktion ermöglicht auch die Hervorhebung von Fehlern (in rot) durch falsche Klammerung, wie im nachfolgenden Bild gezeigt.

Laufzeit-Hervorhebung falscher Klammersetzung

Der automatisch Klammerabgleich gibt Ihnen eine sofortige Rückmeldung im Fall falsch gesetzter Klammern oder offen gelassener Coding-Segmente. Der automatische Klammerabgleich erkennt alle Arten von Klammern, Anführungszeichen und Strukturen, die in der Sprachenspezifikation definiert sind. Wenn Sie eine schließende Klammer eingeben, werden sowohl diese Klammer als auch das entsprechende Gegenstück solange hervorgehoben, bis Sie eine andere Taste drücken oder den Cursor bewegen; dasselbe gilt für offene/geschlossene Strukturen. Dadurch wird es sehr viel leichter, Coding-Blöcke zu identifizieren. Zusätzlich lassen sich so falsch gesetzte oder fehlende Klammern und Strukturen erkennen.


 Schriftarten und Farben

Schriftarten und Farben

Verwendung

Sie können die Schriftarten und Farben für Oberflächenelemente mit der Option Schriftarten und Farben so einstellen, wie es für Sie am sinnvollsten ist.

Integration

Sie können diese Optionen einstellen, ehe Sie mit der Arbeit beginnen, und sie bei Bedarf während des Arbeitens anpassen. Änderungen an Farben greifen noch während der Sitzung, in der Sie sie durchführen.

Voraussetzungen

Sie haben den Dialog Options geöffnet. Sie haben die Option Schriftarten und Farben gewählt.

Sie sehen die folgende Grafik:

Schriftarten und Farben

● Schriftart

Mit dieser Funktion können Sie unterschiedliche Schriftarten aus der Liste wählen. Sobald Sie eine bestimmte Schriftart wählen, erscheint der Text in dieser Schriftart.

● Größe

Mit dieser Funktion steuern Sie die Größe des Texts. Der Text erscheint sofort in der Größe, die Sie gewählt haben. Wenn Sie Strg gedrückt halten und gleichzeitig am Mausrad vor und zurück drehen, können Sie das Editorbild dadurch zoomen und die Schriftarten in unterschiedlichen Größen sehen.

● Nur nichtproportionale Schriftarten zeigen

Mit dieser Funktion stellen Sie Schriftarten ein, bei der alle Zeichen die gleiche Zeichenbreite haben. Wenn Sie diese Option gesetzt haben, sehen Sie in der Dropdown-Box Schriftart nur noch nichtproportionale Schriften.

Über die Auswahlspalte können Sie je eine Farbe aus den Dropdown-BoxenVordergrund und Hintergrund wählen. Dadurch ändern Sie die Farbe, in der die Auswahlspalte angezeigt wird.

Sie können jedes Element aus der Anzeigeliste Angezeigte Elemente unter der Dropdown-Box Nur nichtproportionale Schriftarten zeigen auswählen und dafür die Vorder- und Hintergrundfarbe über Vordergrund und Hintergrund setzen. Dabei haben Sie die Wahl zwischen automatischer oder Ihrer eigenen Farbgebung. Wenn Sie sich für eigene Farbgestaltung entscheiden, müssen Sie Ihre bevorzugte Farbe aus der Farbpalette auswählen und als eigene Farbe definieren. Eine andere Möglichkeit wäre es, aus der Liste eine verfügbare Farbe zu wählen.

● Muster

In dieser Box können Sie sehen, wie die ausgewählten Vorder- und Hintergrundfarben aussehen, ehe Sie die Änderungen für die ausgewählten Elemente abspeichern.

● Schriftstil

Über diese Ankreuzfelder können Sie den Text Fett, Kursiv und Unterstrichen anzeigen.


 Code-Hinweise einfügen

Code-Hinweise einfügen

Verwendung

Code-Hinweise helfen Ihnen zur Laufzeit, während Sie Eingaben vornehmen, mit Vorschlägen für Code-Vorlagen, Schlüsselwörtern, Methoden, Variablen usw.

Vorgehensweise

...

1. Wenn ein Code-Hinweis angezeigt wird, können Sie ihn mit der Tabulator-Taste oder Eingabetaste in Ihr Coding einfügen, ohne den Rest der Zeichen eingeben zu müssen.

Die folgende Grafik gibt ein Beispiel:

Code-Hinweise: Editor schlägt eine passende Vorlage vor

Code-Hinweise: Editor schlägt ein Schlüsselwort vor

Wird der Code-Hinweis schwarz auf weiß angezeigt, dann ist nur ein Vorschlag verfügbar.

Wird der Code-Hinweis weiß auf schwarz angezeigt, dann sind mehrere Vorschläge verfügbar.


 Code-Vervollständigung

Code-Vervollständigung

Verwendung

Sie verwenden diese Option des Frontend-Editors um Namen von Klassen, Methoden oder Variablen zu vervollständigen, die bei der Vervollständigung von Methodennamen sichtbar sind. Diese Funktion unterstützt auch die Vervollständigung von denjenigen Keywords, die im Dictionary verfügbar sind. Allgemein verwendete Namen für Felder und Variablen werden abhängig vom jeweiligen Typ vorgeschlagen. Die Vervollständigung funktioniert sogar dann, wenn Sie einen spezifischen Präfix für ein Feld oder eine Variable haben möchten.

Voraussetzungen

Sie haben den Dialog Options geöffnet. Sie haben die Option Code-Vervollständigung gewählt.

Sie sehen dann ein Bild ähnlich dem folgenden:

Code-Vervollständigung

Funktionen

● Aktuellen Block hervorheben

Mit dieser Funktion können Sie Informationen zum Block anzeigen. Wenn Sie diese Option aktivieren, erscheinen die Block-Informationen links von der Statusleiste.

● Quick-Info aktivieren

Diese Funktion zeigt die Klassen- oder Methoden-Block-Informationen an. Wenn Sie diese Option wählen, erscheint eine Quick-Info-Box, sobald Sie den Cursor über einen Block positionieren oder die Tastenkombination Strg+Umschalttaste+Leertaste betätigen.

○ Anzeigen bei platziertem Cursor für

Mit dieser Funktion können Sie Vorschläge zur Code-Vervollständigung anzeigen. Wenn Sie diese Funktion aktivieren, erscheint eine schwebende Quick-Info über dem Text während Ihrer Eingabe. Die Quick-Info verschwindet nach der Zeit, die Sie in Millisekunden im zugehörigen Einstellfeld msek definieren.

● Code-Hinweise aktivieren

Mit dieser Funktion können Sie Codevorschläge anzeigen lassen, die Ihnen helfen, den Code schneller zu vervollständigen. Wenn Sie diese Option aktivieren, erscheinen Code-Hinweise während Ihrer Eingabe.

○ Anzeigen nach Sichern von mindestens

Mit dieser Funktion können Sie angeben, wie viele Buchstaben eingegeben werden müssen, bevor der Hinweis erscheint. Sie können die Anzahl durch Auswahl einer Zahl im Feld Zeichen festlegen.

○ Automatisch ausblenden nach

○ Diese Funktion erlaubt es Ihnen, die Dauer der Anzeige von der Quick-Info anzugeben. Der Code-Hinweis verschwindet nach Verstreichen der Millisekunden, die Sie im zugehörigen Feld msek eingeben.

● Vervollständigung aktivieren

Diese Funktion erlaubt es Ihnen, einige Buchstaben/Wörter einzugeben, woraufhin die Editierkontrolle eine Dropdown-Box mit Vorschlägen zu Ihrer eingegeben Zeichenfolge öffnet.

○ Liste automatisch öffnen nach

Mit dieser Funktion können Sie eine Vervollständigungsliste nach Eingabe von -> öffnen.

Diese Funktion ist noch nicht implementiert. Weitere Informationen hierzu werden in Kürze bereitgestellt.

Dictionary

● Schlüsselwörter vorschlagen

Diese Funktion aktiviert Code-Hinweise und Vervollständigungslisten, die ABAP-Schlüsselwörter anzeigen.

● Nicht-Schlüsselwörter aus dem Text vorschlagen

Diese Funktion aktiviert Code-Hinweise und Vervollständigungslisten, die Nicht-ABAP-Schlüsselwörter anzeigen.


 Format

Format

Verwendung

Der Frontend Editor unterstützt eine Reihe nützlicher Funktionen, mit denen Sie den Text während des Programmierens formatieren können.

Funktionen

Sie können alle nachstehend aufgeführten Funktionen aufrufen, indem Sie im Coding mit der sekundären Maustaste klicken und die entsprechende Funktion im Kontextmenü auswählen.

● Selektion formatieren

Mit dieser Funktion formatieren Sie einen ausgewählten Block. Wählen Sie dazu Format ®Selektion formatieren

● Mit Vorlage umgeben

Mit dieser Funktion können Sie ausgewählten Text mit einer definierten Vorlage umgeben. Wählen Sie dazu Format ®Mit Vorlage umgeben

● Vorlage extrahieren

Mit dieser Funktion legen Sie Ihre eigene Vorlage an. Um eine Vorlage zu kopieren und in die Liste der vordefinierten Vorlagen auszunehmen, wählen SieFormat ® Vorlage extrahieren. Ein Dialog Add Code Template zum Hinzufügen der Code-Vorlage erscheint. Sie können eine Verknüpfung anlegen, eine Beschreibung angeben und die Vorlage auswählen, die Sie hinzufügen wollen.

● Zeilen kommentieren / Kommentar entfernen

○ Kommentieren

Mit dieser Funktion legen Sie einen Kommentar zu einer bestimmten Zeile im Coding an.

○ Kommentar entfernen

Mit dieser Funktion entfernen Sie einen Kommentar aus der Zeile.

Sie stellen diese Optionen ein, indem Sie Format ® Zeilen kommentieren bzw. Nicht-Kommentarzeilen wählen.

Sie können die Einstellungen auch über Strg + \ für Zeilen kommentieren und Strg + Umschalttaste + \ für Kommentar entfernen vornehmen.

● Selektion kommentieren / Kommentare in Selektion entfernen

○ Selektion kommentieren

Mit dieser Funktion legen Sie einen Kommentar zu einer Auswahl an.

○ Kommentare in Selektion entfernen

Mit dieser Funktion entfernen Sie den Kommentar.

Sie stellen diese Optionen ein, indem Sie Format ® Selektion kommentieren bzw. Kommentare in Selektion entfernen wählen.

● Zeileneinrückung vergrößern / Zeileneinrückung verringern

Mit dieser Funktion rücken Sie Zeilen im Coding um eine bestimmte Anzahl von Leerstellen ein.

Um die Zeile weiter ein- oder auszurücken, wählen Sie Format ® Zeileneinrückung vergrößern bzw. Zeileneinrückung verringern.

Sie können die Zeileneinrückung auch über die Tabulatortaste vergrößern und über Umschalttaste + Tabulatortaste verringern.

● Groß-/Kleinschreibung ändern

Mit dieser Funktion können Sie zwischen unterschiedlichen Groß-/Kleinschreibversionen wechseln.

Wählen Sie dazu Format ® Groß-/Kleinschreibung ändern.

Sie können auch mit folgenden Tastenkombinationen wechseln:

○ Strg + L für Kleinschreibung

○ Strg + U für Großschreibung

○ Strg + J für Erster Buchstabe groß

○ Strg + T für Anfangsbuchstabe groß

○ Strg + K für Groß-/Kleinschreibung wechseln

● Zeilen verbinden

Mit dieser Funktion verbinden Sie die Texte von zwei oder mehr Zeilen.

Wählen Sie dazu Format ® Zeilen verbinden.

● Zeilen sortieren

Mit dieser Funktion wählen Sie Zeilen in Ihrem Quelltext aus und sortieren sie alphabetisch.

Wählen Sie dazu Format ® Zeilen sortieren.

Kontextmenü zur Formatierung

Der Frontend Editor unterstützt weitere Formatierungsfunktionen.

Weitere Informationen hierzu finden Sie unter

Zeilenumbruch-Arten

Code-Blöcke und Code-Strukturierung

Formatierungen

Formatierungsoptionen


 Zeilenumbruch-Arten

Zeilenumbruch-Arten

Verwendung

Diese Funktion beschreibt, welche Arten von Zeilenumbruch im Frontend Editor unterstützt werden.

Funktionsumfang

Anpassbare Zeilenumbrüche helfen Ihnen, wenn Sie mit Zeilen arbeiten, die länger als die Bildschirmbreite oder die definierte Seitenbreite sind. Es stehen Ihnen verschiedene Zeilenumbruchsarten im Editor zur Verfügung:

● An Fensterrand, wie in der Abbildung gezeigt.

● Nach Seitenbreite

● Nach Spaltenanzahl mit festem Zeilenumbruch.

Zeilenumbruch am Fensterrand

Siehe auch:

Anzeigeoptionen


 Code-Blöcke und Code-Strukturierung

Code-Blöcke und Code-Strukturierung

Verwendung

Diese Funktion beschreibt, wofür Sie Code-Blöcke und Code-Strukturierung im Frontend Editor verwenden können.

Funktionsumfang

Code-Blöcke ermöglichen einen besseren Überblick über das Dokument und vereinfachen die Suche nach Fehlern – zum Beispiel, ungeschlossene Strukturen -, ohne eine Prüfung oder Kompilierung durchzuführen. Dies ist ähnlich der komprimierten Ansicht von Code im traditionellen ABAP Text Editor, in dem Sie komprimierte if-endif-Code-Blöcke anzeigen konnten, um schnell festzustellen, ob verschachtelte Konstruktionen korrekt definiert sind.

Weitere Funktionen der Code-Blöcke:

● Code kann in einer Hierarchie angezeigt werden

● Code-Blöcke können komprimiert und expandiert werden

● Code kann auf die Definition komprimiert werden

● Mehrzeilige Kommentare können komprimiert und expandiert werden

Ein komprimierter Code-Block mit Quick-Info


 Formatierungen

Formatierungen

Verwendung

Diese Funktion formatiert den Quelltext und aktiviert die Berücksichtigung von Programmiersprachen-Regeln: Schlüsselwörter können in Groß- und Kleinbuchstaben erscheinen. Formatierter Code ist optisch ansprechender und hilft dem Leser die Komponenten des Codes zu erkennen.

Funktionen

Nachfolgend finden Sie eine Liste der verfügbaren Laufzeitfunktionen:

● Automatische Klammern aktivieren

Diese Funktion fügt automatisch eine schließende Klammer hinzu, sobald Sie eine öffnende Klammer eingegeben haben.

● Automatisches Einrücken aktivieren

Diese Funktion erkennt Sprachstrukturen und setzt die entsprechenden Leerstellen vor jede verschiedene Struktur während Sie Code eingeben.

● Intelligentes Einfügen von Tabs

Diese Funktion optimiert die Tabulator-Ergänzungsfunktion am Anfang der Zeilen.

● Klammern, Anführungszeichen ergänzen

Diese Funktion hilft, einschließende Anführungszeichen oder Klammern für die Auswahl einzugeben.

● Tastatur-Wiederholungsrate verdoppeln

Diese Funktion beschleunigt die Funktionsgeschwindigkeit aller Tasten.

● Automatische Formatierung nach jedem Einfügen

Diese Funktion fügt Text entsprechend der gegenwärtigen Einrückung ein und passt die Groß-/Kleinschreibung der Schlüsselwörter an, wodurch Sie die manuelle Anpassung nicht mehr vornehmen müssen.

● Unbeabsichtigte Verwendung von Hochfeststelltaste korrigieren

Diese Funktion stellt die unbeabsichtigte Verwendung der Feststelltaste fest und korrigiert dies entsprechend.

● Autokorrektur hilft Eingabefehler festzustellen und korrigiert sie. Die Liste der zu korrigierenden Wörter kann beliebig erweitert werden.


 Formatierungsoptionen

Formatierungsoptionen

Verwendung

In diesem Abschnitt werden die Optionen für die Formatierungen beschrieben.

Integration

Sie benötigen diese Option um Ihren Code auf eine Grundeinstellung zu setzen, in der das Gedruckte dem Geschriebenen entspricht.

Voraussetzungen

Sie haben den Dialog Options geöffnet. Sie haben die Option Formatierungen gewählt.

Sie sehen die folgende Grafik:

Formatierungen

Funktionen

Korrektur von Groß-/Kleinschreibung

● Schlüsselwort einfügen in

Diese Funktion ermöglicht es Ihnen, Schlüsselwörter in den folgenden Schriftarten zu ergänzen:

○ Wie eingegeben

○ Großschreibung

○ Kleinschreibung

○ Anfangsbuchstabe groß

Sonstige

● Automatische Klammern aktivieren

Diese Funktion ermöglicht es Ihnen, während der Eingabe automatisch Klammern einzufügen. Wenn Sie diese Option setzen, werden dem Code standardmäßig Klammern hinzugefügt.

● Automatisches Einrücken aktivieren

Mit dieser Funktion können Sie die linke Zeilengrenze angleichen. Wenn Sie diese Option auswählen, fügt der Editor bei Betätigung der Eingabetaste automatisch immer die gleiche Anzahl von Leerstellen an den Anfang der nächsten Zeile ein und sorgt damit für eine einheitliche Anordnung der linken Zeilengrenze.

● Automatisches Einfügen von Tabs

Mit dieser Funktion können Sie Wörter schnell ergänzen. Wenn Sie diese Option wählen und Code schreiben, können Sie Wörter durch Betätigen der Tabulatortaste ergänzen.

● Klammern, Anführungszeichen ergänzen

Diese Funktion erlaubt es Ihnen, die Codezeilen mit den erforderlichen Zeichen zu vervollständigen. Wenn Sie diese Option aktivieren, setzt der Editor jedes Mal, wenn Sie die Eingabetaste betätigen oder Weiter wählen, automatisch das entsprechende Zeichen (,{,[,” oder ’, um die Codezeile zu vervollständigen.

● Tastatur-Wiederholungsrate verdoppeln

Diese Funktion ermöglicht es Ihnen, die Tastatur-Wiederholsrate zu beschleunigen. Wenn Sie die Navigationstasten (Pfeile nach oben und unten) gedrückt halten, verdoppelt sich die Geschwindigkeit.

● Automatische Formatierung nach jedem Einfügen

Mit dieser Funktion können Sie alle Zeilen neu ausrichten. Wenn Sie diese Option wählen, wird der Code nach jeder Einfüge-Aktion formatiert.


 Autokorrektur

Autokorrektur

Verwendung

Bei einem Fehler während der Eingabe von Code öffnet sich ein kleines Fenster mit einer Liste von Vorschlägen zur Korrektur dieses Fehlers.

Integration

Aktivieren Sie diese Option, um die Anzahl der eventuell bei der Eingabe auftretenden Fehler zu reduzieren.

Voraussetzungen

Sie haben den Dialog Options geöffnet. Sie haben Autokorrektur im Verzeichnisbaum gewählt.

Sie sehen die folgende Grafik:

Formatieren ® Autokorrektur

Funktionen

● Unbeabsichtigte Verwendung von Hochfeststelltaste korrigieren

Mit dieser Funktion können Sie den Status der Feststelltaste auf Normal zurücksetzen.

● Bei Eingabe ändern

Diese Funktion ersetzt das falsche Wort durch das korrekte aus dem Dictionary.

● Hinzufügen

Über diese Funktion können Sie neue Wörter zum Dictionary hinzufügen.

● Löschen

Mit dieser Funktion können Sie Wörter aus dem Dictionary löschen.


 Benutzerdefinierte Code-Vorlagen

Benutzerdefinierte Code-Vorlagen

Die benutzerdefinierten Vorlagen mit Auto Expand-Funktion erleichtern die Eingabe von Standardkonstruktionen erheblich. Der Frontend Editor unterstützt vordefinierte Bezeichner (Tags), wie das momentane Datum/Zeit, den Inhalt der Zwischenablage und die Code-Vervollständigung.

Code-Vorlagen können eingefügt werden, wenn ein bestimmtes Wort eingegeben wird. Zum Beispiel wird die loop-Vorlage als Code-Hinweis loop($) vorgeschlagen, wenn Sie loop eingeben. Die entsprechende Vorlage wird eingefügt sobald Sie Tab oder Enter (Eingabe) drücken.

Siehe auch:

Code-Vorlagen


 Code-Vorlagen

Code-Vorlagen

Verwendung

Mit dieser Funktion können Sie Code-Vorlagen hinzufügen, bearbeiten, einfügen und löschen.

Integration

Um den Dialog Options zu öffnen, wählen Sie [image] rechts unten auf dem Editorbild.

Voraussetzungen

Sie haben den Dialog Options geöffnet. Sie haben die Option Code-Vorlagen gewählt.

Sie sehen ein Bild ähnlich dem folgenden:

Code-Vorlagen

Funktionen

● Tag einfügen

Mit dieser Funktion können Sie Variablen in die Code-Vorlage einfügen. Wenn Sie Tag einfügen wählen, sehen Sie die folgenden Optionen, wie auf nachstehendem Bild gezeigt:

Tag einfügen

● Cursorposition

Diese Variable definiert, wo der Cursor nach dem Einfügen einer Vorlage stehen soll.

● Datum Uhrzeit

Diese Variable wird durch das aktuelle Datum und die aktuelle Zeit ersetzt.

● Zwischenablage

Diese Variable wird durch den aktuellen Inhalt im Zwischenspeicher ersetzt.

● Zu umgebender Text

Diese Variable wird durch die aktuelle Textauswahl ersetzt.

● Dokumentname

Diese Variable wird durch den Namen des aktuellen Dokuments ersetzt.

● Interaktiv

Hier wird eine generische Variable in die Vorlage eingefügt. Sie können den Namen zwischen den Prozentzeichen ändern. Zur Verdeutlichung dient %Form name% im nachfolgenden Beispiel.

Beispiel

...

1. Sie können einen Teil des Quelltexts auswählen, um ihn mit einer Vorlage zu umgeben.

Betrachten Sie als Beispiel die folgende Abbildung:

Ausgewählter Quelltext

2. Aus dem Auswahl-Kontextmenü können Sie, wie unten gezeigt, folgende Elemente auswählen:

Auswahl-Kontextmenü

3. Sie werden nach der undefinierten Vorlagenvariablen %Form name% gefragt.

Betrachten Sie als Beispiel die folgende Abbildung:

Vorlagenparameter

Sie können den Inhalt der Variablen %Form name% sehen: Der ausgewählte Text befindet sich jetzt innerhalb der Form-Routine, genau an der Stelle, an der zuvor die Variable %SurroundedText% stand. Der Cursor steht hinter dem Schlüsselwort USING.

Das Ergebnis sehen Sie hier:

Ergebnis


 Zwischenablage

Zwischenablage

Verwendung

Hier wird beschrieben, wie Sie die Zwischenablage – das Clipboard – des Editors einsetzen können.

Funktionsumfang

Wenn Sie Text ausschneiden oder kopieren, werden die Fragmente in einer Zwischenablage des Editors abgelegt, dem Clipboard Ring. Dort können Sie dann das gewünschte Fragment auswählen und wieder in Ihr Coding einfügen. Der Zwischenspeicher kann bis zu 12 Elemente aufnehmen, die in der Reihenfolge angezeigt werden, in der sie eingefügt wurden, und die nach dem Prinzip „zuletzt rein, zuerst raus“ eingefügt werden. Diese Funktion ist äußerst sinnvoll, wenn Sie mehrere Textausschnitte an eine neue Stelle kopieren wollen oder um Text zurückzurufen, den Sie versehentlich ausgeschnitten haben. Der Clipboard Ring merkt sich Blockauswahl und normale Elemente.

Um einen ausgewählten Block in den Zwischenspeicher zu kopieren, klicken Sie mit der sekundären Maustaste auf das Coding und wählen Mehr ® Kopieren und anhängen. Ctrl + Shift + V öffnet ein Kontextmenü, aus dem Sie auswählen können, welches Element Sie aus dem Ring einfügen wollen (Erweitertes Einfügen).

Sie können das Menü Erweitertes Einfügen auch aufrufen, indem Sie mit der sekundären Maustaste auf das Coding klicken und anschließend Mehr ® Erweitertes Einfügen wählen.

Das Menü Erweitertes Einfügen mit einer Liste von Textelementen im Clipboard Ring

Diverse Formate der Zwischenablage

Der Frontend Editor unterstützt diverse Formate der Zwischenablabe wie Text, Rich Text Format und HTML und bietet die Möglichkeit, WYSIWYG-Text z.B. in Microsoft Word oder Microsoft Outlook einzufügen. Die Daten können ohne Informationsverluste in ein Standardformat der Zwischenablage übersetzt werden. Auch das Unicode-Textformat wird unterstützt, so dass Sie Unicode-Zeichen kopieren und einfügen können.

Siehe auch:

Puffer


 Puffer

Puffer

Verwendung

Mit dieser Funktion können Sie einen ausgewählten Block in drei verschiedene Puffer (Ablagen) kopieren. Diese ausgewählten Blöcke werden zur weiteren Verwendung erhalten. Sie können sie jederzeit einfügen, ohne sie erneut eingeben zu müssen. Dies spart Zeit und erleichtert ihre Arbeit.

Funktionsumfang

● Kopieren in den Puffer

Der Editor unterstützt drei Puffer, in denen Sie Blöcke ablegen können. Wenn Sie einen Block ausgewählt haben, können Sie ihn entweder in den X-Puffer, Y-Puffer oder Z-Puffer kopieren. Dazu klicken Sie mit der rechten Maustaste auf den ausgewählten Block und wählen Block/Ablage ® Kopieren in X-Ablage. Sie können zwei weitere Blöcke in die verbleibenden Puffer kopieren.

● Einsetzen aus dem Puffer

Wenn Sie bereits verschiedene Blöcke in die Puffer kopiert haben, können Sie jeden einzelnen Block an eine bestimmte Stelle im Code einfügen. Dazu klicken Sie mit der rechten Maustaste auf den ausgewählten Block und wählen Block/Ablage ® Einsetzen X-Ablage. Sie können zwei weitere Blöcke aus den entsprechenden Puffern einfügen.

● Block drucken

Sie können einen ausgewählten Block drucken, indem Sie mit der rechten Maustaste auf den ausgewählten Block klicken und Block/Ablage ® Block Drucken wählen.

● Block duplizieren

Sie können eine Kopie desselben ausgewählten Blocks machen, indem Sie mit der rechten Maustaste auf den ausgewählten Block klicken und Block/Ablage ® Block Doppeln wählen.


 Suchen und Ersetzen

Suchen und Ersetzen

Verwendung

Hier erfahren Sie, wie Sie im Editor nach einem bestimmten Text suchen und ihn durch einen anderen Text ersetzen können.

Funktionsumfang

● Der Dialog Suchen verfügt über eine erweiterte Funktionalität, zusätzlich zu den allgemeinen Funktionen des Frontend Editors:

○ Historien-Dropdown-Boxes mit einer Liste der zuletzt eingegebenen Elemente

○ Die Funktion Alle markieren zum Markieren aller Vorkommen der Textsuche im Dokument mit Lesezeichen

○ Suche mit regulären Ausdrücken

○ Inkrementelle Suche

Sie öffnen diesen Dialog durch Klicken mit der rechten Maustaste im Coding und wählen dann Suchen.

Sie sehen dann ein Bild ähnlich dem folgenden:

Suchen

● Der Dialog Ersetzen hat dieselbe erweiterte Funktionalität wie der Dialog Suchen:

○ Historien-Dropdown-Boxes mit einer Liste der zuletzt eingegebenen Elemente

○ Die Funktion Alle markieren zum Markieren aller Vorkommen der Textsuche im Dokument mit Lesezeichen

○ Suche mit regulären Ausdrücken

○ Inkrementelle Suche

Sie öffnen diesen Dialog durch Klicken mit der rechten Maustaste im Coding und wählen dann Ersetzen.

Sie sehen dann ein Bild ähnlich dem folgenden:

Ersetzen

● Weiter suchen

Mit dieser Funktion suchen Sie nach dem nächsten Vorkommen des Suchkriteriums. Sie suchen nach der nächsten Übereinstimmung durch Klicken mit der rechten Maustaste im Coding und wählen dann Weiter suchen.

● Vorheriges suchen

Mit dieser Funktion suchen Sie nach dem vorhergehenden Vorkommen des Suchkriteriums. Sie suchen nach der vorherigen Übereinstimmung durch Klicken mit der rechten Maustaste im Coding und wählen dann Vorheriges suchen.

Siehe auch:

Inkrementelle Suche (Vorwärts/Rückwärts)


 Inkrementelle Suche (Vorwärts/Rückwärts)

Inkrementelle Suche (Vorwärts/Rückwärts)

Verwendung

Diese Funktion ermöglicht es Ihnen, eine Vorwärts/Rückwärts-Suche in Echtzeit durch das Dokument durchzuführen.

Funktionsumfang

Sobald Sie das erste Zeichen des Suchbegriffs eingeben, beginnt die inkrementelle Suche. Sie starten die Suche, indem Sie den Cursor in den Code platzieren und nach Klicken der rechten Maustaste Inkrementell suchen wählen. Wenn Sie den Suchbegriff eintippen, werden Informationen angezeigt, wo der Suchbegriff gefunden werden kann. Sie sehen den von Ihnen eingegebenen Text auch in der Statusleiste in der unteren linken Ecke des Editors (wie in unten stehender Grafik dargestellt).

Inkrementelle Suche

Sie brauchen die Eingabe nicht mehr vervollständigen, sobald Sie genügend Zeichen eingegeben haben, um den gesuchten Ort zu identifizieren. Abhängig von Ihren weiteren Plänen, können Sie nun die Suche beenden oder nicht. Sobald Sie den Suchbegriff eingeben, fängt der Editor an zu suchen und wählt das erste Vorkommen des Suchbegriffs.

Wenn Sie Suche inkrementell vorwärts wählen und dann hugo eingeben, erscheint das zuerst vorkommende hugo hinter der aktuellen Cursor-Position.

Mit Suche inkrementell rückwärts würden Sie das erste vor der aktuellen Cursor-Position vorkommende hugo finden.


 Navigation

Navigation

Verwendung

Hier erfahren Sie, wie Sie im Code navigieren können.

Funktionsumfang

Navigationsmöglichkeiten im Kontextmenü Bildinhalt

Sie können alle nachstehend aufgeführten Funktionen aufrufen, indem Sie im Code mit der rechten Maustaste klicken und die entsprechende Funktion im Kontextmenü auswählen.

● Gehe zu Zeile

Mit dieser Funktion springen Sie zu einer bestimmten Zeile im Code. Wählen Sie dazu Gehe zu Zeile. Der Dialog Springen zu Zeile erscheint wie nachfolgend gezeigt.

Gehe zu Zeile

● Zur letzten Änderung gehen

Mit dieser Funktion springen Sie zur letzten Änderung, die Sie im Code vorgenommen haben. Wählen Sie dazu Navigation ® Zur letzten Änderung gehen.

● Rückwärts navigieren

Mit dieser Funktion springen Sie zur vorhergehenden Änderung im Code. Wählen Sie dazu Navigation ® Rückwärts navigieren.

● Vorwärts navigieren

Mit dieser Funktion springen Sie zur nächsten Änderung im Code. Wählen Sie dazu Navigation ®Vorwärts navigieren.

● Nächste gleiche Strukturstufe

Mit dieser Funktion springen Sie zur nächsten identischen Struktur im Code. Wählen Sie dazu Nächste gleiche Strukturstufe.

● Vorige gleiche Strukturstufe

Mit dieser Funktion springen Sie zur vorherigen identischen Struktur im Code. Wählen Sie dazu Vorige gleiche Strukturstufe.

● Gehe zu Start der Einheit

Mit dieser Funktion springen Sie zum Beginn einer Einheit im Code. Wählen Sie dazu Gehe zu Start der Einheit.

● Gehe zu Ende der Einheit

Mit dieser Funktion springen Sie zum Ende einer Einheit im Code. Wählen Sie dazu Gehe zu Ende der Einheit.

Blätternavigation

Blätternavigation liefert Informationen zur aktuellen Position im Code als Blätteranzeigeoption; es werden die aktuelle Funktion, Unterprogramm, Klasse, Methode usw. angezeigt. Auch der Bereich der aktuell sichtbaren Zeilen wird gezeigt.

Dies ist im folgenden Beispiel dargestellt.

Blätteranzeigeoption mit aktueller Position im Dokument

Siehe auch:

Lesezeichen


 Lesezeichen

Lesezeichen

Verwendung

Hier werden Lesezeichen und ihre Verwendung im Editor beschrieben.

Funktionsumfang

Funktionen im Kontextmenü der Indikatorspalte

Sie können alle nachstehend aufgeführten Funktionen aufrufen, indem Sie mit der rechten Maustaste in die Indikatorspalte klicken und die jeweilige Funktion im Kontextmenü auswählen.

Lesezeichen

Der Frontend-Editor unterstützt Lesezeichen mit und ohne Namen. Diese helfen bei der Navigation und beim Bearbeiten von Code. Sie können bis zu neun nummerierte Lesezeichen und eine unbegrenzte Anzahl nicht nummerierter Lesezeichen spezifizieren. Um dies auszuführen, wählen Sie Lesezeichen ® Lesezeichen 0. (Sie können eine Nummer zwischen 0 und 9 für ein Lesezeichen wählen.)

Die folgende Grafik zeigt dies an:

Lesezeichen

Sobald Sie Lesezeichen spezifiziert haben, erscheinen diese wie nummerierte blaue Flaggen in der Indikatorspalte. Sie können alle Lesezeichen wieder entfernen, indem Sie mit der linken Maustaste Lesezeichen ® Alle Lesezeichen entfernen wählen.

Gehe zu Lesezeichen

Sie können zu einem anderen Lesezeichen springen, indem Sie Springen zu Lesezeichen ® Lesezeichen 0 (Sie können ein Lesezeichen zwischen 0 und 9 wählen.)

Sie können jederzeit zu einem anderen Lesezeichen springen, indem Sie die Tastaturkombination Strg + Nummer des Lesezeichens verwenden.

Die folgende Grafik zeigt dies an:

Springen zu Lesezeichen

Lesezeichen setzen/löschen

Sie können zwischen Lesezeichen umschalten, indem Sie Mehr ® Lesezeichen setzen/löschen wählen.

Die folgende Grafik zeigt dies an:

Lesezeichen setzen/löschen

Sie können folgende Optionen aktivieren:

● Über Nächstes Lesezeichen gelangen Sie zum nächsten Lesezeichen.

● Über Vorheriges Lesezeichen gelangen Sie zum vorhergehenden Lesezeichen.

● Alle Lesezeichen entfernen entfernt alle vorhandenen Lesezeichen.


 Drucken

Drucken

Verwendung

Hier erfahren Sie, wie Sie den Quelltext in einer gut lesbaren Form drucken können.

Funktionsumfang

Das Drucken im WYSIWYG-Stil liefert gut lesbare Ausdrucke von Dokumenten. Der Druck unterstützt benutzerdefinierten Kopf- und Fußtext mit vordefinierten Formaten und unterschiedlichen Stilen. Mit CTRL+ALT+P können Sie eine Druckvorschau öffnen.

Dies ist im folgenden Beispiel dargestellt.

WYSIWYG-Druckvorschau für ein Dokument im SAP-System

Um das Dokument zu drucken, wählen Sie Print.

Siehe auch:

Druckoptionen


 Druckoptionen

Druckoptionen

Verwendung

Mit dieser Option können Sie die Druckeigenschaften des Codes festlegen.

Voraussetzungen

Sie haben den Dialog Options geöffnet. Sie haben Drucken im Verzeichnisbaum gewählt.

Sie sehen die folgende Grafik:

Drucken

Funktionsumfang

● Eingaben in Kopf erlauben es Ihnen, beispielsweise die Seitennummer oder die Gesamtseitennummer oben auf der Seite anzuzeigen.

● Eingaben in Fußnote erlauben es Ihnen, beispielsweise den Dateinamen und das Datum unten auf der Seite platzieren.

● Bei Auswahl von Zeilennummern drucken erscheinen die Zeilennummern, wenn Sie den Code ausdrucken.

● Zeilen umbrechen – Der Code wird beim Ausdruck so umgebrochen, dass er auf die Seite passt.


 Exportfunktionen

Exportfunktionen

Verwendung

Diese Funktion beschreibt den Export von Code in verschiedene Formate.

Funktionsumfang

Der Frontend Editor unterstützt die Exportfunktion für die gebräuchlichsten Textformate.

● Export nach HTML

Dies ist im folgenden Beispiel dargestellt.

HTML-Export

● Export nach RTF

Dies ist im folgenden Beispiel dargestellt.

RTF-Export

● Export nach PDF

Dies ist im folgenden Beispiel dargestellt.

PDF Export


 Tastenkombinationen

Tastenkombinationen

Verwendung

Diese Funktion beschreibt eine Liste von Tastenkombinationen.

Funktionen

In untenstehender Tabelle finden Sie Tastenkombinationen für den Frontend Editor. Diese helfen Ihnen, Zeit und Aufwand zu sparen.

Diese Tastenkombinationen gelten für das deutsche Tastaturlayout.

Tastaturkombinationen

Befehl | Tastenkombination
Bearbeitung |
Zurücknehmen | STRG+Z
Redo | STRG+Y
Text ausschneiden | STRG+X
Text kopieren | STRG+C
Text einfügen | STRG+V
Löschen | NUM Entf
Alle auswählen | STRG+A
Zeile kopieren | STRG+UMSCHALT+T
Zeile ausschneiden | STRG+UMSCHALT+X
Zeile löschen | STRG+UMSCHALT+L
Zeile umsetzen | STRG+UMSCHALT+T
Zeile duplizieren | STRG+D
Nach oben verschieben | STRG+ALT+NUM 8
Zeile nach unten verschieben | STRG+ALT+NUM 2
Suchen und Ersetzen |
Suchen | STRG+F
Annäherungssuche | STRG+I
Zurücklegen | STRG+H
Weitersuchen | STRG+G
Letztes suchen | STRG+UMSCHALT+G
Letzte Annäherungssuche | STRG+UMSCHALT+I
Formatierung |
Kommentarzeilen | STRG+ \
Zeile dekommentieren | STRG+UMSCHALT+ \
Zeileneinzug erhöhen | Tabulatortaste
Zeileneinzug verringern | UMSCHALT+TAB
Kleinschreibung | STRG+L
Großschreibung | STRG+U
Groß schreiben | STRG+J
Satz erstellen | STRG+T
Groß-/Kleinschreibung umschalten | STRG+K
Navigationsmöglichkeiten |
Gehe zu Zeile | STRG+O
Code-Blöcke |
Code-Block komprimieren/expandieren | STRG+NUM*
Alles komprimieren | STRG+UMSCHALT+NUM-
Alles expandieren | STRG+UMSCHALT+NUM+
Lesezeichen |
Lesezeichen0 | STRG+ALT-0
Lesezeichen1 | STRG+ALT-1
Lesezeichen2 | STRG+ALT-2
Lesezeichen3 | STRG+ALT-3
Lesezeichen4 | STRG+ALT-4
Lesezeichen5 | STRG+ALT-5
Lesezeichen6 | STRG+ALT-6
Lesezeichen7 | STRG+ALT-7
Lesezeichen8 | STRG+ALT-8
Lesezeichen9 | STRG+ALT-9
Lesezeichen ein-/ausschalten | STRG+ALT+M
Nächstes Lesezeichen | STRG+M
Vorhergehendes Lesezeichen | STRG+UMSCHALT+M

Siehe auch:

Tastaturoptionen


 Tastaturoptionen

Tastaturoptionen

Verwendung

Sie können zusätzliche Tastenkombinationen erstellen oder die existierenden verändern.

Sie können verschiedene Optionen von Tastenkombinationen setzen, um einen Befehl in der Code-Umgebung auszuführen. Außerdem können Sie den Tastenbelegung für Befehle entfernen, die nicht benötigt werden.

Voraussetzungen

Sie haben den Dialog Options geöffnet. Sie haben Tastatur im Verzeichnisbaum gewählt.

Sie sehen dann ein Bild ähnlich dem folgenden:

Tastatur

Funktionsumfang

Sie können einen Befehl setzen und eine Taste oder eine Tastenkombination zuweisen, um den Befehl auszuführen. Im Feld Befehlsbeschreibung können Sie sehen, welche Aktion ausgeführt werden wird. Sie können eine neue Tastenkombination durch Auswahl einer Befehlsbeschreibung aus der Liste und durch Auswahl von Zuweisen hinzufügen. Falls keine Tastenkombination diesem Befehl zugewiesen ist, können Sie eine neue erstellen und als Standardeinstellung speichern. Falls Sie bereits eine Kombination zugewiesen haben und diese ändern wollen, können Sie die bestehende Kombination löschen und eine neue zuweisen.


 XML-Einstellungen

XML-Einstellungen

Alle Einstellungen werden im XML-Format gespeichert und erleichtern somit den Export und Import in andere Systeme.


 Optioneneinstellungen

Optioneneinstellungen

Verwendung

Diese Funktion beschreibt wie Sie die Funktionen ihres Editors beim Schreiben von Code einstellen. Sie können verschiedene Optionen des Editors verändern, wie untenstehend beschrieben.

Voraussetzungen

Sie haben den Frontend Editor aufgerufen. Sie haben in der unteren rechten Ecke der Statusleiste das Symbol für die Optionseinstellungen gewählt. Sie haben den Dialog Options geöffnet. Sie können nun beginnen die Funktionen in ihrer Editorumgebung einzustellen.

Funktionsumfang

● Anzeigeoptionen

● Schriftarten und Farben

● Code-Vervollständigung

● Code-Vorlagen

● Formatierungsoptionen

● Autokorrektur

● Tastaturoptionen

● Druckoptionen


Glossary

Finding terms

To search for a glossary term, enter the term in the text field of the Index tab.

To search for a term in the full text, enter the term in the text field of the Search tab, and press Enter or the pushbutton List Topics.

Displaying terms

To display a term highlighted in the list box, double-click on it or press the pushbutton Display.


Hilfe zum HTML Help Viewer

Verwendung

Mit dem HTML Help Viewer können Sie die SAP-Bibliothek im Dateiformat Compiled HTML (*.CHM) anzeigen.

Funktionsumfang

Der HTML Help Viewer beinhaltet:

  • ein Topic-Fenster zur Anzeige des aktuellen Hilfedokuments
  • ein Navigationsfenster für die Anzeige des aktuellen Inhaltsverzeichnisses, die Schlagwortsuche und die Volltextsuche. (Das Navigationsfenster kann aus- und eingeblendet werden: Ausblenden/Einblenden)
  • eine Symbolleiste mit Funktionen zum Navigieren, Drucken, etc.

Wenn Sie bei der Navigation in der Online-Hilfe zu Dokumenten in anderen Hilfedateien verzweigen, dann werden weitere Instanzen des HTML Help Viewer geöffnet. Diese können einzeln geschlossen werden. Durch Schließen der Ausgangsinstanz werden alle Instanzen des Viewer geschlossen.

Um zur Startseite der SAP-Bibliothek zu gelangen, wählen Sie Startseite. Von dort aus können Sie auf die gesamte Dokumentation zugreifen: SAP-Bibliothek, Glossar, Einführungsleitfaden (IMG) und Release-Informationen.

Suchen nach Hilfedokumenten

Sie können nach Hilfedokumenten suchen, indem Sie:

  1. in der Baumstruktur des Inhaltsverzeichnisses navigieren (Registerkarte Inhalt)
    • Um alle Zweige des Inhaltsverzeichnisses zu öffnen bzw. zu schließen, klicken Sie im Navigationsfenster die rechte Maustaste und wählen Sie im Kontextmenü Alle öffnen bzw. Alle schließen.
    • Um in einem durchlaufenen Navigationspfad zurück und wieder vor zu gehen, wählen Sie Zurück bzw. Vorwärts in der Symbolleiste. Dies gilt jeweils für den Navigationspfad innerhalb einer Instanz des HTML Help Viewer.
    • Um im Inhaltsverzeichnis nur Einträge bestimmter Info-Klassen anzuzeigen, klicken Sie im Navigationsfenster die rechte Maustaste und wählen Sie im Kontextmenü Anpassen... Legen Sie im folgenden Dialog fest, welche Info-Klassen im Inhaltsverzeichnis erscheinen sollen.
  2. eine Schlagwortsuche durchführen (Registerkarte Index)

Abhängig davon, ob Sie sich in der SAP-Bibliothek oder in einer anderen, darin referenzierten Hilfedatei befinden, wird der Gesamtindex oder der Index der aktuellen Hilfedatei angezeigt. Wenn zur aktuellen Hilfedatei kein Index existiert, dann erscheint die Registerkarte Index nicht.

Das Laden des Gesamtindex (ca. 8 MB) kann, je nach Ausstattung Ihres PC, bis zu einigen Minuten in Anspruch nehmen.

Selektieren Sie einen Eintrag in der Liste der Schlagwörter und wählen Sie Anzeigen.
Ist das selektierte Schlagwort nur einem Hilfedokument zugeordnet, dann wird dieses unmittelbar angezeigt. Andernfalls erscheint eine Liste der gefundenen Dokumente zur Auswahl.

Da Release-Informationen und der Einführungsleitfaden (IMG) nicht beschlagwortet sind, ist dort nur die Volltextsuche möglich.
  3. eine Volltextsuche durchführen (Registerkarte Suchen)

Geben Sie eine Suchanfrage ein und wählen Sie Themenliste.
Abhängig davon, ob Sie sich in der SAP-Bibliothek oder in einer anderen, darin referenzierten Hilfedatei befinden, wird in allen Dokumenten oder lediglich in den Dokumenten der aktuellen Hilfedatei gesucht. Eine Liste der gefundenen Dokumente wird zur Auswahl angezeigt.

Sie können komplexe Suchanfragen bilden durch:
    • Verwendung der Platzhalter ? für einzelne Zeichen und * für beliebige Zeichenfolgen in Suchbegriffen.
    • Einbeziehung ähnlicher Suchbegriffe (Ähnliche Wörter suchen)
    • Verknüpfung von Suchbegriffen mit den Operatoren:
      • AND (alle Begriffe kommen im Dokument vor)
      • OR (mindestens einer der Begriffe kommt im Dokument vor)
      • NOT (der Begriff kommt im Dokument nicht vor)
      • NEAR (die Begriffe kommen in räumlicher Nähe, z.B. im selben Satz, im Dokument vor)
    • Einschränkung der Suche auf den Titel der Dokumente (Nur Titel suchen)
    • Einschränkung der Suche auf die mit der vorherigen Suchanfrage gefundene Dokumentenmenge (Vorherige Ergebnisse suchen)

Die globale Suche in der SAP-Bibliothek erfordert viel Hauptspeicher und virtuellen Speicher, insbesondere bei der Volltextsuche. Die globale Volltextsuche sollte deshalb nur benutzt werden, wenn die Hilfedateien auf der lokalen Festplatte liegen.

Lokalisieren des aktuellen Hilfedokuments im Inhaltsverzeichnis

Sind Sie zum aktuellen Topic durch eine Suche oder durch einen Hyperlink gelangt, dann wird die Position des Topics im Inhaltsverzeichnis nicht angezeigt. Um das Topic im Inhaltsverzeichnis zu lokalisieren, wählen Sie Suchen in der Symbolleiste des HTML Help Viewer.

Wurde das aktuelle Topic durch eine globale (Volltext- oder Schlagwort-) Suche in der SAP-Bibliothek gefunden, dann muß zunächst die Hilfedatei bestimmt werden, in der es enthalten ist. Klicken Sie hierzu auf die Suchen-Ikone [image] im Titel des Topics. Wählen Sie anschließend Suchen in der Symbolleiste, um das Inhaltsverzeichnis der Hilfedatei zu expandieren und die Position des Topics zu lokalisieren.

Drucken von Hilfedokumenten

Sie können einzelne Hilfedokumente oder mehrere Dokumente zugleich ausdrucken:

  • Um das aktuelle Topic zu drucken, wählen Sie Drucken mit der Option Ausgewähltes Thema drucken.
  • Um das aktuelle Topic und alle darunterliegenden Topics zu drucken, wählen Sie Drucken mit der Option Ausgewähltes Thema und alle Unterthemen drucken.


SAP Library

These product-specifc HTML-based documents form part of the SAP Library.
To view the entire SAP Library, please go to http:\\help.sap.com.


Broken link

Error: Broken link

You tried to follow a link that points to an unknown target document.