Arbeiten mit der Knowledge Workbench

Verwendung

Die Knowledge Workbench ist die PC-Anwendung des SAP Knowledge Warehouse, die alle Autorenfunktionen für die Erstellung von Informationsobjekten zur Verfügung stellt. Sie können mit der Knowledge Workbench Informationsobjekte anlegen und ändern, Attribute pflegen und sich die Informationsobjekte in einem Web-Browser anzeigen lassen.

Integration

Sie können mit der Knowledge Workbench online oder offline arbeiten.

Wenn Sie online arbeiten, dann haben Sie Zugriff auf die Informationsobjekte im Knowledge Warehouse.

Wenn Sie offline arbeiten, dann haben Sie nur Zugriff auf die Informationsobjekte, die auf Ihrem lokalen PC oder dem Dateisystem abgelegt sind.

Voraussetzungen

Die Knowledge Workbench muß auf Ihrem PC installiert sein.

Sie benötigen einen Benutzer im SAP-System des SAP Knowledge Warehouse.

Funktionsumfang

Drei Inhaltsablagen

In der Knowledge Workbench benutzen Sie bei der Erstellung von Informationsobjekten drei Inhaltsablagen:

  • Knowledge Warehouse

Im Knowledge Warehouse sind alle Informationsobjekte enthalten, die im Knowledge Warehouse abgelegt wurden. Sie können nur dann auf das Knowledge Warehouse zugreifen, wenn Sie mit der Knowledge Workbench im Online-Modus arbeiten und am R/3-System des Knowledge Warehouse angemeldet sind.

Sie können Mappen des Knowledge Warehouse Ihren Favoriten hinzufügen.

Wenn Sie im Knowledge Warehouse Infomationsobjekte auswählen und die Bearbeitungsfunktion aufrufen, dann werden die Informationsobjekte in das Local Repository auf Ihrem PC heruntergeladen und für andere Benutzer gesperrt. Andere Benutzer können sich die ausgecheckten Informationsobjekte nur anzeigen lassen.
  • Local Repository auf dem PC

Im Local Repository sind alle Informationsobjekte enthalten, die Sie zur Bearbeitung aus dem Knowledge Warehouse ausgecheckt haben.

Außerdem sind alle Informationsobjekte enthalten, die Sie neu oder durch Import von Dateien aus dem Local System angelegt haben.

Wenn Sie mit der Knowledge Workbench im Offline-Modus arbeiten, dann werden alle neuen und geänderten Informationsobjekte im Local Repository abgelegt.

Wenn Sie geänderte Informationsobjekte wieder in das Knowledge Warehouse einchecken, dann werden diese Objekte aus dem Local Repository entfernt und im Knowledge Warehouse entsperrt.
  • Local System

Über Local System haben Sie Zugriff auf alle Dateien auf dem PC und im Netz, die Sie als Quelle für Informationsobjekte des Knowledge Warehouse benutzen können. Sie können Informationsobjekte aus Dateien des lokalen Systems erstellen, indem Sie sie entweder direkt oder über das Local Repository in das Knowledge Warehouse einchecken.

Online- und Offline-Modus

Im Online-Modus haben Sie Zugriff auf alle Informationsobjekte des Knowledge Warehouse. Sie können alle Informationsobjekte ansehen, miteinander verknüpfen, ihre Attribute ändern und sie bearbeiten. Wenn ein anderer Benutzer Informationsobjekte ausgecheckt hat, dann können Sie diese Objekte nicht bearbeiten und auch nicht ihre Attribute ändern.

Im Offline-Modus haben Sie nur Zugriff auf die Informationsobjekte im Local Repository und auf die Daten im Local System.

Navigation in Explorer-Fenstern

In der Knowledge Workbench greifen Sie auf Mappen und Informationsobjekte in Explorer-Fenstern zu. Die Navigation in Explorer-Fenstern läuft genauso ab wie im Microsoft Windows Explorer.

In jedem Explorer-Fenster sehen Sie in der Kontextleiste (unterhalb der Titelleiste) die aktuellen Einstellungen des Versionskontexts (Sprache, Release).

Je nach Inhaltsablage, in der Sie navigieren, nimmt die Kontextleiste eine andere Farbe an:

  • Grün im Knowledge Warehouse
  • Blau im Local Repository
  • Grau im Local System

Wenn Sie mehrere Explorer-Fenster öffnen, dann können Sie mehrere Teile des Knowledge Warehouse, des Local Repository oder Local System gleichzeitig ansehen und bearbeiten. Außerdem können Sie für verschiedene Funktionen Drag&Drop nutzen, z.B. für das Einfügen von Informationsobjekten in eine Struktur.

Funktionen für Informationsobjekte

Über das Menü oder über die rechte Maustaste werden Ihnen die Funktionen angeboten, die für das ausgewählte Informationsobjekt möglich sind.

Einschränkungen

Einige Autorenfunktionen stehen in der Knowledge Workbench nicht zur Verfügung. Die folgenden Funktionen können Sie nur im R/3-System des Knowledge Warehouse ausführen:

  • R/3-Links zwischen R/3-Anwendungsobjekten und Informationsobjekten des Knowledge Warehouse setzen und prüfen
  • Strukturen mit Informationsobjekten drucken
  • Offline-Präsentationen von Trainingskursen erstellen
  • Indexeinträge pflegen (Bereich: Dokumentation)
  • Informationsobjekte prüfen (Bereich: Dokumentation)

Um diese Funktionen nutzen zu können, müssen Sie sich im SAP-System des Knowledge Warehouse anmelden.

Aktivitäten

Sie starten die Knowledge Workbench über Programme ® SAP Frontend ® Knowledge Workbench vom Windows-Start-Menü aus.

Um im Online-Modus zu arbeiten, geben Sie die entsprechenden Daten auf der Registerkarte Work online des Anmeldedialogfensters ein.

Um offline zu arbeiten, wählen Sie einen Inhalt auf der Registerkarte Work offline des Anmeldedialogfensters aus.


Knowledge Workbench starten

Voraussetzungen

Sie haben die Knowledge Workbench über die SAP-Gui-CD installiert.

Vorgehensweise

Um die Knowledge Workbench zu starten, gehen Sie wie folgt vor:

  1. Wählen Sie Start ® Programme ® SAP Frontend ® Knowledge Workbench.

    2. Sie gelangen auf das Anmeldebild der Knowledge Workbench.

  2. Wählen Sie den Modus aus, in dem Sie die Knowledge Workbench starten möchten.
    • Um im Online-Modus zu arbeiten, geben Sie die entsprechenden Daten auf der Registerkarte Work online des Anmeldedialogfensters ein.
    • Um offline zu arbeiten, wählen Sie einen Inhalt auf der Registerkarte Work offline des Anmeldedialogfensters aus.
  1. Wählen Sie Anmelden.

Ergebnis

Die Knowledge Workbench wird gestartet. Anschließend wird ein Explorer-Fenster mit den Inhaltsablagen angezeigt, die zur Verfügung stehen.


Konfiguration der Knowledge Workbench

Verwendung

In der Knowledge Workbench können Sie eine Reihe von Einstellungen vornehmen, mit denen Sie steuern

  • in welchem Kontext (Sprache, Erweiterung, Release) Sie Informationsobjekt-Versionen pflegen und ansehen können
  • welche Informationsobjekt-Attribute in den Explorer-Fenstern angezeigt werden, die Sie in der Knowledge Workbench öffnen
  • welche Attributwerte als Standardwerte benutzt werden, wenn Sie neue Informationsobjekte anlegen.

Funktionsumfang

In der Knowledge Workbench können Sie folgende Bereiche konfigurieren:

  • Pflege von Informationsobjekten

Durch Auswahl eines Kontextes (Sprache, Erweiterung, Release) steuern Sie, welche Versionen eines Informationsobjekts Sie benutzen oder anlegen möchten.

Wenn Sie auf Informationsobjekte aus verschiedenen Kontexten zugreifen möchten, dann können Sie den eingestellten Kontext für jedes geöffnete Explorer-Fenster ändern.

Außerdem können Sie einen Einstiegskontext festlegen, der für neue Explorer-Fenster gilt.
  • Anzeige von Informationen

Durch die Definition von Anzeigeoptionen können Sie steuern, welche Informationsobjekt-Attribute im Knowledge Warehouse und Local Repository angezeigt werden sollen.

Im aktiven Explorer-Fenster können Sie die Struktursicht und die Objektvorschau ein- oder ausblenden.
  • Standardwerte für neue Informationsobjekte

Durch die Definition von Standardwerten für die Attribute neuer Informationsobjekte können Sie die erforderlichen Dateneingaben beim Anlegen neuer Informationsobjekte verringern.

Sie können die Standardwerte für alle Informationsobjekte pro Bereich des Knowledge Warehouse festlegen.


Kontext für das aktive Explorer-Fenster eingeben

Verwendung

Sie können durch den Kontext steuern, auf welche Informationsobjekt-Versionen Sie über das aktive Explorer-Fenster der Knowledge Workbench zugreifen können.

Vorgehensweise

Um den Kontext für das aktive Explorer-Fenster einzugeben, gehen Sie wie folgt vor:

  1. Wählen Sie das Explorer-Fenster aus, das Sie für die Anzeige des Mappeninhalts benutzen möchten.
  2. Wählen Sie Kontext ® Aktuellen Kontext ändern...

    3. Sie gelangen auf ein Dialogfenster.

  3. Wählen Sie die Kontextparameter aus und wählen Sie dann OK.

Ergebnis

Die Anzeige der Mappen und Informationsobjekte des aktiven Explorer-Fensters wird aktualisiert. Es werden nur die Informationsobjekte angezeigt, von denen eine Version in dem von Ihnen gewählten Kontext vorliegt.


Einstiegskontext einstellen

Verwendung

Mit dem Einstiegskontext können Sie steuern, welcher Kontext beim Öffnen eines neuen Explorer-Fensters angezeigt werden soll.

Vorgehensweise

Um einen Standardkontext einzustellen, gehen Sie wie folgt vor:

  1. Wählen Sie Einstellungen ® Knowledge Warehouse...
  2. Wählen Sie die Registerkarte Einstiegskontext.
  3. Geben Sie Ihre Kontextparameter ein und wählen Sie OK.

Ergebnis

Wenn Sie jetzt ein neues Explorer-Fenster öffnen, wird der von Ihnen eingestellte Kontext als Einstiegskontext benutzt.


Anzeige von Informationsobjekt-Attributen einstellen

Verwendung

Sie können festlegen, welche Informationsobjekt-Attribute in Explorer-Fenstern angezeigt werden sollen.

Vorgehensweise

Um die anzuzeigenden Attribute auszuwählen, gehen Sie wie folgt vor:

  1. Wählen Sie Ansicht® Einstellungen ® Knowledge Warehouse...
  2. Wählen Sie auf dem folgenden Register die Registerkarte Anzeigeattribute.
  3. Um ein Attribut anzuzeigen, markieren Sie das Attribut in der Liste Verfügbare Eigenschaften und wählen Hinzufügen.

    4. Um ein Attribut aus der aktuellen Anzeigeeinstellung herauszunehmen, markieren Sie das Attribut in der Liste Ausgewählte Eigenschaften und wählen Entfernen.

  4. Wählen Sie OK.

Ergebnis

Wenn Sie sich Mappeninhalte in Explorer-Fenstern ansehen, dann werden die Informationsobjekte mit allen Attributen angezeigt, die Sie in die Liste Ausgewählte Eigenschaften aufgenommen haben.


Standardwerte für neue Informationsobjekte setzen

Verwendung

Sie können Attributwerte definieren, die neuen Informationsobjekten automatisch zugewiesen werden. Wenn Sie Standardwerte definieren, dann müssen Sie beim Anlegen von neuen Informationsobjekten weniger Attribute pflegen.

Vorgehensweise

  1. Wählen Sie Einstellungen ® Standardwerte ...

    2. Sie gelangen auf ein Dialogfenster, auf dem Sie Standardwerte für die Attribute von Informationsobjekten der unterschiedlichen Info-Objekt-Klassen in den einzelnen Bereichen hinterlegen können.

  2. Wählen Sie einen Bereich aus.

    3. Die Info-Objekt-Klassen des gewählten Bereiches werden angezeigt.

  3. Wählen Sie eine Info-Objekt-Klasse aus.

    4. Die Attribute der Informationsobjekte der gewählten Info-Objekt-Klasse werden angezeigt.

  4. Wählen Sie ein Informationsobjekt-Attribut aus.
  5. Wählen Sie Standardwert angeben und geben Sie einen Attributwert in das dazugehörige Textfeld ein.

    6. Bei einigen Attributen, z.B. bei Verantw. können Sie die Option Spezieller Standardwert wählen und dann z.B. Ihren Benutzernamen als Standardwert hinterlegen.

    Wenn das Genehmigungsverfahren aktiviert ist, dann können Sie für den Status keinen Standardwert pflegen.

  6. Sichern Sie die Standardwerte mit OK.

Ergebnis

Wenn Sie ein Informationsobjekt anlegen, dann sind die von Ihnen angegebenen Standardwerte schon vorbelegt.


Anzeigeoptionen

Verwendung

Die Knowledge Workbench umfaßt eine Reihe von Optionen, mit denen Sie die Menge und die Art der Informationen einstellen können, die in einem Explorer-Fenster angezeigt werden. Einige dieser Einstellungen betreffen alle Explorer-Fenster, andere hingegen nur das aktive Fenster.

Voraussetzungen

Sie befinden sich in der Knowledge Workbench und haben ein Explorer-Fenster geöffnet.

Funktionsumfang

Folgende Informationen können Sie in der Knowledge Workbench ein- oder ausblenden:

  • Favoriten

Es werden alle Mappen angezeigt, die Sie den Favoriten zugeordnet haben.
  • Tips

Es werden verschiedene Tips angezeigt, die Sie beim Arbeiten mit der Knowledge Workbench unterstützen sollen.

Folgende Informationen können Sie je Explorer-Fenster ein- oder ausblenden:

  • Struktur der Inhaltsablagen

Es wird die Struktur der einzelnen Inhaltsablagen angezeigt.
  • Objektvorschau für Informationsobjekte

Für Inhaltsobjekte wird der Inhalt angezeigt.

Für Strukturen wird nur die Kurzinformation angezeigt.
  • Anzeigeart der Informationsobjekte

Wenn Sie Detail wählen, dann werden alle Attribute angezeigt, die Sie für die Anzeige ausgewählt haben.
  • Sortieren der Anzeige der Informationsobjekte

Die Anzeige der Informationsobjekte wird entsprechend Ihrer Auswahl sortiert.

Aktivitäten

Sie wählen im Menü Ansicht die Anzeigeoptionen aus.


Favoriten ein- oder ausblenden

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Vorgehensweise

Um die Favoriten ein- oder auszublenden, wählen Sie Ansicht ® Favoriten.

Ergebnis

Die Favoriten werden in einem separaten Fenster angezeigt.

Wenn Favoriten gekennzeichnet ist, dann werden die Favoriten eingeblendet. Ansonsten werden die Favoriten ausgeblendet.


Tips ein- oder ausblenden

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Vorgehensweise

Um die Tips für die Arbeit mit der Knowledge Workbench ein- oder auszublenden, wählen Sie Ansicht ® Tips.

Um den nächsten Tip anzuzeigen, drücken Sie die rechte Maustaste und wählen Sie Nächster Tip.

Ergebnis

Die Tips werden in einem separaten Fenster angezeigt.

Wenn Tips gekennzeichnet ist, dann werden die Tips eingeblendet. Ansonsten werden die Tips ausgeblendet.


Struktur der Inhaltsablagen ein- oder ausblenden

Voraussetzungen

Sie befinden sich in der Knowledge Workbench und haben ein Explorer-Fenster geöffnet.

Vorgehensweise

Um die Struktur der Inhaltsablagen einzublenden, wählen Sie Ansicht ® Strukturansicht.

Ergebnis

Die Struktur der Inhaltsablagen werden im linken Teil des Explorer-Fensters angezeigt.

Wenn Strukturansicht gekennzeichnet ist, dann wird die Struktur eingeblendet. Ansonsten wird die Struktur ausgeblendet.


Vorschau der Informationsobjekte ein- oder ausblenden

Voraussetzungen

Sie befinden sich in der Knowledge Workbench und haben ein Explorer-Fenster geöffnet.

Vorgehensweise

Um die Vorschau der Informationsobjekte einzublenden, wählen Sie Ansicht ® Objektvorschau.

Ergebnis

Der Inhalt eines markierten Inhaltsobjekts wird im unteren Teil des Explorer-Fensters angezeigt.

Für Strukturen wird nur eine Kurzinformation angezeigt.

Wenn Objektvorschau markiert ist, dann wird die Vorschau eingeblendet. Ansonsten wird die Vorschau ausgeblendet.


Anzeigeart der Informationsobjekte auswählen

Verwendung

Mit dieser Vorgehensweise können Sie festlegen, wie die Liste der Informationsobjekte angezeigt werden soll.

Sie können wählen zwischen:

  • Kleine Symbole
  • Auflisten
  • Detail

Voraussetzungen

Sie befinden sich in der Knowledge Workbench und haben ein Explorer-Fenster geöffnet.

Vorgehensweise

Um die Anzeigeart einzustellen, wählen Sie Ansicht ® Kleine Symbole/Auflisten/Detail.

Ergebnis

Die Liste wird entsprechend Ihrer Wahl aufgebaut. Die Anzeigeart wird im Menü gekennzeichnet.

Wenn Sie Detail gewählt haben, dann werden alle Attribute angezeigt, die Sie mit der Funktion Einstellungen ® Knowledge Warehouse ® Anzeigeattribute ausgewählt haben.


Liste der Informationsobjekte sortieren

Verwendung

Mit dieser Vorgehensweise können Sie die Liste der Informationsobjekte sortieren.

Ihnen stehen jeweils die Attribute als Sortierkriterien zur Verfügung, die Sie über die Funktion Anzeigeattribute ausgewählt haben.

Voraussetzungen

Sie befinden sich in der Knowledge Workbench und haben ein Explorer-Fenster geöffnet.

Vorgehensweise

Um die Liste der Informationsobjekte zu sortieren, wählen Sie Ansicht ® Symbole anordnen nach ® ....

Ergebnis

Die Liste der Informationsobjekte wird entsprechend Ihrer Wahl sortiert.

Im Menü wird das Attribut gekennzeichnet, nachdem Sie die Liste sortiert haben.


Verwaltung von Mappen

Verwendung

In der Knowledge Workbench können Sie Mappen anlegen und verwalten, die als Behälter für Gruppen von Informationsobjekten verwendet werden. Abgesehen von wenigen Ausnahmen (z.B. Mappen löschen) stehen in der Knowledge Workbench und im SAP-System des Knowledge Warehouse dieselben Funktionen zur Verfügung.

Integration

Wenn Sie mit der Knowledge Workbench im Online-Modus arbeiten, dann können Sie auf alle Mappen des Knowledge Warehouse zugreifen.

Ihre Favoriten werden im SAP-System des Knowledge Warehouse abgelegt.

Funktionsumfang

In der Knowledge Workbench können Sie:

  • Neue Mappen anlegen
  • Mappen suchen
  • Mappen den Favoriten hinzufügen
  • Mappen aus den Favoriten entfernen
  • Mappenattribute anzeigen


Mappe anlegen

Verwendung

Sie können neue Mappen direkt im Knowledge Warehouse anlegen oder die Mappe zuerst im Local Repository anlegen und dann in die Favoriten aufnehmen.

SAP empfiehlt, immer dann eine neue Mappe anlegen, wenn Sie ein neues Projekt erstellen möchten.

Voraussetzung

Sie befinden sich in der Knowledge Workbench.

Sie haben die Berechtigung für das Anlegen von Mappen.

Vorgehensweise

Um eine Mappe anzulegen, gehen Sie wie folgt vor:

  1. Positionieren Sie den Cursor im Knowledge Warehouse oder im Local Repository auf einen beliebigen Knoten.
  2. Wählen Sie Info-Objekt ® Neu ® Mappe ...

    3. Sie gelangen zum Assistenten Assistent Mappe anlegen, der Sie beim Anlegen der Mappe unterstützt.

  3. Wählen Sie Weiter.
  4. Geben Sie den Bereich ein, in dem Ihre Mappe angelegt werden soll und wählen Sie Weiter.
  5. Geben Sie die Mappenattribute an.

    6. Wenn Sie Standardwerte für die Info-Objekt-Klasse Mappe im ausgewählten Bereich gepflegt haben, dann sind die Felder vorbelegt.

  6. Wählen Sie Beenden.

Ergebnis

Wenn Sie die Mappe im Knowledge Warehouse angelegt haben, dann wird die neue Mappe als oberster Knoten in die Struktur Ihre Favoriten eingehängt. Wenn Sie die Favoriten auffrischen, dann werden die Mappen alphabetisch geordnet.

Wenn Sie im Local Repository eine neue Mappe angelegt haben, dann wird die neue Mappe im Local Repository abgelegt. In diesem Fall erscheint die Mappe erst dann im Knowledge Warehouse, wenn Sie die Mappe eingecheckt haben und zu Ihren Favoriten hinzugefügt haben.

Sie können nur Mappen einchecken, die Informationsobjekte enthalten.


Mappe suchen und im Explorer-Fenster anzeigen

Verwendung

Sie können im Knowledge Warehouse nach Mappen suchen und die Mappe anschließend in einem Explorer-Fenster anzeigen lassen.

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Vorgehensweise

Um eine Mappe im Knowledge Warehouse zu suchen, gehen Sie wie folgt vor:

  1. Wählen Sie Bearbeiten ® Suchen ® Mappen im Knowledge Warehouse.

Sie gelangen auf das Dialogfenster Mappe suchen.
  2. Wählen Sie den Bereich, in dem die Mappe gesucht werden soll.
  3. Um die Performance zu verbessern, schränken Sie die Suche anhand von Selektionskriterien ein.

SAP empfiehlt Ihnen, anhand des technischen Namens zu suchen, da dies am schnellsten Suchergebnisse bringt.
  4. Starten Sie die Suche.

    5. Die gefundenen Mappen werden aufgelistet.

  5. Wählen Sie die Mappe aus, die im Explorer-Fenster angezeigt werden soll.

    6. Sie gelangen auf das Dialogfenster Mappenkontext auswählen.

  6. Wählen Sie den Mappenkontext aus.

Ergebnis

Es wird ein Explorer-Fenster geöffnet.

In diesem Explorer-Fenster wird die ausgewählte Mappe und die enthaltenen Informationsobjekte im angegebenen Kontext angezeigt.


Organisation der Favoriten

Verwendung

Sie können häufig verwendete Mappen Ihren Favoriten hinzufügen.

Integration

Die Favoriten werden benutzerspezifisch abgelegt.

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Funktionsumfang

Sie können Mappen zu den Favoriten hinzufügen oder aus den Favoriten entfernen.

Sie können Mappen im Knowledge Warehouse anlegen und diese gleichzeitig in Ihre Favoriten aufnehmen.

Sie können Mappen aus der Einstiegsstruktur in Ihre Favoriten einfügen.


Mappe anlegen und den Favoriten hinzufügen

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Sie haben die Berechtigung zum Anlegen einer Mappe.

Vorgehensweise

Um eine Mappe anzulegen und den Favoriten hinzuzufügen, gehen Sie wie folgt vor:

  1. Wählen Sie Werkzeuge ® Favoriten organisieren.

Sie gelangen auf das Dialogfenster Organisieren der Favoriten.
  2. Wählen Sie Mappe anlegen.

Sie gelangen zum Assistenten Assistent Mappe anlegen, der Sie beim Anlegen der Mappe unterstützt.

  3. Wählen Sie Weiter.
  4. Geben Sie den Bereich ein, in dem Ihre Mappe angelegt werden soll und wählen Sie Weiter.
  5. Geben Sie die Mappenattribute an.

    6. Wenn Sie Standardwerte für die Info-Objekt-Klasse Mappe im ausgewählten Bereich gepflegt haben, dann sind die Felder vorbelegt.

  6. Wählen Sie Beenden.

Ergebnis

Die Mappe wird angelegt und zu den Favoriten hinzugefügt.


Mappe den Favoriten hinzufügen

Verwendung

Sie möchten Mappen, auf die Sie häufiger zugreifen, den Favoriten hinzufügen.

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Vorgehensweise

Ausgewählte Mappe aus der Einstiegsstruktur hinzufügen

Um eine Mappe aus der angezeigten Einstiegsstruktur den Favoriten hinzuzufügen, gehen Sie wie folgt vor:

  1. Markieren Sie in der Einstiegsstruktur eine Mappe.
  2. Wählen Sie Info-Objekt ® In Favoriten aufnehmen.

Mappe hinzufügen

Um eine Mappe aus dem Knowledge Warehouse den Favoriten hinzuzufügen, gehen Sie wie folgt vor:

  1. Wählen Sie Werkzeuge ® Favoriten organisieren.

Sie gelangen auf das Dialogfenster Organisieren der Favoriten.
  2. Wählen Sie Mappe einfügen.

Sie gelangen auf das Dialogfenster Mappe auswählen.
  3. Wählen Sie den Bereich, in dem die Mappe gesucht werden soll.
  4. Um die Performance zu verbessern, schränken Sie die Suche anhand von Selektionskriterien ein.

SAP empfiehlt Ihnen, anhand des technischen Namens zu suchen, da dies am schnellsten Suchergebnisse bringt.
  5. Starten Sie die Suche.

    6. Die gefundenen Mappen werden aufgelistet.

  6. Wählen Sie die Mappe aus, die zu den Favoriten hinzugefügt werden soll.

Ergebnis

Die ausgewählte Mappe wird zu den Favoriten hinzugefügt.


Mappe aus Favoriten entfernen

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Vorgehensweise

Um eine Mappe aus den Favoriten zu entfernen, gehen Sie wie folgt vor:

  1. Markieren Sie die Mappe, die Sie aus den Favoriten entfernen möchten.
  2. Wählen Sie Info-Objekt ® Aus Favoriten entfernen.

Ergebnis

Die ausgewählte Mappe wird aus den Favoriten entfernt.


Mappenattribute anzeigen

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Sie haben eine Mappe im Explorer-Fenster geöffnet.

Vorgehensweise

Um die Mappenattribute anzuzeigen, gehen Sie wie folgt vor:

  1. Markieren Sie eine Mappe.
  2. Wählen Sie Info-Objekt ® Info-Objekt-Attribute anzeigen.

Sie gelangen auf das Dialogfenster Info-Objekt-Attribute.

Ergebnis

Auf verschiedenen Registerkarten werden die Attribute der ausgewählten Mappe angezeigt.


Suche nach Mappen oder Informationsobjekten

Verwendung

Sie können nach Mappen oder Informationsobjekten suchen.

Integration

Diese Funktion wird Ihnen angeboten:

  • über das Menü als separate Funktion
  • beim Einfügen von Hyperlinks in Inhaltsobjekte
  • beim Einfügen von bereits existierenden Informationsobjekten in eine Struktur

Voraussetzungen

Wenn Sie nach Mappen oder Informationsobjekten im Knowledge Warehouse suchen möchten, müssen Sie im Online-Modus der Knowledge Workbench arbeiten.

Funktionsumfang

Sie können suchen nach

  • Informationsobjekten im Local Repository
  • Informationsobjekten im Knowledge Warehouse
  • Mappen im Knowledge Warehouse

Aktivitäten

Sie wählen Bearbeiten ® Suchen und dann eine der angezeigten Suchmöglichkeiten.


Informationsobjekte im Local Repository suchen

Verwendung

Sie können nach ausgecheckten Informationsobjekten im Local Repository suchen.

Voraussetzungen

Im Local Repository befinden sich Informationsobjekte.

Vorgehensweise

Um nach Informationsobjekten im Local Repository zu suchen, gehen Sie wie folgt vor:

  1. Wählen Sie Bearbeiten ® Suchen ® Info-Objekte im Local Repository

    2. Sie gelangen auf ein Dialogfenster, auf dem Sie den Kontext einstellen können, in dem Sie die Informationsobjekte suchen möchten.

  2. Stellen Sie den gewünschten Kontext ein.

    3. Sie gelangen auf ein Dialogfenster, auf dem Sie die Suchkriterien eingeben können.

  3. Geben Sie geeignete Suchkriterien ein und wählen Sie Suchen.

Sie erhalten eine Liste mit Informationsobjekten, die Ihren Suchkriterien entsprechen.

Ergebnis

Die gefundenen Informationsobjekte werden in einem Explorer-Fenster angezeigt, von dem aus Sie die Informationsobjekte anzeigen oder bearbeiten können.


Informationsobjekte im Knowledge Warehouse suchen

Verwendung

Sie können nach Informationsobjekten im Knowledge Warehouse suchen.

Voraussetzungen

Um im Knowledge Warehouse suchen zu können, müssen Sie am SAP-System des Knowledge Warehouse angemeldet sein.

Vorgehensweise

Um nach Informationsobjekten zu suchen, gehen Sie wie folgt vor:

  1. Wählen Sie Bearbeiten ® Suchen ® Info-Objekte im Knowledge Warehouse

    2. Sie gelangen auf ein Dialogfenster, auf dem Sie den Kontext einstellen können, in dem Sie die Informationsobjekte suchen möchten.

  2. Stellen Sie den gewünschten Kontext ein.

    3. Sie gelangen auf ein Dialogfenster, auf dem Sie die Suchkriterien eingeben können.

  3. Geben Sie geeignete Suchkriterien ein und wählen Sie Suchen.

Sie erhalten eine Liste mit Informationsobjekten, die Ihren Suchkriterien entsprechen.

Ergebnis

Die gefundenen Informationsobjekte werden in einem Explorer-Fenster angezeigt, von dem aus Sie die Informationsobjekte anzeigen oder bearbeiten können.


Mappen im Knowledge Warehouse suchen

Voraussetzungen

Um im Knowledge Warehouse suchen zu können, müssen Sie am SAP-System des Knowledge Warehouse angemeldet sein.

Vorgehensweise

Um nach Mappen zu suchen, gehen Sie wie folgt vor:

  1. Wählen Sie Bearbeiten ® Suchen ® Mappen im Knowledge Warehouse.
  2. Wählen Sie den Bereich aus, in dem Sie die Mappe suchen möchten.
  3. Geben Sie geeignete Suchkriterien ein und wählen Sie Suchen.

    4. Sie erhalten eine Liste mit den Mappen, die Ihren Suchkriterien entsprechen.

  4. Wählen Sie eine Mappe aus.

Sie gelangen auf ein Dialogfenster, in dem Sie den Kontext angeben können. In dem ausgewählten Kontext werden dann die Informationsobjekte der Mappe angezeigt.

Ergebnis

Die Informationsobjekte der ausgewählten Mappe werden in einem Explorer-Fenster angezeigt, von dem aus Sie die Informationsobjekte anzeigen oder bearbeiten können.


Anlegen neuer Informationsobjekte

Verwendung

Mit der Knowledge Workbench können Sie alle Arten von Informationsobjekten anlegen, die im Knowledge Warehouse zur Verfügung stehen.

Funktionsumfang

Die angelegten Informationsobjekte werden so lange in Ihrem Local Repository gespeichert, bis Sie sie in das Knowledge Warehouse einchecken . Erst dann können andere Benutzer des Knowledge Warehouse auf diese Objekte zugreifen.

Informationsobjekte werden immer in Mappen angelegt. Jede Mappe wird einem Bereich zugeordnet. Sie können Informationsobjekte nur in den Info-Objekt-Klassen anlegen, die es in dem jeweiligen Bereich gibt.

Neben den Funktionen zum Anlegen einzelner Informationsobjekte können Sie mit der Knowledge Workbench auch mehrere Informationsobjekte gleichzeitig auf der Grundlage einer Webseite oder PowerPoint-Präsentation erstellen.


Struktur anlegen

Vorgehensweise

Um eine Struktur anzulegen, gehen Sie wie folgt vor:

  1. Markieren Sie die Mappe, in der Sie die Struktur anlegen möchten.

    2. Die Mappe kann eine Mappe im Knowledge Warehouse oder eine Mappe im Local Repository sein. In beiden Fällen wird die Struktur im Local Repository angelegt.

  2. Wählen Sie Info-Objekt ® Neu ® Struktur ...

    3. Sie gelangen zum Assistenten Neue Struktur anlegen.

  3. Wählen Sie Weiter.

    4. Wenn Sie eine Struktur im Bereich Intranet-Management anlegen, dann wählen Sie die Info-Objekt-Klasse Structure aus und anschließend Weiter.

  4. Weisen Sie der Struktur ein Inhaltsobjekt als Wurzelobjekt zu, indem Sie ein Inhaltsobjekt anlegen oder ein vorhandenes Inhaltsobjekt verwenden.

Um ein neues Inhaltsobjekt als Wurzelobjekt anzulegen, gehen Sie wie folgt vor:
    1. Wählen Sie Wurzelobjekt anlegen >>>.

      2. Sie gelangen zum Assistenten Neues Inhaltsobjekt anlegen.

    2. Wählen Sie Weiter.
    3. Wählen Sie den Inhaltstyp für das neue Inhaltsobjekt aus und gehen Sie weiter.
    4. Wählen Sie Beenden.

Um ein vorhandenes Inhaltsobjekt als Wurzelobjekt zu verwenden, gehen Sie wie folgt vor:
    1. Wählen Sie Wurzelobjekt auswählen >>>.

      2. Sie gelangen auf das Dialogfenster Info-Objekt suchen.

    2. Geben Sie an, wie Sie das Informationsobjekt suchen möchten und wählen Sie Weiter .
    3. Um die Performance zu verbessern, geben Sie geeignete Suchkriterien ein.
    4. Starten Sie die Suche.

      5. Sie erhalten eine Liste mit den gefundenen Informationsobjekten.

    5. Markieren Sie das Informationsobjekt, welches Sie als Wurzelobjekt Ihrer Struktur verwenden möchten und wählen Sie Ok.

Sie gelangen wieder zum Assistenten Neue Struktur anlegen.

  5. Wählen Sie Weiter.
  6. Geben Sie die Attribute für die neue Struktur ein.

    7. Wenn Sie Standardwerte gepflegt haben, dann sind die Felder bereits vorbelegt.

  7. Wählen Sie Beenden.

Ergebnis

Die Struktur wird im Local Repository in der ausgewählten Mappe angelegt.

Wenn Sie eine Mappe im Knowledge Warehouse ausgewählt haben, wird die Struktur in der (temporären) Mappe desselben Namens im Local Repository erstellt.

Als Wurzelobjekt ist jetzt das Inhaltsobjekt angegeben, das Sie angelegt oder ausgewählt haben.


Inhaltsobjekt anlegen

Verwendung

Sie können neue Inhaltsobjekte in der Info-Objekt-Klasse HTML, Folie, Text oder Topic anlegen.

HTML-Objekte werden im Bereich Intranet-Management verwendet. Sie werden mit einem HTML-Editor bearbeitet.

Folien sind im Bereich Training die am häufigsten verwendete Art von Inhaltsobjekten. Sie werden mit MS PowerPoint bearbeitet.

Texte werden im Bereich Training und Topics im Bereich Dokumentation verwendet. Beide werden mit MS Word bearbeitet.

Vorgehensweise

Um ein Inhaltsobjekt anzulegen, gehen Sie wie folgt vor:

  1. Öffnen Sie die Mappe, in der Sie das neue Inhaltsobjekt anlegen möchten.
  2. Überprüfen Sie, ob der richtige Kontext eingestellt ist.
  3. Wählen Sie Info-Objekt ® Neu ® Inhaltsobjekt ...

    4. Sie gelangen zum Assistenten Neues Inhaltsobjekt anlegen.

  4. Wählen Sie Weiter.
  5. Wählen Sie den Inhaltstyp für das neue Inhaltsobjekt aus und gehen Sie weiter.
  6. Geben Sie die Attribute für das neue Inhaltsobjekt ein.

    7. Wenn Sie Standardwerte gepflegt haben, dann sind die Felder bereits vorbelegt.

  7. Wählen Sie Beenden.

Ergebnis

Das Inhaltsobjekt wird im Local Repository angelegt.


Multimedia-Objekt anlegen

Verwendung

Sie können ein neues Inhaltsobjekt der Info-Objekt-Klasse Multimedia-Objekt anlegen.

Sie können jedes beliebige Dokument als Multimedia-Objekt einchecken, welches über die Document Modeling Workbench modelliert wurde.

Allerdings stehen zur Bearbeitung des Inhalts von Multimedia-Objekten im Knowledge Warehouse keine Funktionen zur Verfügung, wie es für Inhaltsobjekte der Info-Objekt-Klassen Folie, Text und Topic der Fall ist. Die Inhalte der Multimedia-Objekte werden außerhalb des Knowledge Warehouse mit einer entsprechenden MS-Windows-Anwendung bearbeitet. Daher können Sie zwar von Folien, Texten, Topics und Strukturen einen Hyperlink auf Multimedia-Objekte setzen, nicht jedoch von Multimedia-Objekten auf andere Inhaltsobjekte.

Voraussetzung

Damit eine Multimedia-Datei als Multimedia-Objekt eingecheckt werden kann, muß ihr Format als Format im Knowledge Warehouse registriert sein. Außerdem muß die Anwendung auf dem PC installiert sein, die zur Bearbeitung oder Anzeige des Objekts benutzt wird.

Vorgehensweise

Um ein Multimedia-Objekt anzulegen, gehen Sie wie folgt vor:

  1. Öffnen Sie die Mappe, in der Sie das neue Multimedia-Objekt anlegen möchten.
  2. Überprüfen Sie, ob der richtige Kontext eingestellt ist.
  3. Wählen Sie Info-Objekt ® Neu ® Info-Objekt aus vorhandener Datei.

    4. Sie gelangen auf ein Dialogfenster, auf dem Sie in Ihrem Dateisystem navigieren können.

  4. Gehen Sie in das Verzeichnis, wo die Multimedia-Datei abgelegt ist.
  5. Markieren Sie die Datei und wählen Sie Open.

Sie gelangen zum Assistenten Informationsobjekte anlegen.

Der Multimedia-Datei wird die Info-Objekt-Klasse Multimedia-Objekt zugeordnet.
  5. Geben Sie die Attribute für das neue Multimedia-Objekt ein.

    6. Wenn Sie Standardwerte gepflegt haben, dann sind die Felder bereits vorbelegt.

    Sie gelangen auf eine Liste, in der die Multimedia-Datei aufgeführt ist, die als Multimedia-Objekt angelegt wird.

  6. Wählen Sie Beenden.

Ergebnis

Das Multimedia-Objekt wird im Local Repository angelegt.


Informationsobjekte aus einer vorhandenen Datei anlegen

Verwendung

Sie können eine komplette Webseite mit allen Komponenten oder die Folien einer PowerPoint-Präsentation als Informationsobjekte in das Knowledge Warehouse einchecken.

Beim Einchecken einer PowerPoint-Präsentation wird eine Struktur erstellt, in der die Folien in derselben Reihenfolge wie in der PowerPoint-Präsentation eingehängt werden.

Vorgehensweise

Um Informationsobjekte auf der Grundlage einer Webseite oder PowerPoint-Präsentation anzulegen, gehen Sie wie folgt vor:

  1. Öffnen Sie im Local Repository oder im Knowledge Warehouse die Mappe, die die Informationsobjekte aufnehmen soll, die Sie aus der Webseite oder der PowerPoint-Präsentation erstellen.
  2. Überprüfen Sie, ob der Kontext richtig eingestellt ist.
  3. Markieren Sie die Webseite oder die PowerPoint-Dateien in Ihrem lokalen Dateisystem und ziehen Sie sie in die Mappe, die die Infomationsobjekte aufnehmen soll.

Sie gelangen zum Assistenten Info-Objekte anlegen.
  4. Wählen Sie Weiter.

Sie sehen eine Liste der ausgewählten Datei bzw. der ausgewählten Dateien.

Sie können die Info-Objekt-Klasse beim Import der Dateien ändern (Info-Objekt-Klassen-Zuordnung ändern >>>).

Wählen Sie diese Option nur, wenn Sie die Webseite oder die PowerPoint-Präsentation als einzelnes allgemeines Informationsobjekt einchecken wollen.
  5. Wählen Sie Weiter.

    6. Die Dateien werden verarbeitet.

  6. Geben Sie die Attribute für die neuen Informationsobjekte ein, indem Sie das jeweilige Informationsobjekt markieren.

    7. Wenn Sie Standardwerte gepflegt haben, dann sind die Felder bereits vorbelegt.

    Anschließend wird eine Liste der Informationsobjekte angezeigt, die auf der Grundlage der Webseite oder der PowerPoint-Präsentation erzeugt werden sollen.

  7. Wählen Sie Beenden.

Ergebnis

Das System erstellt im Local Repository die Informationsobjekte auf Grundlage der von Ihnen ausgewählten Datei(en).


Trainingskapitel exportieren

Verwendung

Sie können sich eigene PowerPoint-Präsentationen zusammenstellen anhand des exportierten Trainingskapitels.

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Ein Trainingskapitel hat nur eine Unterebene.

Vorgehensweise

Um ein Trainingskapitel zu exportieren, gehen Sie wie folgt vor:

  1. Wählen Sie im Knowledge Warehouse die Struktur aus, die das zu exportierende Kapitel enthält.
  2. Wählen Sie Info-Objekt ® Pflegeformat anzeigen.

    3. Die Struktur wird zur Anzeige ausgecheckt und im Local Repository abgelegt. Anschließend wird sie im Struktur-Editor schreibgeschützt geöffnet.

  3. Positionieren Sie den Cursor auf der ersten Folie des Trainingskapitels
  4. Wählen Sie Info-Objekt ® Export des Kapitels ins lokale Dateisystem.

    5. Sie gelangen auf ein Dialogfenster, in dem Sie den Pfad angeben können, wo Sie das Kapitel als PowerPoint-Datei ablegen können.

  5. Stellen Sie den Pfad ein.
  6. Geben Sie einen Dateinamen ein und wählen Sie Save.

Ergebnis

Das Kapitel wird exportiert und in dem angegebenen Pfad als PowerPoint-Datei abgelegt.

Die einzelnen Objekte werden zur Anzeige ausgecheckt und im Local Repository abgelegt.


Auschecken von Informationsobjekten

Verwendung

Neben dem automatischen Auschecken durch Bearbeitung des Informationsobjekts können Sie auch Informationsobjekte auschecken, ohne sie sofort zu bearbeiten.

Diese Funktion ist gerade für die Arbeitsvorbereitung hilfreich.

Beim Auschecken werden Informationsobjekte auf dem PC so abgelegt, daß Sie dort auf alle Objekte desselben Kontexts zugreifen können.

Folgende Kontextparameter werden bei der lokalen Ablage berücksichtigt:

  • Sprache
  • Release
  • der Benutzer
  • die Bearbeitungsart
  • das R/3-System, aus dem die Informationsobjekte ausgecheckt wurden

Der um diese Attribute ergänzte Kontext bildet ein lokales Arbeitspaket auf dem PC.

Sie können nicht gemeinsam auf Informationsobjekte zugreifen, die

  • von verschiedenen Benutzern ausgecheckt wurden
  • in verschiedenen Bearbeitungsarten ausgecheckt wurden
  • aus unterschiedlichen SAP-Systemen ausgecheckt wurden.

Auch bei mehrfachem Auschecken von Informationsobjekten aus unterschiedlichen Mappen werden sie in demselben lokalen Kontext (Arbeitspaket) abgelegt, sofern sie dessen Merkmale haben.

In der Knowledge Workbench können Sie jeweils auf alle Informationsobjekte genau eines lokalen Kontexts gemeinsam zugreifen. Informationsobjekte können nur von dem Benutzer bearbeitet werden, der sie ausgecheckt hat.

Integration

Beim Einchecken von Informationsobjekten müssen das gewählte SAP-System und der Benutzer übereinstimmen mit den entsprechenden Werten des lokalen Kontexts der Informationsobjekte.

Voraussetzungen

Sie befinden sich im Einstiegsbild und möchten Informationsobjekte zur Offline-Bearbeitung auf dem PC auschecken.

Die Informationsobjekte sind nicht bereits von einem anderen Benutzer änderbar ausgecheckt.

Funktionsumfang

Informationsobjekte können änderbar oder schreibgeschützt ausgecheckt werden:

  • Änderbar ausgecheckte Informationsobjekte können bearbeitet werden. Sie sind gegen Änderungen durch andere Benutzer gesperrt. Sie können von anderen Benutzern jedoch angezeigt und als Ziel für Hyperlinks verwendet werden.
  • Zur Ansicht ausgecheckte Informationsobjekte können lediglich angezeigt, aber nicht bearbeitet werden.

Sie können eine Auswahl von Informationsobjekten auschecken oder alle Informationsobjekte, die zu einer Struktur gehören (nur im Struktureditor).


Informationsobjekte zum Ändern auschecken

Verwendung

Sie möchten mehrere Informationsobjekte auf einmal auschecken, ohne sofort zu bearbeiten.

Voraussetzungen

Sie haben die Info-Objekt-Liste der Mappe geöffnet, die die auszucheckenden Informationsobjekte enthält .

Die Informationsobjekte sind nicht bereits von einem anderen Benutzer änderbar ausgecheckt.

Vorgehensweise

  1. Markieren Sie die Informationsobjekte, die Sie auschecken möchten (über Shift oder Strg).
  2. Wählen Sie Info-Objekt ® Auschecken ® Zum Ändern.

Ergebnis

Die ausgewählten Informationsobjekte werden ausgecheckt und im Local Repository auf dem PC abgelegt.

Sie können jetzt die Informationsobjekte bearbeiten, auch ohne eine Verbindung zum Knowledge Warehouse zu haben.


Informationsobjekte zur Ansicht auschecken

Verwendung

Sie möchten mehrere Informationsobjekte auf einmal auschecken, um sie in Ihrer Struktur oder in Ihren Inhaltsobjekten zu verwenden, ohne daß Sie auf das Knowledge Warehouse zugreifen müssen.

Voraussetzungen

Sie haben die Info-Objekt-Liste der Mappe geöffnet, die die auszucheckenden Informationsobjekte enthält .

Vorgehensweise

  1. Markieren Sie die Informationsobjekte, die Sie auschecken möchten (über Shift oder Strg).
  2. Wählen Sie Info-Objekt ® Auschecken ® Zur Ansicht.

Ergebnis

Die ausgewählten Informationsobjekte werden ausgecheckt und im Local Repository auf dem PC abgelegt. Sie sind im Knowledge Warehouse nicht gesperrt und können weiterhin durch einen anderen Autoren bearbeitet werden.

Sie können jetzt die Informationsobjekte anzeigen oder darauf Links setzen, auch ohne eine Verbindung zum Knowledge Warehouse zu haben.


Informationsobjekte einer Struktur auschecken

Verwendung

Sie möchten alle Informationsobjekte einer Struktur zur Ansicht oder zum Ändern auschecken.

Voraussetzungen

Sie haben eine Struktur im Struktureditor geöffnet.

Vorgehensweise

Alle Informationsobjekte

Wählen Sie im Struktureditor Info-Objekt ® Auschecken ® Gesamte Struktur zum Ändern oder Info-Objekt ® Auschecken ® Gesamte Struktur zur Ansicht.

Auswahl von Informationsobjekten

Um mehrere Informationsobjekte auszuchecken, gehen Sie wie folgt vor:

  1. Markieren Sie die auszucheckenden Informationsobjekte im rechten Teil des Fensters mit Shift oder Strg.
  2. Wählen Sie im Struktureditor Info-Objekt ® Auschecken ® Zum Ändern oder Info-Objekt ® Auschecken ® Zur Ansicht.

Ergebnis

Die ausgewählten Informationsobjekte werden ausgecheckt und im Local Repository abgelegt.


Bearbeiten von Inhaltsobjekten

Verwendung

In der Knowledge Workbench bearbeiten Sie Inhaltsobjekte der Info-Objekt-Klassen Folie, Text und Topic mit MS PowerPoint oder MS Word. Diese beiden Editoren sind in die Knowledge Workbench integriert und werden automatisch aufgerufen, wenn Sie Inhaltsobjekte bearbeiten möchten. Sie wurden mit speziellen Bearbeitungsfunktionen des Knowledge Warehouse erweitert.

Inhaltsobjekte der Info-Objekt-Klasse HTML können in einem speziellen HTML-Editor bearbeitet werden, der Ihnen vom Knowledge Warehouse zur Verfügung gestellt wird.

Sie können auch Multimedia-Objekte (Info-Objekt-Klasse Multimedia-Objekt) bearbeiten, die mit Windows-Anwendungen (wie z.B. Lotus ScreenCam) erstellt wurden. Für diese Objekte stehen allerdings keine speziellen Bearbeitungsfunktionen des Knowledge Warehouse zur Verfügung.

Integration

Mit der Knowledge Workbench werden alle Inhalte lokal auf Ihrem PC im Local Repository bearbeitet.

Wenn Sie Objekte im Knowledge Warehouse auswählen und die Bearbeitungsfunktion aufrufen, werden die Objekte automatisch in das Local Repository auf Ihrem PC heruntergeladen und für Änderungen durch andere Benutzer gesperrt.

Wenn Sie die Bearbeitung der Inhaltsobjekte im Local Repository abgeschlossen haben, dann müssen Sie die Inhaltsobjekte einchecken.

Voraussetzungen

Wenn Sie Inhaltsobjekte aus dem Knowledge Warehouse bearbeiten möchten, die Sie noch nicht in das Local Repository heruntergeladen haben, dann müssen Sie die Knowledge Workbench im Online-Modus betreiben.

Die Inhaltsobjekte, die Sie bearbeiten möchten, dürfen nicht bereits von anderen Benutzern aus dem Knowledge Warehouse ausgecheckt sein. Inhaltsobjekte, die von anderen Benutzern ausgecheckt sind, können Sie nur anzeigen.

Funktionsumfang

Es stehen folgende Bearbeitungsfunktionen für die verschiedenen Arten von Inhaltsobjekten zur Verfügung:

Folie, Text und Topic (Editoren: PowerPoint und Word)

  • Inhalte bearbeiten
  • Standardsymbole einfügen
  • Hyperlinks auf andere Inhaltsobjekte einfügen, z.B. auf IMG-Dokumente und SAP-Glossarbegriffe (die als Inhalt des Knowledge Warehouse ausgeliefert werden)

HTML (Editor: HTML-Editor des Knowledge Warehouse)

  • Inhalte bearbeiten
  • Grafiken einfügen
  • Hyperlinks auf andere Inhaltsobjekte einfügen

Multimedia-Objekt (Editor: MS-Windows-Anwendung)

  • Inhalte bearbeiten (wenn die Anwendung lokal installiert ist) oder Inhaltsobjekte durch Einchecken einer neuen Objektdatei aktualisieren

Aktivitäten

Sie können eine Auswahl an Inhaltsobjekten direkt von der Info-Objekt-Liste einer Mappe aus oder bei der Pflege einer Struktur mit dem Struktur-Editor der Knowledge Workbench bearbeiten.


Erweiterung von Informationsobjekten

Verwendung

Sie können in Erweiterungsinhalten Informationsobjekte der SAP oder anderer zugrundeliegenden Basis-Kontexte verwenden, indem Sie:

  • auf Informationsobjekte der SAP oder des zugrundeliegenden Basis-Kontexts verweisen

Bei Verweisen auf Strukturen haben Sie die Möglichkeit, diese durch einen Link oder durch ein Include zu referenzieren.
  • Erweiterungen zu Informationsobjekten anlegen und diese Erweiterungsversionen Ihren Anforderungen entsprechend modifizieren

Die folgende Abbildung zeigt, in welcher Weise Sie SAP-Strukturen verwenden können.

Wenn Sie SAP-Strukturen in Ihren Erweiterungsinhalten unverändert wiederverwenden möchten, so reicht es aus, darauf zu verweisen, entweder durch einen Link (I.a) oder durch ein Include (I.b). Wenn Sie in einem späteren Erweiterungsrelease auf einem jüngeren SAP-Release als Basisrelease aufsetzen, wird bei dieser Art der Wiederverwendung automatisch auf die jüngere Version der SAP-Struktur verwiesen.

Wenn Sie eine SAP-Struktur in Ihren Erweiterungsinhalten nur in modifizierter Form verwenden möchten, dann müssen Sie zunächst eine Erweiterungsversion der Struktur anlegen. Diese kann dann modifiziert und ggf. durch einen Link (II.a) oder ein Include (II.b) referenziert werden.

Erweiterungen von SAP-Objekten bieten gegenüber der Neu-Erstellung von Informationsobjekten folgende Vorteile:

  • Sie ersparen Aufwand für das Erstellen von Struktur und Inhaltsobjekten. Dies macht sich insbesondere dann bemerkbar, wenn nur geringfügige Modifikationen gegenüber dem Standard durchzuführen sind.
  • Verknüpfungen von Inhaltsobjekten und Struktur mit dem R/3-System durch R/3-Links werden aus dem Standard übernommen. Wenn diese Verknüpfungen auch in der Erweiterung geeignet erscheinen, müssen also keine neuen, erweiterungsspezifischen R/3-Links gepflegt werden.
  • Etwaige Verweise auf die Info-Objekte werden ebenfalls übernommen. D.h. im Erweiterungskontext erscheint nun das Erweiterungsobjekt an allen Stellen, an denen auf das ihm zugrundeliegende SAP-Objekt verwiesen wird.

Aktivitäten

Sie verweisen in Inhaltsobjekten der Erweiterung auf SAP-Inhaltsobjekte, indem Sie Hyperlinks pflegen (siehe Hyperlinks zwischen Inhaltsobjekten pflegen ).

Sie verweisen in Strukturen der Erweiterung auf SAP-Inhaltsobjekte, indem Sie diese in die Struktur einfügen (siehe Info-Objekte einer Struktur hinzufügen ).

Sie verweisen in Strukturen der Erweiterung auf SAP-Strukturen, indem Sie diese als Link oder als Include in die Struktur einfügen (siehe Info-Objekte einer Struktur hinzufügen ).

Sie legen Erweiterungsversionen von SAP-Objekten an und modifizieren diese.

Beim nächsten SAP-Inhaltsupdate können Sie über den Strukturvergleich und über die Modifikationsliste prüfen, welche SAP-Informationsobjekte geändert wurden.


Erweiterung zu Informationsobjekten anlegen

Verwendung

Um SAP-Informationsobjekte in modifizierter Form in den von Ihnen gepflegten Erweiterungsinhalten wiederverwenden zu können, legen Sie Erweiterungen an.

Voraussetzungen

  • Sie befinden sich in einem Erweiterungskontext in einer Info Object List (SAPgui-Frontend) oder in einem Explorer-Fenster (Knowledge Workbench).
  • Die Informationsobjekte wurden im aktuellen Kontext nicht bereits erweitert. Hierbei ist allein die Erweiterung (Erweiterungsname) maßgeblich, nicht das Erweiterungsrelease.

Vorgehensweise

Knowledge Workbench

  1. Markieren Sie ein Info-Objekt.
  2. Wählen Sie Info-Objekt(e) ® bearbeiten

    3. In einem Dialogfenster erscheint die Meldung, daß das Informationsobjekt im aktuellen Kontext nicht existiert und erst eine Erweiterung angelegt werden muß, um es bearbeiten.

  3. Wählen Sie Weiter.

SAPgui-Frontend

  1. Markieren Sie ein oder mehrere Informationsobjekte.
  2. Wählen Sie Info-Objekt ® Erweiterung ® Anlegen.

Die markierten Informationsobjekte erscheinen nicht mehr gelb ("im aktuellen Kontext nicht änderbar"), sondern grau unterlegt.

In den Attributen Erweiterung und Änderungsrelease erhalten die Informationsobjekte die Werte des Erweiterungskontexts (Erweiterungsname und Erweiterungsrelease) zugewiesen.

Ergebnis

Es werden inhaltliche Kopien der markierten Informationsobjekte als Versionen des Erweiterungskontexts angelegt.

Sie können in einem Erweiterungskontext zu einem bereits erweiterten Informationsobjekt nicht erneut eine Erweiterung anlegen. Um ein erweitertes und bereits modifiziertes Informationsobjekt wieder auf den Stand zum Zeitpunkt des Erweiterns zurückzusetzen, oder um auf einer zwischenzeitlich veränderten, aktuelleren Version des SAP-Objekts aufzusetzen, können Sie jedoch die gewünschte Version in den Erweiterungskontext kopieren .


Bearbeiten und Sichern von Folien

Einsatzmöglichkeiten

Sie können Inhaltsobjekte der Info-Objekt-Klasse Folie in PowerPoint bearbeiten.

Sie können Folien bearbeiten, die sich im Knowledge Warehouse oder im Local Repository befinden. Während der Bearbeitung werden die Folien im Local Repository abgelegt.

Folgende Funktionen werden Ihnen zur Verfügung gestellt:

  • Bearbeiten einer oder mehrerer Folien
  • Bearbeiten der Folien eines Kapitels
  • Setzen von Hyperlinks

Voraussetzungen

Um auf Folien zugreifen zu können, die sich im Knowledge Warehouse befinden, müssen Sie die Knowledge Workbench im Online-Modus starten.

Ablauf

Sie markieren eine oder mehrere Folien und wählen Info-Objekt ® Info-Objekt(e) bearbeiten.

Sie markieren im Struktureditor ein Kapitel (Strukturknoten mit einer untergeordneten Ebene) und wählen Info-Objekt ® Kapitel bearbeiten.

Ergebnis

Die Folie wurde bearbeitet.

  • Wenn Sie den Bearbeitungsprozeß nicht beendet haben, dann bleibt der Bearbeitungsprozeß offen und wird in der Mappe am Ende der Info-Objekt-Liste angezeigt.

Er wird mit folgendem Symbol gekennzeichnet:

Wenn Sie die Anzeige auffrischen, stehen alle geöffneten Bearbeitungsprozesse am Anfang der Info-Objekt-Liste.

Sie können den Bearbeitungsprozeß fortsetzen.
  • Wenn Sie den Bearbeitungsprozeß beendet haben, dann werden folgende Aktionen ausgeführt:
    • Neue Inhaltsobjekte wurden im Local Repository angelegt.
    • Geänderte Inhaltsobjekte werden im Local Repository aktualisiert.
    • Die geänderte Struktur wird im Local Repository aktualisiert.


Folien bearbeiten

Voraussetzungen

Wenn die Inhaltsobjekte noch nicht in das Local Repository auf Ihrem PC heruntergeladen sind, dann müssen Sie die Knowledge Workbench im Online-Modus starten, damit Sie Zugriff auf das Knowledge Warehouse haben.

Sie haben die Mappe mit den Inhaltsobjekten in einem Explorer-Fenster geöffnet oder bearbeiten eine Struktur, die die Inhaltsobjekte enthält.

Vorgehensweise

Folien von der Info-Objekt-Liste der Mappe aus bearbeiten

  1. Wählen Sie im Knowledge Warehouse die Folien aus, die Sie bearbeiten möchten.

    2. Wenn Sie bereits ausgecheckte Folien bearbeiten möchten, dann wählen Sie die Folien im Local Repository aus.

  2. Wählen Sie Info-Objekt ® Info-Objekt(e) bearbeiten.

    3. Die ausgewählten Inhaltsobjekte werden vom Knowledge Warehouse in das Local Repository heruntergeladen. PowerPoint wird mit einer Datei geöffnet, die die Folien enthält.

    Um die Inhaltsobjekte samt ihrer Mappe im Local Repository anzusehen, markieren Sie den Knoten des Local Repository im Explorer-Fenster und frischen die Anzeige auf.

  3. Bearbeiten Sie die Folien in PowerPoint.
  4. Sichern Sie Ihre Änderungen.

    5. Weitere Informationen zum Sichern der Datei finden Sie unter Datei sichern .

  5. Schließen Sie die Datei.

    6. Weitere Informationen zum Schließen der Datei finden Sie unter Datei schließen .

  6. Schließen Sie PowerPoint.

Weitere Informationen zum Schließen von PowerPoint finden Sie unter PowerPoint schließen .

Folien bei der Strukturpflege mit dem Struktur-Editor bearbeiten

Sie können Folien auch vom Struktur-Editor aus bearbeiten:

  • Um Folien einzeln zu bearbeiten, wählen Sie eine Folie in der Struktur aus, die Sie gerade bearbeiten, und fahren Sie dann genauso fort wie oben beschrieben.
  • Um alle Folien eines Trainingskurskapitels zu bearbeiten, folgen Sie den Anweisungen in Kapitel eines Trainingskurses bearbeiten .

Wenn Sie nur die Struktur ausgecheckt haben und nicht die enthaltenen Folien, dann können Sie im Struktur-Editor das Auschecken aller enthaltenen Folien starten.

Ergebnis

Die Folien werden gesichert, und PowerPoint wird geschlossen. Im Local Repository nimmt das Attribut Geändert für die bearbeiteten Folien den Wert Ja an.


Kapitel eines Trainingskurses bearbeiten

Voraussetzungen

Sie bearbeiten die Kursstruktur im Struktur-Editor.

Ein Kapitel kann nur eine Unterebene haben.

Vorgehensweise

Um ein Kapitel zu bearbeiten, gehen Sie wie folgt vor:

  1. Überprüfen Sie, ob der richtige Kontext eingestellt ist.
  2. Wählen Sie den Einstiegsknoten eines Kapitels in der Struktur aus.

    3. Die Knoten unterhalb des Einstiegsknotens müssen alles Endknoten sein.

  3. Wählen Sie Info-Objekt ® Kapitel bearbeiten.

    4. Das Inhaltsobjekt des Einstiegsknotens und alle untergeordneten Inhaltsobjekte werden geöffnet.

    Wenn Sie Info-Objekt ® Info-Objekt(e) bearbeiten wählen, dann wird nur der Einstiegsknoten des Kapitels geöffnet.

  4. Bearbeiten Sie den Inhalt der Folien und ändern Sie die Reihenfolge der Folien in der PowerPoint-Datei nach Bedarf.
  1. Sichern Sie Ihre Änderungen.

    2. Weitere Informationen zum Sichern der Datei finden Sie unter Datei sichern .

  6. Schließen Sie die Datei.

    7. Weitere Informationen zum Schließen der Datei finden Sie unter Datei schließen .

  7. Schließen Sie PowerPoint.

Weitere Informationen zum Schließen von PowerPoint finden Sie unter PowerPoint schließen .

Ergebnis

Die Folien werden gesichert, und PowerPoint wird geschlossen.

Im Local Repository nimmt das Attribut Geändert für die bearbeiteten Folien und die Struktur den Wert Ja an.


Hyperlinks in Folien pflegen

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Sie haben eine Folie geöffnet.

Vorgehensweise

Hyperlink einfügen

Um einen Hyperlink einzufügen, gehen Sie wie folgt vor:

  1. Markieren Sie die Einfügeposition für den Hyperlink oder den Text, der als Hotspot für den Hyperlink benutzt werden soll.
  2. Wählen Sie SAP ® Insert Link to Info Object.

    3. Sie gelangen auf ein Dialogfenster, auf dem Sie angeben können, wie Sie nach dem Ziel-Inhaltsobjekt suchen möchten.

    Wenn das Dialogfenster Info-Objekt suchen nicht erscheint, dann verwenden Sie ALT+Tab, um das Dialogfenster in den Vordergrund zu bringen.

  3. Navigieren Sie zu der Mappe, die das gesuchte Inhaltsobjekt enthält oder geben Sie Suchkriterien ein, um das Inhaltsobjekt zu finden.
  4. Wählen Sie das Inhaltsobjekt aus und wählen Sie OK.

Ein Hyperlink auf das ausgewählte Inhaltsobjekt wird eingefügt. Wenn Sie keinen Text markiert haben, wird der Titel des Objektes als Hotspot für den Hyperlink verwendet.

Der Hyperlink wird gelb und unterstrichen dargestellt.

Hyperlink löschen

Um einen Hyperlink zu löschen, gehen Sie wie folgt vor:

  1. Markieren Sie den Hotspot des Hyperlinks.
  2. Wählen Sie Bearbeiten ® Ausschneiden oder drücken Sie ENTF.

Der Hyperlink wird zusammen mit dem Hotspot aus dem Dokument gelöscht.

Hyperlink-Hotspot ändern

Um einen Hyperlink-Hotspot zu ändern, gehen Sie wie folgt vor:

  1. Markieren Sie den Hotspot des Hyperlinks.
  2. Überschreiben Sie den Text.


Datei sichern

Verwendung

Mit dieser Vorgehensweise können Sie neu angelegte Folien oder geänderte Folien sichern.

Voraussetzungen

Sie befinden sich in der Knowledge Workbench und haben eine Folie in PowerPoint geöffnet.

Vorgehensweise

Wenn Sie die Bearbeitung der Datei beendet haben und die Datei sichern möchten, dann gehen Sie wie folgt vor:

  1. Wählen Sie SAP ® Save and Finish.

    2. Sie gelangen auf ein Dialogfenster, auf dem Sie für jedes Inhaltsobjekt bestätigen können, ob Sie Ihre Änderungen sichern möchten.

  2. Markieren Sie die Inhaltsobjekte, die angelegt oder gesichert werden sollen.
  3. Wählen Sie Weiter.

Die Änderungen wurden gesichert. Die PowerPoint-Datei wurde geschlossen. Der Bearbeitungsprozeß wurde beendet:
    • Neue Inhaltsobjekte wurden im Local Repository angelegt.
    • Geänderte Inhaltsobjekte werden im Local Repository aktualisiert.
    • Die geänderte Struktur wird im Local Repository aktualisiert.

Wenn Sie die Bearbeitung der Datei fortsetzen möchten und jetzt die Datei nur sichern möchten, dann gehen Sie wie folgt vor:

  1. Wählen Sie SAP ® Save.

    2. Die Änderungen werden gesichert.

    Der Bearbeitungsprozeß bleibt offen und wird in der Mappe am Ende der Info-Objekt-Liste angezeigt.

    Er wird mit folgendem Symbol gekennzeichnet:

    Wenn Sie die Anzeige auffrischen, stehen alle geöffneten Bearbeitungsprozesse am Anfang der Info-Objekt-Liste.

    Die Datei bleibt in PowerPoint geöffnet, so daß sie Ihre Arbeit fortsetzen können.

  2. Um die Datei zu schließen, wählen Sie SAP ® Close.

Die Datei wird geschlossen.

Weitere Informationen zum Schließen der Datei finden Sie unter Datei schließen .


Datei schließen

Verwendung

Mit dieser Vorgehensweise können Sie eine PowerPoint-Datei schließen.

Voraussetzungen

Sie befinden sich in der Knowledge Workbench und haben eine Datei im PowerPoint geöffnet.

Vorgehensweise

Um die Datei zu schließen, gehen Sie wie folgt vor:

  1. Wählen Sie SAP ® Close.

    2. Verwenden Sie nicht die Funktionen von MS PowerPoint, um die Datei zu schließen.

    Ansonsten wird der Bearbeitungsprozeß für Folien in der Knowledge Workbench nicht korrekt beendet.

  2. Geben Sie an, ob Sie Änderungen sichern möchten.
  3. Geben Sie an, ob Sie den Bearbeitungsprozeß beenden möchten.

Ergebnis

Auf dem folgenden Bild werden die Ergebnisse für die Anwendung der Funktion Close gezeigt:
  • Wenn Sie die Fragen zum Sichern der Datei und Beenden des Bearbeitungsprozesses mit Ja beantwortet haben, dann wurden Ihre Änderungen gesichert.

Wenn Sie mehrere Folien oder ein Kapitel in einer Datei geöffnet haben, dann gelangen Sie auf ein Dialogfenster, auf dem Sie für jedes Inhaltsobjekt bestätigen können, ob Sie Ihre Änderungen sichern möchten.

Die PowerPoint-Datei wurde geschlossen.

Der Bearbeitungsprozeß wurde beendet:
    • Neue Inhaltsobjekte wurden im Local Repository angelegt.
    • Geänderte Inhaltsobjekte werden im Local Repository aktualisiert.
    • Die geänderte Struktur wird im Local Repository aktualisiert.
  • Wenn Sie die Fragen zum Sichern der Datei und Beenden des Bearbeitungsprozesses mit Nein beantwortet haben, dann werden Ihre Änderungen nicht gesichert.

Die PowerPoint-Datei wurde geschlossen.

Der Bearbeitungsprozeß bleibt offen und wird in der Mappe am Ende der Info-Objekt-Liste angezeigt.

Er wird mit folgendem Symbol gekennzeichnet:

Wenn Sie die Anzeige auffrischen, stehen alle geöffneten Bearbeitungsprozesse am Anfang der Info-Objekt-Liste.

Sie können die Bearbeitung der Datei zu einem späteren Zeitpunkt fortsetzen .

  • Wenn Sie die Frage zum Beenden des Bearbeitungsprozesses mit Nein beantwortet haben, dann bleibt der Bearbeitungsprozeß offen und wird in der Mappe am Ende der Info-Objekt-Liste angezeigt.

Er wird mit folgendem Symbol gekennzeichnet:

Wenn Sie die Anzeige auffrischen, stehen alle geöffneten Bearbeitungsprozesse am Anfang der Info-Objekt-Liste.

Sie können die Bearbeitung der Datei zu einem späteren Zeitpunkt fortsetzen .


PowerPoint schließen

Verwendung

Mit dieser Vorgehensweise können Sie die Anwendung PowerPoint schließen.

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Sie haben alle Dateien in PowerPoint geschlossen .

Vorgehensweise

Um die Anwendung PowerPoint zu schließen, wählen Sie Datei ® Beenden.

Ergebnis

Die Anwendung PowerPoint wird geschlossen.


Bearbeitung der Datei fortsetzen

Verwendung

Sie können die Bearbeitung der Datei fortsetzen, wenn Sie

  • den Bearbeitungsprozeß der Datei nicht beendet haben
  • die Inhaltsobjekte noch nicht ins Knowledge Warehouse eingecheckt haben.

Voraussetzungen

Sie befinden sich in der Knowledge Workbench

Vorgehensweise

Bearbeitung fortsetzen, wenn der Bearbeitungsprozeß nicht beendet wurde

Um den Bearbeitungsprozeß einer Datei fortzusetzen, gehen Sie wie folgt vor:

  1. Markieren Sie den jeweiligen Bearbeitungsprozeß.

Er wird mit folgendem Symbol gekennzeichnet:

Sie können jeweils nur einen Bearbeitungsprozeß auswählen, um die Bearbeitung in PowerPoint fortzusetzen.
  2. Wählen Sie Info-Objekt ® Info-Objekt(e) bearbeiten.

Bearbeitung fortsetzen, wenn die Inhaltsobjekte noch nicht ins Knowledge Warehouse eingecheckt wurden

Um die Bearbeitung der Inhaltsobjekte fortzusetzen, markieren Sie die jeweiligen Inhaltsobjekte und wählen Info-Objekt ® Info-Objekt(e) bearbeiten.

Die Inhaltsobjekte werden wieder in PowerPoint geöffnet. Sie können die Bearbeitung fortsetzen.

Ergebnis

Die Datei wird wieder in PowerPoint geöffnet. Sie können die Bearbeitung fortsetzen.


Bearbeitungsprozeß abbrechen

Verwendung

Wenn sich die Datei in Powerpoint nicht mehr öffnen läßt, dann können Sie den Bearbeitungsprozeß abbrechen.

Es werden alle Änderungen gelöscht, auch wenn sie schon einmal gesichert wurden.

Um einen offenen Bearbeitungsprozeß zu beenden, dessen Datei sich öffnen läßt, verwenden Sie die Funktionen zum Bearbeiten von Folien .

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Es gibt einen nicht beendeten Bearbeitungsprozeß.

Er wird mit folgendem Symbol gekennzeichnet:

Dieser Bearbeitungsprozeß kann nicht fortgesetzt werden, da sich die Datei nicht öffnen läßt

Vorgehensweise

Um einen Bearbeitungsprozeß beenden, ohne die Datei in PowerPoint zu öffnen, gehen Sie wie folgt vor:

  1. Markieren Sie den Bearbeitungsprozeß, dessen Datei sich in PowerPoint nicht öffnen läßt.
  2. Wählen Sie Info-Objekt ® Attribute anzeigen.

    3. Sie gelangen auf das Dialogfenster Attribute des Bearbeitungsprozesses.

  3. Wählen Sie die Registerkarte Werkzeuge.
  4. Wählen Sie Jetzt beenden im Rahmen Den Bearbeitungsprozeß beenden.

    5. Es werden alle Änderungen gelöscht, auch wenn sie schon einmal gesichert wurden.

  5. Bestätigen Sie die Sicherheitsabfrage

Ergebnis

Der Bearbeitungsprozeß wird beendet.


Texte und Topics bearbeiten

Verwendung

Sie können Texte des Bereichs Training und Topics des Bereichs Dokumentation bearbeiten.

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Wenn die Inhaltsobjekte noch nicht in das Local Repository auf Ihrem PC heruntergeladen sind, dann müssen Sie die Knowledge Workbench im Online-Modus starten, damit Sie Zugriff auf das Knowledge Warehouse haben.

Vorgehensweise

Texte und Topics von der Info-Objekt-Liste der Mappe aus bearbeiten

Um Inhaltsobjekte der Info-Objekt-Klasse Text und Topic zu bearbeiten, gehen Sie wie folgt vor:

  1. Wählen Sie im Knowledge Warehouse den Text oder das Topic aus, das Sie bearbeiten möchten.
  2. Wählen Sie Info-Objekt ® Info-Objekt(e) bearbeiten.

    3. Wenn das ausgewählte Inhaltsobjekt noch nicht ausgecheckt wurde, wird es jetzt vom Knowledge Warehouse in das Local Repository heruntergeladen.

    Um das Inhaltsobjekt samt seiner Mappe im Local Repository anzuzeigen, markieren Sie den Knoten des Local Repository im Explorer-Fenster und frischen die Anzeige auf.

    Word wird geöffnet.

  3. Bearbeiten Sie das Inhaltsobjekt.
  4. Sichern Sie Ihre Änderungen.
  5. Schließen Sie die Datei.

Sie gelangen auf ein Dialogfenster, auf dem Sie für das Inhaltsobjekt bestätigen können, ob Sie Ihre Änderungen sichern möchten.
  6. Markieren Sie das Inhaltsobjekt, das angelegt oder gesichert werden soll.
  7. Wählen Sie Weiter.

Texte und Topics bei der Strukturpflege mit dem Struktur-Editor bearbeiten

Um Inhaltsobjekte der Info-Objekt-Klasse Text und Topic innerhalb des Struktur-Editor zu bearbeiten, gehen Sie wie folgt vor:

Wenn Sie nur die Struktur ausgecheckt haben und nicht die enthaltenen Inhaltsobjekte, dann können Sie im Struktur-Editor das Auschecken aller enthaltenen Inhaltsobjekte starten.
  1. Markieren Sie den Text oder das Topic, das Sie bearbeiten möchten.
  2. Wählen Sie Info-Objekt ® Info-Objekt(e) bearbeiten.

Wenn das ausgewählte Inhaltsobjekt noch nicht ausgecheckt wurde, wird es jetzt vom Knowledge Warehouse in das Local Repository heruntergeladen.

Word wird geöffnet.
  3. Bearbeiten Sie das Inhaltsobjekt.
  4. Sichern Sie Ihre Änderungen.
  5. Schließen Sie die Datei.

Sie gelangen auf ein Dialogfenster, auf dem Sie für das Inhaltsobjekt bestätigen können, ob Sie Ihre Änderungen sichern möchten.
  6. Markieren Sie das Inhaltsobjekt, das angelegt oder gesichert werden soll.
  7. Wählen Sie Weiter.

Ergebnis

Das Inhaltsobjekt wird gesichert und geschlossen. Im Local Repository nimmt das Attribut Geändert für das bearbeitete Inhaltsobjekt den Wert Ja an.


Hyperlinks in Texte oder Topics einfügen

Verwendung

Sie können Hyperlinks auf andere Inhaltsobjekte einfügen.

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Sie bearbeiten ein Text oder ein Topic in MS Word.

Vorgehensweise

Hyperlink einfügen

Um einen Hyperlink einzufügen, gehen Sie wie folgt vor:

  1. Markieren Sie die Einfügestelle für den Hyperlink oder den Text, der als Hotspot für den Hyperlink benutzt werden soll.
  2. Wählen Sie SAPKW ® Insert Link.

    3. Sie gelangen auf ein Dialogfenster, auf dem Ihnen mehrere Möglichkeiten geboten werden, um das Inhaltsobjekt zu finden, das Sie als Ziel des Hyperlinks definieren möchten.

    Wenn das Dialogfenster Info-Objekt suchen nicht erscheint, dann verwenden Sie ALT+Tab , um das Dialogfenster in den Vordergrund zu bringen.

  3. Navigieren Sie zu der Mappe, die das gesuchte Inhaltsobjekt enthält oder geben Sie Suchkriterien ein, um das Inhaltsobjekt zu finden.
  4. Wählen Sie das Inhaltsobjekt aus und wählen Sie OK.

Ein Hyperlink auf das ausgewählte Inhaltsobjekt wird eingefügt. Wenn Sie keinen Text markiert haben, wird der Titel des Objektes als Hotspot für den Hyperlink verwendet.

Der Hyperlink wird blau und unterstrichen dargestellt.

Ergebnis

Im Word-Dokument wird ein Hyperlink auf das selektierte Inhaltsobjekt eingefügt.

Der Hotspot des Links wird in blauer Farbe und unterstrichen dargestellt.

Ebenso können Sie Hyperlinks auf Glossardefinitionen einfügen.


Hyperlink ändern

Verwendung

Sie können das Ziel eines Hyperlinks oder den Hotspot-Text ändern.

Voraussetzungen

Sie haben ein Inhaltsobjekt geöffnet, in dem sich Hyperlinks befinden.

Vorgehensweise

Ziel eines Hyperlinks ändern

Um das Ziel eines Hyperlinks zu ändern, gehen Sie wie folgt vor:

  1. Löschen Sie den Hyperlink.
    • Wenn Sie alle Hyperlinks löschen möchten, die sich in einem Absatz befinden, dann markieren Sie den gesamten Absatz und wählen Strg 6.
    • Wenn sich im Absatz mehrere Hyperlinks befinden und Sie nur einen Hyperlink löschen möchten, dann positionieren Sie den Cursor vor diesem Hyperlink und wählen Strg 6.
  1. Setzen Sie den neuen Hyperlink.

Hotspot eines Hyperlinks ändern

Um den Hotspot eines Hyperlinks zu ändern, gehen Sie wie folgt vor:

  1. Markieren Sie den Hyperlink.
  2. Überschreiben Sie den Hotspot mit dem neuen Text.

Ergebnis

Das Ziel des Hyperlinks oder der Hotspot wurde geändert.


Hyperlink löschen

Voraussetzungen

Sie haben ein Inhaltsobjekt in Word geöffnet, in dem sich Hyperlinks befinden.

Vorgehensweise

Um einen Hyperlink zu löschen, gehen Sie wie folgt vor:

  • Wenn Sie alle Hyperlinks löschen möchten, die sich in einem Absatz befinden, dann markieren Sie den gesamten Absatz und wählen Strg 6 .
  • Wenn sich im Absatz mehrere Hyperlinks befinden und Sie nur einen Hyperlink löschen möchten, dann positionieren Sie den Cursor vor diesem Hyperlink und wählen Strg 6 .

Ergebnis

Der Hyperlink wurde gelöscht.


Einfügen von Grafiken in Texte oder Topics

Verwendung

Sie können in Ihre Texte und Topics Grafiken einfügen. Sie können alle Grafikformate einfügen, die dem Knowledge Warehouse bekannt sind.

Integration

Beim Einchecken werden die Grafiken in webfähige Formate konvertiert.

Funktionsumfang

Sie können

  • eine Grafik aus einer Datei mit mehreren Grafiken einfügen

Sie haben eine PowerPoint-Präsentation mit mehreren Grafiken. In dieser PowerPoint-Präsentation gibt es eine Grafik, die Sie in einem Text oder Topic wiederverwenden möchten.
  • eine Grafik-Datei einfügen

Sie haben eine PowerPoint-Präsentation, die nur aus einer Grafik besteht, die Sie in einem Text oder Topic wiederverwenden möchten.

ein Grafik-Objekt einfügen

Sie haben eine Bitmap-Grafik oder eine Gif-Datei, die Sie in einem Text oder Topic verwenden möchten.

Aktivitäten

Sie fügen die gewünschte Grafik ein.


Grafik aus einer Datei mit mehreren Grafiken einfügen

Verwendung

Sie können in Topics oder Texte eine PowerPoint-Grafik, aus einer Datei mit mehreren Grafiken herauslösen und in Ihr Inhaltsobjekt einfügen.

Voraussetzungen

Sie befinden sich in Word und haben ein Inhaltsobjekt geöffnet.

Sie haben PowerPoint geöffnet.

Vorgehensweise

Um eine Grafik aus einer Datei mit mehreren Grafiken in Ihr Inhaltsobjekt einzufügen, gehen Sie wie folgt vor:

  1. Wählen Sie in der Sortieransicht von PowerPoint die Grafik aus, die Sie in Ihr Inhaltsobjekt einfügen möchten und kopieren Sie sie in die Zwischenablage.
  2. Wechseln Sie nach Word in Ihr Inhaltsobjekt.
  3. Positionieren Sie den Cursor dort, wo die Grafik eingefügt werden soll.
  4. Wählen Sie Bearbeiten ® Inhalte einfügen.
  5. Markieren Sie Microsoft PowerPoint-Folie-Objekt.
  6. Deaktivieren Sie die Optionen Über den Text legen und als Symbol.
  7. Wählen Sie ok.

Ergebnis

Die PowerPoint-Grafik wird in Ihr Inhaltsobjekt eingefügt.


Grafik-Datei in Topics oder Texte einfügen

Voraussetzungen

Sie haben ein Inhaltsobjekt geöffnet.

Sie möchten eine Grafikdatei, z.B. im Bitmap-Format (BMP) einfügen.

Wenn Sie Ihre Inhaltsobjekte übersetzen möchten, dann verwenden Sie nur Grafik-Dateien, für die es einen Editor (z.B. PowerPoint) gibt.

Verwenden Sie dann die Vorgehensweise Grafik-Objekt in Topics oder Texte einfügen .

Vorgehensweise

  1. Wählen Sie die gewünschte Einfügeposition.
  2. Wählen Sie Einfügen ® Grafik ® Aus Datei...

    3. Sie gelangen auf das Dialogfenster Grafik einfügen.

  3. Schalten Sie die Optionen Verknüpfung zu Datei und Über den Text legen aus.
  4. Wählen Sie die gewünschte Datei aus und wählen Sie Einfügen.
  5. Positionieren Sie die Grafik durch Ausrichtung des Absatzes als links- oder rechtsbündig oder zentriert.

Ergebnis

Die Grafikdatei wird in das Inhaltsobjekt eingebettet und beim Sichern mit dem Inhaltsobjekt gespeichert.

Um eine mit einer anderen Anwendung erstellte Grafik in ein Word-Dokument einzufügen, muß ein entsprechender Grafikfilter installiert sein. Für BMP-Dateien wird kein Grafikfilter benötigt.


Grafik-Objekt in Topics oder Texte einfügen

Voraussetzungen

Sie befinden sich in Word und haben ein Inhaltsobjekt geöffnet. Sie möchten eine mit einer Microsoft Windows Anwendung erstellte Grafikdatei (z.B. eine PowerPoint-Datei) als Objekt in das Inhaltsobjekt einfügen.

Die Anwendung PowerPoint ist geöffnet.

Vorgehensweise

  1. Wählen Sie die gewünschte Einfügeposition.
  2. Wählen Sie Einfügen ® Objekt.

    3. Sie gelangen auf das Dialogfenster Objekt.

  3. Wählen Sie die Registerkarte Aus Datei erstellen und schalten Sie die Optionen Verknüpfen, Über den Text legen und Als Symbol aus.
  4. Wählen Sie die gewünschte Datei aus und wählen Sie OK.
  5. Positionieren Sie die Grafik durch Ausrichtung des Absatzes als links- oder rechtsbündig oder zentriert.

Ergebnis

Die Grafikdatei wird als Objekt in das Inhaltsobjekt eingebettet und beim Sichern mit dem Inhaltsobjekt gespeichert.

Eine als Objekt in ein Inhaltsobjekt eingebettete Grafik kann mit Bearbeiten ® <Anwendung>-Objekt ® Öffnen direkt aus Word heraus bearbeitet werden.


Standardsymbole in Topics einfügen

Voraussetzungen

Sie befinden sich in Word und haben ein änderbar ausgechecktes Inhaltsobjekt geöffnet.

Vorgehensweise

Symbol für Inhaltstyp in Titel einfügen

  1. Positionieren Sie den Cursor vor dem ersten Buchstaben des Titels.
  2. Wählen Sie SAPKW ® Standardsymbol einfügen.

    3. Sie gelangen auf das Dialogfenster zur Auswahl eines Standardsymbols.

  3. Wählen Sie das Symbol für den gewünschten Inhaltstyp aus und wählen Sie OK.

Symbol für Hinweis, Beispiel oder Warnung einfügen

  1. Wählen Sie die gewünschte Einfügeposition.
  2. Wählen Sie SAPKW ® Standardsymbol einfügen.

    3. Sie gelangen auf das Dialogfenster zur Auswahl eines Standardsymbols.

  3. Wählen Sie das gewünschte Symbol aus und wählen Sie OK.

Ergebnis

Das ausgewählte Standardsymbol wird an der Cursorposition eingefügt.


HTML-Objekte bearbeiten

Verwendung

Sie können HTML-Objekte des Bereichs Intranet-Management bearbeiten.

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Vorgehensweise

HTML-Objekte von der Info-Objekt-Liste der Mappe aus bearbeiten

Um Inhaltsobjekte der Info-Objekt-Klasse HTML zu bearbeiten, gehen Sie wie folgt vor:

  1. Wählen Sie im Knowledge Warehouse das HTML-Objekt aus, das Sie bearbeiten möchten.
  2. Wählen Sie Info-Objekt ® Info-Objekt(e) bearbeiten.

    3. Wenn das ausgewählte Inhaltsobjekt noch nicht ausgecheckt wurde, wird es jetzt vom Knowledge Warehouse in das Local Repository heruntergeladen.

    Um das Inhaltsobjekt samt seiner Mappe im Local Repository anzusehen, markieren Sie den Knoten des Local Repository im Explorer-Fenster und frischen die Anzeige auf.

    Der vom Knowledge Warehouse mitgelieferte HTML-Editor wird geöffnet.

  3. Bearbeiten Sie das Inhaltsobjekt.
  4. Sichern Sie Ihre Änderungen.
  5. Schließen Sie die Datei.

Sie gelangen auf ein Dialogfenster, auf dem Sie für das Inhaltsobjekt bestätigen können, ob Sie Ihre Änderungen sichern möchten.
  6. Markieren Sie das Inhaltsobjekt, das angelegt oder gesichert werden soll.
  7. Wählen Sie Weiter.

HTML-Objekte bei der Struktur- oder Verzeichnispflege mit dem Struktur-Editor bearbeiten

Um Inhaltsobjekte der Info-Objekt-Klasse HTML innerhalb des Struktur-Editor zu bearbeiten, gehen Sie wie folgt vor:

Wenn Sie nur die Struktur ausgecheckt haben und nicht die enthaltenen Inhaltsobjekte, dann können Sie im Struktur-Editor das Auschecken aller enthaltenen Inhaltsobjekte starten.
  1. Markieren Sie das HTML-Objekt, das Sie bearbeiten möchten.
  2. Wählen Sie Info-Objekt ® Info-Objekt(e) bearbeiten.

Der vom Knowledge Warehouse mitgelieferte HTML-Editor wird geöffnet.
  3. Bearbeiten Sie das Inhaltsobjekt.
  4. Sichern Sie Ihre Änderungen.
  5. Schließen Sie die Datei.

Sie gelangen auf ein Dialogfenster, auf dem Sie für das Inhaltsobjekt bestätigen können, ob Sie Ihre Änderungen sichern möchten.
  6. Markieren Sie das Inhaltsobjekt, das angelegt oder gesichert werden soll.
  7. Wählen Sie Weiter.

Ergebnis

Das Inhaltsobjekt wird gesichert und geschlossen. Im Local Repository nimmt das Attribut Geändert für das bearbeitete Inhaltsobjekt den Wert Ja an.


Tabelle einfügen

Verwendung

Sie können im HTML-Editor des Knowledge Warehouse Tabellen in HTML-Objekte einfügen

Voraussetzungen

Sie befinden sich im HTML-Editor des Knowledge Warehouse und haben ein HTML-Objekt geöffnet.

Vorgehensweise

Um eine Tabelle in ein HTML-Objekt einzufügen, gehen Sie wie folgt vor:

  1. Postionieren Sie den Cursor dort, wo Sie die Tabelle einfügen möchten.
  2. Wählen Sie Tabelle einfügen.

    3. Sie gelangen ein Dialogfenster.

  3. Geben Sie die Anzahl der Zeilen und Spalten an und wählen Sie Ok.

Ergebnis

Die Tabelle wird an der Einfügeposition eingefügt.


Webseite oder Bild als Hyperlink einfügen

Verwendung

Sie können im HTML-Editor des Knowledge Warehouse Hyperlinks in HTML-Objekte einfügen.

Voraussetzungen

Sie befinden sich im HTML-Editor des Knowledge Warehouse und haben ein HTML-Objekt geöffnet.

Im Web Browser wird die Webseite oder das Bild angezeigt, daß Sie als Zielobjekt verwenden möchten.

Vorgehensweise

Um einen Hyperlink einzufügen, gehen Sie wie folgt vor:

  1. Kopieren Sie die Adresse der Webseite oder des Bildes in die Zwischenablage.

Um die Adresse in die Zwischenablage zu kopieren, gehen Sie wie folgt vor:
    1. Klicken Sie auf die Webseite oder das Bild und wählen Sie über die rechte Maustaste Properties.
    2. Markieren Sie die vollständige Adresse.
    3. Klicken Sie auf die markierte Adresse und wählen Sie über die rechte Maustaste Copy.

Die Adresse wird in die Zwischenablage kopiert.
  1. Fügen Sie in das HTML-Objekt den Hyperlink ein.

Um den Hyperlink in das HTML-Objekt einzufügen, gehen Sie wie folgt vor:
    1. Markieren Sie im HTML-Editor den Text, der als Hotspot verwendet werden soll.
    2. Wählen Sie Hyperlink einfügen.

      3. Sie gelangen auf das Dialogfenster Hyperlink.

    3. Klicken Sie mit der rechten Maustaste auf das leere Feld URL und wählen Sie Paste.
    4. Überprüfen Sie, ob der Hyperlink vollständig ist.
    5. Wählen Sie OK.

Ergebnis

Der Hyperlink wurde eingefügt.


Hyperlink ändern

Verwendung

Sie können im HTML-Editor des Knowledge Warehouse Hyperlinks in HTML-Objekte ändern.

Voraussetzungen

Sie befinden sich im HTML-Editor des Knowledge Warehouse und haben ein HTML-Objekt geöffnet.

Vorgehensweise

Um einen Hyperlink zu ändern, gehen Sie wie folgt vor:

  1. Markieren Sie den Text, der als Hotspot verwendet wird.
  2. Wählen Sie Hyperlink einfügen.

    3. Sie gelangen auf das Dialogfenster Hyperlink.

  3. Geben Sie die neuen Hyperlink-Informationen ein und wählen Sie OK.

Ergebnis

Das Ziel des Hyperlinks wurde geändert.


Hyperlink löschen

Verwendung

Sie können im HTML-Editor des Knowledge Warehouse Hyperlinks in HTML-Objekten löschen.

Voraussetzungen

Sie befinden sich im HTML-Editor des Knowledge Warehouse und haben ein HTML-Objekt geöffnet.

Vorgehensweise

Um einen Hyperlink zu löschen, gehen Sie wie folgt vor:

  1. Positionieren Sie den Cursor auf dem Text, der den Hyperlink enthält.
  2. Wählen Sie Hyperlink einfügen.

    3. Sie gelangen auf das Dialogfenster Hyperlink.

  3. Löschen Sie die Hyperlink-Informationen und wählen Sie OK.

Ergebnis

Der Hyperlink wurde gelöscht. Der Text ist nicht mehr als Hotspot gekennzeichnet.


Bild einfügen

Verwendung

Sie können im HTML-Editor des Knowledge Warehouse Bilder in HTML-Objekte einfügen.

Voraussetzungen

Sie befinden sich im HTML-Editor des Knowledge Warehouse und haben ein HTML-Objekt geöffnet.

Vorgehensweise

Um ein Bild einzufügen, gehen Sie wie folgt vor:

  1. Postionieren Sie den Cursor dort, wo das Bild eingefügt werden soll.
  2. Wählen Sie Insert Image.

    3. Sie gelangen auf das Dialogfenster Picture.

  3. Geben Sie die Quelle des Bilds an oder wählen Sie es über Browse aus.
  4. Geben Sie einen Text an, der erscheinen soll, wenn das Bild nicht vorhanden ist.
  5. Geben Sie die Attribute für Layout und Spacing an.
  6. Wählen Sie Ok.

Ergebnis

Das Bild wird an der Cursorposition eingefügt.


Multimedia-Objekte bearbeiten

Verwendung

Sie können ein Multimedia-Objekt bearbeiten, z.B. Videos oder ScreenCam.

Voraussetzungen

Auf Ihrem PC muß die erforderliche Software zum Bearbeiten der Multimedia-Objekte installiert sein.

Sie befinden sich in der Knowledge Workbench.

Wenn die Inhaltsobjekte noch nicht in das Local Repository auf Ihrem PC heruntergeladen sind, dann müssen Sie die Knowledge Workbench im Online-Modus starten, damit Sie Zugriff auf das Knowledge Warehouse haben.

Vorgehensweise

  1. Wählen Sie im Knowledge Warehouse das Multimedia-Objekt aus, das Sie bearbeiten möchten.
  2. Wählen Sie Info-Objekt ® Info-Objekt(e) bearbeiten.

    3. Wenn das ausgewählte Inhaltsobjekt noch nicht ausgecheckt wurde, wird es jetzt vom Knowledge Warehouse in das Local Repository heruntergeladen.

    Wenn die erforderliche Software zum Bearbeiten des Multimedia-Objekts auf Ihrem PC installiert ist, dann wird die Software gestartet.

    Um das Inhaltsobjekt samt seiner Mappe im Local Repository anzuzeigen, markieren Sie den Knoten des Local Repository im Explorer-Fenster und frischen die Anzeige auf.

  3. Bearbeiten Sie das Multimedia-Objekt.
  4. Sichern Sie Ihre Änderungen.

Ergebnis

Das Inhaltsobjekt wird gesichert, und die Anwendung wird geschlossen. Im Local Repository nimmt das Attribut Geändert für das bearbeitete Inhaltsobjekt den Wert Ja an.


Bearbeiten von Strukturen

Verwendung

Sie können Ihre Informationsobjekte strukturieren und Verzeichnisse des Bereichs Intranet-Management bearbeiten.

Verzeichnisse des Bereichs Intranet-Management werden genauso bearbeitet wie Strukturen. Deshalb wird in den folgenden Abschnitten nur die Bearbeitung von Strukturen beschrieben.

Integration

Mit der Knowledge Workbench werden alle Strukturen lokal auf Ihrem PC im Local Repository bearbeitet.

Wenn Sie Objekte im Knowledge Warehouse auswählen und die Bearbeitungsfunktion aufrufen, werden die Objekte automatisch in das Local Repository auf Ihrem PC heruntergeladen und für Änderungen durch andere Benutzer gesperrt.

Außerdem werden die Informationen zu den Inhaltsobjekten heruntergeladen, auf die in der Struktur verwiesen wird.

Die Inhaltsobjekte selbst werden erst heruntergeladen, wenn Sie

  • die Bearbeitungsfunktion für Inhaltsobjekte aufrufen
  • die Informationsobjekte auschecken

In der Knowledge Workbench werden Strukturen mit dem Struktur-Editor bearbeitet. Wenn Sie im Knowledge Warehouse oder im Local Repository eine Struktur oder ein Verzeichnis zur Bearbeitung auswählen, dann wird der Struktur-Editor gestartet und die ausgewählte Struktur angezeigt.

Wenn Sie die Bearbeitung der Informationsobjekte im Local Repository abgeschlossen haben, müssen Sie die Informationsobjekte einchecken.

Voraussetzungen

Wenn Sie Informationsobjekte aus dem Knowledge Warehouse bearbeiten möchten, die Sie noch nicht in das Local Repository heruntergeladen haben, dann müssen Sie die Knowledge Workbench im Online-Modus betreiben.

Die Informationsobjekte, die Sie bearbeiten möchten, dürfen nicht bereits von anderen Benutzern aus dem Knowledge Warehouse ausgecheckt sein. Informationsobjekte, die von anderen Benutzern ausgecheckt sind, können Sie nur anzeigen.

Funktionsumfang

Für jede Struktur wird ein eigenes Fenster des Struktur-Editors geöffnet.

Das Fenster besteht aus zwei Rahmen:

  • Im linken Rahmen wird die Struktur als Baum angezeigt, dessen Knoten Sie expandieren und komprimieren können. Aktionen für einzelne Informationsobjekte können in der Baumansicht im linken Rahmen ausgeführt werden.
  • Im rechten Rahmen werden die Informationsobjekte des aktuell ausgewählten Knotens angezeigt. Wenn Sie Aktionen für mehrere Objekte gleichzeitig ausführen möchten, dann müssen Sie die Objekte im rechten Rahmen markieren.

Im Struktur-Editor können Sie:

  • Informationsobjekte der Struktur zum Ändern oder zur Ansicht auschecken
  • Informationsobjekte in eine Struktur einfügen
    • aus einer Mappe im Knowledge Warehouse oder Local Repository
    • aus einer Trefferliste, die durch eine Suche im Knowledge Warehouse oder Local Repository erstellt wurde
  • Informationsobjekte aus einer Struktur entfernen
  • Informationsobjekte innerhalb einer Struktur verschieben
  • Informationsobjekte innerhalb einer Struktur kopieren
  • Verknüpfungsart einer eingebetteten Struktur ändern(Struktur-Include in Struktur-Verweis oder umgekehrt)
  • Attributwerte von Informationsobjekten ändern und anzeigen

Aktivitäten

Sie wählen die zu bearbeitende Struktur aus.

Sie starten den Struktur-Editor mit Info-Objekt ® Info-Objekt(e) bearbeiten.


Neues Inhaltsobjekt in die Struktur einfügen

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Sie haben eine Struktur im Struktur-Editor geöffnet.

Vorgehensweise

Um ein neues Inhaltsobjekt in die Struktur einzufügen, gehen Sie wie folgt vor:

  1. Postionieren Sie den Cursor dort, wo das neue Inhaltsobjekt eingefügt werden soll.
  2. Wählen Sie Bearbeiten ® Neues Info-Objekt ® Vor Knoten ... oder Nach Knoten ... oder Als erster Unterknoten ... oder Als letzter Unterknoten ...

    3. Sie gelangen zum Assistenten Neues Inhaltsobjekt anlegen.

  3. Wählen Sie Weiter.
  4. Wählen Sie den Inhaltstyp für das neue Inhaltsobjekt aus und gehen Sie weiter.
  5. Geben Sie die Attribute für das neue Inhaltsobjekt ein.

    6. Wenn Sie Standardwerte gepflegt haben, dann sind die Felder bereits vorbelegt.

  6. Wählen Sie Beenden.

Ergebnis

Das neue Inhaltsobjekt wird in die Struktur eingefügt.


Informationsobjekte in eine Struktur einfügen

Verwendung

Sie können beliebige Informationsobjekte in die Struktur einfügen, die zum selben Bereich wie die Struktur (zum Beispiel Training) gehören.

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Sie haben die Struktur im Struktur-Editor geöffnet, in die Sie Informationsobjekte einfügen möchten.

Vorgehensweise

Um ein Informationsobjekt in die Struktur einzufügen, gehen Sie wie folgt vor:

  1. Positionieren Sie den Cursor dort, wo das Informationsobjekt eingefügt werden soll.
  2. Wählen Sie Bearbeiten ® Neues Info-Objekt ® Vor Knoten ... oder Nach Knoten ... oder Als erster Unterknoten ... oder Als letzter Unterknoten ...

    3. Sie gelangen auf das Dialogfenster Info-Objekt suchen.

  3. Wählen Sie aus, wie Sie nach Informationsobjekten suchen möchten.
  4. Wählen Sie Weiter.
    • Wenn Sie durch Suchen nach einer Mappe gewählt haben, dann wählen Sie auf dem Dialogfenster Mappe auswählen die Mappe aus, in der gesucht werden soll.
    • Wenn Sie durch Suchen im Local Repository gewählt haben, dann wählen Sie auf dem Dialogfenster Lokalen Kontext auswählen den lokalen Kontext aus, in dem gesucht werden soll.
    • Wenn Sie durch Suchen nach Info-Objekten im Knowledge Warehouse gewählt haben, dann geben Sie auf dem Dialogfenster Info-Objekte im Knowledge Warehouse suchen geeignete Suchkriterien ein, nach denen gesucht werden soll.
    • Wenn Sie durch Suchen nach einer Mappe im Knowledge Warehouse gewählt haben, dann geben Sie auf dem Dialogfenster Mappe auswählen geeignete Suchkriterien ein, nach denen gesucht werden soll.

Sie erhalten eine Liste mit den gefundenen Informationsobjekten.
  5. Wählen Sie das Informationsobjekt aus, das in die Struktur eingefügt werden soll.
  6. Wählen Sie Ok.

Ergebnis

Das Informationsobjekt wird in die Struktur eingefügt.

Eingefügt werden nur Referenzen auf die Informationsobjekte. Es werden keine physischen Kopien der eigentlichen Informationsobjekte erstellt.

Wenn Sie eine Struktur eingefügt haben, dann wird diese als Struktur-Include eingefügt.

Der Vorteil von Struktur-Includes ist, daß kein Bildwechsel in der Struktur erfolgt bei der Anzeige der Informationsobjekte.


Struktur-Include in einen Struktur-Link ändern

Verwendung

Wenn Sie eine Struktur in Ihre Struktur eingefügt haben, dann wird sie als Struktur-Include eingefügt.

Mit dieser Vorgehensweise können Sie ein Struktur-Include in einen Struktur-Link ändern.

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Sie haben im Struktur-Editor die Struktur geöffnet, in der das Struktur-Include enthalten ist.

Vorgehensweise

Um ein Struktur-Include in einen Struktur-Link zu ändern, gehen Sie wie folgt vor:

  1. Markieren Sie die Struktur, die als Struktur-Include eingefügt wurde.
  2. Wählen Sie Bearbeiten ® Knoteneigenschaften.

    3. Sie gelangen auf das Dialogfenster Knoteneigenschaften.

  3. Wählen Sie die Beziehungsart Struktur-Link.

Ergebnis

Die Beziehungsart der Struktur wurde auf Struktur-Link geändert.


Informationsobjekte innerhalb einer Struktur verschieben

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Die Struktur ist im Struktur-Editor geöffnet.

Vorgehensweise

Um Informationsobjekte innerhalb einer Struktur zu verschieben, gehen Sie wie folgt vor:

  1. Wählen Sie die Informationsobjekte aus, die Sie verschieben möchten.

    2. Wenn Sie ein Informationsobjekt verschieben möchten, dann wählen Sie dieses Informationsobjekt im linken Rahmen des Struktur-Editors aus.

    Wenn Sie mehrere Informationsobjekte verschieben möchten, dann wählen Sie diese im rechten Rahmen des Struktur-Editors aus.

  2. Ziehen Sie die ausgewählten Informationsobjekte mit gedrückter linker Maustaste an die neue Position innerhalb der Struktur im linken Rahmen des Struktur-Editors.

Wenn Sie die Maustaste loslassen, dann gelangen auf ein Dialogfenster mit den folgenden Einträgen:
    • Vor Knoten einfügen
    • Nach Knoten einfügen
    • Als erster Unterknoten einfügen
    • Als letzten Unterknoten einfügen
  3. Wählen Sie einen Eintrag.

Ergebnis

Das Informationsobjekt wird an die neue Position innerhalb der Struktur verschoben.


Informationsobjekte innerhalb einer Struktur kopieren

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Die Struktur ist im Struktur-Editor geöffnet.

Vorgehensweise

Um Informationsobjekte innerhalb der Struktur zu kopieren, gehen Sie wie folgt vor:

  1. Wählen Sie die Informationsobjekte aus, die Sie kopieren möchten.

    2. Wenn Sie ein Informationsobjekt kopieren möchten, dann wählen Sie dieses Informationsobjekt im linken Rahmen des Struktur-Editors aus.

    Wenn Sie mehrere Informationsobjekte kopieren möchten, dann wählen Sie diese im rechten Rahmen des Struktur-Editors aus.

  2. Wählen Sie Bearbeiten ® Kopieren.
  3. Positionieren Sie den Cursor innerhalb der Struktur im linken Rahmen des Struktur-Editors.
  4. Wählen Sie Bearbeiten ® Einfügen.

Sie gelangen auf ein Dialogfenster mit den folgenden Einträgen:
    • Vor dem aktuell ausgewählten Knoten
    • Nach dem aktuell ausgewählten Knoten
    • Als erster Unterknoten des aktuell ausgewählten Knotens
    • Als letzter Unterknoten des aktuell ausgewählten Knotens
  5. Wählen Sie einen Eintrag.

Ergebnis

Das Informationsobjekt wird kopiert und an der gewählten Position innerhalb der Struktur eingefügt.

Eingefügt werden nur Referenzen auf die Informationsobjekte. Es werden keine physischen Kopien der Informationsobjekte erstellt.


Informationsobjekte zwischen Strukturen kopieren

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Ausgangs- und Zielstruktur sind in je einem Fenster des Struktur-Editors geöffnet.

Vorgehensweise

Um Informationsobjekte zwischen Strukturen zu kopieren, gehen Sie wie folgt vor:

  1. Wählen Sie die Informationsobjekte aus, die Sie kopieren möchten.

Wenn Sie ein Informationsobjekt kopieren möchten, dann wählen Sie dieses Informationsobjekt im linken Rahmen des Struktur-Editors aus.

Wenn Sie mehrere Informationsobjekte kopieren möchten, dann wählen Sie diese im rechten Rahmen des Struktur-Editors aus.
  2. Wählen Sie Bearbeiten ® Kopieren.
  3. Positionieren Sie den Cursor innerhalb der anderen Struktur im linken Rahmen des Struktur-Editors.
  4. Wählen Sie Bearbeiten ® Einfügen.

Sie gelangen auf ein Dialogfenster mit den folgenden Einträgen:
    • Vor dem aktuell ausgewählten Knoten
    • Nach dem aktuell ausgewählten Knoten
    • Als erster Unterknoten des aktuell ausgewählten Knotens
    • Als letzter Unterknoten des aktuell ausgewählten Knotens
  5. Wählen Sie einen Eintrag.

Ergebnis

Das Informationsobjekt wird zwischen den Strukturen kopiert und an der gewählten Position innerhalb der anderen Struktur eingefügt.

Eingefügt werden nur Referenzen auf die Informationsobjekte. Es werden keine physischen Kopien der Informationsobjekte erstellt.


Informationsobjekt in der Struktur ersetzen

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Sie haben eine Struktur im Struktur-Editor geöffnet.

Vorgehensweise

Um ein Inhaltsobjekt in der Struktur zu ersetzen, gehen Sie wie folgt vor:

  1. Markieren Sie das Inhaltsobjekt, das ersetzt werden soll.
  2. Wählen Sie Bearbeiten ® Ausgewählten Knoten ersetzen.

Sie gelangen auf das Dialogfenster Info-Objekt suchen.
  3. Wählen Sie aus, wie Sie nach Informationsobjekten suchen möchten.
  4. Wählen Sie Weiter.
    • Wenn Sie durch Suchen nach einer Mappe gewählt haben, dann wählen Sie auf dem Dialogfenster Mappe auswählen die Mappe aus, in der gesucht werden soll.
    • Wenn Sie durch Suchen im Local Repository gewählt haben, dann wählen Sie auf dem Dialogfenster Lokalen Kontext auswählen den lokalen Kontext aus, in dem gesucht werden soll.
    • Wenn Sie durch Suchen nach Info-Objekten im Knowledge Warehouse gewählt haben, dann geben Sie auf dem Dialogfenster Info-Objekte im Knowledge Warehouse suchen geeignete Suchkriterien ein, nach denen gesucht werden soll.
    • Wenn Sie durch Suchen nach einer Mappe im Knowledge Warehouse gewählt haben, dann geben Sie auf dem Dialogfenster Mappe auswählen geeignete Suchkriterien ein, nach denen gesucht werden soll.

Sie erhalten eine Liste mit den gefundenen Informationsobjekten.
  5. Wählen Sie ein Informationsobjekt aus.
  6. Wählen Sie Ok.

Ergebnis

Das Informationsobjekt wird durch das ausgewählte Informationsobjekt ersetzt, indem das vorherige Informationsobjekt aus der Struktur entfernt wird und das ausgewählte Informationsobjekt eingesetzt wird.

Das entfernte Informationsobjekt ist weiterhin im Knowledge Warehouse vorhanden.


Informationsobjekte aus einer Struktur entfernen

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Die Struktur ist im Struktur-Editor geöffnet.

Vorgehensweise

Um Informationsobjekte aus der Struktur zu entfernen, gehen Sie wie folgt vor:

  1. Wählen Sie die Informationsobjekte aus, die Sie entfernen möchten.

    2. Wenn Sie ein Informationsobjekt entfernen möchten, dann wählen Sie dieses Informationsobjekt im linken Rahmen des Struktur-Editors aus.

    Wenn Sie mehrere Informationsobjekte entfernen möchten, dann wählen Sie diese im rechten Rahmen des Struktur-Editors aus.

  2. Wählen Sie Bearbeiten ® Knoten entfernen oder drücken Sie die Taste Entf .

Ergebnis

Das Informationsobjekt wird aus der Struktur entfernt.

Es wird nur die Referenz auf das Informationsobjekt entfernt. Das physische Informationsobjekt wird nicht gelöscht und ist weiterhin im Knowledge Warehouse vorhanden.


Informationsobjekt-Attribute in Strukturen pflegen

Verwendung

Sie können folgende Informationsobjekt-Attribute pflegen und anzeigen:

  • die Art der Verknüpfung zwischen einer Struktur und einem anderen Strukturobjekt, das in die Struktur eingebettet ist (Struktur-Link oder Struktur-Include)
  • allgemeine Attribute von Informationsobjekten in einer Struktur

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Die Struktur mit den Informationsobjekten ist im Struktur-Editor geöffnet.

Vorgehensweise

Um die einzelnen in der folgenden Tabelle aufgeführten Funktionen aufzurufen, wählen Sie das Informationsobjekt in der Struktur aus und öffnen das Kontextmenü mit der rechten Maustaste.

Funktion | Eintrag im Kontextmenü
Verknüpfungsart für die gewählte eingebettete Struktur ändern | Knoteneigenschaften ...
Attributwerte der ausgewählten Informationsobjekte anzeigen | Attribute anzeigen ...
Attributwerte der ausgewählten Informationsobjekte ändern | Attribute ändern ...
Kontexte anzeigen, in denen es Versionen der ausgewählten Informationsobjekte gibt | Kontextliste anzeigen ...
Informationsobjekte anzeigen, die einen Link auf das ausgewählte Info-Objekt haben | Verwendungsnachweis ...


Bearbeiten von Web-Verzeichnissen

Verwendung

Sie können Web-Verzeichnisse des Bereichs Intranet-Management bearbeiten.

Die Funktionen zur Bearbeitung von Verzeichnissen stimmen mit den Funktionen zur Bearbeitung von Strukturen überein. Verwenden Sie deshalb die Dokumentation zum Bearbeiten von Strukturen .

Im Unterschied zu Strukturen können Verzeichnisse nur eine Ebene unter dem Wurzelobjekt haben.


Informationsobjekte ins Knowledge Warehouse einchecken

Verwendung

Sie checken die Informationsobjekte ins Knowledge Warehouse ein, die Sie im Local Repository angelegt oder bearbeitet haben.

Wenn Sie die Informationsobjekte eingecheckt haben, dann steht der (aktualisierte) Inhalt dieser Objekte anderen Benutzern des Knowledge Warehouse zur Verfügung.

Voraussetzungen

Sie arbeiten mit der Knowledge Workbench im Online-Modus.

Die Informationsobjekte wurden neu angelegt oder geändert.

Vorgehensweise

Um Informationsobjekte ins Knowledge Warehouse einzuchecken, gehen Sie wie folgt vor:

  1. Wählen Sie im Local Repository die Informationsobjekte aus, die Sie ins Knowledge Warehouse einchecken möchten.

    2. Sie können nur Informationsobjekte einchecken, für die das Attribut Geändert den Wert Ja hat.

  2. Wählen Sie Info-Objekt ® Info-Objekt(e) aktualis.

    3. Die ausgewählten Informationsobjekte werden ins Knowledge Warehouse eingecheckt.

    Sie gelangen auf ein Dialogfenster, auf dem bestätigt wird, daß der Eincheckvorgang erfolgreich abgeschlossen wurde.

  3. Wählen Sie OK.

Ergebnis

Die Informationsobjekte wurden ins Knowledge Warehouse eingecheckt.

Wenn Sie die Objekte zuvor zur Bearbeitung aus dem Knowledge Warehouse ausgecheckt haben, dann stehen jetzt die neuen (aktualisierten) Versionen dieser Objekte im Knowledge Warehouse zur Verfügung.

Im Local Repository sind nur noch die Informationsobjekte vorhanden, die Sie nicht geändert oder neu angelegt haben. Somit können Sie an diesen Objekten die Arbeit fortsetzen, ohne erneut auszuchecken. Wenn Sie diese Informationsobjekte nicht mehr bearbeiten möchten, dann können Sie diese Informationsobjekte aus dem Local Repository entfernen .


Anzeigen und Ändern von Info-Objekt-Attributen

Verwendung

Die Informationsobjekte im Knowledge Warehouse haben eine Reihe von Attributen, die die Informationsobjekte oder deren Entwicklungsprozeß beschreiben, z.B. Inhaltstyp, Status, Erstellungsdatum.

Entsprechend ihrer unterschiedlichen Funktionen werden manche Attribute von den Benutzern des Knowledge Warehouse gepflegt und andere vom R/3-System vergeben.

Integration

Alle Attribute können Sie für die Suche nach Informationsobjekten verwenden.

Funktionsumfang

Sie können sich alle Info-Objekt-Attribute zu einem ausgewählten Informationsobjekt anzeigen lassen.

In der Knowledge Workbench können Sie folgende Info-Objekt-Attribute ändern:

  • Strukturen
    • Verwendungsart
    • Status
  • Inhaltsobjekte
    • Status

Wenn Sie ein Informationsobjekt im Local Repository angelegt und es noch nicht ins Knowledge Warehouse eingecheckt haben, dann können Sie auch den Verantwortlichen und den technischen Namen ändern.

Ansonsten können Sie die Info-Objekt-Attribute (wie z.B. Inhaltstyp, technischer Name, Verantwortlicher) im SAP-System pflegen.


Info-Objekt-Attribute anzeigen

Vorgehensweise

Um die Info-Objekt-Attribute zu einem ausgewählten Informationsobjekt anzuzeigen, gehen Sie wie folgt vor:

  1. Wählen Sie ein Informationsobjekt aus.
  2. Wählen Sie Info-Objekt ® Info-Objekt-Attribute anzeigen.

Ergebnis

Auf dem Dialogfenster Info-Objekt-Attribute auf der Registerkarte Attribute werden Ihnen die Info-Objekt-Attribute zum ausgewählten Informationsobjekt angezeigt.


Info-Objekt-Attribute ändern

Verwendung

In der Knowledge Workbench können Sie folgende Info-Objekt-Attribute ändern:

  • Strukturen
    • Verwendungsart
    • Status
  • Inhaltsobjekte
    • Status

Wenn Sie ein Informationsobjekt im Local Repository angelegt und es noch nicht ins Knowledge Warehouse eingecheckt haben, dann können Sie auch den Verantwortlichen und den technischen Namen ändern.

Ansonsten können Sie die Info-Objekt-Attribute (wie z.B. Inhaltstyp, technischer Name, Verantwortlicher) im SAP-System pflegen.

Vorgehensweise

Um Info-Objekt-Attribute einer Struktur oder von Inhaltsobjekten zu ändern, gehen Sie wie folgt vor:

  1. Wählen Sie ein Informationsobjekt aus.
  2. Wählen Sie Info-Objekt ® Info-Objekt-Attribute ändern.

    3. Sie gelangen auf das Dialogfenster Info-Objekt-Attribute, in dem Ihnen die änderbaren Attribute angezeigt werden.

  3. Ändern Sie die Attribute und sichern Sie Ihre Eingaben.

Ergebnis

Die Info-Objekt-Attribute für das ausgewählte Informationsobjekt wurden geändert.


Info-Objekt-Status

Verwendung

Das Attribut Status kennzeichnet den Bearbeitungsstand eines Informationsobjekts. Der Status wird von Autoren und Übersetzern gepflegt.

In der Bearbeitungsart Ändern zeigt dieses Attribut den Bearbeitungsstand eines Informationsobjekts in der Originalsprache.

Funktionsumfang

Folgende Info-Objekt-Status werden unterschieden:

Status | Bedeutung
Migriert | Informationsobjekt (IO) wurde in Knowledge Warehouse migriert, dort aber noch nicht bearbeitet.
Bearbeitung | IO wurde im aktuellen Kontext noch nicht für die Übersetzung und die Auslieferung freigegeben. Es ist für die Übersetzung nicht zugreifbar. Dieser Status wird automatisch gesetzt, wenn ein Informationsobjekt ausgecheckt wird. Er kann auch manuell gesetzt werden.
Zur Freigabe | Dieser Status wird eingeblendet, wenn das Genehmigungsverfahren aktiviert ist. IO wurde im aktuellen Kontext für die Freigabe vorgesehen. Dieser Status wird manuell gesetzt, wenn der Autor seine Arbeit abgeschlossen hat. Dann erscheint dieses Informationsobjekt automatisch beim Genehmigenden im Eingang des Business Workflow. Der Genehmigende kann den Status Freigegeben oder Nicht freigegeben setzen.
Nicht freigegeben | Dieser Status wird eingeblendet, wenn das Genehmigungsverfahren aktiviert ist. IO muß noch einmal vom Autoren überarbeitet werden. Dieser Status wird manuell gesetzt, wenn der Genehmigende seine Arbeit abgeschlossen hat. Dann erscheint dieses Informationsobjekt automatisch beim Mappenverantwortlichen im Eingang des Business Workflow.
Freigegeben | IO wurde im aktuellen Kontext für die Übersetzung und die Auslieferung freigegeben. Dieser Status wird manuell gesetzt, wenn der Autor oder der Genehmigende seine Arbeit abgeschlossen hat. Dann erscheint dieses Informationsobjekt automatisch bei der Übersetzung. Zusätzlich wird für den Übersetzer ein Übersetzungsstatus generiert, der angibt, ob das Informationsobjekt neu ist (Übersetzungsstatus: neu) oder geändert wurde (Übersetzungsstatus: zu übersetzen).
Copy Editing | IO wird einem Copy Editing unterzogen. Dieser Status wird manuell gesetzt. Wenn das Copy-Editing-Verfahren aktiviert ist, dann wird das Informationsobjekt über den Business Workflow an den Copy-Editor geschickt. Ansonsten hat dieser Status nur einen dokumentarischen Zweck. Der Copy-Editor kann den Status Freigegeben oder Wiedervorlage setzen.
Wiedervorlage | Dieser Status wird eingeblendet, wenn das Copy-Editing-Verfahren aktiviert ist. IO wurde nicht dem Copy-Editing unterzogen. Dieser Status wird manuell gesetzt, wenn der Copy-Editor das Informationsobjekt nicht geprüft hat. Dann erscheint dieses Informationsobjekt automatisch beim Mappenverantwortlichen im Eingang des Business Workflow.
Review | IO wird einem inhaltlichen Review unterzogen. Dieser Status wird manuell gesetzt und hat nur einen dokumentarischen Zweck.


Info-Objekt-Status ändern

Vorgehensweise

Um den Info-Objekt-Status zu ändern, gehen Sie wie folgt vor:

  1. Wählen Sie ein Informationsobjekt aus.
  2. Wählen Sie Info-Objekt ® Info-Objekt-Attribute ändern.

    3. Sie gelangen auf das Dialogfenster Info-Objekt-Attribute, in dem Ihnen die änderbaren Attribute angezeigt werden.

  3. Wählen Sie einen Wert für den Info-Objekt-Status und sichern Sie Ihre Eingaben.

Ergebnis

Der Status für das ausgewählte Informationsobjekt wurde geändert.


Verwendungsart von Strukturen ändern

Verwendung

Sie können die Verwendungsart einer Struktur ändern.

Es gibt folgende Verwendungsarten:

  • Buchstruktur

Eine Buchstruktur kann unabhängig von anderen Strukturen angezeigt werden.

Sie kann als Strukturverweis oder Struktur-Include verwendet werden.

Bei der Aushärtung wird für jede Buchstruktur eine HTML-Help-Datei (.chm) erzeugt.
  • Teilstruktur

Eine Teilstruktur kann nur über eine andere Struktur angezeigt werden.

Sie kann nur als Struktur-Include verwendet werden.

Vorgehensweise

Um die Verwendungsart von Strukturen zu ändern, gehen Sie wie folgt vor:

  1. Wählen Sie eine Struktur aus.
  2. Wählen Sie Info-Objekt ® Info-Objekt-Attribute ändern.

    3. Sie gelangen auf das Dialogfenster Info-Objekt-Attribute, in dem Ihnen die änderbaren Attribute angezeigt werden.

  3. Wählen Sie einen Wert für die Verwendungsart und sichern Sie Ihre Eingaben.

Ergebnis

Die Verwendungsart für die ausgewählte Struktur wurde geändert.


Anzeigen von Informationsobjekten aus der Knowledge Workbench

Verwendung

Sie können sich Informationsobjekte aus der Knowledge Workbench heraus anzeigen lassen.

Integration

Wenn Sie Informationsobjekte aus dem Knowledge Warehouse zur Anzeige auswählen, dann wird der Web Browser gestartet.

Voraussetzungen

Sie befinden sich in der Knowledge Workbench.

Funktionsumfang

Folgende Anzeigemöglichkeiten werden Ihnen zur Verfügung gestellt:

Informationsobjekte anzeigen

  • Knowledge Warehouse

Die ausgewählten Informationsobjekte werden im Web Browser angezeigt.
  • Local Repository

Im Local Repository können nur Inhaltsobjekte angezeigt werden. Es wird der dazugehörige Editor gestartet. Das Inhaltsobjekt ist schreibgeschützt.

Pflegeformat anzeigen

  • Knowledge Warehouse

Die ausgewählten Informationsobjekte werden im dazugehörigen Editor schreibgeschützt angezeigt. Sie werden zur Anzeige ausgecheckt und im Local Repository mit dem Status Anzeige abgelegt.

  • Local Repository

Die ausgewählten Informationsobjekte werden im dazugehörigen Editor schreibgeschützt angezeigt.

Aktivitäten

Sie wählen Info-Objekt ® Info-Objekt(e) anzeigen oder Info-Objekt ® Pflegeformat anzeigen.


Informationsobjekte im Web Browser anzeigen

Verwendung

Sie können die aktuelle Version eines Informationsobjektes im Web Browser anzeigen, die sich im Knowledge Warehouse befindet.

Wenn das Informationsobjekt gerade ausgecheckt ist und von einem anderen Autor bearbeitet wird, dann sehen Sie nicht die Änderungen, die dieser Autor an dem Informationsobjekt in seinem Local Repository vorgenommen hat.

Voraussetzungen

Sie arbeiten mit der Knowledge Workbench im Online-Modus.

Vorgehensweise

Um Informationsobjekte im Web Browser anzuzeigen, gehen Sie wie folgt vor:

  1. Wählen Sie das Informationsobjekt im Knowledge Warehouse aus, das Sie im Web Browser anzeigen möchten.
  2. Wählen Sie Info-Objekt ® Info-Objekt(e) anzeigen.

Ergebnis

Das Informationsobjekt wird in Ihrem Web Browser angezeigt.


Inhaltsobjekte im Local Repository anzeigen

Verwendung

Sie können ein Inhaltsobjekt anzeigen, das zur Bearbeitung ins Local Repository ausgecheckt wurde.

Vorgehensweise

  1. Wählen Sie ein Inhaltsobjekt im Local Repository aus.
  2. Wählen Sie Info-Objekt ® Info-Objekt(e) anzeigen.

Ergebnis

Das Inhaltsobjekt wird in dem Editor angezeigt, der der Info-Objekt-Klasse des Objekts entspricht.

Da die HTML-Versionen von Inhaltsobjekten erst beim Einchecken ins Knowledge Warehouse erstellt werden, werden die Inhaltsobjekte im Local Repository in ihrem Pflegeformat angezeigt.


Informationsobjekte im Pflegeformat anzeigen

Voraussetzung

Sie befinden sich in der Knowledge Workbench.

Vorgehensweise

  1. Wählen Sie ein Informationsobjekt aus.
  2. Wählen Sie Info-Objekt ® Pflegeformat anzeigen.

Ergebnis

Das ausgewählte Informationsobjekt wird zur Ansicht ausgecheckt und im Local Repository abgelegt. Außerdem wird es schreibgeschützt im dazugehörigen Editor angezeigt.


Verwendungsnachweis für Informationsobjekte anzeigen

Verwendung

Sie können prüfen, wo das Informationsobjekt verwendet wird.

Voraussetzungen

Sie haben die Knowledge Workbench im Online-Modus aufgerufen.

Vorgehensweise

Um den Verwendungsnachweise für ein Informationsobjekt aufzurufen, gehen Sie wie folgt vor:

  1. Positionieren Sie im Knowledge Warehouse den Cursor auf dem Informationsobjekt, zu dem Sie den Verwendungsnachweis anzeigen möchten.
  2. Wählen Sie Info-Objekt ® Verwendungsnachweis.

Ergebnis

Es wird angezeigt, in welchen Informationsobjekten das ausgewählte Informationsobjekt verwendet wird.


Freie Inhaltsobjekte anzeigen

Verwendung

Sie können sich die Inhaltsobjekte anzeigen lassen, die in keiner Struktur verwendet werden.

Voraussetzungen

Sie haben die Knowledge Workbench im Online-Modus aufgerufen.

Vorgehensweise

Um die freien Inhaltsobjekte anzuzeigen, gehen Sie wie folgt vor:

  1. Öffnen Sie im Knowledge Warehouse die Mappe, in der Sie nach freien Inhaltsobjekten suchen möchten.
  2. Wählen Sie Werkzeuge ® Suche in der Liste nach Info-Objekten ohne Struktur-Verwendung.

Ergebnis

Es wird eine Liste erstellt, in der die freien Inhaltsobjekte angezeigt werden.


Kontextliste für Informationsobjekte

Verwendung

Sie können sich anzeigen lassen, in welchen Kontexten es Versionen zu einem Informationsobjekt gibt.

Voraussetzungen

Sie haben die Knowledge Workbench im Online-Modus aufgerufen.

Funktionsumfang

Folgende Funktionen werden in der Kontextliste zur Verfügung gestellt:

  • Anzeigen der Kontexte, in denen Versionen existieren
  • Anzeigen der Version im Web Browser
  • Anzeigen der Attribute der Informationsobjekt-Version

Aktivitäten

Sie rufen die Kontextliste auf.

Sie wählen über die rechte Maustaste die gewünschte Funktion.


Kontextliste für ein Informationsobjekt anzeigen

Verwendung

Sie können sich anzeigen lassen, in welchen Kontexten es Versionen zu einem Informationsobjekt gibt.

Voraussetzung

Sie haben die Knowledge Workbench im Online-Modus aufgerufen.

Vorgehensweise

Um die Kontexte für ein Informationsobjekt anzuzeigen, gehen Sie wie folgt vor:

  1. Positionieren Sie im Knowledge Warehouse den Cursor auf dem Informationsobjekt, zu dem Sie die Kontexte anzeigen möchten.
  2. Wählen Sie Info-Objekt ® Kontextliste anzeigen.

Ergebnis

Es wird angezeigt, in welchen Kontexten es Versionen für das ausgewählte Informationsobjekt gibt.


Version eines Informationsobjekts anzeigen

Verwendung

Sie können sich eine Version im Web Browser anzeigen lassen.

Voraussetzung

Sie haben die Knowledge Workbench im Online-Modus aufgerufen.

Sie befinden sich in der Kontextliste eines Informationsobjekts.

Vorgehensweise

Um die Version eines Informationsobjekts im Web Browser anzuzeigen, gehen Sie wie folgt vor:

  1. Positionieren Sie den Cursor auf der Version, die Sie im Web Browser anzeigen möchten.
  2. Wählen Sie über die rechte Maustaste Anzeigen.

Ergebnis

Der Web Browser wird aufgerufen. Die ausgewählte Version wird angezeigt.


Attribute der Version des Informationsobjekts anzeigen

Verwendung

Sie können sich zu einer Version die Attribute anzeigen lassen.

Voraussetzung

Sie haben die Knowledge Workbench im Online-Modus aufgerufen.

Sie befinden sich in der Kontextliste eines Informationsobjekts.

Vorgehensweise

Um die Attribute für eine Version anzuzeigen, gehen Sie wie folgt vor:

  1. Positionieren Sie den Cursor auf der Version, zu der Sie die Attribute anzeigen möchten.
  2. Wählen Sie über die rechte Maustaste Attribute.

Ergebnis

Sie gelangen in die Anzeige der Attribute.


Inhaltsvorlagen auffrischen

Verwendung

Wenn die Inhaltsvorlagen geändert wurden, dann können Sie die auf dem PC gespeicherten Inhaltsvorlagen aktualisieren.

Voraussetzung

Sie haben die Knowledge Workbench im Online-Modus aufgerufen.

Vorgehensweise

Um die Inhaltsvorlagen aufzufrischen, wählen Sie Werkzeuge ® Local Repository ® Inhaltsvorlagen des Local Repository auffrischen.

Ergebnis

Die Inhaltsvorlagen werden aufgefrischt.


Informationsobjekte aus dem Local Repository entfernen

Verwendung

Sie können Informationsobjekte aus dem Local Repository entfernen, die Sie

  • aus dem Knowledge Warehouse ausgecheckt haben, aber nicht aktualisieren möchten
  • neu im Local Repository angelegt haben, aber nicht einchecken möchten

Voraussetzung

Sie arbeiten mit der Knowledge Workbench im Online-Modus.

Vorgehensweise

Um Informationsobjekte aus dem Local Repository zu entfernen, gehen Sie wie folgt vor:

  1. Wählen Sie die Informationsobjekte aus, die Sie entfernen möchten.

    2. Wenn Sie diese Informationsobjekte im Local Repository neu angelegt haben, dann werden sie gelöscht und können nicht mehr eingecheckt werden.

  2. Wählen Sie Info-Objekt ® Info-Objekte aus dem Local Repository entfernen oder drücken Sie die Taste Entf .
  3. Bestätigen Sie die Sicherheitsabfrage.

Ergebnis

Die ausgewählten Informationsobjekte werden aus dem Local Repository entfernt.

  • Wenn Sie diese Informationsobjekte aus dem Knowledge Warehouse ausgecheckt hatten, dann werden diese im Knowledge Warehouse entsperrt und können wieder von anderen Autoren zur Bearbeitung ausgecheckt werden.
  • Wenn Sie diese Informationsobjekte im Local Repository neu angelegt haben, dann werden sie gelöscht und können nicht mehr eingecheckt werden.


Informationsobjekte im Knowledge Warehouse löschen

Verwendung

Sie können Informationsobjekte aus dem Knowledge Warehouse löschen.

Diese Informationsobjekte stehen in zukünftigen Kontexten nicht mehr zur Verfügung.

Voraussetzungen

Sie arbeiten mit der Knowledge Workbench im Online-Modus.

Vorgehensweise

Um Informationsobjekte im Knowledge Warehouse zu löschen, gehen Sie wie folgt vor:

  1. Überprüfen Sie den Kontext.
  2. Wählen Sie die Informationsobjekte aus, die Sie löschen möchten.
  3. Wählen Sie Info-Objekt ® Objekte aus Knowledge Warehouse entfernen oder drücken Sie die Taste Entf .
  4. Bestätigen Sie die Sicherheitsabfrage.

Ergebnis

Die ausgewählten Informationsobjekte werden im Knowledge Warehouse gelöscht und stehen in zukünftigen Kontexten nicht mehr zur Verfügung.


Informationsobjekte im Knowledge Warehouse entsperren

Verwendung

Sie können im Knowledge Warehouse das Auscheck-Kennzeichen für ausgecheckte Informationsobjekte zurücksetzen, die nicht mehr eingecheckt werden.

Die Informationsobjekte werden entsperrt und können von anderen Benutzern bearbeitet werden.

Dies kann erforderlich sein, wenn Sie ausgecheckte Informationsobjekte aus dem Local Repository entfernt haben und die Knowledge Workbench im Offline-Modus war.

Voraussetzungen

Sie arbeiten mit der Knowledge Workbench im Online-Modus.

Vorgehensweise

  1. Wählen Sie die Informationsobjekte aus, die Sie im Knowledge Warehouse entsperren möchten.
  2. Wählen Sie Info-Objekt ® Auschecken zurücksetzen.

Wenn Sie diese Aktion ausgeführt haben, können Sie die Informationsobjekte nicht mehr vom Local Repository aus einchecken. Alle Änderungen, die Sie an diesen Objekten vorgenommen haben, gehen somit verloren.

Ergebnis

Die Informationsobjekte werden im Knowledge Warehouse entsperrt und für die Bearbeitung durch andere Benutzer freigegeben.


Glossary

Glossar

Begriff suchen

Um einen Glossareintrag zu suchen, geben Sie den Begriff in das Textfeld der Registerkarte Index ein.

Um im gesamten Text zu suchen, geben Sie den Begriff in das Textfeld der Registerkarte Search ein, und drücken Sie die Eingabetaste oder die Schaltfläche List Topics.

Begriff anzeigen

Um einen in der Listbox markierten Begriff anzuzeigen, wählen Sie ihn per Doppelklick aus oder drücken Sie die Schaltfläche Display.


Hilfe zum HTML Help Viewer

Verwendung

Mit dem HTML Help Viewer können Sie die SAP-Bibliothek im Dateiformat Compiled HTML (*.CHM) anzeigen.

Funktionsumfang

Der HTML Help Viewer beinhaltet:

  • ein Topic-Fenster zur Anzeige des aktuellen Hilfedokuments
  • ein Navigationsfenster für die Anzeige des aktuellen Inhaltsverzeichnisses, die Schlagwortsuche und die Volltextsuche. (Das Navigationsfenster kann aus- und eingeblendet werden: Ausblenden/Einblenden)
  • eine Symbolleiste mit Funktionen zum Navigieren, Drucken, etc.

Wenn Sie bei der Navigation in der Online-Hilfe zu Dokumenten in anderen Hilfedateien verzweigen, dann werden weitere Instanzen des HTML Help Viewer geöffnet. Diese können einzeln geschlossen werden. Durch Schließen der Ausgangsinstanz werden alle Instanzen des Viewer geschlossen.

Um zur Startseite der SAP-Bibliothek zu gelangen, wählen Sie Startseite. Von dort aus können Sie auf die gesamte Dokumentation zugreifen: SAP-Bibliothek, Glossar, Einführungsleitfaden (IMG) und Release-Informationen.

Suchen nach Hilfedokumenten

Sie können nach Hilfedokumenten suchen, indem Sie:

  1. in der Baumstruktur des Inhaltsverzeichnisses navigieren (Registerkarte Inhalt)
    • Um alle Zweige des Inhaltsverzeichnisses zu öffnen bzw. zu schließen, klicken Sie im Navigationsfenster die rechte Maustaste und wählen Sie im Kontextmenü Alle öffnen bzw. Alle schließen.
    • Um in einem durchlaufenen Navigationspfad zurück und wieder vor zu gehen, wählen Sie Zurück bzw. Vorwärts in der Symbolleiste. Dies gilt jeweils für den Navigationspfad innerhalb einer Instanz des HTML Help Viewer.
    • Um im Inhaltsverzeichnis nur Einträge bestimmter Info-Klassen anzuzeigen, klicken Sie im Navigationsfenster die rechte Maustaste und wählen Sie im Kontextmenü Anpassen... Legen Sie im folgenden Dialog fest, welche Info-Klassen im Inhaltsverzeichnis erscheinen sollen.
  2. eine Schlagwortsuche durchführen (Registerkarte Index)

Abhängig davon, ob Sie sich in der SAP-Bibliothek oder in einer anderen, darin referenzierten Hilfedatei befinden, wird der Gesamtindex oder der Index der aktuellen Hilfedatei angezeigt. Wenn zur aktuellen Hilfedatei kein Index existiert, dann erscheint die Registerkarte Index nicht.

Das Laden des Gesamtindex (ca. 8 MB) kann, je nach Ausstattung Ihres PC, bis zu einigen Minuten in Anspruch nehmen.

Selektieren Sie einen Eintrag in der Liste der Schlagwörter und wählen Sie Anzeigen.
Ist das selektierte Schlagwort nur einem Hilfedokument zugeordnet, dann wird dieses unmittelbar angezeigt. Andernfalls erscheint eine Liste der gefundenen Dokumente zur Auswahl.

Da Release-Informationen und der Einführungsleitfaden (IMG) nicht beschlagwortet sind, ist dort nur die Volltextsuche möglich.
  3. eine Volltextsuche durchführen (Registerkarte Suchen)

Geben Sie eine Suchanfrage ein und wählen Sie Themenliste.
Abhängig davon, ob Sie sich in der SAP-Bibliothek oder in einer anderen, darin referenzierten Hilfedatei befinden, wird in allen Dokumenten oder lediglich in den Dokumenten der aktuellen Hilfedatei gesucht. Eine Liste der gefundenen Dokumente wird zur Auswahl angezeigt.

Sie können komplexe Suchanfragen bilden durch:
    • Verwendung der Platzhalter ? für einzelne Zeichen und * für beliebige Zeichenfolgen in Suchbegriffen.
    • Einbeziehung ähnlicher Suchbegriffe (Ähnliche Wörter suchen)
    • Verknüpfung von Suchbegriffen mit den Operatoren:
      • AND (alle Begriffe kommen im Dokument vor)
      • OR (mindestens einer der Begriffe kommt im Dokument vor)
      • NOT (der Begriff kommt im Dokument nicht vor)
      • NEAR (die Begriffe kommen in räumlicher Nähe, z.B. im selben Satz, im Dokument vor)
    • Einschränkung der Suche auf den Titel der Dokumente (Nur Titel suchen)
    • Einschränkung der Suche auf die mit der vorherigen Suchanfrage gefundene Dokumentenmenge (Vorherige Ergebnisse suchen)

Die globale Suche in der SAP-Bibliothek erfordert viel Hauptspeicher und virtuellen Speicher, insbesondere bei der Volltextsuche. Die globale Volltextsuche sollte deshalb nur benutzt werden, wenn die Hilfedateien auf der lokalen Festplatte liegen.

Lokalisieren des aktuellen Hilfedokuments im Inhaltsverzeichnis

Sind Sie zum aktuellen Topic durch eine Suche oder durch einen Hyperlink gelangt, dann wird die Position des Topics im Inhaltsverzeichnis nicht angezeigt. Um das Topic im Inhaltsverzeichnis zu lokalisieren, wählen Sie Suchen in der Symbolleiste des HTML Help Viewer.

Wurde das aktuelle Topic durch eine globale (Volltext- oder Schlagwort-) Suche in der SAP-Bibliothek gefunden, dann muß zunächst die Hilfedatei bestimmt werden, in der es enthalten ist. Klicken Sie hierzu auf die Suchen-Ikone [image] im Titel des Topics. Wählen Sie anschließend Suchen in der Symbolleiste, um das Inhaltsverzeichnis der Hilfedatei zu expandieren und die Position des Topics zu lokalisieren.

Drucken von Hilfedokumenten

Sie können einzelne Hilfedokumente oder mehrere Dokumente zugleich ausdrucken:

  • Um das aktuelle Topic zu drucken, wählen Sie Drucken mit der Option Ausgewähltes Thema drucken.
  • Um das aktuelle Topic und alle darunterliegenden Topics zu drucken, wählen Sie Drucken mit der Option Ausgewähltes Thema und alle Unterthemen drucken.


SAP-Bibliothek
Release 4.6D, März 2000
SAP-Bibliothek

Glossar

Anwendungsübergreifende Komponenten

Basis
© Copyright 2002 SAP AG
Alle Rechte vorbehalten.


Broken link

Fehler: Kaputter Link

Sie haben versucht, einem Link zu folgen, der auf ein unbekanntes Dokument zeigt.