Übersetzen von Inhaltsobjekten mit dem KW-Translator

Einsatzmöglichkeiten

Mit dem Knowledge Warehouse Translator wird Ihnen ein Werkzeug zur Verfügung gestellt, mit dem Sie folgende Informationsobjekte übersetzen können:

  • komplette Websites des Bereichs Intranet-Management
  • Informationsobjekte in beliebigen Formaten

Der Knowledge Warehouse Translator ist eine 32-bit-Frontend-Applikation für Microsoft Windows, die ein komfortableres Arbeiten mit Übersetzungspaketen gestattet (Explorer, Statusverwaltung)

Formate, die nicht bearbeitet werden können, werden der Übersetzung zugänglich gemacht, indem eine vorliegende Datei als Übersetzung aufgenommen werden kann ("Multimedia-Übersetzung")

Mit dem Knowledge Warehouse Translator können Sie die genannten Informationsobjekte übersetzen, ohne eine Online-Verbindung zu einem Knowledge Warehouse-System zu haben.

Einführungshinweise

Der Knowledge Warehouse Translator wird über die Komponente Knowledge Warehouse der SAP Gui-CD installiert.

Integration

Im Knowledge Warehouse werden Übersetzungspakete erstellt, deren Inhalt dann mit dem Knowledge Warehouse Translator übersetzt werden kann.

Funktionsumfang

  • Unterstützung der Übersetzung aller Formate, die im Knowledge Warehouse registriert sind, z.B.
    • HTML
    • XML
    • Word, PowerPoint, Visio
    • Bilder, Satzformate, ... (z.B. Filme übersetzen, indem eine synchronisierte Fassung eingecheckt wird)
  • Aufnahme bereits übersetzter Dateien in das Übersetzungspaket
  • halbautomatische Status-Verwaltung
  • Support-Unterstützung durch
    • eine Ablaufkontrolle (WDFTRACE.EXE)
    • Meldungsdatei "Protocol.txt" (im Paketverzeichnis)


Übersetzen eines Übersetzungspaketes

Einsatzmöglichkeiten

Sie können ein Übersetzungspaket übersetzen, welches Sie im Bereich Intranet-Management erstellt haben.

Das Übersetzungspaket enthält alle Komponenten der ausgewählten Mappe oder Inhaltsobjekte.

Voraussetzungen

Das zu übersetzende Übersetzungspaket wurde mit der Option KW-Translator erstellt und auf dem PC abgelegt.

Ablauf

  1. Sie starten den KW-Translator.
  2. Sie öffnen das Übersetzungspaket.

    3. Der Inhalt des Übersetzungspakets wird angezeigt geordnet nach den Komponenten der zu übersetzenden Inhaltsobjekte.

  3. Sie übersetzen den Inhalt des Übersetzungspakets.

    4. Sie können nur ein Inhaltsobjekt mit einem Editor übersetzen, daß als Primärkomponente gekennzeichnet ist und dessen technischer Name angezeigt wird.

    Primärkomponenten sind Objekte, die als eigenständige Inhaltsobjekte ins Knowledge Warehouse eingecheckt wurden.

    Wenn Sie eine andere Komponente des Inhaltsobjekts mit einem Editor übersetzen möchten, dann müssen Sie diese Komponente als Primärkomponente kennzeichnen.

  4. Sie ordnen den Status übersetzt zu.

    5. Es können nur Übersetzungspakete eingecheckt werden, deren Inhaltsobjekte den Status übersetzt haben.

  5. Sie schließen den KW-Translator.

Ergebnis

Das Übersetzungspaket ist übersetzt und kann wieder ins Knowledge Warehouse eingelesen werden.


KW-Translator starten

Voraussetzungen

Der KW-Translator wurde über den SAP-Gui installiert.

Vorgehensweise

Um den KW-Translator zu starten, wählen Sie Start ® Programs ® SAP Frontend ® Knowledge Warehouse Translator.

Ergebnis

Der KW-Translator wird gestartet.


Oberflächensprache einstellen

Voraussetzungen

Sie befinden sich im KW-Translator.

Vorgehensweise

Um die Oberflächensprache des KW-Translator einzustellen, gehen Sie wie folgt vor:

  1. Wählen Sie Extras ® Optionen.

    2. Sie gelangen auf das Dialogfenster, in dem Sie allgemeine Einstellungen vornehmen können.

  2. Wählen Sie im Feld Sprache die Oberflächensprache für den KW-Tranlator aus und anschließend Ok.

Ergebnis

Die Oberfläche des KW-Translator wird an die ausgewählte Sprache angepaßt.


Übersetzungspaket öffnen

Voraussetzungen

Das zu übersetzende Übersetzungspaket wurde mit der Option KW-Translator erstellt und auf dem PC abgelegt.

Sie befinden sich im KW-Translator.

Vorgehensweise

Um ein Übersetzungspaket zu öffnen, gehen Sie wie folgt vor:

  1. Wählen Sie Datei ® Übersetzungspaket öffnen.

    2. Sie gelangen auf das Dialogfenster Übersetzungspaket öffnen.

  2. Wechseln Sie in das Verzeichnis, in dem Sie das Übersetzungspaket abgelegt haben.
  3. Wählen Sie die Datei trans.kxf aus und anschließend Open.

Ergebnis

Das ausgewählte Übersetzungspaket wird im KW-Translator geöffnet.

Es werden die technischen Namen der zu übersetzenden Inhaltsobjekte angezeigt.

Wenn Sie die einzelnen Inhaltsobjekte expandieren, dann sehen Sie die einzelnen Komponenten, die zum Inhaltsobjekt gehören.

Übersetzt wird jeweils die Primärkomponente, die mit folgendem Symbol gekennzeichnet wird:


Inhaltsobjekt mit Editor übersetzen

Verwendung

Im KW-Translator übersetzen Sie Inhaltsobjekte der Info-Objekt-Klassen Folie, Text und Topic mit MS PowerPoint oder MS Word. Diese beiden Editoren werden automatisch aufgerufen, wenn Sie Inhaltsobjekte übersetzen möchten.

Inhaltsobjekte der Info-Objekt-Klasse HTML können in einem speziellen HTML-Editor übersetzt werden, der Ihnen vom Knowledge Warehouse zur Verfügung gestellt wird.

Voraussetzungen

Das zu übersetzende Übersetzungspaket wurde mit der Option KW-Translator erstellt und auf dem PC abgelegt.

Im Übersetzungspaket sind Inhaltsobjekte der Info-Objekt-Klassen Folie, Text, Topic oder HTML enthalten.

Sie befinden sich im KW-Translator.

Das zu übersetzende Inhaltsobjekt ist als Primärkomponente gekennzeichnet.

Vorgehensweise

Um ein Inhaltsobjekt mit dem dazugehörigen Editor zu übersetzen, gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf das Inhaltsobjekt.

    2. Es wird der dazugehörige Editor geöffnet. Im KW-Translator wird das Inhaltsobjekt als geöffnet gekennzeichnet.

    Es werden zwei Fenster angezeigt. In dem einen Fenster ist die Originalsprachendatei und im zweiten Fenster die Zielsprachendatei.

    Wenn Sie nur ein Fenster sehen (z.B. bei der Übersetzung von HTML-Objekten), dann verschieben Sie dieses Fenster. Das zweite Fenster liegt darunter.

  2. Übersetzen Sie das Inhaltsobjekt und sichern Sie die Übersetzung.
  3. Schließen Sie den Editor.

Es werden beide Fenster geschlossen.

Ergebnis

Das Inhaltsobjekt wurde übersetzt. Es wird im KW-Tranlator mit dem Status In Übersetzung gekennzeichnet.

Wenn Sie das Inhaltsobjekt fertig übersetzt haben, können Sie den Status auf übersetzt setzen.


Übersetzte Datei zuweisen

Verwendung

Sie können den Komponenten eines Inhaltsobjekts eine beliebige Datei als Übersetzung zuweisen und somit eine Übersetzung ohne Editor erstellen.

Voraussetzungen

Das zu übersetzende Übersetzungspaket wurde mit der Option KW-Translator erstellt und auf dem PC abgelegt.

Sie befinden sich im KW-Translator.

Vorgehensweise

Um einer Komponente eine übersetzte Datei zuzuweisen, gehen Sie wie folgt vor:

  1. Wählen Sie eine Komponente aus.
  2. Wählen Sie Bearbeiten ® Übersetzte Datei zuweisen.

    3. Sie gelangen auf ein Dialogfenster.

  3. Wechseln Sie in das Verzeichnis, in dem die Datei liegt, die Sie als Übersetzung zuweisen möchten.
  4. Wählen Sie die Datei aus und anschließend ok.

Wenn Sie eine Primärkomponente ausgewählt hatten, der Sie eine Übersetzung zuweisen wollten, dann können Sie weitere Komponenten als Übersetzung zuweisen.

Ergebnis

Der ausgewählten Komponente wurde die ausgewählte Datei als Übersetzung zugewiesen.

Das Inhaltsobjekt wird im KW-Tranlator mit dem Status In Übersetzung gekennzeichnet.

Wenn Sie das Inhaltsobjekt fertig übersetzt haben, können Sie den Status auf übersetzt setzen.


Titel übersetzen

Verwendung

Mit dieser Vorgehensweise können Sie den Titel eines Inhaltsobjekts übersetzen.

Voraussetzungen

Das zu übersetzende Übersetzungspaket wurde mit der Option KW-Translator erstellt und auf dem PC abgelegt.

Sie befinden sich im KW-Translator.

Vorgehensweise

Um den Titel zu übersetzen, gehen Sie wie folgt vor:

  1. Wählen Sie ein Inhaltsobjekt aus.
  2. Wählen Sie Bearbeiten ® Titel übersetzen.

    3. Sie gelangen auf das Dialogfenster Titel übersetzen.

  3. Geben Sie im unteren Fenster den übersetzten Titel ein und wählen Sie anschließend ok.

Ergebnis

Der Titel des ausgewählten Inhaltsobjekts wurde übersetzt.


Lokaler Übersetzungsstatus

Definition

Der lokale Übersetzungsstatus kennzeichnet den Übersetzungszustand eines Inhaltsobjekts, das sich im Übersetzungspaket befindet.

Er wird teilweise automatisch gesetzt, kann aber auch von Ihnen zugewiesen werden.

Verwendung

Sie können mit dem lokalen Übersetzungsstatus den Übersetzungszustand eines Inhaltsobjekts kennzeichnen.

Struktur

Es gibt folgende lokale Übersetzungsstatus:

  • Zu übersetzen

Das Inhaltsobjekt muß übersetzt werden.

Der Status wird automatisch gesetzt.
  • In Übersetzung

Das Inhaltsobjekt wurde im Editor geöffnet und gesichert oder dem Inhaltsobjekt wurde eine übersetzte Datei zugewiesen.

Der Status wird automatisch gesetzt.
  • Übersetzt

Das Inhaltsobjekt wurde vollständig übersetzt.

Der Status wird von Ihnen gesetzt.


Lokalen Übersetzungsstatus setzen

Verwendung

Sie können mit dem lokalen Übersetzungsstatus den Übersetzungszustand eines Inhaltsobjekts kennzeichnen.

Voraussetzungen

Das zu übersetzende Übersetzungspaket wurde mit der Option KW-Translator erstellt und auf dem PC abgelegt.

Sie befinden sich im KW-Translator.

Vorgehensweise

Um einem Inhaltsobjekt einen lokalen Übersetzungsstatus zuzuweisen, gehen Sie wie folgt vor:

  1. Wählen Sie das Inhaltsobjekt aus.
  2. Wählen Sie Bearbeiten ® Dokument markieren als ® Zu übersetzen oder In Übersetzung oder Übersetzt.

Ergebnis

Dem ausgewählten Inhaltsobjekt wird der jeweilige lokale Übersetzungsstatus zugeordnet.


Ändern der Komponenten

Verwendung

Mit dieser Funktion können Sie die Komponenten eines Inhaltsobjekts ändern.

Integration

Ein Inhaltsobjekt kann aus mehreren Komponenten bestehen, wobei das Inhaltsobjekt die Primärkomponente ist.

Eine Website besteht aus mehreren HTML-Dateien und Gif-Dateien.

Die Website wurde als eigenständiges Inhaltsobjekt ins Knowledge Warehouse eingecheckt. Dieses Inhaltsobjekt ist die Primärkomponente.

Die dazugehörigen HTML-Dateien und Gif-Dateien wurden zu Komponenten des Inhaltsobjekts (Website).

Nur die Primärkomponente kann mit einem Editor übersetzt werden. Wenn Sie also eine Komponente des Inhaltsobjekts mit einem Editor übersetzen möchten, dann müssen Sie diese Komponente erst als Primärkomponente deklarieren

Voraussetzungen

Das zu übersetzende Übersetzungspaket wurde mit der Option KW-Translator erstellt und auf dem PC abgelegt.

Sie befinden sich im KW-Translator.

Funktionsumfang

Folgende Funktionen werden Ihnen für das Ändern von Komponenten zur Verfügung gestellt:

  • Deklarierung einer Komponentendatei als Primärkomponente

Die als Primärkomponente gekennzeichnete Datei kann mit einem Editor übersetzt werden.
  • Hinzufügen neuer Komponenten
  • Ersetzen einer oder aller Komponentendateien durch andere Dateien
  • Löschen von Komponenten

Aktivitäten

Sie markieren ein oder mehrere Komponenten und wählen Bearbeiten ® Komponentendatei und dann eine der angezeigten Optionen.


Komponente als Primärkomponente deklarieren

Verwendung

Wenn Sie eine Komponente mit einem Editor übersetzen möchten, dann muß diese Komponente als Primärkomponente gekennzeichnet werden.

Voraussetzungen

Das zu übersetzende Übersetzungspaket wurde mit der Option KW-Translator erstellt und auf dem PC abgelegt.

Sie befinden sich im KW-Translator.

Vorgehensweise

Um eine Komponente als Primärkomponente zu deklarieren, gehen Sie wie folgt vor:

  1. Wählen Sie die Komponente aus, die Sie mit einem Editor übersetzen möchten.
  2. Wählen Sie Bearbeiten ® Komponentendateien ® Komponentendatei als primär deklarieren.

Ergebnis

Die ausgewählte Komponente wird als Primärkomponente mit einer Ikone gekennzeichnet. Sie kann jetzt mit einem Editor übersetzt werden.


Neue Komponentendatei hinzufügen

Voraussetzungen

Das zu übersetzende Übersetzungspaket wurde mit der Option KW-Translator erstellt und auf dem PC abgelegt.

Sie befinden sich im KW-Translator.

Vorgehensweise

Um eine neue Komponente hinzuzufügen, gehen Sie wie folgt vor:

  1. Wählen Sie ein Inhaltsobjekt aus, zu dem Sie eine neue Komponente hinzufügen möchten.
  2. Wählen Sie Bearbeiten ® Komponentendateien ® Komponentendatei hinzufügen.

    3. Sie gelangen auf ein Dialogfenster.

  3. Wechseln Sie in das Verzeichnis, in dem die Datei liegt, die Sie als neue Komponente hinzufügen möchten.
  4. Wählen Sie die Datei aus und anschließend ok.

Ergebnis

Die neue Komponente wurde dem Inhaltsobjekt hinzugefügt.


Komponentendatei ersetzen

Voraussetzungen

Das zu übersetzende Übersetzungspaket wurde mit der Option KW-Translator erstellt und auf dem PC abgelegt.

Sie befinden sich im KW-Translator.

Vorgehensweise

Um eine Komponente zu ersetzen, gehen Sie wie folgt vor:

  1. Wählen Sie eine Komponente aus, die Sie ersetzen möchten.
  2. Wählen Sie Bearbeiten ® Komponentendateien ® Komponentendatei ersetzen.

    3. Sie gelangen auf ein Dialogfenster.

  3. Wechseln Sie in das Verzeichnis, in dem die Datei liegt, mit der Sie die ausgewählte Komponente ersetzen möchten.
  4. Wählen Sie die Datei aus und anschließend ok.

Ergebnis

Die ausgewählte Komponente wurde ersetzt.


Komponentendatei löschen

Voraussetzungen

Das zu übersetzende Übersetzungspaket wurde mit der Option KW-Translator erstellt und auf dem PC abgelegt.

Sie befinden sich im KW-Translator.

Vorgehensweise

Um eine Komponente zu löschen, gehen Sie wie folgt vor:

  1. Wählen Sie eine Komponente aus, die Sie löschen möchten.
  2. Wählen Sie Bearbeiten ® Komponentendateien ® Komponentendatei löschen.

Ergebnis

Die ausgewählte Komponente wurde gelöscht.


Glossary

Glossar

Begriff suchen

Um einen Glossareintrag zu suchen, geben Sie den Begriff in das Textfeld der Registerkarte Index ein.

Um im gesamten Text zu suchen, geben Sie den Begriff in das Textfeld der Registerkarte Search ein, und drücken Sie die Eingabetaste oder die Schaltfläche List Topics.

Begriff anzeigen

Um einen in der Listbox markierten Begriff anzuzeigen, wählen Sie ihn per Doppelklick aus oder drücken Sie die Schaltfläche Display.


Hilfe zum HTML Help Viewer

Verwendung

Mit dem HTML Help Viewer können Sie die SAP-Bibliothek im Dateiformat Compiled HTML (*.CHM) anzeigen.

Funktionsumfang

Der HTML Help Viewer beinhaltet:

  • ein Topic-Fenster zur Anzeige des aktuellen Hilfedokuments
  • ein Navigationsfenster für die Anzeige des aktuellen Inhaltsverzeichnisses, die Schlagwortsuche und die Volltextsuche. (Das Navigationsfenster kann aus- und eingeblendet werden: Ausblenden/Einblenden)
  • eine Symbolleiste mit Funktionen zum Navigieren, Drucken, etc.

Wenn Sie bei der Navigation in der Online-Hilfe zu Dokumenten in anderen Hilfedateien verzweigen, dann werden weitere Instanzen des HTML Help Viewer geöffnet. Diese können einzeln geschlossen werden. Durch Schließen der Ausgangsinstanz werden alle Instanzen des Viewer geschlossen.

Um zur Startseite der SAP-Bibliothek zu gelangen, wählen Sie Startseite. Von dort aus können Sie auf die gesamte Dokumentation zugreifen: SAP-Bibliothek, Glossar, Einführungsleitfaden (IMG) und Release-Informationen.

Suchen nach Hilfedokumenten

Sie können nach Hilfedokumenten suchen, indem Sie:

  1. in der Baumstruktur des Inhaltsverzeichnisses navigieren (Registerkarte Inhalt)
    • Um alle Zweige des Inhaltsverzeichnisses zu öffnen bzw. zu schließen, klicken Sie im Navigationsfenster die rechte Maustaste und wählen Sie im Kontextmenü Alle öffnen bzw. Alle schließen.
    • Um in einem durchlaufenen Navigationspfad zurück und wieder vor zu gehen, wählen Sie Zurück bzw. Vorwärts in der Symbolleiste. Dies gilt jeweils für den Navigationspfad innerhalb einer Instanz des HTML Help Viewer.
    • Um im Inhaltsverzeichnis nur Einträge bestimmter Info-Klassen anzuzeigen, klicken Sie im Navigationsfenster die rechte Maustaste und wählen Sie im Kontextmenü Anpassen... Legen Sie im folgenden Dialog fest, welche Info-Klassen im Inhaltsverzeichnis erscheinen sollen.
  2. eine Schlagwortsuche durchführen (Registerkarte Index)

Abhängig davon, ob Sie sich in der SAP-Bibliothek oder in einer anderen, darin referenzierten Hilfedatei befinden, wird der Gesamtindex oder der Index der aktuellen Hilfedatei angezeigt. Wenn zur aktuellen Hilfedatei kein Index existiert, dann erscheint die Registerkarte Index nicht.

Das Laden des Gesamtindex (ca. 8 MB) kann, je nach Ausstattung Ihres PC, bis zu einigen Minuten in Anspruch nehmen.

Selektieren Sie einen Eintrag in der Liste der Schlagwörter und wählen Sie Anzeigen.
Ist das selektierte Schlagwort nur einem Hilfedokument zugeordnet, dann wird dieses unmittelbar angezeigt. Andernfalls erscheint eine Liste der gefundenen Dokumente zur Auswahl.

Da Release-Informationen und der Einführungsleitfaden (IMG) nicht beschlagwortet sind, ist dort nur die Volltextsuche möglich.
  3. eine Volltextsuche durchführen (Registerkarte Suchen)

Geben Sie eine Suchanfrage ein und wählen Sie Themenliste.
Abhängig davon, ob Sie sich in der SAP-Bibliothek oder in einer anderen, darin referenzierten Hilfedatei befinden, wird in allen Dokumenten oder lediglich in den Dokumenten der aktuellen Hilfedatei gesucht. Eine Liste der gefundenen Dokumente wird zur Auswahl angezeigt.

Sie können komplexe Suchanfragen bilden durch:
    • Verwendung der Platzhalter ? für einzelne Zeichen und * für beliebige Zeichenfolgen in Suchbegriffen.
    • Einbeziehung ähnlicher Suchbegriffe (Ähnliche Wörter suchen)
    • Verknüpfung von Suchbegriffen mit den Operatoren:
      • AND (alle Begriffe kommen im Dokument vor)
      • OR (mindestens einer der Begriffe kommt im Dokument vor)
      • NOT (der Begriff kommt im Dokument nicht vor)
      • NEAR (die Begriffe kommen in räumlicher Nähe, z.B. im selben Satz, im Dokument vor)
    • Einschränkung der Suche auf den Titel der Dokumente (Nur Titel suchen)
    • Einschränkung der Suche auf die mit der vorherigen Suchanfrage gefundene Dokumentenmenge (Vorherige Ergebnisse suchen)

Die globale Suche in der SAP-Bibliothek erfordert viel Hauptspeicher und virtuellen Speicher, insbesondere bei der Volltextsuche. Die globale Volltextsuche sollte deshalb nur benutzt werden, wenn die Hilfedateien auf der lokalen Festplatte liegen.

Lokalisieren des aktuellen Hilfedokuments im Inhaltsverzeichnis

Sind Sie zum aktuellen Topic durch eine Suche oder durch einen Hyperlink gelangt, dann wird die Position des Topics im Inhaltsverzeichnis nicht angezeigt. Um das Topic im Inhaltsverzeichnis zu lokalisieren, wählen Sie Suchen in der Symbolleiste des HTML Help Viewer.

Wurde das aktuelle Topic durch eine globale (Volltext- oder Schlagwort-) Suche in der SAP-Bibliothek gefunden, dann muß zunächst die Hilfedatei bestimmt werden, in der es enthalten ist. Klicken Sie hierzu auf die Suchen-Ikone [image] im Titel des Topics. Wählen Sie anschließend Suchen in der Symbolleiste, um das Inhaltsverzeichnis der Hilfedatei zu expandieren und die Position des Topics zu lokalisieren.

Drucken von Hilfedokumenten

Sie können einzelne Hilfedokumente oder mehrere Dokumente zugleich ausdrucken:

  • Um das aktuelle Topic zu drucken, wählen Sie Drucken mit der Option Ausgewähltes Thema drucken.
  • Um das aktuelle Topic und alle darunterliegenden Topics zu drucken, wählen Sie Drucken mit der Option Ausgewähltes Thema und alle Unterthemen drucken.


SAP-Bibliothek
Release 4.6D, Juni 2000
SAP-Bibliothek

Glossar

Einführung in das SAP-System

Releaseinformationen

Einführungsleitfaden
© Copyright 2000 SAP AG
Alle Rechte vorbehalten.


Broken link

Fehler: Kaputter Link

Sie haben versucht, einem Link zu folgen, der auf ein unbekanntes Dokument zeigt.