An Introduction to NetWeaver SAPSetup – SAP’s Front-End Software Deployment Tool

NetWeaver SAPSetup – SAP’s Front-End Software Deployment Tool

NetWeaver SAPSetup is SAP’s new Windows Front-End Software Deployment Tool.

This powerful multi-product installer allows the Administrator to collect many SAP front-end components (or front-end products) on an Installation Server, and then perform installations, updates or un-installations on workstations via a network. In addition to this, it also features all the functionality that one would expect from a standard installer – features like installing directly from a CD or a distribution media.

The purpose of this document is to make you familiar with the process of deploying SAP Front-End Software on workstations using NetWeaver SAPSetup.

Also read: Features of the Windows Front-End Software Installer | Installing components using an Installation Server


SAPSetup Workstation Installer - A Feature Overview

* SAPSetup Workstation Installer – A Feature Overview

SAPSetup Workstation Installer is SAP’s multi-product front-end software installation tool that provides the following features:

  • Manage multiple SAP front-end components deployed on the workstations.
  • Install and uninstall multiple products or SAP front-end components in one installation cycle.
  • Full command-line based support towards installing, or uninstalling multiple products.
  • Install packages from an Installation Server with administrator-configured installation parameters.
  • Install single or multiple packages using a single command-line.
  • Local Security Handling when configured on the Installation Server allows a user with non-administrative privileges on his workstation to install SAP Software.
  • Automatic Workstation Update Service to update the workstations and reboot them if necessary, whenever the installation server is patched, or the packages installed are updated. The SAP Automatic Workstation Update is not SAP GUI-specific, it works with all components available on the installation server.
  • For the update of SAP GUI, you can also use the SAPLogon-enabled update instead of the Automatic Workstation Update. However, this method is user-dependent. After a certain number of double-clicks on the SAP Logon icon on the desktop, a check for updates is executed.

The front-end installation tool NWSAPSetup.exe is available on the SETUP directory of an Installation Server.

Also read: Installing SAP Front-End Components | Installing Administrator-Configured Packages | Updating or Patching SAP Front-End Software Installations | Command-Line Parameters


Installation of SAP Front-End Software

This section will present the various methods of deploying software on a Windows Workstation using NetWeaver SAPSetup.

The three ways of installing SAP Front-End Software are:

  • Installing locally from a CD or a distribution media
  • Installing components from an Installation Server
  • Installing administrator-configured packages from an Installation Server


Installing Locally from a CD or a Distribution Media

Installing Locally from CD

Use

This procedure helps install SAP front-end software components on a single computer from a distribution CD.

Prerequisites

The user logged on to the workstation (Windows 2000, Windows XP or Windows Vista) must have local administrative privileges.

Procedure

Installing the SAP Front-End

...

1. In folder Gui\Windows\Win32\SETUP in the substructure for Presentation CD1 on the NetWeaver Presentation DVD, start SAPGUISetup.exe.
The SAPSetup installation wizard appears, showing you a list of components that are part of the product SAP GUI for Windows 7.10.

To view and optionally install all products – that is, SAP front-end components available on the installation medium including SAP GUI and others (the SAP NetWeaver Presentation DVD contains SAP GUI for Windows and SAP BI front-end as well as other components that can be integrated on an individual basis) – use SetUpAll.exe.

2. Choose Next.

A list with (de)selectable products is displayed:

Products that have already been installed are pre-selected.

3. Select the products or SAP front-end components that you want to install or deselect the ones you want to remove.
Changes in the selection list are indicated by a yellow dot. If you select a product for installation, you will see a green plus next to the product to install. If you select a product for de-installation, a red minus appears as shown in the following picture:

4. Choose Next.
The installation wizard might prompt you to enter or change information to customize the installation of the selected products, such as the installation folder.

The default path for installing SAP GUI for Windows 7.10 is C:\Program Files\SAP\FrontEnd, but you can change this if required.

5. If necessary, change this information and choose Next to start the installation.

The installation starts and you see a progress screen.

Processing is recorded in the following file:

% ProgramFiles%\SAP\SAPetup\Logs\NWSAPSetup.log

If there are errors, you see a link to an Error Report. Errors are recorded in the following file, which you can view using your normal web browser:

%ProgramFiles%\SAP\SAPSetup\Errors\SAPSetupErrors_<DateTime>.xml

If you have a problem, create a probem message in BC-FES-INS and attach these files to the message. Supplying these two files to SAP Support will help in resolving problems quickly – should you face any.

When the installation is complete, you see a confirmation screen.


Installing Components using an Installation Server

Installing Components from an Installation Server

This procedure tells you how to install components from an installation server.

Prerequisites

  • You have already set up an installation server.
  • The user logged on to the workstation (Windows 2000, Windows XP or Windows Vista) must have local administrative privileges. Or, if the user does not have local administrative privileges, Local Security Handling should be correctly configured on the Installation Server.

Procedure

  1. Start NWSAPSetup.exe from the SETUP folder of the Installation Server.
    The SAPSetup installation wizard appears.
  2. Choose Next.
    The product list is displayed. Products that have already been installed are pre-selected as shown in the following picture:

Select the products or SAP front-end components that you want to install or deselect the ones you want to remove.

Yellow dots indicate changes in the selection list. The green plus next to a product name indicates that this product will be installed when the user installs the package on his or her workstation.

If you deselect a product in this list that has already been installed, a red minus appears to indicate that this product is marked for uninstallation.

3. After (de)selection, choose Next.
The installation wizard might prompt you to enter or change information needed to customize the installation of the selected products – for example, the installation folder.

The default path for installing SAP GUI for Windows 710 is C:\Program Files\SAP\FrontEnd, but you can change this if required.

4. If necessary, change this information and choose Next to start the installation.
The installation starts and a progress screen appears.

Processing is recorded in the following file:

% ProgramFiles%\SAP\SAPetup\Logs\NWSAPSetup.log

If there are errors, you see a link to an Error Report. Errors are recorded in the following file, which you can view using your normal web browser:

%ProgramFiles%\SAP\SAPSetup\Errors\SAPSetupErrors_<DateTime>.xml

If you have a problem, create a problem message in BC-FES-INS and attach these files to the message.

When the installation is complete, you see a confirmation screen.

Also read: Updating SAP Front-End Components | Uninstalling SAP Front-End Components | Command-Line Parameters


Installing Administrator-Configured Packages

Installing Admin-Configured Packages

This procedure lets you install or remove packages on your front-end that have been configured by the administrator on the installation server.

Be careful when removing packages. Make sure you do not mistakenly remove shared components that are used by other packages you want to keep.

Prerequisites

  • You have already set up an Installation Server.
  • The administrator has created packages using NWSAPSetupAdmin for deployment on the front-end.
  • The user logged on to the workstation (Windows 2000, Windows XP or Windows Vista) must have local administrative privileges. Or, if the user does not have local administrative privileges, Local Security Handling should be correctly configured at the Installation Server.

Procedure

...

1. Start NWSAPSetup.exe /package from the SETUP folder of the installation source.
A list of the packages that the user is authorized to install or uninstall is displayed. Packages that have already been installed are pre-selected. In the following case, the package BW Package is already installed on the workstation.

2. Select the components or packages that you want to install or deselect the ones you want to remove.

In this case, the Hospital Planning Package has been selected for installation. The yellow dot indicates a change in the selection list. The green plus next to the product name indicates that this object will be installed when the user installs the package on his or her workstation. If you deselected a package, you would see a red minus next to the object selected for de-installation.

3. After (de)selection, choose Next.

4. SAPSetup now processes the packages and displays the completion status when finished.

When installing multiple packages, components that are common are installed once. When a package is uninstalled, other packages that contain the same component are invalidated and made available for re-installation.

Note that components which are not common to the package being uninstalled and the package(s) being invalidated are not uninstalled.

Also read: Command-Line Parameters


Installing Packages Using the Logon Script

Use

Since the front-end software is normally installed on a large number of computers, NWSAPSetup allows you to automate this task.

By inserting a command line into the logon scripts of the computers on which the front-end software is to be installed, you can start a package installation each time the user logs on.

Procedure

Insert the following command line (both the path and either the package name or unique package identifier must be used):

\\<server>\<shared folder>\setup\NWSAPSetup.exe /package:“<package command-line name>“ /silent

The command-line path that can be used to install or uninstall a package silently can also be taken from NWSAPSetupAdmin.exe.

When you start this command for the very first time on a computer, NWSAPSetup installs the specified package.

The front-end software (especially SAP GUI) should not be running at the same time because program files in use could cause a reboot.

Also read: Command-Line Parameters


Updating or Patching SAP Front-End Software Installations

There are a couple of ways of distributing patches released by SAP to the end-user workstations that contain installed SAP components.

These are:

  • Apply the Patch to the Installation Server and execute an Update on the Workstation (recommended)
  • Apply the Patch locally on every Workstation, one by one


Updating the Workstations

Updating the Front-End from an Installation Server

Use

You can update the front end from an installation server.

Procedure

Updating the front end basically involves the same steps as an installation, see section Installation of the SAP Front End from an Installation Server.

You have the possibility to have the update run unattendedly, automatically, or SAP Logon-enabled:

● For unattended update, use the following command line: \\<server_path>\setup\NWSAPSETUP.exe /UPDATE /silent

● For automatic update, you can use the SAP Automatic Workstation Update Service. Whenever the installation server is patched, or the packages installed are updated, this service will update the workstation(s) and reboot them if necessary. The workstation updater works in two modes - one in the presence of a logged-on user and another in his or her absence

○ When a user is logged on, the user is informed of update availability and the update happens on the user's assent. The user is also informed if a reboot is necessary and the reboot is also only executed on the user's assent.

○ If no user is logged on, the update is done automatically and the reboot (if necessary) is done automatically, too.

The SAP Automatic Workstation Update is not SAP GUI-specific, it works with all components available on the installation server. You find details on this in the installation server part of the docu.

● For the update of SAP GUI, you can alternatively use the SAP Logon-enabled update feature. In contrast to the SAP Automatic Workstation Update Service described above, this method is dependent on user actions. After a certain number of double-clicks on the SAP Logon icon on the desktop, a check for updates is executed. For details, see SAP Logon-enabled Update of the Front End.

Result

Depending on the chosen update method, the front end is updated with or without user interaction. In case of a user-interactive update, the user just has to choose Next to start the front-end update.

Also read: Uninstalling SAP Front-End Components | Command-Line Parameters


Patching a Standalone Workstation

Simply execute the Patch on the Workstation. The wizard will guide you through the process.

We recommend performing an update using an Installation Server to performing manual updates on individual workstations.


Enabling User-Specific Automatic Update

SAP Logon-Enabled Update of the Front End

Use

If SAP GUI 7.10 (or any other SAP Front-End Software supplied with this feature) is installed from an installation server, the workstation user has the option to enable automatic update from this server.

With SAP GUI for Windows this works as follows:

If he or she double-clicks the SAP Logon (or SAP Logon Pad) icon, the automatic update will check the installation server to see if it has been updated since the last installation. If so, NwSAPSetup /update will be run before SAP Logon will be started. This mechanism helps reducing network load. It is an alternative to using the logon script.

Procedure

...

1. On the desktop or in the Start menu (Start ® Programs ® SAP Front End), right-click on the SAP Logon icon and choose Configure Auto-Update.

The following dialog box appears:

By default, the automatic update is:

○ Switched on if the installation of SAP GUI 7.10 was run from an installation server.

○ Switched off if the installation of SAP GUI 7.10 was run from CD.

2. To activate your selection, choose OK.

3. The number in the Update Check Frequency field specifies the number of times that an application will be executed before the availability of an update is checked for.

For Administrators:

Also read: “Installation Server Help.chm” - “Package Event Scripting Samples” (Example 2: Setting registry values to pre-configure Auto-Update settings for SAP Logon)


Uninstalling SAP Front-End Components

Procedure

...

1. In the Windows control panel, choose Add or Remove Programs.

2. Select the SAP Front-End Component.

3. Choose Remove.

4. Select Uninstall all SAP Front-End Components.

5. Choose Finish.

Result

The SAP front-end is uninstalled and a log file generated.

SAP front-end applications should not be running at uninstall-time.

Else, the user will be prompted to reboot to complete the process.

Also read: Command-Line Parameters


* Viewing Log Files and Reporting Errors

The installation tool NWSapSetup.exe maintains a record of its activity in the form of log-files that can be found under:

● %ProgramFiles%\Sap\SAPSetup\Logs

The tool maintains the last ten LOG files.

Errors are recorded in an XML document called SapSetupErrors_<DateTime>.xml that can be viewed in any browser window and can be found in the folder:

● %ProgramFiles%\Sap\SAPSetup\Errors

While reporting errors to SAP, use the Check Tool that will provide you with a CAB-file containing all installation information. This will help quicken problem diagnosis.

Also read: Diagnosing an Installation using the Check Tool | Troubleshooting and FAQs


Diagnosing Front-End Software Installations using NWCheckWorkstation

To diagnose a workstation containing installed SAP components, start NWCheckWorkstation.exe from either the SETUP directory of the Installation Server or from the SETUP directory of the workstation i.e. %PROGRAMFILES%\SAP\SAPSetup\Setup, and follow the wizard. You will be presented with a report on completion of the check process.

NWCheckWorkstation verifies the installation of SAP front-end components by checking for discrepancies in files, services, registry-keys, and other artifacts deployed using NWSAPSetup.

The workstation check tool will collect critical installation files and compress them into a cabinet archive. This CAB-File will be presented to the user after the completion of the process, and can be supplied to SAP support staff when reporting installation issues - for quicker diagnosis.

Also read: Troubleshooting and FAQs


SAPSetup Command-Line Parameters

Command-Line Parameters for Front-End Installation and Update

You can call NWSAPSetup.exe with the command-line parameters listed below.

NWSAPSetup Parameter

Description

/package:["<package name>"] [/silent]

Displays the wizard that lets you choose packages

You cannot switch to Product View.

/Product:["<product name>"]

[/uninstall] [/silent]

● If no product name is supplied, this command line parameter enables a view of available products and products that have already been installed.

● If a product name is supplied, the installer displays information about the supplied product only.

You cannot switch to Package View.

/noDlg

Shows only the progress dialog

Displays no other user interface. You can use it instead of /silent.

If using /noDlg, you need to specify a product name or package name.

/force

Switches off the version check so that older versions can be copied over newer versions (this does not apply to Microsoft system files)

/once:”<name>”

Prevents NWSAPSetup from running more than once for a given parameter <name>

If you want to use NWSAPSetup again, change the value of <name> (or delete the switch /once completely).

/silent

Displays no user interface – not even progress

If using /silent, you need to specify a product name or package name.

/uninstall

Uninstalls components that belong to a specified product or a package

This command-line parameter is valid only together with one of the following:

/Product=”Product Command-Line Name”

/Package=”Package Command-Line Name”

/all for uninstalling all SAP components installed by SAPSetup

You normally use this command-line parameter with /Silent or /NoDlg.

/update

Updates all components

You can install multiple products and packages using a single command with the + operator, as shown in the following examples:

\\ServerName\ShareName\Setup\NwSAPSetup.exe /Product=”SAPGUI710+SAPBI” /NoDlg

\\ServerName\ShareName\Setup\NwSAPSetup.exe /Package=”Package1+Package2” /NoDlg

To uninstall multiple products or packages, append the /uninstall command-line parameter.


* Troubleshooting and FAQs

This section addresses some issues and frequently asked questions concerning NetWeaver SAPSetup – SAP’s Windows Front-End Software Installer.

  • Why is the Next button not enabled on the component selection wizard page?
  • When the component-selection wizard page shows, I see that some components are already selected. Why is that?
  • When the component-selection wizard page shows, what happens when I select some components and de-select previously selected ones?
  • Can I install multiple packages on a single workstation?
  • When I install a package, will components that are a part of the package but already installed on the Workstation be reinstalled?
  • What happens to components shared by multiple packages at package uninstall time?
  • What happens if I install SAP Front-End Components using an admin-configured package, but un-installed some components using Add Remove Programs in Windows Control Panel?
  • What information do I need to supply when reporting installation issues to SAP Support?
  • What is the command line for uninstalling all SAP front end components?

Q. Why is the Next button not enabled on the component selection wizard page?

A. The Next button is enabled only when an existing selection is changed.

Q. When the component selection wizard page shows, I see that some components are already selected. Why is that?

A. Components that are shown as selected when the selection wizard page starts are the components that are already installed on the Workstation. De-selecting them will mark them for un-installation.

Q. When the component selection wizard page shows, what happens when I select some components and de-select previously selected ones?

A. Components that are newly selected will be marked for installation, and components that were shown as selected when the page showed up but are de-selected will get marked for un-installation.

This feature allows you to configure the installation of new SAP Front-End Components and Products available on the Installation Server and erase those existing on the Workstation in one deployment cycle. Thus what take most standard installers multiple installation and un-installation cycles is performed by SAPSetup in one-go thus saving you time.

Q. Can I install multiple packages on a single workstation?

A. Yes, you can.

Q. When I install a package, will components that are a part of the package but already installed on the Workstation be reinstalled?

A. No, previously installed components that belong to a package will not be reinstalled if they are present in the latest available version. However, if a better version is available on the Installation Server, these will be automatically updated.

Q. What happens to components shared by multiple packages at a package’s uninstall time?

A. If a component is shared by more than one package, then, uninstalling a package that contains the component will invalidate the other packages that contained the same. These invalidated packages can however be re-installed.

Q. What happens if I install SAP Front-End Components using an admin-configured package, but un-installed some components using Add Remove Programs in Windows Control Panel?

A. The same thing as above. If components belonging to a package are uninstalled either via Control Panel or via another the package that also contains them, the package in question is invalidated, shown as not-installed and hence made available for re-installation.

Q. What information do I need to supply when reporting installation issues to SAP Support?

A. In addition to a description of the problem, attach the cabinet file created by the check tool NWCheckWorkstation.exe to help quicken problem diagnosis.

Q. What is the command line for uninstalling all SAP front end components?

A. It is NwSapSetup.exe /uninstall /all /silent.