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Multi-Port Serial-to-Ethern

Application Kit Contents
• 2 CD-ROMs — Dynamic C® with complete product docum

sample programs, software, and information related to the 
• RCM3700 module.
• RCM3700 Prototyping Board, with a bag of accessory part

Board.
• QKits QK145 Serial Temperature Sensor.
• AC adapter, 12 V DC, 1 A (included only with Application 

header plug leading to bare leads is provided to allow overs
with a DC output of 7.5–30 V.

• 10-pin header to DB9 programming cable with integrated l
• Cables and cable kits to access QK145 temperature sensor 

Prototyping Board.
• Ethernet crossover cable.
• Getting Started instructions.
• Rabbit 3000 Processor Easy Reference poster.
• Registration card.

Installing and Running Dynamic C
Once the RCM3700 is connected and Dynamic C is installed as described in the preceding pages, start 
Dynamic C by double-clicking on the Dynamic C icon or by double-clicking on dcrab_XXXX.exe in 
the Dynamic C root directory, where XXXX are version-specific characters. Dynamic C uses the serial port 
specified during installation.

If you are using a USB port to connect your computer to the RCM3700 module, choose Options > 
Project Options and select “Use USB to Serial Converter” under the Communications tab.

Run a Sample Program
Use the File menu to open the sample program PONG.C, which is in the Dynamic C SAMPLES folder. 
Press function key F9 to compile and run the program. The STDIO window will open on your PC and will 
display a small square bouncing around in a box.

Troubleshooting
If Dynamic C cannot find the target system (error message "No Rabbit Processor Detected."):

• Check that the RCM3750 is powered correctly — the power LED above the RESET button on the 
Prototyping Board should be lit.

• Check to make sure you are using the PROG connector, not the DIAG connector, on the programming 
cable.

• Check both ends of the programming cable to ensure that they are firmly plugged into the PC and the 
programming port on the RCM3750.

• Ensure that the RCM3750 module is firmly and correctly installed in its connector on the Prototyping 
Board.

• Select a different COM port within Dynamic C. From the Options menu, select Project Options, 
then select Communications. Select another COM port from the list, then click OK. Press <Ctrl-Y> 
to force Dynamic C to recompile the BIOS. If Dynamic C still reports it is unable to locate the target sys-
tem, repeat the above steps until you locate the active COM port.

If a program compiles and loads, but then loses target communication before you can begin debugging, it is 
possible that your PC cannot handle the default debugging baud rate. Try lowering the debugging baud rate.

• Locate the “Serial Options” dialog in the Dynamic C Options > Project Options > Communica-
tions menu. Choose a lower debug baud rate.

If there are any other problems:

• Use the Dynamic C Help menu to get further assistance with Dynamic C.

• Check the Rabbit Semiconductor Technical Bulletin Board at www.rabbit.com/support/bb/.

• Use the Technical Support e-mail form at www.rabbit.com/support/questionSubmit.shtml.

NOTE: If you purchased your RCM3700 through a distributor or through a Rabbit Semiconductor 
partner, contact the distributor or partner first for technical support.

Where Do I Go From Here?
If the sample program ran fine, you are now ready to go on to other sample programs on the supplementary 
CD-ROM and to develop your own applications. The source code for the sample programs is provided to 
allow you to modify them for your own use. Application Note AN406, Will That Be Serial or Ethernet?, 
describes the software and sample programs for this Application Kit, and is available on the supplementary 
CD-ROM.

Installing Dynamic C®

Insert the Dynamic C CD from the Application Kit in you
If the installation does not auto-start, run the setup.exe
directory of the Dynamic C CD. Install any Dynamic C mo
from the supplemental CD after you install Dynamic C.
et Application Kit

entation on disk, and supplemental CD with 
Application Kit.

s and jumpers for use on the Prototyping 

Kits sold for the North American market). A 
eas users to connect their own power supply 

r PC’s CD-ROM drive. 
 program in the root 
dules and the software 
evel-matching circuitry.
and serial and analog input connectors on 
Rabbit and Dynamic C are registered trademarks of Rabbit Semiconductor Inc.

http://www.zworld.com/support/bb/index.html
http://www.zworld.com/support/questionSubmit.shtml


The header pins may become bent or damaged if the pin alignment is offset, and the module will 
not work. Permanent electrical damage to the module may also result if a misaligned module is 
powered up.

Press the module’s pins firmly into the Prototyping Board socket.

2.  Connect Programming Cable
The programming cable connects the RCM3700 to the PC running Dynamic C to download programs 
and to monitor the RCM3700 module during debugging.

Be sure to use the programming cable supplied with this Application Kit—the program-
cable has blue shrink wrap around the RS-232 converter section located in the middle of 
ble. Programming cables from other Z-World or Rabbit Semiconductor kits were not 

ned to work with RCM3700 modules.

Some PCs now come equipped only with a USB port. It may be possible to use an 
2/USB converter with the programming cable supplied with the RCM3700 series 

lopment Kit. An RS-232/USB converter is available through the Z-World Web store.

ower
connections have been made, you can connect power to the Prototyping Board. 
ll transformer to 3-pin header J4 on the Prototyping Board as shown in Figure 1. The 
 be attached either way as long as it is not offset to one side.

 transformer. The LED above the RESET button on the Prototyping Board should 
M3700 and the Prototyping Board are now ready to be used.

The RESET button is provided on the Prototyping Board to allow a hardware reset with-
sconnecting power.

lopment Kits

ts sold outside North America include a header connector that may be connected to 3-
 the Prototyping Board. The red and black wires from the connector can then be con-

sitive and negative connections on your power supply. The power supply should deliver 
 at 500 mA.

er Cables and Jumpers

t crossover 
t the RJ-45 

3700 to 
n your PC. 
e sample 

w you run 
 either 
ore jump-
n header 

J2 of the RCM3700 Proto-
typing Board, or you will 
use one of the cables with 
a 10-pin header and a DE9 
connector to connect 
header J2 to either a PC or 
to the QK145 temperature 
sensor.

Additional Hardware Information
ore RCM3700 User’s Manual on the Dynamic C CD-ROM provides complete informa-

g and developing applications for the RCM3700, and includes further information on the 
 Board and an optional LCD/keypad module.

Figure 2.  Connect Other Cables and Jumpers
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Connect the 10-pin connector of the programming cable labeled PROG to header J2 on the RCM3700 
as shown in Figure 1. Be sure to orient the marked (usually red) edge of the cable towards pin 1 of the 
connector. (Do not use the DIAG connector, which is used for a normal serial connection.)

Connect the other end of the programming cable to a COM port on your PC.

The RabbitC
tion on usin
Prototyping
Hardware Connections
1.  Attach Module to Prototyping Board
Turn the RCM3700 module so that the Ethernet jack is on the left as shown in Figure 1 below. Insert 
the module’s J1 header into the TCM_SMT_SOCKET socket on the Prototyping Board. The shaded 
corner at the bottom right corner of the RCM3700 module should face the same direction as the corre-
sponding shaded corner below it on the Prototyping Board.

Figure 1.  Install the RCM3700 Module on the Prototyping Board

NOTE: It is important that you line up the pins on header J1 of the RCM3700 module exactly 
with the corresponding holes of the TCM_SMT_SOCKET socket on the Prototyping Board. 
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Hardware Connections
Attach Module to Prototyping Board
Turn the RCM3700 module so that the Ethernet jack is on the left as shown in Figure 1 below. Insert 
the module’s J1 header into the TCM_SMT_SOCKET socket on the Prototyping Board. The shaded 
corner at the bottom right corner of the RCM3700 module should face the same direction as the corre-
sponding shaded corner below it on the Prototyping Board.

Figure 1.  Install the RCM3700 Module on the Prototyping Board

NOTE: It is important that you line up the pins on header J1 of the RCM3700 module exactly 
with the corresponding holes of the TCM_SMT_SOCKET socket on the Prototyping Board. 
The header pins may become bent or damaged if the pin alignment is offset, and the module will 
not work. Permanent electrical damage to the module may also result if a misaligned module is 
powered up.

Press the module’s pins firmly into the Prototyping Board socket.

Connect Programming Cable
The programming cable connects the RCM3700 to the PC running Dynamic C to download programs 
and to monitor the RCM3700 module during debugging.

Connect the 10-pin connector of the programming cable labeled PROG to header J2 on the RCM3700 
as shown in Figure 1. Be sure to orient the marked (usually red) edge of the cable towards pin 1 of the 
connector. (Do not use the DIAG connector, which is used for a normal serial connection.)

Connect the other end of the programming cable to a COM port on your PC.
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NOTE: Be sure to use the programming cable supplied with this Application Kit—the program-
ming cable has blue shrink wrap around the RS-232 converter section located in the middle of 
the cable. Programming cables from other Rabbit Semiconductor kits are not designed to work 

a 10-pin header and a DE9 
connector to connect 
header J2 to either a PC or 
to the QK145 temperature 
sensor.

Additional Hardware Information
The RabbitCore RCM3700 User’s Manual on the Dynamic C CD-ROM provides complete informa-
tion on using and developing applications for the RCM3700, and includes further information on the 

Figure 2.  Connect Other Cables and Jumpers
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Prototyping Board and an optional LCD/keypad module.
with RCM3700 modules.

NOTE: Some PCs now come equipped only with a USB port. It may be possible to use an 
RS-232/USB converter (Part No. 540-0070) with the programming cable supplied with the 
Application Kit. Note that not all RS-232/USB converters work with Dynamic C.

Connect Power
When all other connections have been made, you can connect power to the Prototyping Board. 
Connect the wall transformer to 3-pin header J4 on the Prototyping Board as shown in Figure 1. The 
connector may be attached either way as long as it is not offset to one side.

Plug in the wall transformer. The LED above the RESET button on the Prototyping Board should 
light up. The RCM3700 and the Prototyping Board are now ready to be used.

NOTE: The RESET button is provided on the Prototyping Board to allow a hardware reset with-
out disconnecting power.

Overseas Development Kits

Development kits sold outside North America include a header connector that may be connected to 3-
pin header J4 on the Prototyping Board. The red and black wires from the connector can then be con-
nected to the positive and negative connections on your power supply. The power supply should deliver 
7.5 V–30 V DC at 500 mA.

Attach Other Cables and Jumpers

Use the Ethernet crossover 
cable to connect the RJ-45 
jack on the RCM3700 to 
the RJ-45 jack on your PC. 
Depending on the sample 
program and how you run 
it, you will then either 
attach one or more jump-
ers across pins on header 
J2 of the RCM3700 Proto-
typing Board, or you will 
use one of the cables with 
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Installing and Running Dynamic C
Once the RCM3700 is connected and Dynamic C is installed 

• Use the Technical Support e-mail form at www.rabbit.com

NOTE: If you purchased your RCM3700 through a d
partner, contact the distributor or partner first for te

Where Do I Go From Here?
If the sample program ran fine, you are now ready to go on to o
CD-ROM and to develop your own applications. The source c
allow you to modify them for your own use. Application Note
describes the software and sample programs for this Applicatio
CD-ROM.
lti-Port Serial-to-Ethernet Application Kit

ication Kit Contents
D-ROMs — Dynamic C® with complete product documentation on disk, and supplemental CD with 
ple programs, software, and information related to the Application Kit.

M3700 module.
M3700 Prototyping Board, with a bag of accessory parts and jumpers for use on the Prototyping 
rd.
its QK145 Serial Temperature Sensor.
 adapter, 12 V DC, 1 A (included only with Application Kits sold for the North American market). A 
der plug leading to bare leads is provided to allow overseas users to connect their own power supply 

as described in the preceding pages, start 

talling Dynamic C®

t the Dynamic C CD from the Application Kit in your PC’s CD-ROM drive. 
 installation does not auto-start, run the setup.exe program in the root 
tory of the Dynamic C CD. Install any Dynamic C modules and the software 
 the supplemental CD after you install Dynamic C.
Mu

Appl
• 2 C

sam
• RC
• RC

Boa
• QK
• AC

hea

Dynamic C by double-clicking on the Dynamic C icon or by double-clicking on dcrab_XXXX.exe in 
the Dynamic C root directory, where XXXX are version-specific characters. Dynamic C uses the serial port 
specified during installation.

If you are using a USB port to connect your computer to the RCM3700 module, choose Options > 
Project Options and select “Use USB to Serial Converter” under the Communications tab.

Run a Sample Program
Use the File menu to open the sample program PONG.C, which is in the Dynamic C SAMPLES folder. 
Press function key F9 to compile and run the program. The STDIO window will open on your PC and will 
display a small square bouncing around in a box.

Troubleshooting
If Dynamic C cannot find the target system (error message "No Rabbit Processor Detected."):

• Check that the RCM3750 is powered correctly — the power LED above the RESET button on the 
Prototyping Board should be lit.

• Check to make sure you are using the PROG connector, not the DIAG connector, on the programming 
cable.

• Check both ends of the programming cable to ensure that they are firmly plugged into the PC and the 
programming port on the RCM3750.

• Ensure that the RCM3750 module is firmly and correctly installed in its connector on the Prototyping 
Board.

• Select a different COM port within Dynamic C. From the Options menu, select Project Options, 
then select Communications. Select another COM port from the list, then click OK. Press <Ctrl-Y> 
to force Dynamic C to recompile the BIOS. If Dynamic C still reports it is unable to locate the target sys-
tem, repeat the above steps until you locate the active COM port.

If a program compiles and loads, but then loses target communication before you can begin debugging, it is 
possible that your PC cannot handle the default debugging baud rate. Try lowering the debugging baud rate.

• Locate the “Serial Options” dialog in the Dynamic C Options > Project Options > Communica-
tions menu. Choose a lower debug baud rate.

If there are any other problems:

• Use the Dynamic C Help menu to get further assistance with Dynamic C.

• Check the Rabbit Semiconductor Technical Bulletin Board at www.rabbit.com/support/bb/.

Ins
Inser
If the
direc
from
Rabbit and Dynamic C are registered trademarks of Rabbit Semiconductor Inc.B

with a DC output of 7.5–30 V.
• 10-pin header to DB9 programming cable with integrated level-matching circuitry.
• Cables and cable kits to access QK145 temperature sensor and serial and analog input connectors on 

Prototyping Board.
• Ethernet crossover cable.
• Getting Started instructions.
• Rabbit 3000 Processor Easy Reference poster.
• Registration card.

/support/questionSubmit.shtml.

istributor or through a Rabbit Semiconductor 
chnical support.

ther sample programs on the supplementary 
ode for the sample programs is provided to 
 AN406, Will That Be Serial or Ethernet?, 
n Kit, and is available on the supplementary 

http://www.zworld.com/support/bb/index.html
http://www.zworld.com/support/questionSubmit.shtml
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