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1.0 INTRODUCTION

1.1 Qtfor Embedded Linux

Qt for Embedded Linux is a C++ framework for GUI and application development for embedded devices.
It runs on a variety of processors, usually with Embedded Linux. Qt for Embedded Linux provides the
standard Qt API for embedded devices with a lightweight window system.

Application Source Code
Qt API

Accelerated
G Fap hii IS

Linux Kernel Framebuffer

Qt for Embedded Linux applications write directly to the framebuffer, eliminating the need for the X
Window System and saving memory. The Linux framebuffer is enabled by default on all modern Linux
distributions and provides an efficient way to develop GUI applications for embedded Linux devices.
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1.2 Outline

The aim of this application note is to guide the user through the steps to set up a Qt application
development environment for Yocto systems using Qt Designer.

The application note will guide the user through the setup of a Qt sample project, deployment of the
build results to a Yocto system and required configurations necessary for application debugging.

Current Linux Distribution
Required Packages

o)

Secure the Linux Yocto Kernel Target Image

l Secure the Target @

Install the ADT Root Filesystem and Index of Downloads
Cross-Toolchain{» s ||

Prepare Host System for the Yocto Project

— Create and Build Application

Deploy the Image with the Application

QEMU___

o
,/’
,‘/
QEMU Emulator
Target
Hardware

®

> Test and Debug the Application

Figure 1-1: Yocto Application Development Workflow Overview
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1.3 Assumptions

This application note has been written for use by technically competent personnel with a good
understanding of the usage of a Linux desktop operating system and common Linux commands.

This application note applies to all Digi ARM embedded modules running Digi Embedded Yocto (DEY).

A DEY 1.6 installation on the development host and a Digi ConnectCore 6 SBC target hardware platform
is assumed.

It’s further assumed the Digi ConnectCore 6 SBC is running a previously compiled dey-image-graphical
operating system image with the following extra image features included:

e EXTRA_IMAGE_FEATURES = "debug-tweaks tools-debug eclipse-debug dey-qt"

Follow the “Digi Embedded Yocto 1.6 First Steps Guide (SBC)”, P/N: 90001423 A for detailed
instructions about the installation of DEY and the building of the dey-image-graphical image.

1.4 Corrections

Requests for corrections or amendments to this application note are welcome and should be addressed
to: embedded.presales@digi.com. Requests for new application notes can be sent to the same address.

1.5 Version

Version Number: 0.1

Status: DRAFT
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20 YOCTO QT TOOLCHAIN GENERATION AND INSTALLATION

2.1 Yocto Qt Toolchain Generation

To build a Qt enabled image the dey-qt extra image feature needs to be included in your project. Make
sure the project configuration (conf/local.conf) is configured with the following extra image features:

e EXTRA_IMAGE_FEATURES = "debug-tweaks tools-debug eclipse-debug dey-qt"

Initialize the build environment for the ccimx6sbc platform and build the matching toolchain with the
following commands:

e source /usr/local/dey-1.6/mkproject.sh -p ccimx6sbc
e bitbake meta-toolchain-qt
The resulting SDK file is located in your project folder in the tmp/deploy/sdk directory:

e dey-eglibc-i686-meta-toolchain-gt-cortexa9hf-vfp-neon-toolchain-qt-1.6.1.sh

2.2 Yocto Qt SDK Installation

Run the .sh file to install the toolchain in a directory of choice (this example assumes installation into
Jopt/dey-1.6/graphical/qt/ccimx6sbc):

e ./dey-eglibc-i686-meta-toolchain-qt-cortexa9hf-vfp-neon-toolchain-qt-1.6.1.sh

/Enter target directory for SDK (default: /opt/poky/1.6): /opt/dey-1.6/graphical/qt/ccimesbc/\

You are about to install the SDK to
"/opt/dey-1.6/graphical/qt/ccimx6sbc/". Proceed[Y/n]? Y

[sudo] password for <user>; ****
Extracting SDK...done

Setting it up...done

SDK has been successfully set up and is ready to be used. /

-
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3.0 QT CREATOR INSTALLATION AND SETUP

3.1 Qt Creator Installation

Download the standalone Qt Creator IDE from the Qt Website: http://qt-project.org/downloads.

Install Qt Creator by running the install file:

e . /gt-creator-opensource-linux-x86-3.2.1.run

Patch the gtcreator.sh start script to source the Yocto environment setup script at Qt Creator start-up,
with the following patch code:

/ diff --git a/qtcreator.sh b/qgtcreator.sh \

index aca30f5b9ecf..114f69717877 100755

--- a/qtcreator.sh

+++ b/qtcreator.sh

@@-1,3+1,4 @@

+source /opt/dey-1.6/graphical/qt/ccimx6sbc/environment-setup-cortexa9hf-vfp-neon-dey-linux-gnueabi
#! /bin/sh

\ makeAbsolute() { /

You can copy & paste the above patch code into a new file e.g. named “0001-Source-Yocto-

environment-script-setup.patch” and apply the patch with the following command:

e patch gtcreator.sh < 0001-Source-Yocto-environment-script-setup.patch

Make sure the path given in the patch file matches the path to the dey environment setup script of your
development system.

Start Qt Creator:

e /usr/local/qgtcreator-3.2.1/bin/qtcreator.sh &
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4.0 CONFIGURE TARGET CONNECTION AND TOOLCHAIN

4.1 Create New Device Configuration

In Qt Creator menu go to the “Tools” -> “Options"

Select “Devices” and “Add” a new “Generic Linux Device”:

Filter Devices
@ Environment | Devices
Text Editor Device: | Local PC (default for Desktop) QL Add... D
% FakeVim General
@ e Name: Local Pc @ Device Configuration Wizard Selection
{} C++ Type: Desktop . . ] Dcesses...

] Auto-detected: Yes (id is "Desktop Device") =— S 1
4 Qt Quick Current state:  Unknown T
[Q} Build & Run .| QNX Device

Type Specific

@ Debugger
j Designer
[E8 Analyzer

Dy .
EI Version Control
IL)' Android
.

0K Cancel Apply

Configure the target connection with your targets IP address, login and password and run the optional

X New Generic Linux Device Configuration Setup

“Device Test”:

Connection
= Connection The name to identify this configuration: | ccimx6sbc
The device's host name or IP address: 192.168.42.31
hentication type: ® Password Key

Connecting to hest...
Checking kernel version... B rEsEaEEE :]
Linux 3.10.44-dey+gd5fa698 armv7l B .

Checking if specified ports are available... containing the user's private key.

All specified ports are available.

Device test finished successfully.
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4.2 Setup New Build & Run Configuration

Select “Build & Run”, go to the “Kits” tab and “Add” a new kit.

In the “Sysroot:” field, browse to the sysroot folder of your Qt toolchain installation directory and point
to cortexa9hf-vfp-neon-dey-linux-gnueabi:

e /opt/dey-1.6/graphical/qt/ccimx6sbc/sysroots/cortexa9hf-vfp-neon-dey-linux-gnueabi

Filter Build & Run

@ Environment Genet Versions | Compilers Debuggers CMake
Text Editor @
Name =

FakeVim Auto-detected
@ ¥ Manual | Clone |
@ Help ccimx6sbe (default) | Remove |
{} Ca Make Default
<] ot Quick
(0 build & Rum>

Name: ccimx6sbe =
@ Debugger =)
\ ) Device type: | Generic Linux Device B
ﬂ Designer

Device: ccimx6sbc (default for Generic Linux) +| | Manage...
[E® Analyzer ! ( 2 LM ge... |

[ Sysroot: opt/dey-1.6/graphical/qt/ccimx6sbc/sysroots/cortexadhfvfp-neon-dey-linux- nueatm

[ version control T |/opt/dey-1.6/graphical/qt/ /sysroots/ P ylinux-gnueabl | | B
) Android Compiler: | GCC (x86 32bit in /usr/bin) | | Manage...
e BlackBerry Debugger: |System GDB at /usr/bin/gdb :| | Manage... |
I Devices Qtversion: |None :| | Manage... |
Code Pasting Qt mkspec:

| Cancel || OK |
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Move to the “Qt Version” tab and make sure your toolchain’s gmake is selected. If not Auto-detected,
add it manually:

o /opt/dey-1.6/graphical/qt/ccimx6sbc/sysroots/i686-pokysdk-linux/usr/bin/gmake

Filte | Build & Run

@Environment | General mpilers Debuggers = CMake
Text Editor Name gmake Location

: Auto-detected
g FakeVim v Manual | Remove |
@ Help A\ Qt4.8.5 (System) /opt/dey-1.6/graphical/qt/ccimx6sbc/sysroots/i686-pokysdk-linux/usr/bin/qgmake

{} C++ Clean up

o o
< qtQuick ‘ Select a qmake Executable
Build & Run

Q ek : lﬁj l':_"”o_ptﬂdey—1.6”graphical”q_t“(cimxésbc”sysroots I i686-pokysdk-linux J| ust bin
ebugger
/ Designer Places Name v | size | Modified
B8 Analyzer Q, search arm-dey-linux-gnueabi 07/28/2014
> Version name: Qt 4.8 O Recently ... I E— 2.4MB 1519
m Version Control | it = digi & qmake2 2.4 MB)| 15:19
gl gmake locatio/opt/de = K
A andisl ABI detection failed: M | _ D_ES top
G BlackBerry No gmlviewer installe |— File System
[ (2) VBOXADD...
' Devices Qt version 4.8.5 for D« @ Documents |-
== R G
| gmake : |
| Cancel Open .

Move to the “Compilers” tab and “Add” you gcc compiler from your toolchain installation folder:

o /opt/dey-1.6/graphical/qgt/ccimx6sbc/sysroots/i686-pokysdk-linux/usr/bin/arm-dey-linux-
gnueabi/arm-dey-linux-gnueabi-gcc

Filter Build & Run

(B Environment General | Kits Qt V{sions | Compilers | Debuggers | CMake
¥ Auto-detected

FakeVim B
ke GCC (x86 32bit in /ust/bin) GCC | clone |
@ Help ¥ Manual ) | Remove |
arm-dey-linux GCC —
{3 e
] ot quick
E} Build & Run
6 Debugger
/ Designer
[B® Analyzer Name: T
‘Version Contry T » . . . . . . . N ’ T
Compiler path: Jopt/dey-1.6/graphical/qt/ccimx6sbe/sysroots/i686-pokysdk-linux/usr/bin/arm-dey-linux-gnueabi/arm-dey-linux-gnueabi-gcc W... |
i) Android - )
PlatrormT G
@ BlackBerry
Platform linker flags:
' Devices

ABI: | arm-linux-generic-elf-32bit

Code Pasting

EL J oKk

Page | 10



Qt Application Development for Yocto Systems

v1l.0

Move to the “Debuggers” tab and “Add” your gdb debugger from your toolchain installation folder:

o /opt/dey-1.6/graphical/qt/ccimx6sbc/sysroots/i686-pokysdk-linux/usr/bin/arm-dey-linux-
gnueabi/arm-dey-linux-gnueabi-gdb

o Options

Filte Build & Run

@Environment General = Kits | Qt Versions = Cdqpilers = Debuggers | CMgke

Text Editor [ = - .
% Fakevim ¥ Auto-detected

System GDB at fusr/bin/gdb /bin/gdh. DB | clone |
@ Help hs —Remove |
e dey-li -1.6/graphical oots/i686-pokysdk-linux/usr/bin/arm-dey-li bifarm-dey-linux-gnueabi-gdb GDB

] ot quick

IQ)‘ Build & Run
Q Debugger

j Designer

[BR Analyzer
Version Cantrol
) Android

e BlackBerry
a o Path: |/opt/dey-1.6/graphical/qt/ccimx6sbc/sysroots/i686-pokysdk-linux/usr/bin/arm-dey-linux-gnueabi/arm-dey-linux-gnueabi-gdb | Browse... |
evices =

Name: |arm-dey-linux

= ) ABIs: |arm-linux-generic-elF-32bit
@ Code Pasting

¢ Apply || Ca)yel | oK |

Go back to the “Kits” tab and chose the just configured arm-dey-linux “Compiler” and “Debugger”.
Finalize your settings by pressing the “Ok” button:

Filter Build & Run

@ Environment [ Gener Versions = Compilers Debuggers CMake

Text Editor Name | Add |
; Auto-detected

@ FakeVim v Manual | Clone |

@ Help ccimxésbc (default)

| Remove |

{} Ct+ Make Default
«,1 Qt Quick

. . Name: ccimxésbe =]

[Qy Build & Run =
Device type: | Generic Linux Device & |
@ Debugger .
: . Device: | ccimxésbc (default for Generic Linux) *| | Manage... |
X Designer : & :
. Y, - i H X - - i - i

BB Analyzer Sysroot: opt/dey-1.6/graphical/qt/ccimx6sbc/sysroots/cortexaShf-vfp-neon-dey-linux-gnueabi | | Browse... |

Version @6ntrol Compiler: | arm-dey-linux : | | Manage... |
.|| Debugger: |arm-dey-linux / | | Manage... |

i Android

e Blackeermy Qtversion: | QLASS (System) 2| | Manage... |
I Devices - Qt mkspec:

= . -

Apply || cancel | ok |
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5.0 CREATE QT PROJECT AND APPLICATION

5.1 Create New Qt Project

In Qt Creator menu go to the “File” -> “New File or Project..." and “Choose” an “Empty Qt Project” from
the “Other Project” category:

Choose a template: | Desktop Templates 2|
Prcgeclts . - Il Qtunit Test . ] Creates a qmake-based project
Applications B2 ot custom Designer Widget without any Files. This allows you to
Librarie &l = Empty Qt Project create an application without any
- ™ default classes.
Other Project = subdirs Project
Non-Qt Project J Code Snippet Supported PlatForms: Desktop

Import Project
Files and Classes

C++

BlackBerry

Qt

GLSL

General

Java

L TS .

| Ca nc@

Enter a project “Name” and select the “Create in” folder within your workspace directory:

Empty Qt Project

Introduction and Project Location

¥ Location
Kits This wizard generates an empty Qt project. Add Files to it later on by using the other wizards.

Nae: | CC6_QT_Helloworld

Create in: |/home/digi/workspace/CC6_QT_Helloworld Browse... |
[] Use as deFault project location

| Next> || Cancel |

summary
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Select the just created “ccimx6sbc” kit and finish the project setup:

X Empty Qt Project

) Kit Selection
Location

P Kits Qt Creator can use the following kits For project
CC6_QT_Helloworld:

summary

& = ccimx6sbe Details +

> Empty Qt Project
) Project Management
| <Back Next > Location

Kits Add as a subproject to project
2 summary

Add to version control: | <None> : | | Configure... |

Files to be added in
/home/digi/workspace/CC6_QT_HelloWorld/CC6_QT_HelloWorld: ’ ‘

CC6 OT HellowWorld.pro =

| <Back q Finish }Cancel |

5.2 Add Your Application Source Code

Go to the “File” -> “New File or Project..." to add your new application “C++ Source File”:

Choose a template: | Desktop Templates : |
Brolacts = — Creates a C++ source file that you
Applications Q@ B c++sourceFile can add to a C++ project.
Libraries ] C++Header File

Supported Platforms: Deskto
Other Project PP P

Non-Qt Project
Import Project

“ H lasses
BlackBerry

Qt
GLSL
General

Java
Python -

| Eance[( Choose... |)
B New C++ Source File

Choose th

Location

& Location

Name: [CCG_QT_HelloWorld| \ ]

Path: |/home/digi/workspace/CC6_QT_Helloworld/CCé_QT_Helloworld Easy

| next> } Cancel | Page | 13
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Complete the new project setup by pressing the “Finish” button on the “Project Management” dialog
box:

X New C++ Source File

) Project Management
Location

& Ssummary Add to project: | €C6_QT_Helloworld.pro =~

Add to version control: | <None= | | Configure... |

Files to be added in

/home/digi/workspace/CC6_QT_HelloWorld/CC6_QT_HelloWorld:

CC6_QT_HellowWorld.cpp

| <Back q Finish ) cancel |
l

Write your application source code into the newly added source code file (or copy and paste the hello
world example code from above):

CC6_QT_HelloWorld.cpp - CC6_QT_HelloWorld - Qt Creator
File Edit Build Debug Analyze Tools Window Help

-

Projects T @B X ¢ * cCc6 QT Helloworl...* = “ main(int, char *[]...s » B+ X

P ¥ (@ CC6_QT_Helloworld #include <QApplication>
|m CC6_QT_Helloworld.pro #include <=QPushButton=

v st F:OUF(ES int main{(int argc, char *argv[]}
les] CC6_QT_Helloworld.cpp I

Qfpplication applargc, argv);

Debug QPushButton hello("Hello world!"};

Projects hello.show();
return app.execl);

Analyze

13

Open Documents
CC6_QT_Helloworld.cpp*
CC6_QT_Helloweorld.pro

| Il P~ Type to locate (Ctr... IssuesSear...App...Com-.. QM... _l
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“Hello World” Qt example code:
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6.0 BUILD YOUR PROJECT AND DEPLOY APPLICATION

6.1 Build Your Application

In Qt Creator menu go to the “Build” -> “Build All”:

CC6_QT_HelloWorld.cpp - CC6_QT_HelloWorld - Qt Creator
Edit P:fGH Debug Analyze Tools Window Help

S » Build All Ctrl+Shift+B

v [ /* Build Project "CC6_QT_Helloworld” Ctrl+B
Run gmake
Build File "CC6_QT_Helloworld.cpp” Ctrl+Alt+B
Deploy All

Deploy Project "CC6_QT_Helloworld" “

The application source code will be guild using your Yocto Qt toolchain configuration.

File
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6.2 Deploy Application Binary to Target

In the left side tool bar in Qt Creator go to the “Projects” and select the “Run” configuration of your kit:

CC6_QT_Helloworld.cpp - CC6_QT_Helloworld - Qt Creator
File Edit Build Debug Analyze Tools Window

CC6_QT_Helloworld
0[ CUIGEATLY | Editor | CodeStyle | Dependencies |

Welcome

Add Kit v
| Manage Kits... | Build Run

ccimx6she

Deployment

m Method: | Deploy to Remote Linux 2| | Add ~+| Remove | | Rename... |
‘ Projects |

Files to deploy:

Analyze Local File Path Remote Directory

®

Help

We should be able to add files to

deploy, but the controls are not
Upload Files via SFTP visible.

Check For free disk space

| Add Deploy Step  ~ |

Run .

L D
| Bl £- Type to locate (Ctr Issues Search Re... EApplicatin...H Compile ... QML/JS G _

Manually add files to deploy in your .pro project configuration file located in your project directory:

e nano CC6_QT_HelloWorld/CC6_QT_HelloWorld.pro

Add the following code to the .pro file and save it:
TARGET = CC6_QT_HellowWorld
target.files = CC6_QT_HelloWorld
target.path =/

INSTALLS += target

Page | 17



Qt Application Development for Yocto Systems

v1l.0

Qt Creator may notify you that the .pro file changed. Accept the changes by pressing the “Yes to All”
button:

™ File Changed

The file cC6_QT_Helloworld.pro has changed outside Qt Creator. Do you want to
reload it?

| Show Details... || Close || NotoAll || No (| YestoAll | )| i —

Your “Files to Deploy” list in Qt Creator should now get updated and show the added files:

Files to deploy:

Local File Path
/home/digifworkspace/CCé_QT_Helloworld/build-CCé_QT_Helloworld-ccimx6sbc-Debug/CC6_QT Helloworle

L]
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7.0 RUN AND DEBUG YOUR APPLICATION ON THE TARGET

7.1 Run Your Application

In the left side tool bar in Qt Creator press the green arrow “Run” button to execute the application on

your target:

Run

Run configuration: | CC6_QT_Helloworld for 2| | Add ~| Remove Rename...

Executable on host: /home/digi/workspace/CC6_QT_Helloworld/build-cC6_QT_Helloworld-ccimx6
Executable on device: //cce_QT_Helloworld

Alternate executable on device: ["] use this command instead
Arguments: | |
Wworking directory: [<default> |

_ | I £- Type to locate (Ctr... n Issues Search Resulks Application Output Compile Output QML/JS Console]

You should see the “Hello World” application come up on your target’s display:

Hello World

Hella world!
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7.2 Debug Your Application

Similar to running the application you can press the debug arrow on the left side tool bar in Qt creator

to start debugging:

% B (C 9 o= [E] += Threads: Debugger finished.
Level Function File Line

te (Ctr... Issues Search Results Application Output n Compile Output QML/JS Console _
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