Problem:

I can dial in on a standard com port, but not through the Digi board.  How can I test this?


Cause:

Because there are several things that could be causing this, mainly:
1. The Digi not passing the RING to the application.
2. The application not answering.
We need to break this out to help narrow it down so
to verify the Digi board is working properly, 
try dialing in and out usin
g Hyperterminal.

Solution:

1.  Choose Start >  Accessories > Communications > Hyperterminal

2.  Type in a name, and choose an icon.  It really doesn't matter what you choose for either.  Choose OK when finished.

3.  In the Connect using drop down box, choose the com port you wish to test.  DO NOT SELECT THE MODEM DEVICE (we don't want to test using TAPI).  Choose OK when finished.

4.  Choose the defaults for all port properties.  Choose OK.

5.  You should now see a blinking cursor on the main Hyperterminal screen. 
NOTE: If you get a "Unable to open comX" message, this means the port is already open, make sure all applications that might be accessing the port are closed, or their services have been stopped (faxing applications, RAS, Citrix MetaFrame, etc.).  Until you can get into a blank screen, we will not be able to test the modems.  If you are having difficulty stopping the application services, you will need to contact the application vendor for assistance in making sure what services should be stopped.

6.  With your modem hooked up to the Digi board, or if you have an AccelePort RAS with built in modems, you can issue
AT commands to the modem and should get a response.  Make sure your modem is set to properly echo and respond to commands.  Let's try an ATI3 command, you should see a response reporting the modems firmware version.
NOTE: If you do not see the ATi3, type ATi3 and hit enter anyhow.  You should still get a response, but may not have echo turned on.  This can be done with ATe1 and hit enter. 

7.  From a handset, try dialing into that modem.
     NOTE: If you are set up on a hunt group, you will need to run a direct phone line into this modem, or the call maybe
     routed to another modem.
    
8.  You should see a RING on the Hyperterminal screen.  When you do, type ATA and you should hear the modem pick up.
   
9.  You can turn around and try an outbound call to a nearby phone by typing:
      ATDTxxxxxxx (where xxxxxxx is the number to a nearby phone with no dashes or spaces to see if it rings).

10. If this work, the modem is working as should be with the operating system and should work with your application.
      If it is not, you may want to check with your application vendor as we are passing the RING to the application, which
      is then responsible for answering.